Teamcenter 10.1

Structure Manager Guide
Proprietary and restricted rights notice

This software and related documentation are proprietary to Siemens Product Lifecycle Management Software Inc.

© 2013 Siemens Product Lifecycle Management Software Inc. All Rights Reserved.

Siemens and the Siemens logo are registered trademarks of Siemens AG. Teamcenter is a trademark or registered trademark of Siemens Product Lifecycle Management Software Inc. or its subsidiaries in the United States and in other countries. All other trademarks, registered trademarks, or service marks belong to their respective holders.
# Contents

**Proprietary and restricted rights notice** ............................................. 2

**Getting started with Structure Manager** ................................. 1-1

Getting started with Structure Manager ........................................ 1-1  
Before you begin ................................................................. 1-1  
Structure Manager interface .................................................... 1-2  
Basic concepts ................................................................. 1-30  
Basic tasks ................................................................. 1-42

**Configuring Structure Manager** ............................................. 2-1

Configuring Structure Manager .................................................. 2-1  
Setting your local user preferences ........................................... 2-1  
Configure the structure line title format ................................... 2-3  
Setting administrative preferences ............................................ 2-4  
Setting the viewer memory allocation and Java heap size .......... 2-6

**Browsing product structure** ................................................. 3-1

Browsing product structure ..................................................... 3-1  
Viewing the structure .......................................................... 3-1  
Viewing product structure properties ....................................... 3-4  
Insert or remove a property column ......................................... 3-4  
Setting find numbers .......................................................... 3-4  
Open a structure ............................................................... 3-5  
Expanding or collapsing an assembly ......................................... 3-7  
Sorting the structure tree ..................................................... 3-10  
Select structure lines .......................................................... 3-10  
Packing or unpacking structure lines ......................................... 3-11  
Creating aggregate occurrences and defining quantity ............... 3-13  
Finding a component by property ............................................ 3-14  
Adding components using the guided component search ............... 3-15  
Make product structure searches ............................................. 3-17  
Create a structure report in Microsoft Excel .................................. 3-17  
Printing Teamcenter objects in Teamcenter Rapid Start ............... 3-19  
Printing structure information .................................................. 3-21  
Print structure information .................................................... 3-21  
Print property information ..................................................... 3-21  
Print table ............................................................................. 3-23  
Viewing standard notes and custom notes .................................. 3-23  
Opening a structure in NX or Teamcenter lifecycle visualization .... 3-24  
Interpreting transform data ...................................................... 3-26  
Communicating with the owning user ......................................... 3-28  
Viewing remote components .................................................... 3-29  
Show connections ............................................................... 3-34  
View welds and datum points .................................................. 3-34
Building and editing product structure ............................ 4-1
Building and editing product structure ............................ 4-1
Cloning a structure .................................................... 4-1
Create an item from a template ..................................... 4-4
Creating a new BOM view revision ............................... 4-5
Using Save As to save a BOM view revision .................... 4-6
Saving and refreshing the product structure ..................... 4-7
Adding components to the product structure .................... 4-8
Restructuring and editing the product structure ................. 4-14
Highlighting edits to the structure .................................. 4-22
Marking up the product structure ................................... 4-24
Defining units of measure ............................................ 4-49
Managing global alternates ......................................... 4-50
Changing components ............................................... 4-52
Defining substitute components ..................................... 4-55
Add or remove optional parts ....................................... 4-61
Exporting a product structure containing related parts ....... 4-61
Export a product structure to Briefcase ......................... 4-61
Export datasets with structure information ...................... 4-62
Add parts to NX ....................................................... 4-64
Using item elements .................................................. 4-65
Creating connections and links ..................................... 4-67
Creating and editing notes .......................................... 4-68
Deleting items ......................................................... 4-69
Grading structures .................................................... 4-70
Save structure change records ...................................... 4-75
Link requirements .................................................... 4-75
Searching the data dictionary ........................................ 4-80
Releasing structures .................................................. 4-94
BOM session recovery ................................................ 4-97

Working with occurrences .............................................. 5-1
Working with occurrences .............................................. 5-1
Occurrence elements .................................................. 5-1
Creating precise and imprecise occurrences ..................... 5-2
Using absolute occurrences ......................................... 5-2
Managing absolute occurrences (in-context editing) ........... 5-8

Managing properties and notes ........................................ 6-1
Managing properties and notes ........................................ 6-1
Displaying properties .................................................. 6-1
Creating and editing display names ................................ 6-9
Managing column configurations ................................... 6-10
View properties ......................................................... 6-12
Modify common properties ......................................... 6-12
Editing a single property in place .................................. 6-14
Adding a compound property ........................................ 6-15
Displaying item master form attributes ........................... 6-15
Creating structure properties rollup reports ..................... 6-16
Using the Variant Formula property ............................... 6-19
Displaying occurrence notes ........................................... 6-22
Editing and copying occurrence notes ............................. 6-23
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tracking occurrence note changes</td>
</tr>
<tr>
<td><strong>Visualizing product structure</strong></td>
</tr>
<tr>
<td>Visualizing product structure</td>
</tr>
<tr>
<td>Using stand-alone Lifecycle Visualization</td>
</tr>
<tr>
<td>Viewing a structure in Lifecycle Visualization</td>
</tr>
<tr>
<td>Using the embedded viewer</td>
</tr>
<tr>
<td>Understanding the structure tree</td>
</tr>
<tr>
<td>Synchronizing the structure tree and the viewer</td>
</tr>
<tr>
<td>Isolate parts for viewing</td>
</tr>
<tr>
<td>Generate an outline image</td>
</tr>
<tr>
<td>Manipulate graphics</td>
</tr>
<tr>
<td>Save the current session</td>
</tr>
<tr>
<td>Working with product views</td>
</tr>
<tr>
<td>Manipulating subcomponents</td>
</tr>
<tr>
<td><strong>Making where-used searches</strong></td>
</tr>
<tr>
<td>Making where-used searches</td>
</tr>
<tr>
<td>Configuring for where-used searches</td>
</tr>
<tr>
<td>Perform a where-used search and obtain a graphical result</td>
</tr>
<tr>
<td>Perform a where-used search with the print wizard and obtain a printable result</td>
</tr>
<tr>
<td><strong>Making spatial and attribute searches</strong></td>
</tr>
<tr>
<td>Making spatial and attribute searches</td>
</tr>
<tr>
<td>Configuring spatial searches</td>
</tr>
<tr>
<td>Perform a search</td>
</tr>
<tr>
<td>Managing search results</td>
</tr>
<tr>
<td><strong>Comparing product structures</strong></td>
</tr>
<tr>
<td>Comparing product structures</td>
</tr>
<tr>
<td>Understanding product structure (BOM) comparisons</td>
</tr>
<tr>
<td>Understanding graphical comparisons</td>
</tr>
<tr>
<td>Comparing structures under change management</td>
</tr>
<tr>
<td><strong>Using item revision configuration</strong></td>
</tr>
<tr>
<td>Using item revision configuration</td>
</tr>
<tr>
<td>Understanding revision rules</td>
</tr>
<tr>
<td>Configuring privileged and unprivileged users</td>
</tr>
<tr>
<td>Creating a revision rule</td>
</tr>
<tr>
<td>Defining revision rule entries</td>
</tr>
<tr>
<td>Applying a revision rule to a Structure Manager window</td>
</tr>
<tr>
<td>Set a revision rule</td>
</tr>
<tr>
<td>Set date/unit/end item</td>
</tr>
<tr>
<td>Set an override folder</td>
</tr>
<tr>
<td>Viewing revision rule information</td>
</tr>
<tr>
<td>Displaying and editing revision effectivity</td>
</tr>
<tr>
<td>Releasing multiple item revisions in a single workflow process</td>
</tr>
<tr>
<td>Managing nested effectivity</td>
</tr>
<tr>
<td>Using revision rules from My Teamcenter</td>
</tr>
<tr>
<td>Managing occurrence to part relationships</td>
</tr>
</tbody>
</table>
## Contents

**Capturing configurations** ................................................. 12-1
Capturing configurations .................................................. 12-1

**Managing incremental changes** ........................................ 13-1
Managing incremental changes ......................................... 13-1
Elements of incremental change ........................................ 13-1
Setting up incremental change ........................................... 13-3
Creating an incremental change baseline ......................... 13-6
Viewing properties of incremental change data ................ 13-9
Using incremental change ................................................. 13-10
Enable and disable incremental change management .......... 13-12
Turn off incremental change tracking ............................... 13-12
Customize buttons ......................................................... 13-13
Create a new incremental change ...................................... 13-13
Showing unconfigured changes ......................................... 13-15
Find and make active an existing change object ............... 13-15
View or edit information about an incremental change ....... 13-16
View incremental changes for a structure ....................... 13-16
Find recently used change objects ................................. 13-17
Track attachments with incremental changes .................. 13-17
Track changes retrospectively ........................................ 13-18
Remove incremental changes ......................................... 13-19
Split an incremental change ........................................... 13-20
Exporting and importing incremental change data .......... 13-20

**Configuring structures by occurrence effectivity** .............. 14-1
Configuring structures by occurrence effectivity ............. 14-1
Understanding occurrence effectivity .............................. 14-1
Associate existing effectivity to an occurrence ............... 14-3
Create effectivity on multiple occurrences .................... 14-4
Modify the effectivity of an occurrence ......................... 14-4
Remove effectivity from an occurrence .......................... 14-5
Copying occurrences with effectivity ............................. 14-5
Setting the date for occurrence effectivity .................... 14-6
Configuring occurrences with multi-unit configuration ....... 14-6
Customizing occurrence effectivity ................................ 14-10

**Configuring structures by classic variants** ....................... 15-1
Configuring structures by classic variants ...................... 15-1
Elements of classic variants ........................................ 15-2
View and edit variant data ........................................... 15-2
Configure to load ...................................................... 15-3
Using classic variants .................................................. 15-4
Configuring mandatory choices and accessories .......... 15-8
Identifying unique variant data .................................... 15-9
Identifying unique options ......................................... 15-9
Placing variant data .................................................... 15-10
Managing variant data by control change ....................... 15-11
Changing the allowed values of an option ..................... 15-11
Sharing structure ....................................................... 15-12
Configuring complex variant conditions ...................... 15-13
Creating a separate item for a particular variant .......... 15-14
Figures

Item revision configuration ........................................... 1-40
Multiple views ......................................................... 1-41
Simplified example of product structure .......................... 3-2
Example of product structure with relative transformation matrixes 3-27
Example of product structure with relative and absolute transformation matrixes 3-28
Example of saving in multiple windows ........................... 4-7
Global alternates – single direction .................................. 4-50
Global alternates – multiple alternates ............................ 4-50
Global alternates – nonsharing ........................................ 4-51
Global alternates – chaining ......................................... 4-51
Before pasting assembly E in NX ................................... 4-65
After pasting assembly E in NX ...................................... 4-65
Sample product structure with relative occurrences only .... 5-4
Sample product structure with absolute occurrences ......... 5-5
Tracking changes to absolute occurrences ........................ 5-7
Absolute occurrences in a structure ............................... 5-9
Attaching visualization files to items .............................. 5-15
Propagate override data ............................................... 5-16
Where-used search results ............................................ 8-3
Example results of structure comparison ......................... 10-6
Nested effectivity 1 ...................................................... 11-26
Nested effectivity 2 ...................................................... 11-26
Nested effectivity 3 ...................................................... 11-27
Product generations .................................................... 11-28
Occurrence effectivity rule ............................................. 14-2
Mutually exclusive effectivity ranges .............................. 14-3
Creating variant data on the structure ............................. 15-5
Defining a variant rule check ......................................... 15-6
Defining derived values ............................................... 15-7
Unique options .......................................................... 15-10
Allowed values of an option ......................................... 15-11
Changing option allowed values .................................... 15-12
Shared structure ......................................................... 15-13
Creating an item for a variant ........................................ 15-14
Populating variant data ................................................. 15-17
Structure of engine ...................................................... 15-35
Structure of engine with option values ............................ 15-36
Configured structure of engine ..................................... 15-36
VI for engine structure ............................................... 15-36
Lower level variant items in engine structure .................... 15-37
Structure of assembly and options ................................. 16-3
Presenting options ...................................................... 16-5
Creating external options .......................................... 16-10
New option definition ................................................. 16-17
Edit option dialog box ............................................... 16-17
Present option dialog box ............................................ 16-18
Presented child option in data pane ................................. 16-19
Error checks dialog box .............................................. 16-19
Error check in data pane .............................................. 16-20
Constraints dialog box ................................................. 16-21
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints dialog box</td>
<td>16-22</td>
</tr>
<tr>
<td>Child module constraints</td>
<td>16-23</td>
</tr>
<tr>
<td>Variant condition dialog box</td>
<td>16-24</td>
</tr>
<tr>
<td>Condition statements</td>
<td>16-24</td>
</tr>
<tr>
<td>Complex constraints</td>
<td>16-25</td>
</tr>
<tr>
<td>Saved MVL expression</td>
<td>16-25</td>
</tr>
<tr>
<td>Public options</td>
<td>16-34</td>
</tr>
<tr>
<td>Saving a variant configuration</td>
<td>16-37</td>
</tr>
<tr>
<td>Mapping options to expressions in NX</td>
<td>16-49</td>
</tr>
</tbody>
</table>
## Chapter 1  Getting started with Structure Manager

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Getting started with Structure Manager</td>
<td>1-1</td>
</tr>
<tr>
<td>Before you begin</td>
<td>1-1</td>
</tr>
<tr>
<td>Structure Manager interface</td>
<td>1-2</td>
</tr>
<tr>
<td>Structure Manager menus</td>
<td>1-3</td>
</tr>
<tr>
<td>Edit menu</td>
<td>1-6</td>
</tr>
<tr>
<td>View menu</td>
<td>1-8</td>
</tr>
<tr>
<td>Tools menu</td>
<td>1-10</td>
</tr>
<tr>
<td>Graphics menu</td>
<td>1-18</td>
</tr>
<tr>
<td>Structure line context menu</td>
<td>1-19</td>
</tr>
<tr>
<td>Structure Manager buttons and symbols</td>
<td>1-22</td>
</tr>
<tr>
<td>Structure Manager tabs</td>
<td>1-26</td>
</tr>
<tr>
<td>Structure Manager structure tree images</td>
<td>1-27</td>
</tr>
<tr>
<td>Rich client perspectives and views</td>
<td>1-30</td>
</tr>
<tr>
<td>Basic concepts</td>
<td>1-30</td>
</tr>
<tr>
<td>Navigating the structure</td>
<td>1-31</td>
</tr>
<tr>
<td>Product structure elements</td>
<td>1-31</td>
</tr>
<tr>
<td>Creating product structure</td>
<td>1-33</td>
</tr>
<tr>
<td>Understanding items</td>
<td>1-34</td>
</tr>
<tr>
<td>Working with items</td>
<td>1-34</td>
</tr>
<tr>
<td>Navigating the structure</td>
<td>1-35</td>
</tr>
<tr>
<td>Where used</td>
<td>1-35</td>
</tr>
<tr>
<td>Compare</td>
<td>1-35</td>
</tr>
<tr>
<td>Find in structure</td>
<td>1-36</td>
</tr>
<tr>
<td>Nonspatial searches</td>
<td>1-36</td>
</tr>
<tr>
<td>Fast searches</td>
<td>1-36</td>
</tr>
<tr>
<td>Understanding BOM view revisions, view types, and multiple views</td>
<td>1-37</td>
</tr>
<tr>
<td>Setting a default view type</td>
<td>1-38</td>
</tr>
<tr>
<td>Setting access control on view types</td>
<td>1-38</td>
</tr>
<tr>
<td>Understanding precise and imprecise assemblies</td>
<td>1-38</td>
</tr>
<tr>
<td>Creating multiple views</td>
<td>1-41</td>
</tr>
<tr>
<td>Locating multiple views in the product structure</td>
<td>1-41</td>
</tr>
<tr>
<td>Basic tasks</td>
<td>1-42</td>
</tr>
</tbody>
</table>
Chapter

1 Getting started with Structure Manager

Getting started with Structure Manager

Structure Manager allows you to create generic product structures that can be configured to show the product structure at a particular time or for a certain unit, for example:

- The current production design of the product
- The product structure that was effective on a certain date
- A particular customer variant

By creating a single generic structure that can be configured according to a particular user's needs, you avoid duplicating assembly structures, with all the associated problems of maintenance, redundant information, and complexity of searches.

Structure Manager displays your product structure in a multilevel indented list format, making it easy to browse. This list is similar to the bill of materials (BOM) that engineering organizations use to list manufacturing information.

Structure Manager interoperates with other applications that define or use the product structure, including Platform Designer, DesignContext, Multi-Structure Manager, Manufacturing Process Planner, and Part Planner.

Before you begin

<table>
<thead>
<tr>
<th>Prerequisites</th>
<th>You do not need any special permissions to use the Structure Manager application.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Structure Manager</td>
<td>Structure Manager does not need to be enabled before you use it. However, certain optional features of Structure Manager must be selected during installation, including visualization and embedded software management.</td>
</tr>
<tr>
<td>Configure Structure Manager</td>
<td>You must set various preferences (options) to configure the user interface and certain default functions before using Structure Manager.</td>
</tr>
</tbody>
</table>

For more information about configuring Structure Manager, see Configuring Structure Manager.
Start Structure Manager

Click **Structure Manager** in the navigation pane.

Structure Manager interface

The left-hand navigation bar of Structure Manager contains:

- **The standard Search and Quick Links features provided with all rich client applications.** Click **MyView/Markup** to view any BOM markups on the currently selected line.

- **Open Items**

  Provides a list of currently open BOM windows or structures. Click an entry in the list to select and make it active.

- **History**

  Provides a list of BOM windows or structures that you have recently opened. Click an entry in the list to select and make it active.
1 Structure navigation tree  Allows you to navigate the product structure, expanding or collapsing nodes to view the appropriate data. The images in the tree indicate the purpose of each node.

For more information, see Structure Manager structure tree images. The properties columns to the right of the identifier can be tailored to your needs, as described in Managing properties and notes.

2 Data panes  Allow you to view data about the selected line. To display a different data pane, click its tab.

For more information, see Structure Manager tabs.

3 Search area  Allows you to search for a structure and configure it with commonly used data.

For more information, see Structure Manager buttons and symbols.

4 Incremental change management area  Shows the current incremental change (if one is applied) and allows you to manage the incremental change data.

For more information, see Managing incremental changes.

5 Status symbols  Show the current status of the selected line.

For more information, see Structure Manager buttons and symbols.

Structure Manager uses the Teamcenter rich client interface.

For general information about the rich client interface, see Getting Started with Teamcenter and the Rich Client Interface Guide.

Not all of the following menu commands and buttons may be visible on your system, as the administrator can hide or reveal only those commands and buttons that are appropriate for your site.

For more information about the Embedded Software Explorer, Signal Manager, and Connection Manager commands, see the Embedded Software Solutions Guide.

**Note**  For information about the Window menu commands, see the Rich Client Interface Guide.

### Structure Manager menus

#### File menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New→Item</td>
<td>Creates a new item, functionality, or document.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>New→BOM View Revision</td>
<td>Creates a new BOM view revision for the selected line.</td>
</tr>
<tr>
<td>New→Workflow Process</td>
<td>Creates a new change process for the selected structure.</td>
</tr>
<tr>
<td>New→Part</td>
<td>Creates a new part.</td>
</tr>
<tr>
<td>New→Design</td>
<td>Creates a new design, that is, a CAD representation of a part or assembly.</td>
</tr>
<tr>
<td>New→Snapshot</td>
<td>Creates a new snapshot of the selected structure.</td>
</tr>
<tr>
<td>New→Item Element</td>
<td>Creates a new item element (GDE) and associates it with the selected line.</td>
</tr>
<tr>
<td>New→Connection</td>
<td>Creates a new revisable connection (for example, connection or datum point)</td>
</tr>
<tr>
<td></td>
<td>or nonrevisable (Tc Link) connection. To associate the connection with the</td>
</tr>
<tr>
<td></td>
<td>connected objects, select the connection and objects, and then choose</td>
</tr>
<tr>
<td></td>
<td><strong>Edit→Connect</strong>.</td>
</tr>
<tr>
<td>New→Manufacturing Feature</td>
<td>Creates a new manufacturing feature, for example, a weld point.</td>
</tr>
<tr>
<td>New→Interface Definition</td>
<td>Creates a new interface (for example, connection or network port) and</td>
</tr>
<tr>
<td></td>
<td>associates it with the selected line.</td>
</tr>
<tr>
<td>New→Process Variable</td>
<td>Creates a new process variable.</td>
</tr>
<tr>
<td>New→Signal</td>
<td>Creates a new electrical signal.</td>
</tr>
<tr>
<td>New→Item From Template</td>
<td>Creates a new item or item revision from a predefined template.</td>
</tr>
<tr>
<td>New→Folder</td>
<td>Creates a graphical representation of an aggregation of objects.</td>
</tr>
<tr>
<td>New→Dataset</td>
<td>Creates a Teamcenter data object used to manage data files created by other</td>
</tr>
<tr>
<td></td>
<td>software applications. Each dataset can manage multiple operating system</td>
</tr>
<tr>
<td></td>
<td>files, and each dataset references a dataset tool object and a dataset</td>
</tr>
<tr>
<td></td>
<td>business object.</td>
</tr>
<tr>
<td>New→Form</td>
<td>Creates a data object used to display product information (properties) in a</td>
</tr>
<tr>
<td></td>
<td>predefined template. Forms can be used to create an electronic facsimile of</td>
</tr>
<tr>
<td></td>
<td>a hardcopy form.</td>
</tr>
<tr>
<td>New→URL</td>
<td>Creates a data object used to access a Web resource. The URL (uniform</td>
</tr>
<tr>
<td></td>
<td>resource locator) is an address that is used as a link to access a Web</td>
</tr>
<tr>
<td></td>
<td>resource within Teamcenter or in a separate browser.</td>
</tr>
<tr>
<td>New→Data Requirement Item</td>
<td>Allows you to create a data requirement item (DRI) if you are working with</td>
</tr>
<tr>
<td></td>
<td>contract data.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>New→Parameter Management→Parameter Definition</td>
<td>Allow you to use the Calibration and Configuration Data Management (CCDM) solution to create and manage embedded software calibration and configuration parameter data. CCDM is a separately licensed solution that must be installed to expose these commands. For detailed information about CCDM, see the Embedded Software Solutions Guide.</td>
</tr>
<tr>
<td>New→Parameter Management→Parameter Definition Group</td>
<td></td>
</tr>
<tr>
<td>New→Software Design Component</td>
<td></td>
</tr>
<tr>
<td>Open (Ctrl+O)</td>
<td>Opens the selected structure.</td>
</tr>
<tr>
<td>Open in NX</td>
<td>Sends PLM XML data representing the geometry of the selected assembly to NX.</td>
</tr>
<tr>
<td>Open in Lifecycle Visualization</td>
<td>Loads DirectModel datasets for the selected lines and displays them in standalone Lifecycle Visualization.</td>
</tr>
<tr>
<td>Save (Ctrl+S)</td>
<td>Saves changes made in Structure Manager. For example, you must explicitly save any new BOM lines or variants.</td>
</tr>
<tr>
<td></td>
<td>If there are unsaved changes, the title pane of the Structure Manager window and the tooltip for any open pane are shown in bold with an asterisk * appended to the name. When you save the changes, the bold highlight and the asterisk are removed.</td>
</tr>
<tr>
<td>Save As→Item (Revision)</td>
<td>Depending on the currently selected line, creates a new item or new item revision from the selected line.</td>
</tr>
<tr>
<td>Save As→BOMView (Revision)</td>
<td>If a view is currently selected, creates a new structure view of an item from the view in the selected line.</td>
</tr>
<tr>
<td></td>
<td>If an item is currently selected, creates a new BOM view revision of the selected item.</td>
</tr>
<tr>
<td></td>
<td>For detailed information, see Using Save As to save a BOM view revision.</td>
</tr>
<tr>
<td>Save Session</td>
<td>Saves the current Teamcenter session, including the top-level item revision, the effective revision rules, and the state of the viewer pane.</td>
</tr>
<tr>
<td></td>
<td>By default, this menu entry is hidden. To make it visible, you must set the enableSessionFile entry in your customer.properties file to true. If this file does not already exist, you must create it.</td>
</tr>
<tr>
<td>Open Session</td>
<td>Opens a previously saved Teamcenter session.</td>
</tr>
<tr>
<td>Revise</td>
<td>Revises the selected item.</td>
</tr>
</tbody>
</table>
Getting started with Structure Manager

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate</td>
<td>Clones the selected structure or assembly. The selected line and everything below it will be copied into the new (cloned) structure. Datasets and attachments may be copied to the new (cloned) structure, depending on Business Modeler IDE deep copy rules. CAD-specific attachments and relationships may be copied depending on options you selected and the closure rules configured for the CAD integration. For example, part family members may be replicated in the new (cloned) structure. For detailed information, see Cloning a structure. <strong>Note</strong> This command is unavailable if you select an architecture object type or subtype, for example, architecture breakdown element (ABE). However, you can duplicate any custom object types that your administrator creates.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the currently displayed structure.</td>
</tr>
<tr>
<td>Print</td>
<td>Views, prints, or saves information about the currently selected structure.</td>
</tr>
<tr>
<td>Print...</td>
<td>Views, prints or saves properties, textual information, graphics or information associated with the selected item.</td>
</tr>
<tr>
<td>Exit</td>
<td>Ends your Structure Manager session.</td>
</tr>
</tbody>
</table>

**Note** By default, the Open in NX and Open in Lifecycle Visualization commands and the corresponding buttons on the toolbar may be hidden. To show these commands and buttons, you must set the TC_show_open_in_NX_button and TC_show_open_in_vmu_button preferences, respectively, to ON.

Edit menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut (Ctrl+X)</td>
<td>Marks the selected lines for removal and copy their contents to the clipboard. Cut lines are only removed once they are pasted elsewhere in the product structure.</td>
</tr>
<tr>
<td>Copy (Ctrl+C)</td>
<td>Copies the selected lines to the clipboard.</td>
</tr>
<tr>
<td>Paste (Ctrl+V)</td>
<td>Pastes item revisions from the clipboard as components of the selected lines.</td>
</tr>
<tr>
<td>Paste Substitute</td>
<td>Pastes item revisions from the clipboard as substitutes for the selected (assembly) lines.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Paste Special</td>
<td>Pastes components on the clipboard to the selected assembly (line). Depending on the contents of the clipboard, this command may move a cut and pending line or lines to another location in the product structure. You can also move lines by drag-and-drop methods or with the Windows shortcut commands.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds components to the selected assembly (line) by typing in an item identifier.</td>
</tr>
<tr>
<td>Revert Edit</td>
<td>Cancels any pending additions or removals of the selected lines. It also cancels any pending property edits.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Certain edits are committed immediately to the database and cannot be reverted. Such edits are not displayed in red strike-through text.</td>
</tr>
<tr>
<td>Revert All</td>
<td>Cancels all pending additions or removals of lines anywhere in the structure. It also cancels any pending property edits.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Certain edits are committed immediately to the database and cannot be reverted. Such edits are not displayed in red strike-through text.</td>
</tr>
<tr>
<td>Split Occurrence</td>
<td>Divides an assembly or part represented by the selected line into two lines, and splits the quantity between them.</td>
</tr>
<tr>
<td>Insert Level</td>
<td>Creates a new item and insert it as a branch of the selected line.</td>
</tr>
<tr>
<td>Replace</td>
<td>Replaces the selected line with the item revision or item element on the clipboard.</td>
</tr>
<tr>
<td>Replace...</td>
<td>Allows you to browse for an item revision to replace the selected line.</td>
</tr>
<tr>
<td>Change To Replace</td>
<td>Changes separate deletion and addition actions to a single replacement action.</td>
</tr>
<tr>
<td>Remove (Ctrl+R)</td>
<td>Removes the selected lines from the product structure. Any child branches of the removed line are moved up to the next level. Data including occurrences notes and absolute occurrences attached to the removed line are lost.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes a single item or an item and all its children. Optionally, you can also remove any associated referenced objects. This command permanently removes any selected item from the structure and the database.</td>
</tr>
<tr>
<td>Properties on Relation</td>
<td>Allows you to edit the properties of the object represented by the selected line.</td>
</tr>
</tbody>
</table>
## Command Table

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>User Setting</strong></td>
<td>Changes your group, role, or volume assignments and your application logging and journaling options.</td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td>Changes your user interface settings that affect all applications, not only Structure Manager.</td>
</tr>
<tr>
<td><strong>Guided Component Search</strong></td>
<td>Searches for matching components within an assembly. This search allows you to choose from a list of only those classified workspace objects that fit into the first component of your search. You must first configure it in the Classification Administration application.</td>
</tr>
<tr>
<td><strong>Variant Condition</strong></td>
<td>Creates a variant condition on the selected line.</td>
</tr>
<tr>
<td><strong>Toggle Precise/Imprecise</strong></td>
<td>Changes the precision of the selected assembly (line).</td>
</tr>
<tr>
<td><strong>Show/Hide Superseded Revisions</strong></td>
<td>Shows or hides all revisions in the selected structure that are superseded by a later revision. This command is applicable only if the BOM view revision and current revision rule are precise.</td>
</tr>
<tr>
<td><strong>Select Below→All Lines</strong></td>
<td>Selects all lines below the currently selected line.</td>
</tr>
<tr>
<td><strong>Select Below→Lowest Lines</strong></td>
<td>Selects only the lowest lines below the currently selected line.</td>
</tr>
<tr>
<td><strong>Toggle in Context Mode</strong></td>
<td>Enables or disables editing in context mode, allowing creation of absolute occurrences for the selected assembly.</td>
</tr>
<tr>
<td><strong>Remove Design from Product</strong></td>
<td>Removes a CAD design from an installation assembly attached to an architecture breakdown element. This command is used when your site utilizes Platform Designer.</td>
</tr>
<tr>
<td><strong>Replace Design in Product</strong></td>
<td>Removes a CAD design in an installation assembly attached to an architecture breakdown element with another CAD design. This command is used when your site utilizes Platform Designer.</td>
</tr>
<tr>
<td><strong>Replace Part in Product</strong></td>
<td>Replaces a part (an ERP part) in an architecture breakdown element. This command is used when your site utilizes Platform Designer.</td>
</tr>
</tbody>
</table>

### View menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Refresh Window</strong></td>
<td>Synchronizes the currently displayed product structure with the database. The displayed structure refreshes with changes that have been made in other sessions and saved since you loaded the currently displayed product structure.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Embedded Software Explorer</td>
<td>Allows you to view binary software information in the same way as you view data about hard parts. For more information about these commands, see the Embedded Software Solutions Guide.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> The Embedded Software Solutions (ESS) menu commands must be exposed using Command Suppression.</td>
</tr>
<tr>
<td>Signal Explorer</td>
<td>Allows you to view signals in an electromechanical structure. You can view the source, target, transmitter, process variable, signal of process variable, redundant signal, transmitted signal, and received signal associated with the selected lines, as applicable.</td>
</tr>
<tr>
<td>Show Connected Lines</td>
<td>Shows or hides all lines that are connected by the selected connection.</td>
</tr>
<tr>
<td>Implemented By→Show</td>
<td>Shows all lines that implement the selected line.</td>
</tr>
<tr>
<td>Implemented By→Show</td>
<td>Shows all lines that the selected line implements.</td>
</tr>
<tr>
<td>Realized By→Show</td>
<td>Shows all lines that realize the selected line.</td>
</tr>
<tr>
<td>Realized By→Show</td>
<td>Shows all lines that the selected line realizes.</td>
</tr>
<tr>
<td>Expand</td>
<td>Expands the substructure immediately below the selected lines.</td>
</tr>
<tr>
<td>Expand Below</td>
<td>Expands the complete substructure below the selected lines.</td>
</tr>
<tr>
<td>Expand Below...</td>
<td>Expands the substructure below the selected lines to a user-selected level. You can also collapse an expanded substructure when you choose this command (hide certain child lines).</td>
</tr>
<tr>
<td>Collapse Below</td>
<td>Collapses the complete substructure below the selected lines (hide all child lines).</td>
</tr>
<tr>
<td>Pack</td>
<td>Packs the selected lines so that all lines with the same item revision and find number are displayed as a single line. The actual quantity of lines is appended to the node.</td>
</tr>
<tr>
<td>Unpack</td>
<td>Unpacks the selected packed lines so that they are displayed as separate lines, one for each occurrence.</td>
</tr>
<tr>
<td>Pack All</td>
<td>Packs all packable lines in the displayed structure.</td>
</tr>
<tr>
<td>Unpack All</td>
<td>Unpacks all lines in the displayed structure.</td>
</tr>
</tbody>
</table>
## Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show Unconfigured Variants</strong></td>
<td>Shows or hides unconfigured variant components. Disabled if the <code>PSEEnableFilteringUnconfigdDueToClassicVariantsPref</code> preference is set to <code>True</code>.</td>
</tr>
<tr>
<td><strong>Show Unconfigured By Occurrence Effectivity</strong></td>
<td>Shows or hides components that are not configured when using occurrence effectivity.</td>
</tr>
<tr>
<td><strong>Show Unconfigured Changes</strong></td>
<td>Shows or hides unconfigured incremental changes.</td>
</tr>
<tr>
<td><strong>Show Part Solutions</strong></td>
<td>Shows or hides part solutions. Part solutions are available if your site uses Platform Designer.</td>
</tr>
<tr>
<td><strong>Show Suppressed Occurrences</strong></td>
<td>Shows or hides suppressed occurrences.</td>
</tr>
<tr>
<td><strong>Enable Classic Variant Configure to Load</strong></td>
<td>Hides or shows components that are not configured by the selected variant rule. Enabled if the <code>PSEEnableFilteringUnconfigdDueToClassicVariantsPref</code> preference is set to <code>True</code>.</td>
</tr>
<tr>
<td><strong>Properties</strong></td>
<td>Allows you to view all properties of the selected line. You can edit those properties to which you have permission.</td>
</tr>
<tr>
<td><strong>Notes</strong></td>
<td>Allows you to view, and edit if permitted, all occurrence notes for the selected line.</td>
</tr>
<tr>
<td><strong>Audit→View Audit Logs</strong></td>
<td>Shows the audit file for the selected structure or assembly. This menu command is seen when the <code>TC_audit_manager</code> preference value is <code>ON</code> and the <code>TC_audit_manager_version</code> preference value is <code>2</code>.</td>
</tr>
<tr>
<td><strong>Show/Hide Data Panel</strong></td>
<td>Shows or hides the data pane containing, for example, variant data, Referencers information, or the embedded viewer.</td>
</tr>
<tr>
<td><strong>Show/Hide Search Panel</strong></td>
<td>Shows or hides the Structure Manager search pane.</td>
</tr>
<tr>
<td><strong>Show/Hide Search Result Panel</strong></td>
<td>Shows or hides the Structure Manager search results pane.</td>
</tr>
<tr>
<td><strong>Show/Hide Superseded Revisions</strong></td>
<td>Shows or hides the supersedure revisions of the selected part or assembly.</td>
</tr>
<tr>
<td><strong>Show GCS Connection Points</strong></td>
<td>Shows or hides all connection points defined for guided component searches (GCSs). GCSs are defined in the Classification Administration application.</td>
</tr>
</tbody>
</table>

### Tools menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Check-In/Out→Check Out</strong></td>
<td>Checks a selected component out of the database.</td>
</tr>
<tr>
<td><strong>Check-In/Out→Check In</strong></td>
<td>Checks a selected component into the database.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Check-In/Out→Cancel Checkout</td>
<td>Cancels a request checkout action.</td>
</tr>
<tr>
<td>Check-In/Out→Transfer Checkout</td>
<td>Transfers a selected, checked-out component to another user.</td>
</tr>
<tr>
<td>Check-In/Out→Notification List</td>
<td>Allows you to view or edit the list of users who are informed if the selected component is checked in or checked out.</td>
</tr>
<tr>
<td>Check-In/Out→Check Out History</td>
<td>Allows you to view the history of checkout actions for the selected component.</td>
</tr>
<tr>
<td>ID Display Rule→View/Set Current</td>
<td>Allows you to view the ID display rule currently applied to the selected structure or set a different ID display rule.</td>
</tr>
<tr>
<td>ID Display Rule→Modify Current</td>
<td>Modifies the ID display rule currently applied to the selected structure.</td>
</tr>
<tr>
<td>ID Display Rule→Create/Edit</td>
<td>Creates a new ID display rule or modify an existing ID rule.</td>
</tr>
<tr>
<td>Process and Change Selector</td>
<td>Attaches the selected structure to a Workflow process or change.</td>
</tr>
<tr>
<td>Embedded Software Manager</td>
<td>Allows you to manage binary software in the same way as you manage hard parts.</td>
</tr>
</tbody>
</table>

For more information about these commands, see the *Embedded Software Solutions Guide*.

**Note** The ESS menu commands must be exposed using Command Suppression.

- **Signal Manager→Associate Signal To**: Allows you to associate a signal line in an electromechanical structure to another line as a source, target, transmitter, process variable, or redundant signal.
- **Signal Manager→Remove Signal Association**: Removes the association between the selected signal line in an electromechanical structure and another line.
- **Connection Manager→Connect**: Connects two selected lines with a revisable or nonrevisable connection.
- **Connection Manager→Disconnect**: Disconnects the currently selected line with a revisable or nonrevisable connection to another line.
- **Implemented By→Create Implemented By**: Creates *Implemented By* relationships between the selected line and another line.
- **Implemented By→Remove Implemented By**: Removes *Implemented By* relationships between the selected line and another line.
- **Realized By→Create Realized By**: Creates *Realized By* relationships between the selected line and another line.
- **Realized By→Remove Realized By**: Removes *Realized By* relationships between the selected line and another line.
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fix In-Structure Associations→Current Level</strong></td>
<td>Allows you to identify and remove any invalid associations that were created when the structure was manually edited. This command fixes all invalid associations with the selected line.</td>
</tr>
<tr>
<td><strong>Fix In-Structure Associations→All Levels</strong></td>
<td>Allows you to identify and remove any invalid associations that were created when the structure was manually edited. This command fixes all invalid associations with the selected line and all lines below it.</td>
</tr>
<tr>
<td><strong>Project→Assign</strong></td>
<td>Assigns the selected structure to a predefined project.</td>
</tr>
<tr>
<td><strong>Project→Remove</strong></td>
<td>Removes the selected structure from a project to which it is assigned.</td>
</tr>
<tr>
<td><strong>License→Attach</strong></td>
<td>Attaches an ADA license to the selected workspace object.</td>
</tr>
<tr>
<td><strong>License→Detach</strong></td>
<td>Detaches the ADA license from the selected workspace object.</td>
</tr>
<tr>
<td><strong>View/Set Closure Rule for Expansion</strong></td>
<td>Allows you to view the available closure rules and select a rule to limit structure expansions.</td>
</tr>
<tr>
<td></td>
<td>For more information, see <em>Set or unset a closure rule.</em></td>
</tr>
<tr>
<td><strong>Trace Link→Traceability</strong></td>
<td>Generates a traceability report for the selected structure.</td>
</tr>
<tr>
<td><strong>Revision Rule→View/Set Current</strong></td>
<td>Allows you to view or set the revision rule for the currently displayed structure.</td>
</tr>
<tr>
<td><strong>Revision Rule→Set Date/Unit/End Item</strong></td>
<td>Sets the date, unit number, or end item to configure the structure, if the current rule allows.</td>
</tr>
<tr>
<td><strong>Revision Rule→Set Override Folder</strong></td>
<td>Sets an override folder to override item revisions that would otherwise be selected by other criteria.</td>
</tr>
<tr>
<td><strong>Revision Rule→Modify Current</strong></td>
<td>Modifies the current revision rule and apply the modified rule to the current structure. You can save the change if you have write access to the original rule.</td>
</tr>
<tr>
<td><strong>Revision Rule→Create/Edit</strong></td>
<td>Creates or edits a revision rule.</td>
</tr>
<tr>
<td><strong>Effectivity→Occurrence Effectivity→View, Edit and Create</strong></td>
<td>Allows you to view, edit, or create occurrence date effectivity data for the occurrence of the selected line. You must have the appropriate permissions to create or edit effectivity data.</td>
</tr>
<tr>
<td><strong>Effectivity→Occurrence Effectivity→Create on Multiple BOM Lines</strong></td>
<td>Allows you to create occurrence date effectivity data on multiple BOM lines. You must have the appropriate permissions to create or edit effectivity data.</td>
</tr>
</tbody>
</table>
### Command and Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Effectivity→Revision</strong>&lt;br&gt;<strong>Effectivity</strong></td>
<td>Allows you to view, edit, create, or copy effectivity data for the item revision of the selected line. You must have the appropriate permissions to create or edit effectivity data.</td>
</tr>
<tr>
<td><strong>Effectivity→Effectivity Mapping</strong></td>
<td>Allows you to view, edit, create, or copy effectivity mapping for an end item. Effectivity mappings are needed if you implement nested effectivity.</td>
</tr>
<tr>
<td><strong>Variants→Configure</strong>&lt;br&gt;<strong>Variants</strong></td>
<td>Allows you to configure or edit a variant structure for the selected top-level module.</td>
</tr>
<tr>
<td><strong>Variants→Only Configure Root</strong></td>
<td>Allows you to set to on to only display options for the top-level module, regardless of the line selected. Set to off to configure the structure for a lower level module.</td>
</tr>
<tr>
<td><strong>Variants→Search...</strong></td>
<td>Searches for an existing variant item.</td>
</tr>
<tr>
<td><strong>Variants→Count Modules</strong></td>
<td>Counts the modules defined for the selected variant structure.</td>
</tr>
<tr>
<td><strong>Variants→Unlink Variant Item</strong></td>
<td>Unlinks a variant item from the generic module item to make changes.</td>
</tr>
<tr>
<td><strong>Variants→Update Variant Item</strong></td>
<td>If you make structural changes to a generic item and create a new item revision, Teamcenter does not automatically propagate such changes to each associated variant item. Choose this option to make such changes manually.</td>
</tr>
<tr>
<td><strong>Set/Unset Global Option Item</strong></td>
<td>Allows you to identify the selected item or item revision as a product item with which global options are associated.</td>
</tr>
<tr>
<td><strong>Incremental Change→Create Context</strong></td>
<td>Allows you to create an new incremental change. <strong>Note</strong> This command is visible only if your administrator sets the MoveICCreationToMenu preference to True. If it is not visible, use the Create IC Object button on the incremental change toolbar to create a new incremental change.</td>
</tr>
<tr>
<td><strong>Incremental Change→Add</strong></td>
<td>Retrospectively creates an add change and attaches it to the active incremental change.</td>
</tr>
<tr>
<td><strong>Incremental Change→Remove</strong></td>
<td>Retrospectively creates a remove change and attaches it to the active incremental change.</td>
</tr>
<tr>
<td><strong>Incremental Change→Delete on Object</strong></td>
<td>Establishes a delete change to the attachment.</td>
</tr>
<tr>
<td><strong>Incremental Change→Create on Object</strong></td>
<td>Establishes a create change to the attachment.</td>
</tr>
<tr>
<td><strong>Incremental Change→Remove Change</strong></td>
<td>Removes (undoes) changes on the active incremental change.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Incremental Change→Incremental Change Baseline</strong></td>
<td>Revises the parent assembly to create an incremental change baseline.</td>
</tr>
<tr>
<td><strong>Incremental Change→Split</strong></td>
<td>Splits some of the changes from the active incremental change into another existing incremental change.</td>
</tr>
<tr>
<td><strong>Incremental Change→Intent</strong></td>
<td>Allows you to create a new intent for which the incremental change is valid. An intent represents an alternate solution.</td>
</tr>
<tr>
<td><strong>Incremental Change→Display icons</strong></td>
<td>Customizes how incremental change icons are displayed and the contexts in which you want to see icons.</td>
</tr>
<tr>
<td><strong>Arrangements→View/Set</strong></td>
<td>Allows you to view and set the current NX arrangements.</td>
</tr>
<tr>
<td><strong>Unattached Lines→Clear All</strong></td>
<td>Allows you to clear all the unattached lines in the results of an appearances search.</td>
</tr>
<tr>
<td><strong>Unattached Lines→Clear Selected</strong></td>
<td>Allows you to clear the currently selected unattached lines in the results of an appearances search.</td>
</tr>
<tr>
<td><strong>Unattached Lines→Show Parent</strong></td>
<td>Allows you to find the parent of an unattached line in the results of an appearances search.</td>
</tr>
<tr>
<td><strong>Unattached Lines→Attach</strong></td>
<td>Allows you to reattach unattached lines in the results of an appearances search.</td>
</tr>
<tr>
<td><strong>All History Lines→Clear All</strong></td>
<td>Clears all history lines in the results of an appearances search.</td>
</tr>
<tr>
<td><strong>All History Lines→Clear Selected</strong></td>
<td>Clears selected history lines in the results of an appearances search.</td>
</tr>
<tr>
<td><strong>Validation→Run Validations</strong></td>
<td>Validates attributes of a selected item revision, using third-party software applications, according to criteria set by the system administrator.</td>
</tr>
<tr>
<td><strong>Validation→View Results</strong></td>
<td>Allows you to view the results of previous validations.</td>
</tr>
<tr>
<td><strong>Import→Remote</strong></td>
<td>Imports a structure from a remote site in a Multi-Site Collaboration environment.</td>
</tr>
<tr>
<td><strong>Import→Software Parameters</strong></td>
<td>Allows you to import software parameter data in PLM XML format.</td>
</tr>
<tr>
<td><strong>Export→Objects</strong></td>
<td>Allows you to export the selected workspace objects through a predefined application interface (AI).</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Export→To PLMXML               | Export the selected structure and its attachments in PLM XML format to a selected export directory. You must choose the appropriate transfer mode for the destination system and selected structure.  
For details of how to specify a structure export in PLM XML format, see the PLM XML/TC XML Export Import Administration Guide.  
If you export a structure in which substitute components are defined, the substitutes are also exported.  
For details of how to export structure changes tracked by incremental changes in PLM XML format, see Exporting and importing incremental change data.  
For details of how to specify a suitable closure rule, see the PLM XML/TC XML Export Import Administration Guide. |
| Export→To Briefcase            | Allows you to export a configured product structure in TC XML format. You must choose the appropriate transfer mode for the destination system and selected structure.  
If you track changes with incremental changes, you can optionally export only changes to the configured assembly. Only those objects directly or indirectly affected by incremental changes configured on the structure are exported in full, and other objects are exported as stubs.  
For details of how to export structure changes tracked by incremental changes in TC XML format, see Exporting and importing incremental change data. |
| Export→Objects to Excel        | Exports the selected structure lines to an Excel spreadsheet.                                                                                                                                                                                                                                                                            |
| Export→Objects to Word         | Exports the selected structure lines to a Microsoft Word document.                                                                                                                                                                                                                                                                       |
| Export→Configured NXAssembly   | Exports a product structure that is configured with revision rules and variants to NX in native format. This command is visible only if your administrator sets the TC_ExportConfigUGNXAssembly preference to TRUE and NX is installed on the client machine.                                                                                           |
| Export→Software Parameters     | Allows you to export software parameter data in PLM XML format.                                                                                                                                                                                                                                                                        |
| Stock Selection Rule           | Allows you to choose the rule that selects stock material. Typically used in aerospace and defense environments.                                                                                                                                                              |
## Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send Data To</td>
<td>Sends selected data to another application or external program. Your Teamcenter administrator uses the Business Modeler IDE application to create new application interface types associated with a specific application. Each of these types are available in the Send Data To dialog box.</td>
</tr>
<tr>
<td>Send Additional Data To</td>
<td>Sends additional data to a running session of the application launched using the Send Data To menu command.</td>
</tr>
<tr>
<td>Vendor Part Selection Rule</td>
<td>Allows you to apply a predefined vendor parts selection rule to the structure.</td>
</tr>
<tr>
<td>BOM Grading→Run</td>
<td>Allows you to grade or validate the product structure or subassemblies against predefined criteria.</td>
</tr>
<tr>
<td>For more information, see Grading structures.</td>
<td></td>
</tr>
<tr>
<td>BOM Grading→Show Results</td>
<td>Allows you to view grading results for the select product structure or subassembly.</td>
</tr>
<tr>
<td>Request Substance Compliance Check</td>
<td>Allows you to request a material substance declaration (MSD) from the supplier of vendor parts for the selected line and its children.</td>
</tr>
<tr>
<td>Initiate Substance Compliance Check</td>
<td>Runs a compliance check of the selected part or assembly against selected regulations.</td>
</tr>
<tr>
<td>Apply Exemptions</td>
<td>Allows you to approve the exemption of a part from a selected regulation.</td>
</tr>
<tr>
<td>Initiate Compliance Results Validation</td>
<td>Allows you to invalidate all substance compliance results that are qualified for invalidation because of expired exemptions.</td>
</tr>
<tr>
<td>Baseline</td>
<td>Copies work in progress (WIP) item revisions. During the development of a product design, you may need to share such copies of your working design with other users at the same or different sites. You can also save your design for future reference.</td>
</tr>
<tr>
<td>For more information, see Using baselines.</td>
<td></td>
</tr>
<tr>
<td>Validate Occurrences</td>
<td>Allows you to validate that a selected line and (optionally) any child lines meet the business rules defined by your administrator for structure edits.</td>
</tr>
<tr>
<td>For information, see Performing on-demand validation.</td>
<td></td>
</tr>
<tr>
<td>Manage Global Alternates</td>
<td>Allows you to define global alternates and a preferred alternate for the selected component.</td>
</tr>
<tr>
<td>Compare...</td>
<td>Compares two product structures (or different revisions of the same structure) in separate windows.</td>
</tr>
<tr>
<td>Clear Compare</td>
<td>Clears the results of comparing two product structures.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Graphical BOM Compare</strong></td>
<td>Compares two revisions of a part or assembly and examine the difference in the <strong>Viewer</strong> pane. You cannot use this command to compare multilevel structures.</td>
</tr>
<tr>
<td><strong>Intermediate Data Capture</strong></td>
<td>Saves the current structure configuration in PLM XML format on your system for later retrieval or transfer.具体的结构配置信息以XML格式保存在系统中，待之后使用。For information about creating intermediate data captures, see <em>Using intermediate data captures</em>.</td>
</tr>
<tr>
<td><strong>Markup→Markup Mode</strong></td>
<td>Turns markup mode on or off.</td>
</tr>
<tr>
<td><strong>Markup→Show Markup View</strong></td>
<td>If the selected line has an associated markup, allows you to view its properties.</td>
</tr>
<tr>
<td><strong>Markup→Delete Markup (this level)</strong></td>
<td>Deletes the active markup for the selected line.</td>
</tr>
<tr>
<td><strong>Markup→Apply Markup (this level)</strong></td>
<td>Applies uncommitted changes in the markup associated with the current line. Any markups associated with lines below the current selection are not committed.</td>
</tr>
<tr>
<td><strong>Markup→Apply Markup (all levels)</strong></td>
<td>Applies uncommitted changes in the markup to the structure, starting from the top line.</td>
</tr>
<tr>
<td><strong>Markup→Validate Access to Apply Markups (all levels)</strong></td>
<td>Identifies if you have the necessary write access to the BOM view revision (BVR) to commit changes in a markup associated with any line below the structure’s top line.</td>
</tr>
<tr>
<td><strong>Site Check In/Out→Check Out to Site</strong></td>
<td>If you are working with Multi-Site Collaboration, allows you to check out the selected object to a chosen site.</td>
</tr>
<tr>
<td><strong>Site Check In/Out→Check in from Site</strong></td>
<td>If you are working with Multi-Site Collaboration, allows you to check in to the selected object from a chosen site.</td>
</tr>
<tr>
<td><strong>Roll up Report→Create</strong></td>
<td>Allows you to create a rollup report. For more information, see <em>Creating structure properties rollup reports</em>.</td>
</tr>
<tr>
<td><strong>Roll up Report→View</strong></td>
<td>Allows you to view a rollup report. For more information, see <em>Creating structure properties rollup reports</em>.</td>
</tr>
<tr>
<td><strong>Roll up Report→Templates</strong></td>
<td>Allows you to manage templates for rollup reports. For more information, see <em>Creating structure properties rollup reports</em>.</td>
</tr>
</tbody>
</table>
You may see additional commands in this menu if optional features are installed at your site. For example, if you install Teamcenter Integration for NX, an Export NX Assembly command is available. Similarly, some commands are hidden unless a preference setting is changed. For information about any additional commands, see the documentation for the optional feature or contact your Teamcenter administrator.

**Graphics menu**

*Note*  The Graphics menu appears when you click the Graphics tab.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection—Select All</td>
<td>Selects all the objects displayed in the viewer.</td>
</tr>
<tr>
<td>Selection—Select None</td>
<td>Unselects any objects currently selected in the viewer.</td>
</tr>
<tr>
<td>Selection—Reverse</td>
<td>Selects all objects not selected in the viewer, while simultaneously unselecting any objects currently selected in the viewer.</td>
</tr>
<tr>
<td>Selection—Expand to Selected</td>
<td>Expands the assembly tree until the part selected in the viewer is displayed in the tree.</td>
</tr>
<tr>
<td>Visibility—View Selected</td>
<td>Blanks and unblanks objects loaded in the viewer.</td>
</tr>
<tr>
<td>Visibility—Blank Selected</td>
<td>Makes any objects selected in the viewer invisible.</td>
</tr>
<tr>
<td>Visibility—Blank All</td>
<td>Makes all objects in the viewer invisible.</td>
</tr>
<tr>
<td>Visibility—Unblank All</td>
<td>Makes all objects loaded in the viewer visible.</td>
</tr>
<tr>
<td>Visibility—Reverse Blank All</td>
<td>Makes any currently visible objects invisible, while simultaneously making visible any loaded objects which are currently invisible.</td>
</tr>
<tr>
<td>Visibility—Unload Selected</td>
<td>Unloads any objects selected in the viewer.</td>
</tr>
<tr>
<td>Edit Color/Translucency</td>
<td>Modifies the color, transparency, and shine of selected objects in the viewer. These settings only apply to the currently loaded objects. The next time the edited object is loaded, the settings revert to the default color and translucency.</td>
</tr>
<tr>
<td>Insert</td>
<td>Allows you to insert JT, stereolithography (.stl) and VRML (.wrl) files as reference graphics.</td>
</tr>
<tr>
<td>Insert—Insert from File</td>
<td>Inserts a reference graphic from the operating system, using the Open by Name dialog box.</td>
</tr>
</tbody>
</table>
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert→Insert from Clipboard</td>
<td>Inserts a reference graphics object from the clipboard.</td>
</tr>
<tr>
<td>Note</td>
<td>Only item revisions (not items) can be displayed as reference graphics.</td>
</tr>
<tr>
<td>Views→Views Control...</td>
<td>Creates, edits and displays standard views, using the Rotate and Standard Views dialog boxes.</td>
</tr>
<tr>
<td>Draw Children</td>
<td>Displays the components of a subassembly. You can also access this command if you right-click in the product structure.</td>
</tr>
<tr>
<td>Show Subcomponents</td>
<td>Breaks down solids in the corresponding monolithic JT files and make the subcomponents independently controllable. This function is only available for only leaf and unpacked structure line nodes.</td>
</tr>
<tr>
<td>Hide Subcomponents</td>
<td>Removes all merged subcomponents and the one-level tree from the tree. You can load or unload the monolithic JT file related to this structure line node in the normal way.</td>
</tr>
<tr>
<td>Export 3D File</td>
<td>Exports the current visible objects to a STEP or VRML file.</td>
</tr>
<tr>
<td>Transformation→Temporary Transformation</td>
<td>Generates an exploded view for use in technical illustrations.</td>
</tr>
<tr>
<td>Transformation→Persistent Transformation</td>
<td>Modifies the physical location of a part (or set of parts) in an owning assembly.</td>
</tr>
<tr>
<td>Replace JT File</td>
<td>Replaces the JT file that represents an item revision. You can choose a replacement file from one of the JT files associated with the current structure line item.</td>
</tr>
<tr>
<td>Clearance→Preferences</td>
<td>Allows you to set the clearance calculator, define the parameters of the clearance calculation, and indicate how the results should be displayed.</td>
</tr>
<tr>
<td>Clearance→Toggle Results Window</td>
<td>Allows you to change the clearance results that are displayed.</td>
</tr>
<tr>
<td>Performance...</td>
<td>Sets rendering, culling and general performance preferences.</td>
</tr>
<tr>
<td>Preferences...</td>
<td>Sets clearance analysis and general viewer preferences.</td>
</tr>
</tbody>
</table>

### Structure line context menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open BOM View</td>
<td>Displays a list of other BOM views in which you can open the selected data. If the line has no BOM views, this command appears as No BOM View to open.</td>
</tr>
</tbody>
</table>
### Command | Description
--- | ---
**Guided Component Search** | Searches for matching components within an assembly. This search allows you to choose from a list of only those classified workspace objects that fit into the first component of your search. You must first configure it in the Classification Administration application.

**Properties on Relation** | Allows you to edit the properties of the object represented by the selected line.

**Cut** | Cuts the selected lines from the structure and places them on the clipboard.

**Copy** | Copies the selected lines in the structure and places them on the clipboard.

**Paste** | Pastes the components from the clipboard as children of the currently selected (assembly) line in the structure or into NX.

**Revert Edit** | Undoes the last manual edit of the selected line.

**Paste Property** | Allows you to paste a property value from the clipboard into one or more structure lines.

**Set In Context** | Allows you to edit the properties of an occurrence in the context of a selected line, that is, to create an absolute occurrence.

**Remove In Context Override** | Removes override data from an absolute occurrence without entering replacement data.

**Show/Hide In Context BOM line** | Shows or hides the line that is the context of a particular in context edit.

**Expand** | Expands the substructure immediately below the selected lines.

**Expand Below** | Expands the complete substructure below the selected lines.

**Expand Below...** | Expands the substructure below the selected lines to a user-selected level. You can also collapse an expanded substructure when you choose this option (hide certain child lines).

**Expand to Type** | Expands the complete substructure below the selected lines until a specified type is encountered.

**Unload Below** | Unloads all lines below the selected line to free memory.

**Collapse Below** | Collapses the complete substructure below the selected lines (hide all child lines).

**Generate Report** | Generates a report on the selected object. You can choose the reporting tool and formatting options.

**Send an Instant Message to Owning User** | Allows you to initiate communication with the user who owns the item or item revision represented by the selected line. The Microsoft Office Communicator integration must be installed on your system.

**Open With** | Opens selected data in a rich client view.
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send To</td>
<td>Sends selected data to another application or an external program. Your Teamcenter administrator uses the Business Modeler IDE application to create new application interface types associated with a specific application. Each of these types are available in the <strong>Send Data To</strong> dialog box.</td>
</tr>
<tr>
<td>Check In/Out</td>
<td>Checks out the object represented by the selected line if it is not already checked out or checks in the object represented by the selected line if it is checked out.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Synchronizes the currently displayed product structure with the database. The displayed structure refreshes with changes that have been made in other sessions and saved since you loaded the currently displayed product structure.</td>
</tr>
<tr>
<td>Properties</td>
<td>Allows you to view all properties of the selected line. You can edit those properties to which you have permission.</td>
</tr>
<tr>
<td>Access</td>
<td>Shows any Access Manager restrictions on the selected line.</td>
</tr>
<tr>
<td>Project→Assign</td>
<td>Assigns the selected structure to a predefined project.</td>
</tr>
<tr>
<td>Project→Remove</td>
<td>Removes the selected structure from a project to which it is assigned.</td>
</tr>
<tr>
<td>License→Attach</td>
<td>Attaches an ADA license to the selected workspace object.</td>
</tr>
<tr>
<td>License→Detach</td>
<td>Detaches the ADA license from the selected workspace object.</td>
</tr>
<tr>
<td>Multi-site Synchronization</td>
<td>Allows you to synchronize a selected object, component or assembly with the remote site in a Multi-Site Collaboration environment. It is only necessary to synchronize structures if the <strong>Sync State</strong> property shows the structure or a component is superseded or out of date.</td>
</tr>
<tr>
<td>Add To Favorites</td>
<td>Allows you to add the selected structure to your list of frequently used objects.</td>
</tr>
<tr>
<td>Update Suppressed</td>
<td>Updates any suppressed occurrences attached to the current line.</td>
</tr>
<tr>
<td>Remove Design from Product</td>
<td>Removes the selected design from the product structure. It is used when your site utilizes Platform Designer.</td>
</tr>
<tr>
<td>Search Reference Designators</td>
<td>Allows you to search for reference designator values; this search allows you to specify wildcards.</td>
</tr>
<tr>
<td>Show Markup View</td>
<td>If the selected line has an associated markup, allows you to view its properties.</td>
</tr>
<tr>
<td>Delete Markup (this level)</td>
<td>Deletes the active markup for the selected line.</td>
</tr>
<tr>
<td>Apply Markup (this level)</td>
<td>Applies uncommitted changes in the markup associated with the current line. Any markups associated with line below the current selection are not committed.</td>
</tr>
<tr>
<td>Disconnect</td>
<td>Disconnects the currently selected line with a revisable or nonrevisable connection to another line.</td>
</tr>
</tbody>
</table>
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect</td>
<td>Connects the currently selected line to another line with a revisable or nonrevisable connection.</td>
</tr>
</tbody>
</table>

### Structure Manager buttons and symbols

**Note** You can add buttons that are not displayed on the main toolbar by right-clicking the toolbar, choosing Customize, and selecting the buttons you want to add. Once you have added buttons to the toolbars, they are displayed in future sessions. Consider adding buttons that:

- You use frequently.
- Provide a shortcut to menu commands that are not primary selections, for example, Tools→Revision Rule→Set Date/Unit/End Item.
- Show current status, for example, incremental change configuration options.

### Button Purpose

These standard buttons are located on the main toolbar at the top of the product structure pane.

<table>
<thead>
<tr>
<th>Button</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Soft abort" /></td>
<td>Soft abort If enabled, allows you to terminate the current operation without closing Structure Manager or losing data.</td>
</tr>
<tr>
<td><img src="image" alt="Cut" /></td>
<td>Cut Cuts the selected lines from the structure and places them on the clipboard.</td>
</tr>
<tr>
<td><img src="image" alt="Copy" /></td>
<td>Copy Copies the selected lines in the structure and places them on the clipboard.</td>
</tr>
<tr>
<td><img src="image" alt="Paste" /></td>
<td>Paste Pastes the components from the clipboard as children of the currently selected (assembly) line in the structure or into NX.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Delete Deletes the selected lines from the structure and does not place them on the clipboard.</td>
</tr>
<tr>
<td><img src="image" alt="Save" /></td>
<td>Save Saves changes you made to the structure since it was last saved.</td>
</tr>
<tr>
<td><img src="image" alt="Split occurrence" /></td>
<td>Split occurrence Splits a line that represents several occurrences into two branches. The new branch and the original (changed) branch initially have the same notes, variant conditions, and other data, but you can subsequently modify them independently</td>
</tr>
<tr>
<td><img src="image" alt="Open" /></td>
<td>Open Opens the selected structure line in a new window.</td>
</tr>
</tbody>
</table>
### Button | Purpose
---|---
[![](image1)](image1) | Signal | Creates a new message or signal. For more information about creating signals, see the *Embedded Software Solutions Guide* or the *Systems Engineering Guide*.

[![](image2)](image2) | Remove | Removes the selected lines from the structure completely and does not place them on the clipboard.

[![](image3)](image3) | Revert marked pending edits | Cancels any pending additions or removals of the selected lines. It also cancels any pending property edits.

**Note** | This button is visible only if you select the *Display Markups for pending edits* option on the *Product Structure* tab of the *Options* pane, and then restart Structure Manager. To display the *Options* pane, choose the Edit→Options command.

| | | Certain edits are committed immediately to the database and cannot be reverted. Such edits are not displayed in red strike-through text.

[![](image4)](image4) | Revert all | Cancels all pending additions or removals of lines anywhere in the structure. It also cancels any pending property edits.

**Note** | This button is visible only if you select the *Display Markups for pending edits* option on the *Product Structure* tab of the *Options* pane, and then restart Structure Manager. To display the *Options* pane, choose the Edit→Options command.

| | | Certain edits are committed immediately to the database and cannot be reverted. Such edits are not displayed in red strike-through text.

[![](image5)](image5) | Remove design from product | Removes the selected design from the product structure. This command is used when your site utilizes Platform Designer.

[![](image6)](image6) | Replace design in product | Replaces the selected design in the product structure with another design. This command is used when your site utilizes Platform Designer.

[![](image7)](image7) | Replace part in product | Replaces the selected part in the product structure with another part. This command is used when your site utilizes Platform Designer.
### Chapter 1  
*Getting started with Structure Manager*

<table>
<thead>
<tr>
<th><strong>Button</strong></th>
<th><strong>Purpose</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Edit the variant condition" /></td>
<td>Allows you to view or edit the variant condition on the selected lines.</td>
</tr>
<tr>
<td><img src="image" alt="Change to replace" /></td>
<td>Changes separate deletion and addition actions to a single replacement action.</td>
</tr>
<tr>
<td><img src="image" alt="Pack selected line" /></td>
<td>Packs the selected lines so that all lines with the same item revision and find number are displayed as a single line. The actual quantity of lines appended to the node.</td>
</tr>
<tr>
<td><img src="image" alt="Unpack selected line" /></td>
<td>Unpacks the selected packed lines so that they are displayed as separate lines, one for each occurrence.</td>
</tr>
<tr>
<td><img src="image" alt="View properties" /></td>
<td>Shows the properties of the selected line.</td>
</tr>
<tr>
<td><img src="image" alt="Add/edit note" /></td>
<td>Adds or edits the occurrence notes of the selected line.</td>
</tr>
<tr>
<td><img src="image" alt="Show connected lines" /></td>
<td>Displays all lines that are connected by the selected connection.</td>
</tr>
<tr>
<td><img src="image" alt="View/set revision rule" /></td>
<td>Allows you to view or set the revision rule on the current line.</td>
</tr>
<tr>
<td><img src="image" alt="Save, set and load variant option values" /></td>
<td>Allows you to view, set, save, and load the variant option values for the selected line.</td>
</tr>
<tr>
<td><img src="image" alt="View or change active arrangement" /></td>
<td>Allows you to view or change the active arrangement for the root assembly.</td>
</tr>
<tr>
<td><img src="image" alt="Objects to Word" /></td>
<td>Opens the selected document in Microsoft Word.</td>
</tr>
<tr>
<td><img src="image" alt="Open in NX" /></td>
<td>Starts NX and displays the selected assembly structure. This action sends PLM XML data representing the geometry of the selected assembly to NX.</td>
</tr>
<tr>
<td><img src="image" alt="Open in Lifecycle Visualization" /></td>
<td>Starts Lifecycle Visualization and displays the selected assembly structure.</td>
</tr>
<tr>
<td><img src="image" alt="Show/hide data pane" /></td>
<td>Displays the data pane that contains the Attachments, Graphics, Incremental Change Info, Variants, Referencers, Parts, and Supersede tabs and panes.</td>
</tr>
<tr>
<td><img src="image" alt="Graphical compare" /></td>
<td>Opens the Graphical Compare dialog box and allows you to visually compare two revisions of the same structure.</td>
</tr>
<tr>
<td><img src="image" alt="Show/hide search results" /></td>
<td>Allows you to show or hide the Structure Manager Search Results pane.</td>
</tr>
<tr>
<td><img src="image" alt="Search" /></td>
<td>Allows you to search the product structure for a particular component or subassembly. Results are displayed in the Structure Manager Search Results pane.</td>
</tr>
<tr>
<td>Button</td>
<td>Purpose</td>
</tr>
<tr>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>Move to first revision</td>
<td>Jumps to the earliest revision of the selected component or subassembly.</td>
</tr>
<tr>
<td>Move to previous revision</td>
<td>Jumps to the preceding revision of the selected component or subassembly.</td>
</tr>
<tr>
<td>Move to next revision</td>
<td>Jumps to the succeeding revision of the selected component or subassembly.</td>
</tr>
<tr>
<td>Move to last revision</td>
<td>Jumps to the final revision of the selected component or subassembly.</td>
</tr>
<tr>
<td>Markup mode</td>
<td>Enables or disables markup mode.</td>
</tr>
<tr>
<td>Markup view</td>
<td>Opens or closes the Markup view.</td>
</tr>
<tr>
<td>Add signals from library</td>
<td>Allows you to add a signal or other object from the data dictionary to the structure.</td>
</tr>
<tr>
<td>Navigation pane</td>
<td>Opens the navigation pane.</td>
</tr>
<tr>
<td>Create note</td>
<td>Displays the New Item wizard, allowing you to create a new standard note or custom note.</td>
</tr>
<tr>
<td>Add classified component</td>
<td>Allows you to use the guided component search to add a classified component to the structure.</td>
</tr>
<tr>
<td>View/set closure rule</td>
<td>Allows you to view available closure rules and then set a closure rule to limit structure expansions.</td>
</tr>
</tbody>
</table>

The following buttons are displayed at the bottom left corner of the product structure navigation tree pane.

<table>
<thead>
<tr>
<th>Button</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open by name</td>
<td>Browses for and opens a specific structure by name.</td>
</tr>
<tr>
<td>Most recently used (MRU) list</td>
<td>Shows a list of your most recently accessed structures. If you select an entry from the list, Structure Manager loads the structure into the structure pane. You can configure the number of entries shown in the MRU list by right-clicking the button and moving the slider to the desired number.</td>
</tr>
<tr>
<td>Most recently used (MRU) revision rules list</td>
<td>Selects a revision rule to apply to the current product structure from a list of the rules you have used recently. You can configure the number of entries shown in the MRU by right-clicking the button and moving the slider to the desired number.</td>
</tr>
<tr>
<td>Find components in display</td>
<td>Searches for matching lines (components) in the displayed product structure by entering an expression. You can search with any combination of the available properties.</td>
</tr>
</tbody>
</table>
### Structure Manager tabs

Click , or choose **View→Show/Hide Data Panel** to display the data pane which contains these tabs.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments</td>
<td>Allows you to select and view attachments to the selected line, for example, a dataset or form. The visibility of this tab is controlled by the setting of the <strong>BOM_Display_Attachments_Panel</strong> preference.</td>
</tr>
</tbody>
</table>
## Tab Description

**Graphics**
Displays an image of the selected line or lines, if a DirectModel dataset is available.

**Incremental Change Info**
Allows you to add, edit, or remove incremental changes for the selected line.

The visibility of this tab is controlled by the setting of the Incremental_Change_Management preference.

For more information, see Managing incremental changes.

**Referencers**
Allows you to perform a where-used or where-referenced search for the selected item revision.

The visibility of this tab is controlled by the BOM_Display_Referencer_Panel preference.

**Roll Up Report**
Allows you to view or create rollup reports for the selected line. You can also create and manage rollup report templates.

**Supersedure**
Displays supersedure information for the selected item revision.

The visibility of this tab is controlled by the ECM_SET_GENELOGY preference.

**Variability**
Allows you to assign variability to a product context for use in Platform Designer.

The visibility of this tab is controlled by the PSM_global_option_item_ids preference.

**Variants**
Displays variant data such as options, option defaults, and rule checks. Variant conditions are displayed in the Properties pane.

The visibility of this tab is controlled by the BOM_Display_Variant_Super_Panel preference.

**Vendor Parts**
Allows you to view and select from the vendor parts associated with the selected item revision.

This tab is available only if the optional vendor management solution is installed; consequently, the VendorManagement_feature_installed preference is set.

### Structure Manager structure tree images

The images in the product structure navigation tree indicate the purpose of each node. Descriptions of images specific to certain functionality are provided with the relevant procedures.

<table>
<thead>
<tr>
<th>Image</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image.png" alt="Image" /></td>
<td>Item</td>
</tr>
</tbody>
</table>
## Image Meaning

<table>
<thead>
<tr>
<th>Image</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>Item revision (structure line or BOM line)</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td>Item element (general design element)</td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td>Form</td>
</tr>
<tr>
<td><img src="image4.png" alt="Image" /></td>
<td>Dataset</td>
</tr>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td>BOM view</td>
</tr>
<tr>
<td><img src="image6.png" alt="Image" /></td>
<td>Part</td>
</tr>
<tr>
<td><img src="image7.png" alt="Image" /></td>
<td>Design</td>
</tr>
<tr>
<td><img src="image8.png" alt="Image" /></td>
<td>Alternate ID</td>
</tr>
<tr>
<td><img src="image9.png" alt="Image" /></td>
<td>Document</td>
</tr>
<tr>
<td><img src="image10.png" alt="Image" /></td>
<td>Document revision</td>
</tr>
<tr>
<td><img src="image11.png" alt="Image" /></td>
<td><strong>DirectModel</strong> dataset</td>
</tr>
<tr>
<td><img src="image12.png" alt="Image" /></td>
<td><strong>UGMaster</strong> dataset</td>
</tr>
<tr>
<td><img src="image13.png" alt="Image" /></td>
<td><strong>UGPart</strong> dataset</td>
</tr>
<tr>
<td><img src="image14.png" alt="Image" /></td>
<td><strong>UGScenario</strong></td>
</tr>
<tr>
<td><img src="image15.png" alt="Image" /></td>
<td>Variant item</td>
</tr>
<tr>
<td><img src="image16.png" alt="Image" /></td>
<td>Variant item revision</td>
</tr>
<tr>
<td><img src="image17.png" alt="Image" /></td>
<td>Incremental change removed</td>
</tr>
<tr>
<td><img src="image18.png" alt="Image" /></td>
<td>Incremental change added</td>
</tr>
<tr>
<td><img src="image19.png" alt="Image" /></td>
<td>Separate incremental changes removed and added</td>
</tr>
<tr>
<td><img src="image20.png" alt="Image" /></td>
<td>Absolute occurrence override removed by incremental change</td>
</tr>
<tr>
<td><img src="image21.png" alt="Image" /></td>
<td>Absolute occurrence override added by incremental change</td>
</tr>
<tr>
<td><img src="image22.png" alt="Image" /></td>
<td>Absolute occurrence overrides removed and added by separate incremental changes</td>
</tr>
<tr>
<td><img src="image23.png" alt="Image" /></td>
<td>In scope for creation of absolute occurrences</td>
</tr>
<tr>
<td>Image</td>
<td>Meaning</td>
</tr>
<tr>
<td>-------</td>
<td>---------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>Absolute occurrence created</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td>Added structure line</td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td>Removed structure line</td>
</tr>
<tr>
<td><img src="image4.png" alt="Image" /></td>
<td>Replaced structure line</td>
</tr>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td>Structure line has unreadable children</td>
</tr>
<tr>
<td><img src="image6.png" alt="Image" /></td>
<td>Structure line is a variant module</td>
</tr>
<tr>
<td><img src="image7.png" alt="Image" /></td>
<td>Component has alternates</td>
</tr>
<tr>
<td><img src="image8.png" alt="Image" /></td>
<td>Component has substitutes</td>
</tr>
<tr>
<td><img src="image9.png" alt="Image" /></td>
<td>Component has variants</td>
</tr>
<tr>
<td><img src="image10.png" alt="Image" /></td>
<td>Process</td>
</tr>
<tr>
<td><img src="image11.png" alt="Image" /></td>
<td>Process revision</td>
</tr>
<tr>
<td><img src="image12.png" alt="Image" /></td>
<td>Process variable</td>
</tr>
<tr>
<td><img src="image13.png" alt="Image" /></td>
<td>Snapshot</td>
</tr>
<tr>
<td><img src="image14.png" alt="Image" /></td>
<td>PS connection</td>
</tr>
<tr>
<td><img src="image15.png" alt="Image" /></td>
<td>PS connection revision</td>
</tr>
<tr>
<td><img src="image16.png" alt="Image" /></td>
<td>PS signal</td>
</tr>
<tr>
<td><img src="image17.png" alt="Image" /></td>
<td>PS signal revision</td>
</tr>
<tr>
<td><img src="image18.png" alt="Image" /></td>
<td>Allocation</td>
</tr>
<tr>
<td><img src="image19.png" alt="Image" /></td>
<td>Allocation map</td>
</tr>
<tr>
<td><img src="image20.png" alt="Image" /></td>
<td>Allocation map revision</td>
</tr>
<tr>
<td><img src="image21.png" alt="Image" /></td>
<td>When displayed in the structure tree after a search, this symbol indicates the line has hidden children. Click this box to load and view the hidden children.</td>
</tr>
<tr>
<td><img src="image22.png" alt="Image" /></td>
<td>Remote part</td>
</tr>
<tr>
<td><img src="image23.png" alt="Image" /></td>
<td>Line of assembly</td>
</tr>
</tbody>
</table>
Rich client perspectives and views

Within the Teamcenter rich client user interface, application functionality is provided in perspectives and views. Some applications use perspectives and views to arrange how functionality is presented. Other applications use a single perspective and view to present information.

**Note** Your administrator can use the **HiddenPerspectives** preference to prevent the display of some Teamcenter perspectives in the rich client.

For information about editing preference values, see the *Preferences and Environment Variables Reference*.

If your site has online help installed, you can access application and view help from the rich client **Help** menu or by pressing F1.

For more information about rich client perspectives and views, see the *Rich Client Interface Guide*.

Basic concepts

Before creating or modifying product structure, you should read *Getting Started with Product Structure*, which describes the basic concepts behind product structure and includes advanced information on how to use and administer it.

Engineers group parts into assemblies to allow reuse of the same assemblies elsewhere in the product or in other products. An assembly can contain components that are piece parts or assemblies. In this way, you can model a complete product structure as a hierarchy of single-level assemblies.

Teamcenter supports two methods of modelling parts. You can create an item that represents the part and CAD design simultaneously, which is the method familiar to former users of Teamcenter Engineering Process Management. You can also create parts and designs separately, then link (publish) parts and designs when they are ready to release.

You can view previously created graphics that represent all or part of the structure, allowing easy visual identification of a component in the structure.

Structure Manager allows you to create assemblies that are one of the following:

- **Precise**
  A precise assembly references a specific revision of each component.

- **Imprecise**
  In an imprecise assembly, the revision configured in the Structure Manager window is determined by the revision rule currently in force.

You can define sophisticated revision rules to configure the structure in different ways. For example, you can use revision configuration based on the release status.
of each item revision. This allows you to configure the structure according to its effective date or unit number, or the date released.

For more information about revision rules and their use, see *Using item revision configuration*.

To take full advantage of Structure Manager, you should be familiar with the Teamcenter elements that are used to define and present product structure, the basic process of creating product structure, and how item revisions relate to how you manage default and multiple product views.

### Navigating the structure

Structure Manager allows you to create a product structure, navigate an existing product structure, and find items in it.

For detailed conceptual information, see *Getting Started with Product Structure*.

### Product structure elements

The following elements may be included in a product structure that you manage in Structure Manager.

**Note** The terms *component*, *line*, and *occurrence* are used commonly. All these terms refer to the single-level link between an assembly and a component. Information typically associated with the link includes find numbers and notes for assembly (such as torque setting and lubrication notes). Data used for configuration may also be stored on an occurrence (for example, variant condition).

<table>
<thead>
<tr>
<th>Element</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aggregate occurrence</td>
<td>A single occurrence representing multiple usages of the same component item by setting the quantity attribute. Use an aggregate occurrence where separate occurrences are not required to distinguish individual usages (for example, rivets).</td>
</tr>
<tr>
<td>Assembly</td>
<td>A single-level assembly with no hierarchy, as distinct from a multilevel product structure. Assembly data is stored in a BOM view revision.</td>
</tr>
<tr>
<td>BOM view revision</td>
<td>A workspace object that stores the single-level assembly structure of an item revision, that is, occurrences. Access may be controlled on the structure (BOM view revision) independently of other data. BOM view revisions are only meaningful in the context of the item revisions for which they are created.</td>
</tr>
</tbody>
</table>
### Element | Purpose
--- | ---
Component | A node in a structure—a child in a single-level parent-child relationship. When you add components, you create an occurrence for each component added.

Contrast with *instance*—a child in a multilevel parent-child relationship.

**Note** Do not confuse a component in Teamcenter with a component in NX. In Teamcenter, a component is a single-level assembly-child relationship (a relative occurrence).

Configuration rule | A rule that configures the structure. There are two kinds of configuration rules: *revision rules* and *variant rules*.

Custom note | Provides additional information about an item or item revision. A custom note contains unique information about the part or document. Compare with *standard note*.

**DirectModel** dataset | A dataset containing a JT (visualization) file. Files of this format can be generated by NX and other applications.

Default view type | Teamcenter applies a default global view type where possible, for example, when opening an item revision. Use of a default view type avoids the need for a user to choose between multiple views. The default view type is set by the *PSE_default_view_type* preference.

Design | The CAD design solution that implements a business part. Each part may be implemented by one or more CAD designs. Likewise, a CAD design may implement more than one part. Certain parts do not require a design solution, for example, paint and glue.

Find number | A number that identifies individual occurrences (or groups of occurrences) within a single-level assembly. Components are ordered by find number within an assembly.

**Note** By default, occurrences are populated with numeric find numbers. However, they may contain any text string. Teamcenter ignores nonnumeric values when ordering components in the assembly.

Line | A line in the product structure and all the attributes associated with it. A line represents a single occurrence in the structure. When you click a line, you select all the properties associated with the line, including both occurrence and item properties.

**Note** In Structure Manager, you can edit appropriate properties of the selected line, for example, the item revision or note.

Note (occurrence note) | Assembly related textual data that is associated with an occurrence. Contrast with *standard note* and *custom note*. 
### Table

<table>
<thead>
<tr>
<th>Element</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note type (occurrence note)</td>
<td>The system administrator creates different occurrence note types. Users can then specify values for the different note types where required.</td>
</tr>
<tr>
<td>Occurrence</td>
<td>(Sometimes called relative occurrence.) A hierarchical structure relationship between the immediate parent assembly and its child component item (in an imprecise assembly) or item revision (in a precise assembly). You can use a find number to identify an occurrence, but this number may not be unique. Data can be stored on the occurrence, including occurrence notes and transforms.</td>
</tr>
<tr>
<td>Part</td>
<td>A business object that is represented by an item in the product structure. Each part may have one or more CAD designs associated with it. The part is managed by the company’s part releasing system; it is typically revised and releases separately from the associated design.</td>
</tr>
<tr>
<td>Piece part</td>
<td>A part with no structure (no associated BOM view revision). This is sometimes referred to as a detail part.</td>
</tr>
<tr>
<td>Product structure</td>
<td>The whole multilevel product structure, as distinct from a single-level assembly (which is sometimes referred to as a BOM view revision or BVR).</td>
</tr>
<tr>
<td>Standard note</td>
<td>Provides additional information about an item or item revision. A standard note typically contains information provided by a standards organization and can be attached to multiple parts or documents. Compare with custom note.</td>
</tr>
<tr>
<td>Substitute</td>
<td>A particular occurrence may have substitute components that are interchangeable for that specific occurrence. One is the preferred substitute, and Teamcenter shows it in the structure. If these substitute parts are intended as manufacturing substitutes, you can manufacture an assembly using any of the substitutes.</td>
</tr>
<tr>
<td>View type</td>
<td>An attribute of a BOM view revision that specifies its intended usage, for example, design or manufacture. The administrator may define any number of view types.</td>
</tr>
</tbody>
</table>

### Creating product structure

You create a product structure that represents the design and configuration of your product.

In Structure Manager, you create a product structure, sometimes called a bill of materials (BOM). Teamcenter allows you to view an indented listing of the assemblies and piece parts that comprise the product structure; the indenting
allows you to interpret the relationship between the assemblies and piece parts. An assembly has structure of its own; a piece part has no structure.

In My Teamcenter, you can attach CAD files, specification documents or other information to the top-level assembly (the product itself), or to any of the assemblies or piece parts.

You can also attach item elements (sometimes called general design elements or GDEs) to items in the product structure. They represent features that are not parts of the physical structure but are associated with it or implemented by it, for example, weld points or ports for connectors. They are stored as occurrence relations.

You can build, view, and manipulate the product structure in Teamcenter, or you can import it from an MCAD system such as NX.

You can include 3D visualization data as Direct Model dataset objects within an item revision. Users can then view these images in the embedded viewer in Structure Manager.

Understanding items

The term item generically describes all types of items that exist in Teamcenter. To effectively manage many types of item, you should create specific types of item appropriate to your business.

You should also distinguish between the item and its associated item revisions, as follows:

- Item
  An item commonly represents manufactured product such as parts, assemblies, end items, and tools. It is an abstract container that holds item revisions and general documents that apply to the product, rather than to a particular revision. You cannot build or test an item.

- Item revision
  An item revision represents a physical entity and is a unique, specific revision of a previously created item. It may have associated CAD models, drawings or specifications that are applicable only to this revision. You can release an item revision with a workflow or through change management. This action applies a Released status to the item revision, preventing further edits and allowing Teamcenter to maintain product history.

Users can search for an item if they do not know the applicable item revision; all available item revisions are grouped below the item. When the relevant item revision is identified, you can retrieve CAD files and other file representations of part data including 2D or 3D images of drawings or models. If you search for an assembly, you can also view the structure of the product.

Working with items

Items are the fundamental objects used to manage information in Teamcenter. They represent parts and other objects that you want to manage with a life cycle. Items generally represent data that is configuration controlled by revisioning. Items collect a variety of different types of business data, for example, CAD files for parts, document files such as specifications, reports, and forms for metadata. All such data is related to the item by appropriate relationships.
Each item has at least one item revision, as described in *Understanding items.* Each item has a label containing two pieces of information:

- **Item identifier**
  
  An identifier for the item. No two items can have the same item ID. An item ID may be the part number or the document number of the object it represents.

  In a standard environment, each item has a single, unique identifier. However, in a multifield keys environment, the administrator may combine a domain name (business object type) and one or more of the object’s properties to construct the identifier. For example, in the `Part[item_id]` key, `Part` is the domain. In this environment, the item ID may not be unique and the system may present you with a list of possible items if you specify a nonunique item ID.

- **Item name**
  
  A short description that is usually a logical name such as *Bolt, Bracket,* or the title of a document.

**Navigating the structure**

Structure Manager provides several methods that assist you in navigating the product structure and finding items.

**Where used**

A *where used* search allows you to find all parent assemblies in which a part is used, navigating up the structure. You can set the search depth as follows:

- **One level**
  
  Reports immediate parent assemblies only.

- **All levels**
  
  Reports all assemblies up to the top-level product.

- **Top level**
  
  Reports final products only.

The search results may be displayed or stored as a report.

**Compare**

You can compare two structures to view and reconcile the differences between structures. The comparison is performed on the *as-expanded* structure and you can choose the areas of the structure to compare. You can set the revision rule and variant rule separately for each structure, allowing different configurations to be compared. The comparison identifies quantity and revision differences in three modes:

- **Single level**
  
  Compares only the first levels of the product structures.

- **Multilevel**
Chapter 1  Getting started with Structure Manager

Performs a single-level comparison at the top level, and then invokes further single level comparisons on any subassemblies that match between the two product structures. This process is repeated successively down the product structure.

- Lowest level only

  Compares only the lowest level items of the product structures, ignoring all intermediate assemblies. This is useful for checking that piece parts are consistent.

The results are displayed in a dialog box that steps you through each difference. You can also print the results to a report.

You can also perform the comparison graphically in the embedded viewer, which is a useful tool for designers. In this case, the components present in one structure but not the other are highlighted in separate colors and can be isolated from the other common parts, allowing easy visualization of the changes. You can also perform this comparison on different revisions of piece parts to highlight geometry changes.

The Multi-Structure Manager application allow you to compare two views of the same product structure to identify differences. For example, you may want to compare two revisions of the same structure or the design and manufacturing views of the same structure. Any anomalies found during the comparison are reported, although an imbalance between the two structures may not necessarily indicate a problem with either of the structures. The following anomalies are reported:

- Lines in the source structure that are not consumed in the target.
- Each time a line is consumed more than once.

You can run an analysis manually or in batch mode. You can also run it with or without variant options applied.

Find in structure

You can search for components in the structure by any of their properties, for example, item ID, name, attributes on the item revision master form, and occurrence note attributes. You can build a query with as many expressions as necessary, giving a flexible way to find components in large structures. This search works on the expanded state of the structure.

Nonspatial searches

You can search a structure by organizational attributes, rather than performing spatial searches. Searches can be made against one or more such attributes, for example, partition identifier, logical position, usage address, and absolute occurrence identifier. You do not need to configure appearances to run this type of search.

Fast searches

Teamcenter provides a quick spatial search mechanism that allows you to query a given configuration of the product structure to locate parts in a particular area of the product. Spatial searches are primarily useful for large products containing thousands of structure lines.
You can specify the area to search by entering spatial coordinates in the search dialog window or by dragging a search box on the viewer pane. The search results are displayed as a list of items or item revisions in the specified area. Spatial searches may be combined with Classification searches, saved queries, and filters to refine the search results.

The quick spatial search does not require you to maintain data caches. However, Teamcenter supports appearance searches and quick part locator (QPL) searches if you maintain secondary data caches for use with those mechanisms.

For more information about spatial searches, see *Making spatial and attribute searches*.

**Understanding BOM view revisions, view types, and multiple views**

A *BOM view revision* is a Teamcenter workspace object that contains the single-level structure of an item revision. You can see BOM view revisions attached to the item revision by the *BOMView revision* relation. BOM view revisions are visible in other Teamcenter applications and allow you to easily distinguish different view types. Teamcenter processes BOM view revisions in a similar way to items.

You can apply protection to BOM view revisions independently of other data. You can also release a BOM view revision independently of the related item revision or other associated data.

Teamcenter automatically creates BOM view revisions when you initially create the product structure in Structure Manager; it is not necessarily to manually create BOM view revisions. However, you can manually create BOM view revisions if you create multiple views in the structure.

BOM view revisions are only meaningful in the context of the item revision in which they are created. You can paste references to BOM view revisions into a regular folder, for example, to collect together objects to submit to a release. However, you cannot copy references of BOM view revisions into other item revisions.

The *view type* is an attribute of a BOM view revision that indicates its purpose, for example, design or manufacturing. It allows you to distinguish one BOM view revision to be distinguished from another BOM view revision in the same item revision.

The view type of a BOM view revision in a parent assembly is not dynamically configured in the same way as revisions. You must specify the view type when you add the component to the assembly, for example, adding a specific (nonconfigurable) view of the component. If the component has multiple views, you can change the view type referenced by the parent assembly, but must have write access to the parent assembly to complete this edit operation.

The administrator defines a set of view types for each site using the Business Modeler IDE, as described in the *Business Modeler IDE Guide*. Any number of view types can be defined, but most sites only require a single view type for product structure synchronization with Structure Manager.

You can use a *Bought In* view type to model a view that has no components. This may be useful when an assembly designed in one organization should be treated as a piece part in the parent assembly of a different structure.

For information on creating and modifying view types, see *Managing BOM view types*. 
Setting a default view type

In general, few assemblies require multiple views and Teamcenter does not expect you to select a view type when you work with single view assemblies. To ensure single view assemblies are managed correctly, your administrator can define a default view type for each action that requires selection of a view type, for example, creating, editing or opening a structure.

Teamcenter uses the following rules to determine whether to use a default view type.

- If there is only one view type available, Teamcenter uses this view type.
- If there are multiple view types available, Teamcenter:
  - Uses the same view as the parent assembly, for example, when creating a structure.
  - Use the default view type if possible.
  - If there are several view types available and Teamcenter cannot determine the appropriate selection, it prompts the user to select a view types.

Consider setting the default view type in Role preference files, for example, so that the preference file for the Designer role has the default view type of Design, and the preference file for the Manufacturing Engineer role has the default view type of Manufacture. You can set the default view type option in any of the other preference files—User, Group, or Site.

Setting access control on view types

You can use Access Manager to create rules that control write access to the different view types, preventing users from inadvertently editing the structure when manipulating multiple views. For example, production engineers creating manufacturing views should not have write access to design view types. This would prevent production engineers from unintentionally cutting components from the design view when copying components from the design view to create the associated manufacturing view.

Understanding precise and imprecise assemblies

Imprecise assemblies are dynamic structures of items. An imprecise assembly has links (occurrences) to items of its components.

Imprecise assemblies allow you to see the product structure (bill of materials) configured with the relevant item revisions, according to the revision rule you choose for the window. For example, you may want to configure the product structure with revisions that are released for production or, alternatively, with the latest working revision of components. All users look at the same underlying product structure, but view different configurations in different circumstances according to the revision rule to suit particular needs. Teamcenter automatically reconfigures an imprecise structure when new parts are released or created, or other changes are made. Consequently, it is not necessary to make a copy of the structure and manually update it if you make changes.

Precise assemblies are fixed structures of specific item revisions. A precise assembly has links (occurrences) to item revisions of its components. When you modify a
component to a new revision, you must manually update the assembly by removing the old revision of the component and adding the new revision.

You configure the precise references with a **revision rule** containing a **precise** rule entry. However, you can dynamically configure a precise assembly (treated it as imprecise) by applying a revision rule that does not contain the precise rule entry, or has the entry at a lower precedence. Precise assemblies are useful in situations where you must control the configuration very carefully, for example, in aerospace environments.

When the parent assemblies are released and can no longer be modified, any change may result in significant **revision ripple**. If you incorporate new revisions of piece parts, every parent assembly to the top of the structure must also be revised. However, you can group changes into batches to minimize this effect.
### Item revision configuration

You can change a BOM view revision from precise to imprecise if you have write access to the BOM view revision. This operation causes all the occurrences of that BOM view revision (for example, all of the components for that assembly, everywhere it occurs) to be changed. When you toggle an assembly from imprecise to precise, the precise occurrences reference the item revision that was configured. When you change precise BOM view revisions to imprecise, the Structure Manager window’s revision rule is applied to determine the revision of the item for each component in the BOM view revision that should display.
Creating multiple views

Different users within an organization often need to view the structure of a product in different ways. For example, a designer may require a structure hierarchy that is organized by functional subsystem, while a manufacturing engineer may require a structure that reflects the manufacturing assembly process, to allow a better interface to an ERP system. These structures contain the same set of piece parts and represent the same overall physical part. It may therefore be convenient to model the structures as different, independently modifiable views of the same assembly. The multiple views functionality allows you to model such structures in this way.

Multiple views

You can also use multiple views if the different structures do not reference the same set of piece parts, for example, to model a spares structure that is derived from a design structure.

You can also create multiple views to exchange data with ERP systems, particularly if are several manufacturing sites.

The structures in the different view types are independent of each other—changes in one view type do not affect any others. If you intend to keep multiple views synchronized, you must do this manually using data generated by the Compare feature. You can apply access rights separately to each view type.

Similarly, you can be submit each view separately to a release procedure. Typically, you employ a formal release process (for example, a change management procedure) to approve multiple views as consistent and valid before they are released and locked against change.

Note Teamcenter does not attach any semantic significance to specific view types. However, it is good practice for the name of each view type to reflect its function or purpose.

Locating multiple views in the product structure

Multiple views generally only occur at a high level in the structure of a complete product, for example, for assemblies representing major modules. The lower level assemblies typically only have a single view, for example, for design or manufacture.

Teamcenter allows a parent assembly with a BOM view revision of a manufacture type to refer to components with a BOM view revision of a different type (for
example, design). This may be useful if the structures differ at a high level, but share the same structure at a lower level.

**Basic tasks**

<table>
<thead>
<tr>
<th>Task</th>
<th>Overview</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Browse product structure</strong></td>
<td>You can view the assembly structure of a product, navigate around the structure, and find components in the structure. From any point in the structure, you can access the associated data, for example, datasets.</td>
</tr>
<tr>
<td><strong>Visualize product structure</strong></td>
<td>You can display a graphical representation of the product, if the relevant <strong>DirectModel</strong> dataset image is associated with the product structure. Selecting a component in the viewer highlights the component in the product structure and vice versa.</td>
</tr>
<tr>
<td><strong>Build and edit structure</strong></td>
<td>You can create and modify product structure using <strong>Cut</strong>, <strong>Copy</strong>, <strong>Paste</strong>, and <strong>Remove</strong> commands. You can specify related information, such as torque settings, for any component.</td>
</tr>
<tr>
<td><strong>Make where-used searches</strong></td>
<td>A where-used search reports all assemblies in which a part is used. Perform this search in the <strong>Referencers</strong> pane.</td>
</tr>
<tr>
<td><strong>Compare product structures</strong></td>
<td>You can compare two Structure Manager structures, each configured as required, to highlight any changes.</td>
</tr>
<tr>
<td><strong>Use item revision configuration</strong></td>
<td>You can set a revision rule that determines the revision of each component that Teamcenter configures. This allows you to configure a structure as it was or will be on a particular date, for example, by utilizing effectivity data on each item revision (release status).</td>
</tr>
<tr>
<td><strong>Configure variant products</strong></td>
<td>You can set a variant rule to determine which variant components are configured in the structure. Teamcenter references variant data you create on the structure to determine the appropriate variant components.</td>
</tr>
<tr>
<td><strong>Configure modular variant products</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Open a structure in NX or Teamcenter lifecycle visualization</strong></td>
<td>You can load a complete product structure or selected components from the structure, into NX directly from Structure Manager, if you have installed Teamcenter Integration for NX. Teamcenter Integration for NX allows you to make changes to the assembly structure in NX and synchronizes the changes into the Teamcenter database.</td>
</tr>
</tbody>
</table>

**Note**  You can also manage product structures created in other CAD packages, if you have installed the appropriate integration software.

For more information, contact your Siemens PLM Software representative.
Chapter

2 Configuring Structure Manager

Configuring Structure Manager ............................................. 2-1

Setting your local user preferences ........................................ 2-1
  Setting the default view type ............................................. 2-1
  Setting the default revision rule ......................................... 2-1
  Packing the Structure Manager display by default ................. 2-2
  Allowing searches of remote sites ..................................... 2-2
  Enabling markups ............................................................ 2-2
  Setting BOM view precision .............................................. 2-2
  Setting the visibility of unconfigured variants ...................... 2-3
  Setting the visibility of unconfigured occurrences ................. 2-3
  Setting the color of precise and imprecise assemblies .......... 2-3
  Setting the visibility of information center elements ............ 2-3

Configure the structure line title format ................................. 2-3

Setting administrative preferences ....................................... 2-4
  Setting the owning item display for option variant data ......... 2-4
  Controlling users who can set effectivity ........................... 2-5
  Setting publishing preferences .......................................... 2-5
  Setting find number allocation ......................................... 2-5

Setting the viewer memory allocation and Java heap size ........... 2-6
Chapter

2 Configuring Structure Manager

Configuring Structure Manager

Set your user preferences by choosing the Edit→Options menu command and selecting the appropriate preference. For more information about setting preferences, see the Preferences and Environment Variables Reference.

Setting your local user preferences

You can set the local user preferences by choosing the Edit→Options menu command or other command where described. These preferences (options) configure the user interface and certain default functions to suit your requirements. They are stored in your personal preference file in the Teamcenter database. In addition, the system administrator sets site and group preferences that configure other user options to the same values for all users.

Note It is not necessary to add or set every user preference manually. Teamcenter creates or sets some preferences automatically when you perform certain actions or use specific features, for example, PS_assume_legacy_transform_units.

Setting the default view type

This option sets the default view type Teamcenter uses when multiple views are present and there is ambiguity, for example, when opening Structure Manager or pasting in an assembly.

Typically, your administrator sets a default view type for all users at the site, for example, Design. However, this setting is most appropriately defined in conjunction with each user’s role. For example, users with the role of production engineer can define their default view type as Manufacture; users with the role of designer can define their default view type as Design. For additional information, see the Preferences and Environment Variables Reference.

• Corresponding preference name: PSE_default_view_type
• Default setting: view

Setting the default revision rule

This option sets the default revision rule Teamcenter uses when opening a new product structure window. Your site or group administrator may set a default value that you can change for your current session.
• Corresponding preference name: TC_config_rule_name

• Default setting: Latest Working

Packing the Structure Manager display by default

This option sets how the structure is displayed if there are a number of components with the same item revision. You can choose to show the structure as one line or with one line for each component. For more information, see Packing or unpacking structure lines.

This option applies in two circumstances:

• When a structure is first created, for example, the components are added.

• When the assembly that contains the components is first expanded.

You may explicitly change how a particular set of item revisions are packed or unpacked by choosing the View→Pack and View→Unpack menu commands. This selection applies only for the duration of the session.

• Corresponding preference name: PSEAutoPackPref. Accepts a logical 0 or 1 as a value.

• Default setting: 1 (pack identical occurrences on a single structure line).

Allowing searches of remote sites

If you work in a Multi-Site Collaboration environment, assemblies and components can be mastered at a site other than the one where you work. The Allow Structure Manager to perform search using Appearance Search Engine at remote sites option allows Teamcenter to search data at remote sites as well as data at your site. The default setting is off.

Note If you enable searching of remote sites, results may be returned more slowly than if you search only your local site.

Enabling markups

This option allows you to mark proposed changes on the product structure or an assembly, and then save the markup as a persistent workspace object. The default setting is off.

Setting BOM view precision

This option sets whether BOM view revisions are created as precise or imprecise. This option accepts the values Precise and Imprecise.

• Corresponding preference name: TC_BOM_Precision_Preference

• Default setting: Imprecise
Setting the visibility of unconfigured variants

This preference sets whether unconfigured variant components are hidden or displayed by default. You can change this setting by choosing the View→Show Unconfigured Variants menu command.

- Preference name: PSEShowUnconfigdVarPref. Set to 0 for hidden or 1 for displayed.
- Default setting: 1

Setting the visibility of unconfigured occurrences

This preference sets whether unconfigured occurrences are hidden or displayed by default. You can change this setting by choosing the View→Show Unconfigured By Occurrence Effectivity menu command.

- Preference name: PSEShowUnconfigdEffPref. Set to 0 for hidden or 1 for displayed.
- Default setting: 1

Setting the color of precise and imprecise assemblies

This preference determines the colors in which precise and imprecise assembly lines are displayed. By default, both preferences have site protection scope so they must be set by your administrator. There is no corresponding user option.

- Preference name: PSEPreciseColorPref. Set to the color value for the display of precise lines.
- Preference name: PSEImpreciseColorPref. Set to the color value for the display of imprecise lines, for example, #FFFFFF for white.

The default colors are green and gray, respectively.

Setting the visibility of information center elements

You can independently turn on or off the Where Used, Where Referenced, Child CountAccess, and State elements in the information center at the bottom right corner of the Structure Manager window.

To change the current settings, right-click in the information center. Teamcenter shows a dialog box containing a check box that allows you to show or hide each of the elements.

Configure the structure line title format

1. Add the structure (BOM) line title column to the list of displayed columns in Structure Manager, by choosing View→Properties and selecting it from the list of available columns.

   Initially, the BOM Line Title column displays the same information displayed in the Structure Manager tree (BOM Line).
Chapter 2  Configuring Structure Manager

2. Choose **Edit→Options**. Teamcenter displays the **Options** dialog box.

3. Click the **Product Structure** node in the **Options** tree. Teamcenter displays the options in the right pane of the window.

4. From the **BOM Line Title format for Items of type** list, choose the item type for which you are defining the structure (BOM) line title format.

5. Enter a combination of fixed text and other structure line properties in the text field, for example:

   $bl\_item\_item\_id, with name $bl\_item\_object\_name of type $bl\_item\_object\_type and find number $bl\_find\_no

   **Note** If you enter an invalid property name, for example, $my\_missing\_property, Teamcenter does not display an error; rather it displays the text without the dollar sign ($).

   The $string entries are structure line property names that act as substitution points when populating the cells in the Structure Manager columns. Property names are listed in the bom_attr.h file.

6. Click **OK**. Teamcenter closes the **Options** dialog box.

7. Refresh the Structure Manager window to apply the title format change.

**Setting administrative preferences**

Administrative preferences are set by your Teamcenter administrator on a site-wide or group-wide basis. Site preferences affect the appearance or functionality of Structure Manager for every user of the system; group preferences affect only users of the specified group.

For more information about setting preferences, see the *Preferences and Environment Variables Reference*.

**Setting the owning item display for option variant data**

Set this preference to display the owning item for options. It applies to any application where option names are displayed.

- Preference name: **PSE_show_option_item_prefix**. Set to 0 for hidden or 1 for displayed.
- Default setting: 1
Controlling users who can set effectivity

Use this preference to control the users who may set effectivity by adding the following rules in Access Manager at an appropriate place at the top level of the rule tree:

- Has Type (Release Status) → Create Effectivity Users
- Has Type (Effectivity) - Edit Effectivity Users

The release status rule controls who has write access to the release status and consequently can attach effectivity objects to it. This also determines who can initially create effectivity. Similarly, the effectivity rule controls who can edit an existing effectivity object.

For more information and examples, see the *Security Administration Guide*.

Setting publishing preferences

If you are managing CAD designs and linking them with parts in Teamcenter, the group administrator sets the following constant and preferences:

- **Mature Statuses** constant
  
  Determines the status that denotes the maturity level of a design revision. A design revision is a subtype of an item revision. Typically, when development of a design revision is complete, it becomes mature. Set this constant in the Business Modeler IDE.

- **PUBLISH_AlignableSourceTypes** preference
  
  Determines the types that can be used as the source of a publish link. A publish link connects occurrences and can be used to copy information from a source occurrence to a target occurrence. For example, it allows Teamcenter to copy transform data from a design occurrence to a part occurrence.

- **PUBLISH_AlignableTargetTypes** preference
  
  Determines the types that can be used as the target of a publish link.

Setting find number allocation

Use the **PS_new_seqno_mode** preference to determine how Teamcenter allocates new find numbers when items are inserted into a BOM view or BOM view revision. This preference has three possible settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Every item is given a new find number within the current BOM view, starting with 10 and increasing by increments of 10.</td>
</tr>
<tr>
<td>Existing</td>
<td>If an item with the same identifier already exists in the BOM view, Teamcenter assigns the inserted item the same find number. If not, the item is assigned a new find number according to the default sequence.</td>
</tr>
</tbody>
</table>
Setting the viewer memory allocation and Java heap size

The viewer memory allocation can affect the display of large product structures. If it is set too low, the Teamcenter session may be terminated when viewing a large structure. To set the viewer memory allocation, right-click in the viewer and choose Performance → Edit → Memory. If the memory allocation is exceeded, the viewer unloads parts to make room for new parts.

If you are visualizing large structures of 18,000 or more lines, increase the maximum Java heap size to 1,024 Mbytes.

For more information, see the Java documentation.
Chapter

3 Browsing product structure

Browsing product structure .................................................. 3-1
Viewing the structure .......................................................... 3-1
Viewing product structure properties ...................................... 3-4
  View properties of the product structure .............................. 3-4
Insert or remove a property column ....................................... 3-4
Setting find numbers ............................................................ 3-4
Open a structure ..................................................................... 3-5
  Managing multiple views .................................................... 3-7
  Display previously loaded product structure ......................... 3-7
Expanding or collapsing an assembly ....................................... 3-7
  Expand an assembly ........................................................... 3-7
  Collapse an assembly ......................................................... 3-8
  Unload lines ................................................................. 3-8
  Set or unset a closure rule ............................................... 3-8
Sorting the structure tree ....................................................... 3-10
Select structure lines ............................................................. 3-10
Packing or unpacking structure lines ...................................... 3-11
  Restrictions on packed lines ............................................. 3-11
  Pack structure lines ......................................................... 3-12
  Unpack structure lines .................................................... 3-12
  Pack all or unpack all lines .............................................. 3-12
  Packing or unpacking lines with reference designators .......... 3-12
Creating aggregate occurrences and defining quantity .............. 3-13
  Create an aggregate occurrence ....................................... 3-13
  Convert an aggregate occurrence to individual components .... 3-14
Finding a component by property ........................................... 3-14
  Find components by property ........................................... 3-14
Adding components using the guided component search .......... 3-15
  Display connection point information in the hierarchy tree .... 3-16
  Run the guided component search .................................... 3-16
  Removing a component .................................................... 3-17
Make product structure searches .................................................. 3-17
Create a structure report in Microsoft Excel ................................. 3-17
Printing Teamcenter objects in Teamcenter Rapid Start ................... 3-19
Printing structure information ...................................................... 3-21
Print structure information ......................................................... 3-21
Print property information .......................................................... 3-21
  Print object properties .............................................................. 3-21
  Print contents ........................................................................... 3-22
  Print application (HTML/text) information ................................. 3-22
  Print application (graphics) information ...................................... 3-23
Print table .................................................................................. 3-23
Viewing standard notes and custom notes ..................................... 3-23
  View note .................................................................................. 3-23
Opening a structure in NX or Teamcenter lifecycle visualization ....... 3-24
  Open a structure in NX ............................................................... 3-24
  Transfer configured structures to and from NX ......................... 3-24
    Push a variant structure from Structure Manager to NX .......... 3-24
    Pull a variant structure from NX to Structure Manager .......... 3-25
      Using the Assembly Navigator .............................................. 3-25
      Adding components in NX ................................................... 3-25
    Open a structure in Lifecycle Visualization ............................ 3-25
Interpreting transform data ........................................................... 3-26
Communicating with the owning user ............................................ 3-28
Viewing remote components ........................................................ 3-29
  Import remote components associated with stub references ....... 3-29
  Importing part families ............................................................ 3-29
    Synchronize assembly replicas .............................................. 3-30
Show connections ....................................................................... 3-34
View welds and datum points ....................................................... 3-34
Chapter

3 Browsing product structure

Browsing product structure

You can create a product structure by importing product data from NX or by building the structure manually, as described in Building and editing product structure. Before you begin to build the product structure, you must understand how to interpret the product structure display. You should know how to browse the product structure to see the structure of a product, navigate around the structure, and find components in the structure, as described next.

To find the top-level assembly or product structure line, you can use the Search pane to find it in the database. For details of how to make searches, see the Rich Client Interface Guide.

You can access the data associated with any point in the structure, for instance, the item revisions and datasets.

Caution Certain other applications including Manufacturing Process Planner and Multi-Structure Manager automatically save structures that you browse in Structure Manager. To avoid inconsistent data, Siemens PLM Software recommends that you close all other applications when you work in Structure Manager.

Note In earlier versions of Teamcenter, unattached BOM lines could be shown in the results of appearance searches. The visibility of unattached lines was determined by the APPR_no_unattached_line preference. From Teamcenter 10 onward, Structure Manager maps all BOM lines in the results to the correct BOM window, and no unattached lines are shown.

Viewing the structure

To display the components of a structure, expand the line corresponding to the structure in the structure tree. You can do this by double-clicking the node corresponding to the line, or by clicking the + (plus) sign.

The following figure shows a simplified product structure.
Simplified example of product structure

The structure is displayed in an indented format that indicates the relationship between its components.

- Each component (node) in the tree lists several properties which may include:
  - Item ID and name
    - Depending on your company’s data, an item may represent a part or assembly, a CAD design, or both. For example, 2212/B;1–R-Wheel in the example is an item.
  - Item revision
    - If no configured revision is found in a precise structure, Teamcenter displays ??? for the revision. If this is an assembly, it cannot be expanded.
  - Item type
  - Quantity
    - This is the total quantity represented by the line, which is greater than one if the line is packed or represents an aggregate occurrence. If any of the values are As Required, the quantity is shown as A/R.
  - View type for assemblies
  - Other properties configured for your site or you have added to the display.

For more information about adding properties, see Displaying properties.

- Assembly nodes have a + (plus) or – (minus) symbol:
  - + (plus) indicates the structure is not expanded.
    - Double-click the node, click the + symbol or choose View→Expand Below to expand the structure
  - – (minus) indicates the structure is expanded.
    - Double-click the node, click the – symbol or choose View→Collapse Below to collapse the structure.
  - Nodes with alternate components have a ⬤ symbol.

The structure is displayed in an indented format that indicates the relationship between its components.

- Each component (node) in the tree lists several properties which may include:
  - Item ID and name
    - Depending on your company’s data, an item may represent a part or assembly, a CAD design, or both. For example, 2212/B;1–R-Wheel in the example is an item.
  - Item revision
    - If no configured revision is found in a precise structure, Teamcenter displays ??? for the revision. If this is an assembly, it cannot be expanded.
  - Item type
  - Quantity
    - This is the total quantity represented by the line, which is greater than one if the line is packed or represents an aggregate occurrence. If any of the values are As Required, the quantity is shown as A/R.
  - View type for assemblies
  - Other properties configured for your site or you have added to the display.

For more information about adding properties, see Displaying properties.

- Assembly nodes have a + (plus) or – (minus) symbol:
  - + (plus) indicates the structure is not expanded.
    - Double-click the node, click the + symbol or choose View→Expand Below to expand the structure
  - – (minus) indicates the structure is expanded.
    - Double-click the node, click the – symbol or choose View→Collapse Below to collapse the structure.
  - Nodes with alternate components have a ⬤ symbol.

The structure is displayed in an indented format that indicates the relationship between its components.

- Each component (node) in the tree lists several properties which may include:
  - Item ID and name
    - Depending on your company’s data, an item may represent a part or assembly, a CAD design, or both. For example, 2212/B;1–R-Wheel in the example is an item.
  - Item revision
    - If no configured revision is found in a precise structure, Teamcenter displays ??? for the revision. If this is an assembly, it cannot be expanded.
  - Item type
  - Quantity
    - This is the total quantity represented by the line, which is greater than one if the line is packed or represents an aggregate occurrence. If any of the values are As Required, the quantity is shown as A/R.
  - View type for assemblies
  - Other properties configured for your site or you have added to the display.

For more information about adding properties, see Displaying properties.

- Assembly nodes have a + (plus) or – (minus) symbol:
  - + (plus) indicates the structure is not expanded.
    - Double-click the node, click the + symbol or choose View→Expand Below to expand the structure
  - – (minus) indicates the structure is expanded.
    - Double-click the node, click the – symbol or choose View→Collapse Below to collapse the structure.
  - Nodes with alternate components have a ⬤ symbol.
Nodes with substitute components have a 🔄 symbol.

Nodes that are variant components have a 🔐 symbol.

By default, the first level of the structure does not automatically expand when opened, as this may cause a performance problem with very large and very flat structures. To expand the structure automatically, your administrator sets the PSE\_expand\_on\_open preference to 1 or undefined.

If lower levels of the structure are initially hidden, the hidden lines are represented by a ... symbol and you can click this symbol to reveal them.

Teamcenter also colors certain lines in the product structure to indicate a particular status, as follows:

- Imprecise assemblies
  The structure line appears in gray.

- Precise assemblies
  The structure line appears in green.

- Substitute occurrence
  The structure line appears in blue.

- Added occurrence after structure comparison
  The structure line appears in red.

- Changed occurrence after structure comparison
  The structure line appears in orange.

**Note** All colors are defaults and may be changed by editing the relevant preference. For more information, see the Preferences and Environment Variables Reference.

You can attach datasets, documents or forms to a line in the structure. To view the contents of any attachment, select the line and click the Attachments pane. Attachments made in a specific context are visible only when you select the relevant absolute occurrence. You can use incremental changes to track edits to forms or documents.

The information center at the bottom right corner of the application window contains symbols that indicate Where Used, Where Referenced, Child Count, Object Access, and Object State. You can turn off these functions by right-clicking with the cursor over the information center. Turning off these functions improves display performance when expanding an assembly or selecting a line.

**Note** Once you have expanded the structure under the top line, you cannot set a new top line in the same window. Open the new top line in a separate window before expanding it.
Chapter 3  
*Browsing product structure*

Viewing product structure properties

A line in the product structure includes multiple properties, including:

- Item properties
- Item revision properties
- BOM view revision properties
- Occurrence properties
  - The use of an item revision in the context of its parent assembly.
- Display properties
  - Properties calculated to show the state of some other property.

View properties of the product structure

- Right-click a line to view its current properties. A full list of the available properties is described in Displaying properties.

Insert or remove a property column

You can add a new column to the structure tree from a list of Structure Manager properties:

1. Right-click any column header and Teamcenter displays a shortcut menu.

2. Choose Insert Column from the shortcut menu and Teamcenter displays the Change Columns dialog box.

3. In the Change Columns dialog box, highlight the required properties and click the Add button to transfer these properties to the right-hand pane.

   **Note**  The dialog box only shows columns that are not already included in the structure tree.

4. Click Apply to add these properties as new columns.

To remove a column, right-click on the column and choose Remove this column from the shortcut menu.

Setting find numbers

Teamcenter assigns a unique find number to each line in the product structure. They provide an additional identifier or label for organizing the items in a single-level structure relationship.

- When you add an item to the product structure, the line receives the next available find number in the defined sequence.
By default, the numbers are assigned in increments of 10 — that is, if the previous line added was assigned a find number of 20, Teamcenter assigns a find number of 30 to the next line added.

- Depending on your CAD environment, each find number may map to a callout number or a line number in the CAD design. If the find number is linked to the callout, changes of quantity made in the CAD design may directly update the quantity shown in the product structure.

- If appropriate, you can rearrange the structure in find numbers by clicking the Find Number column header. This rearrangement persists for future Structure Manager sessions, until you make another selection.

By default, when you pack the product structure, Teamcenter packs by find number, item ID, and variant condition. This allows you to pack two or more occurrences of the same item, if each occurrence has the same find number, item ID, and variant condition. To pack structure lines, they must all have the same occurrence effectivity object or objects; that is, they must have shared effectivity; it is not sufficient for the lines to only have the same effectivity ranges.

You can define if occurrences are packed on your workstation by changing the PSEAAutoPackPref preference. Your site may also customize Teamcenter behavior so that the structure is packed by criteria other than find number. For more information, see Pack structure lines.

Your Teamcenter administrator can configure find number processing.

- Change the way find numbers are assigned to BOM views and BOM view revisions by setting the PS_new_seqno_mode preference.

- Set the PS_Find_Number_Validation preference to allow Teamcenter to validate that find numbers are not zero and unique within the same parent.

- Disable updating of duplicate find numbers of the same item, by setting the PS_Duplicate_FindNo_Update preference to disabled.

Open a structure

You can open a structure by any of the following methods:

- **Click the Open by Name button**
  Use this method to open an existing structure.
  
  o Enter strings for the ID or the name of the items you want to open.
  
  o Double-click the item you want to open.

  **Note** If the item has several revisions, the window’s current revision rule determines the revision opened. If you want to open a specific revision, locate the revision in another application and open it by sending it to Structure Manager or by dragging-and-dropping.

- **Click the MRU (Most Recently Used) button**
Chapter 3  Browsing product structure

This button opens any of the last four top-level structures you opened. This list is saved across sessions, and is an easy way to reopen structures you were previously working on. Click the item revision you want to open.

**Note** You can configure the number of entries shown in the MRU list by right-clicking the button and moving the slider to the desired number.

- **Use the clipboard**
  This is useful for opening multiple structures from another application, for example, My Teamcenter, as follows:

  1. Copy the items or item revisions to the clipboard in the other application, then go to Structure Manager.
  
  2. Click the Clipboard button to display the copied objects and choose the items or item revisions you want to open in Structure Manager.
  
  3. Repeat the previous step as necessary. You can only open one item or item revision at a time.

- **Open from another application using the Send To command**
  This method is useful if you have a reference to the required top-level structure (which may be an item, item revision, BOM view or BOM view revision), in another application.

  1. Place the cursor over the object you want to open in the other application.
  
  2. Right-click the object to display the structure line shortcut menu and choose Send To.
     Teamcenter displays a list of the destination applications (for example, Multi-Structure Manager and My Teamcenter).
  
  3. Click the desired application.

  If the object is an item or BOM view, Teamcenter typically uses the default revision rule to determine the revision opened, as follows.

  - When you send a structure to Structure Manager from My Teamcenter, Teamcenter opens Structure Manager, loads the structure, and then applies the default revision rule.

  - If an empty Structure Manager window is already open, Teamcenter loads the structure into it, and then applies the default revision rule.

  - However, if a Structure Manager window is already open and contains a configured structure, Teamcenter loads the structure into it, and then applies the revision rule used to configure the previously-displayed structure.

- **Choose the File→Open command**
  This is useful for opening a new Structure Manager window on a subassembly. Select the line for which you want to open a new window and choose File→Open.

- **Drag and drop**
Drag the line representing the structure from another application such as My Teamcenter and drop it into the empty navigation tree pane.

- **Click a link**
  
  Click a link in the Open Items, History, or Favorites sections of the navigation pane.

If the current Structure Manager window already contains an opened structure, all of these methods create a new Structure Manager window.

To reduce the amount of time-consuming database interaction required to view a product structure, the components of an assembly are not loaded from the database until you expand the assembly. The first expansion may be slow, but subsequent expansion and contractions do not require data from the database and are therefore faster.

**Managing multiple views**

If multiple views exist and you do not select a specific view, Teamcenter determines the object to display according to the following rules:

- If the item revision has no BOM view revisions, it opens the object as a component.

- If the item revision has exactly one BOM view revision, it opens the BOM view revision.

- If the item revision has a BOM view revision of your default view type, it opens that BOM view revision.

If none of the rules match, Teamcenter uses the default view type.

**Display previously loaded product structure**

- Click the appropriate link in the History section of the navigation pane to redisplay a recently loaded structure.

**Expanding or collapsing an assembly**

When working on a structure, it may be convenient to load the entire assembly structure or a major section of it at the same time. Any further expansion or collapsing of the structure is faster, since this only requires a change to the display of the structure, not a full reload.

**Expand an assembly**

- Choose View—Expand Below... to expand all nodes below the currently selected node or nodes. Teamcenter displays the Expand to level dialog box, allowing you to enter the desired number of levels to which you want to expand the structure.

  The structure expands to the piece parts, where appropriate. Teamcenter loads any necessary components from the database.
Chapter 3  Browsing product structure

Note If you try to expand the structure by fewer levels than the existing expansion, the display does not change unless you select the **Collapse to level** check box in the dialog box.

If you try to expand a large assembly, Structure Manager displays an **Expanding the tree may take a long time. Do you want to continue?** message. Click **Yes** to continue with the expansion.

If expansion of selected BOM line types is restricted by a closure rule, Structure Manager displays a **Cannot expand BOM line** message.

For more information about restricting expansions with closure rules, see **Set or unset a closure rule**.

**Collapse an assembly**

Collapse an expanded assembly in one of two ways:

- Select the expanded node and choose **View→Collapse Below**.

Or

1. Select the expanded node and choose **View→Expand Below**. Teamcenter displays the **Expand to level** dialog box.

2. Enter the level to which you want to collapse the assembly, select the **Collapse lower level** check box and click **OK**.

   For example, if the assembly is expanded to five levels and you enter 3, Teamcenter collapses the assembly to three levels.

**Unload lines**

If you encounter memory problems when expanding a structure, you can unload selected lines to free memory manually.

1. Right-click the line below which you want to unload lines (for example, a subassembly) and choose **Unload Below**.

   Teamcenter displays the **Unload Below** dialog box.

2. Click **Yes** to continue.

   Teamcenter unloads all the lines below the current selection from the current session.

**Set or unset a closure rule**

You can limit the expansion of the structure using site-specific criteria to reduce potentially time-consuming expansions. For example, if a line has a monolithic JT file attached to it, you may not want to expand the subassembly below it. Similarly, you may not want to expand an assembly if it is not assigned to the current project. The site administrator specifies the available rules in the **ClosureRulesForBomExpansion** preference.

Select a closure rule before expanding the structure:

1. Choose **Tools→View/Set Closure Rule for Expansion**.
Teamcenter displays the View/Set Closure Rule for Expansion dialog box.

2. Select the required closure rule in the Rules list, and then enter any filter attributes necessary for the selected rule. In the example shown, you must specify at least one project identifier.

   Note In a conditional clause, evaluation of the left-hand expression must give primitive data types such as string or integer. If the related property is a typed reference, untyped reference, relation, or external references, the left-hand expression must evaluate to a primitive data type that uses the property of the object. You must use the property of the object, rather than the object itself. For example, instead of using PRIMARY.bl_uom==”kg” in a condition clause, you should traverse from BOMLine to UnitOfMeasure using bl_uom and then use a symbol property of UnitOfMeasure.

<table>
<thead>
<tr>
<th>Primary object class</th>
<th>Primary object class</th>
<th>Secondary object class</th>
<th>Relation type</th>
<th>Related property</th>
<th>Action type</th>
<th>Conditional clause</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLASS</td>
<td>BOMLine</td>
<td>CLASS</td>
<td></td>
<td>UnitOfMeasure</td>
<td>Property</td>
<td>secondary.symbol</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>bl_uom</td>
<td>Skip</td>
<td>==$var</td>
</tr>
</tbody>
</table>

   Note Line breaks are not supported in closure rules with variables.

3. After you enter the attributes, click OK to set the closure rule.

   Teamcenter applies the closure rule to all future structure expansions until you unset it or set another rule.

   Note You can set the SkipClosureRuleEquivalent user preference to determine whether the closure rule is re-evaluated if you reapply it in the same session and the referenced property has changed.

   To unset the closure rule, select it in the Rules list and then click Unset Rule.
You can see the name of the current closure rule in the title bar of the structure window. It is shown after the revision rule and variant rule names, if any. Unsetting the closure rule clears the closure rule name from the title bar.

If the action type in the closure rule is \texttt{SKIP}, lines meeting the criteria do not appear. If the action type is \texttt{PROCESS}, qualified lines appear but are not expanded (they show a \texttt{+} symbol). To expand such a line, unset the closure rule from the window and then repeat the expansion of the subassembly.

**Sorting the structure tree**

You can sort the product structure tree on the value of a column in the tree table, by clicking the header of the selected column. Teamcenter resorts each level of the table accorded to the values displayed in the selected column within an assembly level.

- The first time you click a column, the tree is sorted in ascending order; each subsequent time you click the column header, the tree table is re-sorted in descending, unsorted, and then ascending order.

- An arrow appears in the column header to indicate the column according to which the tree is sorted.

  The direction of the arrow indicates if it is sorted in ascending, descending or unsorted order.

Once you sort the tree according to a column value, it remains sorted, even if you add structure lines. If you paste a line into a sorted tree, the newly pasted line appears at its correct (sorted) location within the tree.

If the properties you want to sort by are not available, you can insert the necessary columns in the table. For example, you may want to sort by item master form attributes, item revision form attributes and mapped attributes for appearances. To add a column, right-click the column header, choose \textbf{Insert Column} and choose the appropriate property from the selection list.

**Select structure lines**

Use the \textbf{Edit}–\textbf{Select Below} menu command to make multiline selections in a structure. There are two types of multiline selections:

- **Lowest Lines**

  Use this option for:

  - Initial setup of one view from an existing view, for example, setting up a manufacturing view from the design view. This allows you to reference the same components but with different intermediate levels of structure.

  - Selective opening of assembly data in \textit{NX} by passing only the required component references.

  If you open a configured variant assembly in \textit{NX}, you open all of its components whether Teamcenter configures them or not. A \textbf{Lowest Lines}
selection allows you to configure the variants and hide unconfigured occurrences. You can then select the occurrences that remain configured and open them in NX.

**Note** The term *lowest level* corresponds with its usage in the Compare feature. As in structure comparison, your selection of **All Lines** or **Lowest Level** applies to the currently configured structure and expanded in the product structure window.

- **All Lines**
  Allows you to take a snapshot of the structure by copying references to each revision in that structure to an override folder. You can attach this folder to and release it with the top level assembly. You can use this folder as an override list to reload the exact configuration of all component revisions in the product when it was released.

  **Note** You can automate this functionality using the snapshots feature.

### Packing or unpacking structure lines

Grouping multiple identical components in one level of an assembly is known as **packing**. You can pack components if they satisfy all of the following requirements:

- They have the same item revision.
- They have the same find number.
- None have **variant conditions** or they all have the same variant condition.

For example, if a bicycle designer is working on a wheel hub design, it is time-consuming to negotiate 50 individual spokes within the wheel assembly, if each spoke is identical except for its position. All that is necessary is a **Spoke x 50** entry.

**Note** A customizer can use an ITK function to register a different algorithm for packing criteria. For information, see the *Server Customization Programmer’s Guide*.

### Restrictions on packed lines

The following restrictions apply to all lines in the structure that are packed:

- You cannot edit the **Quantity** value.
- If any of the packed lines have notes, the notes are replaced by the text **Packed Notes**. If none of the packed lines has notes, the notes are blank. In both cases, you cannot edit the notes.
- Item and item revision attributes such as part name, weight, and cost remain visible and can be edited if you have the appropriate permissions.
- You can modify the find number. Any such modification applies to each line in the structure and is visible if the structure is unpacked.
Chapter 3  Browsing product structure

- If any of the packed lines has a substitute, the packed line shows **Packed Substitute** in the **Substitute** column. The pack count includes the substitutes.

- Set the **BOMExcludeFromPackCheck** preference to exclude sequence numbers from structure line packing checks. You can set this preference to **seqno** and lines with distinct sequence numbers can be packed, or **none** to exclude them.

You can set the **Packed by Default** preferences so that occurrences are displayed packed when you initially expand the assembly (but not when they are first added).

For more information, see **Setting Local Preferences**.

**Pack structure lines**

To pack lines in the structure that meet the packing criteria, select any one of the lines and choose **Pack** in the **View** menu. Alternatively, you can click the **Pack** button in the toolbar.

In the case of the bicycle example, this action collapses the 50 lines in the product structure into one line representing all spokes and indicated by the 🚴 image. A **x 50** property is appended in the node of the single line and the **Quantity** box shows the value **50**. Teamcenter shows a **Y** character in the **Packed** column, if that column is displayed.

**Note**  Teamcenter makes no distinction made between the sum of a number of separate occurrences or an **aggregate occurrence** displayed in the **Node** column or the **Quantity** column. However, the **Pack Count** column shows the number of lines that have been packed.

**Unpack structure lines**

To unpack lines in the structure, right-click the single packed line and choose the **Unpack** menu command, or press the CTRL+N keys. The packed line separates into individual structure lines, each with its own set of attributes. You can edit these individual attributes.

By default, all components are initially packed to save space.

You can change this behavior by editing the **Pack by Default** preference, as described in **Setting your local user preferences**.

**Pack all or unpack all lines**

Choose **Pack All** or **Unpack All** from the **View** menu to pack or unpack all lines in the currently selected window, if the necessary packing conditions are met.

**Packing or unpacking lines with reference designators**

You can pack or unpack product structure lines that include reference designators. For example, if you pack eight occurrences of the same part with different reference designators, the **Ref Designator** property column shows a concatenated set of reference designators, for example, **C1, C5-7, C10, C14-16**. You cannot edit the reference designators of packed lines.
You can configure reference designator packing rules by setting the `BOM_Enable_Ref_Designator_Value_Packing` preference.

**Note** There are additional rules that determine general packing rules, as described previously. This preference only controls reference designator packing.

You can also unpack packed lines that include concatenated reference designators. Each unpacked line shows a single reference designator, for example, C1.

Teamcenter validates the correct reference designator format. All reference designators must be in the format `prefix number`, where `prefix` is a string of one or more uppercase letters and `number` is an integer. To validate the format and uniqueness of reference designators, set the `PS_Reference_Designator_Vaidation` preference to `on`. This setting also prevents users from editing packed lines. By default, this preference is set to `off` and no validation is performed.

You can search for reference designator values. As with other product structures searches, this is a wildcard search; if you search for C1, the system actually searches for *C1*. You can also include reference designators in structure comparisons.

You can disable updating of duplicate find numbers of the same item. To do this, set the `PS_Duplicate_FindNo_Update` preference to disabled.

The `BOMExcludeFromPackCheck` preference allows you to exclude sequence numbers from structure line packing checks. You can set this preference to `seqno` and structure lines with distinct sequence numbers can be packed or none to exclude them.

### Creating aggregate occurrences and defining quantity

Creating aggregate occurrence is a technique that allows you to define a single occurrence to represent a number of components, for example, 50 cable ties. Using aggregate occurrences reduces the amount of data stored in the database and the size of the displayed structure.

You can only create an aggregate occurrence from components with no units of measure and not from components that require a quantity value, for example, 1.5 liters of oil. Structure Manager does not differentiate between these component types and a numerical value is shown in the `Quantity` column in each case.

**Note** Aggregate occurrences cannot have separate attributes such as notes or positional information associated with any individual component. If this is necessary, use individual occurrences and pack the lines to simplify the display.

### Create an aggregate occurrence

Create an aggregate occurrence by entering a value for the `Quantity` attribute in one of the following ways:

- Edit the `Quantity Per Occurrence` box in the `Add or Paste` dialog box when you add the component.
- Edit the `Quantity` attribute in place. You cannot do this if the line in the structure is packed.
Chapter 3  Browsing product structure

• Edit the **Quantity** box in the **View Properties** dialog box.

  **Note** If you do not specify a quantity value, the occurrence represents a single component and the **Quantity** column is blank. By default, the **Quantity Per Occurrence** box is blank and this implies a value of 1.

**Convert an aggregate occurrence to individual components**

To convert from an aggregate occurrence to individual occurrences (for example, an aggregate occurrence of 100 bolts to 100 individual bolts), modify the **Quantity** value of the aggregate occurrence to 1. Then, copy the line and use the **Paste** command as necessary to create the remaining individual occurrences.

**Finding a component by property**

You can search the displayed product structure to find one or more specified components.

This capability is useful if you are not familiar with the structure and want to navigate quickly to a particular component. You can construct a search expression from any combination of the properties displayed in the columns in the product structure tree.

**Find components by property**

1. Expand the displayed structure fully for those assemblies you want to search. The search function does not find hidden components in unexpanded assemblies.

2. Click the **Find component(s) in display** button at the lower left of the Structure Manager window.

   Teamcenter displays the **Find in Display** dialog box.

   **Note** The search starts at the top-level item in the structure, not at the currently selected line. You do not select an assembly in which to look for the component. If you want to restrict the search to a particular assembly, open the subassembly in a new Structure Manager window by selecting it and choosing **File→Open**. Alternatively, you can collapse all other assemblies except the one you want to search.

3. Click ✡ to display an initial clause.

4. Double-click the **Property Name** text box to select a property from the list of available columns.

5. Double-click the = box to select a different operator.
**Tip** You can use the following relational operators to define property searches:

<table>
<thead>
<tr>
<th>Relational operator</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>= or ==</td>
<td>Equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>!=</td>
<td>Not equal to</td>
</tr>
<tr>
<td>-</td>
<td>Range</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>&quot;&quot;</td>
<td>Exact string</td>
</tr>
<tr>
<td>&amp;</td>
<td>AND</td>
</tr>
</tbody>
</table>

The operators <, <=, >, >= apply to numeric properties only.

6. Click the **Searching Value** text box and type the value you want to search for.

   **Note** Partial matches are selected for string properties. Wildcards are not supported, and the search is not case sensitive.

7. Add further clauses to the search condition by clicking again. You can also double-click **AND** to change it to **OR**.

8. If necessary, reorder clauses by clicking and .

9. When the search condition definition is complete, click **Find**. Teamcenter highlights the first line it finds that matches the search condition, and the **Find** dialog box shows a count of the total number of matching lines found.

10. Click **Find next one** and **Find previous one** to step through the matching lines one at a time. Alternatively, you can click **Load All** to select all matching lines at once.

### Adding components using the guided component search

Using a guided component search (GCS) accelerates the search for matching components within an assembly. This search allows you to choose from a list of only those classified workspace objects that fit into the selected components from which you are initiating the search. Whether a component fits into something else could be based on physical criteria or on other criteria that you decide (for example, Material A can only be used with Material B). To use this search, you must first configure it in the Classification Administration application.
For more information about configuring the guided component search, see the Classification Administration Guide.

The guided component search uses the following criteria to determine if a component matches another:

- If the connection type of each component is the same.

- If components fit into each other. All components in the GCS are assigned a physical shape—plug, socket, or neutral. For the search to find a match, the matching component must always have the opposite shape to the initial component. In other words, a plug component requires a socket component and vice versa, or a neutral component requires another neutral component.

- The attribute values of the components must fulfil the matching criteria set in the Classification Administration application.

Display connection point information in the hierarchy tree

Find the Show GCS Connection Points commands in the View menu or as buttons on the view toolbar.

- Choose one of the following:
  - Show All GCS Connection Points
  - Hide All GCS Connection Points

Run the guided component search

When running the guided component search, there are two types of search that you can use.

- You have a component and want to build onto this component in one direction only.

- You have a component with multiple connection points and want to fulfil these simultaneously.
  
  To perform this type of search, all connection points must have the same shape, same connection type, and same parent component.

1. Select the desired connection point of the component in the assembly structure for which you want to find a matching component.

2. Right-click and choose Guided Component Search, or click the Guided Component Search button on the toolbar.

   The system displays the Classification Search Dialog, but only with components containing connection points that match the connection point selected in the assembly structure. The displayed hierarchy contains only the classes and parent classes of these components.

3. Search the hierarchy and select the desired component.

   You can narrow the search by entering search criteria in the Search pane.

   The system adds the component to the structure.
For more information about searching, see the Resource Manager Guide.

Removing a component

When you remove a component that satisfies one more multiple connection points from a resource assembly using the Cut or Remove a line command, Teamcenter updates the previously satisfied connection points and removes the connection information from the connection points.

Make product structure searches

You can search the product structure as follows:

- You can search large products with a combination of spatial and attribute criteria. Teamcenter displays the results of the search in a dialog window and the embedded viewer.

  To initiate a spatial search, select the structure line to search from and click the Search button.

  Teamcenter displays the Spatial Search Criteria dialog box for you to define the search parameters. Alternatively, you can drag a search box of the appropriate dimensions on the embedded viewer.

  For more information, see Making spatial searches.

[Note] This method is sometimes referred to as cacheless search, because it is not necessary to maintain secondary data caches. However, if you used appearances or QPL cached searches in previous versions, you can still use these techniques instead of cacheless search.

- For smaller products, you can make nonspatial searches for components using item attributes, Classification parameters, reference designators, or occurrence notes.

  To initiate a nonspatial search, click the Search button.

  Teamcenter displays the Nonspatial Search Criteria dialog box for you to define the search parameters.

[Tip] If your site uses alternate IDs, you can search with them instead of item IDs or item revision IDs. To view the alternate IDs in the structure tree, add the bl_item_altid_list property, as described in Displaying properties.

Create a structure report in Microsoft Excel

To perform a simple, static export of the product structure and view the formatted results in Microsoft Excel, do the following:

1. Add a custom Excel template, as follows:
   a. Ensure you are logged on as infodba.
b. Create a new item of type ExcelTemplate in the Teamcenter administrator account’s (infodba) Home—Requirements Management Templates—ExcelTemplates folder.

c. Add the MSExcelX dataset underneath the ExcelTemplateRevision object.

Teamcenter uses the named reference of this dataset as your template for structure export.

Note Choose appropriate naming conventions for item, dataset, and named reference.

Bypass naming rules if required.

2. To include any custom form properties in the report, create a custom transfer mode and add it to the Excel template. The transfer mode comprises a custom closure rule and a custom property set.

   a. In the PLM XML/TC XML Export Import Administration application, create a custom closure rule to export the item revision master form. For example:

<table>
<thead>
<tr>
<th>Primary object class</th>
<th>Primary object</th>
<th>Secondary object class</th>
<th>Secondary object</th>
<th>Relation type</th>
<th>Related property or object</th>
<th>Action type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class</td>
<td>*</td>
<td>*</td>
<td>Item</td>
<td>PROPERTY</td>
<td>IMAN_master_form_rev</td>
<td>PROCESS +</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Version</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Master</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

   b. Create a custom property set that defines the custom form properties you want to export. The property set should contain a line similar to the following example for each custom property you want to export.

<table>
<thead>
<tr>
<th>Primary object class</th>
<th>Primary object</th>
<th>Relation type</th>
<th>Related property or object</th>
<th>Action type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class</td>
<td>Form</td>
<td>PROPERTY</td>
<td>custom_form_name</td>
<td>DO</td>
</tr>
</tbody>
</table>

3. Before configuring the Excel template, test the custom transfer mode works by performing a PLM XML export.

   a. In Structure Manager, select an item revision that includes your custom form properties.

   b. Choose Tools→Export→Object→PLMXML→your custom transfer mode.

   Teamcenter creates a PLM XML output file.

   c. Verify the output file holds the values of the custom properties.

4. Configure the Excel template by adding the necessary columns for the custom properties, logos, and hyperlinks. Refer to the sample files for examples.
5. By default, every level in the Excel template is displayed in a different row in the final result. To merge values for a single revision into one row, you must apply packing to the **Excel Template** item type.
   a. Check out the item.
   b. Select the **apply_packing** value for the **Excel Template Rules** property and modify it as necessary.
   c. Check in the item.

6. Perform the structure export by choosing **Tools→Export→Objects to Excel→Use Excel Template** and selecting your custom Excel template.

### Printing Teamcenter objects in Teamcenter Rapid Start

In Teamcenter Rapid Start, you can print the following object types:

- CAD drawings in a part, assembly, or folder
- Microsoft Office documents in a part, assembly, or folder

**Note** You can print .doc, .docx, .xls, .xlsx, .ppt, and .pptx files.

- Images in a part, assembly, or folder

Teamcenter Rapid Start also allows you to print a watermark on your output. A watermark is text or an image that appears in the background of each page of your printed document.

The following table describes the printing options and the expected output for each option based on the selected object type.

<table>
<thead>
<tr>
<th><strong>Selected object type</strong></th>
<th><strong>Print Button or right-click→Print</strong></th>
<th><strong>File→Print...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder with datasets, items, and/or item revisions</td>
<td>Sends the contents of the folder to the default printer.</td>
<td>Opens a print dialog window where you can select the desired printer and optionally specify a watermark. Once the options are selected, the contents of the folder are printed.</td>
</tr>
<tr>
<td>Item or item revision</td>
<td>Sends the contents of the item or item revision to the default printer.</td>
<td>Opens a print dialog window where you can select the desired printer and optionally specify a watermark. Once the options are selected, the contents of the folder are printed.</td>
</tr>
</tbody>
</table>
**How to print objects**

1. In Teamcenter Rapid Start, select the object or objects in the tree structure or Details table.

   **Note** To select multiple objects, press the Ctrl key as you click.

2. Perform one of the following:

   - To send the selected files to the printer without specifying print options, click the **Print** button in the toolbar or right-click and choose **Print** from the shortcut menu.

   - To specify print options and watermarks:
     
     a. Choose **File→Print...**

     b. Select **Client Printer** or **Server Printer** and then choose the printer name from the list.

     c. Optionally, to print a watermark on the documents, perform one of the following:

        o To print watermark text, select **Watermark Text** and then enter the text in the corresponding text field.

        o To print a watermark graphic, select **Watermark Path** and then click the **Browse** button to locate the graphic file you want to use as the watermark.

   **Note** To adjust the location of the watermark, you can edit the `TC_ROOT\tevis\VVCP\vvep.ini` file. In addition, you can optionally specify the path to an MDS (metadata stamping) file that contains predefined watermark text. You can use MDS stamp commands to change, customize, and improve file stamping. MDS stamp commands are preferences used to create more detailed stamps to apply to your files.

   d. Click **Print**.
Printing structure information

There are several options to extract printed or textual information from a structure including:

- **Print** allows you to print information about the structure below the currently selected line.
- **Print...** allows you to print object properties and application information.
- **Print Table** allows you to print product structure information in tabular format.

Print structure information

To print information about the structure below a line, select the line in the product structure tree and choose **File→Print**. Teamcenter opens the **Print** dialog box, showing how the output will be formatted. The structure below the selected line, if currently expanded, is shown and text information is obtained from the left-most (indented tree) column.

Select the appropriate box at the top right of the dialog box for HTML or text format.

Click the **Format** button at the top right of the dialog box to print or hide the title text and revision rule label.

Click **Print**. If you select text format, print output is sent to the default printer. If you select HTML format, the output is displayed in your default Web browser.

Alternatively, you can click **Save** to open a dialog box in which you can specify a directory and name for the output text or HTML file.

Print property information

To print property information, select a line in Structure Manager and choose **File→Print...**. Teamcenter opens the **Print...** dialog box with the following options:

- **Object Properties**
- **Contents**
- **Application (HTML/Text)**
- **Application (Graphics)**

Print object properties

Choose the **Object Properties** command and click **OK**. Teamcenter opens a dialog box containing the selected line’s properties and their values in tabular form. You can select HTML or text format.

If you select text format, click to specify a delimiter string to separate the property name and value. Select the **Column Alignment** check box to pad the text with spaces and line up the entries up in vertical columns.
You can also click Format at the top right of the dialog box to print or hide the title text.

Click Print. If you select text format, print output is sent to the default printer. If you select HTML format, the output is displayed in your default Web browser.

Alternatively, you can click Save to open a dialog box in which you can specify a directory and name for the output text or HTML file.

**Print contents**

- To print the contents of the structure, choose the Contents command and click OK. The print format is the same as obtained with the Print command.

**Print application (HTML/text) information**

To print application textual information, choose the Application (HTML/Text) command and click OK. Teamcenter displays a dialog box containing the entire contents of the Structure Manager window, as currently expanded. The data is displayed in tabular form and includes every displayed column. You can select HTML or Text format.

If you select text format, click Format and Teamcenter allows you to do the following:

- Specify Delimiter characters.

- Turn Column Alignment on or off. When it is turned on, each property value is padded with spaces. The output is formatted in columns whose width reflects that set for the corresponding columns in the structure tree.

- Turn Auto Indent on or off. When it is turned on, the printed format uses leading spaces to reproduce the indentation of successive levels of structure.

- Turn Show +/- on or off. When it is turned on, appropriate lines are prefixed with + and – characters to identify collapsed and expanded assemblies, respectively.

You can also click Format at the top right of the dialog box to turn on or off the title text.

Click Print. If you select text format, print output is sent to the default printer. If you select HTML format, the output is displayed in your default Web browser.

Alternatively, you can click Save to open a dialog box in which you can specify a directory and name for the output text or HTML file.

**Note** If you turn off Column Alignment, Auto Indent, and Show +/- and set the delimiter to a comma (,). Teamcenter generates a comma-separated output file that can be opened in a spreadsheet application.
Print application (graphics) information

To print application graphics information, click the Application (Graphics) command, then click OK. Teamcenter sends a graphical image of the structure as expanded in the current Structure Manager window to the default printer.

Print table

To print structure information in tabular format, right-click the column headings in the product structure display. Teamcenter displays a shortcut menu including a Print Table command and HTML/Text and Graphics commands. These menu commands provide an alternate to the Print application (HTML/text) information and Print application (graphics) information procedures, respectively.

Viewing standard notes and custom notes

Teamcenter allows you to attach notes to items or item revisions. These notes contain additional documentation about parts or documents. For example, a note may contain the following instructions:

Round all sharp corners to [Radius: 0.01, 0.02, 0.03] inch and heat-treat to [Temperature: 100, 120, 130] degrees Fahrenheit

The following types of note are available:

• Standard note
  Contains information established by a standards engineering organization. It conforms to the design practices of a program or project, is stored in a library, and is available to all participating engineers. A standard note is sometimes called a parametric requirement.

• Custom note
  Contains information that is unique to an individual part or document. It is not stored in a library. Create custom notes in the Business Modeler IDE, as described in the Business Modeler IDE Guide.

Note Do not confuse standard notes and custom notes attached to items or item revisions with occurrence notes.

For information about occurrence notes, see Displaying occurrence notes.

View note

1. Select a product structure line that represents an item or item revision.

2. Click the Show/Hide Data Panel button on the toolbar.
   Teamcenter displays the data pane.

3. On the data pane, click the Attachments tab.
   Teamcenter displays any standard notes or custom notes attached to the selected line, allowing you to view their content or properties.
For detailed information about how to manage standard notes and create and or custom notes, see Creating and editing notes.

Opening a structure in NX or Teamcenter lifecycle visualization

You can open the structure you have displayed in NX or Teamcenter lifecycle visualization.

Open a structure in NX

You can load the structure into NX to work on the design in one of two ways:

• Push the structure from Structure Manager into NX. You can load (push) as many structures as necessary from Structure Manager into a single existing NX session.

• Pull the structure into NX from Teamcenter.

Transfer configured structures to and from NX

You can configure a product structure with revision rules and variants, and then export the configured structure to NX in native format. To do this, select the top-level line of the assembly and choose the Tools→Export Configured NX Assembly menu command.

Teamcenter displays the Export Configured UGNX Assembly dialog box, which allows you to choose the export directory and the naming format.

Note This menu command is visible only if your administrator sets the TC_ExportConfigUGNXAssembly preference to TRUE and NX is installed on the client machine.

The administrator must also enable the NxClone translator, as described in the Dispatcher Server Translators Reference Guide.

You can also push or pull variant structures between Structure Manager and NX.

Push a variant structure from Structure Manager to NX

When a variant rule is in force, you may display a subset of the product structure in Structure Manager, for example, when the View→Show Unconfigured Variants option is set to off. To ensure you see only the configured components in NX:

1. Expand the whole structure in Structure Manager by choosing View→Expand Below.

2. Choose Edit→Select Below→Lowest Lines to select the lowest level of the structure.
Browsing product structure

**Note** If you select the top-level assembly and click **Open in NX**, all components are loaded, not just the configured ones. This applies to any assemblies lower down the structure that are not expanded.

By default, the **Open in NX** button and menu command are not visible in Structure Manager. Your administrator must set the **TC_show_open_in_NX_button** preference to on to make them visible.

3. In NX, click **Open** on the toolbar or choose **File→Open**. Browse to the required structure.

   The Assembly Navigator in NX displays all components in the assembly; unconfigured components are shown as not loaded. The Assembly Navigator cannot distinguish between unconfigured components and those that are manually loaded by pushing them from Structure Manager.

**Pull a variant structure from NX to Structure Manager**

NX can access variant rules saved in Teamcenter. In the **Load Options** dialog box, you can select a saved variant rule attached to the top-level item revision of the product structure. Once loaded, you can configure the structure by applying one or more saved variant rules using the **Assemblies→Variant Configurations...** menu command. (Unlike Teamcenter, NX can apply more than one variant rule to a structure.) If you do not apply a variant rule, all components are loaded into NX.

For additional information, see the Teamcenter Integration for NX documentation.

**Using the Assembly Navigator**

When variant rules are set in NX, the Assembly Navigator suppresses any unconfigured components, so they are not visible in the Assembly Navigator or other NX applications.

**Adding components in NX**

When variant rules are not set in NX, you can add components in NX by pasting it into the product structure; the component has no variant data and thus is always configured. You can later define a variant condition for the added components in Structure Manager. You cannot add components to a configured structure, you must first unset any variant rules applied.

**Open a structure in Lifecycle Visualization**

You can load the structure into Lifecycle Visualization to view the structure with the full Lifecycle Visualization functionality. You can also view the structure in the embedded viewer in the data pane.

When you load configured variant structures into Lifecycle Visualization, graphics (not parts) are displayed for the selected lines.

1. In Structure Manager, expand the whole structure by choosing **View→Expand Below**.

2. Choose **Edit→Select Below→Lowest Lines** to select the lowest level of the structure.
Interpreting product structure

If you select the top-level assembly and click **Open in Lifecycle Visualization**, the graphics of all components are loaded, not only the configured ones. This applies to any assemblies lower down the structure that are not expanded.

By default, the **Open in Lifecycle Visualization** button and menu command are not visible in Structure Manager. Your administrator must set the **TC_show_open_in_vmu_button** preference to **on** to make them visible.

3. Click **Open in Lifecycle Visualization** on the toolbar or choose **File→Open in Lifecycle Visualization**.

The Lifecycle Visualization application launches and displays the structure in a similar way to the Structure Manager structure view. Check boxes allow you to turn on and off the graphics display for individual lines.

For more information, see **Visualizing product structure**.

If you right-click a line that has a JT file attached to it and choose **Show JT Attributes**, Teamcenter displays the attributes of the JT file. You can display JT properties for an assembly or a component.

Interpreting transform data

Teamcenter uses occurrence transformation data to position components in an assembly. It creates transformation data for each component in an assembly. When a Teamcenter assembly is opened in an integrated CAD system, the CAD system interprets the transformation data to reconstruct the assembly.

Teamcenter stores transformations in a matrix in eXT format in the following format:

```
{ R00 R10 R20 P0 R01 R11 R21 P1 R02 R12 R22 P2 T0 T1 T2 S }
```

The components of this matrix are:

- A general rotation submatrix, comprising an x-axis (R00, R01, R02), a y-axis (R10, R11, R12), and a z-axis (R20, R21, R22).

- A general rotation submatrix, comprising an x-axis (R00, R01, R02), a y-axis (R10, R11, R12), and a z-axis (R20, R21, R22).

- A perspective (P0, P1, P2).

- A scaling factor (S).

**Note** Not all of these components are used by every external CAD system that stores data in Teamcenter. For example, NX only uses rigid body transforms and therefore does not use perspective. The three elements representing perspective are always set to 0.0 by Teamcenter Integration for NX. Also, Teamcenter Integration for NX always sets the scaling factor to 1.0. The transform values set by different external CAD systems are not compatible or interchangeable.

You can view and change the transformation associated with a component in the **Absolute Transformation Matrix** property columns, as described in **Displaying**.
In particular, you can add one or more of the following property columns to view transformations:

- **bl_plmxml_occ_xform**
  Shows the PLM XML transformation matrix value assigned to a part occurrence in the product structure.

- **bl_plmxml_abs_xform**
  Shows a run-time, rolled-up PLM XML transformation matrix value assigned to a part occurrence in the product structure. The rolled-up transformation value is calculated by adding the relative transformation matrices of all the occurrence parent parts in the product structure. This property can also override a transformation matrix value if you are making in-context edits.

- **bl_occ_xform_matrix**
  Shows the non-PLM XML transformation matrix value assigned to a part occurrence in the product structure.

- **bl_abs_xform_matrix**
  Shows a run-time, rolled-up non-PLM XML transformation matrix value assigned to a part occurrence in the product structure. The rolled-up transformation value is calculated by adding the relative transformation matrices of all the occurrence parent parts in the product structure. This property can also override a transformation matrix value if you are making in-context edits.

The following example shows a structure that has just relative transformation matrices assigned to it. Structure Manager fills the absolute transformation matrix fields when it rolls up the relative transformation matrices of the structure. In this example, 000010/A;1-n1 does not have a relative transformation matrix assigned to it. If Structure Manager encounters an unassigned matrix, it inserts an identity matrix in the **Absolute Transformation Matrix** column when rolling the matrix values.

![Example of product structure with relative transformation matrixes](image)

The following example shows a structure that has relative transformation matrixes assigned to it and also one absolute transformation matrix in the context of 000009/A;1-top. If appropriate, you can make in-context values to the absolute transformation matrix value. When you do this, a target symbol appears next to the transformation value in the **Absolute Transformation Matrix** column. In-context transformation values override the relative transformation values when Structure
Manager rolls up the transformation values in the **Absolute Transformation Matrix** column.

![Image of the Absolute Transformation Matrix](image)

**Example of product structure with relative and absolute transformation matrixes**

Teamcenter and Teamcenter Integration for NX transformation data is written in PLM XML format and uses meters as the unit of measure. In earlier Teamcenter products, transform data was written in millimeters and inches. Do not combine legacy and current transform measurements but update transform data using the Teamcenter Integration for NX **refile** utility.

Use the following preferences to configure how Teamcenter interprets legacy transformation data:

- **PS_allow_plmxml_transforms_with_no_legacy_factor**
  
  Configures whether Teamcenter converts legacy transform data.

- **PS_assume_old_transform_format**
  
  Determines how Teamcenter interprets the format of legacy transform data.

- **PS_assume_legacy_transform_units**
  
  Determines how Teamcenter interprets the unit of measure for legacy transform data.

- **PS_convert_legacy_transform_to_plmxml**
  
  Enables the display of legacy transforms in a PLM XML format.

**Communicating with the owning user**

If you work in a collaborative environment where several users own assemblies or components in a design, you may want to communicate with the user who owns a particular assembly or component. If the Microsoft Office Communicator integration is installed on your system, you can right-click the line that represents the assembly or component, and then choose **Send an Instant Message to Owning User**. Teamcenter displays a Communicator window, allowing you to begin an instant message conversation with the owner.
Viewing remote components

If you import assembly items to a remote site from the master Multi-Site Collaboration site, the component items of the assembly are not imported, only the BOM view revision. Consequently, when you load the BVR in Structure Manager, the components are not loaded because they are not available locally.

You can, however, view these items as assembly replicas containing remote components. Replicas and out-of-date replicas may be identified by site defined colors, for example, red for out-of-date replicas. The remote components are displayed as stub references in the structure lines of such unavailable remote components that are not available at the local site. If the owning user excludes certain objects from the replica of a remotely owned item, Teamcenter creates an augmented stub at the replica site. If you are authorized to view these stubbed objects, the augmented stub is visible with the ID, name, type, and description attributes shown.

When you open an assembly containing remote components, Structure Manager loads the assembly with the available components and shows the stub references for the structure lines of the remote components. If any of the remote components are not yet replicated locally, Structure Manager may prompt if you want to import these components or imports them without user intervention, depending on the setting of the PSE_prompt_for_remote_import preference.

**Note** These lines may represent remote part family members or other remote components. All remote components are displayed in the same manner.

Import remote components associated with stub references

- Choose Tools→Import Remote. Teamcenter obtains the data from either the Object Directory Services (ODS) or the owning site of the assembly.

Importing part families

In the case of part family member components, Teamcenter obtains the part family member replicas if the master part family members are not available. The part family member replica is imported from the master site of the assembly.

When importing remote part family members:

- If the Import Distributed Components option is not set and the master site of the assembly owns the part family members, the members are imported.

- If the Import Distributed Components option is not set and the master site of the assembly does not own the part family members, the members are imported. Teamcenter imports the part family replica and not the master copy. The master part family members must exist at the owning site.

- If the Import Distributed Components option is set and a site owns and contains the part family members locally, the members are imported. Teamcenter imports the master part family members present at the owning site.

- If the Import Distributed Components option is set and if the part family members do not exist locally at a site that owns them, the members are imported. Teamcenter imports the part family member replica and not the master copy.
Synchronize assembly replicas

You can request that Teamcenter compares the assembly replicas at your site with the remote sites owning them, allowing you to visually ascertain if your replicas match the masters at the remote sites and (if appropriate) demand synchronization. This process may take several minutes to complete, depending on the size of the assembly and the location of the master site.

To determine the need for synchronization, right-click a structure line, and choose one of the following commands:

- **Multi-Site Synchronization→Object**
  
  Choose this command to determine the synchronization state of a selected object, such as a dataset or form. You can also request synchronization of items or item revisions, but the synchronization state of any attached objects is not displayed. Teamcenter displays the synchronization status of the object, which may be one of the following values:

  - **Blank**
    
    The replica object is up-to-date.
  
  - **Up to date per hub**
    
    The replica is up to date according to hub data.
  
  - **Out of date**
    
    The last modified date of the master is later than the last modified date of the replica.

  - **Replica has later date**
    
    The last modified date of the object at your site is later than the last modified date of the object at the master. This occurs if you check out the object.
  
  - **Not configured revision**
    
    The configured revision of your replica is not configured at the owning site. For example, the latest revision is superseded at the owning site, but this is not replicated at your site.
  
  - **Unknown**
    
    The owning site is unavailable.

- **Multi-Site Synchronization→Component**
  
  Choose this command to determine the synchronization state of a selected component revision and all objects associated with it, including BVRs and attachments. This check identifies if the component has been replicated at your site and also if the replica is up-to-date. If the replica is outdated, you can request synchronization and visually verify if the synchronization process succeeded.

  Teamcenter displays the **Synchronization** dialog box, which allows you to set the following options to configure the synchronization process:

  - **Sync Options**
    
    Choose perform sync or perform sync in background to immediately initiate the synchronization process. Teamcenter sends a request to the site owning the selected component to determine the revision to synchronize, based on your revision rule selection. It determines the outdated objects and
initiates a remote import of modified versions, depending on your settings in the Import/Export Preferences dialog box.

**Note** Bulk data files are always included in the synchronization and the latest dataset version is imported.

Choose the **Report Only** option to display a results folder containing the component and associated objects. The properties of each object are shown from the viewpoint of your site. To ascertain the status of each object, view the **Sync State** box, which contains one of the following values:

- **Blank**
  The object is up-to-date.

- **Up to date per hub**
  The replica is up to date according to hub data.

- **Out of date**
  The last modified date of the master is later than the last modified date of the replica.

- **Replica has later date**
  The last modified date of the object at your site is later than the last modified date of the object at the master. This occurs if you check out the object.

- **Not replicated by local site**
  There is no replica of the object at your site.

- **No configured revision**
  The owning site has a different configured revision of the object to the revision at your site.

- **Not replicated**
  A new attachment is added at the owning site, but it is not replicated at your site.

- **Unknown**
  The owning site is unavailable.

You can synchronize a single object by selecting it in the report and choosing **Tools→Import→Remote**. Teamcenter displays the Import/Export dialog box, allowing you to set the parameters of the remote import action. When synchronization is complete, Teamcenter refreshes the report with the latest status.

**Revision Rule**

Select the required revision rule from the list of revision rules available at your site. If you select an item revision, the list displays **Selected Revision** and the configured item revision is synchronized; you cannot set another revision rule.

**Note** Your administrator can set the **TC-sync_revision_rules** preference to permit you to select only certain revision rules, not all rules available at the site.
Chapter 3  

**Browsing product structure**

- **Session Options**
  Choose **Generate Failure Report** to write a failures report if you choose the **Perform Sync** or **Perform Sync In Background** option. This option is disabled if you choose the **Report-Only** synchronization option.

- **General Workspace Object Options**
  Choose **Exclude Folder Contents** and **Exclude Export Protected Objects** to exclude these objects from the synchronization process.

- **Save Options as Default**
  Choose this option to save the selected options as your default for subsequent synchronization or remote import actions.

- **Advanced – Relations to Include and Exclude**
  Choose this option to include and exclude certain object relations from the synchronization process.

- **Multi-Site Synchronization → Assembly**
  Choose this command to determine the synchronization state of an entire assembly. If it is outdated, you can request synchronization of individual components or the entire assembly, and visually verify if the synchronization process succeeded. This check identifies if the component has been replicated at your site and also if the replica is up-to-date.

  Teamcenter displays the **Synchronization** dialog box, which allows you to set the following options to configure the synchronization process.

- **Sync Options**
  Choose **Perform Sync** or **Perform Sync In Background** to immediately initiate the synchronization process. Teamcenter sends a request to the site owning the selected assembly to determine the revision to synchronize, based on your revision rule selection. It determines the outdated objects and initiates a remote import of modified versions, depending on your settings in the **Import/Export Preferences** dialog box.

  **Note**  
  Bulk data files are always included in the synchronization and the latest dataset version is imported.

Choose the **Report Only** option to display a results folder containing the assembly expanded to the maximum level. The report shows components up to the highest level that is outdated within a branch. Consequently, branches may be expanded to different levels. To determine this status, Teamcenter compares the dates of the last modification of the master and the replica.

To ascertain the status of each component, view the **Sync State** box, which contains one of the following values:

- **Blank**
  The component is up-to-date.

- **Up to date per hub**
  The replica is up to date according to hub data.
- **Out of date**
  The last modified date of the master is later than the last modified date of the replica.

- **Replica has later date**
  The last modified date of the component at your site is later than the last modified date of the component at the master. This occurs if you check out the component.

- **Not replicated by local site**
  There is no replica of the component at your site.

- **No configured revision**
  The owning site has a different configured revision of the component to the revision at your site.

- **Not replicated**
  A new attachment is added at the owning site, but it is not replicated at your site.

- **Unknown.** The owning site is unavailable.

You can synchronize an assembly or a single component by selecting it in the report and choosing **Tools→Import→Remote**. Teamcenter displays the **Import/Export** dialog box, allowing you to set the parameters of the remote import action. When synchronization is complete, Teamcenter refreshes the report with the latest status.

1. **Revision Rule**

   Select the required revision rule from the list of revision rules available at your site. If you select an item revision, the list displays **Selected Revision** and the configured item revision is synchronized; you cannot set another revision rule.

   **Note** Your administrator can set the **TC_sync_revision_rules** preference to permit you to select only certain revision rules, not all rules available at the site.

2. **Session Options**

   Choose **Generate Failure Report** to write a failures report if you choose the **Perform Sync** or **Perform Sync In Background** option. This option is disabled if you choose the **Report-Only** synchronization option.

3. **General Workspace Object Options**

   Choose **Exclude Folder Contents** and **Exclude Export Protected Objects** to exclude these objects from the synchronization process.

4. **Assembly Options**

   By default, the **Include Entire BOM** option is automatically chosen. If you only want to synchronize some of the structure to reduce synchronization time, uncheck this option.

   Choose a value in the **Maximum Level** list that represents the maximum depth in the assembly that Teamcenter traverses when you choose the
Chapter 3  
*Browsing product structure*

**Report Only** option. If blank, Teamcenter traverses the entire assembly until it detects an outdated component or leaf node. If set to 1, Teamcenter synchronizes only the selected item revision.

- **Save Options as Default**
  Choose this option to save the selected options as your default for subsequent synchronization or remote import actions.

- **Advanced – Relations to Include and Exclude**
  Choose this option to include and exclude certain object relations from the synchronization process.

**Show connections**

You can display the objects connected by the **Connected To** relationship to:

- View the names of the connected objects directly from the structure line.
- Display the absolute path name for the connected objects.
- Display the objects connected to a given connection.

View the objects connected by a given connection in one of the following ways:

- Select and right-click the connection and Teamcenter displays a shortcut menu. Choose the **Show Connected Lines** menu command to highlight the connected objects.
- Select the connection and choose **View→Show Connected Lines** to highlight the connected objects.
- Select the connection and click the ▶ button to highlight the connected objects.

**View welds and datum points**

If your NX design includes welds or datum points, they are exported to Teamcenter if you export the design through Teamcenter Integration for NX.

Structure Manager shows welds and datum points as child lines within the product structure, one line for each weld or datum point. The child lines are grouped under the parent line that represents the part or assembly with which the weld or datum point is associated.

If a JT file is attached to the child line, you see the welds and datum points in Teamcenter lifecycle visualization or the embedded viewer as follows:

- Welds are displayed with an appropriate representation depending on their type.
- Datum points are displayed as spheres.

Use the **Attachments** tab in Structure Manager to view the feature form that lists the attributes of welds or datum points.
Chapter 4

Building and editing product structure

Building and editing product structure ........................................ 4-1

Cloning a structure .............................................................. 4-1
  Clone (duplicate) a structure ............................................. 4-2

Create an item from a template ............................................. 4-4

Creating a new BOM view revision ...................................... 4-5
  Create a new BOM view revision automatically ................. 4-5
  Create a new BOM view revision manually ...................... 4-5
  Setting the view type .................................................... 4-5

Using Save As to save a BOM view revision ....................... 4-6
  Create a new BOM view revision from an existing BOM view revision . 4-6

Saving and refreshing the product structure .................... 4-7
  Save changes in Structure Manager ................................. 4-7
    Saving changes with multiple windows ....................... 4-7
  Close the product structure window ............................ 4-8
  Refresh the Structure Manager window and resynchronize to database 4-8

Adding components to the product structure .................. 4-8
  Copying and pasting objects ........................................ 4-9
    Copy and paste an item or item revision ................... 4-10
    Copy and paste using the structure line shortcut menu 4-10
    Copying and pasting occurrence attributes of components 4-11
  Use quick add ......................................................... 4-11
  Add a component to an assembly .................................... 4-11
  Paste a component ................................................... 4-13
  Copy multiple views ................................................ 4-13
  Create a new item or item revisions ............................. 4-13

Restructuring and editing the product structure ............. 4-14
  Insert a level in the structure .................................... 4-16
  Remove a level from the structure ................................ 4-17
  Move a node to another branch ................................... 4-17
  Replace a node ....................................................... 4-19
  Split an occurrence ................................................ 4-20
  Fixing in-structure associations .................................. 4-21
    Fix in-structure associations .................................. 4-21
Performing on-demand validation ........................................ 4-21

Highlighting edits to the structure ........................................ 4-22

Marking up the product structure .......................................... 4-24
  Enable markup mode ........................................................ 4-25
  Create and insert general markup ...................................... 4-26
  Display markup properties ................................................. 4-26
  Review and comment on markup ...................................... 4-27
  Validate access to apply markup ...................................... 4-27
  Apply markup .................................................................... 4-27
  Apply all markups ................................................................ 4-28
  Carrying forward markups .................................................. 4-29
  Delete markup .................................................................... 4-29
  Creating markup review sample workflows ........................... 4-29
    Sample 1 ....................................................................... 4-31
    Sample 2 ....................................................................... 4-31
    Sample 3 ....................................................................... 4-32
    Sample 4 ....................................................................... 4-33
      BOMMarkup_Review process .......................................... 4-34
      BOMMarkup_SplitTargets process .................................... 4-35
      BOMMarkup_AddStatus process ...................................... 4-40

Defining units of measure ...................................................... 4-49
  Define unit of measure ........................................................ 4-49

Managing global alternates .................................................... 4-50
  List global alternates .......................................................... 4-51
  Add global alternates ........................................................... 4-51
  Remove global alternates ..................................................... 4-52
  Set or unset preferred global alternate ................................. 4-52

Changing components .......................................................... 4-52
  Remove components ............................................................. 4-53
  Move a component to another assembly ................................ 4-53
  Replacing a component ........................................................ 4-53
    Replace a component ....................................................... 4-54
  Change add and delete operations to a replace operation ....... 4-55

Defining substitute components ............................................. 4-55
  Display substitute components for a line ............................. 4-56
  Display substitutes as separate lines .................................... 4-57
  Create substitute component .............................................. 4-57
  Edit the properties of a substitute ...................................... 4-57
  Compare substitutes ............................................................ 4-57
  Removing substitute components ........................................ 4-58
    Remove a substitute component ....................................... 4-58
  Change the preferred substitute ........................................... 4-59

Managing substitute part relationships .................................... 4-59
  Relating substitute parts ..................................................... 4-59
  Relate substitute parts ........................................................ 4-59
  Relate substitutes with existing substitutes ......................... 4-60
  Edit a substitute part relationship ....................................... 4-60
  View the related substitutes of a selected structure line ....... 4-61
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exporting substitute data</td>
<td>4-61</td>
</tr>
<tr>
<td>Add or remove optional parts</td>
<td>4-61</td>
</tr>
<tr>
<td>Exporting a product structure containing related parts</td>
<td>4-61</td>
</tr>
<tr>
<td>Export a product structure to Briefcase</td>
<td>4-61</td>
</tr>
<tr>
<td>Export datasets with structure information</td>
<td>4-62</td>
</tr>
<tr>
<td>Add parts to NX</td>
<td>4-64</td>
</tr>
<tr>
<td>Using item elements</td>
<td>4-65</td>
</tr>
<tr>
<td>Create an item element</td>
<td>4-66</td>
</tr>
<tr>
<td>Remove item elements</td>
<td>4-66</td>
</tr>
<tr>
<td>Copy and paste item elements</td>
<td>4-66</td>
</tr>
<tr>
<td>Replace item elements</td>
<td>4-66</td>
</tr>
<tr>
<td>View notes on item elements</td>
<td>4-67</td>
</tr>
<tr>
<td>Creating connections and links</td>
<td>4-67</td>
</tr>
<tr>
<td>Create a connection</td>
<td>4-67</td>
</tr>
<tr>
<td>Create a link</td>
<td>4-67</td>
</tr>
<tr>
<td>Remove a connection or link</td>
<td>4-67</td>
</tr>
<tr>
<td>Creating and editing notes</td>
<td>4-68</td>
</tr>
<tr>
<td>Define or edit custom note text</td>
<td>4-68</td>
</tr>
<tr>
<td>Deleting items</td>
<td>4-69</td>
</tr>
<tr>
<td>Delete a single item from the product structure</td>
<td>4-69</td>
</tr>
<tr>
<td>Delete multiple assemblies or items</td>
<td>4-69</td>
</tr>
<tr>
<td>Grading structures</td>
<td>4-70</td>
</tr>
<tr>
<td>Run grading</td>
<td>4-71</td>
</tr>
<tr>
<td>View grading results</td>
<td>4-71</td>
</tr>
<tr>
<td>Override grading results</td>
<td>4-73</td>
</tr>
<tr>
<td>Grading for substance compliance</td>
<td>4-74</td>
</tr>
<tr>
<td>Initiate compliance check</td>
<td>4-74</td>
</tr>
<tr>
<td>Apply exemption from regulation</td>
<td>4-74</td>
</tr>
<tr>
<td>View material and substance dashboard</td>
<td>4-74</td>
</tr>
<tr>
<td>View compliance dashboard</td>
<td>4-74</td>
</tr>
<tr>
<td>Request substance declaration from vendor</td>
<td>4-75</td>
</tr>
<tr>
<td>Save structure change records</td>
<td>4-75</td>
</tr>
<tr>
<td>Link requirements</td>
<td>4-75</td>
</tr>
<tr>
<td>Create trace links</td>
<td>4-76</td>
</tr>
<tr>
<td>Generate a traceability report</td>
<td>4-76</td>
</tr>
<tr>
<td>Export a traceability report to Microsoft Office Excel</td>
<td>4-77</td>
</tr>
<tr>
<td>Delete trace links</td>
<td>4-78</td>
</tr>
<tr>
<td>Creating trace links to absolute occurrences</td>
<td>4-79</td>
</tr>
<tr>
<td>Create trace links on absolute occurrences</td>
<td>4-79</td>
</tr>
<tr>
<td>Searching the data dictionary</td>
<td>4-80</td>
</tr>
<tr>
<td>Open the Data Dictionary Search Dialog</td>
<td>4-81</td>
</tr>
</tbody>
</table>
Find a library object ................................................. 4-81
Searching the class hierarchy ........................................ 4-82
  Search by object ID .............................................. 4-82
  Search by type .................................................... 4-83
  Selecting a class ................................................ 4-85
    Use the quick search feature .................................. 4-85
    Use the Search Class dialog box ......................... 4-85
  Search all objects in a selected class ................... 4-86
  Search for library objects by attribute value ........... 4-88
  Configuring revision rules for searching ............. 4-90
    Apply a revision rule ....................................... 4-90
    Using relational operators ................................ 4-91
    Using wildcard characters ................................ 4-92
Navigating the matches ............................................ 4-92
  View search results in the Properties pane ............. 4-92
  View search results in the Table pane .................... 4-93
  View search results in the Viewer pane ................... 4-93
Select the desired library objects ......................... 4-94

Releasing structures ............................................. 4-94
  Release a structure ......................................... 4-95

BOM session recovery ............................................. 4-97
Chapter

4  Building and editing product structure

Building and editing product structure

You can create the product structure manually in Teamcenter, you can import it from your CAD system, or you can clone an existing structure to use as the basis of a new structure. When you import a structure, Teamcenter keeps the structure synchronized with any changes to the native CAD design. After you create the structure, you modify it as necessary to reflect any changes to the product design.

Caution  Certain other applications including Manufacturing Process Planner and Multi-Structure Manager automatically save structures that you edit in Structure Manager. To avoid inconsistent data, Siemens PLM Software recommends that you close all other applications when you work in Structure Manager.

You check out an item revision to make changes and check it in again when the changes are complete. You may also cancel the checkout of an item revision, even if it is open in a structure editor. This action causes the changes made to the item revision and to its first-level structure to be lost. If the item revision is open in a structure editor window, you must refresh the full window refresh to restore absolute occurrence data for any lines edited in context of the item revision.

Caution  Siemens PLM Software recommends you do not use the Cancel Checkout command on item revisions that contain changes tracked by incremental change. This action causes permanent loss of incremental changes that are tracking structure edits.

Cloning a structure

You can clone (duplicate) an existing product structure to create a new structure.

You can clone the entire product structure from the top level down or a selected subassembly. It is not necessary to open the CAD tool when creating the new (cloned) assembly.

The cloning operation uses Business Modeler IDE deep copy rules to determine how datasets and attachments are copied. It also uses the Business Modeler IDE StructureCloneTransferModes global constant to determine how CAD-specific attachments and relationships are copied.

When you open the new (cloned) structure, you can edit or update any of the items, item revisions, datasets, and attachments without affecting the original structure.
The cloning process does not support occurrence effectivity and any configuration of the structure with occurrence effectivity does not carry forward to the clone.

The user who performs the cloning action owns the copy. Any elements of the original structure that were referenced, rather than copied, remained owned by their original owner. Access rights and ACL rules on structure lines are not carried forward from the original structure to the new (cloned) structure.

If you do not have access rights to a substructure in the original structure, you cannot duplicate that substructure and Teamcenter instead references the existing substructure.

If the original structure was shared by Multi-Site Collaboration, the new (cloned) structure does not inherit its permissions. It is a new structure and is therefore owned by the site where it was created.

**Clone (duplicate) a structure**

1. If you are using a CAD tool, verify that your administrator has set the `StructureCloneTransferModes` global constant to the name of the transfer mode for your CAD integration, as described in the *Business Modeler IDE Guide*.

2. Open the structure in Structure Manager and configure it as appropriate. Cloning a precise structure creates a precise copy; likewise, cloning an imprecise structure creates an imprecise copy.

3. Select the top line of the structure or a subassembly in the structure. The selected line and everything below it will be copied into the new (cloned) structure.

4. Choose *File*→*Duplicate*.

   Structure Manager displays the *Duplicate* dialog box. You can use the + and - buttons to expand or collapse the structure tree that is displayed in the dialog box.

5. Select or clear the check box at the left-hand end of each line in the structure to copy or reference that line in the new (cloned) structure.

6. Select one or more of the check boxes on the left-hand side of the *Duplicate* dialog box to determine how the clone should be created:

   **Display** check boxes

   - **Drawings From All Revisions**  
     If selected, all item revisions with drawings that are related to the structure are shown. Drawings under the same item revision as their solid models are implicitly included, and are not displayed again in the dialog box.

   - **Required Dependencies**  
     If selected, only the item revisions necessary to open the structure or assembly in the CAD tool are shown.

   - **All Dependencies**  
     If selected, all related item revisions are shown.
Part Families check boxes

**Masters**
If selected, part family masters defined in Classification are shown. If an original item revision is a part family master, the cloned item revision is also a part family master.

**Members**
If selected, part family members defined in Classification are shown. If an original item revision is a part family member that is selected for cloning, the cloned item revision is also a part family member.

Click the **Update Display** button to refresh the structure display if you change these check boxes.

**Rename CAD Files** check box

If checked, the CAD integration renames all CAD files when you open the clone in the CAD tool. If you choose to rename CAD files, a deep clone is created, that is, all CAD datasets and their named references are copied.

**New Item ID by Selection** check boxes

Click the **Apply** button to update the structure display if you change the default mapping.

**Assign New IDs**
If selected, you can specify the naming pattern of duplicated items that are included in the clone. The new identifiers are not applied until you create the clone.

**Prefix**
Allows you to define a prefix to the original name of each duplicated item that is included in the clone, for example, **NEW**.

**Suffix**
Allows you to define a suffix after the original name of each duplicated item that is included in the clone.

**Replace**
Allows you to replace a specified substring in the original item name with another defined string in the duplicated item name.

**Naming** check boxes

Click the **Apply** button to update the structure display if you change the default mapping.

**Assign New IDs**
If selected, you can modify the naming pattern of original items before they are included in the clone.

**Prefix**
Allows you to define a prefix for the original item name before it is included in the clone.
Chapter 4  Building and editing product structure

<table>
<thead>
<tr>
<th>Suffix</th>
<th>Allows you to define a suffix after the original item name before it is included in the clone.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace With</td>
<td>Allows you to replace a specified substring in the original item name with another defined string before the clone is created.</td>
</tr>
</tbody>
</table>

**Note** If you try to define a naming pattern that does not conform with the naming rules defined in Business Modeler IDE, Teamcenter displays an error message.

7. Click **OK** to create the clone structure.

   Structure Manager displays the **Duplicate Results** dialog box and saves the top item of the new (cloned) structure to the clipboard and copies it to the **NewStuff** folder when it is complete. The dialog box also states if Teamcenter could not duplicate any items in the original structure, it referenced them instead.

Create an item from a template

Over time, you may design standard products or generic structures that can be reused in similar products. Using templates provides a way to reuse these standard designs as you create new structures for similar products. A template may be created from an actual in-use product, or you may create a generic structure explicitly for use as a template.

1. Ensure that the necessary **Product.Template** preferences are defined, as described in the **Preferences and Environment Variables Reference**. These preferences contain the rules that determine how the related objects in the template are mapped to the objects in the new item—each object may be cloned (copied), referenced, or ignored. Items created from a template are typically product or subassembly structures.

2. Choose **File→New→Item from Template**. It is not necessary to load a structure or template into the current window.

   Teamcenter displays the **New Item** dialog box.

3. To create the new item from a template, click the **Choose Template** tab, enter the name of the structure top line to clone in the **Template ID** box. Alternatively, you can browse to the template structure you require or to another product structure to clone.

   In the lower pane of the tab, Teamcenter populates the item identifier, revision and name of the new item. The item identifier is assigned sequentially and you cannot change the displayed value.

4. Click the **Configuration** tab and select the cloning rule to apply from the **Cloning Rule** list. If required, you can also change the revision rule on this tab.

5. Click **OK** or **Apply** to create the new product from the template you choose. The new top level is not loaded into the window and, if you want to verify that it was created correctly, you must search for it.
Creating a new BOM view revision

When you add a component to an assembly, you are creating an occurrence of that item or item revision in the assembly, which is stored on the BOM view revision (BVR). This occurrence is displayed as a BOM line. A BVR is a single-level structure that contains occurrences of its immediate children. A multilevel structure is built up from many single line BVRs.

Any modification to a product structure (including changing any of the occurrence attributes or adding a substitute) causes a change to the BVR of the parent assembly. If no BVR exists in the parent assembly, Teamcenter creates one automatically. When BVRs are automatically created in this way, they may be precise or imprecise according to your specified options; by default, imprecise BVRs are created.

You can also create a new BOM view revision manually.

Create a new BOM view revision automatically

If there is no BOM view revision in an assembly item revision when you add the first component, Teamcenter automatically creates one. It sets the precision (precise/imprecise) of the BOM view revision as follows:

- If the item revision is a component, the precision is that of the parent assembly in the current window.

- If the item revision is at the top-level of the structure, the precision is set according to your default BOM view precision option.

Create a new BOM view revision manually

When required, Teamcenter automatically creates BOM view revisions. You can also create BOM view revisions manually with Structure Manager or My Teamcenter (which allows you to set the view type). To create a new BOM view revision, you must have write access to the original BOM view.

- To create a BOM view revision and associate it with the selected item revision, choose File→New→BOMView (Revision). You cannot edit the item identifier and item revision of the owning item; you can only confirm the correct item revision is selected.

Setting the view type

When creating a new BOM view revision manually, you specify a view type that is not already created for the item. You select the view type from a list of values defined by the Teamcenter administrator in the Business Modeler IDE, as described in the Business Modeler IDE Guide.

Teamcenter attempts to provide an appropriate default view type, according to the following rules:

- If there is only a single view type defined for your site, it uses the defined view type.

- If there is only one view type not used by the existing BOM view revisions of the item revision, it uses the undefined view type.
If your default view type is not used by the existing BOM view revisions of the item revision, it uses your default view type.

If Teamcenter cannot determine the view type, you must enter a value manually.

**Note** If the new structure is similar to an existing one, consider choosing the **Save As→BOM View Revision** menu command to make a copy of the BOM view revision and edit the copy structure.

When you save a structure with a different name using the **Save As** command, the workspace objects it comprises are renamed, including the item identifier, the revision identifier, and any variant rule.

**Note** Teamcenter derives the names of BOM views and BOM view revisions from the identifiers of the owning item or item revision with the view type appending.

### Using Save As to save a BOM view revision

In most cases, you do not explicitly save a BOM view with the **Save As** command because Teamcenter automatically copies the BOM view revision whenever you choose the **Save As** command for an item revision. However, you may sometimes want to save the BOM view with a different type, for example, if you create a BOM view revision of another view type or copy a structure to another item.

When you save a structure with the **Save As** command, the workspace objects it comprises are renamed, including the item identifier, the revision identifier, and any variant rule.

If you select an item revision with multiple views (rather than a BOM view revision) and choose this command, Teamcenter makes a copy of each view type.

### Create a new BOM view revision from an existing BOM view revision

1. Select the line containing the BOM view revision in the product structure tree.

2. Choose **File→Save As→BOM View Revision**.

   Teamcenter displays the **Save BOM View Revision As** dialog box.

3. Specify a view type that is not already been created for the item. You select the view type from a list of values defined by the administrator.

   The precision of the BOM view revision is the same as the BOM view revision you copied. If you want to change the precision, choose **Edit→Toggle Precise/Imprecise**.

To add a similar structure to another item revision, choose the **File→Save As→BOM View Revision** menu command to create a new BOM view revision in a different item. Specify the target item identifier and revision in the **Item** and **Revision** boxes of the dialog box. This action copies the occurrence attributes, including the find number, notes, quantity, substitutes, and variant conditions into the new BOM view revision.

**Note** Variant conditions are copied if you use modular variants but not if you use classic variants.
Saving and refreshing the product structure

You must explicitly save any changes you make to the product structure because Structure Manager does not save them automatically. For example, you must explicitly save any new BOM lines or variants. If you try to exit from Structure Manager and there are unsaved changes, the system prompts you to save them. If you have more than one window open, you must save changes in each window.

If there are unsaved changes, the title pane of the Structure Manager window and the tooltip for any open pane are shown in bold with an asterisk * appended to the name. When you save the changes, the bold highlight and the asterisk are removed. The titles of windows with no changes are always shown in normal font with no asterisk, allowing you to easily identify those windows that have changes.

Save changes in Structure Manager

Choose the File→Save Structure Manager menu command to save all the changes made in the currently displayed structure window. Changes to the structure result in a modification to BOM view revisions, for example, adding or removing components, or changing occurrence attributes such as notes and find numbers. Teamcenter prevents you accidentally closing a structure window without saving changes.

Saving changes with multiple windows

You can open multiple windows by using the split window button.

- If you make structure changes, only those changes made in the window where you choose the Save command are saved. If you create additional windows and open structures in those windows, changes made in the other windows are not saved.

- If you want to save changes made in other windows, you must explicitly choose the Save command in the window in which the structure changes were made.

Example of saving in multiple windows

- In window 1, remove E from M. This also causes E to be removed from M in window 2.
• In window 2, remove L from D and change a note on J. Add a note to Z in M and this change is also seen in window 1.

• In window 1, save the product structure. This action saves changes to assembly M but not D.

  **Note** Changes are saved, regardless of where they are made. Therefore, the changes made in window 2 to M are also saved. The save action in window 1 thus causes a partial save of the changes made in window 2, on those assemblies that are also seen in window 1.

• In window 2, save the product structure. This action saves changes to assembly D.

### Close the product structure window

If unsaved changes are made in a product structure window and you choose the **File**—**Close** menu command, Teamcenter displays the **Close Application - Save Modifications** dialog box.

The unsaved modifications are listed and you can select the check box next to each modification to save it.

• Click **OK** to save all selected changes and close the dialog box. Updates to unselected changes are discarded.

• Click **Cancel** to return to the Structure Manager session without saving changes.

### Refresh the Structure Manager window and resynchronize to database

Structure changes you make are propagated across all product structure windows in a particular session. However, changes are not propagated across sessions.

• Choose **View**—**Refresh Window** to resynchronize the current window to the database. This action picks up changes made in other sessions and saved since you loaded the product structure. This function does not cause your own changes to be saved or lost.

  **Note** Teamcenter does not permit other users to change any BOM view revision that you are editing. The BOM view revision is locked by the first person to make a change, whether this is adding or removing a component or modifying any of the occurrence attributes of any of the components.

### Adding components to the product structure

There are four ways you can add components to the product structure:

• **Copying and pasting objects**
  
  Allows you to copy references to existing items, parts, and designs.

• **Use quick add**
Allows you to add new components by typing in the item, part, and design identifiers.

- **Add a component to an assembly**
  Allows you to enter the item identifier by specifying (for example) the number of components to add.

- **Create a new item or item revisions**
  Allows you to use a top-down approach by simultaneously modelling structure and creating new items, parts, and designs.

If you manage parts and CAD designs separately, you must publish links between them as an appropriate time. For details of how to do this, see the *Multi-Structure Manager Guide*.

If another user is editing a single level assembly within the product structure, Teamcenter prevents you making changes until the other user has saved their changes. A warning message identifies the other user working on the assembly. This safeguard does not prevent you making changes to other assemblies that are not being worked on.

Optionally, Teamcenter can validate the structure by verifying that you add only appropriate child items and item elements (GDEs). If you attempt to make an invalid addition, Teamcenter displays an error message stating that you cannot add the selected child item to the current parent item. To enable validation, your Teamcenter administrator sets the `TCEnforceSingleType` and `TCAllowedChildTypes Item Type/GDE Type` preferences, as described in the *Preferences and Environment Variables Reference*.

**Note** If you try to add an incompatible part type to the product structure, Teamcenter displays an error message. For example, you cannot add a manufacturer part to the product structure in Structure Manager.

### Copying and pasting objects

The Teamcenter clipboard is shared by all applications and by NX. Consequently, for example, objects you place on the clipboard by copying them in My Teamcenter may subsequently be pasted into the product structure in Structure Manager.

You can also edit the product structure with the **Remove**, **Copy**, **Paste**, and **Paste Special** commands.

When you paste an item or item revision from the clipboard, Teamcenter creates corresponding components in the selected assembly in the product structure. Structure Manager allows you to paste items and item revisions (including parts, designs, and their revisions), structure lines, and item elements; other objects are ignored if you attempt to paste them.

If you cut and paste structure lines, the pending lines are removed from the clipboard after you choose **Paste** or **Paste Special**. If the cut lines are in the same structure as the target, Teamcenter performs a move action, rather than a cut and paste action.

If your administrator has defined mandatory properties for the type of object you are creating, Teamcenter displays the **Properties** dialog box, which allows you to define attribute values for the objects. To modify the properties of an existing object, choose **Edit → Properties On Relations**.
If the component you are adding to the structure contains unsatisfied connection points, Teamcenter checks if any of the other components in the structure also contain unsatisfied connection points and offers to connect them.

For more information, see Adding components using the guided component search.

Copy and paste an item or item revision

1. Select and copy the item or item revision (including parts, designs, and their revisions) from elsewhere in the product structure displayed in Structure Manager or from another application such as My Teamcenter. You can copy the item or item revision by clicking Copy , choosing Edit→Copy or pressing the Ctrl+C keys. This action places the item or item revision on the clipboard.

2. In Structure Manager, select the assembly into which you want to add the component.

3. Paste the item or item revision by clicking Paste , choosing Edit→Paste or pressing the Ctrl+V keys.

Pasting does not remove the object from the clipboard. Therefore, you can click Paste again to add another line of the same item revision to the assembly. Another Copy operation replaces the previous clipboard contents with the new object.

Caution After creating an architecture breakdown structure in Platform Designer and sending it to Structure Manager, do not copy and paste or drag and drop architecture elements in the same window. It can lead to data corruption in Platform Designer. If you inadvertently perform one of these actions, delete the resulting line using the Remove Design from Product button.

Copy and paste using the structure line shortcut menu

If you right-click a line in the product structure, Teamcenter displays the structure line shortcut menu, allowing you to:

- Choose the Copy command to copy the line to the clipboard. This is the same action as pressing the Ctrl+C shortcut keys, choosing Edit→Copy, or clicking Copy on the toolbar.

- Choose the Paste command to paste the contents of the clipboard as components of the line. This is the same action as pressing the Ctrl+V shortcut keys, choosing Edit→Paste, or clicking Paste on the toolbar.

- Choose the Properties command to view the properties of the line. This is the same action as choosing View→Properties or clicking Properties on the toolbar.

Note You do not need to explicitly select the line before right-clicking it.
Copying and pasting occurrence attributes of components

When you copy a component from an assembly and then paste it elsewhere:

- The occurrence attributes (for example, the quantity and any notes) are also copied and pasted.
- The find number is not copied.
  Teamcenter automatically generates the find number according to the position of the component in the target assembly.
- If the component has an associated substitute list, this is also copied and pasted.

If you paste the component into My Teamcenter, rather than Structure Manager, Teamcenter pastes the lines as individual item revisions.

**Note** You cannot view occurrence attributes such as quantity or notes in My Teamcenter.

Teamcenter does not copy variant conditions with components. You must copy variant conditions separately, as described in *Copy variant conditions to other occurrences*.

Use quick add

Often it is more convenient to insert the component by typing its identifier instead of pasting it from the clipboard. To do this:

1. Select the assembly into which you want to add the component.
2. Click the text box in the lower left of the Structure Manager application window.
3. Enter the component ID and click \( \Rightarrow \).

You can only use Quick Add for adding existing items. To create a new item and add it to the structure, choose **File→New→Item**.

Add a component to an assembly

You may want to specify additional data about the use of a component as you add it to the structure, for example, a quantity or find number. You can do this by choosing the **Add...** command to insert a new component.

1. Select the assembly to which you want to add the component.
2. Choose **Edit→Add...** and Teamcenter displays the **Add** dialog box.
   Use the upper pane of the dialog box to specify the component to add and the view type, if multiple views exist. Use the lower pane of the dialog box to specify the occurrence information.
3. Complete the dialog box as follows:
   - Enter the component item identifier directly, or search for the item by its identifier or name. You cannot enter the item name, but Teamcenter displays the name as confirmation that you entered the required identifier.
• Optionally, specify the revision according to its precision, as follows.
  
o If the parent assembly BOM view revision is imprecise, the **Revision** box is disabled and you cannot specify a revision.

  **Note** When the component is added to the structure and displayed in Structure Manager, the actual revision is determined by the revision (configuration) rule. If there is not a revision that satisfies the revision rule, the revision is shown as ???.

  o If the parent assembly BOM view revision is precise, you are creating a precise occurrence. The **Revision** box is enabled and you can specify a revision.

• Choose **Component** or **Selected Assembly**. For information about substitute components, see *Defining substitute components*.

• Set the view type if there are multiple views of the component; you do not want the default view type. You can select another view type from the list of views created for the component.

• Specify any of the following occurrence attributes:
  
o **Number of Occurrences**
  
  Specify the number of lines to add to the structure. The default selection is 1.

  o **Quantity Per Occurrence**
  
  Specify the quantity associated with each line in the structure.

    - If the item has a unit of measure defined, the units are displayed next to the **Quantity per Occurrence** box and you can enter a fractional value (for example, 1.5). If the units are displayed as **Each**, the box shows the number of parts and you must enter a whole number.

    - If the quantity box is blank, the default value is 1 for items that have no unit of measure or 0 for items with a unit of measure. These values are used in quantity rollups, for example, when lines in the structure are packed.

  **Note** You can enter the string A/R or a to specify a quantity value of **As Required**.

  o **Find Number**
  
  Edit the find number if necessary.

  **Note** Find numbers are automatically generated according to the scheme defined for your site with the **PS_new_seqno_mode** preference. The default scheme increments the find number by 10 as each new component is added.

4. If you specified an item ID that is shared by multiple objects, Teamcenter displays the **Select Unique Item** dialog box.

   Select the object you require from the list.
Teamcenter returns to the Add dialog box.

5. Click OK or Apply to add the component to the assembly.

**Paste a component**

You can specify additional data about the use of a component as you add it to the structure, for example, a quantity or find number.

- Choose the Paste Special command to insert an existing component that you copied to the clipboard into the structure. Unlike Add..., Teamcenter prepopulates the Component ID (Revision) and Name boxes of the Paste Special dialog box with item or item revision information from the clipboard.

**Copy multiple views**

If you copy an item revision with more than one view type from another rich client application and paste it into the structure in Structure Manager, Teamcenter uses the following rules to determine the view type to which the new occurrence refers.

- If a specific view type is copied from the other application, Teamcenter uses the same view.

- If no view type is copied, Teamcenter displays a list of all the available view types for that item.

Use the Paste Special or Add... menu command or the Replace command when copying an item revision with multiple views. This allows you to specify the required view type manually. If you paste the item revision directly and none of the items view types match the default view type, Teamcenter displays an error message but attempts to complete the paste operation.

If you copy a line from the structure in Structure Manager that represents a specific BOM view revision and paste it into another structure in Structure Manager, the new occurrence references the same BOM view revision as you copied.

**Create a new item or item revisions**

You can create an item revision and structure it as an assembly, by adding new components one item or part at one time. This technique is useful when doing top-down modeling. You must have write access to the BOM view revision to create the new item revision.

1. Select the parent assembly in the product structure tree.

2. Choose File→New→Item or File→New→Part.

Teamcenter performs the same checks as described for the Add... command (see Add a component to an assembly) and displays the Create Item or Create Part dialog box.

3. Enter the necessary parameters in the dialog box and click OK.

Teamcenter creates the new item or part (or its revision) and adds it as a component of the selected assembly.
Restructuring and editing the product structure

You can restructure a representation, including a BOM view, occurrence group, structure context, or composition. You must revise a frozen product structure before restructuring. Restructuring edits the product structure in downstream views (for example, manufacturing) while preserving the derived occurrence structure and data related to specific occurrences of parts and assemblies. Restructuring is disabled for product structures that contain CAD designs because it can make the CAD data invalid.

During restructuring operations, Teamcenter maintains the integrity of incremental changes, classic or modular variants, and structure relationships. Teamcenter displays warnings when it encounters absolute occurrences attributes and data. If you have edits pending to a product structure, you must save the edits before you open the structure in another application.

In addition to restructuring, you can edit individual properties on any line, subject to the following limitations:

- Restructuring is not permitted on lines that have pending edits.
- Property edits are associated with a relative occurrence and are marked as pending until they are saved to the database.
- Property edits are highlighted only if you use the column editor. If you use other methods of changing properties (for example, the Properties dialog box), these edits are not visually highlighted in the properties table. However, Teamcenter still retains the details of such edits until you save or revert them.
- If any note in the list of notes is edited, the All Notes field shows a ... symbol with a red strike-through. It does not show the exact original value.
- Edits to the absolute or relative transformation matrix are not highlighted.
- You cannot edit the first property column (BOM Line).
- By default, if you cut or copy a line and then paste it to a new location, incremental change elements (ICEs) are not copied. This may necessitate significant manual recreation of data if you are cutting or copying many lines together. To automatically copy ICEs, the administrator must set two Business Modeler IDE constants:
  - Fnd0EnableIceCarryOver business object constant
    - When moving, copying, or assigning a line from one location to another, this constant determines if the ICEs are carried forward. You must set this constant to true on both the source location’s parent and the target location’s parent.
  - Fnd0AttrICEsToExclude property constant
Defines the occurrence attributes that Teamcenter does not copy to the target location for occurrence attribute changes.

These settings apply to in-context changes made to structure lines, their attachments, and their occurrence attributes.

**Note** Restructuring primitive actions include:

- Removing a level (removing a line and keeping child lines)
- Inserting a level (including pasting a line as a parent of selected lines)
- Moving a line to a new location (for example, cut and paste actions)
- Splitting an occurrence
- Replacing data in context

Only the last two actions make copies of the absolute occurrence data; the other actions share the existing absolute occurrence data.

In certain cases, restructuring may cause valid reports of broken links, as shown in the following examples:

**Example 1:**

```
  A
 /|
B +------------C (APN1 in context of A)
 / |
C +------------D
```

If you remove level C, the structure becomes:

```
  A
 /|
B +------------D
```

The link to C is lost. This is correctly reported as a broken link.

**Example 2:**

```
  A
 /|
B +------------E
 +------------C
   +------------D(APN1 in context of B)
```

If you move D to E, it is outside of the context of B and APN1 is lost. This is correctly reported as a broken link.

**Example 3:**

```
  A
 /|
B +------------C
 /|
C +------------D(APN2 in context of A)
 /|
B +------------C
 /|
C +------------D(APN1 in context of A)
```

```
  A
 /|
B +------------D
 /|
C +------------D
```

If you move C to D, the system cannot determine which D to move the APN to without user interaction. It skips the APN and logs an error message.

*Example 4:*

```
A
+--------B
    +--------C
    +-------D(APN1 in context of B)
```

If you remove level B, it becomes:

```
A
+--------C
 +-------D
```

The link to D is lost. This is correctly reported as a broken link.

**Insert a level in the structure**

You can create an item and insert it in the current structure as a new level below the selected line. The number of relative occurrences of the children is preserved. If you select more than one line, they must share the same parent.

1. Select the parent line of the new level and choose **Edit→Insert Level**.
   
   Teamcenter displays the **Insert Level** dialog box.

2. Enter the item identifier and other attributes of the new item. If the inserted item is new, you must insert it with a quantity of 1.

3. On completion, click **OK** or **Apply**.

   Teamcenter creates the new item and inserts it as a new level. The selected branches become children of the inserted level, while the inserted level becomes a branch of the original parent. All existing variant conditions, notes, absolute occurrences, and other data is moved down with the selected branches. The default quantity of the new level is 1, meaning that no quantity change occurs.

**Note**

In most cases, associations between objects (such as **Connected To** relations) are correctly maintained or are reassOCIated. However, after editing a Mechatronics structure, always choose the **Fix In-Structure Associations** command to identify any invalid associations.

For more information, see **Fix in-structure associations**.

You cannot insert a level if the selected line represents a generic design element (GDE).

**Note**

You can only insert a level if the line represents a standard business object type. If the line represents a custom type, copy it to the clipboard and choose **Paste Special**. Teamcenter pastes it as a new level above the currently selected line.
Remove a level from the structure

1. Select the affected line and choose Edit→Remove or click Remove .
   Teamcenter displays the Remove dialog box.

2. (Optional) Select Keep subtree to reattach the children of the removed level
to the next higher level parent line.

3. Click Yes to confirm removal of the line. The total number of instances is
   preserved at the end of this action. Any options of the removed lines are moved
   up and variant conditions are merged.

If you try to remove a level that would result in option definitions becoming
inconsistent (for example, options that are referenced by a parent line), Teamcenter
displays an error message.

Caution If you select a line for removal and edit tracking is enabled, the line is
displayed in red with a strike-through until you commit the edits. Do not
attempt to edit or work with this line, or you may obtain unpredictable
results. If you want to edit or work with a line that is marked for removal,
revert the removal of the line by choosing Edit→Revert Edit first.

Similarly, do not edit or work with a marked line in another structure
editor such as Multi-Structure Manager. Always complete and save
your work on the structure in Structure Manager before you open it
in another structure editor.

If you remove one of the lines that is the context of a Mechatronics
relation between primary and secondary lines, the relation itself is also
removed.

Note In most cases, associations between objects (such as Connected To
relations) are correctly maintained if you select Keep subtree or are
reassociated. However, after editing a Mechatronics structure, always
choose the Fix In-Structure Associations command to identify any invalid
associations.

For more information, see Fix in-structure associations.

You cannot insert a level if the selected line represents a generic design
element (GDE).

Move a node to another branch

You can move a selected node from one branch to another. All substructure and
occurrence data moves with the node.

1. Move a node using any of the following methods:
   • Cut and paste using the Edit→Cut and Edit→Paste menu commands.
   • Cut and paste using the Ctrl+X and Ctrl+V shortcut keys.

Caution Do not try to move a node by dragging the line to its new position.
Teamcenter performs a copy action when you drag a line.
Teamcenter displays the **Paste** dialog box.

2. Do one or more of the following:
   - Change the item ID and revision ID.
   - Change the view type, if applicable.
   - Select if the line should be pasted as a component of the selected assembly line, as a substitute for the selected line, or as a new level above the selected line.
   - Specify the number of occurrences, quantity per occurrence, and find number.

3. Click **OK** or **Apply** to complete moving the line.

**Caution** If you cut a line and edit tracking is enabled, the line is displayed in red with a strike-through until you commit the edits. Do not attempt to edit or work with this line, or you may obtain unpredictable results. If you want to edit or work with a line that is marked as cut, revert changes to the line by choosing **Edit→Revert Edit** first.

Similarly, do not edit or work with a marked line in another structure editor such as Multi-Structure Manager. Always complete and save your work on the structure before you open it in another structure editor.

**Note** In most cases, associations between objects (such as **Connected To** relations) are correctly maintained or are reassOCIated. However, after editing a mechatronics structure, you should always choose the **Fix In-Structure Associations** command to identify any invalid associations.

For more information, see **Fix in-structure associations**.

Any lines representing GDEs are renumbered after moving a node.

If you move both the primary and secondary lines of a mechatronics relation out of context, the relation is removed. However, if you move both the primary and secondary lines of a mechatronics relation to any level below the context, the relation is not removed. It is listed in the **Fix In-Structure Associations** dialog box when you choose **Tools→Fix In-Structure Associations**, allowing you to fix the invalid association.

If you remove the secondary line of a mechatronics relation out of context, the relation itself is removed. Refresh the primary line to see the updated BOM column properties.

If the line has an associated variant condition and you move it out of the scope of the option referenced in the variant condition, the variant condition is not retained.

If you move a node that has absolute occurrence overrides out of the scope of the context of the overrides, the system does not retain the override values after the move.
Replace a node

You can replace an item representing a node in the structure with another item. All data associated with the original node is preserved.

**Note** Your system administrator sets the `PS_replace_with_substructure` preference to determine if any substructure below the node is replaced. If this preference is `true`, the node and its entire substructure (if any) are replaced without prompting. If it is `false`, Teamcenter displays an error message and does not complete the replacement action.

1. Select the line to replace and choose **Edit**→**Replace Node** or click \[Replace Line\].
Teamcenter displays the **Replace Node** dialog box.

2. Enter the item identifier and other attributes of the item that replaces the existing item.

3. Click **OK** or **Apply**.
Teamcenter replaces the existing item.
If you have edit highlighting turned on, the number of the original part is shown in red, strike-through text.

**Note** In most cases, associations between objects (such as **Connected To** relations) are correctly maintained or are reassociated. However, after editing a Mechatronics structure, you should always choose the **Fix In-Structure Associations** command to identify any invalid associations.

For more information, see **Fix in-structure associations**.

If the child of the copied item includes **RealizedBy**, **ImplementedBy**, or **RedundantSignal** as the primary association, the corresponding child in the replaced assembly points to the secondary association of the original (copied) assembly.

You can replace a line that represents a generic design element (GDE) with another GDE line but not with a line that represents another object.

You can replace Mechatronics items with any type of item. However, Siemens PLM Software recommends you use the same item type as the replaced item or one of its subtypes for the replacement item. Use of incompatible types may result in invalid relationships between occurrences in the product structure. The following table lists possible Mechatronics items for replace operations.

---

### Mechatronics items for replace operations

<table>
<thead>
<tr>
<th>Object</th>
<th>Recommended types for replace</th>
</tr>
</thead>
<tbody>
<tr>
<td>Functionality</td>
<td>Functionality or its subtype</td>
</tr>
<tr>
<td>Connection</td>
<td>Connection or its subtype</td>
</tr>
<tr>
<td>Network</td>
<td>Network or its subtype</td>
</tr>
<tr>
<td>PSConnection</td>
<td>PSConnection or its subtype</td>
</tr>
</tbody>
</table>
Object | Recommended types for replace
--- | ---
Signal | Signal or its subtype
PSSignal | PSSignal or its subtype
Message | Message or its subtype
HRN_Accessory | HRN_Accessory or its subtype
HRN_AssemblyPart | HRN_AssemblyPart or its subtype
HRN_CavityPlug | HRN_CavityPlug or its subtype
HRN_CavitySeal | HRN_CavitySeal or its subtype
HRN_CoPackPart | HRN_CoPackPart or its subtype
HRN_ConHousing | HRN_ConHousing or its subtype
HRN_Fixing | HRN_Fixing or its subtype
HRN_GenTerminal | HRN_GenTerminal or its subtype
HRN_GeneralWire | HRN_GeneralWire or its subtype
HRN_Harness | HRN_Harness or its subtype
HRN_Module | HRN_Module or its subtype
HRN_WireProtect | HRN_WireProtect or its subtype
AppSoftware | AppSoftware or its subtype
Calibration | Calibration or its subtype
ConfigFile | ConfigFile or its subtype
PriBootloader | PriBootloader or its subtype
SecBootloader | SecBootloader or its subtype
Processor | Processor or its subtype

**Split an occurrence**

You can split a line that represents several occurrences into two branches. The new branch and the original (changed) branch initially have the same notes, variant conditions, and other data, but you can subsequently modify them independently. The quantity on the original line before the split must be greater than 1.

1. Select the occurrence line and choose **Edit→Split Occurrence**.
   Teamcenter displays the **Split Occurrence** dialog box.

2. Enter the quantity for the new line that results from the split and click **OK** or **Apply**.
You cannot split an occurrence if the line represents a logical object, for example, Connection, Signal, or Software. You can split interfaces and other Mechatronics objects, for example, HRN_GeneralWire and Processor.

In most cases, associations between objects (such as Connected To relations) are correctly maintained or are reassOCIated. However, after editing a Mechatronics structure, you should always choose the Fix In-Structure Associations command to identify any invalid associations.

For more information, see Fix in-structure associations.

If you split an occurrence line that represents a GDE, Teamcenter increments the GDE number. The quantity of a GDE line must always be an integer.

If the child of the original occurrence includes RealizedBy, ImplementedBy, or RedundantSignal as the primary association, the corresponding child occurrence of the split occurrence points to the secondary association of the original occurrence.

Fixing in-structure associations

When you manually edit a structure containing Mechatronics elements such as signals and connections, you may inadvertently create invalid associations between elements. To avoid multiple, potentially misleading warnings, Teamcenter does not display error messages during the editing session. However, once you have completed any editing session during which you chose the Insert Level, Remove, Move or Replace commands, manually check for and remove any invalid associations.

Fix in-structure associations

1. Select the top line of the edited structure and choose Tools→Fix In-Structure Associations→Current Level or Tools→Fix In-Structure Associations→All Levels.

   Teamcenter displays a dialog box containing a list of invalid associations. The scope of the invalid associations depends on whether you chose the current level or all levels.

2. Select the first invalid association and click Remove.

   Teamcenter removes the selected association from the structure.

3. Repeat the previous step for each of the other invalid associations in turn.

   Any associations that you do not remove manually remain in the structure.

Performing on-demand validation

Your administrator can configure Teamcenter to enforce any rules imposed by the organization on what types of content are allowed in the structure. You cannot add content or make other structure edits that would violate the defined business rules.

The following types of restrictions on content within a structure are enforced:

- Only certain item classes or types may exist anywhere in a structure.
• Only certain item classes or types may be children of others.
• Only certain item classes or types may be parents of others.
• Properties of the parent or child object must satisfy specified values or be NULL.

For allowable substitutes in a given BOM line, the same restrictions that apply to the primary part occurrence are applied to the substitute.

Validations are provided for the following operations:
• Creating a new occurrence
• Adding a substitute for a given occurrence
• Cloning (duplicating) a structure
• Importing or exporting a structure
• Revise and baseline

**Note**  Teamcenter validates only the first two operations in real time.

When you save edits, Teamcenter validates that they do not violate the defined business rules and, if they do, displays an error message and does not save the changes.

Optionally, you can perform an on-demand validation of property updates at any time by right-clicking a top line with substructure and choosing **Tools→Validate Occurrences**. If no issues are found, Teamcenter displays a confirmation and saves a validation log. If issues are found, it displays a list of errors.

**Note**  The administrator uses the Business Modeler IDE to define these business rules on explicitly stated classes. Any subclasses or subtypes of these classes inherit the same rules.

For more information, see the *Business Modeler IDE Guide*.

You must also create and set the following preferences:

- **PS_Default_Rev_For_Occ_Cond_Validation**
  Defines the default revision rule when a child item is used for validation.

- **PS_Bypass_Occurrence_Condition**
  Configures the system to bypass occurrence condition validation for defined actions or operations.

### Highlighting edits to the structure

If your administrator sets the **PSE_Display_Pending_Edits** preference to **true**, edits to the product structure tabular display are highlighted visually until you save them to the database.
If necessary, you can override this preference setting locally for your current session by selecting the **Display Markups for pending edits** command.

Highlighting edits feature is available only in Structure Manager, not other structure editor applications.

**Note**  This feature is not compatible with the BOM markup feature described in *Marking up the product structure*, and you cannot use the two features together.

Ensure you select this feature when you want to edit the BOM directly, not when you want to create markups (propose changes).

You cannot convert pending BOM edits into markups.

**Tip**  Enable highlighting only when you want to specifically track edits you are making; otherwise, the display may become difficult to interpret.

Close all Structure Manager windows before changing this option to avoid having open windows where edits are not highlighted. (Changing this option does not affect existing windows.)

Edits indicated are as follows:

- **Additions**
  
  Displayed in green italic font.

- **Removals**
  
  Displayed in red with a strike-through line.

- **Property edits**
  
  Displayed with the original values in red with a strike-through line.

If you have pending edits to the structure, you can do any of the following:

- **Click Revert** to undo all pending edits to the selected line.
  
  All edit marks are removed from the line.

- **Click Save** to commit all pending edits to the database.
  
  The structure is redisplayed with no edit marks.

- **Click Revert All** to cancel all pending edits.
  
  The structure is redisplayed with no edit marks.

**Note**  You cannot compare structures with pending edits with the **BOM Compare** command. However, you can expand the structure manually to view the effect of pending edits.

Likewise, you cannot highlight pending edits if you enable incremental changes.
You cannot create new associations (for example, a Connected To, Implemented By or Embeds relation) to a line that is displayed in red with a strike-through line.

When you save pending edits, any associations to deleted lines are also deleted. If you revert pending edits, all associations are maintained.

Marking up the product structure

You can:

- Mark proposed changes on the product structure or an assembly.
- Save the markup in a persistent workspace object.
- Route the assembly with its markup object for review, and apply the proposed changes.
- Add more proposed changes and comments to a previously marked-up structure and save them in the existing markup object.

This feature is not compatible with the pending edit redlining feature described in Highlighting edits to the structure, and you cannot use the two features together. Ensure you select the BOM markup mode when you want to create markups (propose changes), not when you want to edit the BOM directly. You cannot convert pending BOM edits into markups.

The markup is related to the BOM view revision (BVR) of the structure. The BVR may have multiple markups associated with it, but only one markup may be active; once a markup is applied, it ceases to be active.

A markup change represents a single proposed change to the BVR or one of its child lines. A markup change always references a markup, and a markup may include multiple markup changes. The author and the date and time of each markup change is tracked.

The following proposed changes to the structure can be included in a markup:

- Addition or removal of an occurrence.
- Addition or removal of a substitute for a line.
- Replacement of a line (a change to the item revision when in precise mode or to the item when in imprecise mode).
- Change to the value of certain occurrence properties, for example, name, notes, quantity, sequence number, unit of measure, reference designator, and variant condition. The properties that are tracked in markups are defined in the Fnd0BOMMarkupSupportedProperties global constant in the Business Modeler IDE. You can add properties to this global constant, but you cannot delete the default entries.

To allow users to work with markups, the administrator must set the Fnd0BOMMarkupAllowed global constant to true in the Business Modeler IDE.

Set the following preferences to specify how markup actions are displayed:
Building and editing product structure

- **BOM_MARKUP_ADD_FONT_STYLE**
  Specifies the font style in which added line markups are displayed. For example, if this preference is set to 2, additions are shown in italic.

- **BOM_MARKUP_ADD_FOREGROUND**
  Specifies the color in which added line markups are displayed. For example, if this preference is set to 0,255,0, additions are shown in green.

- **BOM_MARKUP_STRIKE_FOREGROUND**
  Specifies the color in which removed line and property markups are displayed. For example, if this preference is set to 255,0,0, removals and changes are shown in red.

  Many editing actions are not supported in markup mode and the corresponding menu commands are disabled.

  The markup commands are not available if Teamcenter is tracking pending edits to the structure in the active pane. Save or cancel any pending changes before inserting the markup. Editing a structure with markups may obsolete or remove impacted markups.

  You cannot mark up changes to absolute occurrences; that is, if in-context editing is turned on, the markup commands are not available.

  You cannot propose changes to an existing markup change. You should create a general markup with your comments or delete the existing markup change and create a new one.

  Changes to properties are limited to 160 bytes.

**Enable markup mode**

- To turn markup mode on, choose **Tools→Markup→Markup Mode** or click 

  Teamcenter displays a check mark [✓] next to the menu command. Any existing markups to the structure are loaded and displayed.

  You can only turn on markup mode if your administrator has set the **Fnd0BOMMarkupAllowed** global constant to **true** in the Business Modeler IDE.

  You cannot turn markup mode on if you have **Display Markups for pending edits** enabled by your option (preference) settings. You must save or cancel those edits first.

  You cannot turn markup mode on if you have uncommitted changes. You must save or cancel those changes first.

- To turn markup mode off, choose **Tools→Markup→Markup Mode** again or click 

  Teamcenter removes the check mark [✓] next to the menu command.
Create and insert general markup

1. Ensure you are in markup mode, as described in Enable markup mode.
2. Select the structure line where you want to add the general markup.
3. Choose Tools→Markup→Show Markup View or click 

   Teamcenter displays the BOM Markup view.
4. Click the Add General Comment button  next to the Show changes for this line pane.
   Teamcenter adds a new line in the pane.
5. Enter an appropriate comment (for example, a general description of the proposed change).
   Teamcenter saves this general comment to the markup object.

   **Note** You cannot mark up the first property column (Quantity).

Display markup properties

- In My Teamcenter, select the markup object whose properties you want to display, and then choose View→Properties. Alternatively, you can right-click the object and choose Properties.

   Teamcenter displays the properties of the markup, including the following details for markup changes:
   - A numeric identifier (#)
     Shows a unique identifier for grouping related changes. All changes with the same number are related.
   - **Dependent?**
     Contains Y if there are dependent markup changes; otherwise it is blank.
   - **Markup Description**
     Displays the description of the markup that was entered by the user who created it.
   - **Status**
     Shows the current status of the markup, for example, **Working** or **Obsolete**.
   - **Note**

   **Note** The # and **Dependent** columns are populated for an ADD BOM line markup change to allow you to visually relate the change information. When you create an ADD BOM line markup change, Teamcenter creates dependent property markup changes for the find number and quantity.
Review and comment on markup

1. Select a line with a related markup and then choose Tools→Markup→Show Markup View or click 

   Note: You can also choose Structure Manager→Window→Show View→Other→Teamcenter→BOM Markup View to display the markup view.

   Teamcenter displays the BOM Markup view.

2. In Show markup for this level, type a text comment in the Comments box. Teamcenter saves the comment to the markup object.

   Note: The BOM Markup pane shows markup information for the selected BOM line. It shows only active markups and active markup changes, not obsolete changes.

   For an ADD change, it shows only the ADD BOM line markup change and does not display the dependent property markup changes. Consequently, the BOM Markup view corresponds exactly with the redlining shown in the BOM panel.

   The dependent markup changes are not redlined as property changes, but are displayed as part of the ADD redlining. The dependent markup changes are deleted as part of an ADD markup change deletion.

Validate access to apply markup

- Select a line with a related markup and choose Tools→Markup→Validate Access to Apply Markups (all levels).

   Teamcenter checks if you have the necessary access privileges to save the changes in the markup and displays a confirmation message.

   Note: This check only identifies if you have access to the BVR associated with the selected line. It does not check if you have access to the marked-up child BOM lines.

   You do not need write privileges to markup a structure, only to commit (save) the changes included in the markup.

Apply markup

You can save (commit to the database) all changes recorded in the markup that are related to the current line.

This does not affect any changes recorded in markup objects related to the child lines below it. To save changes in markups related to child lines, see Apply all markups.

1. Select the line with the relevant markup and choose Tools→Markup→Apply Markup (this level).

   Alternatively, you can right-click the line and choose Apply Markup (this level).

   Teamcenter displays a confirmation dialog box.
Chapter 4  Building and editing product structure

2. Click OK and Teamcenter applies the changes in the markup to the structure.

   Once a markup is applied, it ceases to be active and any future markups are captured in a new markup object.

   A markup cannot be applied more than once, although the results of an applied markup are visible in the structure.

   **Note**  If you do not have write privileges to the selected line, Teamcenter displays a dialog box asking if you want to create a new BVR. Click OK and Teamcenter creates the necessary BVR.

Alternatively, you can apply a markup at the selected level as follows:

1. Select the line to which the markup is related and then choose
   
   **Tools**→**Markup**→**Show Markup View** or click 📝.

   Teamcenter displays the BOM Markup view.

2. Review the details of the markup, then choose **Tools**→**Markup**→**Apply markup (this level)**.

   Teamcenter applies the changes in the markup to the structure.

   If the apply action causes full or partial errors, Teamcenter displays a dialog box that lists the errors and the failed components. You must evaluate the error descriptions and decide how to fix them.

   For example, if the error results from access restrictions, you can ask another user with suitable access rights to apply the markup or revise the item revision to obtain access.

### Apply all markups

You can save (commit to the database) all changes in the markup that are related to the current line and also changes in any markups related to the lines below it. To only save changes in the markup related to the current line, see **Apply markup**.

**Caution**  Applying multiple markups to a large structure may take a considerable time.

1. Select the top-level line with a relevant markup and choose
   
   **Tools**→**Markup**→**Apply Markup (all levels)**.

   Teamcenter displays a confirmation dialog box.

2. Click OK and Teamcenter applies the changes in the markups to the structure.

   Once a markup is applied, it ceases to be active and any future markups are captured in a new markup object.

   A markup cannot be applied more than once, although an applied markup remains visible in the structure.

   **Note**  If you do not have write privileges to any of the child lines below the selected line, Teamcenter displays a dialog box asking if you want to create new BVRs. Click OK and Teamcenter creates the necessary BVR.
If the apply action causes full or partial errors, Teamcenter displays a dialog box that lists the errors and the failed components. You must evaluate the error descriptions and decide how to fix them. For example, if the error results from access restrictions, you can ask another user with suitable access rights to apply the markup or revise the item revision to obtain access.

**Carrying forward markups**

Active markups may be automatically carried forward, depending on how you copy the structure:

- **Baselining or revising.**
  Markups are copied.

- **Cloning.**
  Markups are not copied, because closure rules do not apply to a structure clone.

- **Sequencing.**
  Markups are not copied.

- **Saving the item or BVR using the Save As command.**
  Markups are not copied.

**Delete markup**

1. Select the line with the markup you want to delete and choose **Tools→Markup→Delete Markup (this level)**. Alternatively, right-click the line and choose **Delete Markup (this level)**.
   Teamcenter displays a confirmation dialog box.

2. Click **OK** and Teamcenter deletes the active markup related to the selected line. When a markup is deleted, all of its markup changes are also deleted.

Alternatively, you can delete a markup at the selected level as follows:

1. Select the line to which the markup is related and then choose **Tools→Markup→Show Markup View** or click .
   Teamcenter displays the **BOM Markup** pane.

2. Review the details of the markup, then choose **Delete markup (this level)**.
   Teamcenter deletes the active markup related to the selected line.

**Creating markup review sample workflows**

You can create workflow process to manage the review and approval of an active markup to a product structure. Four sample workflows are described, as follows:

- **Sample 1**
  Use this sample when there is one markup object related to a BOM view revision (BVR) and it is active. The workflow routes this markup object for review.
• Sample 2
  Use this sample when there are multiple markup objects related to a BVR and
  one object is active. The workflow selects the active markup object and routes it
  for review. A user can copy and paste the active markup as a specific target in
  the workflow process.

• Sample 3
  Use this sample when there are multiple markup objects related to a BVR and
  one object is active. The workflow filters the active markup object and routes it
  for review. A revise operation on a BVR with multiple markup objects only
  carries forward the active markup object.

• Sample 4
  Use this sample when there are multiple markup objects related to a BVR and
  one object is active. The workflow process filters the active markup and routes it
  for review. The workflow also applies an approved status to the active markup
  object.

This sample includes three processes and they must be invoked in the order
listed:

1. **BOMMarkup_Review**
   Sends an item revision or BVR to a review task. After approval, it starts the
   **BOMMarkup_SplitTarget** process.
   
   The review task is a manual operation. The reviewer or approver must send
   the workflow target (the item revision or BVR) to Structure Manager to
   view the product structure. Markup mode must be switched on to see the
   proposed changes.

2. **BOMMarkup_SplitTargets**
   Adds the markup objects as targets. As there may be multiple
   markup objects, the workflow sends each of them individually to the
   **BOMMarkup_AddStatus** object to identify the active markup.

3. **BOMMarkup_AddStatus**
   o Always has a single target object because the parent
     **BOMMarkup_SplitTargets** process always spawns a new
     **BOMMarkup_AddStatus** subprocess for each new target object.

   o Checks if the target object is a markup object. If not, it must be an item
     revision or BVR, and Teamcenter sends it to the **Add BOMMarkup
     Approved Status** task.

   o If the target is a markup object, checks if it is active. If so, Teamcenter
     sends it to the **Add BOMMarkup Approved Status** task; otherwise,
     no status is added.

For information about how to create the necessary processes, see the **Workflow
   Designer Guide**.
Note You can also use these samples as the basis of a workflow that applies markups or permits a user to apply markup changes manually.

Sample 1
Use this sample if one markup object is related to a BVR and it is the active markup object.

1. Use Workflow Designer to create the following workflow.

![Workflow Diagram]

2. Open the **Handlers** dialog box and select the **Start** task.

3. Add the **EPM-attach-related-objects** handler, as follows.

![Handler Configuration]

This action adds the markup object as a target. You can send an item revision or BVR to this workflow.

Sample 2
Use this sample if more than one markup object is related to a BVR and only one is the active markup object.

1. Use Workflow Designer to create the following workflow.
Note Do not add the EPM-attach-related-objects handler to the Start task because the markup object is a target of the workflow.

2. Copy the active markup and paste it as a specific target of the workflow process.

Sample 3

Use this sample if more than one markup object is related to a BVR and only one is the active markup object. If you revise the item revision, Teamcenter only carries forward the active markup and you can submit the new revision to the workflow process. For example, the following BVR is related to multiple markup objects, but only one markup object is active.
1. Use Workflow Designer to create the same workflow as described for sample 1.

2. Revise the item revision.
   Teamcenter carries forward the active markup and you can submit it to the workflow.

Sample 4

Use this sample if more than one markup object is related to a BVR and only one is the active markup object. It provides a sample workflow process that accepts an item revision or BVR with multiple markup objects for review, but only adds a **BOM Markup Approved** status to the active markup object.

If you select the item revision as the initial target, Teamcenter adds **BOM Markup Approved** status to the item revision, BVR, and the active markup objects. If you select the BVR as the initial target, Teamcenter adds **BOM Markup Approved** status to the BVR, and the active markup objects.
**Chapter 4**  
*Building and editing product structure*

**Note**  
A BVR may contain several markup objects, but only one of these objects can be active, as shown in the following example.

**BOMMarkup_Review process**

1. Use Workflow Designer to create a new **BOMMarkup_Review** process. Place a review task and a generic task between the **Start** and **Finish** tasks, as follows.

2. Select the **Start** task and click the **Task Handlers** button.

   Teamcenter displays the **Handlers** dialog box.

3. Verify that the **EPM_attach-item-revision-targets** handler is attached as follows.

4. Select the **Sub-process** task and click the **Task Handlers** button.

   Teamcenter displays the **Handlers** dialog box.
5. Add the **EPM-create-sub-process** under **Complete**, as follows.

6. Make the template available for use by selecting the **Set stage to available** check box.

**BOMMarkup_SplitTargets process**

1. Use Workflow Designer to create a new **BOMMarkup_SplitTargets** process. Add a condition task, two generic tasks, and an **OR** task between the **Start** and **Finish** tasks, as follows.

2. Select the **Start** task and click the **Task Handlers** button.

   Teamcenter displays the **Handlers** dialog box.

3. Verify that the **EPM-attach-related-objects** handler is defined under **Start** as follows. This action adds the markup objects as workflow targets.
4. Create a **Has Multiple Targets?** condition task that counts the number of workflow target objects and determines if there is more than one. Create this condition task with workflow handlers and a query object, as follows:

   a. In Query Builder, create the following query to check the value of the task result.
b. In Workflow Designer, select the **BOMMarkup_SplitTargets** template, and then select the **Has Multiple Targets?** condition task.

c. Click the **Attributes** button.
   Teamcenter displays the **Attributes** pane.

d. Click **Condition Query**.
   Teamcenter displays the **Condition Query** dialog box.

e. Select **BM-Has Multiple Targets?** and **Query Against - Task** as shown, and then click **Assign** to assign the query.

![Condition Query Dialog](image)

f. Close the dialog box.

g. Click **Display Settings** and ensure the **Attributes** dialog box shows the following settings.
h. Close the dialog box.

i. Ensure the Has Multiple Targets? condition task is still selected and click the Task Handlers button.

Teamcenter displays the Handlers dialog box.

j. Add the EPM-set-task-result-to-property handler under Start as follows. This reads the num_property task property and sets its value as the task result.

k. Verify that the EPM-set-condition handler is defined under Start as follows. (This handler was added in step b previously.)
5. Configure the **Single Target** task to start the **BOMMarkup_AddStatus** subprocess. Select **Single Target** and click the **Task Handlers** button. Teamcenter displays the **Handlers** dialog box.

6. Create the **EPM-create-sub-process** handler under **Complete** as follows.

7. Configure the **Multiple Targets** task to start the **BOMMarkup_AddStatus** subprocess for each target. Select **Multiple Targets** and click the **Task Handlers** button. Teamcenter displays the **Handlers** dialog box.

8. Create the **EPM-create-sub-process** handler under **Complete** as follows.
9. Make the template available for use by selecting the **Set stage to available** check box.

**BOMMarkup_AddStatus process**

1. Use Workflow Designer to create a new **BOMMarkup_AddStatus** task. Add two condition tasks, two **OR** tasks, and an **Add Status** task between the **Start** and **Finish** tasks, as follows.

2. Select the **Start** task and click the **Task Handlers** button.

   Teamcenter displays the **Handlers** dialog box.

3. Verify that the **EPM-attach-related-objects** and **EPM-attach-item-revision-targets** handlers are not defined under **Start** as follows. It is not necessary to add or introduce more targets to the subprocess.
4. Create a **BM – Is Markup Object?** condition task that checks if the target object is a markup object. (The process expects only one target object.) It does this by checking the `object_type` property value of the markup object with a query that you create as follows.

   a. In Query Builder, create the following query.
b. In Workflow Designer, select the **BOMMarkup_AddStatus** template, and then select the **BM – Is Markup Object?** condition task.

c. Click the **Attributes** button.

Teamcenter displays the **Attributes** pane.

d. Click **Condition Query**.

Teamcenter displays the **Condition Query** dialog box.

e. Select **BM-Is Markup Object?** and **Query Against - Task** as shown, and then click **Assign** to assign the query.
f. Close the dialog box.

g. Click **Display Settings** and ensure the **Attributes** dialog box shows the following settings.
h. Close the dialog box.

i. Ensure the **BM – Is Markup Object?** condition task is still selected and click the **Task Handlers** button.

Teamcenter displays the **Handlers** dialog box.

j. Verify that the **EPM-set-condition** handler is defined under the **Start** folder as follows.

5. The **BM – Is Markup Active?** condition task checks if the markup object is active. It does this by querying the **find0active** property value of the markup object.

a. In Query Builder, create the query as follows.
b. In Workflow Designer, select the `BOMMarkup_AddStatus` template, and then select the **BM – Is Markup Active?** condition task.

c. Click the **Attributes** button.
   Teamcenter displays the **Attributes** pane.

d. Click **Condition Query**.
   Teamcenter displays the **Condition Query** dialog box.

e. Select **BM – Is Markup Active?** and **Query Against - Target** as shown, and then click **Assign** to assign the query.
f. Close the dialog box.

   g. Click **Display Settings** and ensure the **Attributes** dialog box shows the following settings.
Building and editing product structure

h. Close the dialog box.

i. Ensure the **Is Markup Object?** condition task is still selected and click the Task Handlers button.

   Teamcenter displays the Handlers dialog box.

j. Verify that the **EPM-set-condition** handler is defined under the Start folder as follows.

   ![Diagram of the Handlers dialog box]

6. The **Add BOMMarkup Approved Status** condition task adds the **BOMMarkup Approved** status to the target object, which may be an item revision, BVR, or active markup object.

   **Note**  
   **BOMMarkup Approved** is not a standard status type. It is created for this workflow to ensure the system can write to the workflow’s target objects after the approval process.
a. In Workflow Designer, select the **Add BOMMarkup Approved Status** status, and then click the **Attributes** button  

Teamcenter displays the **Attributes** pane.

b. Enter a **Release Status** of **Fnd0BOMMarkupApproved** as follows.

![Attributes pane](image)

- **Named ACL:**
- **Task Type:** EFMAddStatusTaskTemplate
- **Icons:**
- **Release Status:** Fnd0BOMMarkupApproved
- **Duration:**
- **Recipients:**

Select **Show Task in Process Stage List**.

![Attributes pane](image)

- **Show Task in Process Stage List**

![Attributes pane](image)

- **Show Task in Process Stage List**

- **Set**
- **Set**

(c) Ensure the **Add BOMMarkup Approved Status** status is still selected and click the **Task Handlers** button  

Teamcenter displays the **Handlers** dialog box.

d. Verify that the **EPM-create-status** handler is defined under the **Start** folder as follows.

![Handlers dialog box](image)

- **Task Action:** Start
- **Action Handler:** create-status
- **Argument:** Fnd0BOMMarkupApproved

7. (Optional) In Access Manager, create a write operation in the rule tree for **status=BOMMarkup Approved**. This setting allows you to apply markups to the product structure after the review and approval process.
8. Make the template available for use by selecting the **Set stage to available** check box.

## Defining units of measure

Unit of measure is an attribute of the item. In Structure Manager, you specify the value of the **Quantity** occurrence property in the units of measure for the component item (for example, 1.5 L for an Oil item). Alternatively, you can specify the unit of measure as **each**, that is, a numerical value. In this case, you must specify the value as a whole number (for example, 500).

For more information, see *Creating aggregate occurrences and defining quantity*.

You can optionally specify a quantity for a structure line in a user-defined unit of measure. To enable this option, the administrator sets the **Fnd0PSEQtyConversionDSName** and **Fnd0PSEEnableQtyConversionUOM** Business Modeler IDE constants and creates an XML file specifying all UOM conversion rules that are valid at your site.

For more information, see *Define unit of measure* and *Configure units of measure*.

You cannot change the unit of measure after any revision of the item is released or is used in the structure.

**Note** When you add a line to the structure, its unit of measure (UOM) is initially the same as the default UOM for the corresponding item type. You can subsequently change the UOM of the line, if appropriate.

If the default UOM of the item is not **each**, you cannot change the UOM of the line to **each**.

Teamcenter considers the UOM of the line when displaying a quantity value. If the UOM of the line is **each**, it displays the quantity value as an integer; otherwise, it displays a floating (real) value.

By default, Teamcenter displays quantities with a maximum of two decimal places. However, your administrator can change the number of decimal places by editing the **Displayed_Decimals_for_Qty** preference.

When customizing Teamcenter, the special UOM value **each** is reserved. If you add another **each** value, the default Teamcenter behavior may change.

For more information about adding units of measure to Structure Manager, see the *Business Modeler IDE Guide*.

### Define unit of measure

1. Double-click the **Quantity** property of the affected BOM line.

   Teamcenter displays the **Edit Quantity** dialog box.

2. Type the required value in the **Quantity** box and select a UOM from the **Unit Of Measure** list.

   Teamcenter converts the value you entered to the default item UOM and displays it for verification. For example, if the default item UOM is grams, when you enter a quantity of 2 and select a UOM of **lb (pound)**, it displays **907** grams.
3. Click **OK** to save the quantity in the database. The quantity is stored in the database in the item UOM, not the user-selected UOM.

**Managing global alternates**

A *global alternate* part is interchangeable with another part in *all* circumstances, regardless of where the other part is used in the product structure. A global alternate applies to any revision of the part and is independent of any views.

Parts and their global alternates are related only in a single direction. For example, if part **A** has three global alternates (parts **B**, **C**, and **D**), then **B**, **C**, and **D** are each a global alternate of **A**. However, part **A** is not an alternate of **B**, **C**, or **D**, as shown next.

![Diagram showing global alternates](image)

**Global alternates – single direction**

One part can be a global alternate of more than one other part. For example, part **B** may be a global alternate of parts **E** and **F**, as well as a global alternate of part **A**, as shown next.

![Diagram showing global alternates](image)

**Global alternates – multiple alternates**

Global alternate relationships are not shared. For example, part **C** is not a global alternate of part **B**, even though they are both global alternates of part **A**, as shown next.
Global alternates – nonsharing
Likewise, global alternate relationships are not chained. For example, if part B is a global alternate of part A, and part C is a global alternate of part B, part C is not a global alternate of part A, as shown next.

Global alternates – chaining

List global alternates

1. Select a line in the product structure. If it has global alternates, this is indicated by the symbol.

2. Click Global Alternates at the bottom of the pane.
   Teamcenter displays the Global Alternate dialog box, which lists all the global alternatives of the selected item. The preferred global alternate (if any) is marked with a check mark.

   Note: You can also list global alternates in My Teamcenter.

Add global alternates

1. List the global alternates (if any) of the item for which you want to add one or more global alternates, as described in List global alternates.

2. In the Global Alternate dialog box, click Open.
   Teamcenter displays the Open by Name dialog box.

3. Search for the item that you want to define as a global alternate of the selected item.

4. If you want to define more than one global alternate of the selected item, repeat the previous step for each global alternate.
You cannot add the same item as the global alternate more than once. Teamcenter displays a **Cannot create duplicate alternates of same item** message if you attempt this action.

**Remove global alternates**

1. List the global alternates of the item from which you want to remove one or more global alternates, as described in *List global alternates*.

2. In the **Global Alternate** dialog box, select one or more global alternates to remove and click **Remove**.

   Teamcenter removes the selected global alternates from the list.

   **Note** If you remove all the global alternates from an item, the corresponding line in the product structure no longer shows the 🌓 symbol.

**Set or unset preferred global alternate**

1. List the global alternates of the item from which you want to remove one or more global alternates, as described in *List global alternates*.

2. In the **Manage Global Alternates** dialog box, select a global alternate and click **Prefer**.

   Teamcenter designates the selected global alternate as preferred and places a check mark next to it in the list.

   To remove the preferred designation from a global alternate, select it and click **Prefer** again. Teamcenter removes the check mark next to it in the list of global alternates.

**Changing components**

Any modification you make to the product structure changes the BOM view revision in the parent assembly. Modifications that change the BOM view include adding, deleting, or substituting components; adding a substitute component; or changing any of the occurrence attributes, for example, a note or find number.

You must have write access to the BOM view revision to make such modifications. You may not have write access for one of several reasons, including:

- Another user is modifying the BOM view revision and the changes are not yet saved. In this case, Teamcenter displays an error message, stating who is currently modifying the BOM view revision.

- The BOM view revision is protected against write access, for example, because it is released.

When you choose **File→Save As** for a selected item revision, Teamcenter creates a physical copy of the BOM view revision.
Remove components

1. Select the component or group of components to remove from the product structure tree.

2. Choose Edit→Remove, or press Ctrl+R.

   Teamcenter removes the selected components from the structure. If you select a line that has substitutes, these are also removed.

   **Note** This action does not place the selected line or lines on the clipboard.

Move a component to another assembly

1. Select the component or group of components to move to another assembly.

2. Click Cut on the toolbar, choose Edit→Cut, or press Ctrl+X to place the selected components on the clipboard. Teamcenter grays out the affected component lines.

3. Select the target assembly.

4. Click Paste on the toolbar, choose Edit→Paste, or press Ctrl+P. New component lines appear under the selected assembly, and the grayed-out lines are removed from the structure.

   **Note** Lines grayed out after a Cut command are not actually removed from the structure until you paste them elsewhere in the structure. If you place another object on the clipboard before pasting, the grayed-out lines are restored to their previous state and are removed from the clipboard.

Replacing a component

You can make the following replacements in a product structure:

- Replace a component without losing the occurrence data.

  You can change an item revision in an assembly by cutting out the old item revision and pasting in the new item revision. However, this method breaks the occurrence link to the old component, so you lose any occurrence attributes including notes and the find number of the old component. A replacement retains the occurrence data.

- Change the revision of a component item in precise assemblies.

- Change the view type.

  If the component has multiple views and you want the parent assembly to reference a different view, you can edit the parent assembly to change the view type.

You cannot replace one component with two or more components. However, you can select multiple components and replace each with a single component.
Teamcenter does not verify if the replacement request is valid for your business data. If necessary, check the validity of the replacement action with the Teamcenter administrator.

Replace a component

1. Select the component to replace in the product structure.

2. Optionally, copy the replacement component to the clipboard. This action prepopsulates the Replace Component dialog box with the item identifier and revision of the replacement component.

3. Choose Edit→Replace....

Teamcenter displays the Replace dialog box. The lower pane of the dialog box contains details of the selected component to replace.

4. In the upper pane of the dialog box, enter the item identifier of the replacement component. If you copied the replacement component to the clipboard, the item ID and revision boxes are already populated with those of the copied component. You can change the identifier if required, but not the item name; the item name is derived from the item identifier you enter.

Note If you specify an item identifier that is shared by multiple objects, Teamcenter displays the Select Unique Item dialog box allowing you to select the object you require.

You can specify a revision in some circumstances, depending on whether the parent assembly BOM view revision of the component replaced is precise or imprecise:

- If the BOM view revision of the parent assembly is precise, you can specify a revision. In this situation, you can use the replace command to replace one component item revision with another item revision or to replace the component with a revision of a different item. If an item is taken from the clipboard, Teamcenter determines the revision by the revision rule.

- If the BOM view revision of the parent assembly is imprecise, you cannot specify the revision. In this situation, you use the replace command to replace one component item with another item.

If there is not a revision that satisfies the revision rule when you add the component to the structure, Teamcenter displays the revision as ???.

5. Optionally, use the bottom section of the Replace Component dialog box to change the scope of the replacement by clicking one of the following:

- Single Component
  Replaces only the selected component.

- All in Parent Assembly
  Replaces all components of the selected item revision that are in the parent assembly.
If the component to replace has multiple views, Teamcenter uses the default view type. If no default is defined, Teamcenter displays an error message and you must specify a view type in the Replace... dialog box.

Alternatively, to replace one or more items (parts) or item elements for another:

1. Select one or more source lines that represent items or item elements, and choose Edit→Copy.

2. Select target lines that represents the same types of item or item element and choose Edit→Paste. If you copied more than one source line to the clipboard, but only selected a single target line, Teamcenter displays the Select Object for Replace dialog box. Otherwise, it replaces the targets with the sources and updates the find numbers, as appropriate. If you attempt to replace an item or item element with a line of another type, Teamcenter displays an error message and does not replace any of the selected lines.

3. If Teamcenter displays the Select Object for Replace dialog box, select the required source from those listed and click Replace.

Change add and delete operations to a replace operation

During prototyping or other changes, you may delete an item or part and subsequently add another item or part in the product structure.

To convert the separate delete and add operations into a single replacement operation during BOM comparison:

1. Open two product structure windows side-by-side and configure two different BOM view revisions (BVRs) showing the individual operations. For example, configure a BVR showing the deleted part in one window and a second BVR showing the added part in the second window.

2. Select the deleted and added parts and choose Edit→Change To Replace.

Teamcenter converts the individual delete and add operations into a replacement operation, replacing the occurrence thread of the added part with the occurrence thread of the deleted part to keep the same occurrence thread.

Defining substitute components

Substitute components are parts that are interchangeable with a particular component in an assembly. Substitutes are often defined for manufacturing purposes, allowing use of the substitute if the preferred part is unavailable, for example, due to a stock shortage.

You define a substitute for a single occurrence in an assembly and not for an item. In general, you control a change to an item of this nature by making the changes selectively for each assembly, using a where used search to identify each instance of the item. Do not use substitutes to address marketing variations of a product—use variants or modular variants for this purpose.

You can define more than one substitute for each component. One of the substitutes is designated the preferred substitute and is displayed in the structure. You can see the other substitutes by clicking the List Substitutes button. You can change the preferred substitute at any time.
When a primary part has one or more substitutes, you can display all the substitute parts as siblings of the preferred structure line directly below the primary part. You can then easily compare, edit, or remove the substitutes. You can enable the display of substitutes on separate lines by setting the `PSEShowSubstitutesPref` preference.

**Note** If you are working in NX and perform a rollup calculation (for example, cost or weight), the calculation uses the preferred substitute.

If you add a substitute, you modify the BOM view revision and you consequently must have write access to the BOM view revision. You can change the preferred substitute any time during a session (for example, to view the change in NX), but you can only save the change if you have write access to the BOM view revision.

Substitutes of one occurrence all share the same occurrence attributes, for example, find number, quantity, and notes, as specified for the substituted part.

Substitute components are item revisions in a precise assembly and items for an imprecise assembly. In an imprecise assembly, the revision rule selects the correct revision of a substitute component.

If you drag and drop BOM lines and there are substitutes in the selection, the drop operation ignores the substitutes and only copies the primary BOM lines.

When you pack BOM lines with substitutes, the substitute lines associated with the pack master are displayed as its siblings. A group of BOM lines can be packed only if they have the same set of substitutes. The pack count for the preferred BOM line includes the substitutes. For example, if a packed BOM line contains three BOM lines and each of the BOM lines has one substitute part, the pack count is shown as six. If the primary BOM lines do not have the same substitutes, you cannot pack those BOM lines.

When a BOM line is packed, adding a substitute to the packed line recursively adds the same substitutes to all of the occurrences. Likewise, removing a substitute from the packed line recursively removes the substitute from all of the occurrences.

You cannot add substitute BOM lines to substitute groups.

BOM rollup report calculations exclude substitute lines.

When BOM markup is enabled, added or removed substitute lines are marked.

### Display substitute components for a line

Teamcenter identifies the lines in the product structure with substitute components by a 🕵️ symbol. If the line has substitute components, it has the `Has Substitutes` property set to `Y`.

1. Select the line in the product structure tree.
2. Click **List Substitutes 🕵️**.

   Teamcenter displays the **List Substitutes** dialog box. This allows you to view the available substitutes.

   If a substitute part has an underlying structure, it is still represented as a leaf part when displayed as a separate substitute line.
Display substitutes as separate lines

1. Set the value of the PSEShowSubstitutesPref preference to 1.
2. Load the structure that has substitutes defined for primary items.
   Teamcenter displays substitutes as separate lines at the same level as the corresponding primary items. For example:

```
!002827/141-Item1  Item Preferred  002827, 002828
!002827/141-Substitute1 (View) Item Substitute
!002829/141-Substitute2  Item Substitute
```

Create substitute component

1. Copy the substitute item revision to the clipboard in Structure Manager or another application.
2. Select the line in the product structure in Structure Manager for which you want to define this item revision as a substitute.
   You can also add a substitute to more than one line in a single operation by selecting all the necessary line. If the lines are packed, unpack them before you select them.
3. Choose Edit→Paste Substitute to paste the substitute directly. You can also choose Edit→Paste Special and click As Substitute of Selected Line in the resulting dialog box.

You can also type in the item identifier of the substitute directly, by selecting the line in the structure, choosing Edit→Add..., and clicking As Substitute of Selected Line in the resulting dialog box.

Edit the properties of a substitute

If you display substitutes as separate lines, follow this procedure:
1. Load a product structure with substitutes defined for the primary items.
2. Select the substitute you want to edit, and make your modification in the data pane.
   Teamcenter saves the edited properties.

   **Note** You must have necessary permissions to edit substitute parts.
   For substitutes, there are no occurrence properties. You can only edit properties for items, item revisions, and master forms.
   You cannot make in-context edits or create incremental change data for substitute lines.

Compare substitutes

If you display substitutes as separate lines, follow this procedure:
Chapter 4  Building and editing product structure

1. Load the product structures with substitutes that you want to compare in two separate BOM windows.

2. Choose Tools→Compare.
   The BOM Compare dialog box appears.

3. Select the desired report options and the Single level (with substitutes) mode, and then click Apply.
   Teamcenter generates a BOM Compare report that compares the substitute parts as well as the primary parts.

   **Note**  You can only compare substitute parts with other substitute parts, not with primary parts.
   If you choose any other comparison mode, the results may be incorrect.

Removing substitute components

You can remove a substitute part that has related substitutes from the product structure. When you do this, Teamcenter:

- Notifies you about all the related substitute parts of the selected substitute.
- Notifies owners of the parent BVRs of all related parts by Teamcenter e-mail.
- Changes or removes all relations in which the selected substitute parts participate to ensure consistency.
- Removes the selected substitute part from the substitute part list.

Remove a substitute component

If you do not display substitutes as separate lines, follow this procedure:

1. Select the required line in the product structure tree.

2. Click List Substitutes.
   Teamcenter displays the List Substitutes dialog box.

3. Select the substitute component you want to remove and click (Remove) or choose Edit→Remove.
   You can also press Shift+Ctrl to select more than one substitute in the list for removal. If you remove all listed substitutes, the line in the product structure is no longer marked as having substitutes.

If you display substitutes as separate lines, follow this procedure:

1. Load the structure that has substitutes defined for primary items.

2. Select the substitute line and choose Edit→Remove.
   A confirmation dialog box appears.

3. Click Yes.
Teamcenter removes the substitute line from the structure.

This action only removes the substitute from the substitute list of the primary part. It does not delete the underlying part.

**Change the preferred substitute**

1. Select the required line in the product structure tree.
2. Click the List Substitutes. Teamcenter displays the List Substitutes dialog box.
3. Select the item to be the preferred substitute and click Prefer. Teamcenter displays the item identifier of the selected substitute and adds the original preferred substitute to the list.
   Alternatively, you can right-click the required line and click Set Preferred Substitute to display a list of the substitute components. Click the new preferred substitute.
4. If you have write access to the BOM view revision, you can save this change to the structure. If you do not have write access, Teamcenter warns that you cannot save the preferred substitute but you can make a temporary change. The ability to make a temporary change is useful if you want to visualize one of the nonpreferred substitutes in the structure.

**Managing substitute part relationships**

You can define and edit substitute part relationships to manage dependencies between substitute part selections. You can also define optional parts according to size selections.

**Relating substitute parts**

If there are dependencies between substitute part selections, you can relate the substitute part of one occurrence with substitute parts of the other occurrence. You can define these relationships for any occurrence in any BOM view revision.

Such relationships are bidirectional. For example, you can relate substitute A of the lower bearing in the product structure to substitute B of the upper bearing, if the selection of B depends on the current selection of A. The same dependency applies to the selection of B as the upper bearing; that is, A must always be the lower bearing if B is selected as the upper bearing, and B must always be the upper bearing if A is selected as the lower bearing. However, Teamcenter does not enforce this relationship, if you choose to override it in a particular structure configuration.

To relate substitutes, you must have write access to the parent BOM view revisions of the selected lines. If you do not have permission to modify either of the parents, you cannot relate the substitute parts.

**Relate substitute parts**

1. In the product structure tree, select the two lines that represent the applicable occurrences and choose Tools→Related Substitute→Relate.
Teamcenter displays the View/Create Related Substitutes dialog box.

2. Verify the parent lines and selected substitute items are those you want to relate. You can also click the Preview button to check the relation to be created.

3. When you are satisfied that the correct relationship is selected, click the Create button to confirm the selection.

Teamcenter creates the relationship between the proposed substitutes and saves it in the database; it is not necessary to explicitly save changes to the product structure. If you create an incorrect relationship, click the Reset button to reset the changes.

**Note** The Related Substitutes menu command is only visible if your site administrator sets the PSE_enable_related_substitutes preference to True.

When you save a product structure that includes related substitute parts as a new structure, all substitute part relations are carried forward.

**Relate substitutes with existing substitutes**

1. Click the Preview button before you create the relation to verify if previous relations exist and their effect on the relation you propose to create.

For example, the 000005 Substitute A for Lower Bearing line in the BVR is already related to the 000014 – Substitute A for Fuel Pipe line. If you try to relate the 000005 Substitute A for Lower Bearing line to another line, 000006 Substitute A for Upper Bearing, and click the Preview button, Teamcenter displays the following new relation:

```
000002/A-view:000003:10 ->000005 - Substitute A for Lower Bearing
000002/A-view:000003:20 ->000006 - Substitute A for Upper Bearing
000012/A-view:000013:150 ->000014 - Substitute A for Fuel Pipe
```

2. Click the Create button to commit the relation. In the previous example, Teamcenter relates substitute A for the lower bearing, substitute A for the upper bearing and substitute A for the fuel pipe.

**Edit a substitute part relationship**

You can change or remove the relationship between substitute related parts, as follows:

1. In the product structure tree, select a structure line with related substitutes and choose Tools→Related Substitutes→Relate.

Teamcenter displays the View/Create Related Substitutes dialog box.

2. Click the Show Related button.

Teamcenter shows all the related substitute parts for the selected substitute in the right-hand pane of the dialog box.

3. Select the relation to edit and click the Cut button to remove it, or click the Modify button to change the relation.
To modify substitute part relationships, you must have write access to the parent BOM view revisions of the selected lines. If you do not have permission to modify either of the parents, you cannot modify the substitute part relationships.

**View the related substitutes of a selected structure line**
- Choose Tools→Relate Substitutes→View Related.

Teamcenter displays all defined relations in a dialog box for information purposes; you cannot change the relations in this dialog box.

**Exporting substitute data**
- You can export substitute component data in a structure to an external system. To do this, your administrator must add the appropriate closure rule to the transfer mode, as described in the PLM XML/TC XML Export Import Administration Guide. You must choose this transfer mode each time you export substitute component data.

**Add or remove optional parts**

You can define optional parts for any occurrence and its substitute parts. Optional parts are selected according to their size. A part may have both substitutes and optional parts. A substitute part (including the preferred substitute) may have optional parts.

**Note** Size-selected optional parts are attachments to an occurrence. You cannot view or configure them into the product structure.

1. Choose Tools→Relate Substitutes→Optional Parts.

Teamcenter displays the Optional Parts dialog box that lists any lines with previously defined optional parts.

2. To add an optional part, select the structure line, click the Add button and Teamcenter displays the Add Optional Part dialog box. You can then enter or browse for the item identifier and name of the component to add as an optional part. To remove an optional part, select the line and click the Remove button.

**Exporting a product structure containing related parts**

You can export a product structure that contains related substitute parts or optional parts in PLM XML format.

For details of PLM XML import and export, see the PLM XML/TC XML Export Import Administration Guide.

**Export a product structure to Briefcase**

You can export a configured product structure in PLM XML format.
If Data Exchange is installed at your site, you can export a configured product structure to a Briefcase file to share with a partner or supplier.

You can export:

- Product structures that are configured by a revision rule, variant rule, and incremental change.
- Product structures that are partially configured by only a revision rule and a variant rule is not applied.
- Precise or imprecise product structures.
- Notes, attachments, absolute occurrences and overrides, alternates, substitutes, and generic design elements (GDEs) included in the product structure.
- Systems Engineering and Mechatronics Process Management objects included in the product structure, for example, trace links and signals.

1. Select the top line of the product structure to export and choose **Tools→Export→To Briefcase**.
   Teamcenter displays the **Export To Briefcase Via Global Services** dialog box.

2. Click ☑️ in the bottom right-hand corner of the dialog box.
   Teamcenter displays the **TIE Export Configured Export Default** dialog box.

3. Select the check box corresponding to each of the export options you want to use and then click **OK**.
   Teamcenter closes the **TIE Export Configured Export Default** dialog box.

4. In the **Export To Briefcase Via Global Services** dialog box, enter all the required information including **Reason**, **Target Sites**, **Option Set**, **Briefcase Package Name**, **Revision Rule**, and **Variant Rule**, and then click **OK**.
   Teamcenter displays a **Remote Export Options Setting** confirmation dialog box.

5. Click **Yes**.
   Teamcenter starts the export of the product structure using the options you entered.

For more information about configuring export of configured product structures, see the **Data Exchange Guide**.

**Export datasets with structure information**

You can export multiple dataset types in an assembly in one operation, as follows:

1. Open the assembly structure in the Structure Manager application and specify the appropriate revision rule and variant condition.

2. Select the structure line representing the assembly in the product structure.
To export *without* structure information, open the item or item revision. When you choose an item, Teamcenter identifies the item revision from the default revision rule.

3. Choose **Tools→BOM→Export**.

Teamcenter displays the **Export to Connection** dialog box.

**Note** The **Export to Connection** menu command is available in Structure Manager only if at least one application is registered to which you can export data.

4. Enter the following information in the dialog box:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select an existing connection</strong></td>
<td>A root directory is shown according to the preset preference for the root directory location. You must define a unique connection name. Choose the <strong>Select an existing connection</strong> command to use a previously-defined connection or choose the <strong>Create a new connection</strong> to define a new connection.</td>
</tr>
<tr>
<td><strong>Create a new connection</strong></td>
<td></td>
</tr>
</tbody>
</table>

**Export Rule:**

- **Add**
  
  Adds the primary file of the dataset to the connection.

- **Resend**
  
  Reexports the selected file and all secondary files with attribute information to the connection directory. Any existing files are overwritten. Only use **Resend** if you made an error in modifying the files and you want your export data identical to that in Teamcenter.

- **Refresh**
  
  Checks if the selected file is modified in Teamcenter since the export to connection. If so, Teamcenter exports the selected file and sends the latest attribute information. It then ensures all the components of the selected files are in the connection by invoking **Add** for each component file.

**Dataset Type**

Lists all the dataset types that are registered and can be exported, if they appear in the assembly structure. You can:

- Select a single dataset type to export.
- Select several dataset types to export.
- Select all dataset types to exported. Enter **All** to export all known dataset types.
Chapter 4  Building and editing product structure

Once you make the necessary selections, the top structure line appears. It can be configured and expanded, if necessary.

5. Check the appropriate boxes in the dialog box and click OK to initiate the export operation:

   **Skip**  Select none of the boxes. Teamcenter exports the selected datasets under this line.

   **Export**  Select only the Export box. Teamcenter exports the selected datasets under this line but does not check them out (makes a read only copy).

   **Export+CO**  Select the Export and CO boxes. Teamcenter exports the selected datasets under this line and checks them out (makes a read/write copy).

   **Note**  A checkout can be performed only if you have write access to the dataset.

Add parts to NX

You can add parts from the product structure and paste them into an assembly in NX, as follows:

1. Find the parts to add to NX. These may be individual parts outside the context of any assembly (items or item revisions) or parts in the context of an owning assembly (structure lines).

   To find individual parts, such as brackets or seals, and send them or item revisions to NX without any assembly context information:

   a. Browse through your product structure or perform a Classification search to locate the parts.

   b. Select the required items or item revisions and copy them to the clipboard.

2. Copy the items, item revisions or structure lines from the Teamcenter clipboard to the NX clipboard by right-clicking the clipboard symbol in the lower right corner of the Structure Manager window and choosing **Send clipboard contents to NX**.

   The item revisions and/or lines on the rich client clipboard are then transferred to the NX clipboard.

   **Note**  Only item revisions, not items, are sent to NX. If the clipboard contains any items, Teamcenter identifies the latest working item revision corresponding to each item and sends them to NX instead.

3. Once you transfer the parts to the NX clipboard, add them to an assembly in NX using one of the NX paste options. The parts become components at the currently selected level in the NX assembly. Because a structure line has positioning information, the corresponding new components are positioned according to the spatial information stored in Teamcenter and, consequently, the parts are positioned correctly regardless of the currently selected level in the NX
assembly. Items or item revisions have no inherent positioning information, so the corresponding new components are positioned at a default location.

If the pasted item revision represents an assembly, Teamcenter Integration for NX loads the corresponding assembly, and adds it as a subassembly under the current NX assembly. Depending on the NX load options, this operation may load any additional parts referenced by the pasted assembly.

For an example of how to add assemblies to NX, see the following figures. This example assumes you load assembly A into NX and decide to add mounting hardware. Having searched Teamcenter for the mounting hardware, you decide assembly E is appropriate, and copy its item revision to the clipboard.

Note that you do not copy parts F and G to the clipboard, only part E.

---

**Before pasting assembly E in NX**

After sending E to the NX clipboard, you can paste it under assembly A, and the result is the assembly hierarchy shown in the following figure. Note that E was the only item revision explicitly pasted into NX; parts F and G were implicitly loaded because they are referenced by E.

---

**After pasting assembly E in NX**

---

**Using item elements**

An item element (sometimes called a general design element) represents an interface, characteristic or feature of a component in the structure. For example, it may represent a weld point on a bracket that is welded to a parent assembly. The item element is shown in the product structure as a separate line under the associated component and is represented by the image.
Chapter 4  Building and editing product structure

Create an item element

1. Select the assembly in the product structure with which you want to associate the item element.

2. Choose File→New→Item Element.
   Teamcenter displays the New Item Element dialog box.

3. Enter the name of the item element and click OK.
   Teamcenter creates the new item element and adds it as an item element line in the product structure.

   **Note**  You cannot create a new item element by copying an existing item element. Consequently, the File→SaveAs and File→Save As→Bom View Revision menu commands are not available when an item element is selected.

Remove item elements

1. Select the item element you want to remove from the product structure.

2. Choose Edit→Remove.
   Teamcenter displays the Removing Lines dialog box.

3. Click OK to confirm removal of the selected item elements.

Copy and paste item elements

You can copy and paste item elements in the same way as other lines in the product structure.

To copy an item element, choose Edit→Copy to copy a selected item element to the clipboard.

To paste an item element, choose Edit→Paste to paste a copied item element from the clipboard into the product structure.

Replace item elements

1. Select one or more item elements (source lines) from the structure and choose Edit→Replace.

2. Select one or more (item elements) target lines in the structure and choose Edit→Paste.
   If you copied more than one source line to the clipboard, but only selected a single target line, Teamcenter displays the Select Object for Replace dialog box. Otherwise, it replaces the target item elements with the source item elements and updates the instance numbers, as appropriate. If you attempt to replace a target item element with a source item element of another type, Teamcenter replaces only those lines where the source is a subtype of the target type. Otherwise, it displays an error message and does not replaces any lines.

3. If Teamcenter displays the Select Object for Replace dialog box, select the required source item element from those listed and click Replace.
View notes on item elements

You can view a note associated with an item elements, select the item element and choose View—Notes.

Creating connections and links

You can create connections or links between item elements in the product structure. Connections can be revised if their characteristics change; links are nonrevisable and cannot be updated.

Create a connection

To create a connection between lines with a PSConnection relationship:

1. Choose File—New—Connection—Revisable to create a revisable connection.
   Teamcenter displays the New Connection wizard.

2. Choose the connection type and its options, then click Finish.
   Teamcenter creates the connection as an item element.

3. Select the lines in the product structure you want to connect and the connection, then choose Tools—Connection Manager—Connect.
   Note You can also right-click the lines and choose Connect.

Create a link

To create a link between lines with a GDELinkLine relationship:

1. Choose File—New—Connection—Non-Revisable to create a non-revisable connection (link).
   Teamcenter displays the New Link wizard.

2. Enter a name and description, then click Finish.
   Teamcenter creates the new link.

3. Select the lines in the product structure you want to link and the link, then choose Tools—Connection Manager—Connect.
   Note You can also right-click the selected lines and choose Connect.

Remove a connection or link

1. Select the lines in the product structure you want to disconnect. You cannot remove a connection or link if the top line of the structure is connected.

2. Choose Tools—Connection Manager—Disconnect to remove the connection or link between the selected lines. You can also right-click the lines and choose Disconnect.
Creating and editing notes

Teamcenter allows you to attach notes to items or item revisions. These notes contain additional documentation about parts or documents. For example, a note may contain the following instructions:

Round all sharp corners to [Radius: 0.01, 0.02, 0.03] inch
and heat-treat to [Temperature: 100, 120, 130] degrees Fahrenheit

The following types of note are available:

- **Standard note**
  Contains information established by a standards engineering organization. It conforms to the design practices of a program or project, is stored in a library, and is available to all participating engineers. A standard note is sometimes called a *parametric requirement*.

- **Custom note**
  Contains information that is unique to an individual part or document. It is not stored in a library. A custom help can only be attached to a single item or item revision.

**Note**  Do not confuse standard notes and custom notes attached to items or item revisions with *occurrence notes*.

For information about occurrence notes, see *Displaying occurrence notes*.

For detailed information about how to view standard notes or custom notes, see *Define or edit custom note text*.

**Define or edit custom note text**

1. Select a product structure line that represents an item or item revision with a standard note or custom note attached to it.

2. Click the **Show/Hide Data Panel** button on the toolbar.
   Teamcenter displays the data pane.

3. On the data pane, click the **Attachments** tab.
   Teamcenter displays any attachments to the selected line, including standard notes and custom notes.

4. Select the line that represents the note you want to define or edit.
   If the note is saved in rich text (RTF), it opens in Microsoft Word; otherwise, it is displayed as editable text fields.

5. For a standard note, make the necessary changes, then click **Apply** to save them.
   For a custom note in text format, edit the **Note Text** field, then click **File→Save** in Teamcenter.
   For a custom note in RTF format, edit the content with Microsoft Word and save the changes with Word's **Save** command.
Deleting items

You can delete a single selected item or you can recursively delete all items below a selected line. You must have read-write permissions to the item to successfully delete it.

**Note** Deleting an item occurs in two steps—removal of the line from the parent in Structure Manager and then deletion of the item from the database. If the deletion fails, the line is removed from the parent, but the item is not deleted from the database. (Deletions typically fail because the user does not have the necessary permissions.) You can search for the item, then copy and paste it back into the structure.

**Delete a single item from the product structure**

1. Select the item in the product structure.
2. Choose **Edit→Delete** or press the Delete key.
   Teamcenter displays a request for confirmation.
3. Click **OK** to confirm and remove the item from the product structure.

**Note** This action permanently removes the item from the Teamcenter database if you have read-write permissions to the item.

**Delete multiple assemblies or items**

You can delete all items in the product structure below a selected line. This process is called a **recursive deletion** and may be useful if you want to delete several nested assemblies or items from the structure at the same time.

When you request a recursive deletion, Teamcenter verifies if the items below the selected line can be deleted. You can only delete an item if it meets the following criteria:

- The item or one of its revisions is referenced by an occurrence of any view of any revision of any other item in the structure.

- The item and its revisions are not referenced by any other occurrences outside the structure.

- You have delete permission for the item and all its revisions.

- Neither the item or any of its revisions is checked out or otherwise locked.

**Caution** Only use recursive deletions on product structures that do not contain CAD data. CAD integrations, including the Teamcenter Integration for NX, may track dependencies at the dataset level, as well as at the item or item revision level. Such dependencies cause the recursive deletion to fail because of referential integrity violations. For structures containing CAD data, manually delete datasets and items from the top down in a hierarchical fashion when necessary.

1. Select the line in the product structure below which you want to delete all items and assemblies, then choose **Edit→Delete** or click the **Delete** button.
Teamcenter displays the **Delete** dialog box.

2. Click the **Recursive Delete** button.

   Teamcenter displays an **Explore Selected Component** dialog box. The **Recursive Delete** button appears only if you select a single item for deletion.

3. Select any associated objects to delete (for example, datasets) in the **Explore** dialog box and click **OK**.

   Teamcenter displays the dialog box listing items and any associated objects selected for deletion. The list of items includes both items that can be deleted and items that cannot be deleted. If Teamcenter determines that an item cannot be deleted, it displays the reason.

   If you set suitable types or relations with the **Type** or **Relation** buttons, Teamcenter automatically checks all these objects for deletion in the dialog box. Alternatively, you can click the **Select All** button to select all objects for deletion.

4. Click **Yes** in the **Delete** dialog box to begin deleting all applicable items and the selected associated objects.

   Teamcenter shows the status of the deletion process in the status bar.

   You can pause deletion process by clicking the **Stop** button at any time. You can terminate the deletion process by clicking the **Abort** button.

   When the deletion process is complete, Teamcenter displays an updated **Explore** dialog box. This contains a flattened list of all the items in the substructure of the originally selected item. Any duplicates are removed and any items that Teamcenter could not remove are indicated.

**Grading structures**

Teamcenter allows you validate that the design represented by the product structure contains only approved parts. This process is sometimes called **BOM grading**. Parts approved for use in one project or locale may not be approved for another project or locale. For example, a part may comply with a European standard but not a U.S. standard. Tracking such approvals manually is time-consuming, and this feature automates much of the effort.

Grading results are stored in a structure context associated with the validated product or assembly, and may be retrieved when required.

The grading process checks that each part (item revision) is valid under all conditions under the selected checker. If the structure contains subassemblies, it checks each part in the context of each subassembly. It also checks generic design elements (GDEs) if any are included in the structure.

For example, if you want to check that a product is valid for the U.S. market or the Asia market, the administrator may create the **checkAsiaComplianceRule**, **checkUSComplianceRule**, and **CheckPartIsApproved** conditions and assign them to business objects using verification rules. These conditions may be included in two separate checkers, as follows:

- Asia checker
  
  **checkAsiaComplianceRule** and **CheckPartIsApproved** conditions
• U.S. checker

`checkUSComplianceRule` and `CheckPartIsApproved` conditions

`CheckPartIsApproved` is a common condition and can be assigned to any checker.

For a checker to approve the entire structure, each part and subassembly must pass validation. Depending on your company's working practices, you may be able to request a temporary or permanent override on a failed or unknown part or subassembly to achieve an overall approval. Each such request must be authorized by a designated person, for example, a project manager.

**Note**  Before using this feature, the administrator must do the following:

- Create conditions and associate them with business objects using verification rules in Business Modeler IDE. A condition contains multiple expressions that evaluate part attributes to ensure they are approved.

  For more information, see the *Business Modeler IDE Guide*.

- Add the conditions to a checker in Validation Manager. Create a checker for every project, product, or locale against which you want to grade the structure. Only one BOM grading agent is permitted and all checkers must be included in that agent.

  For more information, see the *Validation Manager Guide*.

- Set the necessary preferences.

  For more information, see the *Preferences and Environment Variables Reference*.

**Run grading**

1. Configure the product structure and select the line that represents the context in which you perform grading. This may be the top line of the product or a subassembly line.

2. Choose **Tools→BOM Grading→Run**.

   Teamcenter displays the **Validation Agent Selection** dialog box.

3. Select the agent revision and desired checker, click ✅, and then click OK to begin grading.

   On completion, Teamcenter displays the BOM grading viewer. The **BOM Result** box shows the result for the complete structure, based on the results for individual parts.

**View grading results**

Use the BOM grading viewer to identify results that are out-of-date, due to changes to the checker, condition or assembly.

1. Select the structure line that was the context of the grading action and choose **Tools→BOM Grading→Show**.
Teamcenter updates the BOM grading viewer with the relevant validation results.

**Tip** You can filter the validation results with the **Checker**, **Target Type**, and **Condition** lists.

Examine the **Validation Name** and **Condition Name** property columns to identify the validation agent and condition used for validation.

2. Examine the **Result** property column to determine the validation status of each part, as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓</td>
<td>Pass.</td>
</tr>
<tr>
<td>✖</td>
<td>Fail.</td>
</tr>
<tr>
<td>🚨</td>
<td>Unknown or no data. If you modify the structure after running grading, the status of the affected parts is shown as unknown. This status may also indicate that the selected checker does not contain any condition that tested the part.</td>
</tr>
</tbody>
</table>

The **Detail Information** pane shows information about the cause of any failures.

3. (Optional) Filter the structure display by clicking one of the following buttons.

- 🚨: Filter overridden results in or out.
- 🚨: Filter unknown results in or out.
- 🚨: Filter pass results in or out.
- 🚨: Filter fail results in or out.

4. (Optional) Click 🚨 to rerun the validation at and below the selected level, rather than on the entire structure.

The results of a typical grading run are as follows.
Override grading results

1. Right-click the result in the table you want to override and choose **Create Override**.
   Teamcenter displays the **Create Override** dialog box.

2. Choose the override type (for example, **Temporary** or **Permanent**), the requested **Override State** (for example, **Passed**), the **Override Category**, the **Override Reason**, and the **Detailed Reason**.
   You must also choose the **Override Decision User** (any user with an **Override Approver** role) and then click **OK**.
   Teamcenter updates the **Override To State** column in the tree with the requested state. It also sends a Teamcenter mail to the selected override decision user.

3. The designated override decision user receives the mail, right-clicks the folder in the mail, and then chooses **Send To→BOM Grading Viewer**.
   Teamcenter opens the structure and highlights the line for which a result has an override request pending.

4. Right-click the result and choose **Override→Review**.
   Teamcenter displays the **Override Decision** dialog box.

5. Choose **Approve** or **Reject**, type any optional comments in the **Override Decision Comments** box, and then click **OK**.
   Teamcenter sends a mail containing the decision to the requesting user and updates the structure status. Similarly, if the override decision user updates or deletes the override request, Teamcenter also sends a mail message.

6. Repeat the previous steps for each additional part for which you want to override the grading status. You must request an override for one part at a time.
Grading for substance compliance

You can grade a structure or BOM for compliance with one or more regulations defined in a preconfigured compliance checker. Completing this task requires you have Substance Compliance installed on your system.

For more information, see the *Substance Compliance Solution Guide*.

Initiate compliance check

1. Select a part or assembly, and then choose **Tools→Initiate Substance Compliance Check**.
   Teamcenter displays the **Substance Compliance Check** dialog box.

2. Select one or more of the predefined regulations listed in the dialog box, and then click **OK**.
   Teamcenter starts the compliance check process and sends the request to the configured compliance checker.

Apply exemption from regulation

**Note** The compliance officer performs this procedure.

1. Select an item revision or structure line, and then choose **Tools→Apply Exemptions**.
   Teamcenter displays the **Apply Exemptions** dialog box.

2. Select one of the regulations listed in the dialog box, and then click **OK**.
   Teamcenter starts the exemption workflow and adds a new task to the compliance officer's worklist.

3. In the workflow viewer, the compliance officer selects one or more exemption with its expiry date, enters the reason for the exemption in the **Comments** box, and then clicks **Save** to complete the exemption workflow.

View material and substance dashboard

- Select a structure line and choose **Window→Show View→Other...→Material Management→Material and Substance Dashboard**.
  Teamcenter displays a list of the constituent materials and substances of the associated part or assembly.

View compliance dashboard

- Select a structure line and choose **Window→Show View→Substance Compliance→Substance Compliance Dashboard**.
  Teamcenter displays a summary report of the compliance status of the part or assembly.
Request substance declaration from vendor

1. Select one or more structure lines and choose Tools→Request Substance Declaration.
   Teamcenter starts a workflow that identifies all vendor parts associated with the part or assembly.

2. The compliance officer receives and completes a workflow task to review the vendor parts.
   Teamcenter sends the selected vendors an e-mail with two Microsoft Office Excel spreadsheets attached. One spreadsheet contains vendor part information and the other a list of materials and substance information.

   Note  Sending the Excel spreadsheets with list of materials and substance information is optional and is controlled by the SUBSCMPL_send_materials_list preference. If this preference is set to true, Teamcenter exports a list of all material revision instances, together with the material substance declaration request.

3. The vendor reviews and completes the spreadsheets, and then e-mails them back to the compliance officer.

Save structure change records
If you make changes to the product structure, you can save structure change records in Change Manager in one of two ways:

• Clicking the Save button on the menu bar. This button is disabled until you edit the structure.

• Updating the change record while opening the Supersedure dialog box as described below.

   To create structure changes records for an affected assembly sent to Structure Manager, click the toolbar button to open the Supersedure Definition dialog box; the assembly must be under change control. Teamcenter displays a dialog box asking if you want to update the change records. You can then create or update the existing changes, or leave them unchanged.

Link requirements
Use trace links to associate requirements with items, item revisions, and absolute occurrences that satisfy the requirements. To create, view, or delete trace links, and generate a traceability report, you must enable the trace link features.

For more information about requirements, trace links, and traceability reports, see the Systems Engineering Guide.

Note  This procedure sets the Tracelink_Edit_enabled preference to true. That setting also enables the trace link features in other Teamcenter applications such as My Teamcenter, Systems Engineering, and Multi-Structure Manager.
Chapter 4  Building and editing product structure

1. Choose Edit→Options.
   Teamcenter displays the Options dialog box.

2. Select Requirements Management.

3. Select the Tracelink Mode check box.

Create trace links

1. Select one or more source objects, for example, a requirement.

   Note: If you select only one source object, you can create trace links to multiple target objects. If you select multiple source objects, you can create trace links to only one target object.

2. Choose Tools→Trace Link→Start Trace Link, click the Start Trace Link Creation button on the toolbar, or right-click the selection and choose Trace Link→Start Trace Link.

   You can also choose Edit→Copy, click the Copy button on the toolbar, or right-click the selection and choose Copy.

3. Select one or more target objects, for example, an item, item revision, or absolute occurrence.

4. Specify the trace link subtype and name by doing one of the following:
   • To accept the default subtype and name, choose Tools→Trace Link→End Trace Link, click the End Trace Link Creation button on the toolbar, or right-click the selection and choose Trace Link→Trace Link→End Trace Link.

   • To assign a custom subtype and name:
     a. Choose Tools→Trace Link→End Trace Link..., click the End Trace Link Creation with Subtype button on the toolbar, or right-click the selection and choose Trace Link→End Trace Link....

     The Create Trace Link with Subtype dialog box appears.

     b. In the list of subtypes on the left, select the subtype to assign to each trace link.

     c. In the Name box, type the name to assign to each trace link.

     In the Description box, you can type plain text as additional information.

     A trace link symbol is shown for each defining and complying object. To view a defining or complying path, generate a traceability report.

Generate a traceability report

A traceability report displays defining and complying relationships for an object. You use this report to view the defining and complying paths of trace links.
1. In the structure pane, select the object for which you want to generate the report.

2. Choose Edit→Traceability Report, click the Traceability Report button on the toolbar, or right-click the object and choose Edit→Traceability Report.

   The Traceability Report window appears.

Export a traceability report to Microsoft Office Excel

1. Choose Tools→Export→Objects To Excel.

   Teamcenter displays the Export To Excel dialog box.

2. Under Output, do one of the following:

   • For a standard Excel file that is not connected to Teamcenter, click Static Snapshot.

   • For an interactive live Excel file that is connected to Teamcenter, click Live integration with Excel (Interactive).

   • For a live Excel file that is not connected to Teamcenter, click Live integration with Excel (Bulk Mode).

   You can accumulate changes and later connect the file to Teamcenter.

   • To export the data to an Excel file that also contains import processing information on a separate sheet, click Work Offline and Import.

   • To check out objects while exporting to live Excel, select Check out objects before export.

      [Note] The checkout applies to all objects being exported. Use this option carefully if you are exporting a large set of objects or perhaps an entire product structure.

3. Under Output Template:

   a. Select Export All Visible Columns to export all the columns in the Structure Manager view.

   b. Select Use Excel Template to activate the template list.

      In the list, select the template that specifies the data that you want to export.

      For information about managing and creating Excel export templates, see the Systems Engineering Guide.

4. Click Copy URL.
Chapter 4  Building and editing product structure

Note • Copy URL is unavailable if you select more than one object to export.

• Copy URL is unavailable if you select any of the following dialog box options:
  o Work Offline and Import
  o Export All Visible Columns
  o Export All Objects in View

The export file is generated and the URL Generated message is displayed, confirming that the URL is in your Windows Clipboard and showing the URL details.

5. Click OK to generate the export Excel file.

Excel opens a temporary file. You can create a permanent file by choosing File→Save As in Excel to display the Save As dialog box.

If you save a live Excel file, you can open it later in My Teamcenter to reconnect it to the database.

Note Values that you cannot change in Teamcenter are unavailable in the cells of the live Excel file.

Delete trace links

Caution If the defining or complying object for a trace link you attempt to delete is included in a baseline structure, you may be prevented from deleting the trace link. If this is the case, an error message appears. The message is based on the value set for the Fnd0PreventTraceLinkDelete business object constant.

The constant setting prevents deletion of trace links to the released object revision, it does not prevent deletion of trace links to occurrences of the object. Therefore, you can still delete trace links on object occurrences in the baseline structure.

For more information about setting the Fnd0PreventTraceLinkDelete business object constant, see the Business Modeler IDE Guide.

Note When deleting a trace link on an occurrence object, you must consider the context of the occurrence.

Tip You can use the following procedure to delete trace links from one or more workspace or occurrence objects at a time.

1. In the traceability report or the Traceability view, select the workspace or occurrence object or objects with the trace links to delete.

Note For occurrence objects, be sure to select the occurrence object in the correct context.
2. Click the **Delete Trace Link** button at the bottom of the traceability report or **Traceability** view or press the Delete key.

3. In the **Delete** dialog box, click **Yes**.

   If the trace link has custom notes, the **Delete** dialog states the trace link has custom notes.

   The trace links are deleted from the selected workspace objects or from the occurrence objects, in context.

   **Tip**

   If trace link symbols are not removed from the primary view, you can refresh the symbol display by doing either of the following:

   - On the **Traceability** view toolbar, click the **Associate this ‘Secondary’ view to a different ‘Primary’ view** button, and then select another primary view.

   - Close the **Traceability** view, and then open a new one.

   You can select an object in the primary view and choose **Tools—Trace Link—Traceability**.

   Or, you can double-click the symbol in the **Trace Link** column for an object.

**Creating trace links to absolute occurrences**

You can create trace links between requirements and product structure objects. The product structure object can be a regular structure line, or you can store the trace link on an absolute occurrence. An absolute occurrence is an occurrence that contains additional information that is only relevant in the context of another structure line higher in the structure. Absolute occurrences are created by setting a higher level line as the context of an edit and adding information specific to this relationship.

For more information about creating and editing absolute occurrences, see *Managing absolute occurrences (in-context editing)*.

If you create a trace link on an absolute occurrence, this trace link exists in all structures containing both the context line and the trace link object in the same hierarchical relationship. If multiple revisions of the structure containing the related structures exist, the trace link exists in all the revisions. If you delete the trace link from one revision, it is deleted from all revisions.

You can also create trace links between objects in Structure Manager and objects in other structure applications, for example, Multi-Structure Manager.

**Create trace links on absolute occurrences**

The following procedure describes how to create a trace link between a source absolute occurrence and a target requirement object. You can also create the link in the opposite direction.

1. Right-click the structure line that is the context of the edit. This line must be an ancestor of the structure line that is the source line of the trace link.

2. Choose **Set In Context**.
Chapter 4  Building and editing product structure

Teamcenter displays the symbol in front of the line and colors the line green to show that the item is the context for the creation of absolute occurrences. In addition, Teamcenter grays out all siblings of the selected context and you cannot create absolute occurrences for these lines. The in-context item is also identified in the title bar of the structure tree.

3. Select the source line, or select multiple objects by using the standard Windows functions.

4. Choose Tools→Trace Link→Start Tracelink, click Start Trace Link Creation on the toolbar, or right-click the selection and choose Trace Link→Start Tracelink.

5. In the Requirements view of Systems Engineering, select the target requirement for the trace link and specify the trace link subtype and name by doing one of the following:
   - To accept the default subtype and name, choose Tools→Trace Link→End Tracelink, click the End Trace Link Creation button on the toolbar, or right-click the selection and choose Trace Link→End Tracelink.
   - To assign a custom subtype and name:
     a. Choose Tools→Trace Link→End Tracelink, click End Trace Link Creation with Subtype on the toolbar, or right-click the selection and choose Trace Link→End Tracelink.

The Create Trace Link dialog box appears.

b. In the list of subtypes on the left, select the subtype to assign to each trace link.

c. In the Name box, type the name to assign to each trace link.

d. (Optional) In the Description box, type additional information.

You can view trace links in the Traceability view of Systems Engineering or by creating a traceability report.

Searching the data dictionary

In typical automotive and aerospace functional and logical design activities, key building blocks or components of the designs are reused to save time and effort. To facilitate reuse of these building blocks or components in multiple designs across several projects or programs, Teamcenter provides a central organizational repository for them. Designers can easily search for and find components based on criteria and reuse them in their designs. Typically the organizational repository is tightly controlled and the components or blocks in it have gone through a formal, customer specific approval process. Once approved, the blocks or components are labeled as ready to use. This central organizational repository is referred to as a data dictionary. It allows you to organize data by your own criteria with the goal of easy reuse.
A data dictionary is modeled in the Classification application as a library. The Classification administrator builds a customer-specific hierarchy under one or more libraries for organizing data, for example, signals and interfaces. Depending on access privileges, you can then:

- Create, modify, and delete data from the dictionary.
- Associate a project or program with one or more dictionaries. Typically, the product design data is also associated with the same project or program.
- Search the dictionary for data meeting specified criteria.
- Add data from the dictionary to a functional, physical, or logical breakdown.
- Create signals in structures and associate them with interfaces and connections.

For more information, see the *Classification Administration Guide*.

You search for objects in the library using the **Data Dictionary Search Dialog**. This dialog box provides access to the classification hierarchy where you can search for objects to add to the structure you create. The **Data Dictionary Search Dialog** provides a view to the Classification application.

For more information about using the Classification application, see the *Classification Guide*.

**Open the Data Dictionary Search Dialog**

1. Select a line in the structure to which you want to add a signal or other library object.

2. Click **Add Signals from Library**.

   Teamcenter displays the **Data Dictionary Search Dialog** containing the classes designated as libraries.

   For more information on searching the data dictionary, see *Find a library object*.

   For more information about setting up a data dictionary, see the *Classification Administration Guide*.

**Find a library object**

1. **Search the classification hierarchy**.

   When searching the hierarchy, you can:

   - Search for a specific ID or part of an ID.
   - Search for groups or classes.
   - Search for objects possessing specific criteria.

2. **Navigate through the search results**, collecting objects of interest in the selection box at the right of the pane.

3. **Select the object you want**.
Searching the class hierarchy

When you are looking for a specific library object, there are several situations you may encounter:

- You know all or part of the object ID. In this case, you can use the object ID search feature. You can narrow this search using the search by type function. This allows you to search, for example, only for library objects that classify something, or only for objects that do not classify anything.

- You do not know the ID but would like to search within a specific group or class. For this, you must know how to select a class. From within this class, you can either search all objects in the class or search for objects matching specific criteria.

- You do not know the ID but know that the library object should possess specific attribute values. Use the attribute value search to perform this search. You can narrow this search by first selecting a class, or specifying all or part of an object ID.

  **Note** There are two search buttons in the Properties pane:

  - Click the search button 🔍 to the right of the Object ID box to search the entire classification hierarchy. You can narrow down this search by entering a search type.

  - Click the search button 🔍 at the bottom of the Search pane to search within a selected class.

    This type of search can include any search refining features, such as object ID, attribute value, or search by type.

    Additionally, there is another search button below the hierarchy tree. This is the quick search button.

    For more information, see *Use the quick search feature*.

Search by object ID

If you know at least a portion of the object ID of a library object, you can use the object ID search feature. An object ID search encompasses the entire classification hierarchy and cannot be limited to the contents of a particular class or subclass.

1. Click the Search pane located to the right of the hierarchy tree.

2. Type the exact object ID or partial object ID and wildcard characters in the Object ID box, located at the top of the Search pane.

3. (Optional) Narrow your search using the search by type feature.

4. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule for the search. If you enter a specific revision in the Object ID box, the search ignores the revision rule. If a revision rule is already set, it is displayed in the revision rule link.
For more information about configuring revision rules in the Data Dictionary Search Dialog, see Apply a revision rule.

For a complete discussion of revision rules, see Using item revision configuration.

5. Press Enter or click the Search button to the right of the Object ID box.
The object ID search returns the objects found in alphabetical/numeric order by object ID. The first object found is displayed in the Properties pane. When navigating through the objects, the class and subclass to which the object belongs are highlighted in the classification tree. The total number of objects found is displayed in the Search Results box.

6. Navigate through the search results.
For more information, see Navigating the matches.

7. Select the desired library object and transfer it to Structure Manager.
For more information, see Select the desired library objects.

8. (Optional) Perform subsequent searches by clicking the Search tab, clicking Clear and proceeding from step 2.

Search by type
You can search the classification hierarchy for library objects classifying specific workspace object types:

1. In the classification tree, expand the desired class and select it by either:
   - Double-clicking if it is a leaf node.
   - Right-clicking and choosing Select if it is not a leaf node.

   The class names are highlighted in the tree.

2. Type an ID, a class ID, or attribute values.

3. Click the Drag button. A list of workspace object types follows.

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Search among all classification instances. This is the default search method." /></td>
<td>Search among all classification instances. This is the default search method.</td>
</tr>
<tr>
<td><img src="Image" alt="Search among all classification instances that classify a workspace object." /></td>
<td>Search among all classification instances that classify a workspace object.</td>
</tr>
<tr>
<td><img src="Image" alt="Search among all classification instances that do not classify a workspace object." /></td>
<td>Search among all classification instances that do not classify a workspace object.</td>
</tr>
<tr>
<td><img src="Image" alt="Search among all classification instances that classify an item." /></td>
<td>Search among all classification instances that classify an item.</td>
</tr>
<tr>
<td><img src="Image" alt="Search among all classification instances that classify an item revision." /></td>
<td>Search among all classification instances that classify an item revision.</td>
</tr>
<tr>
<td><img src="Image" alt="Search among all classification instances that classify a process." /></td>
<td>Search among all classification instances that classify a process.</td>
</tr>
</tbody>
</table>
Click  To

Search among all classification instances that classify a process revision.

Note  The types available in this list are configurable.

For more information, see the Classification Administration Guide.

4. Select a type of workspace object to narrow your search. Only library objects classifying this type of workspace object are found in the search.

5. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule to the search. If you search by a type that excludes revisions (for example, item or process), the search ignores the revision rule. If a revision rule is already set, it is displayed in the revision rule link.

For more information about configuring revision rules in the Data Dictionary Search Dialog, see Apply a revision rule.

For more information about revision rules, see Using item revision configuration.

6. Click the Search button at the bottom of the Search pane to list all matching instances within the class.

The total number of instances that match the search criteria is displayed at the bottom of the Search pane.

Note  The Search pane displays no values upon completion of the search. You must switch to the Properties or Table pane to navigate through the results and display the values for a specific instance.

7. View the search results using one of the following methods:

- In the Table pane, double-click the instance to be viewed.
  Its attributes are displayed on the Properties pane. The classification tree is updated to show the class of the selected object.

- In the Properties pane, use the navigation arrows at the bottom of the pane to browse forward and back through the list of items that matched your search criteria. As different objects are selected, the classification hierarchy is updated to show the class of the selected object.

Two modes are used for updating the classification hierarchy when displaying the search results:

- Click the View in class stored button to display the class in which the item is stored.

- Click the View in class searched button to display the class that you selected as a basis for the search.

By default, View in class stored is active.

As you view your search results, also use the Viewer pane to display any image associated with the current item. If you select multiple objects in the table and switch to the Viewer pane, only these objects are available in the viewer.
Selecting a class

The first step in searching the classification hierarchy is to find a class in which to search. There are three methods to select a group or class:

- Navigate through the classification hierarchy manually, clicking the groups and classes until you find your desired class.
- Use the quick search feature.
- Use the Search Class dialog box.

You can search for a class using any of the alias names shown in the class tooltip.

Use the quick search feature

1. In the search box located beneath the hierarchy tree in the Data Dictionary Search Dialog, type text corresponding to the name of the group or class that you want to locate. You can also search by ID by typing id=xxx in the box, where xxx is the class ID.

   The search text can be the exact name or ID of the group or class you are looking for, a class alias name, or you can use character strings combined with wildcard characters.

2. Press Enter to start the search.

   The hierarchy tree expands to display the first object in the hierarchy that matches the search criteria. The path of the group, class, or subclass is indicated in bold text. If multiple objects are found, the arrow buttons at the bottom of the hierarchy tree are enabled.

3. Click the left-arrow and right-arrow buttons to display the matching objects, one at a time. This highlights the classes found in the hierarchy tree. The right-arrow button moves down the hierarchy tree, and the left-arrow key moves up the tree.

   If you prefer to view a list of the results, you can display the Search Class dialog box by clicking the magnifying glass button located beneath the hierarchy tree.

4. Right-click the class in the hierarchy tree within which you want to search.

5. Choose Select.

   The Search pane displays the attributes associated with the selected class, and the images appear in the class image window.

   If the class or subclass you select is a leaf node (lowest level node) in the hierarchy, you can double-click the node to display it in the Search pane, rather than use the right mouse button.

Use the Search Class dialog box

1. Click the Find Class button located beneath the hierarchy tree.
Chapter 4  Building and editing product structure

The Search Class dialog box is displayed at the bottom of your window. To move the dialog box, double-click the title bar and drag it to another location on your desktop.

2. Define the search criteria by performing the following steps:
   a. Choose a property from the list at the upper-left corner of the dialog box. The available properties are Class ID, Name, Attribute ID, and Attribute Name.

      Note: You can use the Name and Class ID properties to search for groups and classes. When searching by attribute, the results include the class in which the attribute is defined and any subclasses in which the attribute is used. Classes that inherit the attribute are not included in the results.

   b. Type search text corresponding to the selected property.

      The search text can be the exact name or ID you are looking for, or you can use character strings combined with wildcard characters.

      Note: The search box is case sensitive.

3. (Optional) If localization is enabled, select the language in which you want to search.

   For more information about localization, see the Localization Guide.

4. To start the search, either click the magnifying glass button located in the upper-right corner of the dialog box or press Enter.

   Teamcenter displays the results of the search in the message area of the dialog box, sorted in the same order as the hierarchy tree display.

5. To display an object in the tree, double-click the entry in the results list.

   The hierarchy tree expands to display the selected group, class, or subclass. The path to the object is indicated in bold text.

6. Click the left and right arrow keys beneath the class hierarchy tree to move through the search results to locate the desired class or group.

7. Right-click the class in the hierarchy tree within which you want to search.

8. Choose Select.

   The Search pane displays the attributes associated with the selected class, and the images appear in the graphics window.

   Note: If the class or subclass you select is a leaf node (lowest level node) in the hierarchy, you can double-click the node to display it in the Search pane, rather than use the right mouse button.

Search all objects in a selected class

1. Select the class in the hierarchy tree within which you want to search for objects.

   For more information, see Selecting a class.
2. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule to the search. If you search by a type that excludes revisions (for example, item or process), the search ignores the revision rule. If a revision rule is already set, it is displayed in the revision rule link.

For more information about configuring revision rules in the Data Dictionary Search Dialog, see Apply a revision rule.

For more information about revision rules, see Using item revision configuration.

3. Determine the scope of the search by clicking the Search Scope button. By default, the scope is set to Hierarchy.
   - Click Hierarchy to search within the selected class and all related child classes.
   - Click Class to search only within the selected class.

4. If you work in a multilanguage environment, select the language in which to search.

   Caution Changing the language also changes the value of the TC_language_search preference interactively, which affects all Teamcenter localization.

5. Click one of the following at the bottom of the pane to narrow down the search.

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>M</td>
<td>Search only in metric classes.</td>
</tr>
<tr>
<td>I</td>
<td>Search only in nonmetric classes.</td>
</tr>
<tr>
<td>M/I</td>
<td>Search in both metric or nonmetric classes.</td>
</tr>
</tbody>
</table>

   Caution If you are searching in a different unit of measurement than the one that you use to enter the attribute value, be sure to enter enough digits after the decimal point to avoid rounding errors.

   For more information, see the Classification Guide.

For more information about managing units of measurement, see the Classification Administration Guide.

6. Click the Search button at the bottom of the Search pane to list all search matches within the class.

   The total number of objects that match the search criteria is displayed at the bottom of the Search and Properties pane.

   Note The Search pane displays no values upon completion of the search. You must switch to the Properties or Table pane to navigate through the results and display the values for a specific instance.

7. Navigate through the search results.

   For more information, see Navigating the matches.
8. Select the desired object and transfer it to your structure.
For more information, see *Select the desired library objects*.

9. (Optional) Perform subsequent searches within the same class or subclass by clicking $\text{\textcopyright}^\circ$ in the Search pane and repeating the process.

**Search for library objects by attribute value**

1. Select the class in the hierarchy tree within which you want to search for library objects.
For more information, see *Selecting a class*.

2. Type values, including relational operators and wildcard characters, in the boxes corresponding to the attributes by which you want to search.

You can:

- Narrow your search by specifying search criteria for multiple attributes.
  For more information, see *Using relational operators* and *Using wildcard characters*.

- Change the displayed unit of the value by clicking it or typing the unit in the dialog box along with the value.
  Teamcenter changes the unit for you automatically.

[Note] If the attribute or attribute value by which you want to search is not available for searching, one of the following reasons may apply:

- It is a reference attribute.
  For more information about assigning reference attributes, see the *Classification Administration Guide*.

- It may already have a default value assigned in Classification Administration.
  For more information about assigning default values, see the *Classification Administration Guide*.

- It may be encrypted in the database.
  For more information about encrypting attributes, see the *Classification Administration Guide*.

- One or more of the key-LOV's values may be deprecated.
  For more information about deprecating key-LOVs, see the *Classification Administration Guide*.

3. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule to the search. If you search by a type that excludes revisions (for example, item or process), the search ignores the revision rule. If a revision rule is already set, it is displayed in the revision rule link.
For more information about configuring revision rules in the **Data Dictionary Search Dialog**, see *Apply a revision rule*.

For a complete discussion of revision rules, see *Using item revision configuration*.

4. Determine the scope of the search by clicking the **Search Scope** button. By default, the scope is set to **Hierarchy**.
   - Click **Hierarchy** to search within the selected class and all related child classes.
   - Click **Class** to search only within the selected class.

5. If you work in a multilanguage environment, select the language in which to search.
   - **Caution** Changing the language also changes the value of the **TC language search** preference interactively, which affects all Teamcenter localization.

6. Click one of the following to narrow down the search.

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>M</td>
<td>Search only in metric classes.</td>
</tr>
<tr>
<td>N</td>
<td>Search only in nonmetric classes.</td>
</tr>
<tr>
<td>M/N</td>
<td>Search in both metric or nonmetric classes.</td>
</tr>
</tbody>
</table>

   For more information about managing units of measurement, see the **Classification Administration Guide**.
   - **Caution** If you are searching in a different unit of measurement than the one that you use to enter the attribute value, be sure to enter enough digits after the decimal point to avoid rounding errors.
   - For more information, see the **Classification Guide**.

7. Click the **Search** button at the bottom of the **Search** pane to list all search matches within the class.

   The total number of objects that match the search criteria is displayed at the bottom of the **Search** and **Properties** pane.
   - **Note** The **Search** pane displays no values upon completion of the search. You must switch to the **Properties** or **Table** pane to navigate through the results and display the values for a specific instance.

8. Navigate through the search results.
   - For more information, see *Navigating the matches*.

9. Select the desired library object and transfer it to your structure.
   - For more information, see *Select the desired library objects*.

10. (Optional) Perform subsequent searches within the same class or subclass by clicking in the **Search** pane and repeating the process.
Configuring revision rules for searching

You can apply revision rules to searches. This narrows down the number of search results so that Teamcenter returns only the revisions you require. You can control the default behavior of the revision rules with the following preferences:

- **ICS_search_default_revision_rule_<application_name>**
  Sets the default revision rule for the specified application.

- **ICS_search_use_revision_rule**
  Enables or disables revision rules for classification searches.

For a complete discussion of revision rules, see *Using item revision configuration*.

Apply a revision rule

1. In the Search pane, click the Revision Rule hyperlink. This link shows the name of a revision rule, if one is set, or simply states **Click to add a revision rule**.

   The View/Set Current Revision Rule dialog box is displayed containing all existing revision rules.

2. Select the appropriate revision rule and click **OK**.

3. Click ▼ beside the revision rule hyperlink.

   A list with configuration options appears.

4. Select one of the following.

<table>
<thead>
<tr>
<th>Configuration option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use revision rule</td>
<td>Enables or disables the currently selected revision rule for the search.</td>
</tr>
</tbody>
</table>
Configuration option | Description
--- | ---
**Save as default** | Saves the currently selected revision rule as the default rule for this application. Teamcenter saves it in the `ICS_search_default_revision_rule_<application>` preference. The default revision rule is directly selected and enabled for the search the next time you launch the application.

**Restore default** | Selects and enables the saved default revision rule. The **Use Revision Rule** menu command is also automatically selected.

For more information about revision rules, see *Using item revision configuration*.

**Using relational operators**

Use the following relational operators to perform Classification attribute searches.

<table>
<thead>
<tr>
<th>Relational operator</th>
<th>Definition</th>
<th>For example, if you type</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
<td>=3.0 in the <strong>Corner Radius</strong> attribute box of the <strong>Taper Shank End Cutter</strong> subclass, all library objects within the subclass with a corner radius equal to 3.0 are found. You can achieve the same behavior by typing a number. If no value is given after the equal sign, the system searches for all instances where no value is set for the attribute.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>&gt;3.0 in the <strong>Corner Radius</strong> attribute box of the <strong>Taper Shank End Cutter</strong> subclass, all library objects within the subclass with a corner radius greater than 3.0 are found.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>&lt;3.0 in the <strong>Corner Radius</strong> attribute box of the <strong>Taper Shank End Cutter</strong> subclass, all library objects within the subclass with a corner radius less than 3.0 are found.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>&gt;=3.0 in the <strong>Corner Radius</strong> attribute box of the <strong>Taper Shank End Cutter</strong> subclass, all library objects within the subclass with a corner radius greater than or equal to 3.0 are found.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>&lt;=3.0 in the <strong>Corner Radius</strong> attribute box of the <strong>Taper Shank End Cutter</strong> subclass, all library objects within the subclass with a corner radius less than or equal to 3.0 are found.</td>
</tr>
<tr>
<td>!=</td>
<td>Not equal to</td>
<td>!=15.00 in the <strong>Diameter</strong> attribute box, all library objects with a diameter not equal to 15.00 are found. If no value is given after the equal sign, the system searches for all instances where any value is set for the attribute.</td>
</tr>
</tbody>
</table>
Chapter 4  Building and editing product structure

<table>
<thead>
<tr>
<th>Relational operator</th>
<th>Definition</th>
<th>For example, if you type</th>
</tr>
</thead>
<tbody>
<tr>
<td>–</td>
<td>Range</td>
<td>10.00 – 20.00 in the Diameter attribute box, all library objects with a diameter within the range of 10.00 to 20.00 (including the values 10.00 and 20.00) are found. A blank space must precede and follow the hyphen.</td>
</tr>
<tr>
<td></td>
<td>OR</td>
<td>Walter</td>
</tr>
<tr>
<td></td>
<td>““”</td>
<td>Exact string</td>
</tr>
</tbody>
</table>

Using wildcard characters

Classification employs the standard wildcard characters defined for your site. You can use these in any text box.

Navigating the matches

After you perform a search, there are several methods to navigate the matches returned by the search. You can:

- View the results in the Properties pane.
- View the results in the Table pane.
- View the results in the Viewer pane.

View search results in the Properties pane

When you view library objects in the Properties pane, the class it belongs to is highlighted in the hierarchy. Two modes are used for updating the classification hierarchy when displaying the search results:

- Click the View in class stored button to display the class in which the item is stored.
- Click the View in class searched button to display the class that you selected as a basis for the search.

You can see the active unit of measurement in the attribute values title bar in the Properties pane using the following symbols.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The library object is currently displayed and stored in a metric system of measurement.</td>
</tr>
<tr>
<td>Symbol</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>📚</td>
<td>The library object is currently displayed and stored in a nonmetric system of measurement.</td>
</tr>
<tr>
<td>📚📊</td>
<td>The library object is currently displayed in metric, but was originally stored in a nonmetric measurement system.</td>
</tr>
<tr>
<td>📚📊</td>
<td>The library object is currently displayed in a nonmetric measurement system, but was originally stored in a metric system.</td>
</tr>
</tbody>
</table>

**View search results in the Table pane**

You can view the data of the library objects found in the search collectively using the **Table** pane.

**Note** If the measurement unit symbol at the beginning of each row contains an exclamation mark, the library object is displayed in a unit system other than the one in which it was stored. For example, if the symbol 📚📊 is displayed, the library object was stored in a nonmetric unit system but is currently displayed in a metric unit.

1. Perform one of the following actions:
   - Click ⬇️ to load the next page of found library objects into the table.
     The next library objects are appended to those currently displayed.
     **Note** By default, the number of library objects displayed on a page is set to 5. Your administrator can change the default display by modifying the **ICS_table_pagesize** preference.
   - Click 🔍 to load all matches into the table.

2. Use the scroll bars to move through the found library objects.

3. (Optional) Sort the table data; double-click the column header corresponding to the property to switch between ascending, descending, and natural sort order.
   Teamcenter can display different units of measurement in the same column. The displayed unit depends on the optimized unit for each of the attribute values.
   Teamcenter sorts these columns based on the attribute values in the storage unit.
   For more information about optimizing attribute values, see the **Classification Administration Guide**.

4. (Optional) Select a line in the **Tree** pane and click 🔍 to view its properties.

5. Double-click a library object in the table to view it.
   The system opens the object in the **Properties** pane and highlights its class in the tree.

**View search results in the Viewer pane**

You can view all search results in the **Viewer** pane. You can move backward and forward in the match list using the navigation buttons.
If the object does not have an item attached, or if the item does not contain a graphic, no image appears in the Viewer pane.

**Select the desired library objects**

While you navigate through the search matches, you can collect desired objects in the selection box on the right of the dialog box. After you finish navigating the matches, you select one or several library objects to return to Structure Manager.

1. Click the **Properties**, **Table**, or **Graphics** tabs.

   **Note** The Graphics pane is only active for a library object that has an item attached.

2. Navigate to the desired library object.
   - In the **Properties** or **Graphics** pane, use the navigation arrows. Teamcenter displays all attributes and values for each library object.
   - In the **Table** pane, do one of the following:
     - Select the library object by clicking it.
     - Double-click the library object. Teamcenter switches to the Properties pane and shows all attributes and values for the selected object.
     - Select multiple library objects.

3. (Optional) With library objects selected in one of the panes, click ‡ to add them to the selection box on the right.

4. When you finish adding objects to the selection box, select the objects in the selection box that you want to add to the structure and click **OK**.

   The item or item revision classified by the library object is displayed in Structure Manager. If a library object has no item or item revision attached, the system creates one so that it can open that item in Structure Manager.

   If you open multiple library objects at once by selecting several library objects in the Data Dictionary Search Dialog, they are all transferred to Structure Manager. The selected objects appear in the structure you are building in the order in which they appear in the Data Dictionary Search Dialog table.

**Releasing structures**

You can release any complete product or subassembly structure using a Workflow process defined for your site. You can release any of the following:

- Item revision with assembly
- BOM view revision
- Change revision
• Item revision (assembly structure line)

Note Not all components in the structure need be released with the same Workflow process. For example, you can release the connections in an electromechanical design separately from the mechanical structure.

Release a structure

1. Select the appropriate top line in the navigation tree and choose Tools→Process and Change Selector.

Teamcenter displays the Process and Change Selector dialog box. This dialog box contains:

• An input tree in the top left of the box. This allows you to refine the selection of the structure to release.

• A process tree in the bottom left of the box. This allows you to select the required Workflow process, its targets and its references.

• A search pane in the top right of the box. This allows you to search for objects to release.

• A result pane in the bottom right of the box, showing the results of the last search.

2. In the input tree, select the revision you want to release.

Teamcenter loads the appropriate search pane selection boxes and you can select the search parameters from the lists as follows:

• View Type
  Lists all the BOM view revisions attached to the selected change.

• Revision Rule.
  Lists all available revision rules.

You can also check one or both of the following check boxes to refine the search results:

• Include GDE Lines
  If selected, the search results include item elements. The types of item element included are defined in the TC_releasable_logical_types preference, which includes the PSConnectionRevision, PSSignalRevision, and GeneralDesignElement types by default.

• Include BOM Lines
  If selected, the search results include item revisions.

3. Click the Load button.

Teamcenter loads all the first level children of the selected object into the results pane, according to the selections you made in the search pane. The objects represented by the lines in the results pane may be:
Chapter 4  Building and editing product structure

- Unreleased.
- Not a target of any workflow process.
- The target of a workflow process but not attached to a change.

4. If appropriate, you can start a separate process with selected result lines as the target:
   a. Ensure the correct process is selected in the process tree.
   b. Select one or more lines in the results pane and click the Attach To Process button.
      Teamcenter displays the New Process dialog box with the selected lines as the target attachments.
   c. Click the Process Template tab, select the appropriate process template and click OK.
      Teamcenter creates the new process and updates the result pane in the Process and Change Selector dialog box with the new status of the objects.

5. If your search criteria included structure lines, you can attach selected child lines to a BVR process as follows:
   a. Select one or more lines in the results pane and click the Copy button.
   b. Select the appropriate Targets folder in the process tree and click the Attach To Process button to paste the lines as targets of the process.

6. If you are using change management, you can include changes to items elements (for example, GDEs, connections and signals) in controlled changes to the parent assembly. Use the ECM-attach-components-to-change action handler to identify all unreleased child revisions and GDEs at the first level of the affected assembly to the change folder specified in the action handler. You can only use this action handler in a process where the primary target is a change revision. If you do not specify a revision rule, Teamcenter uses the default revision rule specified in the TC_config_rule_name preference.

   To do this, you must select a change revision in the navigation tree before choosing Tools→Process and Change Selector. If you do this, the change revision is highlighted in the input tree of the Process and Change Selector dialog box. To attach the change revision to a change process:
   a. Select one or more lines in the results pane and click the Copy button.
   b. Select the appropriate change process Targets folder in the process tree and click the Attach To Change button to paste the lines as targets of the change process.

7. If you want to control new parts in a structure with a separate change process (that is, parts that are not yet change controlled), select the relevant lines in the result pane and click the Attach To Change button. (Do not select a process in the process tree.)

   Teamcenter displays a dialog box that allows you to search for the relevant change revision. After you locate the change revision, you can copy the objects
to attach from the left-hand pane into the appropriate change folder in the right-hand pane.

**BOM session recovery**

If you are working with Structure Manager in a four-tier environment and a server or network failure or time-out occurs, Teamcenter reassigns the client session to another server. It also attempts to use the client cache to reconstruct the run-time configured structure and minimize loss of information.

If the server connection is lost, Structure Manager displays two dialog boxes:

- **Server Reassigned**
  
  Informs you that the server connection was lost. Click OK to log off Teamcenter and attempt to log on to another server.

- **BOM Session Recovery**
  
  Informs you that a BOM recovery session has started. Click OK to dismiss the dialog box or click More to show detailed information about the recovery session.

On completion of the recovery session, Structure Manager appends **Recovered Session** to the title of the BOM window and colors the title text red. Additional error messages may appear, depending on the state of the recovered session.

The following limitations apply to BOM session recovery:

- BOM sessions are recovered only for the four-tier rich client. Thin client or two-tier rich client session are not recovered.

- Sessions with CAD and third-party integrations such as Teamcenter Integration for NX are not recovered.

- Teamcenter recovers the BOM session to a usable status, but not necessarily the exact state before failure or time-out occurred. For example, if you expanded multiple levels of the structure, Teamcenter recovers only the first-level expansion of the structure.

- The recovery may take an appreciable time to complete, depending on the quantity of data Teamcenter must process.

- Unsaved changes are lost. For example, if you made changes in normal editing or pending edit mode, but did not save them, the changes are lost.

- If you were performing a complex action when the server terminated, Teamcenter may not recover to the same step. For example, if you started to insert a level in the structure, after recovery Teamcenter does not resume at the same step in the wizard. Incomplete actions do not execute correctly; you should cancel them if they do not terminate automatically.

- All dynamic (run-time objects) such as BOM windows and BOM lines are invalid after reconnection even though the Structure Manager user interface may be recovered to the previous state.
• If you copied BOM lines to the clipboard before the server terminated, Teamcenter removes them.

• If the server terminated after encountering bad data during expansion, the recovery process may expand the same structure and encounter the same bad data. You must resolve these data issues in the database manually.

• If the server terminated due to memory shortage when expanding the first level of the structure, the recovery process may expand the same structure and encounter the same memory shortage. You must resolve such memory issues separately.

• If the data pane was open, Teamcenter closes it after recovery and it may no longer function correctly.

Once Structure Manager is running in the recovered session, you should perform any necessary cleanup tasks, and then continue working.
Chapter 5

Working with occurrences

Working with occurrences .............................................. 5-1
Occurrence elements .................................................... 5-1
Creating precise and imprecise occurrences ......................... 5-2
Using absolute occurrences ............................................ 5-2
  Tracking changes to absolute occurrences ......................... 5-6
Managing absolute occurrences (in-context editing) ............... 5-8
  Interpreting absolute occurrence data .............................. 5-8
  Show and hide the in-context line ................................. 5-11
  Create absolute occurrences ..................................... 5-11
  Identify absolute occurrences ................................... 5-12
  Change absolute occurrence override data ....................... 5-12
  Remove absolute occurrence override data ....................... 5-13
  Disable in-context editing mode ................................ 5-13
Associate data with absolute occurrences ........................ 5-13
  Associate a dataset or form with an absolute occurrence ..... 5-14
  Associate a transformation with an absolute occurrence ..... 5-14
  Associate an occurrence note with an absolute occurrence .. 5-14
  Apply a variant condition to an absolute occurrence .......... 5-14
View attachments associated with an absolute occurrence .... 5-15
Data precedence ......................................................... 5-15
  Propagate override data ........................................... 5-16
Override data in multiple contexts ................................. 5-16
Chapter

5 Working with occurrences

Working with occurrences

Teamcenter allows you to work with occurrences and absolute occurrences, according to your product structure needs.

An occurrence consists of one component in an assembly including its relative position with respect to its parent assembly. Occurrence types are representations of the PSOccurrence business object.

For details about creating occurrence types, see the Business Modeler IDE Guide.

Occurrences may be suppressed in a CAD tool. If an occurrence is suppressed, the CAD tool behaves as though the occurrence does not exist. The occurrence is not displayed in the CAD system or the Structure Manager viewer. Positioning or mating constraints related to a suppressed occurrence are ignored in geometric solves.

You can determine if an occurrence is suppressed by checking the following properties:

- **bl_is_occ_suppressed**
  Any line that has this flag set to true is hidden unless you choose the Show Suppressed Occurrences command. This flag captures occurrence suppression settings from the CAD tool, if you import a CAD structure. You can override this flag in the context of another line for a specific arrangement.

- **bl_is_suppressed**
  This read-only, runtime property indicates if a line is suppressed. A line is considered suppressed if the variant state is suppressed, the line is not configured, or the occurrence is explicitly suppressed by setting the bl_occ_is_suppressed property. If any of these conditions is true, the bl_is_suppressed property is true, otherwise it is false. The value of the bl_is_suppressed property is not affected by the Show Suppressed Occurrences or Show Unconfigured commands.

Occurrence elements

The following table lists elements of the product structure that are relevant to occurrences, absolute occurrences, and managed occurrences.
### Element | Purpose
--- | ---
Absolute occurrence | A relationship between a *parent* assembly and an item one or more levels lower in the structure. The parent assembly is the *context* in which the absolute occurrence exists. You can define data on the absolute occurrence that overrides the data stored on the item when you select the context assembly and view the structure. Both relative occurrence data (notes and transforms) and attachments can be overridden with data on absolute occurrences.

Each absolute occurrence can have one or more unique attribute values that distinguish it from the other absolute occurrences derived from the same single occurrence.

Occurrence (relative) | (Sometimes called *relative occurrence.*) A hierarchical structure relationship between the immediate parent assembly and its child component item (in an imprecise assembly) or item revision (in a precise assembly). You can use a find number to identify for an occurrence, but this number may not be unique. Data can be stored on the occurrence, including occurrence notes and transforms.

### Creating precise and imprecise occurrences

When you add a component to an assembly, you create an occurrence of the item or item revision in the assembly. Teamcenter displays the item or item revision as a line in the product structure.

The occurrence is precise or imprecise, depending on whether the BOM view revision is precise or imprecise in the parent assembly. Teamcenter applies the following rules:

- If the BOM view revision parent assembly is precise, the occurrence references the specific item revision for the component that you pasted. If you add an item, the revision is chosen by the revision rule. If no revision is found that satisfies the revision rule, Teamcenter displays an error message.

- If the BOM view revision parent assembly is imprecise, the occurrence references an item for the component. The revision is determined by the revision rule.

**Note** | If you try to paste an item revision with an imprecise BOM view revision into an item revision that has a precise BOM view revision, Teamcenter may display a warning message. If you paste an imprecise assembly into a precise structure, it displays a warning. If you paste a precise assembly, Teamcenter applies the precision of the parent assembly and does not display a warning.

### Using absolute occurrences

You can use absolute occurrences to manage data that is unique to a specific use of an item within a product structure. If you have ownership of and write access to a
particular BOM view revision, you can define a subset of BOM line properties that other users can edit in the context of the BVR. You can also allow users to attach forms or datasets in context, by configuring business rules that define the types of primary and secondary objects for the relationships.

When a user enters in-context values or attachments, Teamcenter *overrides* certain structural data associated with a relative occurrence in the context of a specific higher level assembly. Data you can override includes:

- Occurrence notes
- Occurrence type
- Quantity
- Absolute transform
- Find number
- Variant condition
- Attachment, for example, a JT file for a different rendering
- Component item for a replacement

A BOM line represents an absolute occurrence with respect to the current top line in the product structure. You can set occurrence attribute values on such a BOM line, without those values appearing in the product structure everywhere the BOM line’s parent appears. There are cases where a user needs to store values specific to the BOM line with respect to the top line or some intermediate assembly between the BOM line’s parent and the top line. Absolute occurrences are always created in the context of a selected top line; the same absolute occurrence may not be in context for another top line.

The following figure shows an example where two vehicles are built on the same chassis. The chassis contains two occurrences of a suspension system, one for the front of the vehicle and one for the rear; these occurrences are positioned relative to the chassis by transforms T3 and T4, respectively. The suspension assembly contains two occurrences of a wheel assembly, one for the left side of the suspension system and the other for the right side of the suspension system. The wheel assembly occurrences are positioned relative to the suspension assembly by transforms T1 and T2, respectively. The wheel assembly is composed of a wheel, tire, and valve stem. The occurrence of the tire is annotated with a recommended tire pressure of 30 PSI.
Sample product structure with relative occurrences only

Relative occurrences correlate directly to structure relationships. If the structure relationship has a quantity associated with it, the number of relative occurrences associated with the structure relation equals the quantity.

In the previous figure, when you display the product structure for vehicle Y, every occurrence of the tire shows a recommended tire pressure of 30 PSI; that is, the value set on the occurrence of the tire in the wheel assembly is propagated to all BOM lines for the tire. Positioning information is derived in the same way. The position of the wheel assembly in a vehicle is derived from transformation values specified on the (relative) occurrences in the product structure, for example, the position of the front left wheel is derived by multiplying T1 and T3.

Consider a case when the position of the front wheels must change so they toe-in by 0.5 degrees or the case where the recommended tire pressure for the rear-tires in vehicle X must change to 33 PSI. One way to accomplish this is to modify the structure, but in most situations, this approach is not practical. Instead, you should
make context-specific modifications to BOM line properties without changing the product structure. To permit such context-specific modifications, you can create *absolute occurrences*. Creating absolute occurrences allows you to effectively flatten the representation of a structure while knowing how to map back to the actual product structure. The following figure illustrates this concept, expanding on the preceding example.

**Sample product structure with absolute occurrences**

The dashed lines in the figure represent absolute occurrences. In this case, the absolute occurrences specify or override values in a specific context. In the example,
they override positioning information and recommended tire pressure. The context of the override and the value is shown in the label on each dashed line.

Specifically, in the context of the vehicle-X, the front tires have a recommended tire pressure of 30 PSI; this is derived from the relative occurrence of the tire in the wheel assembly. However, the two rear tires have a recommended tire pressure of 33 PSI; this is explicitly set on the absolute occurrence in the context of the vehicle. The value of 33 PSI on the absolute occurrence overrides the value of 30 PSI that appears on the relative occurrence of the tire in the wheel assembly. Vehicle-Y, however, has a recommended tire pressure of 30 PSI for all four tires.

Positioning information is derived in a similar way. The values specified on the absolute occurrence override the values that are otherwise derived by catenation of the transforms from the relative occurrences. That is, in the second figure, T5 overrides the value that would otherwise be derived from the multiplication of T3 and T1. Because this example specifies the transform overrides in the context of the chassis, both vehicle-X and vehicle-Y use T5.

If you release an intermediate BOM line that represents a subassembly, the line is locked and you do not have write access to it. However, you can still make changes to its absolute occurrences in the context of a parent assembly whose BOM view revision is also released, for example, to attach a dataset with associated JT files.

**Tracking changes to absolute occurrences**

The following figure shows how you can track changes to absolute occurrences with incremental changes.
Tracking changes to absolute occurrences

The possible configurations of occurrence data on A200 (left occurrence) in assembly A100 are as follows:

- Units 1 through 9: No incremental changes configured. Original occurrence data: Transform=T0, Note 1=12, Form F-2.

- Units 10 through 19: Incremental change 1 configured. Transform=T1, Note 1=12, Form F-2.

- Unit 20 and above: Incremental change 1, incremental change 2 & incremental change 3 configured. Transform=T2, Note 1=15, Form F-3. Form F-2 is still attached to the right occurrence of A200.

There is no **Remove** change on the occurrence data, for example, for the transform or note 1. You simply define a new value that overrides the value on the normal relative occurrence. For example, the new value may define an end unit for an incremental change.

For detailed information about incremental changes, see *Managing incremental changes*. 
Managing absolute occurrences (in-context editing)

An absolute occurrence is a specific instance of a component or assembly in a structure. It may be independent of the top-level assembly and only meaningful in the context of a lower level assembly. For example, you may have four occurrences of a wheel in the design of a vehicle; you can label one of those occurrences as left rear wheel, which is an absolute occurrence of the wheel. When you open a window containing the structure, each absolute occurrence is represented by a single line.

To create an absolute occurrence, you edit the occurrence line in context with respect to the assembly in which the absolute occurrence data is meaningful. Hence, the creation of absolute occurrences is sometimes referred to as editing in context.

**Note** Absolute occurrences are not the same as appearances. Absolute occurrences are generated when you build the structure (edit in context) and do not have associated spatial information.

A component or subassembly that appears in more than one product structure can have the same absolute occurrence in each structure.

You cannot create absolute occurrences directly, only by converting a relative occurrence and editing its properties. Similarly, you cannot delete absolute occurrences directly. You cannot create absolute occurrences on substitutes.

An absolute occurrence may appear more than once in the structure, depending on the context in which you created it.

**Note** If you use absolute occurrences with product structures that are not created in NX, see the description of the PS_allow_plmxml_transforms_with_no_legacy_factor preference in the Preferences and Environment Variables Reference. To avoid conversion errors, set this preference to yes if you are configuring structures for the first time and have no legacy data.

Interpreting absolute occurrence data

The following figure shows how absolute occurrences appear in the structure when in context editing is enabled.
Absolute occurrences in a structure

Note the following lines in this structure:

<table>
<thead>
<tr>
<th>Line</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>20487187/C (view)</td>
<td>The immediate parent that is in context for absolute occurrence edits.</td>
</tr>
</tbody>
</table>

The line is also color-coded in the structure and in the title bar of the pane where the current context is shown. The color is green in this example but may be changed by your administrator.

Lines that are not in the current context are grayed out. Similarly, the out-of-context parts corresponding to the grayed out lines may also be grayed-out in the viewer. You cannot create absolute occurrences from grayed-out lines in the current context and you cannot edit an existing property value on such lines.
Chapter 5  Working with occurrences

<table>
<thead>
<tr>
<th>Line</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lines below 20487187/C (view) are generally not grayed out and are in context.</td>
<td></td>
</tr>
<tr>
<td>20367635_101/B (view)</td>
<td>This is a standard occurrence note. It is in context and may be edited.</td>
</tr>
<tr>
<td>20367635_201/A</td>
<td>This occurrence note is not in context because it is not in all occurrences of the immediate parent assembly.</td>
</tr>
<tr>
<td>20367635_3/A</td>
<td>The overriding note value in the context of 20487187 only for this specific occurrence of the parent. To obtain more information about edited absolute occurrence data, place the cursor over any cell containing the symbol. The tool tip banner shows the context in which the edited data is valid.</td>
</tr>
</tbody>
</table>

By default, the assembly viewer highlights only those items in the assembly that are in scope in the selected context; items that are not in context are shown grayed out. The administrator may optionally change this behavior so that all items are shown.

The structure contains symbols that indicate the status of the structure lines as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>A line containing this symbol is the context for the creation of certain absolute occurrences. The line is also color-coded in the structure and in the title bar of the pane where the current context is shown.</td>
</tr>
<tr>
<td></td>
<td>A line that contains this symbol has one or more of the absolute occurrences edited in a context but not necessarily the current context.</td>
</tr>
<tr>
<td></td>
<td>A property cell containing this symbol is already edited in a context; the current absolute occurrence data is shown in the cell. Each cell that contains data for a specific absolute occurrence includes this symbol.</td>
</tr>
<tr>
<td></td>
<td>A line that contains this symbol before its name is a target for editing data in the current context. Look for a symbol in one or more properties cells of the same line to identify if the necessary edits are already made.</td>
</tr>
<tr>
<td></td>
<td>This symbol identifies a target in the current context. It may not appear in the same line if you select a different context.</td>
</tr>
<tr>
<td></td>
<td>A line that contains this symbol has an in-context edit made by an incremental change. The edit may be an add, remove, or both.</td>
</tr>
</tbody>
</table>
Working with occurrences

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Symbol" /></td>
<td>A cell that contains this symbol has an in-context edit removed by an incremental change.</td>
</tr>
<tr>
<td><img src="image2" alt="Symbol" /></td>
<td>A cell that contains this symbol has an in-context edit added by an incremental change.</td>
</tr>
<tr>
<td><img src="image3" alt="Symbol" /></td>
<td>A cell that contains this symbol has in-context edits added and removed by an incremental change.</td>
</tr>
</tbody>
</table>

Show and hide the in-context line

You can show or hide the line that is the context of a particular in-context edit. To do this, right-click an edited property of a line containing the edit and choose **Show/Hide In-Context BOM Line**. This action toggles between showing and hiding the relevant line. When shown, the in-context line is highlighted in yellow and the editable property cells are highlighted similarly.

Create absolute occurrences

To create an absolute occurrence, you must enable in-context editing mode and edit the properties of an occurrence, as follows:

1. If necessary, expand the structure by choosing **View→Expand Below**.

2. Select the top line that is the context of this edit and choose **Edit→Toggle In-Context Mode**. You can also right-click the line and choose **Set In-Context**, or click the ![Button](image4) button on the toolbar.

If a line in the displayed structure is marked with a ![Symbol](image5) symbol and colored green, it is the item that is the context for the creation of absolute occurrences. If a line is grayed out, it is not in the selected context and you cannot create absolute occurrences for these lines. The in-context item is also identified in the title bar of the structure tree.

- You cannot enable in-context editing mode for a line that has no children.
- You cannot create an absolute occurrence in the context of its immediate parent.
- You cannot change the value of a property that is already overridden at a higher level.

3. Click the cell in the lower line containing the property you want to enter or edit. You must select one of the following supported properties:

- Suppressed
- Position constrained
- Suppression constrained
- Any GRM relation impacted by preferences
- Any occurrence note
- Quantity
- Find number
- Occurrence type
Chapter 5  Working with occurrences

- Variant conditions
- Variant formula
- Absolute transformation matrix
- Unit of measure
- Is designed in place
- Requires positioned design

**Caution**  Ensure you have selected in-context editing mode. If this mode is not selected, the change is made to *every* instance of the selected item anywhere in the assembly.

4. Type the required new value and press the Enter key. A 🌐 symbol on the line indicates one of its property cells has an absolute occurrence override.

**Note**  If you create an absolute occurrence override of a property and the same property is already overridden at a lower level in the structure, the new, higher level value replaces the existing value. Conversely, you cannot edit an individual property value if the same property is overridden at a higher level in the structure.

**Identify absolute occurrences**

You can assign identifiers to absolute occurrences and these identifiers are displayed in two columns in the property table, as follows:

- **ID In Context (Top Level)**
  
  Shows only the identifier assigned to the line in the context of the loaded top-level line. You can add or edit an identifier by double-clicking in this cell and typing the necessary value.

  **Note**  Any absolute occurrence identifiers defined at a lower level than the currently selected top-level line are not visible.

  If in-context editing mode is disabled, the top-level line is always considered the in-context line.

- **ID In Context (All Levels)**

  Shows the identifiers assigned to the line in all contexts. You cannot edit this column.

**Change absolute occurrence override data**

You can change the override data for an existing absolute occurrence at any time. For example, you may want to change the quantity assigned to a structure line to correct a previous error. It is not necessary to enable context editing to make such changes, ensure only the correct context is selected, then double-click the property cell and edit the value.

**Note**  If you want to define relative occurrence data for a property that is already defined in context, remove the absolute occurrence data from the property first.
Remove absolute occurrence override data

You can remove override data from an absolute occurrence without entering replacement data. To do this, right-click the property to remove (that is, select the relevant cell) and choose the Remove In Context Override command.

Disable in-context editing mode

When you are not creating or editing absolute occurrence data, consider disabling in-context editing mode to avoid inadvertent changes. Do this by choosing Edit→Toggle In-Context Mode or clicking the button in the toolbar.

Associate data with absolute occurrences

During the design process, an engineer may attach data such as a CAD design file, viewer (JT) file, classification information, and specifications to an item revision. The actual usage of the item revision in the structure, including its transformation, is tied to an occurrence.

You can attach data to a specific instance of an item revision in the structure, which is represented by an absolute occurrence. You can attach data that is unique to the absolute occurrence, or information that is already attached to the associated item revision or occurrence. Examples of data that you may want to attach to a specific absolute occurrence include:

- Cost data
- Transformations
- Quantity
- Variant conditions (not modular variant expressions)
- Viewer information
- Name and ID
- Occurrence note, type, or find number
- Instance number
- Find number
- Occurrence position constrained
- Occurrence suppressed

For example, you may want to attach a different occurrence note to each absolute occurrence to specify additional assembly work instructions.

The level of the absolute occurrence in the structure determines the precedence of data you attach to it. Data attached at a high or mid-level in the structure override the corresponding data at lower levels; data attached to an absolute occurrence at the lowest level does not override data elsewhere.
Chapter 5  Working with occurrences

Associate a dataset or form with an absolute occurrence

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode, right-clicking the structure line, and choosing Set In Context; or clicking the button on the toolbar.

2. Select the line containing the absolute occurrence with which you want to associate a new instance-specific dataset or form, then click the Attachments tab in the data pane.

3. If you are associating a new dataset or form, create it by choosing File→New→Dataset or File→New→Form, respectively.

   If you are replacing an existing dataset or form, select it in the Attachments tab. You can then search for and insert a replacement dataset or form.

Associate a transformation with an absolute occurrence

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode, right-clicking the structure line, and choosing Set In Context; or clicking the button on the toolbar.

2. Select the line containing the absolute occurrence for which you want to change the transformation.

3. Click the Graphics tab and choose Graphics→Transformation→Persistent Transformation.

4. Change the position of the affected component and save the changes.

Associate an occurrence note with an absolute occurrence

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode, right-clicking the structure line, and choosing Set In Context; or clicking the button on the toolbar.

2. Select the line containing the absolute occurrence with which you want to associate an occurrence note.

3. Choose View→Notes, or click the Notes button on the toolbar.

   Teamcenter displays the Notes dialog box.

4. Type the properties of the note and click OK.

Apply a variant condition to an absolute occurrence

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode, right-clicking the structure line, and choosing Set In Context; or clicking the button on the toolbar.

2. Select the line containing the absolute occurrence with which you want to associate a variant condition.
3. Choose **Edit→Variant Condition** or click the **Edit Variant Conditions** button on the menu bar.

   Teamcenter displays the **Variant Condition** dialog box.

4. Add a new variant condition to the absolute occurrence or edit the existing variant condition.

**View attachments associated with an absolute occurrence**

To view all the attachments associated with an absolute occurrence, select the line containing the absolute occurrence and choose the **Attachments** pane. All the attachments to the absolute occurrence are shown below the absolute occurrence.

*Note* If incremental change orders are used at your site, attachments associated with unconfigured changes may be hidden. To view all absolute occurrence data, choose **View→Show Unconfigured Changes** and set unconfigured changes to on.

The **Associated to Absolute Occ?** column also shows if the data item is attached to absolute occurrence.

**Data precedence**

You can associate data with an item revision or absolute occurrence. You can create the absolute occurrence in the context of a top-level item.

The following figure shows how visualization (JT) files may be attached to items.

![Diagram](attachment:diagram.png)

**Attaching visualization files to items**

In this example, you can see `file1.jt` in the viewer in My Teamcenter without any context. However, when you view the same item revision (`ItemRev1`) in the context of `TopItem1`, you see the JT file (`file2.jt`) that is associated with the corresponding absolute occurrence (`appr1`) in the context of item `TopItem1/A`.

You can associate a different JT file as an override if `TopItem1` is revised from revision A to revision B.

Data is associated with an absolute occurrence in the context of a specified revision. When you revise an item, the data associated with the previous revision is copied and you can change it as necessary.
Propagate override data

You can associate data to absolute occurrences in the context of an intermediate level, as well as in the context of the top level, as shown in the following figure.

In this example, ItemRev1 has two override JT files, file2.jt and file3.jt. The file2.jt file is added in the context of TopItem1/A, while the file3.jt file is added in the context of S11/A. Consequently, if you view ItemRev1 in the context of TopItem1/A, you see the file2.jt file.

Override data in multiple contexts

You can create absolute occurrence data on a single line in more than one context. For example, you may want to override the find number in the context of the top-level assembly and the quantity in the context of a lower level assembly. Make these in-context edits in turn, ensuring you have selected the correct context (line) each time. The system shows the relevant absolute occurrence data for the current context and consequently data that applies to other contexts is hidden.

Note You cannot change the value of a property that is already overridden in a higher level context.
## 6 Managing properties and notes

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managing properties and notes</td>
<td>6-1</td>
</tr>
<tr>
<td>Displaying properties</td>
<td>6-1</td>
</tr>
<tr>
<td>Creating and editing display names</td>
<td>6-9</td>
</tr>
<tr>
<td>Create a display name</td>
<td>6-9</td>
</tr>
<tr>
<td>Managing column configurations</td>
<td>6-10</td>
</tr>
<tr>
<td>Save column configuration</td>
<td>6-10</td>
</tr>
<tr>
<td>Apply column configuration</td>
<td>6-10</td>
</tr>
<tr>
<td>Update column configuration</td>
<td>6-11</td>
</tr>
<tr>
<td>Delete column configuration</td>
<td>6-11</td>
</tr>
<tr>
<td>Freeze columns</td>
<td>6-12</td>
</tr>
<tr>
<td>View properties</td>
<td>6-12</td>
</tr>
<tr>
<td>Modify common properties</td>
<td>6-12</td>
</tr>
<tr>
<td>Editing a single property in place</td>
<td>6-14</td>
</tr>
<tr>
<td>Edit find numbers</td>
<td>6-14</td>
</tr>
<tr>
<td>Edit quantities</td>
<td>6-15</td>
</tr>
<tr>
<td>Adding a compound property</td>
<td>6-15</td>
</tr>
<tr>
<td>Displaying item master form attributes</td>
<td>6-15</td>
</tr>
<tr>
<td>Creating structure properties rollup reports</td>
<td>6-16</td>
</tr>
<tr>
<td>Create a structure rollup report template</td>
<td>6-17</td>
</tr>
<tr>
<td>Create a structure rollup report</td>
<td>6-18</td>
</tr>
<tr>
<td>View or edit a structure rollup report</td>
<td>6-19</td>
</tr>
<tr>
<td>Export a structure rollup report</td>
<td>6-19</td>
</tr>
<tr>
<td>Using the Variant Formula property</td>
<td>6-19</td>
</tr>
<tr>
<td>Displaying occurrence notes</td>
<td>6-22</td>
</tr>
<tr>
<td>Display a single note type</td>
<td>6-22</td>
</tr>
<tr>
<td>Display the all notes column</td>
<td>6-22</td>
</tr>
<tr>
<td>Editing and copying occurrence notes</td>
<td>6-23</td>
</tr>
<tr>
<td>Set the value of an occurrence note</td>
<td>6-23</td>
</tr>
<tr>
<td>Remove a note</td>
<td>6-24</td>
</tr>
<tr>
<td>Copy a note</td>
<td>6-24</td>
</tr>
<tr>
<td>Viewing packed notes</td>
<td>6-24</td>
</tr>
</tbody>
</table>
Chapter

6 Managing properties and notes

Managing properties and notes

Properties and notes contain information about items in the product structure that does not necessarily appear in the CAD design. Examples of properties of a line in the product structure may include find numbers for parts in an assembly, release status, and cost. Your Teamcenter administrator can change or customize the list of properties displayed in Structure Manager at your site according to business requirements.

Occurrence notes contain information pertinent to occurrence of the part in the structure, for example, the inflation pressure of a particular tire or the torque value for a bolt. Your Teamcenter administrator creates and manages the occurrence note types required at your site. You can then make use of any of the available note types to specify a value for a particular line in the structure.

For more details about creating occurrence note types, see the Business Modeler IDE Guide.

Displaying properties

The following table lists some of the columns available in the properties view of the product structure and provides a description of their functions.

BOM line properties have display names or system names, and the system names are in the format bl.xxx. Add or edit a display name for a system name using Business Modeler IDE, as described in Creating and editing display names.

You can add or remove property columns in the table tree by right-clicking the BOM window and choosing Insert Columns in the shortcut menu. By default, Teamcenter displays selection lists of all available properties to add or remove that may contain a large number of system and custom properties. To make the selection list more manageable, the administrator can restrict the properties that are displayed by group or role. You can also freeze commonly used columns so that they are always visible.

You can save property column configurations at a user, site, or group level. The same columns are then available for every session and for multiple users.

You can update the values of all the displayed properties in the BOM window by pressing the F5 key. This feature may be useful if more than one user is working on the structure and you want to synchronize to the latest information, for example, a changed value or modified occurrence note.
Chapter 6  Managing properties and notes

**Note** If you make a change to a persistent object (for example, an item, item revision, item master, item revision master, GDE, or BOM view revision) in My Teamcenter or a data pane, the BOM line that references the updated property may not refresh automatically.

For more information about saving property column configurations and freezing columns, see *Managing column configurations*.

You specify custom item or item revision classes to add as derived BOM line properties. To configure the list of available properties of custom item or item revision classes available to the end user, the administrator sets the `Fnd0BOMLineItemConfigProps` and `Fnd0BOMLineRevConfigProps` Business Modeler IDE constants and the `BOM_Properties_For_Column_Selection` preference.

For more information about adding custom properties to columns, see the *Business Modeler IDE Guide*.

In addition to the default and custom properties, your administrator may also create customized note types.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
<th>Application</th>
<th>Object</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute Transformation Matrix</td>
<td>Shows the positioning transformation data.</td>
<td>CAD managers</td>
<td>Structure line</td>
</tr>
<tr>
<td>Affected IC</td>
<td>Shows the effective incremental change.</td>
<td>Incremental change</td>
<td>Incremental change/structure line</td>
</tr>
<tr>
<td>All Notes</td>
<td>Combines all occurrence notes into a single property.</td>
<td>All</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Architecture Element ID</td>
<td>Shows the architecture element identifier.</td>
<td>Platform Designer</td>
<td>Occurrence</td>
</tr>
<tr>
<td>bl_abs_xform_matrix</td>
<td>Shows a run-time, rolled-up non-PLM XML transformation matrix value assigned to the part occurrence.</td>
<td>Transformation matrix</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_appearance</td>
<td>Shows the appearance tag ID assigned to the line by the appearances system.</td>
<td>Appearances</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_appearance_path</td>
<td>Shows the appearance path node (APN) tag ID assigned to the line by the appearances system.</td>
<td>Appearances</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_bounding_boxes</td>
<td>Contains a comma-separated array that specifies the dimensions of one or more bounding boxes.</td>
<td>Spatial search</td>
<td>Structure line</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
<td>Application</td>
<td>Object</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>-------------</td>
<td>--------</td>
</tr>
<tr>
<td>bl_is_occ_suppressed</td>
<td>If set to <strong>true</strong>, the line is hidden unless you choose <strong>Show Suppressed Occurrences</strong>. Occurrences may be suppressed by a CAD tool. This property may be edited for a specific arrangement.</td>
<td>All</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_is_suppressed</td>
<td>If <strong>true</strong>, the line is suppressed or not configured.</td>
<td>All</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_item_altid_list</td>
<td>Shows the alternate ID of the item or item revision represented by the line.</td>
<td>Alternate IDs</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_item_ip_classification</td>
<td>Shows the intellectual property (IP) classification attribute of the part occurrence.</td>
<td>All</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_markup_type</td>
<td>Shows the markups (if any) that you can display for the selected line.</td>
<td>All</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_occ_xform_matrix</td>
<td>Shows the non-PLM XML transformation matrix value assigned to the part occurrence.</td>
<td>Transformation matrix</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_plmxml_abs_xform</td>
<td>Shows a run-time, rolled-up PLM XML transformation matrix value assigned to the part occurrence.</td>
<td>Transformation matrix</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_plmxml_occ_xform</td>
<td>Shows the PLM XML transformation matrix value assigned to the part occurrence.</td>
<td>Transformation matrix</td>
<td>Structure line</td>
</tr>
<tr>
<td>bl_substitute_id_compare</td>
<td>Specifies the ID of the selected substitute that is used in comparisons.</td>
<td>Compare</td>
<td>Substitute</td>
</tr>
<tr>
<td>bl_substitute_name_compare</td>
<td>Specifies the ID of the selected substitute that is used in comparisons.</td>
<td>Compare</td>
<td>Substitute</td>
</tr>
<tr>
<td>Changed by Current IC</td>
<td>Set to <strong>Y</strong> if the item is affected by the current incremental change.</td>
<td>Incremental change</td>
<td>Incremental change/structure line</td>
</tr>
<tr>
<td>Changes</td>
<td>Set by the BOM comparison utility to indicate the nature of any changes relating to this line.</td>
<td>Compare</td>
<td>Display</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
<td>Application</td>
<td>Object</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------------------------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>CO - Checked out</td>
<td>Set to Y if the item revision is checked out.</td>
<td>Teamcenter Integration for NX</td>
<td>Display</td>
</tr>
<tr>
<td>Configured IC's</td>
<td>Shows the currently configured incremental changes.</td>
<td>Incremental change</td>
<td>Incremental change/structure line</td>
</tr>
<tr>
<td>Default Unit of Measure</td>
<td>Shows the default unit of measure for the item. It may be overridden for an individual occurrence.</td>
<td>All</td>
<td>Item</td>
</tr>
<tr>
<td>Effectivity ID</td>
<td>Shows the ID of the date effectivity object on the occurrence.</td>
<td>Effectivity</td>
<td>Occurrence</td>
</tr>
<tr>
<td>EOC - Effective Occ. Config’d</td>
<td>Indicates if this occurrence is configured by the date set in the current revision rule. Set to Y for yes, blank for no.</td>
<td>Effectivity</td>
<td>Display</td>
</tr>
<tr>
<td>Find No.</td>
<td>Find number of the line in the structure. Editable.</td>
<td>All</td>
<td>Occurrence</td>
</tr>
<tr>
<td>GDELine Name</td>
<td>Shows the item element name.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>Generic Component</td>
<td>Indicates if this is a generic component.</td>
<td>Variants</td>
<td>Item</td>
</tr>
<tr>
<td>Has Substitutes</td>
<td>Set to Y if the line has substitutes; otherwise, blank.</td>
<td>Substitutes</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Has Children</td>
<td>Set to Y if the line has any children; otherwise, blank.</td>
<td>All</td>
<td>BOM view revision</td>
</tr>
<tr>
<td>HVD - Has Variant Data</td>
<td>Set to Y if the item revision has any variant data (options, defaults, or rule checks).</td>
<td>Variants</td>
<td>Item revision</td>
</tr>
<tr>
<td>Has Legacy Occurrence Effectivity</td>
<td>Indicates if the occurrence has associated legacy effectivity.</td>
<td>Effectivity</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Has Module</td>
<td>Indicates if there is an associated module.</td>
<td>Variants</td>
<td>Display</td>
</tr>
<tr>
<td>Has Notes</td>
<td>Indicates if a standard note or custom note is attached to the line.</td>
<td>All</td>
<td>Item or item revision</td>
</tr>
<tr>
<td>Has Trace Link</td>
<td>Indicates if the line is the source or target of a trace link.</td>
<td>All</td>
<td>Item, item revision, or absolute occurrence</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
<td>Application</td>
<td>Object</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Has Unified Occurrence Effectivity</td>
<td>Indicates if the occurrence has associated unified effectivity.</td>
<td>Effectivity</td>
<td>Display</td>
</tr>
<tr>
<td>IC Effectivity</td>
<td>Shows the effectivity of the current incremental change on the occurrence.</td>
<td>Incremental change</td>
<td>Incremental change/structure line</td>
</tr>
<tr>
<td>IC Intent</td>
<td>Shows if the occurrence is configured by the current incremental change intent.</td>
<td>Incremental change</td>
<td>Incremental change/structure line</td>
</tr>
<tr>
<td>IC Release Status</td>
<td>Shows the release status of the relevant incremental change.</td>
<td>Incremental change</td>
<td>Display</td>
</tr>
<tr>
<td>ID In Context (All Levels)</td>
<td>Shows the occurrence identifier in the context of all levels.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>ID In Context (Top Level)</td>
<td>Shows the occurrence identifier in the context of the top-level item.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>IOC configured</td>
<td>Shows if the occurrence is configured by the current incremental change.</td>
<td>Incremental change</td>
<td>Incremental change/structure line</td>
</tr>
<tr>
<td>Is PublishLink Source</td>
<td>Shows Y if the line represents the source occurrence of a publish link.</td>
<td>Part-CAD alignment</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Is PublishLink Target</td>
<td>Shows Y if the line represents the target occurrence of a publish link.</td>
<td>Part-CAD alignment</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Item Classified</td>
<td>Set to YES if the item is classified directly or to yes if the classification data is inherited from the item revision. If blank, the item is not directly or indirectly classified.</td>
<td>Classification</td>
<td>Display</td>
</tr>
<tr>
<td>Item Description</td>
<td>Shows a description of the item.</td>
<td>All</td>
<td>Item</td>
</tr>
<tr>
<td>Item ID</td>
<td>Shows the ID of the item.</td>
<td>All</td>
<td>Item</td>
</tr>
<tr>
<td>Item Name</td>
<td>Shows the name of the item.</td>
<td>All</td>
<td>Item</td>
</tr>
<tr>
<td>Item Revision Classified</td>
<td>Set to YES if the item revision is classified directly or to yes if the classification data is inherited from the item. If blank, the item revision is not directly or indirectly classified.</td>
<td>Classification</td>
<td>Display</td>
</tr>
</tbody>
</table>
## Chapter 6  Managing properties and notes

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
<th>Application</th>
<th>Object</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Item Revision Status</strong></td>
<td>Displays the release status of the item revision.</td>
<td>All</td>
<td>Item revision</td>
</tr>
<tr>
<td><strong>Item Revision Subclass Name</strong></td>
<td>Displays the name of the subclass to which the item revision belongs.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td><strong>Item Subclass Name</strong></td>
<td>Displays the name of the subclass to which the item belongs.</td>
<td>Classification</td>
<td>Display</td>
</tr>
<tr>
<td><strong>Item Type</strong></td>
<td>Shows the business object type of the item.</td>
<td>All</td>
<td>Item</td>
</tr>
<tr>
<td><strong>Make/Buy</strong></td>
<td>Indicates if you manufacture a part or purchase it from a supplier. It is set to <strong>None</strong> if the line does not represent a part or if you do not use this property. It cannot be set on an occurrence.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td><strong>MCVD — Has Classic Variant Data</strong></td>
<td>Indicates if there is associated classic variant data.</td>
<td>Variants</td>
<td>Display</td>
</tr>
<tr>
<td><strong>MCE — Has Occurrence Effectivity</strong></td>
<td>Indicates if there is associated occurrence effectivity data.</td>
<td>Occurrence Effectivity</td>
<td>Display</td>
</tr>
<tr>
<td><strong>Occurrence Date Range</strong></td>
<td>Shows the range of dates for which the occurrence is effective.</td>
<td>Effectivity</td>
<td>Occurrence</td>
</tr>
<tr>
<td><strong>Occurrence Effectivity</strong></td>
<td>Shows if there is applicable occurrence effectivity.</td>
<td>Effectivity</td>
<td>Display</td>
</tr>
<tr>
<td><strong>Occurrence Effectivity ID</strong></td>
<td>Shows the identifier of any occurrence effectivity.</td>
<td>Effectivity</td>
<td>Display</td>
</tr>
<tr>
<td><strong>Occurrence Name</strong></td>
<td>Displays a user-defined name for the occurrence. It cannot be overridden in context.</td>
<td>All</td>
<td>Occurrence</td>
</tr>
<tr>
<td><strong>Pack Count</strong></td>
<td>Shows the number of occurrences that a packed line represents.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td><strong>Packed</strong></td>
<td>Set to <strong>Y</strong> if the displayed line represents multiple packed lines; otherwise blank.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td><strong>Part Number</strong></td>
<td>Displays the identification number of a part.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
<td>Application</td>
<td>Object</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Position Designator</td>
<td>Shows a value that represents the position of a single part from a line of usage. For example, if the line of usage references four wheels, there are four position designators—one for each wheel.</td>
<td>All</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Precise</td>
<td>Set to Y if this BOM view revision is precise, otherwise blank.</td>
<td>All</td>
<td>BOM view revision</td>
</tr>
<tr>
<td>Published Data from Source</td>
<td>Set to TRANSFORM or SHAPE to indicate data that has been published from the source occurrence.</td>
<td>Part-CAD alignment</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Quantity</td>
<td>Shows the quantity of the item represented by this line.</td>
<td>All</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Qty Change</td>
<td>Set by the structure comparison feature to indicate a change in quantity of an item between two structures.</td>
<td>Compare</td>
<td>Display</td>
</tr>
<tr>
<td>Ref Designator</td>
<td>Displays a unique identifier for an occurrence of a part. It cannot be overridden in absolute occurrence mode. Editable.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>Requires Design</td>
<td>Indicates if a part requires a CAD design. Certain parts do not require a design, for example, paint or glue.</td>
<td>All</td>
<td>Part</td>
</tr>
<tr>
<td>Revision</td>
<td>Shows the ID of the item revision.</td>
<td>All</td>
<td>Item revision</td>
</tr>
<tr>
<td>Rev Change</td>
<td>Set by the structure comparison feature to indicate a change in revision of an item between two structures.</td>
<td>Compare</td>
<td>Display</td>
</tr>
<tr>
<td>Rev Description</td>
<td>Displays a description of the item revision.</td>
<td>All</td>
<td>Item revision</td>
</tr>
<tr>
<td>Rev Name</td>
<td>Shows the name of the item revision.</td>
<td>All</td>
<td>Item revision</td>
</tr>
<tr>
<td>Rev Process Stage</td>
<td>Displays the release process stage of the item revision, if it is in a process.</td>
<td>Workflow</td>
<td>Item revision</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
<td>Application</td>
<td>Object</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Rule configured by</td>
<td>Shows the name of the revision rule that configures this item revision.</td>
<td>Revision configuration</td>
<td>Display</td>
</tr>
<tr>
<td>Structure Line</td>
<td>Contains a combination of item ID, revision ID, revision name, view name, and quantity.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>Structure Line Name</td>
<td>Contains a combination of item ID, revision ID, and revision name.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>Structure Line Title</td>
<td>By default, shows the same text as Line, but you can edit the format.</td>
<td>All</td>
<td>Display</td>
</tr>
<tr>
<td>Substitute</td>
<td>Set to Preferred if the line has any substitutes.</td>
<td>Substitutes</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Unit of Measure</td>
<td>Shows the unit of measure for the occurrence. Overrides the default unit of measure for the item.</td>
<td>All</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Usage Address</td>
<td>Displays the type of object that occupies the occurrence in the structure, for example, wheel.</td>
<td>All</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Variant Condition</td>
<td>Shows the variant condition under which the occurrence is configured. Only used with the old classic variant model, as described in Using the Variant Formula property.</td>
<td>Variants</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Variant Formula</td>
<td>Shows the variant formula under which the occurrence is configured. Only used with the new classic variant model, as described in Using the Variant Formula property.</td>
<td>Variants</td>
<td>Occurrence</td>
</tr>
<tr>
<td>Vendor Parts</td>
<td>Shows related vendor parts and vendor location data, determined by the current vendor part selection rule.</td>
<td>Vendor management</td>
<td>Item revision</td>
</tr>
<tr>
<td>View Type</td>
<td>Shows the type of the BOM view revision.</td>
<td>All</td>
<td>BOM view revision</td>
</tr>
</tbody>
</table>
### Column Description

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
<th>Application</th>
<th>Object</th>
</tr>
</thead>
<tbody>
<tr>
<td>VOC - Variant Occ.</td>
<td>Indicates if this occurrence is configured by the current variant rule. Set to Y for yes, blank for no, or ? for undefined.</td>
<td>All</td>
<td>Display</td>
</tr>
</tbody>
</table>

**Note** You cannot edit or mark up the first property column (Quantity).

**Tip** You can use some of additional properties not listed in the table to determine why a particular line is configured or hidden, for example:

- **bl_is_occ_configured**
  Shows if the line is configured by the current occurrence effectivity.

- **bl_ic_state**
  Shows if the line is configured by the current incremental change.

- **bl_variant_state**
  Shows if the line is configured by the active variant.

### Creating and editing display names

BOM line properties have both display names and system names, and the system names are in the format `bl Xxx`. You should define a display name for a system name if you add a custom business object type to your system.

Define a display name for a BOM line using the `BOMLineFormConfiguredProperties` and `BOMLineRevFormConfiguredProperties` global constants and compound properties available on the `BOMLine` business object in the Business Modeler IDE.

**Caution** Siemens PLM Software recommends that you do not include a dot (.) in the property name. Such names cannot be edited in Structure Manager.

**Note** In previous versions, the administrator could create or change display names by editing the `/textserver/xml` files in the `lang` folder, for example, `system_property_names_locale.xml`. Display names are no longer stored in XML files, and you can now only create or edit them in the Business Modeler IDE.

### Create a display name

1. In the Business Modeler IDE, open the `BOMLine` business object and click the Properties tab.
2. Select the property whose display name you want to create and scroll to the Localization section.
3. Click Add.
The Business Modeler IDE displays the **Add or Modify Localization** dialog box.

4. Enter the display name in the **Value Localization** box, select the locale, and set the status to **Approved**.

5. Save the data model and deploy the template.

For more information on working with display names in the Business Modeler IDE, see the *Business Modeler IDE Guide*.

**Managing column configurations**

You can save and apply column configurations available for your group and configure your view of Structure Manager to view and edit only those properties that your group deals with. Depending on your role, you can save column configurations.

- A *site* administrator can save configurations with the scope set to **User**, **Group**, or **Site**.

- A *group* administrator can only save configurations with the scope set as **User** and **Group**.

- If a site has multiple levels of groups, users can access the site configurations and configurations for all groups to which they belong.

**Save column configuration**

1. Right-click the column header and choose **Save Column Configuration**.

   The **Save Column Configuration** dialog box appears.

2. Type values in the **Name** and **Description** boxes.

   **Note** Column configuration names should be unique.

3. Select the **Scope** option as **User**, **Group**, or **Site**.

   **Note** The options you see enabled depend on your role. If you are a site administrator, you see all three options enabled. If you are a group administrator, you see the **User** and **Group** options enabled. If you are not an administrator, no option displays and the column configuration is saved at the user level.

4. Click **Save**.

   Teamcenter creates a column configuration and saves it for the chosen scope.

**Apply column configuration**

1. Right-click the column header and choose **Apply Column Configuration**.

   The **Apply Column Configuration** dialog box appears with the column configurations available to you, your group, or site.
2. Select the column configuration name you want to apply to the tree table and click **Apply**.

Teamcenter applies the column configuration to the tree table and adjusts the columns in the Structure Manager window according to the applied configuration.

3. Close Structure Manager and then reopen it again to verify that the correct column configuration is applied.

**Update column configuration**

1. Right-click the column header and choose **Apply Column Configuration**.

The **Apply Column Configuration** dialog box appears.

2. Select the column configuration name depending on your role.

   **Note** If you are a site administrator, select the site column configuration name. If you are a group administrator, select the group column configuration name. If you are not an administrator, select the user column configuration name.

3. Click **Modify** to modify the column configuration.

   The **Change Column** dialog box appears allowing you to update the selected configuration.

4. When you have updated the column configuration, click **Apply**.

   Teamcenter updates the column configuration for the current and future sessions.

**Delete column configuration**

1. Right-click the column header and choose **Apply Column Configuration**.

   The **Apply Column Configuration** dialog box appears.

2. Select the column configuration name depending on your role.
Chapter 6  Managing properties and notes

Note If you are a site administrator, select the site column configuration name. If you are a group administrator, select the group column configuration name. If you are not an administrator, select the user column configuration name.

3. Click **Delete** to delete the column configuration.

   Teamcenter displays the **Delete Column Configuration** dialog box.

   Click **OK** to confirm confirmation of the selected column configuration.

Freeze columns

You can freeze selected columns on the left of the pane, so they are always visible when you scroll horizontally, for example, making the item name and number visible while you browse other properties.

1. Set the **BOM_Frozen_Column_Count** preference to a positive integer—\( n \) corresponding to the number of columns you want to freeze.

2. Launch Structure Manager.

   The system displays \( n \) columns frozen on the left. You can scroll the remaining columns horizontally.

   **Tip** You always leave at least one column unfrozen, so that vertical scroll bars are available. This configuration provides easier navigation, especially if you are comparing structures in a split window. If you try to remove the last unfrozen column, Teamcenter displays a **Cannot delete the last column outside of the frozen area** error message.

   **Note** If you reset the **BOM_Frozen_Column_count** preference to 0, no columns are frozen.

   This preference freezes a specified number of columns independently of the selected column configuration. You cannot freeze specific columns.

View properties

- To view the properties of a selected line in the product structure, click **Properties** on the toolbar or choose **View→Properties**.

   Teamcenter displays the **Properties** dialog box containing the properties of the selected line.

Modify common properties

1. Select the lines representing items or item revisions in the product structure whose properties you want to modify and choose **View→Properties**.

   Teamcenter displays the **Common Modifiable Properties** dialog box, as shown in the following example.
If you select a single structure line, Teamcenter displays the **Properties** dialog box containing the properties of the selected line.

In the example, the **Absolute Transformation**, **Item Description**, and **Item Type** properties are common and can be modified. The other properties are unique to each line and cannot be modified here; however, you can modify them *in place*, as described in *Editing a single property in place*.

It is not necessary to check out the source object if you want to modify properties.

2. Click the **BOM Lines** tab in the dialog box. This tab shows the common modifiable properties of the items corresponding to the selected lines. Select the property you want to change and enter its new value in the text box.

In the example, the **Item Description** property is selected and is modified to the value of **Test**.

When the correct replacement value is shown in the text box, click the **✓** button to complete the change. Alternatively, you can click the **✗** button to clear (delete) the current value.

Click the **═** button to display the **Find/Replace** dialog box that allows you to search for any property value.

3. Click the **Item Revisions** tab in the dialog box. This tab shows the common modifiable properties of the item revisions corresponding to the selected lines. Repeat the process given in the previous step to update the values of common modifiable properties of item revisions.

4. Click **OK** or **Apply** to update the properties of the selected items and item revisions.

5. To commit the changes to the database, choose **File→Save**.
Chapter 6  Managing properties and notes

The pending edit markup option highlights some occurrence property edits, including edits to the occurrence name, find number, reference designator, quantity, unit of measure, notes, variant conditions, and occurrence type. However, absolute occurrence (in-context) edits are not highlighted.

For more information, see Highlighting edits to the structure.

If you select multiple lines, Teamcenter displays the common properties of the selected objects. If you edit any of the common properties and then click OK or Apply, Teamcenter saves the property changes to the database but does not update the dialog box. To display the property changes, choose View→Refresh window.

If you want to modify a common property for several but not all lines, copy the required value, right-click each line in turn, and then choose Paste Property.

If you have a large number of property columns to modify, it may be easier to export the structure lines to Microsoft live Excel, make the necessary edits, and then import the modified data back to Structure Manager.

For more information about editing structure data with live Excel, see the Extensions for Microsoft Office Guide.

Editing a single property in place

You can edit a single modifiable property in place by double-clicking the appropriate cell in the properties list and entering the new value. Changes made in this way are immediately committed to the database, together with the associated item or item revision.

Property values you can edit include the find number and reference designator. Find numbers and reference designators can only be edited if the product structure is unpacked. Teamcenter verifies a reference designator is in the correct format after editing; examples of the acceptable formats are C1 or SKA21. To verify the format and uniqueness of reference designators, set the PS_Reference_Designator_Validation preference to on. By default, this preference is set to off and no validation is performed.

Editing of certain properties may not be permitted, even though selection of the associated cells is not disabled. If you try to edit such a property, Teamcenter displays an error message, indicating the cell cannot be edited.

You cannot edit occurrence note types in this way.

If you want to modify a common property for several, but not all lines, copy the required value, right-click each line in turn, and then choose Paste Property.

Edit find numbers

The components in a single-level assembly can be arranged by find number if you click the appropriate column header in the properties table. If you edit a find number in such a way that the order of the structure components must be changed,
they are not reordered until you collapse and expand the particular structure or open it in a new window.

If you change the find number of packed lines, this action changes the find number of all the packed lines.

**Edit quantities**

If you edit a quantity, Teamcenter enforces the following restrictions:

- If the quantity is a property of an item that has no unit of measure defined or has a unit of measure of **Each**, the value must be a whole number.

- If the quantity is a property of an item that has a unit of measure defined, you can enter a whole number. You can also enter an **A/R** string (case insensitive) to indicate *as-required*; you can abbreviate this entry to a.

- By default, you can specify quantities to two decimal places. However, your administrator can edit the **Displayed_Decimals_for_Qty** preference to change this restriction.

You cannot edit the quantity on lines that are packed.

For additional information, see *Creating aggregate occurrences and defining quantity*.

**Adding a compound property**

A **compound property** is a property on a business object that can be displayed as a property of an object (the display object) although it is defined and resides on a different object (the source object). A compound property uses **Relation** and **Reference** properties to traverse from the source to the destination object. A compound property creates the path that the property follows to display the source object’s property on the display object, if the path exists for the two objects. For example, you can use a compound property to display a custom property from a form on a BOM line business object.

For more information about adding compound properties, see the *Business Modeler IDE Guide*.

**Displaying item master form attributes**

You can configure attributes on the item master form, and then use compound property rules so that the attributes are visible on item revisions. To achieve this, you must define and set the following global constants in the **foundation** template of the Business Modeler IDE:

- **BOMLineFormConfiguredProperties**
  
  Adds the properties from the form types in the constant to the BOM line. This configuration point was provided by the **PSE_add_props_of_item_form_types** preference in previous versions.

- **BOMLineRevConfiguredProperties**
Chapter 6  Managing properties and notes

Adds the properties from the revision form type to the BOM line. This configuration point was provided by the `PSE_add_props_of_rev_form_types` preference in previous versions.

For more information about setting global constants, see the Business Modeler IDE Guide.

If either constant is set, all the form properties from the form type are added to the BOM line. By default, the foundation template sets the values of the constants to the item master and item revision master, respectively.

You can then add the attribute to display as a column, as described in Displaying properties. The attribute name is shown in fully qualified format, for example, if your item master attribute name is `A_SPLM`, the column name is shown as `bl_Item_Master_A_SPLM`.

You can optionally change the displayed column name by editing the `system_property_names_locale.xml` file in the `$TC_ROOT\lang\textserver\en` directory. Add an entry for the display name in the following format:

```xml
<key id="bl_Item Master_A_SPLM">A_SPLM_description</key>
```

`A_SPLM_description` is the required display name.

Creating structure properties rollup reports

A rollup is a recursive calculation of selected properties of all children of a selected line in the structure. For example, you can create rollup reports of the mass, center of mass, or moments and products of inertia for a particular assembly.

You can also create and view rollup reports periodically or in batches with the `bom_roll_up_report` utility. Teamcenter creates these reports as XML files and attaches them to a Roll Up Report dataset. The rollup process unpacks the BOM before doing any calculations.

**Tip** You can generate mass and center of mass reports from Teamcenter from data stored in NX, as an alternative to generating the report directly from NX. To do this, you must first define the necessary compound properties and rollup templates. (Teamcenter does not provide the necessary rollup templates or store NX mass compound properties in the database.) You may encounter issues if you try to create a rollup report using compound properties that are defined on the BOM line. Consequently, Siemens PLM Software recommends that you define the compound properties on the item revision or on your custom item revision type.
Tip
Use the Input Accuracy column to determine if the properties of the line being rolled up are used as-is or calculated from the rolled-up values of its children (asserted). This column supports NX, but you can use it with any other system that permits you to choose between asserted values at an assembly level or values derived from the values of its children. NX allows you to assert static mass property values on its parts.

If you do this, the accuracy property on the UGPartMassPropsForm form that is attached to the UGMASTER dataset in Teamcenter is set to -1.0. The value of the accuracy property determines whether the rollout process calculates the values of specific assembly levels. To do this, create a compound property that represents the accuracy property on the UGPartMassPropsForm form and then apply that compound property to the Input Accuracy column.

The Input Accuracy column is available on the Summation, Center of Mass, and Inertia calculation tabs of the Roll up Report Templates dialog box.

Tip
The formulas used to determine center of mass and moments/products of inertia depend on the use of bl_plmxml_abs_xform in the Input Transformation Matrix column in both the center of mass and moments/products of inertia templates.

Use bl_plmxml_abs_xform in the Input Transformation Matrix column.

Note
Use the ROLL_UP_QUANTITY_FLAG preference to define if the rollout calculation takes the quantity into account. For example, if the quantity on a line is 2, the value is doubled for both the line and the substructure. If this preference is set to false, the quantity is included in the summation; if it is set to true, the quantity is excluded. Quantity only applies to rollups of mass.

Substitutes are not included in rollout reports.

Create a structure rollout report template

You create templates to define the standard content of rollout reports. To create a template, you must be a member of the appropriate group:

- Site templates
  You must belong to the DBA group to create, edit, or delete site templates.

- Group templates
  You can create, edit, or delete group templates if you are a member of the group.

- User templates
  You can create, edit, or delete your own user templates.

Note
A member of the DBA group can create, edit, or delete group or user templates if bypass is turned on

1. Choose Tools→Rollup Reports→Templates.
   Teamcenter displays the Roll Up Template Manager dialog box.
2. Optionally, select an existing template in the Templates list to use as the basis of the new template. You can only select from templates that your group has permission to modify.

3. Enter the template name or change the name of the preloaded template. The template name must be unique within the group.

4. Enter a template description, which Teamcenter uses as the name of the rollup dataset, for example, <Item_ID> <Rev_ID> <RT_name> <RT_date> <RT_Mass Total>.

5. Check one of the Scope options to indicate users who have access to the template—Site, Group, or User.

6. Enter the delimiter to use between data fields if this report is exported to a text file. The default character is a tab.

   **Note** To export rollup reports and open them in Microsoft Excel, change the default delimiter character to a comma (,). If you leave the default delimiter as a tab, the data columns do not display correctly in Excel.

7. Add or delete Summation, Center of Mass, and Moments/Products calculations for any relevant structure line property.

8. Add or delete any other properties to include in the rollup report in the Reference box. Referenced properties are not included in rollup calculations.

9. Click OK or Apply to save the new template in the database.

### Create a structure rollup report

1. Select the top-level line of the product or assembly.

2. Choose Tools→Rollup Reports→Create.

   Teamcenter displays the Create Roll Up Report dialog box.

3. Enter the name of the generated report in the Name box. By default, the name is generated from that of the root item revision.

4. Optionally, edit the description of the report in the Description box. The description is generated from the report template and typically is not changed.

5. Enter the delimiter to use if this report is exported to a text file. The default character is a tab character.

   **Note** If you intend to open the report in Microsoft Excel, change the default delimiter character to a comma (,). If you leave the default delimiter as a tab, the data columns do not display correctly in Excel.

6. Choose the name of the report template to use from the Template list.

7. Optionally, select the name of the destination directory for the report in the Output Folder box. By default, this is blank.
8. Click **OK** to generate the report.
   Teamcenter saves it in a rollup dataset that it attaches to the item revision of the root line of the report.

**View or edit a structure rollup report**

- Choose **Tools→Rollup Reports→View/Edit** and Teamcenter displays a list of reports you can select.

   The report contains the following data fields:

   o **Roll Up Reports**
     
     Lists all reports attached to the item revision. For each report, complete information is shown for the top level line, allowing you to identify its content without opening the report. To show the details in the selected report, click **Details**.

   o **Details**
     
     Shows the detailed content of the selected report.

   To create a new report based on the information in the current report, click **Create**.

**Export a structure rollup report**

1. Choose **Tools→Rollup Reports→View/Edit**.
   Teamcenter displays a list of available reports.

2. Select a report and click **Export**.
   Teamcenter displays the **Export** dialog box.

3. Enter or browse to the desired destination directory, then click **OK**.
   Teamcenter exports the content of the report in a text file to the operating system.

**Using the Variant Formula property**

Effective from Teamcenter 8.2, a new BOM line property with a system name of `bl_formula` and a display name in the English locale of **Variant Formula** allows you to view and edit variant expressions. To achieve best performance, Siemens PLM Software recommends you reconfigure your list of displayed BOM line properties in structure editor applications by replacing the existing `bl_variant_condition` property (English locale display name **Variant Conditions**) with this new property. Teamcenter continues to support the **Variant Conditions** BOM line property but, to compute the property text value from new style variant expressions, it must convert the new variant expression into the old variant data model. This conversion eliminates the performance and memory footprint benefits of the new variant data model. (If you avoid the computation of the old style variant expression data format in this way, you typically reduce the number of objects in memory by several million).
The new **Variant Formula** property is available only if you enable the new data model.

You can edit the new **Variant Formula** BOM line property in the usual way, by double-clicking the cell to display the **Edit Variant Condition** dialog window. When you do this, Teamcenter converts the variant expression into the old data model; however, the performance impact is more limited as only data for the selected BOM line is converted.

The differences between the old and new BOM line properties are shown in the following table.

<table>
<thead>
<tr>
<th></th>
<th>Old Variant Conditions property</th>
<th>New Variant Formula property</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>English locale display name</strong></td>
<td>Variant Conditions</td>
<td>Variant Formula</td>
</tr>
<tr>
<td><strong>Internationalization property name key</strong></td>
<td>bl_variant_condition</td>
<td>bl_formula</td>
</tr>
<tr>
<td><strong>Operator precedence and associativity</strong></td>
<td>All Boolean operators have the same precedence. All operators are left-associative, that is, A OR B AND A = (A OR B) AND A.</td>
<td>NOT (!) is higher than AND (&amp;); AND (&amp;) higher than OR (</td>
</tr>
<tr>
<td><strong>Internationalization value</strong></td>
<td>Yes</td>
<td>No. Operators are represented by static symbols.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>I18N key</th>
<th>English value</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_variant_op_is_equal</td>
<td>=</td>
</tr>
<tr>
<td>k_variant_op_not_equal</td>
<td>!=</td>
</tr>
<tr>
<td>k_variant_op_gt</td>
<td>&gt;</td>
</tr>
<tr>
<td>k_variant_op_lt</td>
<td>&lt;</td>
</tr>
<tr>
<td>k_variant_op_gt_eq</td>
<td>&gt;=</td>
</tr>
<tr>
<td>k_variant_op_lt_eq</td>
<td>&lt;=</td>
</tr>
<tr>
<td>k_variant_op_and</td>
<td>AND</td>
</tr>
<tr>
<td>k_variant_op_or</td>
<td>OR</td>
</tr>
<tr>
<td>k_variant_op_not</td>
<td>NOT</td>
</tr>
<tr>
<td>Old Variant Conditions property</td>
<td>New Variant Formula property</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Decodable text values (bijection)?</td>
<td>Yes. A text value may be parsed back into its variant expression. For example, you can enclose a value name of 4 AND/Item/Fam = val (a 21 character value) in single quotes to pause special character interpretation when parsing. The text value uses the following punctuation marks:</td>
</tr>
<tr>
<td></td>
<td>[ Left square bracket Begin option family name space (owning item ID). ]</td>
</tr>
<tr>
<td></td>
<td>] Right square bracket End option family name space (owning item ID).</td>
</tr>
<tr>
<td></td>
<td>( Left parenthesis Begin overriding normal precedence. )</td>
</tr>
<tr>
<td></td>
<td>) Right parenthesis End overriding normal precedence.</td>
</tr>
<tr>
<td></td>
<td>' Single quote Pause or resume interpretation.</td>
</tr>
<tr>
<td></td>
<td>\ Escape Do not interpret next character.</td>
</tr>
</tbody>
</table>

**PSE_show_option_item_prefix** preference The owning option item is suppressed if this preference is turned off.

The owning option item is suppressed if this preference is turned off and the variant option family is unique in the context of the top-level item revision of a BOM window.

**Note** If you use the **Variant Conditions** property, the owning option item is suppressed if this preference is turned off. If you use the **Variant Formula** property, the owning option item is suppressed if this
## Displaying occurrence notes

You can display selected occurrence note types or the text of all available notes.

**Note**  Do not confuse notes that are attached to an occurrence with standard notes and custom notes attached to an item or item revision.

### Display a single note type

You can configure the displayed columns to show only those containing those occurrence note types you want to see, as described in [Viewing product structure properties](#). You can specify any of the note types created by your Teamcenter administrator for the site.

### Display the all notes column

Typically only one occurrence note is attached to each component. However, if you use a large number of note types, providing a column for each note type occupies a great deal of space in the window. In this situation, use the All Notes column to display notes of any type.

---

<table>
<thead>
<tr>
<th>Old Variant Conditions property</th>
<th>New Variant Formula property</th>
</tr>
</thead>
<tbody>
<tr>
<td>preference is turned off and the variant option family is unique in the context of the top-level item revision of a BOM window. Even when the preference is turned off, the owning option item may not be suppressed in certain situations to avoid ambiguity in the resulting formula expression. For example, this may be necessary when an option is defined on an intermediate assembly but is not defined on the top assembly.</td>
<td></td>
</tr>
<tr>
<td><strong>PSE_show_option_family_prefix</strong> preference</td>
<td>The variant option family name is suppressed if the preference is turned off and the variant option value is unique in the context of the top-level item revision of a BOM window.</td>
</tr>
</tbody>
</table>
If a component only has one note, the **All Notes** column shows the text of the note, preceded by the name of the note type and a colon. If the component has several notes, the column shows a comma-separated list of the note types.

**Editing and copying occurrence notes**

Your Teamcenter administrator creates all the occurrence note types required for your site, for example, a note type to contain assembly cost and another for a torque value. You can make use of any of these note types to specify a value for a particular occurrence line in the structure.

Notes are occurrence properties, and you should not use them to specify attributes of an item, for example, revision or material.

**Note** There are a number of special occurrence note types that are used by Teamcenter Integration for NX, for example, **NX REF SET**.

For information, see the *Teamcenter Integration for NX Guide*.

You can edit an occurrence note in the same way as any other property, except for the **All Notes** property.

**Set the value of an occurrence note**

When you create an occurrence note in the Structure Manager window on a particular line, Teamcenter populates the value of the corresponding note with the default value of the note type, if one exists. If a list of values (LOV) is attached to the note type, you can select a value from the list when you create a note.

**Note** You must have write access to the BOM view revision. Otherwise, you can only browse existing occurrence notes not add, remove, or edit notes.

1. Select the appropriate line in the product structure.

2. Choose **View→Notes** or click the **Add/Edit Notes** button on the toolbar, or double-click the **All Notes** column in the properties table.

   Teamcenter displays the Notes editor.

3. In the Notes editor, choose the **Existing Notes List of Values** option and select an existing note to view or edit. Alternatively, choose the **Create List of Values** option to add a new note type.

   If the note has a list of values (LOV), select the appropriate value from the list.

   A default value may initially be selected in the LOV. The default value is *not* set on the note until you actually create the note.

   To change the default value of a note:

   a. Select a structure line that represents an occurrence and the corresponding column for the note.

   b. Click the **Add or Edit Notes** button.
Teamcenter displays the Notes dialog box.

c. In the Notes dialog box, set a value manually or choose from the LOV.

4. Enter a note of up to 160 characters, depending on the particular note type.

5. Repeat steps 3 and 4 for more note types if required.

6. Click OK to apply your changes or click Cancel to exit.

7. Choose File→Save to commit the changes to the database.

Remove a note

- Click Remove if you want to delete the currently displayed note.

Copy a note

1. Select the line with the note text you want to copy. You can select any point on the line, not necessarily the note type cell itself.

2. Right-click the selected line over the cell containing the note you want to copy.
   Teamcenter displays the structure line shortcut menu.

3. From the shortcut menu, choose Copy to copy the contents of the occurrence to the clipboard. You can also use the Ctrl+C shortcut keys.

4. Right-click the cell of the note type of the target line where you want to copy the occurrence.
   Teamcenter displays the structure line shortcut menu.

5. From the shortcut menu, choose Paste Property to complete copying the occurrence.

   Note There is no shortcut for the paste action; you cannot use Ctrl+V.

Viewing packed notes

If a set of occurrences is packed and any of the occurrences has notes, any notes columns display Packed notes for the packed line. You cannot edit the packed notes.

Tracking occurrence note changes

Teamcenter creates structure change records for occurrence note changes when changes to the structure are saved, if the ECM_note_types_to_track preference is set accordingly. Occurrences note changes are also tracked in the appearance cache (if used) if you set mapped attributes.

For more information about viewing note change history, see Managing supersedure.
Chapter

7 Visualizing product structure

Visualizing product structure ........................................... 7-1
Using stand-alone Lifecycle Visualization .......................... 7-1
Viewing a structure in Lifecycle Visualization .................. 7-2
Using the embedded viewer ............................................. 7-2
  Structure Manager viewer ........................................... 7-3
  Configuring a viewer cache ....................................... 7-5
  Opening the structure ............................................. 7-5
  Refresh the embedded viewer .................................. 7-6
Understanding the structure tree ..................................... 7-6
Synchronizing the structure tree and the viewer ................ 7-7
Isolate parts for viewing .............................................. 7-8
Generate an outline image ............................................. 7-8
  Set outline preferences .......................................... 7-8
Manipulate graphics .................................................. 7-9
Save the current session ............................................... 7-10
Working with product views .......................................... 7-10
  Create and save a product view ................................ 7-11
  Configure and manage product views ......................... 7-12
  Previewing product views ...................................... 7-15
  Create product view preview manually ...................... 7-16
  Manage unconfigured data in a product view ............. 7-17
  Retrieve and open an existing product view ............... 7-18
  Checking product views in and out .......................... 7-19
    Check out product view dataset ........................... 7-19
    Check in product view dataset ............................ 7-19
    Cancel checkout of product view dataset ................. 7-19
  Refresh a product view ........................................ 7-19
  Send a product view to an external viewer ............... 7-20
  Delete a product view .......................................... 7-20
Manipulating subcomponents ........................................ 7-20
  View subcomponents in an assembly ......................... 7-21
  Display selected subcomponent in expanded part file .... 7-21
Merge subcomponents ........................................... 7-21
Chapter 7

Visualizing product structure

You can visualize the structure of the product from Structure Manager in one of two ways—with the embedded viewer or the stand-alone Teamcenter lifecycle visualization product. The embedded viewer allows you to visualize the product structure in the same way as with the stand-alone Teamcenter lifecycle visualization, but within the Viewer tab of the data panel. If you want to use the enhanced Lifecycle Visualization capabilities of Teamcenter lifecycle visualization or the embedded viewer, you must purchase and install the necessary additional licenses.

Using stand-alone Lifecycle Visualization

Depending on how stand-alone Lifecycle Visualization is installed and configured for use with your rich client applications, one of the following levels of functionality is available to you:

- Teamcenter lifecycle visualization base
- Teamcenter lifecycle visualization standard
- Teamcenter lifecycle visualization professional
- Teamcenter lifecycle visualization mockup

Lifecycle Visualization is integrated with the rich client and enables you to view 2D formats, such as GIF, JPEG, CGM, and PNG files, as well as 3D formats, such as JT files.

JT file translators are required to generate 3D-format JT files. For example, the ugtopv translators shipped with the NX software translate UGMASTER datasets and create JT files in the database.

You can view the following 3D format or 2D format files:

- **DirectModel**
  
  Imported JT files or JT files created by the translators

- **DirectModelMotion**
  
  Imported VisMovieCapture files.

- **DirectModelMarkup**
  
  Captured image of a DirectModel dataset
Chapter 7  Visualizing product structure

- **DrawingSheets** and **Markup**
  Imported CGM files

- **Image**
  Imported files in formats such as TIFF, GIF, and JPEG.

To view the properties of an assembly or component JT file, right-click the line to which the file is attached and choose **Show JT Attributes**.

### Viewing a structure in Lifecycle Visualization

You can open a structure in stand-alone Lifecycle Visualization (if installed) by selecting the top-level assembly and choosing **File→Open in Lifecycle Visualization**.

When you use stand-alone Lifecycle Visualization, a viewing window opens containing the structure or assembly. To the left of this viewing window is a project workspace window that is a pane containing a tree display with buttons along the bottom. These buttons allow you to choose the context in which you are working, including assembly context (**View Structure Tree**), PMI context (**View PMI Tree**), snapshot context (**View Snapshots**), and cross-section context (**View Section Tree**).

By default, the **Open in Lifecycle Visualization** button and menu command are not visible in Structure Manager. You must set the **TC_show_open_in_vmu_button** preference to **on** to make them visible.

Lifecycle Visualization must be purchased separately and is not provided with Teamcenter.

**Note** If Lifecycle Visualization and Teamcenter are on same machine, a **libsyss.dll** conflict can occur. To avoid this conflict, turn off Lifecycle Visualization when you perform a batch run.

For more information about using stand-alone Lifecycle Visualization, see the Lifecycle Visualization online help.

### Using the embedded viewer

The embedded viewer is available when you click the **Graphics** tab in Structure Manager and allows you to view graphics attached to assemblies and components in the structure tree. The embedded viewer provides a similar visualization capability as the **View Structure Tree** context in stand-alone Lifecycle Visualization; consequently, you can complete most visualization procedures in stand-alone Lifecycle Visualization or in the embedded viewer. Typically, you use the embedded viewer in Structure Manager to visualize 3D assemblies or structures.

For information about how to view and manipulate 3D models, see the **Working with 3D models** manual.

You can also view and mark up schematic diagrams in the viewer, including electrical routing, hydraulic, and piping diagrams. To view schematics, you must set the **TC_Schematic_BOMView_types** preference to the corresponding view type, for example, **Piping System View**. If you do not set this preference, you can only view 2D and 3D images.
When in schematic mode, the following features are available:

- Selection
- Visualize components
  Depending on your authoring tool, some parts of a schematic may be displayed as JT geometries (blocks) that represent the components.
- Preferences
- Zoom
- Pan
- Seek
- View All
- Rubber band
- Image capture
- Product views
- Print
- Measure
- Markup

You can anchor markups to any appropriate component type.

The following standard Lifecycle Visualization features are not available in schematic mode:

- Edit color/translucency
- Insert
- View control
- Export 3D
- Repositioning
- Rotation
- PMI
- Clearance analysis
- Cross section
- Navigation
- Visibility

**Structure Manager viewer**

The viewer embedded in Structure Manager is available within the Viewer tab of the data pane. The viewer allows you to view JT files attached to assemblies and components in the structure tree when you are viewing and editing a product structure.

**Visualization use cases**

- View 3D assemblies or structures.
- View subcomponents in an assembly.
- Compare product structures.
- Create and save product views.

**Visualization tools available**

- **3D Alignment**
  Align parts with other parts in the viewing window.
• **3D Appearance**  
  Change the appearance of 3D models.

• **3D Clearance**  
  Check the clearance of parts in 3D models.

• **3D Comparison**  
  Compare the geometry of two sets of parts.

• **3D Coordinate System**  
  Create and align parts to local coordinate systems.

• **3D GDT Markup**  
  Create 3D GD&T markups.

• **3D Manipulators**  
  Transform 3D models.

• **3D Markup**  
  Create 3D markups.

• **3D Measurement**  
  Perform 3D measurements.

• **3D Movie Capture**  
  Capture your actions in the 3D viewing window as movie files.

• **3D Navigation**  
  Pan, rotate, and zoom 3D models.

• **3D PMI**  
  View and manipulate PMI in your model.

  **Note**  
  PMI functionality is available only when PMI is enabled on your system. If PMI is enabled, you can right-click a part and choose one of the following commands:

  o **Show PMI**  
    Shows all effective PMI on the selected part or subassembly and its children.

  o **Toggle in PMI Tree**  
    Adds PMI from the selected part or subassembly and its children to the PMI tree. Alternatively, if the part or subassembly is already in the PMI tree, Teamcenter removes it.

• **3D Section**
Create 3D cross sections.

- **3D Selection**
  Select parts and pick part entities.

- **3D Standard Views**
  Examine your model from preset viewing angles.

- **3D Thrustline Editor**
  Create and manipulate thrustlines.

- **3D Visibility**
  Hide obscuring parts and clip areas of your model.

**Configuring a viewer cache**

To display structures in the embedded viewer, you must create the corresponding JT file and store it in the Teamcenter file system. To optimize performance, Teamcenter saves the JT file in a cache directory. Whenever you view the image after the initial request, Teamcenter obtains the file from the cache directory, rather than recopying it from the Teamcenter file system. By default, the cache directory is the Java system temporary directory of the workstation, but you can specify a different cache directory using the PortalViewer_Cache property. Typically, the cache directory is set to a local directory, but it can be set to a shared directory (for example, an NFS mounted directory) so that multiple users can share the same set of cached JT files.

**Opening the structure**

You can view a structure if a DirectModel dataset is attached to the associated item revision by choosing View→Show/Hide Data Panel and clicking the Graphics tab.

Alternatively, you can click the Show/Hide Data Panel button on the toolbar.

The selected lines in the structure tree are now shown with a check box on the left of the node. These check boxes allow you to control the lines that are displayed in the viewer. By default, they are all unchecked. To modify the view, you can:

- Select the check box for the top-level line in the structure to load the graphics for every line in the structure, that is, view the entire structure.

- Select the check boxes only on those lines for which you want to load the graphics, that is, view a selected part of the structure.

- Select the check box on the line for a piece part to view only the part.

- Select the check box on a line representing an assembly to load the graphics and view the assembly.

- Clear the check boxes to blank the graphics to hide the entire structure.

**Note** If you applied a variant rule to the structure and unconfigured components are hidden, the graphics for the unconfigured lines are not loaded when you select the check box for the top-level item or an assembly.
When you edit the structure in the tree (for example, adding, removing, or substituting a part or assembly), the view is updated to reflect the changes. When you remove, replace, or substitute a part or assembly, Teamcenter unloads the selected item from the viewer if it is loaded. When you add a part or assembly to the structure, Teamcenter does not automatically display the selected item in the viewer, but adds to the structure tree, allowing you to load it manually.

If a part occurrence has more than one design representation associated with it, the primary published design is shown in the viewer.

**Refresh the embedded viewer**

You can refresh the viewer when the active 3D dataset or BOM line is modified outside the rich client in an external application such as NX.

- To refresh a part or a subassembly, right-click the appropriate line and choose **Refresh**.

  If the current view is exploded, Teamcenter displays a confirmation dialog box, allowing you to save changes. Otherwise, it updates the scene to reflect changed parts, properties and referenced objects.

  **Note** Only the selected line is refreshed, not the entire assembly.

- To refresh the geometry associated with the entire structure tree, choose **View→Refresh Window**.

  If the current view is exploded, Teamcenter displays a confirmation dialog box, allowing you to save changes. Otherwise, it updates the scene to reflect changed parts, properties and referenced objects.

**Understanding the structure tree**

When you open the structure in the embedded viewer, the structure tree contains different symbols and information to that available when you select other tabs. These symbols show the state of a node, as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️</td>
<td>The part or assembly is fully loaded and visible.</td>
</tr>
<tr>
<td>☐</td>
<td>The part or assembly is loaded but not visible.</td>
</tr>
<tr>
<td>☐️</td>
<td>The part or assembly is not loaded.</td>
</tr>
<tr>
<td>☑️</td>
<td>Some parts are loaded and visible (assembly only).</td>
</tr>
<tr>
<td>🟢</td>
<td>The assembly is loaded and some parts are visible (assembly only).</td>
</tr>
<tr>
<td>⇨</td>
<td>No geometry is associated with the part.</td>
</tr>
<tr>
<td>⚡️</td>
<td>New. This symbol may appear when you compare the current assembly with an assembly that you saved in a session file.</td>
</tr>
</tbody>
</table>
Symbol | Indicates
---|---
🗑 | Deleted. This symbol may appear when you compare the current assembly with an assembly that you saved in a session file.

Select the check boxes next to the components in the tree that you want to display. If you select the root item, the entire structure is displayed, for example:

<table>
<thead>
<tr>
<th>BOM Line</th>
</tr>
</thead>
</table>
| 002234| (View)
| 00278| (View)
| 000303| (View)
| 00279| (View)
| 00280| (View)
| 00281| (View)
| 00282| (View)
| 00283| (View)
| 00284| (View)
| 00272| (View)
| 00286| (View)
| 00313| (View)
| 00314| (View)
| 00315| (View)

Synchronizing the structure tree and the viewer

The viewer is synchronized to the structure tree, allowing you to visually associate the geometry for a part or assembly with its location in the structure.

When the graphics are loaded, you can click an object in the viewer and Teamcenter highlights the corresponding part or assembly in the structure tree. Similarly, you can click a line in the structure tree and Teamcenter highlights the corresponding part in the viewer.

**Note** You can use the Fly To Selected command on the shortcut menu in the viewer to help locate a part. For example, if you highlight a line in the structure tree, but cannot see the corresponding part in the viewer, choose Fly To Selected and the viewer changes its scale and orientation so that the selected part is prominent in the graphics window.

When you open 3D model files, two types of information are available: a textual representation of the model assembly and a visual representation of the geometry. The assembly structure appears in the tree and the geometry appears in the viewer.

When you open a DirectModel (JT) assembly file that consists of more than one part, the model assembly is loaded, but the geometry is not automatically displayed in the viewer. This is because assemblies often consist of hundreds or even thousands of parts, and it often takes a long time to load the geometry of such complex models. Because only the assembly is initially displayed, you can turn on only the parts you want to view, and preserve system resources. When you open a model that contains a single part, the part is loaded and displayed immediately.
Isolate parts for viewing

You can remove unwanted parts from the viewer, isolating the part of interest:

1. Select one or more the parts you want to see in the viewer and deselect unwanted parts.

2. Choose Graphics→Visibility→View Selected and Teamcenter blanks all unwanted visible parts and shows only the selected parts. Alternatively, you can right-click required parts in the viewer and choose View Selected.

Generate an outline image

You can generate an outline image of a 3D object in the viewer, as follows:

1. Click the Capture 2D Image button on the viewer toolbar and Teamcenter displays the Image Capture dialog box.

2. In the Image Capture dialog box, select the type of 2D image file you want to generate and click Apply or OK. Teamcenter calculates the 2D outline image and an outline progress meter displays the current status during this process.

To create a hidden line image, select the Outline type from the File Type list, enter a name for the dataset under which the outline image is stored, and optionally enter an description of the dataset.

3. On completion, Teamcenter attaches the 2D outline image in a CGM (Computer Graphics Metafile) file to a DirectModelMarkup dataset and places it in the NewStuff folder. You can then view and mark up this dataset in My Teamcenter.

To view the 2D markup, you must first create a markup dataset on top of the 2D image by clicking the Open File button on the toolbar.

Set outline preferences

You can set the various parameters Teamcenter uses to calculate the 2D outline (hidden line) image:

1. Click the Capture 2D Image button on the viewer toolbar and Teamcenter displays the Image Capture dialog box.

2. In the Image Capture dialog box, click the HLR Prefs button and Teamcenter displays Outline Capture Preferences dialog box. This button is disabled unless the file type is set to Outline.

3. In the Outline Capture Preferences dialog box, set the commands as listed in the following table.

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove Hidden Lines</td>
<td>If this command is selected, only the edges that are visible in the front of the model are displayed in the CGM image file. If this command is not selected, all lines are displayed.</td>
</tr>
</tbody>
</table>
### Menu command | Description
--- | ---
**Preserve Colors** | If this command is selected, the lines in the CGM image have the same colors as their associated parts. If this command is not selected, the lines are displayed with the default 2D background color and line properties.

**Line Thickness** | Enter an integer value between 0 and 5 for the thickness of the outline; the larger the number, the thicker the lines.

**Include Lines for Rounded Edges** | Select this command to draw rounded edges. If this command is not selected, the only lines drawn are silhouette lines, horizon lines, and feature lines as defined by the feature angle.

**Feature Angle** | Enter a value between 0 and 180.

If the angle between the normals of two adjacent surfaces equals or exceeds the specified feature angle, the two surfaces are considered separate features and the edge between them is drawn. If the angle between the normals of two adjacent surfaces is less than the specified feature angle, the two surfaces are considered one feature and the edge between them is not drawn.

To draw more edges, decrease the feature angle.

---

**Manipulate graphics**

Lifecycle Visualization provides a set of graphical manipulation tools that allow you to repositioning parts or assemblies in the structure, including translation, rotation and scaling.

You can perform two types of repositioning:

- **Generate** an exploded view for use in technical illustrations. You cannot save the exploded view, but you can create an image capture of it. Choose **Graphics→Transformation→Temporary Transformation** to generate an exploded view.

- **Edit** the structure to modify the physical location of a part or assembly in an owning structure. Choose **Graphics→Transformation→Persistent Transformation** to modify the location.

  **Note** If there are arrangements in the structure, by default persistent transformations are applied to all of them. To limit persistent transformations to the active arrangement, set the **TCVIS_reposition_all_arrangements** preference to **False**.

The differences between creating an exploded view and editing the structure are listed in the following table.
Chapter 7  Visualizing product structure

<table>
<thead>
<tr>
<th>Functionality</th>
<th>When you create an exploded view</th>
<th>When you perform a structure edit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permanence</td>
<td>All changes are temporary. Teamcenter removes the modifications when you close the window.</td>
<td>Changes are permanent.</td>
</tr>
<tr>
<td>Repositioning options</td>
<td>All options are permitted.</td>
<td>All options are all permitted except scaling of a physical part.</td>
</tr>
<tr>
<td>Occurrences repositioning</td>
<td>Occurrences are not repositioned.</td>
<td>Occurrences are repositioned, potentially updating multiple BOM lines.</td>
</tr>
</tbody>
</table>

The Temporary Transformation and Permanent Transformation dialog boxes provide the same options and commands as the Lifecycle Viewer Part Transformation dialog box. For more information about using the Part Transformation dialog box, see Working with 3D Models.

Save the current session

You can save the current state of the viewer in a session file that you can reopen at a later time to resume your work. The session file contains:

- The top-level item revision in the structure window.
- The effective revision rules.
- The visibility state of individual parts or assemblies.
- New locations of parts moved when creating an exploded view.
- The current 3D viewing orientation and scale.

To save a session file, choose File→Save Session. Teamcenter displays the Save Session dialog box. You can specify the name and location of the new session file. Session files are stored in the file system with an extension of .pses.

**Note** By default, you cannot save a session file. To enable saving of sessions, set the enableSessionFile entry in your customer.properties file to true. If this file does not already exist, you should create it.

To open a saved session file, choose File→Open Session. Teamcenter displays the Open Session dialog box and an MRU (most recently used) list. Enter the name of the session file to open and Teamcenter displays the structure in a new viewer window that is configured in the same way as when the session file was originally saved.

Working with product views

You can save data in the assembly viewer, including current items, zoom factor, rotation angle, and pan displacements. You can retrieve a saved product view
(sometimes called a 3D snapshot or snapshot view) during a subsequent session or share it with other users. You can only save or retrieve product views when a base view structure is displayed in the viewer. You cannot create product views of occurrence groups.

You can create product views that contain one or more of the following:

- Collaboration contexts
- Structure contexts
- Configuration contexts
- Item revisions (structure lines)
- 2D and 3D NX CAD and Lifecycle Visualization files
- Motion (VFM) files
- Published documents, including work instructions

Each product view is stored in a dataset containing a thumbnail image file, a PLM XML session file, 3D markup layers, and the top-level item of the view.

You can configure the structure with revision rules, effectivity, variant rules, and similar techniques. If appropriate, you can use several Show Unconfigured menu commands to hide unconfigured objects in the structure and in the viewer. When product views are captured, these view selections are taken into account; otherwise, potentially unbuildable combinations of parts may be displayed when the view is restored. You can retrieve the original state of the menu commands and consequently the original state of the view.

For more information about working with unconfigured objects in product views, see Manage unconfigured data in a product view.

If the product view is attached to a structure and the structure is cloned, the product view functions correctly in the new (clone) structure. Likewise, product views may be attached to a structure that is shared with Multi-Site Collaboration.

You can also update product views in the Lifecycle Viewer or stand-alone Lifecycle Visualization. You send a dynamic product view to one of these applications, and then create a new product view or update and replace the existing one. When you send the updated product view back to Teamcenter, you can open it in the assembly viewer.

Your Teamcenter administrator sets the size and presentation of the product views with system properties and preferences, as described in the Preferences and Environment Variables Reference.

**Note** In Teamcenter 8.0, the file format of 3D product views changed. If you open a file that was created in an earlier Teamcenter version, it is automatically converted to the new format.

**Create and save a product view**

1. Adjust the content of the viewer window using the pan, rotate, eyeball, and zoom buttons to create the necessary scene.

2. Select an object in the structure base view window.
3. If necessary, right-click in the viewer menu bar and choose **Create Markup**. Teamcenter displays the **Create Markup** toolbar.

4. Click the **Create 3D Product Views** button on the **Create Markup** toolbar in the assembly viewer.

   Teamcenter displays the **Product View Gallery** dialog box, which contains thumbnails of any previously saved product views that are associated with the selected object.

5. Do one of the following:
   - Click the **New Product View** button.
   - Right-click in the window and choose **Create New Product View**.

   You are prompted to enter a name for the product view if the **Vis_PV_Show_Name_Dialog** preference is set to **True**. If it set to **False**, Teamcenter generates a name automatically.

   Teamcenter saves the product view and its configuration in a dataset. It also adds a thumbnail of the view to the **Product Views** dialog box.

   **Note** Thumbnails of all product views are not visible at all times, only for those items related to the selected end item (the top entry in the structure window).

### Configure and manage product views

1. Choose **Options** → **Visualization** → **Product View**.

   Teamcenter displays the **Product View Creation Preferences** pane.

2. Set the following preferences as required:

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Geometry Asset</strong></td>
<td>Determines whether a geometry asset file is added when a product view is created. This file is required if you want to export a PLM XML file of the product view. This option is equivalent to the <strong>Vis_PV_Geometry_Asset</strong> preference.</td>
</tr>
<tr>
<td><strong>Show Product View name dialog</strong></td>
<td>If selected, you are prompted for a name each time you create a product view. If not selected, Teamcenter generates the name automatically. This option is equivalent to the <strong>Vis_PV_Show_Name_Dialog</strong> preference.</td>
</tr>
<tr>
<td><strong>View Toggle Warning Level</strong></td>
<td>If selected, Teamcenter displays a warning or prevents you from continuing if you try to create a product view when one or more of the <strong>View</strong> menu commands to show unconfigured data is selected. This option is equivalent to the <strong>Vis_PV_InvalidConfigWarnLevel</strong> preference.</td>
</tr>
<tr>
<td>Preference</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>View Toggles to consider</td>
<td>Select the View menu commands to show unconfigured data that are considered if the View Toggle Warning Level option is selected. This option is equivalent to the VisPVBlockingViewToggles preference.</td>
</tr>
<tr>
<td>Image Capture</td>
<td>Determines if Teamcenter saves a preview image of the 3D product view when it is created. If you choose Perform Image Capture (Using Image Export Dialog), you are prompted for the settings to use. If you choose, Perform Image Capture (with preferences), it uses values set in preferences. This option is equivalent to the Vis_PV_ImageCapture preference.</td>
</tr>
<tr>
<td>Image Format</td>
<td>Depending on the setting of the Image Capture option, these options may determine the file format, resolution, and size of the preview image. If Perform Image Capture (Using Image Export Dialog) is set, these options are disabled. These options are equivalent to the Vis_PV_ImageCaptureType, Vis_PV_ImageCaptureResolution, Vis_PV_ImageCaptureWidth, and Vis_PV_ImageCaptureHeight preferences, respectively.</td>
</tr>
<tr>
<td>Image Resolution</td>
<td></td>
</tr>
<tr>
<td>Width of image</td>
<td></td>
</tr>
<tr>
<td>Height of image</td>
<td></td>
</tr>
<tr>
<td>Thumbnail:</td>
<td>Determine the size and resolution of the thumbnail image created for each product view. These options are equivalent to the Vis_PV_ThumbnailWidth, Vis_PV_ThumbnailHeight, and Vis_PV_ThumbnailQuality preferences, respectively.</td>
</tr>
<tr>
<td>Play motion in current view</td>
<td>If selected, any motion (VFM) file in the current product view plays when the view is selected. This option is equivalent to the Vis_PV_Play_Motion preference.</td>
</tr>
<tr>
<td>Configuration rule to use</td>
<td>Offers you two choices:</td>
</tr>
<tr>
<td></td>
<td>• Use configuration from the current BOM ignores stored rules and preserves the configuration that was active before you applied the product view.</td>
</tr>
<tr>
<td></td>
<td>• Use configuration from product view considers any arrangements, effectivity, variant rules, and revision rules stored with the product view when you apply it.</td>
</tr>
</tbody>
</table>
## Visualizing product structure

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This option is equivalent to the Vis_PV_HowTo_Configure_BOM preference.</td>
<td></td>
</tr>
</tbody>
</table>

**Note**
Your administrator may configure these preferences with SITE or GROUP protection scope, rather than USER protection scope. If so, you may be able to view but not change the current settings.

3. Right-click a selected product view thumbnail in the **Product View Gallery** dialog box.

   Teamcenter displays a shortcut menu.

   **Note**
   You can identify the currently selected product view by the green border (if checked out) or red border (if not checked out) around its thumbnail.

4. Choose one of the following.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New Tab</strong></td>
<td>Creates a new tab for the element currently selected in the structure. This tab is unavailable if no element is selected in the structure base view window.</td>
</tr>
<tr>
<td><strong>Refresh Tab</strong></td>
<td>Refreshes the currently selected tab in the product view gallery to reflect structure configuration changes.</td>
</tr>
<tr>
<td><strong>Remove Tab</strong></td>
<td>Removes the current tab from the dialog box.</td>
</tr>
<tr>
<td><strong>Refresh All Tabs</strong></td>
<td>Refreshes all the tabs in the product view gallery to reflect structure configuration changes.</td>
</tr>
<tr>
<td><strong>Remove All Tabs</strong></td>
<td>Removes all tabs from the dialog box.</td>
</tr>
<tr>
<td><strong>Add</strong></td>
<td>Creates a new product view from the current contents of the viewer.</td>
</tr>
<tr>
<td><strong>Apply</strong></td>
<td>Applies the configuration of the selected product view to the viewer.</td>
</tr>
<tr>
<td><strong>Delete</strong></td>
<td>Deletes the selected product view.</td>
</tr>
<tr>
<td><strong>Update</strong></td>
<td>Refreshes the stored product view with changes made in the viewer. This command is enabled only if you check out the product view. For more information, see <em>Check out product view dataset</em>.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Rename</td>
<td>Displays a dialog box that allows you to change the name and description of the selected product view. A product view name appears below each button; the description appears when the cursor is placed over the button. If you rename a product view, the order in which thumbnails are displayed in the <strong>Product View Gallery</strong> dialog box changes. Teamcenter generates the default name of a view from the date and time it was initially created. It lists available views in alphanumeric order. You can choose an appropriate new name to move the view up or down the list.</td>
</tr>
<tr>
<td>Enable Multiple Selection</td>
<td>Allows you to select more than one product view.</td>
</tr>
<tr>
<td>Options</td>
<td>Displays the <strong>Product View Creation Preferences</strong> pane.</td>
</tr>
</tbody>
</table>

**Note** If you right-click any part of the **Product View Gallery** dialog box (except one of the buttons) and no product view is selected, the menu commands to apply, update, rename, and delete the product view are unavailable.

**Previewing product views**

By default, Teamcenter provides a small 2D thumbnail image of the captured scene in the product views gallery. Optionally, you can create a high-quality 2D image that replaces the thumbnail and provides a higher resolution preview of the scene. The size, resolution, and format of the image file are defined in the following preferences.

- **Vis_PV_ImageCaptureWidth**
  Defines the width, in pixels, of the preview image created when you save a product view. Teamcenter only uses this preference if the **Vis_PV_ImageCapture** preference is set to **CaptureUsingPrefs**. The valid values are positive integers from 1 to 1040, with a default value of 600.

- **Vis_PV_ImageCaptureHeight**
  Defines the height, in pixels, of the preview image created when you save a product view. Teamcenter only uses this preference if the **Vis_PV_ImageCapture** preference is set to **CaptureUsingPrefs**. The valid values are positive integers from 1 to 1040, with a default value of 400.

- **Vis_PV_ImageCaptureType**
  Defines the format of the preview image created when you save a product view. Teamcenter only uses this preference if the **Vis_PV_ImageCapture** preference is set to **CaptureUsingPrefs**. Valid values are BMP 24bit, BMP 8bit, BMP BW, JPEG 24bit (default), PNG 24bit, PNG 8bit, PNG BW, TIFF 24bit, TIFF 8bit, and TIFF BW.

- **Vis_PV_ImageCaptureResolution**
Chapter 7  Visualizing product structure

Defines the resolution of the preview image created when you save a product view. Teamcenter only uses this preference if the Vis_PV_ImageCapture preference is set to CaptureUsingPrefs. The valid values are positive integers from 1 (lowest resolution) to 1040 (highest resolution), with a default value of 250.

**Note**  The width and height you specify must be the same as the source image, or you can increase or decrease both values by the same proportion. Teamcenter always preserves the aspect ratio of the graphics window to prevent distortion. Consequently, the resulting image dimensions may not exactly match the height and width values set in the properties file.

You can create high-quality images in any of the following file formats and resolutions:

- BMP 24-bit, 8-bit, or black and white
- JPEG 24-bit
- PNG 24-bit, 8-bit, or black and white
- TIFF 24-bit, 8-bit, or black and white

A high-resolution preview image can be captured automatically or manually, as follows:

- If the Vis_PV_ImageCapture preference is set to CaptureUsingPrefs, a high-quality 2D image is created automatically each time a product view is created or updated. The size and resolution of the image is derived from the preferences listed previously.

- If the Vis_PV_ImageCapture preference is set to CaptureUsingDialog, Teamcenter prompts you to create a high-quality 2D image each time you create or update a product view.

  For more information, see Create product view preview manually.

If the Vis_PV_ImageCapture preference is set to NoImageCapture, no high-quality images are created, and the thumbnail image is used in the gallery.

The preview image is stored in the snapshot dataset as a named reference.

When you update an existing product view, the old image is deleted. Depending on the setting of the Vis_PV_ImageCapture preference, it may be replaced by a new image.

**Create product view preview manually**

**Note**  The menu commands described in this procedure are available only if the Image Capture option is set to Perform Image Capture (using Image Export dialog). If you do not select this option, you cannot manually adjust the size, resolution and file format each time you create or update a product view.

1. Right-click a product view or the Product View Gallery tab and select Image Capture.
Teamcenter enables the capture of 2D images, as indicated by a check mark next to the menu command.

2. Create or modify the product view.
   For more information, see Create and save a product view.
   If you selected Perform Image Capture (using Image Export dialog) previously, Teamcenter displays the Image Export dialog box.

3. Change the size and file format of the image if necessary, then click OK.
   Teamcenter creates the product view using the parameters you entered.

Manage unconfigured data in a product view

You can use several menu commands to show or hide unconfigured objects in the structure and in the viewer, as follows:

- Show Unconfigured Variants
- Show Unconfigured By Occurrence Effectivity
- Show Unconfigured Changes
- Show GCS Connection Points
- Show Suppressed Occurrences

When product views are captured and restored, these view selections are preserved; otherwise, potentially unbuildable combinations of parts may be displayed when the view is restored. If you choose to update the configuration from the product view when you reopen it, the saved view selections are retrieved; if you choose to use the current configuration, the saved view selections are ignored.

The administrator can set the following preferences to determine when unconfigured objects are shown:

- Vis_PV_InvalidConfigWarnLevel
  If set to Warning, Teamcenter displays a warning message if any of the options specified in the Vis_PV_BlockingViewToggles preference are on, but you can still create or update a product view. If set to Prevent, Teamcenter prevents you creating or updating a product view if any of the view configuration options specified in the Vis_PV_BlockingViewToggles preference are on. If set to Off, the state of the menu commands does not affect whether product views are created or updated.

  You can also set this preference with the Product View Creation Preferences → View Toggle Warning Level option.

- Vis_PV_BlockingViewToggles
  Specifies the view states that are evaluated when the Vis_PV_InvalidConfigWarnLevel preference is set to show a warning or prevent the creation of a product view.

  You can also set this preference with the Product View Creation Preferences → View Toggles to consider option.
Chapter 7  Visualizing product structure

To evaluate the configuration of an existing product view:

- Right-click a product view in the Product View Gallery and choose Show Configuration.

  Teamcenter displays a dialog box that shows the assembly configuration when the product view was created. The name of the product view is shown in the title bar of the dialog box. The dialog box also lists any Show Unconfigured menu commands that were active at the time the product view was created.

Retrieve and open an existing product view

- Open the product view in Teamcenter:
  1. Select an object in the structure base view window and open the assembly viewer.
  2. Click the Create 3D Product Views button on the viewer toolbar.

    Teamcenter displays the Product View Gallery dialog box containing thumbnails of available product views of the selected structure. Only product datasets associated with the currently selected end item are visible.

  3. Right-click below the image area in the Product View Gallery dialog box and select the configuration that you want to use for the product view.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options→Configuration rule to use→Use configuration from Current BOM</td>
<td>Applies the product structure configuration that is currently set to the product view that you are loading.</td>
</tr>
<tr>
<td>Options→Configuration rule to use→Use configuration from product view</td>
<td>Adopts the configuration that was set at the time the product view being loaded was created.</td>
</tr>
</tbody>
</table>

  4. Do one of the following:

    o Select the thumbnail of the product view you want to open and click Apply.

      Teamcenter opens the product view and retrieves the saved configuration for the structure window and viewer. You can then click Cancel to close the dialog box without opening the product view.

    o Select the thumbnail of the product view you want to open and click OK.

      Teamcenter opens the product view as before and closes the dialog box immediately.

  5. If the product view contains a motion file, replay it by right-clicking the product view and choosing Load Motion File(s). If Play motion in current view is selected, the motion file is played against the current structure; otherwise, it is played against the original structure.

- Open the product view in stand-alone Teamcenter lifecycle visualization:
  1. Select one or more product view datasets in the Attachments tab.
2. Click the **Send to Lifecycle Visualization** button.

**Checking product views in and out**

After you create a product view (3D snapshot), you can check it into the Teamcenter database to make it available to other users. To refresh or delete an existing product view, you must first check it out to prevent other users from inadvertently overwriting your changes.

You can identify a checked out product view by a green frame around the thumbnail image in the **Product View Gallery** dialog box. Similarly, you can identify a checked in product view by a red frame around the thumbnail.

**Check out product view dataset**

- Select a product view and choose **Tools→Check-In/Out→Check-Out**.

Teamcenter applies a checkout lock to the dataset, allowing you to refresh or delete the product view. Other users cannot refresh or delete the product view while you have checked it out.

**Note** If you close the **Product View Gallery** dialog box while you still have datasets checked out, Teamcenter displays a request for confirmation that you want to continue. If you do, all active checkout locks are cancelled.

The **Check-Out** command is enabled only if you select a product view that is not checked out by another user.

**Check in product view dataset**

- Select the product view you checked out and choose **Tools→Check-In/Out→Check-In**.

Teamcenter removes the checkout lock from the dataset, allowing other users to update or delete the product view.

**Cancel checkout of product view dataset**

- Select the checked out product view and choose **Tools→Check-In/Out→Cancel Check-Out**.

Teamcenter removes the checkout lock from the dataset, allowing other users to update or delete the product view.

**Refresh a product view**

You can refresh a saved product view of the current structure at any time with changes you make during the current session in one of the following ways:

- Right-click the product view gallery and choose **Refresh Tab** to update the 3D snapshot in the selected tab to reflect any structure configuration changes.

- Right-click the product view gallery and choose **Refresh All Tabs** to update the 3D snapshots in all tabs to reflect any structure configuration changes.
Manipulating subcomponents

An assembly imported into Teamcenter as a single part file without CAD models may represent an assembly of individual solid objects. Teamcenter treats such an assembly as a single line in the structure and, by default, you cannot expand it to visualize the individual components. For example, if you import an assembly from a non-NX CAD system, Teamcenter creates a single part file without the associated CAD model within the structure.

In this instance, parts files are not necessarily devoid of CAD models and structure. They may have NX or other CAD application models. However, these files may have more than one solid or subcomponent within them. A typical part file only has one subcomponent or solid in it.

To view the individual visualization components, you must specifically select the affected and unpacked structure line and choose Show Subcomponents. You can subsequently hide the subcomponents when you have viewed the assembly.
If the assembly node has a monolithic DirectModel dataset associated with it and the JT_File_OverrideChildren_Refsets preference is set appropriately, Teamcenter uses the monolithic JT file to display the assembly. Assemblies with monolithic JT files have a present 📚 symbol in the tree. If you use Show Subcomponents to expand the structure in the monolithic JT file, you can manipulate the individual subcomponents, control their visibility, and create product views capturing the current state.

**View subcomponents in an assembly**

1. In the structure, select the BOM line node containing an assembly of solids.
   The part file can be a root node or subassembly node. If it is a subassembly node, the JT_File_OverrideChildren_Refsets preference must be set appropriately. You can also select and expand nodes containing multiple part files.

2. Do one of the following:
   - Choose Graphics→Show Subcomponents.
   - Right-click the node and choose Show Subcomponents.

   Teamcenter expands the part file to show the structure of the subcomponents. You can display selected subcomponents in the viewer by selecting the corresponding check boxes.

**Display selected subcomponent in expanded part file**

1. Unpack and select the leaf line node for the relevant subcomponent. You can select more than one node.

2. Do one of the following:
   - Choose Graphics→Show Subcomponents.
   - Right-click and choose Show Subcomponents.

   Teamcenter expands the node. If the node has a monolithic JT file, you can see the structure of the subcomponents. Check boxes appear in the tree for each node.

3. Select or clear the check boxes in the tree to show or hide the subcomponents in the viewer.
   You can control the solids independently, select them in the viewer or the structure tree, and use transformation tools to reposition them.
   After breaking down the solids, you cannot reload the monolithic JT file for the line node.

**Merge subcomponents**

After manipulating the individual subcomponents, you can merge them back into the subassembly.
Chapter 7  Visualizing product structure

1. In the structure, select the leaf node or assembly node part file.
   You can select multiple nodes.

2. Do one of the following:
   • Choose Graphics→Hide Subcomponents.
   • Right-click and choose Hide Subcomponents.

Teamcenter unifies the subcomponents within the parent part and removes the tree from the structure. The subassembly behaves like a single part in the viewer.
Chapter

8 Making where-used searches

Making where-used searches .............................................. 8-1
Configuring for where-used searches ................................. 8-1
Perform a where-used search and obtain a graphical result .... 8-4
Perform a where-used search with the print wizard and obtain a printable result .............................................. 8-5
  Open HTML files in a Web browser .................................. 8-6
  Print a text or HTML file ............................................... 8-6
  Save output to an HTML or text file ................................. 8-7
Chapter

8  Making where-used searches

Making where-used searches

Where-used searches allow you to identify all the item revisions that use another item revision of interest. For example, you can search for all assemblies that contain a particular item or item revision. You can do this to assess the impact of engineering changes to the product structure or to check if changes in one assembly affect other assemblies. If you use Teamcenter product master management, the results show all lines of usage that a part references.

Note  You can perform where-used searches on configured precise or imprecise structures.

Where-used searches do not identify any BOM view revisions (BVRs) where the item or item revision occurs.

There are two methods of performing where-used searches. The first method produces a graphical representation of the assembly or assemblies in which the item or item revision is used. The second method uses the Referencers print wizard and produces a report of the where-used results.

The results of where-used searches can be viewed in the Referencers pane. If the ReferencersPane_Shown preference is set to off, this pane is hidden.

Configuring for where-used searches

A where-used search can take into account the revision rule when searching the product structures and you can choose one of the following outputs:

• All revisions

  Reports all item revisions that have an occurrence of the target item revision. This search result displays all combinations of usage that can possibly occur; when a particular set of revision rules is applied, not all paths may be realized.

• Only the revision configured by a selected revision rule.

  Reports all item revisions that have an occurrence of the target item revision when the selected revision rule is applied.

Use the REV_RULE_WHERE_USED_DEFAULT_VALUE preference to set the default revision rule for where-used searches. This preference is not available by default, and you must create it. Teamcenter populates the Impact Analysis pane with this revision rule.
By default, the search results include all parent item revision objects, regardless of whether they are themselves configured by the revision rule. With this setting, you can (for example) make a where-used query on `Part1–A` to identify every occurrence where `Part1` is used with `A` as its configured revision. You obtain the same results whether you query one level at a time or all levels simultaneously, including with mixed precise and imprecise structures.

With precise or mixed structures that have a large number of item revisions, the standard mode may return many results that can be difficult to interpret. In this case, you can configure the results to omit parent item revision objects that are not themselves configured by the revision rule. That is, this mode reports all intermediate items or item revisions that configure the target.

**Note** This alternative mode is an enhancement of the behavior in Teamcenter Engineering 9.1 and earlier releases. It is no longer necessary to expand all levels to obtain a valid result.

To configure this alternative mode, set the `PS_wu_configd_imprecise_only` preference to `true`. This preference has no effect if the selected revision rule contains any precise entries.

To appreciate the differing results obtained by these modes, consider the following structure and the results of a where-used search on item `100–A`. With the preference set to `false`, item `500–A` is reported in the search results; if it set to `true`, the same item is not reported because it is not configured by a precise rule.
Perform a where-used search and obtain a graphical result

1. Choose View—Show/Hide Data Panel or click the Show/Hide Data Panel button on the toolbar to display the data pane.

2. Click the Referencers tab.

3. Select an item or item revision in the tree or properties table, and drag or copy and paste it to the Referencers pane.

4. Set the following search parameters in the Referencers pane:
   - Select Used in the Where option list, located in the upper-left of the pane.
   - Select a rule from the Where-Used Rule list. This rule provides parameters to locate the assemblies in which the item or item revision is used. For example, if you select the Any Status; Working rule, only the latest released revision of the assembly is retrieved if one exists; if not, the latest working revision is retrieved.

   If you modify the current revision rule in Structure Manager, you can also select the modified rule as the basis of the search. To do this, select From Structure Manager from the Where-Used Rule list.

   **Note** In the Referencers pane in Structure Manager, the rule defaults to the current revision rule in the Structure Manager window.

   - Choose one of the following options in the Depth list located in the bottom-right corner of the pane:
     - One Level to report immediate parent assemblies only
     - All Levels to report all parent assemblies up to the top level
     - Top Level to report the top-level assembly or product only

5. Double-click the item or item revision in the Referencers pane to start the search.

   If the item or item revision is not part of an assembly that matches the selected revision rule, Teamcenter displays a message to that effect. If the item or item revision is part of a configured assembly, the structure is displayed in graphical format in the Referencers pane. The results can be used as a basis for another where-used or where-referenced search or they can be formatted and printed.

   You can change the item revision properties that are shown in the results by selecting the required properties from the Display list. Teamcenter remembers your selection for future sessions.

   You can also filter the results to show only selected item types. To do this, select the Filter by Item Type check box and select the required item type and filter level from the lists. You can also select the Include Subtypes check box to include both item revisions whose item is of the specified type and any subtype of that type. You can further refine the selection by showing the results only for the top level of the structure or for all levels below the selected top level. To rerun the where-used search with changed criteria, double-click the target node.
Perform a where-used search with the print wizard and obtain a printable result

1. Choose View→Show/Hide Data Panel or click the Show/Hide Data Panel button on the toolbar to display the data pane.

2. Click the Referencers tab.

3. Select an item or item revision in the tree or properties table, and drag or copy and paste it to the Referencers pane.

4. Click the Report Wizard button on the toolbar. Teamcenter displays the Referencers print wizard.

5. (Wizard step 1) Select the Where-Used option to generate a where-used report and click Next.

6. (Wizard step 2) Select one of the following Depth options and click Next:
   • One Level to report immediate parent assemblies only
   • All Levels to report all parent assemblies up to the top level
   • Top Level to report the top-level assembly or product only

7. (Wizard step 3) Select a Where-Used Rule revision rule and click Next. This rule provides parameters to locate the assemblies in which the item or item revision is used. For example, if you select the Latest Working rule, only the latest working revision of the assembly is retrieved. Released assemblies and earlier versions of the assembly is not retrieved when this rule is selected.

   If you modify the current revision rule in Structure Manager, you can also select the modified rule as the basis of the search. To do this, select From Structure Manager from the Where-Used Rule list.

8. (Wizard step 4) Select the item or item revision properties to include in the report and click Next.

   Note: The preselected properties are those used when you last ran the wizard. You can change them as necessary.

9. (Wizard step 5) Select an item type to filter the search results by and click Next. You can also select the required filter level, either Top Level Only or All Levels.

   Teamcenter displays the item or item revision and selected revision rule that will be the basis of the search, together with report generation options.

10. Confirm that the required items, item revisions and revision rule are shown correctly, then choose one of the following report generation options:

   • Generate the HTML/Text report
     Presents the where-used results in HTML format in the Print dialog box. From this dialog box, you can format the report and either print it or save it to a file.
Chapter 8  

Making where-used searches

- **Generate the structure report**
  
  Presents the where-used results in tree format.

11. Click the **Yes** button.

   Teamcenter runs the where-used search and displays the results. At this point, you can format, save, and print your report, as follows:

   - Optionally, change the print format to **Text** or **HTML Table**. HTML is the default print format; HTML table format allows easier interpretation of large lists of property values.

   - Optionally, format the report by performing the following steps:

     a. Click the **Set Result Format** button in the upper-right corner of the **Print** dialog box.

        Teamcenter displays the **Print Format** dialog box. The formatting options vary depending on the type of object selected and whether you are printing in HTML, HTML table or text format.

     b. Modify the result format.

     c. Click **Update** to apply your changes.

     d. Close the **Print Format** dialog box. Teamcenter activates the **Print** dialog box.

- To save the file or send it to a printer, complete the process that is appropriate to the file type and desired output format.

### Open HTML files in a Web browser

1. Click the **Open in Web Browser** button.

   The HTML file is displayed in your default Web browser.

2. Execute your browser’s print command.

3. Return to the Teamcenter window and click the **Close** button to dismiss the dialog box.

### Print a text or HTML file

1. Click the **Print** button located in the lower-right corner of the **Print** dialog box. Teamcenter displays the system **Print** dialog box.

2. Define the printer to which the file will be sent. You can accept the default printer that is displayed in the **Name** box or select a different printer from the list.

3. Click **OK** to print the file and dismiss the dialog box.

4. Click **Close** to dismiss the **Print** dialog box.
Save output to an HTML or text file

1. Click the Save button located in the lower-right corner of the Print dialog box and the Save dialog box appears. Teamcenter displays the system Save dialog box.

2. Navigate to the directory location where you want to save the file.

3. Enter the name of the file, including the .htm, .html, or .txt extension, in the File name box.

4. Click Save to save the file and dismiss the dialog box.

5. Click Close to dismiss the Print dialog box.
Chapter

9 Making spatial and attribute searches

Making spatial and attribute searches ........................................ 9-1
Configuring spatial searches ....................................................... 9-2

Perform a search ................................................................. 9-4
Enter search criteria .............................................................. 9-5
Enter Classification or family attributes search criteria ............... 9-6
Enter occurrence note search criteria ...................................... 9-7
Enter spatial filter search criteria ........................................... 9-7
Define a proximity filter ......................................................... 9-8
Define a spatial filter with a 3D box ......................................... 9-8
Use target parts ................................................................. 9-11
Filter search with form attributes ............................................ 9-12

Managing search results ......................................................... 9-13
Manage search results .......................................................... 9-13
Examples of managing search results ....................................... 9-13
Managing the search results panes .......................................... 9-14
Manipulate search results ...................................................... 9-14
Limiting search results ......................................................... 9-15
Chapter

9 Making spatial and attribute searches

Making spatial and attribute searches

You can search large products with spatial criteria or with a combination of spatial and attribute criteria. Spatial searches are particularly useful for end items that represent large products containing a large number of lines, allowing you to focus quickly on a particular area or part of the product. For example, if you are designing a ship, you may want to identify all pipes that pass through a selected compartment, but not pipes that are routed around its perimeter.

It is not necessary to create caches of product structure data or to install a separate database.

The spatial search can function with CAD data from two sources:

- **NX**
  
  NX calculates the bounding box for a part and stores it in Teamcenter as a UGPART-BBOX named reference in a UGMASTER dataset. It can also be configured to create TruShape data for the part and store it as a Trushape-Data named reference in the UGMASTER dataset.

  The accuracy of the search depends on the cell size you configure in NX. A small cell size provides more accurate search results, but the TruShape files are larger and response times slower.

- **Other CAD systems capable of saving JT files**

  Teamcenter uses the Dispatcher Server and JtToBboxAndTso translator to create the necessary bounding box and TruShape data.

  The accuracy of the search depends on the voxel size you configure in Teamcenter. A small voxel size provides more accurate search results, but the TruShape files are larger and response times slower.

  **Note** The bounding box and TruShape data generated for a JT dataset are ignored if an NX dataset exists for the same item revision.

You enter search criteria as numerical values by manually creating a bounding box in the embedded viewer or by specifying minimum and maximum coordinates. You can also construct a bounding box from selected target parts. Teamcenter displays the results of the search as a list of matching items and item revisions. The results include any object that has partial or complete geometry inside, outside, or intersecting the box. Selecting an entry in the list highlights the item or item revision in the structure tree pane and in the embedded viewer.
If the results contain packed lines, the relevant lines are unpacked and displayed. The remaining lines remain packed and are shown as a pack master with a corrected total of lines or with pruned siblings.

You can refine spatial searches with other attributes as follows:

- **Scope**
  You can select an assembly as the scope of the search, rather than searching the entire product.

- **Item and item revision attributes**
  You can refine the search by including attributes of the item or item revision. Typically, this is the item ID, but you can use any attributes stored on the item master or revision master forms.

- **Classification data**
  If the items are classified, you can refine the search with classification attributes. This is called a *classification ad hoc search*. You can search through classified data and find objects contained within a class you specify and containing attribute values that you specify.

- **Occurrence notes**
  You can refine the search with values for occurrence attributes (occurrence notes).

- **Attributes of forms**
  You can refine the search with the attributes of forms that are attached to an item, item revision, or their subclasses.

You can save search criteria for future use, if you perform the same search frequently. You can also create and save searches using the Query Builder application.

### Configuring spatial searches

The following installation and configuration steps must be completed before you can run spatial searches:

- **Install the Spatial Search feature** when you run Teamcenter Environment Manager (TEM).
  
  For more information, see the *Teamcenter Environment Manager Help*.

- **If you have not already done so**, install Dispatcher translation services with Teamcenter Environment Manager (TEM), including the **Spatial Search Indexer** and **Spatial Search Translator** features. If you are creating JT files on the same system as Teamcenter is installed on, ensure you install these services before creating JT files to search.

- **Install a license key** that includes an RDV (Context Management) license.

- **To enable the cacheless search mechanism**, set the `QS_QSEARCH_ENABLED` preference to **True**. If you use appearance searches, set this preference to **False**.
• To enable spatial (box or proximity) searches, set the `QS_SPATIAL_ENABLED` preference to `True`.

• To enable automatic updates of spatial indexes, set the `QSEARCH_update_enabled` preference to `True`. If it is set to `False`, you cannot make spatial searches.

• If you search against TruShape files that Teamcenter creates from CAD data, you must also set the `QS_TRUSHAPE_GENERATION_ENABLED` preference to `True`. This enables the generation of the TruShape data required for spatial searches; the generation process may take an appreciable time when first enabled. Set this preference to `False` if you use the Teamcenter Integration for NX, as TruShape files are automatically saved in the NX datasets. (NX must also be configured to save TruShape data.)

• If you search against existing JT files, you must also set the `QS_BBOX_GENERATION_ENABLED` preference to `True`. This enables the generation of the bounding box data required for spatial searches; the generation process may take an appreciable time when first enabled. Set this preference to `False` if you use the Teamcenter Integration for NX, as bounding boxes are automatically generated. However, set this preference to `True` if you use non-NX CAD integrations or several CAD tools.

• If you are upgrading from a previous release of Teamcenter, use the `create_or_update_bbox_and_tso` utility to convert your existing data for spatial searching. This utility creates bounding box and TruShape data from CAD data files or JT files.

• To specify user-defined units for spatial searches, set the `RDV_user_defined_units_of_measure` preference to `METERS`, `MILLIMETERS`, `INCHES`, or `UNKNOWN`. If you specify `UNKNOWN`, the search is performed in the units of the `assy_units` property set on the top level BVR. If this property is not set, the search is performed in the units specified in the `PS_assume_legacy_transform_units` preference.

• If you want to perform spatial searches from target part selections, set the `RDV_set_default_use_selections_from_tree` to `true` to use selections from the tree or `false` to use selections from the table.

  For more information, see `Use target parts`.

• Set the `RDV_set_default_3DBox_search` preference to `true` to set the 3D box search option as default or `false` to set the proximity search option as default.

• Set the `RDV_set_default_3DBox_dimensions` preference to set the default option for 3D box dimensions, 0 for centroid and size, 1 for origin and size, or 2 for maximum and minimum extents.

• Set the `RDV_set_default_true_shape_filtering_ON` preference to `true` to turn TruShape filtering on by default or `false` otherwise.

• Set the `RDV_default_find_intersecting_parts` preference to `true` to specify whether parts intersecting with the 3D bounding box during a spatial search are included in the results by default or `false` otherwise.
Chapter 9  Making spatial and attribute searches

- Set the **RDV_default_find_inside_parts** preference to *true* to search parts inside the 3D bounding box during a spatial search by default or *false* to search parts outside.

- Set the **StructureManagerIncludeSubComponentsForSpatialSearch** preference to determine if the components of subassemblies are considered as targets. If it is set to *true*, all components of the selected subassembly are included as targets of a proximity search, in addition to the subassembly itself. If it is set to *false*, only the subassembly is the target of a proximity search, not any of its components. Typically set to *false* if you want to search for parts in the vicinity of geometry at the assembly level (for example, in the case of wire harnesses).

- Set the **RDV_show_targets_on_results_dialog** preference to *true* to specify if the target parts table is displayed in the results dialog box after a proximity search or *false* otherwise.

- Set the **RDV_show_targets_on.spatial_dialog** preference to *true* to specify if the target parts table is displayed in the spatial search dialog box after a proximity search or *false* otherwise.

- Set the **RDV_set_default_slider_increment** preference to the default increment of the slider, for example, 0.01.

- Set the **RDV_set_default_3D_Manipulator_ON** preference to *true* to have 3D manipulators on by default or *false* otherwise.

**Note** If you change the settings of any of these site preferences, you must restart the server to clear cached data and restart the services.

For more information about configuring cacheless searches, see the *Cacheless Search Deployment Guide*.

For more information about other spatial search preferences, see the *Preferences and Environment Variables Reference*.

**Perform a search**

1. Open the product structure and select the top line against which you want to search.

2. Click the **Search** button on the toolbar.

   Teamcenter displays the **Search** pane directly below the structure tree.

3. If appropriate, click the **Clear All** button to reset any previously specified criteria.

4. Use the **Search** pane to specify one or more of the following search criteria:
   - **Scope**

   You can search an assembly, rather than the entire product, to obtain results more quickly. To set an assembly as the scope of the search, click the ... button next to the **Search Scope** box and browse to the desired assembly.
Teamcenter displays the name of the selected assembly in the Search Scope box.

- Item identifier
  
  **Tip** You can search for items whose identifiers, names, attributes or types match a specific pattern. For example, you can type `57h*` into the Item ID box to find all items whose ID start with `57h`. Select the appropriate arithmetic function in the leftmost box to obtain the desired results, for example, `=` to obtain an exact match.

- Classification family or attributes
  
  For more information about specifying Classification search values, see *Enter Classification or family attributes search criteria*.

- Occurrence notes
  
  For more information about specifying occurrence note search values, see *Enter occurrence note search criteria*.

- Spatial information using 3D boxes or proximity values.
  
  For more information about specifying spatial search values, see *Define a spatial filter with a 3D box*.

- Form attributes
  
  For more information about specifying form attribute values, see *Filter search with form attributes*.

To specify search criteria, click the ... button to the right of each box and enter information in the resulting dialog box. All the criteria you enter are combined so that you can, for example, search for all bolts whose name starts with `bo` and are within 3 centimeters of another part.

For more information about entering specific search criteria, see *Enter search criteria*.

5. Click the Search button on the pane to begin the search.

Teamcenter starts the search and loads the lines into the Search Results dialog box in batches. It displays a progress bar indicating the number of structure lines found as a percentage of the likely results. You can click the Pause button to the right of the progress bar at any time to halt the search. Click the button to the left of the progress bar to load all the results.

Select a line in the Search Results dialog box to highlight the corresponding item or item revision in the structure tree and the embedded viewer. You can also click Display or Display in New Window to view a selected item from the results list.

You can hide the Search pane when it is no longer needed by clicking the Search button in the toolbar again.

**Enter search criteria**

You can enter one or more of the following search criteria:
Chapter 9  Making spatial and attribute searches

- Search scope
- Classification or family attributes
- Occurrence notes
- Proximity or 3D spatial filters
- Target parts

**Enter Classification or family attributes search criteria**

1. Click the ... button to the right of the Classification box.
   Teamcenter displays the Classification dialog box.

2. Click to open the classification hierarchy.

3. Double-click a class name to select it from the tree.
   Teamcenter adds a line to the table containing the name of the class you select.

4. Specify the system of measurement.
   The systems available (metric, nonmetric, or both) depend on the system in which the class is stored in the Classification Administration application.

5. In the Property Name column, click the cell containing the name of the class.
   Teamcenter displays a list of all the attributes within the class.

6. Select the class and attribute with which you want to search.

7. Click the cell containing the = sign and select an operator.

8. In the Searching Value column, select the cell and type a value for the attribute for which you want to search.

9. (Optional) Click + to create an additional search parameter.
   The lines of the table, each representing an individual search parameter, are joined by the AND operator.

10. Click OK.
    Teamcenter displays the classification search parameters in the General search pane.

If you select a single Classification class, you can further refine the search criteria to include specific attribute values. For example, if you select the Bolt class, you can then:

1. Click the Bolt line in the Family Attributes dialog box to define classification attribute criteria.

2. Click Add to specify additional attribute criteria. For example, you can set two classification attribute criteria—**thread=.25** and **Lock_Wire=1**.
If your site has not configured Classification, you cannot search by classification attributes criteria.

**Enter occurrence note search criteria**

- Click the ... button to the right of the **Occurrence Notes** box and you can search for specific occurrence note values. Your administrator can define occurrence notes and associate them with particular structure lines. You can use these mapped occurrence notes as search criteria.

For example, a mapped occurrence note may contain an interior/exterior flag that indicates if a given part is used on the interior or exterior of the product. You could then search for all parts on the exterior of the product or, by refining the search with other criteria, for all exterior brackets.

Similarly, a mapped occurrence note may contain a number that references an illustration in a service manual that describes how to disassemble the part. You can search for all parts illustrated in the appropriate section of the manual.

**Enter spatial filter search criteria**

1. Click the ... button to the right of the **Spatial Filter** box.

   Teamcenter displays the **Spatial Criteria** dialog box, allowing you to define one of two types of spatial filters and optional target parts.

   **Note** The spatial filter option is disabled if Teamcenter is not configured for cacheless searches or if the necessary NX or JT files are not available.

2. (Optional) Select the **Use selections from table** check box above the **Target Parts** table if you want to search against specified target parts.

   For more information about searching against target parts, see **Use target parts**.

3. Use the **Proximity** and **3D box** radio buttons in the **Spatial Criteria** dialog box to select a search type, and then click **OK** to save the selections.

   - **Proximity**
     
     Limits the search to parts within a specified proximity distance, for example, all parts within 10 centimeters of part X.

     For more information about specifying proximity search criteria, see **Define a proximity filter**.

   - **3D box**
     
     Allows you to define a three dimensional box in the embedded viewer and search for parts completely inside, completely outside or intersecting the box. Use the **Spatial Criteria** dialog box to define the coordinates and size of the box.

     For more information about specifying 3D box search criteria, see **Define a spatial filter with a 3D box**.

   **Note** If you are making appearance searches, you can only search inside and intersecting the box when TruShape filtering is selected.
Chapter 9  Making spatial and attribute searches

**Note** You can use altreps (alternative representations) to define different physical configurations or shapes of a flexible part such as a tube or hose. Spatial searching takes into account an alternate geometric shape of a flexible part by searching the dataset that corresponds to the altrep defined on the occurrence object.

*Define a proximity filter*

1. In the **Spatial Criteria** dialog box, select the **Proximity** button.

2. (Optional) Select **Valid overlays only** and Teamcenter loads otherwise physically mutually exclusive parts, filtering out those known to never coexist in any possible variant exclusive combination with any one of the target parts. It determines the minimum number of variant rules that cover all product variants in which the target components can exist. This selection requires that classic variants are configured at your site.

3. (Optional) Select **True Shape filtering** if you want to test items with intersecting bounding boxes to identify if they have TruShape volumes that intersect the TruShape volumes of the selected objects. Depending on the TruShape parameters configured, Teamcenter displays the geometry of each object as regular cubes (voxels) to provide a simplified representation of the actual shape. TruShape searches return more accurate results but may take longer to complete.

4. Define a proximity value in the **Distance** box in the **Spatial Criteria** dialog box and click **OK**.

Teamcenter limits the search to those parts within the defined proximity of the parts selected in the viewer or structure tree. A part is considered within the proximity if any portion of it is within the specified distance; the part may not be completely within the specified distance.

*Define a spatial filter with a 3D box*

**Note** This procedure requires a mockup license for the viewer and is not available with the base license.

1. In the **Spatial Criteria** dialog box, select the **3D box** button.

   Teamcenter displays a brown bounding box at a default location in the viewer.

2. (Optional) Select **True Shape Filtering** if you want to test items with intersecting bounding boxes to identify if they have TruShape volumes that intersect the TruShape volumes of the selected objects. Depending on the TruShape parameters configured, Teamcenter displays the geometry of each object as regular cubes (voxels) to provide a simplified representation of the actual shape. TruShape searches return more accurate results but may take longer to complete.

3. Make the following selections to define the location and size of the 3D box:

   - **Slider increment**

     Specifies the actual distance equivalent to one increment of the **Maximum** and **Minimum** sliders and spinners.
• **Extents**
  Determines how Teamcenter constructs the bounding box from the values you specify, as follows:

  o **Centroid and size**
    Allows you to specify the bounding box with coordinates of the centroid and lengths in X, Y, and Z directions. It is oriented with respect to the global axes of the end item.

  o **Origin and size**
    Allows you to specify the bounding box with coordinates of the origin and lengths in X, Y, and Z directions.

  o **Minimum and Maximum**
    Allows you to specify the bounding box with minimum and maximum coordinates. This is the default selection.

• **Maximum and Minimum** sliders and spinners
  Allow you to manually define the maximum and minimum extents of the bounding box.

• **Find Parts**
  Allows you to specify if parts returned by the search are fully contained inside or fully outside the bounding box.

• **Include parts intersecting the box**
  If checked, the search returns parts that intersect the bounding box, as well as parts that are fully inside or outside it. This option is enabled only if you select the **True Shape filtering** option.

  **Note** If you use appearance searches, this option is always checked.

• **Enable 3D manipulators**
  If checked, drag handles are displayed on the bounding box, allowing you to move and resize it manually. You can then drag the 3D manipulator to resize or reposition the bounding box.
4. (Optional) Do any of the following to move and resize the bounding box with the manipulators:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the manipulator parallel to a face.</td>
<td>Drag the face of the manipulator.</td>
</tr>
<tr>
<td>Move the manipulator perpendicular to a face.</td>
<td>Press Ctrl as you drag the face.</td>
</tr>
<tr>
<td>Constrain the move to one axis.</td>
<td>Press Shift as you drag a face.</td>
</tr>
<tr>
<td>Resize the manipulator uniformly.</td>
<td>Drag a corner of the manipulator.</td>
</tr>
<tr>
<td>Resize the manipulator along one axis.</td>
<td>Press Ctrl as you drag a corner of the manipulator.</td>
</tr>
</tbody>
</table>

5. (Optional) Click **Build from selections** to construct a bounding box containing all target parts specified in the **Target Parts** table, or selected in the tree or viewer.

6. Click **OK** to save the search criteria.

The 3D box remains visible while the search is active, even if the **Spatial Criteria** dialog box is not open.
Note  You can visualize mixed unit assemblies in the Spatial Search dialog box, that is, assemblies composed of parts defined in both Imperial (English) and metric units. The dialog box uses the appropriate units when you type in dimensional values, for example, spatial distance in the Spatial Criteria dialog box.

Defining granularity of spatial searches

By default, spatial searches return piece parts, that is, parts rather than assemblies. However, you may want the search to return a higher level assembly. For example, if you have small assemblies consisting of parts welded together, you may want to treat the assembly as a unit, rather than returning some of its individual parts.

You can change the search granularity by modifying the TruShape voxel size in NX to only return larger assemblies. You can also disable TruShape voxel searches completely, if the results still provide useful information. The coarser the search results, the more quickly they are displayed.

You can also set the QSEARCH_types_to_avoid_processing preference to avoid indexing certain types of items (occurrences) that do not define the structure but do carry some spatial data, for example, work instructions or other manufacturing process-specific items. Such items are not useful in the context of spatial search results. By default, all items with geometry are indexed.

Use target parts

As an alternative to manually generating the spatial search bounding box with the spinner and slider controls, you can construct a bounding box quickly and accurately from a table of target parts. You can use this method for proximity or 3D bounding box searches.

Note  Generic objects such as GDE elements, GDE link lines, interface definitions, and processes are not valid participants in spatial searches. Consequently, they are not added to the target parts table. If you try to add a generic object to the target parts table, Teamcenter displays an error message indicating the BOM line is invalid.

However, you can add valid generic objects such as signals and designs to the target parts table. If you select these objects in the table or perform a search on them, Teamcenter displays a warning message indicating that they do not have associated bounding boxes.

Note  The target parts table is not available if you are making appearance-based searches.

1. By default, the target parts table is hidden. If necessary, show the target parts table by setting the RDV_show_targets_on Spatial dialog preference to true.

2. Select the Use selections from table check box.

Teamcenter enables the Target Parts table and its associated buttons.

Note  If you select Use selections from table, any selections in the tree or viewer are ignored.
3. Select target parts in the structure tree or viewer, and then click the + button to add them to the **Target Parts** table.
   
   To remove a target part, select it in the table and click the – button.
   
   To clear the table of all entries, click 🗑️.

4. Once all the required target parts are listed to the table, click OK. Alternatively, if you are defined a 3D box search, click **Build from selections**.
   
   Teamcenter draws a bounding box enclosing all the target parts in the viewer.

5. Perform a spatial search, as described in **Perform a search**.
   
   Teamcenter displays the **Search Results** pane containing the results of the spatial search.

6. (Optional) Select the **Show targets table** check box to display a list of the target parts of the search.

7. (Optional) Select one or more BOM lines in the list of target parts or select **Select all targets**, and then do one of the following:
   
   - Click **Display** to show the target parts in the tree and viewer in the same window.
   
   - Click **Display in New Window** to open a new window to show the target parts in the tree and viewer.

**Filter search with form attributes**

You can filter searches using the criteria of forms attached to the items or item revisions.

1. Click the ... button to the right of the **Form Attributes** box.
   
   Teamcenter displays the **Form Attributes** dialog box.

2. Enter the form attributes for the search, including any mathematical operators.
Teamcenter displays the form type and search values as a string in the format similar to the following example:

“ItemRev:BVRSyncInfo:last_struct_mod=value1 AND ItemRev:BVRSyncInfo:last_Sync_date=value2”

Managing search results

The same part may be listed many times in the search results if it has multiple occurrences in the end item that match the search criteria. For example, the same bolt may be used seven times in the end item and, if all seven usages satisfy the defined proximity filter, the bolt appears seven times in the search results.

The search results always displayed shows individual lines without indication of any structure.

When Teamcenter displays the result of a search, the children of the node you searched for may be hidden so the search results are displayed quickly. Each hidden node is represented by a ... (pruned siblings) symbol enclosed in a box. You can click in this box to load and view the hidden children.

If the results contain packed lines, the relevant lines are unpacked and displayed. The remaining lines remain packed and are shown as a pack master with a corrected total of lines, or with pruned siblings.

The search results contain lines that may not be configured by the variant rules in effect to minimize the time needed to generate the search results.

Manage search results

To manage the search results, you can:

- Sort the list by clicking the header of a column in the properties table. By default, the search results table includes the same columns as the product structure tree.

- Customize the columns that are displayed by right-clicking in the column header and Teamcenter displays the **Insert Columns** dialog box. You can click the + button to add a column (for example, **Validity**) to the search results or click the – button to remove unwanted columns.

- Save the list to a file or print it by right clicking in the column header. When saving the results list to a file, you can specify whether to use HTML or text format. The text file contains comma-separated values (CSVs), and you can import data in this format into Microsoft Excel or similar applications.

- Click **Display** or **Display in New Window** to open the currently selected lines in a separate Structure Manager window for examination.

- Click **Copy** to copy the currently selected lines for subsequent pasting into another Structure Manager window.

Examples of managing search results

Because a single search may potentially return thousands of BOM lines, you can control how many search results are listed in the table. If the search finds only a few lines (less than five), Teamcenter lists all of them in the table. If there are more
Chapter 9  
*Making spatial and attribute searches*

lines, Teamcenter lists only the first five and you can click the **Display** button in the **Search Results** pane to add the next group of five to the list.

The information label in the title bar of the **Search Results** pane identifies the end item, view, or effective revision rule in effect.

You can view the search results in a new window, if required, by clicking the **Display in New Window** button. You can then perform another search in that window to refine the results.

**Managing the search results panes**

The search results pane contains an individual tab for each set of search results and a new tab can be added by each new search. Each tab has a label to indicate the configuration rules (for example, revision rule or effective date/unit) in effect when you performed the search.

Having the results in individual tabs allows you to manage and retain distinct lists of search results that might have resulted from:

- Different search criteria
- Different configurations (revision rules)
- Different end items

Your first search results are listed in a tab named **Result 1** by default. Any subsequent search results are added to the current tab. This allows you to merge the results of separate searches. For example, if you want to find all brackets that are on the interior of the product or within 2 cm of part X, you could perform two searches and merge them.

Alternatively, you can lock the results tab causing the next search results to create a new tab—**Result 2**.

To lock a results tab, right-click the tab and choose **Lock/Unlock** from the shortcut menu. You can lock any number of tabs.

If the configuration of the end item changed since the last search, Teamcenter automatically adds a new tab rather than merging the next set of search results into the current tab. For example, if you changed the revision rule since the previous search, the next search results create a new tab. This ensures that all lines in a given tab correspond to the same configuration of the end item.

**Manipulate search results**

To manipulate search results, use the following buttons at the bottom of the search results pane:

- **Display**
  
  Highlights in the viewer and tree all lines that are selected in the search results list. You can then perform another search to refine the results.

- **Display in New Window**
  
  Displays all lines that are selected in the search results list in a new window. You can then perform another search to refine the results.
Making spatial and attribute searches

- **Copy**
  Copies to the clipboard all lines that are selected in the search results list.

You can also select the **Select All** check box to select all lines in the search results list.

You can right-click one of the lines in the search results list and Teamcenter displays a shortcut menu. You can choose any of the following commands:

- **Display**
  Displays the line.

- **Copy**
  Copies the line to the clipboard.

- **Send To**
  Sends the line to another application.

- **Properties**
  Lists properties of the selected line.

**Limiting search results**

You can remove extraneous lines when displaying search results to keep the structure tree compact and manageable.

For example, you perform a search that finds a single line that is 10 levels deep in the structure. If you fully expand the branch from the root down to the line of interest, you may also display hundreds of other lines (all of its ancestors and the siblings of itself and its ancestors). To avoid this, you can prune the branch of the tree and not display any sibling lines (and potentially none of its ancestors).

When you select lines in the search results pane to display, the following occurs:

- If the **Show unconfigured variants** option is turned off, Teamcenter applies the current variant rules to the selected structure lines. If any lines become unconfigured as a result of the variant rules in effect, Teamcenter displays a **Lines are unconfigured due to Variant rules** message.

- The remaining lines are displayed in the tree and pruned as described previously.

- If the viewer is active, the lines are displayed in the viewer.

This assumes that the revision rules associated with the search results match the revision rules in effect in the structure. If not, Teamcenter evaluates each line in the search result to see if it is valid in the context of the currently configured end item. If it is valid, the line is displayed as before. Otherwise, it is displayed in a separate section of the tree called **Unconfigured Objects**.

If you do not have read access to an item that satisfies the search criteria, the corresponding line is not listed in the search results table. If this occurs, the count of lines in the search results is reduced to exclude any lines to which you do not have read access.
Chapter 10 Comparing product structures

Comparing product structures ........................................... 10-1

Understanding product structure (BOM) comparisons .................. 10-1
  Choose a comparison mode ............................................. 10-2
    Single-level mode comparisons .................................... 10-2
    Multilevel mode comparisons ..................................... 10-3
  Lowest level mode .................................................... 10-3
  Comparing logical structures ....................................... 10-4

Performing a comparison and interpreting the results .................. 10-4
  Configure the structures for comparison ............................ 10-4
  Initiate the comparison process .................................... 10-5
  Interpret comparison results ....................................... 10-5
  Example result of a structure comparison ........................... 10-6
  Clear comparison results ............................................ 10-6

Understanding graphical comparisons .................................. 10-7
  Configuring graphical comparison .................................. 10-7
  Change comparison results colors ................................ 10-7
  Initiating the graphical comparison ................................ 10-8
  Show and hide common parts ....................................... 10-8
  Change the revision rule ............................................ 10-9

Comparing structures under change management ........................ 10-9
  Select comparison information ..................................... 10-10
  Viewing and comparing revisions ................................... 10-11
    Using the comparison sliders ..................................... 10-12
      Example of graphical history .................................. 10-13
      Controlling a graphical comparison ............................ 10-13
      Showing and hiding supersedure links ........................ 10-14
      Using the supersedure pane ..................................... 10-14
      Display comparison results in the structure trees .......... 10-15
    Show supersedures graphically .................................. 10-16
    View an individual supersedure link ............................ 10-16
    Define structure change colors, slider colors, and position 10-16
  Create related revision histories ................................... 10-16
  Create disparate revision histories ................................ 10-18
  Create detail part histories ..................................... 10-18
  Viewing supersedure ................................................. 10-19
    Using the supersedure toolbar .................................... 10-19
    Using supersedure lists in the Supersedure pane .............. 10-21
    Interpreting supersedure symbols ................................ 10-21
    Managing supersedure ............................................. 10-23
    Browse supersedure .............................................. 10-23
Display a different supersedure in the context of a parent assembly ........................................ 10-24
Create a new supersedure with respect to a different top-level product ..................................... 10-24
Create a transfer supersedure ........................................ 10-25
Commonly encountered supersedure examples ........................................ 10-26
View a supersedure in Structure Manager ........................................ 10-29
Create a structure change ........................................ 10-29
Create a structure change using dynamic revision ........................................ 10-30
Create the CM base configuration form ........................................ 10-31
Create a BOM change based on dynamic revision rules ........................................ 10-31
Create structure quantity changes ........................................ 10-31
Attach a form to structure change ........................................ 10-32
Create delivered change ........................................ 10-33
Creating a custom supersedure form ........................................ 10-34
Enable custom forms ........................................ 10-34
Associate a custom form with a supersedure ........................................ 10-34
Track history of variant changes ........................................ 10-35
Chapter

10 Comparing product structures

Comparing product structures

You can compare two structures to identify changes or differences between two product structures, for example, to:

- Identify component changes between assemblies
- Test for consistency between multiple views of the same item
- Find differences between differently configured structures

You may only be interested in the immediate components that have changed in a single-level assembly. Conversely, you may want to identify the differences between all the piece parts in the complete product structures (for example, between related multiple views or different variants of the product).

Teamcenter allows you to compare structures in two ways.

- You can compare two product structures (BOMs) in separate Structure Manager windows.
  The differences are highlighted in the product structure trees.
- You can also perform a graphical comparison of two structures.
  Teamcenter highlights differences in the viewer.

You can optionally compare product structures that are controlled by change management, as described in Select comparison information.

Understanding product structure (BOM) comparisons

You compare the displayed state of the product structures (BOMs), that is, everything that is currently visible in the two compared structures. Collapse assemblies if you do not want to include them in the comparison.

You must set the appropriate revision rule and variant rule (if any), to configure the structure in each window. If you apply a variant rule, ensure you hide the unconfigured components. You can also compare loaded view types.

The comparison also identifies differences between supporting objects, including:

- Item elements (also called GDEs or general design elements).
- Connections
Choose a comparison mode

You can compare product structures in one of four standard modes:

- **Single-level mode comparisons** compare only the first level of the product structures. You can choose to include one of find numbers, substitutes, or reference designators in the comparison or exclude them.

- **Multilevel mode comparisons** perform a single-level comparison at the top level of the structure. Teamcenter then makes further single-level comparisons of any subassemblies that appear in the two product structures. You can choose to include find numbers in the comparison or exclude them.

- **Lowest level mode** compares only the lowest level items of the product structures, ignoring all intermediate assemblies.

- **Every level mode** compares each line of every level of the product structure.

Your Teamcenter administrator may define other comparison modes appropriate for your site.

**Single-level mode comparisons**

Single-level mode compares only the first level of the product structures. Two components or subassemblies match if they are the same item and have the same revision and quantity. If there is more than one occurrence of the same item, they are rolled up for the purposes of the comparison. Consequently, one occurrence with a quantity of 2 is the same as two occurrences with a quantity of 1. You can optionally include any one of find numbers, reference designators, and substitutes in the comparison.

In this mode, Teamcenter reports the following differences:

- Additions to one of the product structures
- Quantity changes
- Revision changes
- Addition, revision, and removal of commercial parts
- Addition, revision, and removal of vendor parts
- Change to the preferred status of a vendor part

If included in the comparison, find number changes result in a new item and the comparison reports such changes as additions.
If included in the comparison, reference designator changes result in a new item and the comparison reports such changes as additions.

If included in the comparison, substitute part changes result in a new item and the comparison reports such changes as additions.

**Multilevel mode comparisons**

In multilevel mode, if the comparison process matches two subassemblies in the two product structures, it proceeds to compare the two subassemblies. This process continues down the product structure until it reaches the bottom of the structure or there are no matching subassemblies left.

The subassemblies match if they are the same item and have the same revision, quantity, and find number (if included).

In this mode, Teamcenter reports the following differences:

- Additions to one of the product structures
- Quantity changes
- Revision changes
- Addition, revision, and removal of commercial parts
- Addition, revision, and removal of vendor parts
- Change to the preferred status of a vendor part

If included in the comparison, find number changes result in a new item and the comparison reports such changes as additions.

If included in the comparison, reference designator changes result in a new item and so the comparison reports such changes as additions.

Use this mode to find differences between two configurations of the same product, for example, when variants are applied.

The extended multilevel comparison mode continues until it finds a difference in item or find number. It reports differences in quantity or revision but continues with the comparison.

**Lowest level mode**

Lowest level mode compares the lowest level items in the two product structures, ignoring the intermediate structure. Teamcenter totals the quantities of each item in the product structures before comparing them. Find numbers are not considered in this mode.

In this mode, Teamcenter reports the following differences:

- Additions to one of the product structures
- Quantity changes
- Revision changes
Use this mode to compare multiple views, such as a design view that may have a different structure to a manufacturing view, while maintaining the same set of piece parts.

For more information, see *Multilevel mode comparisons*.

**Comparing logical structures**

A logical structure (LBOM) contains GDE lines that represent signals and connections, as well as items and items revisions. Teamcenter compares GDE lines using their names, signals and connections. When necessary, it compares signals using their source port and destination port attributes. (Not all lines in a logical structure have source and destination ports.)

For such structures, Teamcenter uses single level, multilevel, and lowest level modes to compare the following properties:

- Item ID for item lines
- Revision for item lines
- Name for GDE lines
- Endpoints for connections
- Source, target, and transmitter lists for signals and process variables
- Process variable associations for signals
- Quantity for functionalities

To allow comparison of two different configurations or views of the same LBOM structure, Teamcenter supports occurrence-based and nonoccurrence-based comparisons in single-level and multilevel modes.

**Performing a comparison and interpreting the results**

You must open the two structures to compare in separate Structure Manager panes and configure them before you initiate the comparison process.

**Configure the structures for comparison**

You compare two configured structures displayed in separate Structure Manager panes. Open the source structure in the left pane and the target structure in the right pane.

1. If the structures are not already open, do the following to open the first structure:
   a. Select the BOM view revision and click the Open By Name button. You can also double-click the BOM view revision or use your MRU list to open the required structure.
      Teamcenter opens the Open By Name dialog box.
   b. In the ID box of the Open By Name dialog box, type the identifier of the item you want to compare and click Find.
Comparing product structures

c. Click the **Load all** button.

   Teamcenter displays the results.

   Alternatively, you can right-click an item, item revision, or BOM view revision, and then choose **Send To→Structure Manager** to open it.

2. Click the **Split BOM** button 🛠.

   Teamcenter open a second pane, adjacent to the current pane.

3. Select the second pane and repeat step 1 to open the second structure.

4. Select the correct top-level line in each structure to use for the comparison.

5. Configure the structures by setting the revision rule and variant rule in each window.

6. Expand and collapse assemblies to define the scope of the comparison. You can compare only the visible structures displayed in the windows.

7. Hide unconfigured variants by choosing **View→Show Unconfigured Variants**.

**Initiate the comparison process**

When you have configured the two structures in separate panes:

1. Choose **Tools→Compare....**

   Teamcenter displays the **BOM Compare** dialog box.

2. In the dialog box, select the mode of operation for the comparison from the **Mode** list. These modes are described in **Choose a comparison mode**.

3. Check the **Report** check box if you want to display the report pane summarizing the differences between the structures. The report pane is described in **Example result of a structure comparison**.

4. Click **OK** to begin the comparison.

**Interpret comparison results**

Teamcenter presents the results of the comparison in the following ways:

- In the structure trees

   Teamcenter highlights each of the lines in each Structure Manager pane that differ between the two structures. By default, additions in the target with respect to the source are highlighted in red and changes in quantity or revision are highlighted in orange. Your Teamcenter administrator can change these default colors by changing the **PSEAdditionColorPref** and **PSEChangedColor** preferences, respectively.

   To view details of the changes (for example, revision or quantity changes), examine the **Changes** column in the structure properties table. If this column is not visible, you can add it to the table, as described in **Viewing product structure properties**.
Chapter 10  Comparing product structures

- As a report

Teamcenter displays an additional pane at the bottom of the window, listing the differences. You can select a line in the report to highlight the corresponding changed lines in the two Structure Manager panes. This helps you locate where in the structures the changes took place.

The pane indicates the type of change: **Added** for additions, **Qty** for quantity changes, and **Rev** for revision changes. A comma-separated list appears if more than one change occurs on the same line.

- In single-level mode and lowest level mode, the reports are flat lists of differences.
- In multilevel mode, the report is an indented output showing the parent assemblies of any changed items.

**Example result of a structure comparison**

The following figure shows the result of a single-level comparison between two revisions of the same structure.

Notice that a single item (000124/A) is added to the target view in the right-hand pane and this addition is highlighted in a different color. The difference is also listed in the report pane.

**Example results of structure comparison**

**Clear comparison results**

- Choose **Tools→Clear Compare**.

Teamcenter clears the highlighting colors and the compare columns in the two panes. It also closes the report pane.

**Note**  If you start a new comparison before clearing the results of the previous comparison, the existing results are automatically cleared.
Understanding graphical comparisons

You can compare two revisions of a part or assembly and view differences in the embedded viewer pane. Teamcenter displays any differences by color coding parts or assemblies to indicate the type of change made. The differences are also shown in the product structure tree by icons. You can also compare two occurrence groups to identify differences.

You can compare both revision controlled and nonrevision controlled assemblies (for example, configured by effectivity) graphically.

You can compare:

- An assembly with another assembly.
- A part with another part.
- An occurrence group with another occurrence group.
- Supersedures.

If you compare two assemblies under change management (where one assembly is a problem item and the other is an affected item of an engineering change object), Teamcenter displays a list of supersedures.

**Note** You must implement change management if you want to define and use supersedures. For more information, see *Comparing structures under change management*.

You cannot compare multilevel structures by this method.

Configuring graphical comparison

You must ensure the Lifecycle Visualization license level is set to the **Advanced** level if you want to use graphical comparison. If this is not set correctly, the **Tools→Graphical BOM Compare** menu command is not visible.

Change comparison results colors

1. Click the **Icons/Colors Legend** button.
   Teamcenter shows your current change color settings.

2. Choose **Edit→Options**.
   Teamcenter displays the **Options** dialog box.

3. In the **Options** dialog box, expand the **Change Management** folder and click the **BOM Tracking** entry.
   Teamcenter displays the colors representing the different structure change types.

4. Double-click the type of comparison whose color you want to change and Teamcenter displays the **Color Chooser** dialog box.

5. Choose a new color with the **Swatches**, **HSB**, or **RGB** color selector and click **OK**.
Chapter 10  
Comparing product structures

Teamcenter uses the new color to identify the selected type of comparison everywhere structure changes are displayed in the rich client, including the Structure Manager Supersedure pane. For information about how to change the default colors and positions of the sliders, see Define structure change colors, slider colors, and position.

Initiating the graphical comparison

To access graphical comparison feature, load the two parts, occurrence groups, or configured structures in separate Structure Manager windows, and choose

Tools—Graphical BOM Compare or click the button (if you added this button to the toolbar).

Teamcenter displays the Graphical BOM Compare dialog box, allowing you to manipulate the results.

After running the comparison, Teamcenter highlights the following differences between the two windows in the viewer:

- Adds
  Objects that are in the target window but not the source.

- Cancels
  Objects that are in the source window but not in the target.

- Moves
  Objects that are in different positions in the source and target windows (the transformation matrix has changed).

- Reshapes
  Objects that have an alternative representation between the source and target windows, as identified by an UGALTREP note.

You can use the comparison sliders in the Graphical BOM Compare dialog box to dynamically view the changes. Parts that are added, canceled, moved, or reshaped from one revision to another move across the window as the respective slider is slid from one revision to another.

Also, the parts are color-coded, depending on whether they are added, canceled, moved, or reshaped.

For information about changing the color associated with each type of change, see Change comparison results colors.

After you create the graphical history, you can capture it to export or print.

Show and hide common parts

Certain common parts may remain unchanged between the two structures. By default, Teamcenter does not display these common parts in the viewer, allowing you to more easily distinguish changed parts. Hiding these common parts also allows Teamcenter to load the assembly more quickly.
Comparing product structures

When required, you can display the common parts to more easily see the changes in context of the larger assembly. To show common parts when required, select the **Show Common Parts** check box.

**Note** You can only use common parts if you compare two revisions of the *same* assembly, not different assemblies. Do not use this option if one assembly is a subassembly of the other assembly in the comparison.

To always display common parts, you can change the **CM_show_common_parts** preference, as follows.

1. Choose **Edit→Options**.
   Teamcenter displays the **Options** dialog box.

2. In the dialog box, expand the **Change Management** folder and click **Graphical History**.
   Teamcenter displays the **Graphical History Settings** pane.

3. In the **Graphical History Settings** pane, select the **Show Common Parts** check box.

Teamcenter now displays common parts during the initial loading of graphical history. If required, you can hide common parts by clearing the box after the history is loaded.

**Change the revision rule**

To use a different revision rule from the revision rule applied before you began the comparison:

1. Select the affected structure pane and click the **Revision Rule** button.
   Teamcenter opens the **View/Select Revision Rule** dialog box.

2. In the dialog box, select the desired revision rule from the list on the left-hand side and click **OK** or **Apply**.
   Teamcenter sets the selected revision rule for the structure pane. It recalculates the graphical comparison result and resets all the sliders and buttons in the control pane to their default positions.

   If you want to change the revision rule for the both structure windows, repeat these steps in the other window.

**Comparing structures under change management**

If the structures you compared graphically are under change management, you can view additional information about the change status (*genealogy*) of your product structure or its components. Structure Manager can exchange data with Change Manager.

When change management is enabled and you save product structure changes in Structure Manager, Teamcenter generates add and cancel information for the affected assembly. You can define the supersedure relationships between the various
adds and cancels when you save the changes or later. Change management also allows you to display the genealogy of a component in the assembly.

Supersedure relationships are always created manually in Change Manager. You copy the old item revision to the Impacted Items folder and the new item revision to the Solution Items folder to establish the relationship.

Select comparison information

Select information about the change-managed objects you compared by clicking the Revisions and Graphical Compare tabs of the Change History dialog box.

The Change History tab includes the following two panes:

- Revision list pane

  The Revision List pane displays the item revisions belonging to the selected item. The item revision nodes are color-coded to convey the change revision information of each revision. If a revision has an associated change, it is displayed in pink, otherwise it is displayed in black.

- Progression pane

  The Progression pane displays all the revisions of the parent structure in a vertical multibranched tree. The tree displays one of the two following relationships between child and parent objects, depending on the CM_progression_tree_relation preference setting.

<table>
<thead>
<tr>
<th>Preference value</th>
<th>Types of relationship displayed in the progression tree</th>
</tr>
</thead>
<tbody>
<tr>
<td>EC_affected_to_problem_relation</td>
<td>In the problem/solution relationship, the selected revision is the solution revision. The problem revision is shown as a parent revision.</td>
</tr>
<tr>
<td></td>
<td>This relationship is only displayed in the progression tree if the selected revision is part of a change process.</td>
</tr>
<tr>
<td></td>
<td>This is the default setting of the preference.</td>
</tr>
<tr>
<td>TC_based_on</td>
<td>In the based on relationship, the revision upon which the selected revision was based is shown as the parent revision.</td>
</tr>
<tr>
<td></td>
<td>This relationship does not depend on the selected revision being included in a change process.</td>
</tr>
</tbody>
</table>

The Graphical Compare dialog box includes the following controls and boxes:
### Component | Description
--- | ---
Progression and Revision buttons | Choose the required mode of the revision list. By default, the revision list includes all revisions in a color-coded format. If a revision has change associated, it is displayed in pink; otherwise, it is black.

If you click the Progression button, revisions are displayed sequentially.

Compare With combination box | Selects the revision with which you want to compare the selected revision in the left side tree. By default, the problem revision is selected if a change object created the selected revision. Otherwise (for users not using Change Management), the Based On revision is automatically selected.

View Type combination box | Chooses a particular BOM view type in case the selected revision has multiple BOM view revisions associated. Your default BOM view type is selected automatically. If you are not using multiple BOM view types, the correct type is automatically shown.

Set Revision Rule button | Chooses the revision rule to configure the selected change revision.

Change button | Opens the associated change revision in Change Manager.

Effectivity Data table | Displays the effectivity data attached to the selected revision. If no effectivity is attached, the table is blank. If the revision is effective for multiple end items, all end item effectivity entries are displayed.

Paste button | If you want to compare the selected revision with a revision of another item, you can copy the revision from another application and paste it into the Compare With box.

Status pane | The status pane at the bottom of the dialog box gives status information (for example, loading parts).

### Viewing and comparing revisions

When you select a revision from one of the revision trees and click the Graphical Compare tab, Teamcenter displays the graphical history in the right pane. This tab has two tabs at the bottom, the Controls tab and the Structures tab.

If the selected revision has change associated with it and has a problem revision, Teamcenter displays the current configuration in the embedded viewer. The viewer includes a number of control sliders and buttons that allow you to see the differences between the problem and affected configuration.

If the revision does not have a problem configuration, you can choose another revision for comparison.
### Using the comparison sliders

When you select a revision and click the **Graphical Compare** tab, the graphical configuration is displayed with five slider controls. Use these comparison sliders to dynamically view the changes between the selected revisions. Parts that are added, canceled, moved, or reshaped from one revision to the other move across the screen as you move the slider is slid from one revision to the other. The parts are color-coded according to their status.

Use the sliders to view the histories of the following modifications:

<table>
<thead>
<tr>
<th>Slider</th>
<th>Views the following modifications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adds</td>
<td>Objects that are on the target assembly but not on the source (<em>added</em>). Indicates parts that are added to the revision. This addition corresponds to the addition tracked in any related structure comparison or supersedure. By default, these parts are colored blue.</td>
</tr>
<tr>
<td>Cancels</td>
<td>Objects that are on the source assembly but not on the target (<em>removed</em>). Indicates parts that are removed from the revision. This cancellation corresponds to the addition tracked in any related structure comparison or supersedure. By default, these parts are colored red.</td>
</tr>
<tr>
<td>Moves</td>
<td>Objects that are repositioned (transform matrix changed) between the source and target assembly. Indicates parts that are repositioned. A move is not considered an addition or a cancel in related supersedures. In a structure comparison, the move is tracked with the defined move image. You create a move to track the relocation of a component between the problem and affected assembly. This change is made using an <strong>ALTREP</strong> note type in the two assemblies. Supersedures do not track this type of comparison. By default, these parts are colored green.</td>
</tr>
<tr>
<td>Reshapes</td>
<td>Objects that have an alternate representation (identified by an <strong>UGALTREP</strong> note) between the source and target assembly. Indicates parts whose shapes are changed. A reshape is not considered an add or cancel in any related supersedure. In a structure comparison, the reshape is tracked with the defined reshape image. You create a reshape to track the relocation of a component between the problem and affected assembly. This change is made using an <strong>ALTREP</strong> note type in the two assemblies. Supersedures do not track this type of comparison.</td>
</tr>
</tbody>
</table>
Comparing product structures

<table>
<thead>
<tr>
<th>Slider</th>
<th>Views the following modifications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common</td>
<td>Objects that are in both source and target assemblies.</td>
</tr>
<tr>
<td>All</td>
<td>Shows all of the modifications described previously at the same time.</td>
</tr>
<tr>
<td>Triangular slider</td>
<td>The triangular slider is situated under the standard sliders. It adjusts the speed of the moving parts when you interact with the standard sliders. For example, when parts are large compared with the viewer size, they may move too quickly out of the viewer. Use this slider to reduce the speed to obtain a better transitional effect. Similarly, when parts are too small, you can increase the speed.</td>
</tr>
</tbody>
</table>

**Note**

You can modify the comparison colors by clicking **Icons/Colors Legend** to view and change the currently defined color for each type of comparison.

The **All** comparison slider moves all the comparison slider bars simultaneously. In the far left position of the slider, the assembly is the problem assembly before any parts were modified.

**Example of graphical history**

Assume an assembly named Revision B (that is based on Revision A) contains Part B, which replaced Part A. Assume all the comparison sliders are set under Revision A. At the same time, Part C was moved 10 degrees from its previous location and Part D's curve now begins 9 millimeters higher. Assume all the comparison sliders are set under Revision A.

- Moving the **Adds** slider from Revision A to Revision B causes Part B (colored blue) to move across the viewer and overlay Part A.
- Moving the **Cancels** slider from Revision A to Revision B causes Part A (colored red) to pull out of the assembly and move out of the window.
- Repositioning the **Moves** slider from Revision A to Revision B causes Part C (colored green) to change its location in the assembly.
- Moving the **Reshapes** slider from Revision A to Revision B causes the curve in Part D (colored light blue) to start 9 millimeters higher on the part.

Moving the **All** slider causes all of these changes to occur simultaneously.

After you create the comparison, you can capture the image to export or print.

**Controlling a graphical comparison**

You can use the following controls on the **Graphical Compare** tab to manage the comparison process of change-managed structures:
Chapter 10  
Comparing product structures

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Common Parts</td>
<td>Use this check box to control if Teamcenter displays common components between the two assemblies.</td>
</tr>
<tr>
<td>Show Supersedure link</td>
<td>Use this check box to control if Teamcenter displays supersedure links between added and canceled components.</td>
</tr>
<tr>
<td>Show</td>
<td>These buttons allow you to display other configurations, without returning to the revisions tab and selecting another revision. Use the three</td>
</tr>
<tr>
<td></td>
<td>buttons provided to display one of the following configurations:</td>
</tr>
<tr>
<td></td>
<td>• Previous revision as configured by creation date</td>
</tr>
<tr>
<td></td>
<td>• Next revision as configured by creation date</td>
</tr>
<tr>
<td></td>
<td>• Latest working according to site settings</td>
</tr>
<tr>
<td>Display pane</td>
<td>Shows the list of supersedures (if any) associated with the currently displayed affected assembly.</td>
</tr>
<tr>
<td>Structure tab</td>
<td>Displays a color-coded structure tree for both the configurations. Buttons are provided to allow you to set the variant and revision rules.</td>
</tr>
</tbody>
</table>

Showing and hiding supersedure links

There may be several supersedures between the added and canceled parts that are displayed in the blue and red colors respectively. If you want to identify the added parts that are related to certain canceled parts by a supersedure, select the Show Supersedure Links check box in the control pane. Teamcenter shows a graphical band link between the added and canceled parts of each supersedure associated with the displayed affected assembly. By default, the Show Supersedure Link check box is not selected.

**Note**  To aid identification, added parts are shown in blue and canceled parts are shown in red.

When you show supersedure links, Teamcenter draws a white band between added and canceled components. When supersedures contain several added or canceled components, Teamcenter draws a polygon connecting the center points of all concerned parts. If you move the All comparison slider to the maximum left or right position, the bands disappear automatically and the Show Supersedure Link check box is not selected.

Using the supersedure pane

The supersedure pane at the bottom left corner of the Graphical Compare→Control tab shows the list of supersedures associated with the currently displayed affected assembly.

If you expand a supersedure, Teamcenter shows the relevant added and canceled parts. Select a particular add or cancel to highlight the corresponding graphics in the viewer.
Comparing product structures

If the affected assembly was not created under a change order, the **Supersedure** pane and the **Supersedure Link** check box are hidden.

**Display comparison results in the structure trees**

You can view the differences between the two revisions in tree format as well as in a graphical display. To do this, click the **Structures** tab at the left bottom corner of the **Graphical Compare** tab and Teamcenter displays two structure trees. It shows any modifications (adds, compares, moves, or reshapes) to the selected lines that were detected by the comparison in the appropriate colors.

Use the following buttons to set the effectivity for revision rules and the variant rule.

- **Set Date/Unit/End Item** button

  If you select a dynamic revision rule in the **Revisions** tab before you display the comparison results, the structure tree remains unconfigured and no parts are visible in the viewer.

  A revision rule is *dynamic* if Teamcenter requires end item, date, or unit entries to correctly configure the structure against that rule. If Teamcenter uses a dynamic revision rule to load a structure, it requires the unit number and end item to load the structure correctly.

  To set the correct configurations in this situation:

  1. Select each structure pane and click **Calendar**.
     Teamcenter displays the **Set Date/Unit/End Item** dialog box.

  2. Enter the unit number or end item values and click **OK** in both structure panel.
     Teamcenter configures the structures and displays the comparison results in the viewer.

     When you load a new revision rule, Teamcenter recalculates the comparison results and the control sliders return to their default positions.

- **Set Variant Rule** button

  If the two structures you compare contain components with variant conditions, the comparison results include all the lines, irrespective of the associated variant conditions.

  To limit the comparison to a set of variant rules:

  1. Select each structure pane and click the **Variant** button.
     Teamcenter displays the **Variant Rule** dialog box.

  2. Enter the required variant rule and click **OK** in both structure panels.
     Teamcenter hides the nonconfigured components in the graphical display and the structure tree.

     When you load a new variant rule, Teamcenter recalculates the comparison results and the control sliders return to their default positions.
Chapter 10  Comparing product structures

Show supersedures graphically

When browsing through the replacement history of a component in the context of an item in the Structure Manager Supersedure tab, you can view the graphical history of the changes of a particular replacement record (part to part supersedure).

To do this, select a supersedure from the trail and click Change History. The Change History dialog box opens with the changed components shown in their respective colors. Teamcenter hides the following Show Common Parts and Show Supersedure Link controls and tabs.

You can use the comparison sliders to view the revision changes.

**Note** The PV Viewer_PSE property determines the availability of this functionality. By default, this property is set to False and Teamcenter does not display the button in the toolbar. Set this preference to True in the rich client user properties file to enable this functionality.

View an individual supersedure link

While the Show Supersedure Link command helps you identify the various supersedures in a comparison, it can be difficult to identify a single supersedure in a part-to-part supersedure. In this situation, highlight a single supersedure link, rather than all supersedure links, as follows.

1. Click the Controls tab on the Graphical Compare pane.
2. On the Graphical Compare pane, select the Show Supersedure Link check box.
3. Move the Adds comparison slider to the center or right.
4. Move the Cancels comparison slider to the center or left.
5. In the Supersedure pane, select the supersedure whose link you want to view. Teamcenter shows a single supersedure link in the viewer, corresponding to the selected supersedure.

Define structure change colors, slider colors, and position

You can set your own preferences for the colors of structure changes and for the default color and position of the sliders, as follows.

1. Choose the Edit→Options menu command. Teamcenter displays the Options dialog box.
2. In the Options dialog box, select the desired color for any structure change type.
3. In the Options dialog box, modify the initial location of the slider. (The default initial slider position is 100.)

Create related revision histories

You can compare the graphical histories of two revisions of the same assembly.
For instructions about viewing a graphical comparison of two revisions that do not belong to the same assembly, see Create disparate revision histories.

1. Select an assembly line in the structure tree and click the Graphical History button.
   Teamcenter displays the History dialog box.

2. In the dialog box, click the Revisions tab.
   Teamcenter displays the Revision pane.

3. On the Revision pane, choose two assemblies to compare. Click Revision List to show all the revisions associated with the parent assembly in a tree-format structure. Click Progression for a tree-format display of associated revisions.

4. In the Revision List view, select one of the revisions to compare.

5. From the Compare With list, select the second revision. This list includes all the revisions associated with the selected parent assembly.
   By default, Teamcenter populates the Compare With box with the problem revision if the revision you selected in step 3 is in a change process.

6. If the parent assembly has multiple BOM view revisions associated with it, select a view from the View Type list.

7. Optionally, click Change to open the associated change in Change Manager.

8. Review the effectivity data table for any effectivity data defined for the selected revision. If no effectivity data is defined, the table is blank. If multiple effectivities are defined for the revision, Teamcenter displays all end item effectivity entries.

9. Click the Graphical Compare tab to display the comparison pane.
   Teamcenter displays the revision selected in step 3 in the viewer. The names of both the selected revisions are listed in the comparison sliders pane, with the revision selected in step 4 to the right. By default, the comparison sliders line up under this revision.

10. Check Show Common Parts to load all the parts common to the two assemblies in the viewer.

11. View the history of adds, cancels, moves or reshapes by moving the appropriate slider. To see all changes simultaneously, move the All slider.

12. To compare the histories of other revisions without returning to the Revisions tab and choosing another set of revisions to compare, click one of the following buttons:
   - Click Previous to display the previous revision based on creation date.
   - Click Next to display the next revision based on creation date.
Chapter 10  Comparing product structures

- Click Latest Working to display the latest working revision, based on your site's definition.

13. To view the comparison information in tree format, click the Structures tab at the bottom of the dialog box. The comparison controls are replaced by two structure tree diagrams, indicating the modifications (adds, cancels, moves, reshapes) to each revision by icons and color coding.

Click the Icons/Colors Legend to view the meanings of the icons and colors. In this view, you can also set options for variant rules, view current revision rules and set the current rule and set effectivity information.

Create disparate revision histories

You can compare the graphical histories of two revisions that do not belong to the same parent revision:

1. Select an assembly line in the structure tree and click Graphical History. Teamcenter displays the History dialog box.

2. Click the Revisions tab to display the Revision pane.

   Use the Revision pane to select two objects to compare. Select Revision List to view all the revisions associated with the parent assembly in a tree structure. Select Progression to view a graphical display of associated revisions.

3. In the Revision List view, select the revision you want to compare with a revision not related to this assembly.

4. Locate the other revision from your Home folder or by searching for the revision in the database. Copy it to the clipboard.

5. Paste this second revision into the Compare With box. This list always includes all the revisions associated with the selected parent assembly. It now lists all the associated revisions plus the disparate revision you inserted.

6. Continue with the compare process as described in Create related revision histories, beginning with step 5.

Create detail part histories

Use the History dialog box to generate a graphical history of revisions of detail parts. You can compare two revisions of the same detail part or two revisions of different parts. Teamcenter displays the differences graphically in the viewer and uses color coding to indicating the type of changes performed on the parts. You can also view the differences in a tree-format structure with color-coded icons indicating the types of changes performed upon them.

Use a standard view, tricolor mapping, or distance mapping to view the changes between detail parts.
Comparing product structures

<table>
<thead>
<tr>
<th>Use this view</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard view</td>
<td>Display two detail parts side-by-side. The part colors correspond to the current legend settings.</td>
</tr>
<tr>
<td>Tricolor mapping</td>
<td>Display the two detail parts at the same position. Click the Preferences button to set the color of common material and of each of the two part group materials.</td>
</tr>
<tr>
<td>Distance mapping</td>
<td>Display the distance comparisons between two detail parts at the same position. Click the Preferences button to set the base color and the colors of the high and low values.</td>
</tr>
</tbody>
</table>

To create a comparison between two revisions of a detail part:

1. Select the concerned part in the structure tree and click Graphical History.

   Teamcenter displays the History dialog box containing similar information as for assemblies, except that the configuration switches (BOM view type and revision rule) are not available.

2. From the Compare With list, select a different revision of the same part or a different part.

3. Click the Graphical Compare tab to view the differences between the two part revisions.

   Only one control slider is provided and you can use it to move between the affected and problem revision of the detail part.

Viewing supersedure

Supersedure allows you to view a graphical representation of the replacement history of a given occurrence in the product structure.

Parts and assemblies are often added to and deleted from a product structure during its construction or modification. Some of these additions and deletions can be grouped together as a replacement action. For example, two added parts may replace the form and functionality of one canceled component, making a replacement.

To view and manage the supersedure of the selected line, click the Show/hide data pane button, and then click the Supersedure tab.

The supersedure tree shows the history of such replacements graphically, starting from the selected part.

**Note** Before you can view the supersedure of a component, you must create a supersedure that defines the replacement. You cannot create a supersedure in Structure Manager.

For information about how to create a supersedure, see the Change Manager Guide.

Using the supersedure toolbar

The following buttons are available on the toolbar on the Supersedure pane.
### Button | Button title | Description
--- | --- | ---
| ![Expand screen] | Expand screen | Expands the supersedure pane to full size, or decreases the full-sized screen to partial size. |
| ![New node] | New node | Displays a different supersedure for the selected component in the context of a different parent assembly. Select the alternate parent assembly from the **Where Used** search pane below the supersedure layout. |
| ![Automatic/Manual Layout] | Automatic/Manual Layout | When activate, changes supersedure layout mode to *automatic*. Teamcenter lays out nodes are automatically and ensures that no intersections between the nodes and the supersedures occur. When inactivate, changes supersedure layout mode to *manual*. You can lay out nodes manually. The supersedure’s current layout and motion mode is displayed in the status bar below the supersedure layout. |
| ![Single Node] | Single Node | When active, only a single node can be moved in the display. When inactivated, a supersedure can be moved. This button is active only when the **Automatic/Manual Layout** button is in manual mode. This button’s current mode is displayed in the status bar below the supersedure layout. |
| ![Watch Box] | Watch Box | Displays the item properties of the selected component in the **Item Properties** dialog box that opens when this button is clicked. If you select a change node, the watch box shows customer-defined properties of the associated supersedure component. |
| ![Note History] | Note History | Select a structure line and click this button to display the **Note Change History** dialog box. This dialog box displays the trail of note changes for the selected part or assembly. Structure change records for occurrence note changes are created when changes to the structure are saved. To permit this, set the **ECM_note_types_to_track** preference. |
Comparing product structures

<table>
<thead>
<tr>
<th>Button</th>
<th>Button title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Variant History" /></td>
<td>Variant History</td>
<td>Displays the Variant Condition Change History dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Graphical Supersedure" /></td>
<td>Graphical Supersedure</td>
<td>Displays the Graphical Supersedure dialog box.</td>
</tr>
</tbody>
</table>

Using supersedure lists in the Supersedure pane

<table>
<thead>
<tr>
<th>Supersedure list</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product List</td>
<td>Select a product from the list to generate a new supersedure for the selected part in the context of the selected product.</td>
</tr>
<tr>
<td>Layout</td>
<td>Displays search results in horizontal, vertical or tree layout.</td>
</tr>
<tr>
<td>Find</td>
<td>Performs a query for the part or assembly shown in the text box.</td>
</tr>
<tr>
<td>Where-Used Rule</td>
<td>Performs a where-used search on the selected part or assembly. For information on performing where-used searches, see Configuring for where-used searches.</td>
</tr>
<tr>
<td>Where-Used Depth</td>
<td>Sets the depth of the where-used search. One level searches immediate parent assemblies. All levels searches all assemblies up to the top-level product. Top level searches the final product. For more information, see Configuring for where-used searches.</td>
</tr>
</tbody>
</table>

Interpreting supersedure symbols

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Symbol title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Component Node" /></td>
<td>Component Node</td>
<td>Displays the item name corresponding to the change.</td>
</tr>
<tr>
<td><img src="image" alt="Selected Component Node" /></td>
<td>Selected Component Node</td>
<td>Displays the currently selected component node.</td>
</tr>
<tr>
<td><img src="image" alt="Quantity Node" /></td>
<td>Quantity Node</td>
<td>Shows supersedures created between quantity changes. These are displayed in the Supersedure pane.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In this example, EC01\A changed the quantity of part C from 1 to 3.</td>
</tr>
</tbody>
</table>
## Symbol Table

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Symbol title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Change Node" /></td>
<td>Change Node</td>
<td>Connects the component nodes and displays change information. Component nodes listed above the change occurred before the change was created. Component nodes listed below the change occurred after the change was created. A tool tip lists the parent structure and the component’s effectivity when you place the cursor over the node.</td>
</tr>
<tr>
<td><img src="image" alt="Pure Add" /></td>
<td>Pure Add</td>
<td>Shows the supersedure trail associated with part C, as displayed in the <strong>Supersedure</strong> pane. In this example, part C resulted from EC01/A.</td>
</tr>
<tr>
<td><img src="image" alt="Pure Cancel" /></td>
<td>Pure Cancel</td>
<td>Shows the supersedure trail associated with part C, as displayed in the <strong>Supersedure</strong> pane. In this example, part C resulted from EC0/A, but was canceled by EC03/A.</td>
</tr>
<tr>
<td><img src="image" alt="Selected Change Node" /></td>
<td>Selected Change Node</td>
<td>If red, the selected part or assembly is the currently selected change node.</td>
</tr>
<tr>
<td><img src="image" alt="Transfer Change Node" /></td>
<td>Transfer Change Node</td>
<td>Shows a T to indicate the change node is a transfer supersedure. Transfer supersedures involve the transfer of a part from one level of an assembly to another level of the same assembly.</td>
</tr>
<tr>
<td><img src="image" alt="Delivered Product Change" /></td>
<td>Delivered Product Change</td>
<td>Displays if the supersedure was created as part of a delivered product change. For this type of supersedure, the arrow line appears in red.</td>
</tr>
<tr>
<td><img src="image" alt="Duplicate Supersedure Flag" /></td>
<td>Duplicate Supersedure Flag</td>
<td>Displays if the selected component has a supersedure that is already displayed. The supersedure does not continue from this point as this would produce an infinite loop.</td>
</tr>
<tr>
<td><img src="image" alt="Additional Supersedures" /></td>
<td>Additional Supersedures</td>
<td>Displays if there are additional supersedures in the history to display.</td>
</tr>
<tr>
<td><img src="image" alt="Latest Supersedure" /></td>
<td>Latest Supersedure</td>
<td>Displays if there are no more additional supersedures in the history to display.</td>
</tr>
<tr>
<td><img src="image" alt="Move" /></td>
<td>Move</td>
<td>Green highlights a part or assembly that has moved. You cannot create supersedure for move changes.</td>
</tr>
</tbody>
</table>
**Symbol** | **Symbol title** | **Description**
--- | --- | ---
![](Symbol) | Reshape | Green highlights a part or assembly in the structure that is reshaped. You cannot create supersedure for reshape changes.

**Managing supersedure**

The supersedure tree starts from a selected part and shows the visual path of the subsequent superseded parts. The supersedure tree also shows related product information.

Navigate through the supersedure tree by double-clicking component nodes. Clicking a node expands it to show the next supersedure in the sequence.

You can use the supersedure tree to:

- **Browse the supersedure of the selected part.**
- **Create a new supersedure based on a different parent assembly.**
- **Create a new supersedure based on a different top-level product.**

**Browse supersedure**

The supersedure tree graphically displays the replacement history of the selected part or assembly using rectangular and oval elements to represent components and changes.

Only part numbers are displayed in supersedure, not revision numbers. You cannot create supersedures for revisions; they are assumed to be interchangeable in form, fit, and function.

To view the supersedure of a part or assembly:

1. In the product structure, select a line that represents a part or assembly that has an associated supersedure.

2. Click **Show/Hide Data Panel**.

   The window divides to show the structure tree on the left, and the data pane on the right.

3. In the data pane, click the **Supersedure** tab.

   Teamcenter opens the supersedure view containing the replacement history of the selected component in the context of its parent assembly. It generates the supersedure for the item you specify in the **Where-Used** pane located below the **Supersedure** pane.

4. Optionally, place the cursor over a change to show a tool tip that lists the parent assembly item revision and effectivity of the selected change.

   **Note** A part may be used in more than one assembly and each assembly has its own supersedures. Thus, a part may have more than one supersedure trail.
Chapter 10  Comparing product structures

Display a different supersedure in the context of a parent assembly

An item revision may have several supersedure trails, if it has occurrences in different assemblies. The Supersedure pane shows the history of the selected part or assembly in the context of the current assembly. To see the supersedure of the selected part or assembly in another parent assembly, you must generate a new supersedure with respect to the other assembly.

1. Minimize the Supersedure pane, if necessary, by clicking Expand.

2. Perform a where-used search in the search pane below the supersedure display. For information on performing where-used searches, see Making where-used searches.

3. Select the required different parent assembly in the graphical display of the search results and click New Node.

Structure Manager displays a new supersedure in the context of the newly selected parent assembly.

Create a new supersedure with respect to a different top-level product

A part or assembly may be used in more than one top-level product. Such a part or assembly may eventually be removed from one or more of the top-level products as the products move through their life cycles. When you define the deletion of a part or assembly in a supersedure, the Supersedure pane shows the component in red with a line through the label. The red line indicates the part or assembly is no longer used anywhere in the selected top-level product.

If you select a new top-level product from the product list, Teamcenter creates a new supersedure of the selected part or assembly with respect to the newly selected product.

Note  By default, the capability to show redlined items is disabled. To display redlined relations, go to the \java\com\teamcenter\rac\pse\genealogy\genealogy_user.properties file and set useProductList.FLAG=true.

To show a different supersedure of the selected part or assembly in the context of a different top-level product:

1. Select the part or assembly whose inclusion in various top-level products you want to view.

2. From the product list, select a different product.

Teamcenter shows a new supersedure in the context of the newly selected top-level product. The new supersedure starts with the first supersedure. Any component that has a never-used relationship in the context of the selected top-level product is shown in red and underlined.
Create a transfer supersedure

Transfer supersedures are generated when a component is moved from one assembly to another. Transfer supersedures require at least two affected items and two problem items, one for each assembly level.

When a transfer supersedure is viewed in the supersedure window, Transfer shows next to the supersedure. A transfer supersedure is viewed in the Supersedure pane, as shown.

1. Delete a Problem component from a subassembly:
   a. Send the pertinent change to Change Manager.
   b. Select the desired subassembly item revision from the Affected Item folder.
   c. Right-click the item revision, choose Send To, and send the item revision to Structure Manager.
      Note: There must be at least two item revisions in the Affected Item folder, and one item revision must belong to a subassembly of the other.
   d. Structure Manager opens and the selected subassembly is displayed.
   e. Select the component you want to delete. Click Delete Line.
   f. Click Save.
   g. Structure Manager saves the assembly, then displays the supersedures view.
      • The left pane displays the contents of the Affected Item folder.
      • The right pane displays the contents of the problem items folder.
      • The file name and revision rule of each item revision are displayed at the top of the respective panes.
      • The bottom pane displays the supersedure once it is created.
      • Items that are deleted from the affected item revision display in red in the right pane. In other words, components of the problem item revision (displayed in the right pane) that are deleted from the solution item revision display in red.

2. Transfer the component to a parent assembly:
   a. Return to Change Manager and select the parent assembly from the Affected Item folder. Right-click the item revision and choose Send To. Send the item revision to Structure Manager.
   b. In Structure Manager, select the level of the assembly where you want the component added.
Chapter 10  Comparing product structures

c. Select the component you want to add and click **Copy**. You can select this item revision from My Teamcenter.

d. Return to Structure Manager and click **Paste**.

e. Click **Save**.

Structure Manager displays the split window. The left pane displays the contents of the **Affected Item** folder. Items that are added to the affected item revision display in blue in the left pane.

f. Select the appropriate subcomponent assembly from the **Sub-Assembly** list below the right pane. The assembly is displayed in the right pane. Items that are deleted from the assembly are shown in red.

g. Click **Transfer**.

A transfer supersedure is created.

**Commonly encountered supersedure examples**

<table>
<thead>
<tr>
<th>Description</th>
<th>Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Regular supersedure</td>
<td><img src="image" alt="Diagram" /></td>
</tr>
</tbody>
</table>
Description | Image
---|---
Quantity supersedure, from 1 to 2

Regular supersedure plus pure add

Pure add with quantity
**Chapter 10  Comparing product structures**

<table>
<thead>
<tr>
<th>Description</th>
<th>Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add supersedure plus pure cancel</td>
<td><img src="image1.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Regular supersedure plus pure cancel</td>
<td><img src="image2.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Quantity supersedure</td>
<td><img src="image3.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>
View a supersedure in Structure Manager

Viewing a supersedure displays the additions and deletions to the selected affected item.

1. Right-click an affected item in Change Manager and choose Send To. Send the item revision to Structure Manager.
   
   **Note** If Structure Manager displays a Do you wish to update BOM Changes (needed only if structure is edited outside change control)? message, click Yes. This ensures you can manage the BOM changes that are now being managed in Structure Manager, outside of change control.

2. Click Supersedures Environment.

   The supersedures folder is displayed in the supersedures view in the bottom pane. The Adds folder displays additions to the assembly with a� to the left of the component name.

   The Cancels folder displays deletions from the assembly with a� to the left of the component name.

3. View the supersedure of the same affected item with a different problem item by selecting a different problem item from the list below the right pane. This list displays any other problem items that have been used to create a supersedure with the selected affected item revision.

4. A new supersedure appears, displaying the additions and deletions of the new supersedure.

Create a structure change

In Structure Manager, perform the necessary modifications (additions, deletions, moves, reshapes) by adding and deleting structure lines, then click Save.

**Note** You must have write access to the assembly.

Change management compares the selected affected item with the associated problem item in the change by displaying two panes. The left pane displays modifications to the affected item assembly, the right pane displays modifications from the problem item assembly.

By default, additions are blue, deletions are red, moves are green, reshapes are light blue, quantity changes are orange, and so forth. Click Icons/Colors Legend to view the currently defined color for each type of comparison. You can select the comparison colors by choosing Edit→Options→Change Management→Bom Tracking and changing the colors.

If the change contains more than one problem item, change management applies the following rules to select the appropriate problem item:

1. Choose the item revision with the same ID as the selected affected item.

2. If there is no item revision with the same ID, or if there are multiple revisions of the item revision, you are prompted to select one from those listed in the Problem Items folder.
Chapter 10  Comparing product structures

Note  If the selected assembly is a new part, or else not an affected item (for example, you are only making structure change modifications, not creating a supersedure), choose No Problem Item at the prompt. BOM Change objects of the type Add are created for every component.

In the example, the left pane displays the additions to Assy100/B, and the right pane displays the deletions from Assy100/A, as shown.

<table>
<thead>
<tr>
<th>Left pane: Additions to Assy100/B</th>
<th>Right pane: Deletions from Assy100/A</th>
</tr>
</thead>
<tbody>
<tr>
<td>P10</td>
<td>P10</td>
</tr>
<tr>
<td>P21</td>
<td>P11</td>
</tr>
<tr>
<td>P15</td>
<td>P15</td>
</tr>
<tr>
<td>P25</td>
<td>P18</td>
</tr>
<tr>
<td>Assy200/A</td>
<td>Assy200/A</td>
</tr>
<tr>
<td>P30</td>
<td>P30</td>
</tr>
<tr>
<td>P21</td>
<td>P11</td>
</tr>
</tbody>
</table>

This completes the first stage of making a supersedure—creating structure changes. These same changes can now be viewed from the BOM Changes view in Change Manager by selecting the affected item. The BOM Changes view displays the modifications (adds, cancels, moves, reshapes) with the specified buttons in the Icons/Colors Legend 🎨.

The convenience of viewing color-coded changes to a structure might be sufficient for your change management requirements and you have no need to create supersedures.

Note  When creating structure changes, the only changes processed are additions, deletions, moves, reshapes, and quantity changes. Changes to other component properties, for example, sequence number, occurrence notes) are not included. Variant components are treated as any other component.

Create a structure change using dynamic revision

You can use dynamic revision rules to track a particular change. A dynamic revision rule is dynamic when it requires end item, date, or unit number input to generate correct configured revisions.

When defining a dynamic revision rule to track a change, Teamcenter uses the revision rule set in the TC_config_rule_name preference.

Use the CM Base Configuration form to determine the product unit or date that causes the change to go into effect. This form can be attached during the definition of the change object using the Business Modeler IDE application. Alternatively, the form can be attached by using the ECM-create-base-revrule-form action handler at the beginning of the change process.

If a configuration form is attached to the change, the revision rules are modified according to the form’s effectivity entries.
Create the CM base configuration form

A structure change based on dynamic revision rules requires a change containing the CM Base Configuration form. This form must be manually created before the dynamic revision rule functionality can be used. Before the form can be created, the form type must be defined.

To create a new form, choose File→New→Form. The New Form wizard appears to create the CM Base Configuration form.

Use the following information to create the form and class in step 1 of the New Form wizard:

- **Form Name:** CM Base Configuration
- **Class Name:** CMBaseRevRuleForm

Use the following information to complete the form fields in step 2 of the New Form wizard:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Size</th>
<th>Null</th>
</tr>
</thead>
<tbody>
<tr>
<td>end_item_str</td>
<td>String</td>
<td>128</td>
<td>Check</td>
</tr>
<tr>
<td>unit_no</td>
<td>Integer</td>
<td>N/A</td>
<td>Check</td>
</tr>
<tr>
<td>from_date</td>
<td>Date</td>
<td>N/A</td>
<td>Check</td>
</tr>
</tbody>
</table>

*Note* It is important that the form fields are defined exactly as shown in the table. If the definitions are altered the dynamic revision rules will not work correctly, and once the forms are created, they are not easily revised.

To complete the setup of the dynamic revision rule functionality, the ECM_base_revrule_relation relation type must be created.

Create the relation type using the Business Modeler IDE application.

For additional information, see the *Business Modeler IDE Guide*

Create a BOM change based on dynamic revision rules

A run-time override folder is created for the revision rule of the affected assembly that contains all the affected and solution revisions set in the first entry of the folder. This ensures that the revisions created as part of the change are displayed as the configured revision, irrespective of the effectivity entries.

Create structure quantity changes

A quantity change for an assembly or a component-level item revision must be based in the context of Change Manager.

1. Select a change revision master and send it to Change Manager, using the Send To command.

2. From Change Manager, select the item revision under the Affected Item folder and send it to Structure Manager, using the Send To command.

3. In Structure Manager, make sure the Quantity column is displayed.
4. If the Quantity column is not displayed:
   a. Choose Edit→Options.
   b. Select Structure Manager.
   c. Select Hidden Columns→Quantity to place it in the Shown Columns list.
   d. Once Quantity is in the Shown Columns list, click Up. or Down to position its display in the Structure Manager window columns.
   e. Click OK.
   f. When you have verified the Quantity column is displayed in Structure Manager, return to Change Manager.
   g. Select the same item revision and send it to Structure Manager again, using the Send To command.
      The Quantity column is displayed.
5. In Structure Manager, select the component for which the quantity needs to be changed.
6. Click the quantity in the selected structure line; the Quantity cell is outlined.
7. Type in the quantity, then press Enter.
8. Click Save. A split window displays the item(s) whose quantities have been changed in orange.
   The quantity for item revisions can also be viewed from the Properties information dialog box.

Attach a form to structure change

You can associate a form with a structure change from Change Manager. Once a form is associated with a structure change, it displays in the Form pane of the BOM Changes tab. Its fields can be used to indicate the purpose behind the change or other change information, such as comments, requirements and so forth.

Use the Form pane with the BOM Changes tab to associate a form to a selected structure change. The type of form associated with the structure change is determined via the ECM_bomchange_formtype preference. By default, this preference is set to associate the BOM Change form with structure changes. A system administrator can change this setting; one or more valid Teamcenter form types can be defined for this preference.

For additional information about this preference, see the Preferences and Environment Variables Reference.

To associate a form with a structure change:
1. In Change Manager, select the item revision whose structure changes you want to associate with a form.
2. Click the BOM Changes tab.
The item revision is displayed in the Revision tree of the BOM Changes tab.

3. Click + to expand the View folder.
   Any structure changes made to the item revision appear.

4. Select the structure change to which you want to associate a form.

5. Click Create.
   The form type specified in the ECM_bomchange_formtype preference displays in the Form pane.

6. Type the requested information into the available text boxes.

7. Click OK.
   The information is saved to the database and the form is associated with the structure change.

8. After the form has been associated with the structure change, click Display at any time to display the form and its contents.

9. Click Modify to modify the contents of the form.

10. Click Delete to delete a structure change form.

[Note] To create structure changes, the changes performed in Structure Manager must be made in the context of an change for a given assembly. The item revision must be selected from the Affected Item folder from within Change Manager and then sent to Structure Manager.

Create delivered change

A change, rework, or re-identification of an original part that is assigned Delivered status can be tracked from the original item revision by creating a parallel revision sequence using the Save As command. For example, a parallel revision sequence for the delivered assembly Assy100/C can be based on the site number of the customer to whom the product was delivered, for example, #3382. This allows the item revision to continue the revision progression in a parallel path.

You can perform a delivered product change and named design progression using the same change. The change process must be configured so that the delivered change is assigned special release status which is used to display delivered changes in supersedure.

1. In Change Manager, select the item revision you want to change.

2. Choose File→Save As.
   The Save Item Revision As dialog box is displayed.

3. Type the new Revision ID sequence. In the previous example, change the existing sequence of Assy100 to 3382.

4. Optionally, type a description of the change.
Chapter 10  \textit{Comparing product structures}

5. Click \textbf{OK}.

6. Click \textbf{Apply} to save the changes to the database and leave the dialog box open for additional changes.

\textbf{Creating a custom supersedure form}

You can associate a custom form with a supersedure and use the form to track supersedure attributes, such as effectivity or interchangeability. Your site must first assign a particular form to use with supersedures and enable the custom form functionality. Once the functionality has been enabled, you can associate the form with any supersedure. Only one form can be associated with supersedures.

\textbf{Enable custom forms}

To enable the custom form functionality, your administrator must change a change management default property so that the \textbf{Create Form} button \(\star\) appears in Structure Manager.

1. In the rich client root directory, find the\texttt{com\teamcenter\rac\ecmanagement\ecmanagement\_user.properties} file.

2. In this file, add the \texttt{enableSupercedureForm} property and ensure it is set to \texttt{true}.

3. Set the value of the \texttt{supercedureFormType} property to the name of the form type to use as the supersedure form.

The custom form button \(\star\) now appears in the vertical toolbar of the \textbf{Supersedure} pane. When a user completes the form, it is saved and associated with the selected supersedure by the \texttt{ECM\_supercedure\_to\_form\_reln} relation.

\textbf{Note}  If you later need to determine the form that is associated with a supersedure, query the value of the untyped reference run-time property \texttt{custom\_form\_tag} for the \textbf{Supersedure} type.

\textbf{Associate a custom form with a supersedure}

1. Select a supersedure and click the \textbf{Custom Form} button \(\star\). Teamcenter displays the Supersedure form.

   Your Teamcenter administrator selects the custom form associated with supersedures. For details, see \textit{Enable custom forms}.

2. Complete the form and click \textbf{Apply}.

   Teamcenter saves the form and associates it with the selected supersedure. Once the form is associated with a supersedure, it cannot be detached.

Once a form is created for a supersedure, it displays in the \textbf{Supersedure} pane whenever the supersedure is selected. You can modify the form at any time and save changes by clicking \textbf{Apply}.  

Track history of variant changes

Your Teamcenter administrator enables tracking of variant changes by setting the ECM_track_variant_condition_changes preference to ON. This preference is effective only if the ECM_set_genealogy preference is set to ON.

When you save changes to a structure containing variants, if this preference is ON for the current change type, Teamcenter tracks variant changes between the affected item and the problem item.

To view variant change history:

1. Open the data pane by clicking the Show/Hide Data Panel button on the toolbar.
2. On the data pane, click the Supersedure tab.
3. On the Supersedure pane, click the Variant Change History button. Teamcenter displays the Variant Change Details dialog box, showing variant conditions for the problem item and affected item of the chosen occurrence.
Chapter

11 Using item revision configuration

Using item revision configuration ........................................ 11-1
Understanding revision rules ............................................. 11-1
  Evaluating revision rules for read access .......................... 11-2
  Configuring precise assemblies ..................................... 11-3
  Elements of a revision configured product structure .......... 11-5
Configuring privileged and unprivileged users ....................... 11-6
Creating a revision rule .................................................. 11-6
  Create a rule entry .................................................. 11-6
  Modify a rule entry .................................................. 11-7
  Delete a rule entry .................................................. 11-7
  Edit the entries within a rule .................................... 11-7
  Modify the current revision rule .................................. 11-7
Defining revision rule entries ........................................... 11-8
  Defining a Working entry .......................................... 11-8
    Example of a Working entry .................................... 11-8
    Example of a Working entry with current user/group ....... 11-9
  Defining a Status entry ........................................... 11-9
    Example of status hierarchy in a revision rule ............. 11-10
    Example of effective date configuration in a revision rule 11-10
  Defining a Latest entry ........................................... 11-11
    Example of a revision rule with latest by creation date entry 11-11
  Defining a date entry ............................................. 11-12
  Defining a unit number entry ..................................... 11-12
  Defining an end item entry ...................................... 11-12
  Defining grouped entries ....................................... 11-13
    Example of revision rule with grouped entries ............ 11-13
Grouping revision rule entries by item type ......................... 11-13
  Creating Has Item Type entries ................................ 11-14
  Create and group revision rule entries by equal precedence 11-15
  Create and group Has Item Type revision rule entries .... 11-15
  Group existing revision rule entries by item type .......... 11-16
  Ungroup combinations of item type entries ................... 11-16
  Modify the item types in existing revision rule entries grouped by item type ......................................................... 11-16
Applying a revision rule to a Structure Manager window .......... 11-18
Set a revision rule ...................................................... 11-18
Set date/unit/end item ................................................. 11-18
Set an override folder .............................................. 11-19
Viewing revision rule information ............................... 11-20
Displaying and editing revision effectivity .................. 11-21
  Display revision effectivity data ............................ 11-21
  Edit revision effectivity data ............................... 11-21
  Reuse components in different products .................. 11-22
Releasing multiple item revisions in a single workflow process .... 11-23
Managing nested effectivity ................................. 11-23
  Configuring nested effectivity ............................ 11-24
  Creating a configuration item .............................. 11-24
  Creating a revision rule for nested effectivity .......... 11-25
  Create effectivity mapping on a configuration item .... 11-27
  Managing product generations ............................ 11-28
    Defining end item revisions ............................ 11-28
Using revision rules from My Teamcenter .................. 11-29
Managing occurrence to part relationships ................ 11-29
  Show occurrences of superseded item revision .......... 11-29
  Update precise occurrences of superseded item revision .... 11-29
Chapter

11 Using item revision configuration

Using item revision configuration

You can create and apply revision rules to select the appropriate revision of components in the product structure. A revision rule sets the criteria for selecting the revision, for example, whether to load working revisions or determining the released revisions that are loaded. This allows you to configure a structure as it was or will be on a particular date, for example, by utilizing effectivity data on each item revision (release status).

For additional information, see Understanding revision rules.

Users can use combinations of effectivity data to do the following:

- Create and set date and optional end item revision effectivity.
- Create and set unit number and end item revision effectivity.
- Share an existing effectivity between structures.
- Create and share a named effectivity.
- Protect an effectivity so that only certain users can apply it.

Both unit number and date ranges can be closed or open-ended. For open-ended ranges, UP and SO (stock out) values can be specified. Ranges can be discontinuous, for example, unit numbers 1, 5, 10-UP.

A privileged user (typically, the system administrator) creates the revision rules that are then made available to other users. Consequently, nontechnical users do not have to understand the full complexity of revision configuration but simply apply the appropriate revision rule.

Before creating or implementing item revision configuration, see Getting Started with Product Structure, which includes additional information.

Understanding revision rules

Item revision configuration allows you to create and apply revision rules that select the appropriate revision of parts and assemblies in the product structure. A revision rule:

- Selects working revisions and (optionally) specifies the owning user or group.
- Selects revisions by status (according to status precedence) or the latest revision with any status using release date.
• Optionally specifies the effectivity against which the revisions are configured. Effectivity may be specified by date or unit number.

**Note** Do not confuse the effectivity in the revision rule with the actual effectivity data visible on item revisions.

For more information, see *Displaying and editing revision effectivity*.

• Select revisions in a specified override folder.

• Select the latest revisions according to the revision ID by alphanumeric, numeric, or creation date order. This selection does not depend on whether revisions are working or released.

You define each of these criteria with a revision rule entry. A revision rule may contain any number of rule entries, each of which attempts to select a revision according to the specified criteria, for example, the status that the revision should have or the user or group that owns the revision.

Teamcenter evaluates rule entries in order of precedence until a revision is successfully configured. You can include some entries more than once to define an order of precedence, for example, **Status**:

Working (Owning Group = Project Y)
Has Status (Production, Effective Date)
Has Status (Pre-Production, Effective Date)

You can modify the order of the rule entries to change the precedence Teamcenter uses when evaluating the revision rule. Certain rule entries can also be grouped so they are evaluated with equal precedence.

For more information, see *Defining grouped entries*.

Teamcenter always enforces a revision rule when you open a structure in a Structure Manager window.

### Evaluating revision rules for read access

By default, Teamcenter applies a revision rule to configure a product structure before it applies any rule filter that is set in Access Manager. As a result, if a higher revision rule entry configures a particular revision of an item and the user has no read access to this revision, the structure line in Structure Manager shows an **UNREADABLE** stub entry.

You can optionally configure Teamcenter to continue evaluation when expanding the structure against the revision rule until it encounters a revision of the item to which the user has read access. However, if it finds no accessible item revision for any of the entries, it shows an **UNREADABLE** stub, as before. To allow Teamcenter to continue revision rule evaluation by making read access checks in this way, set the **PSE_check_read_access_for_Rev_Rule_entry** preference to **TRUE**. Structure Manager shows the next item revision to which you have access. If this preference is set to **FALSE**, evaluation stops when the first inaccessible configured item revision is encountered.

You can use any of the following revision rule entries to show configured item revisions to which the user has read access:

• **Latest Working**
• Status

• Latest Revision

• Override

You can include more than one of these entries in the same revision rule to find accessible item revisions.

This behavior applies only to imprecise structures and does not affect the evaluation of precise structures. Similarly, there is no effect if you configure a structure by unit number or date effectivity.

Configuring precise assemblies

If an assembly is precise and the revision rule contains a precise entry, the assembly is configured according to that entry. However, if the assembly is precise and the revision rule does not contain a precise entry, the assembly is treated as imprecise.

If the assembly is treated as imprecise:

• If a revision is configured by a Working revision rule entry that is not accessible to the user, Structure Manager continues to evaluate the next matching readable revision. This behavior is not affected by the presence or value of the PSE_check_read_access_for_Rev_Rule_entry preference.

• If a revision is configured by any other (imprecise) revision rule entry that is not accessible to the user, and the PSE_check_read_access_for_Rev_Rule_entry preference is not present or is FALSE, Structure Manager displays <UNREADABLE>. If the preference is TRUE, Structure Manager continues to evaluate the next matching readable revision.

For example:

• You have an item called Part1 with two revisions, Part1/A is Working and Part1/B is also Working.

A precise assembly Asm is created containing Part1/B. That is:

\[
\text{Asm} \\
|---\text{Part1/B}
\]

If User2 is denied read access to Part1/B and opens Asm in Structure Manager with an AnyStatus;Working revision rule, the system performs the following evaluation:

1. The AnyStatus entry does not configure any revisions.

2. The Working entry configures in Part1/B but access rules make this revision <UNREADABLE>.

3. Regardless of the setting of the PSE_check_read_access_for_Rev_Rule_entry preference, evaluation continues. The next revision is Part1/A, and access rules do not deny access to it, so the final result is Part1/A.

If User2 then changes the revision rule to Latest by Alpha Revision Order, the system performs the following evaluation:
1. The **Latest by Alpha Revision** entry configures in Part1/B but access rules make this revision `<UNREADABLE>`.

2. The system continues evaluation only if the `PSE_check_read_access_for_Rev_Rule_entry` preference is **TRUE**. The next revision is Part1/A, and access rules do not deny access to it, so the final result is Part1/A.

- You have an item called Part1 with three revisions, Part1/A is released with a **TcReleased** status, Part1/B is released with a **TcBaseline** status, and Part1/C is released with a **TcReleased** status.

  A precise assembly **Asm** is created with Part1/C. That is:

  ```
  Asm
  |--Part1/C
  ```

  If User2 is denied read access for the **TcReleased** status and opens **Asm** in Structure Manager with a **AnyStatus;Working** revision rule, the system performs the following evaluation:

  1. The **AnyStatus** entry configures in Part1/C but access rules make this revision `<UNREADABLE>`.

  2. The system continues evaluation only if the `PSE_check_read_access_for_Rev_Rule_entry` preference is **TRUE**. The next revision with status is Part1/B, and access rules do not deny access, so the final result is Part1/B.

- You have an item called Part1 with two revisions, Part1/A is released with a **TcReleased** status and Part1/B is working.

  A precise assembly **Asm** is created with Part1/A. That is:

  ```
  Asm
  |--Part1/A
  ```

  If User2 is denied read access for status **TcReleased** and opens **Asm** in Structure Manager with a **AnyStatus;Working** revision rule, the system performs the following evaluation:

  1. The **AnyStatus** entry configures in Part1/A but access rules make this revision `<UNREADABLE>`.

  2. The system continues evaluation only if the `PSE_check_read_access_for_Rev_Rule_entry` preference is **TRUE**. Because no other revisions have status, the next rule entry of **Working** configures in Part1/B. Access rules do not deny access, so the final result is Part1/B.

  If User2 changes the revision rule to **Latest Working**, the system performs the following evaluation:

  1. The **LatestWorking** rule contains a **Precise** entry, that configures the revision saved with the assembly, namely, Part1/A.

  2. Because access rules make Part1/A unreadable for User2, the final result is `<UNREADABLE>`.
The PSE_check_read_access_for_Rev_Rule_entry preference does not affect the result because the structure and the revision rule are precise.

Elements of a revision configured product structure

The following elements may appear in a product structure that is controlled by revision configuration.

<table>
<thead>
<tr>
<th>Element</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baseline</td>
<td>A copy of the currently configured structure at the time the baseline was created. Baselining configures a completely released structure and thereby guarantees that the models are always the same as when the baseline was created.</td>
</tr>
<tr>
<td>End item</td>
<td>A product, system, or module with respect to which you can configure the structure by effectivity. For example, you can configure the structure of unit number 110 in product X400, where X400 is the end item. For more information about end items, see Displaying and editing revision effectivity.</td>
</tr>
<tr>
<td>End item revision</td>
<td>The configured revision for the selected end item.</td>
</tr>
<tr>
<td>Imprecise assembly</td>
<td>A single-level assembly that has items (not item revisions) as the components. Teamcenter determines the applicable revision from the revision rule settings.</td>
</tr>
<tr>
<td>Override list</td>
<td>A mechanism that allows a user to override the revision that would normally be loaded by the revision rule. The user places item revisions in a workspace folder, and the revision rule is overridden by the rule specified in the override list. The folder provided for the override list may contain multiple nested folders. The item revision in the topmost folder is configured.</td>
</tr>
<tr>
<td>Precise assembly</td>
<td>A single-level assembly that has specific item revisions as the components. When Teamcenter applies the revision rule, the precisely specified item revision is configured by a precise entry in a revision rule.</td>
</tr>
<tr>
<td>Release status</td>
<td>An object assigned to an item revision after it is successfully released. Item revisions can be configured according to their status. The status may optionally contain effectivity data for revision configuration (not occurrence effectivity configuration).</td>
</tr>
<tr>
<td>Revision rule</td>
<td>The parameters set by a user that determine which revision of an item at a particular time. You can also save a revision rule as a workspace object.</td>
</tr>
<tr>
<td>Rule entry</td>
<td>A revision rule comprises an ordered list of rule entries. Each type of rule entry is concerned with a particular type of configuration.</td>
</tr>
</tbody>
</table>
Chapter 11  Using item revision configuration

<table>
<thead>
<tr>
<th>Element</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snapshot</td>
<td>You can save a configured product structure as a snapshot. The snapshot folder contains all revisions of the structure, and you can use it to redisplay a saved structure at any time.</td>
</tr>
<tr>
<td>Working revision</td>
<td>An unreleased version of the structure. Any user with write privileges can freely change this revision. Teamcenter maintains no record of intermediate states of a working revision.</td>
</tr>
</tbody>
</table>

Configuring privileged and unprivileged users

User privileges determine if a user can create and modify revision rules, or only apply rules created by others. Specifically, privileged users have access to all the revision rule menu commands, while unprivileged users have access only to a subset of the commands. Consequently, unprivileged users cannot create or delete revision rules, and have only limited ability to modify revision rules without saving the changes.

Your Teamcenter administrator can restrict user access to these menu commands. Use the Command Suppression application to determine those roles that are privileged and so restrict access to the Revision Rules menu commands.

For more details, see Administering the product structure.

Creating a revision rule

If you are a privileged user, you can use two dialog boxes to create or edit a revision rule:

- The Modify Current Rule dialog box to create temporary revision rules.
- The Create/Edit Rules dialog box to create persistent revision rules.

Both dialog boxes contain the Revision Rule Editor, which comprises two main panes.

- The upper pane lists all the entries in the rule, with buttons you can use to manipulate the entries.
- The lower pane allows you to create or edit an entry, and add it into the rule.

Create a rule entry

1. In the Revision Rule Editor, select the type of entry you want to create. By default, the combination box shows Working. Teamcenter updates the entry boxes appropriately.

2. Enter values into the boxes and click one of the following buttons:
   - Click Append to add your entry at the end of the list of rule entries.
   - Click Insert to add your entry above the selected entry.
• Click **Replace** to replace the selected entry with your entry.

Syntax for revision rule entries is given in *Defining revision rule entries*.

**Modify a rule entry**

1. Select an entry in the list of entries.

2. Click **Copy**. Teamcenter copies the entry into the editing area and displays the appropriate entry type and boxes.

3. Edit the values of the entry and click **Replace** with the original entry still selected. Teamcenter replaces the old entry with the new entry.

Syntax for revision rule entries is given in *Defining revision rule entries*.

**Delete a rule entry**

1. Select an entry in the list of entries.

2. Click **Remove** and Teamcenter removes it from the rule.

**Edit the entries within a rule**

You can use the arrow buttons to move entries up or down within the rule.

You can use the **Group/Ungroup** command to add entries to a group or remove them from a group.

**Modify the current revision rule**

Users can make modifications to the window’s current revision rule. This does not affect the saved revision rule, but instead, Teamcenter creates a copy of the rule, modifies it as specified, and applies it to the window. To modify the current rule, choose **Tools**—**Revision Rule**—**Modify Current**; Teamcenter displays the **Modify Current Rule** dialog box.

Use the **Modify Current Rule** dialog box to modify the current rule with the Revision Rule Editor. The editor contains a copy of the saved revision rule that is applied to the product structure window. The name of the copied rule is the name of the original rule with *(Modified)* appended. You cannot edit the Name box, but you can change the Description box.

After you edit the revision rule, apply your changes by clicking **OK** or **Apply**.

If you have write access to the original rule, you can save your changes back to the original rule by clicking **Save**.

Syntax for revision rule entries is given in *Defining revision rule entries*. 
Defining revision rule entries

A revision rule is made up of a sequential list of entries. Evaluation of the rule involves evaluating each of the entries, in order, until a configured revision of the item is successfully obtained. A rule may be made up of entries of the following types.

Defining a Working entry

Use a working entry to select working item revisions; that is, those items revisions without any release status. By default, Teamcenter selects the latest working revision of the item according to the date it was created. You can select a more specific revision with one of the following settings:

- **Owning user**
  
  If you specify an owning user within a working entry, Teamcenter configures the latest revision owned by the specified user, if there is such a revision. You can also set the owning user to **Current**, and Teamcenter configures the latest revision owned by the current user.

- **Owning group**
  
  If you specify an owning group within a working entry, Teamcenter configures the latest revision owned by the specified group, if there is such a revision. You can also set the owning group to **Current**, and Teamcenter configures the latest revision owned by the current user's group.

**Tip**

There may be more than one working entry within a revision rule. For example, a rule may configure the current user's working revision and, if none is found, configure the current group's working revision instead. If a user changes group, it is necessary to reapply the revision rule to configure the appropriate revisions for the new group.

However, in many circumstances, it is good practice to limit the number of working revisions, typically to a single revision. Do this in Business Modeler IDE, as follows:

1. Right-click the item revision business object on which you want to limit the working revisions and choose **Open**.

2. Click the **Operations** tab, open the **Operations** folder, scroll down to the bottom of the **Operations** folder, and open the **Legacy Operations** folder.

3. Select the **ITEM_copy_rev** operation.

4. In the **Pre-Condition** pane, choose **Add** and select **checkLatestReleased**.

5. Add an argument that specifies the number of working revisions allowed.

6. Save and deploy the modified configuration.

For more information, see the **Business Modeler IDE Guide**

**Example of a Working entry**

An example of **Working** entries in a revision rule follows:
Assume you configure the following two items with this rule:

Part1/A : Status = Production
Part1/B : Working, Owning User = John, Owning Group = Project X
Part1/C : Working, Owning User = Jane, Owning Group = Project X
Part2/A : Status = Production
Part2/B : Working, Owning User = Jane, Owning Group = Project X

Teamcenter configures Revision B of Part 1, because it is owned by John. The owning groups are not relevant.

Teamcenter configures Revision B of Part 2, because it is owned by Project X. There is no revision owned by John.

**Note** If John or by Project X owned more than one revision, Teamcenter would configure the latest created of the matching revisions.

**Example of a Working entry with current user/group**

An example of a current user/group entry in a revision rule follows:

Working( Owning User = Current )

Assume you configure the following item with this rule:

Part1/A : Status = Production
Part1/B : Working, Owning User = John, Owning Group = Project Y
Part1/C : Working, Owning User = Jane, Owning Group = Project X
Part1/D : Working, Owning User = Jane, Owning Group = Project Y

This rule configures a revision that depends on the identity of the user logged into Teamcenter.

- If Jane is logged in, Teamcenter configures Revision D.
- If John is logged in, Teamcenter configures Revision B.

Assume you use the following rule to configure the same item:

Working( Owning Group = Current )

The revision configured by this rule is dependent on which group the user is logged into Teamcenter.

This rule configures a revision that depends on the group in which the user logged into Teamcenter:

- If the user is logged into Group Project X, Teamcenter configures Revision C.
- If the user is logged into Group Project Y, Teamcenter configures Revision D.

**Defining a Status entry**

Use a status entry to select item revisions that are released with a particular status. The following settings are available for status entries:

- Any release status

Teamcenter configures the latest item revision with a released status, regardless of the actual status.
Chapter 11  Using item revision configuration

- Selected status

  Teamcenter configures the latest item revision with a selected status type. This setting allows you to configure a structure that contains only item revisions with a specified status.

  For details about configuring release statuses for your site, see the Business Modeler IDE Guide.

- Released date

  Teamcenter selects the latest item revision according to the date the revision was released (that is, the date the particular status was added).

- Effective date

  Teamcenter selects the latest item revision according to effectivity dates defined on the release status. Privileged users define effective dates as described in Displaying and editing revision effectivity.

- Effective unit number

  Teamcenter selects the latest item revision according to unit numbers defined on the release status.

Example of status hierarchy in a revision rule

The following example shows how to use status hierarchy in a revision rule:

```
Has Status( Production, Configured by Date Released )
Has Status( Pre-Production, Configured by Date Released )
```

Assume you configure the following three items with this rule (dates are release dates):

```
Part1/A : Status = Pre-Production [1-Apr-2007]
Part1/B : Status = Production [1-Jun-2007]
Part1/C : Status = Production [1-Aug-2007]
Part1/D : Working
Part2/A : Status = Pre-Production [1-May-2007]
Part2/B : Status = Production [1-Jul-2007]
Part2/C : Status = Pre-Production [1-Sep-2007]
Part3/A : Status = Pre-Production [1-Aug-2007]
Part3/B : Working
```

Teamcenter configures Revision C of Part 1, because it is the most recently released revision with Production status.

It configures Revision B of Part 2, because it is also the most recently released revision with Production status. The later preproduction revision is not configured.

It configures Revision A of Part 3. There is no revision with Production status, so it configures the latest Pre-Production revision.

**Note**  The rule in this example creates a status hierarchy. If possible, the rule configures a Production release, but if one is not available, it configures a Pre-Production release.

Example of effective date configuration in a revision rule

The following example shows effective date configuration in a revision rule:
Has Status( Production, Configured by Effective Date )

Assume you configure the following item with this rule (dates are effective date ranges):

- Part1/A : Status = Production [1-Apr-2007 to ... ]
- Part1/B : Status = Production [1-Aug-2007 to ... ]
- Part1/C : Status = Production [1-Nov-2008 to ... ]

If today's date is sometime in 2007, Teamcenter configures Revision B, because it has Production status and also has the later effective start date of the two revisions effective in 2007.

Defining a Latest entry

You can specify a latest entry to select the latest item revisions regardless of whether they are released. For this entry, Teamcenter does not differentiate between working revisions and revisions with status. The following settings are available for Latest entries:

- Creation date
  Teamcenter selects the latest item revision according to the date the revision was created.

- Alphanumeric revision ID
  Teamcenter selects the latest item revision in alphanumeric order by revision ID. It selects any numeric revision IDs in numeric order by their first digit, for example, 1, 10, 2, 21, and so on. It selects any alphabetic revision IDs in alphabetic order, for example, a, aa, b, and z.

- Numeric revision ID
  Teamcenter selects the latest item revision in numeric order by revision ID. It does not configure revisions with nonnumeric IDs.

- Alpha and number revision ID
  Teamcenter selects the latest item revision first in order of any initial alphabetic characters, then any following numeric digits, for example, a, a2, a5, b2, b23, aa12, aa123, bc22, aaa0, and aab.

Example of a revision rule with latest by creation date entry

The following example shows a revision rule that configures with the latest by creation date:

`Latest( Creation Date )`

If you configure the following item with this rule (dates are creation dates):

- Part1/A : Status = Production [1-Apr-2006]

Teamcenter configures Revision B because it was created later than revision A. It is not relevant if the revision is working or has status.
Defining a date entry

Use a date entry to specify a date to configure the structure against. You can only use this entry type with other entries. These types of entry find the latest entry before the specified date:

- Status entry – released date or effective date
- Latest entry – creation date

You can set the date in a date entry to **Today**, and Teamcenter evaluates the configuration criteria against the current date and time.

You cannot configure working revisions against a date in the past. Teamcenter does not maintain information about the revisions that were in a working state at a particular time in the past.

**Note** If no date entry is present in a revision rule, Teamcenter evaluates the date by default to today’s date.

You can qualify date effectivity with an **end item entry**.

Defining a unit number entry

A unit number entry specifies a unit number to match when configuring item revisions with status using unit number effectivity. You can only use this entry type with other entries. If no unit number entry is present in a revision rule, Teamcenter configures all status entries that configure by effective unit number.

Typically, a unit number is a property of the end product or a major module of a product. As Teamcenter may manage many units, you typically qualify a unit number entry with an **end item entry**.

Defining an end item entry

Use an end item entry to qualify the unit number or the effective date specified in the revision rule.

The unit number you specify refers to a unit or serial number of the item identified by the end item entry. This item is typically the end product, a major module, or subsystem of a product, if it has its own unit number serialization.

You can also use an end item to qualify date effectivity, so you can make an item revision effective in different products at different times.

If you put an end item entry in a rule, you force the application of the end item in all uses of the rule. If you omit the end item entry, users can specify an end item to configure the structure at runtime by choosing **Tools→Revision Rule→Set Date/Unit/End Item**. You can also add a button to the toolbar to implement the **Set Date/Unit/End Item** menu command.

Teamcenter interprets revisions with date effectivity and no qualifying end item as effective for all possible end items. Therefore, when Teamcenter processes a rule with date effectivity and an end item entry, it considers only revisions having date effectivity with no end item, and those having date effectivity qualified by the end item specified in the rule. Only those revisions with date effectivity qualified by a
different end item are excluded. If the rule does not specify an end item, Teamcenter only considers revisions with date effectivity and no end item qualification.

**Defining grouped entries**

You can group status entries and working entries for equal precedence. In the case of status entries, you can group two or more different statuses with equal precedence.

In the case of working entries, you can group different owners with equal precedence. You can also group entries according to item type.

Teamcenter does not allow you to group different types of entries. Consequently, the following are not valid combinations for grouping:

- Latest
  Has Status, ConfiguredBy ReleaseDate

- Has Status ( TCM Released ), Configured By EffectiveDate
  Has Status ( Pending ), Configured by ReleaseDate

**Example of revision rule with grouped entries**

An example of a revision rule that uses grouped entries to obtain equal precedence of status types follows:

```
[ Has Status( Production, Configured by Date Released )
  Has Status( Pre-Production, Configured by Date Released ) ]
```

Assume you configure the following three items with this rule (dates are release dates)

**Part1/A** : Status = Pre-Production [1-Apr-2007]
**Part1/B** : Status = Production [1-Jun-2007]
**Part1/C** : Status = Production [1-Aug-2007]
**Part1/D** : Working
**Part2/A** : Status = Pre-Production [1-May-2007]
**Part2/B** : Status = Production [1-Jul-2007]
**Part2/C** : Status = Production [1-Sep-2007]
**Part3/A** : Status = Pre-Production [1-Aug-2007]
**Part3/B** : Working

Teamcenter configures Revision C of Part 1, because it is the latest released revision with either **Production** or **Pre-Production** status.

Teamcenter configures Revision C of Part 2 for the same reason.

Teamcenter configures Revision A of Part 3, again for the same reason.

For details about grouping revision rules by item type, see *Grouping revision rule entries by item type*.

**Grouping revision rule entries by item type**

You can modify the order of precedence of revision rule entries by grouping revision rules by item type. Teamcenter evaluates any revision rule under the item type group for configuration of item revision only if the item type of the revision rule group and underlying item revision matches. By using this grouping mechanism in a product
structure that has item revisions of different item types, you can create revision rules that selectively apply the revision rule entries according to the given item type.

For example, you may use an item to manage parts and equipment, but need to distinguish between a production part and the equipment used to manufacture the part. Each of these item types may have the same status but can be configured in a different way, for example, by unit or date released. To achieve this, you can define a revision rule with a clause that restricts some of the entries to certain item types.

Creating Has Item Type entries

Create a Has Item Type entry in a revision rule in the following format:

```
Has Item Type (<item type 1, item type 2, etc>) {
<Entry 1>
<Entry 2>
etc.}
```

For example:

```
Has Item Type (Part) {
Has status (Approved, Configured with Released Date) {
Has status (Production, Configured with Unit Number)
}
```

In this example, the Has status ( Approved, Configured with Released Date) revision rule entry configures the product structure only if the item type is Part. For all other item types in the product structure, Teamcenter applies the Has status (Production, Configured with Unit Number) revision rule entry. If neither of these entries applies, the part is not configured by this revision rule.

Grouping entries for multiple item types

Each Has Item Type entry may have one or more item type arguments, but cannot be left blank, that is, you cannot create a revision rule entry for Has Item Type (Any). To include more than one item type argument, use the syntax in the following example:

```
Has Item Type ( Prototype, Virtual Build ) {
...
```

Grouping combinations of item type entries

You can only use one level of grouping and may not create nesting inside an existing group entry, as shown in the following examples:

- Single revision rule entry grouped for item type:

  ```
  Has Item Type ( Prototype ) {
  entry 1 }
  entry2
  ```

- Multiple revision rule entries grouped for item type without equal precedence:

  ```
  Has Item Type ( Prototype ) {
  entry 1
  entry 2 }
  entry3
  ```

- Multiple revision rule entries grouped for item type with and without equal precedence:
Has Item Type (Part) {
    [Status (Released, Configured Using Release Date)]
}
Has Item Type (Module, Incremental Change) {
    [Status (Released, Configured Using Unit No)]
}
Working

This example shows how you can use the same status type in both situations, but configured differently—in this case, by date for parts, but by unit number and incremental change for modules.

You can only group Working and Status entries with equal precedence.

Create and group revision rule entries by equal precedence

   Teamcenter displays the Revision Rules dialog box.

2. In the dialog box, click the Create/Edit button.
   Teamcenter displays the Revision Rule dialog box with any existing revision rule entries.

3. In the dialog box, define and select the entries of the same type you want to group and click the Group button.
   Teamcenter displays the Group Entries dialog box.

4. In the dialog box, click the Group Entries by Equal Precedence button.
   Click OK and Teamcenter updates the Revision Rule dialog box with the newly grouped revision rule entries.
   ![Note]
   When grouping by equal precedence, you should only group Working entries with other Working entries and Status entries with other Status entries. Do not group other combinations of entries.

5. In the Revision Rule dialog box, complete the definition of the revision rule and click OK.
   ![Note]
   To remove an equal precedence entry from a revision rule, you must highlight all the lines of the entry in the dialog box.

You can also group revision rule entries using engineering change types.

Create and group Has Item Type revision rule entries

   Teamcenter displays the Revision Rules dialog box.

2. In the dialog box, click the Create/Edit button.
   Teamcenter displays the Create New Revision Rule dialog box with any existing revision rule entries.

3. In the dialog box, define and select the entries you want to group and click the Group button.
   Teamcenter displays the Group Entries dialog box.
Chapter 11  Using item revision configuration

4. In the dialog box, click the Group Entries by Item Types button, and then select the item types you want to group in the Available Item Types list. You can transfer the selected item types to the Configure By→Has Item Type box in the dialog box or remove them by clicking the + or – buttons, respectively.

Click OK to update the selected item types in the Configure By→Has Item Type box of the dialog box, with a partially created Has Item Type revision rule entry. It also updates the Revision Rule dialog box with the newly grouped revision rule entries.

5. In the New Revision Rule dialog box, complete the definition of the revision rule and click OK.

Group existing revision rule entries by item type

1. Choose Tools→Revision Rule→Create/Edit.

Teamcenter displays the Revision Rule dialog box.

2. In the dialog box, select one or more revision rule entries and click the Group button.

Teamcenter displays the Group Entries dialog box.

3. In the dialog box, click the Group Entries by Item Types button or the Group Entries by Equal Precedence button, then select the item types you want to group in the Available Item Types list. You can transfer the selected item types to the Configure By→Has Item Type box in the dialog box or remove them by clicking the + or – buttons respectively. Click OK when you have grouped the entries.

Teamcenter updates the selected item types in the Configure By→Has Item Type box of the dialog box, with a partially created Has Item Type revision rule entry.

Note: You can only group Working and Status entries with equal precedence.

Ungroup combinations of item type entries

1. Choose Tools→Revision Rule→Create/Edit.

Teamcenter displays the Revision Rule dialog box.

2. In the dialog box, select one or more Has Item Type revision rule entries that are grouped by item type, and click the Ungroup button.

Teamcenter removes the selected entries and updates the dialog box.

Modify the item types in existing revision rule entries grouped by item type


Teamcenter displays the Modify Revision Rules dialog box, as shown in the following example.
2. In the dialog box, select one or more Has Item Type revision rule entries and click the Edit button or double-click a single line.

Teamcenter displays the Group Entries Item Type Edit dialog box, similar to the following example.

3. The item types that are currently grouped in the selected revision rule entry are displayed in the Configure By-Has Item Type list. To add a selected item type from the Available Item Types list, click the + button. To remove a item type, select it in the Configure By-Has Item Type list and click the – button. When the list of item types is shown correctly, click OK to update the revision rule.

Note You must check at least one item type; otherwise, Teamcenter displays an error message.
Chapter 11  Using item revision configuration

Applying a revision rule to a Structure Manager window

Each Structure Manager window has an associated revision rule that Teamcenter applies to the displayed structure. The name of the revision rule appears in the banner at the top of the window. Setting a revision rule in one window does not affect the revision rule that is applied in another window. When you open a new Structure Manager window, Teamcenter applies your default revision rule to the structure.

If you do not want to use the default rule, you can set a revision rule for your current Structure Manager session by clicking the Revision Rule button or choosing Tools→Revision Rule→View/Set Current. If there are existing windows containing previously opened structures, Teamcenter uses the revision rule of the current window when you open a new structure; otherwise, it uses the default revision rule.

For more information, see Set a revision rule.

A revision rule is always in effect when a Structure Manager window is open. The revision rule allows Teamcenter to determine the specific revision of each part and assembly to configure in the structure. You set your default revision rule by choosing the Edit→Preferences menu command.

When a new revision rule is set on a window already containing a structure, the revision rule only reconfigures the child lines; the top line of the window is not changed. If the top line was revised and you want to set the latest revision as the top line, you should open the latest revision in a new window.

Note  Unlike a revision rule, a variant rule is optional and no default is applied.

Set a revision rule

- Set a revision rule by clicking the Revision Rule button on the toolbar or choosing Tools→Revision Rule→View/Set Current.

Teamcenter displays the Set Revision Rule dialog box containing a list of revision rules that were configured by a privileged user. The right side of the dialog box shows the details of the selected revision rule. To set a revision rule, you select the required rule and click OK or Apply. If you are a nonprivileged user, you do not need to understand the complexity of the rule syntax, but should understand the appropriate rule to apply in a particular circumstance.

Tip  You can save a default revision rule by choosing the Edit→Options menu command.

Set date/unit/end item

- To set the date, unit number, and/or end item of the currently active revision rule, choose Tools→Revision Rule→Set Date/Unit/End Item.

Teamcenter displays the Set Date/Unit/End Item dialog box into which you can enter a date, a unit number, and an end item for the current revision rule.

The first time you make a change to a saved revision rule (including setting a date, unit number, or end item), Teamcenter creates a modified copy of the
rule and applies it to the window. This is the rule to which you make the unit number change.

If any date, unit number, or end item has been explicitly set in the current rule, you cannot change the value in this dialog box and the relevant boxes are grayed out.

Tip You can add a button to the toolbar to initiate the Tools→Revision Rule→Set Date/Unit/End Item command, by right-clicking the toolbar, choosing Customize, and selecting the required button.

Note If you specify an end item identifier that is shared by multiple objects, Teamcenter displays the Select Unique Item dialog box, allowing you to select the object you require.

You can create or modify a revision rule in applications other than Structure Manager, for example, in 4G Designer. Structure Manager does display such revision rules and their entries, and you can use them to configure the structure based on the displayed entries. However, a product structure in Structure Manager and a collaborative design in 4G Designer may have different data conditions. If so, the configurations in the applications are different, even if you use the same revision rule.

Set an override folder

To add an override folder into the currently active revision rule, choose Tools→Revision Rule→Set Override Folder. This command is available to unprivileged users, but is only active for revision rules that contain a special empty override entry (no folder specified). Thus privileged users who define the revision rules should place an empty override entry into a revision rule if they want to allow unprivileged users to use their own override folders with the rule.

The Set Override Folder dialog box allows you to set an override folder and also to see the folder that is currently set. The dialog box has the following boxes:

- A Name box into which you can enter a case sensitive search string to find the required override folder. Click the Find button next to this box to perform the search.

- The search results box. Double-click the folder you want to set.

- A Folder box that displays the folder currently used as the override folder in the revision rule.

To use the existing override folder, simply click OK or Cancel.
Chapter 11  Using item revision configuration

**Note**  •  The first time you make a change (such as setting an override) to a saved revision rule, Teamcenter creates a modified copy of the rule and applies it to the window. This is the rule to which you then make the override change.

•  When you make a change to a folder (for example, adding an item revision to it when Teamcenter Integration for NX is active) and open an assembly configured by a rule that uses the override folder, Teamcenter does not automatically reevaluate the revision rule. Consequently, it does not take into account the change to the override folder. This rule is reevaluated only if you choose File→Options→Load Options in Teamcenter Integration for NX. Click OK before opening the part file.

Viewing revision rule information

Use the **Rule Configured By** column in the product structure window to interpret how a particular line is configured. The values that may appear are:

•  **Working ( Owning User = user, Owning Group = group )**

This appears if the item revision is working and thus configured by a Working entry in the revision rule. The owning user and owning group arguments only appear if they are specified in the revision rule.

•  **Has Status ( status, Configured Using ... )**

Shows the status specified in the revision rule that configured the item revision. If Any Release Status is specified, Any Release Status is shown. The **Release Status** column shows the status of the configured item revision.

The method of configuration (Configured Using) is also displayed and may be Released Date, Effective Date, or Effective Unit No.

Additionally, this column shows the date or unit number used in the configuration, as follows:

  o  **Date ( Today ) or Date ( 1-Jan-2007)**

    The date specified in the revision rule. Used to configure historical revisions with status.

  o  **Unit No. ( 4 )**

    The unit number specified in the revision rule.

  o  **End Item ( item object id )**

    Identifies the end item specified in the revision rule.

•  **Override Folder ( folder )**

The override list folder name is shown if the override list caused the item revision to be configured.

•  **Precise**

This appears if the occurrence is precise and is configured as such.
• **Latest ( ... )**
  This appears if the item revision is configured by a Latest entry in a revision rule. The method of latest configuration can be Creation Date, Rev ID Numeric, or Rev ID Alphanumeric.

• **Not Found**
  This is shown if no revision meets the revision rule criteria. Teamcenter displays ??? to represent the revision.

### Displaying and editing revision effectivity

By default, revision effectivity data is not displayed in the Structure Manager properties table. Before editing revision effectivity, you must first display the data.

If you are working with revision effectivity, you may want to display the Revision Effectivity property, as described in *Displaying properties*.

#### Display revision effectivity data

1. Select the line whose item revision effectivity data (ranges of dates or unit numbers for which the revision is effective) you want to view.

2. Choose **Tools → Effectivity → Revision Effectivity**.
   Teamcenter displays the Revision Effectivity dialog box. This dialog box lists all the effectivity ranges for each status attached to the item revision.

   **Note** While you can set date effectivity without an end item, unit effectivity must always have an end item.

#### Edit revision effectivity data

**Note** For easier access to editing functions, consider adding an Edit Revision Effectivity button to the toolbar by right-clicking the toolbar, choosing Customize, and selecting the required button.

If you previously released two or more items or item revisions simultaneously, when you edit the effectivity of one such item or item revision, you also edit the effectivity of any associated items or item revisions. You can identify any such affected items by sending the structure line to the Workflow Viewer to see the other targets of the process that share the same release status and whose effectivity will also change.

1. In the Revision Effectivity dialog box, select the appropriate revision effectivity line and click **Edit**, or double-click the line.
   Teamcenter displays the Edit Revision Effectivity dialog box.

   **Note** You can also edit revision effectivity in My Teamcenter. Double-click the item status and change the displayed value.

2. In the Create or Edit Effectivity dialog box, choose Units or Dates effectivity, as appropriate, and define the effectiveness data.
If defining unit effectivity, type the desired effectivity range in the Units box. Use the - character within a continuous range, and the , character to separate discontinuous ranges. For example, the unit range 1-5,7-9 defines effectivity for units 1 through 5, and 7 through 9 (but not effective for unit 6).

If defining date effectivity, select a cell in the From or To column, select a date from the calendar (and optionally enter a time), and click Set Date to place that date in the selected cell. Click the Clear Date button to remove the date from the currently selected cell. Repeat these steps for additional date ranges until you have entered all the desired date ranges.

- Click the UP button to add the and up (open-ended effectivity) condition to the end of the unit or date effectivity range.

- Click the SO button to add the stock out condition to the end of the unit or date effectivity range.

- Select the Apply Access Manager effectivity protection check box to apply the predefined Access Manager rules to this effectivity.

**Note** Teamcenter interprets UP and SO conditions as open-ended for revision configuration purposes. The revision is considered effective for any value greater than or equal to the unit or date value immediately preceding the UP or SO. Stock out indicates that existing stocks of a component revision should be used up before the next revision.

3. Optionally, for date effectivity, use the Edit Revision Effectivity dialog box to define an end item to qualify the effectivity range. You must use this with unit effectivity to specify a product, module, or subsystem that carries the unit number to which this effectivity refers. You can select an end item in one of the following ways:

- Clicking Find adjacent to the End Item box and searching for an item by identifier and/or name.

- Copying an item to the clipboard before opening the Revision Effectivity dialog box and clicking Paste adjacent to the End Item box.

- Clicking MRU adjacent to the End Item box.

**Note** If you want to remove the entered end item, click Clear adjacent to the End Item box.

4. Click OK to save the effectivity data you entered.

**Reuse components in different products**

To support reuse of the same components in different products, you can define multiple effectivities on the same status of an item revision, if each effectivity specifies a different end item. To create an additional effectivity on a status that already has effectivity:
1. In the Revision Effectivity dialog box, select the appropriate line and click Create. Teamcenter displays the Edit Revision Effectivity dialog boxes, with blank effectivity ranges.

2. Define the new effectivity, as described in steps 2 and 3 of the previous procedure.

Releasing multiple item revisions in a single workflow process

Teamcenter creates a single release status object and attaches it to all child item revision that are selected as a group and have a revision effectivity applied. Because they share the same release status object, if you change the revision effectivity on any child item revision, the change affects all the child item revisions. For example:

Top_Assy/A
|-Part1/A
|-Part2/A
|-Part3/A

If you select all of the child parts at the same time and apply a release status, they are all associated to the same release status object and have the same revision effectivity. Therefore, updating the revision effectivity of the Part3/A component applies the same revision effectivity to the other components (Part1/A and Part2/A). If each child item revision requires a separate revision effectivity, select a component by itself and apply the release status to each one separately.

Caution: Do not attempt to release multiple item revisions of the same item simultaneously. This action would apply the same release status object to all revisions and cause unpredictable configuration. Teamcenter may also apply incorrect revision effectivity—because the same release status object is attached to each item revision, it applies the same effectivity details to each of them. Always release item revisions of the same item individually.

Managing nested effectivity

A product structure may include a product that has its own effectivity that is separate from that of the product structure. For example, the product structure of a car may include an engine that is obtained from an external supplier. In this case, the effectivity of the engine differs from the effectivity of the car. You can use nested effectivity to change the end item context when you configure the car, as only one effectivity can be set in a revision rule; in this example, you must set the effectivity from car to engine at the engine.

Note: You can use nested effectivity with date or unit number effectivity.

To accommodate variations of effectivity within a product, you create a configuration item to attach to each assembly that is configured by a different end item to the top-level item. In the previous example, you would create a configuration item for the engine and the effectivity of the configuration unit defines the engine assemblies. A configuration item is where the effectivity context of the structure changes; it defines a new end item for the affected substructure.
Tip Use the **CFMEffConfigItemProperties** preference to specify the properties and values that identify an item as an effectivity configuration item.

You can create a mapping table to define the ranges of dates or unit numbers in the top-level product that configure a particular unit number or effective date in the lower level assembly. When you expand the product structure and apply a revision rule, the unit number or date set at the top level is converted to the scheme defined in the mapping specified for the assembly.

For more information about nested effectivity, see *Getting Started with Product Structure*.

### Configuring nested effectivity

To configure nested effectivity, your Teamcenter administrator must set the **EffectivityConfigurationItemProperties** preference. This preference contains the item properties that identify configuration items. For example, the following entry defines the name of the type of item as the identifying attribute:

```plaintext
isConfigurationItem
object_type:object_name
```

Each entry in the list must be followed by the corresponding values. For example, the following example states that a configuration item is of the **Product** or **Vehicle** item type:

```plaintext
EffectivityConfigurationItemProperty.isConfigurationItem=true
EffectivityConfigurationItemProperty.object_type.object_name=
Product
Vehicle
```

### Creating a configuration item

You do not create a configuration item separately, but can identify an item as a configuration item when you create it. To do this, ensure the **Configuration Item** check box is selected on the **New Item** wizard before you click **Finish**.

Alternatively, you can convert an existing item to a configuration by right-clicking and choosing **Configuration Item**.

Note The **Configuration Item** check box appears on the **New Item** wizard only if it has been enabled using the Business Modeler IDE:

1. In the Business Modeler IDE, open the item business object type.
2. Click the **Operation Descriptor** tab and select the **CreatInput** tab.
3. Select the **is_configuration_item** property.
4. On the **Property Constants** tab, select the **Visible** property constant.

For more information about using the **Operation Descriptor** tab to make properties visible on creation wizards, see the *Business Modeler IDE Guide*. 
Creating a revision rule for nested effectivity

When you create a revision rule for a nested effectivity scheme, ensure you select the Nested Effectivity check box. This action adds a Nested Effectivity entry to the revision rule and ensures that Teamcenter modifies the revision rule according to the mapping on any configuration items it encounters. If you do not check this check box, Teamcenter ignores any configuration items. The position of the Nested Effectivity entry in the rule is not significant and never changes.

The following example structure has date effectivity and an end item defined on the item revision of each part:

<table>
<thead>
<tr>
<th>Item</th>
<th>Status, effectivity</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>NE-A1000/A (CI) – Product X</td>
<td>Released, EI: NE-A1000, 15 July-UP</td>
<td>Rev Effect wrt NE-A1000 – Product X</td>
</tr>
<tr>
<td>NE-A2000/A (CI)</td>
<td>Released, EI: NE-A2000, 20 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-A100/A</td>
<td>Released, EI: NE-A2000, 20 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-A200/A</td>
<td>Released, EI: NE-A2000, 20 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-PP30/A</td>
<td>Released, EI: NE-A2000, 20 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-PP10/A</td>
<td>Released, EI: NE-A2000, 20 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-PP20/A</td>
<td>Released, EI: NE-A2000, 20 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-A3100/A (CI)</td>
<td>Released, EI: NE-A1000, 16 July-UP</td>
<td>Rev Effect wrt NE-A1000 – Product X</td>
</tr>
<tr>
<td>NE-A400/A</td>
<td>Released, EI: NE-A3100, 23 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-PP70/A</td>
<td>Released, EI: NE-A3100, 25 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-PP60/A</td>
<td>Released, EI: NE-A3100, 25 July-UP</td>
<td></td>
</tr>
<tr>
<td>NE-A5000/A (CI) – Product Y</td>
<td>Released, EI: NE-A5000, 15 July-UP</td>
<td>Rev Effect wrt NE-A5000 – Product Y</td>
</tr>
<tr>
<td>NE-A2000/A</td>
<td>Released, EI: NE-A5000, 15 July-UP</td>
<td></td>
</tr>
</tbody>
</table>

The resulting configuration item effectivity mappings are:

- Mapping on NE-A2000 (CI):
  
  NE-A1000 (CI) – Product X : NE-A2000 (CI)
  NE-A5000 (CI) – Product Y : NE-A2000 (CI)
Chapter 11  Using item revision configuration

- Mapping on NE-A3100 (CI):
  
  NE-A2000 (CI) – Product Y : NE-A3100 (CI)

If you apply the following revision rule, the structure is configured as shown in the following figure:

Status = Released, Configured by Effective Date
Working
Nested Effectivity
EI = NE-A5000
Date = 27 July 2006

**Nested effectivity 1**

Conversely, if you apply the following revision rule with no nested effectivity entry, the structure is configured as shown in the following figure:

Status = Released, Configured by Effective Date
Working
EI = NE-A5000
Date = 16 July 2005

**Nested effectivity 2**

Teamcenter ignores the mappings, so the end item does not switch from A5000 to NE-A2000/NE-A3100 at the configuration items. Consequently, none of the components below the configuration items are configured, as the end item on the effectivity is not NE-A5000.

If you apply the following revision rule, Teamcenter applies effectivity mapping due to the **Nested Effectivity** entry and the structure is configured as shown in the following figure. However, some of the components are not effective on 23 July and have no configured revision; Teamcenter marks these components as ???.

Status = Released, Configured by Effective Date
Working
Nested Effectivity
EI = NE-A5000
Date = 23 July 2005
Nested effectivity 3

Create effectivity mapping on a configuration item

Effectivity mapping allows you to modify the parameters of the revision rule (for example, the end item, date and unit number) as you cross the borders of configuration items. Teamcenter attaches a mapping table to the revisions of the configuration item, and each entry in this table defines an optional end item and an optional effectivity range that defines the effectivity of the mapping itself. A mandatory subeffectivity entry defines the effectivity parameters used in the configuration item’s substructure.

To view or define the effectivity map for an item, select the item corresponding to the configuration item in the product structure tree and choose Tools → Effectivity → Effectivity Mapping. Teamcenter displays the Effectivity Mapping dialog box allowing you to view any defined mappings for the configuration item or create new mappings.

To create a new effectivity map in the Effectivity Mapping dialog box:

1. Select an end item to which the effectivity map applies. The end item is not normally the configuration item.

2. Optionally, select the Use Shared Effectivity check box to use an effectivity map and share it with another end item. You can also select the Create New check box to create a new effectivity map and make it available to share with other end items.

   **Note** You can share any effectivity type, not just effectivity maps.

3. Define a date or unit effectivity in the usual format.

4. Define the subeffectivity.

   Optionally, you can select the Use last release date check box to set the subeffectivity date to that one which the configuration item is released. This allows you to configure the released substructure without needing to specify the exact date.

   **Note** A blank entry in the mapping table indicates ALL.

To create a new effectivity map, select an item revision in the Effectivity Mapping dialog box and click the Create button. Teamcenter displays the Create Effectivity Mapping dialog box, allowing you to define the parent product effectivity and the subeffectivity of the item revision.

Similarly, to edit an existing effectivity map, select an item revision in the Effectivity Mapping dialog box and click the Edit button. Teamcenter displays the Edit
**Effectivity Mapping** dialog box, allowing you to modify the parent product effectivity and the subeffectivity of the item revision.

**Managing product generations**

Instead of referencing a specific configuration item when you define an effectivity map, you can reference a separate entity—the generation item. The following figure shows a simplified product structure in which the effectivity statements referenced separate generation items (2005–MY and Generation2), rather than a specific configuration item. These generation items are items that can exist independently of a product structure.

The effectivity map of this structure is as follows:

<table>
<thead>
<tr>
<th>End item/revision</th>
<th>Effectivity range</th>
<th>Subeffectivity</th>
</tr>
</thead>
<tbody>
<tr>
<td>2005_MY</td>
<td></td>
<td>Gen2</td>
</tr>
<tr>
<td>2006_MY</td>
<td></td>
<td>Gen3</td>
</tr>
</tbody>
</table>

In this example, the 2005_MY parent end item configures the Gen2 end item when you enter the Engine/A assembly. Similarly, 2006_MY configures Gen3.

The final line of the example shows how you can transform multiple parameters (End Item and Date) in a single mapping.

**Defining end item revisions**

To implement product generations, you can create *end item revisions*. You define end item revisions in the same way as end items, but additionally specify a revision of the end item. For example, you define the following effectivity:

<table>
<thead>
<tr>
<th>Release status</th>
<th>Unit/date range</th>
<th>End item/revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>Production</td>
<td>10-Feb-2007 00:00 to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UP</td>
<td>002988–Car/A</td>
</tr>
<tr>
<td>Production</td>
<td>01-Apr-2007 00:00 to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UP</td>
<td>002988–Car/B</td>
</tr>
</tbody>
</table>

In this example, the effectivity of a component may have a different effectivity, depending on the revision of the car that is configured. The component is effective from 10–Feb in **Car/A** and from 01–Apr in **Car/B**. If you create a revision rule
that defines an end item revision and Teamcenter encounters an object that has effectivity based on the end item (not the revision), it successfully matches if the end item revision is a revision of the end item.

You can also pack or collapse all effectivity entries that share the same release status and unit or date range into a single line by selecting the Packed check box in the Effectivity dialog box.

**Using revision rules from My Teamcenter**

You can create revision rules and save them as workspace objects. These workspace objects can be referenced by folders in other applications, for example, My Teamcenter. You can copy a revision rule into My Teamcenter.

You can also search in My Teamcenter to locate a particular rule. You can then reference a rule within a particular item or revision for configuration purposes.

You can view the contents of a revision rule in My Teamcenter by clicking the Viewer tab. This displays the list of entries in the rule.

**Managing occurrence to part relationships**

By default, an occurrence automatically references a particular item revision, depending on the revision rule currently in effect. Optionally, you can set the occurrence to unconditionally reference a precise revision of the part. You can then detect any precise occurrences that reference an out-of-date revision and manually upgrade each occurrence to an approved revision of the referenced part. This option is available only with a precise structure.

**Note** This functionality is only available if you work with supersedures in a change management environment.

The administrator defines the valid approved status of an item revision in the TC_ValidApprovedStatus preference.

**Show occurrences of superseded item revision**

- When you create a new item revision and it is approved, the occurrences of older revisions are not automatically updated with the new revision if the structure is precise. To identify superseded item revisions, right-click a line with children and choose Edit→Show Superseded. Teamcenter places the superseded item revision symbol (艅) against each child with an approved later item revision.

**Update precise occurrences of superseded item revision**

- To update an occurrence with an old revision to the new approved revision, right-click the occurrence and choose Update Superseded. Teamcenter shows the Update dialog box listing all the approved revision of the item, and you should select a revision and click OK. You can update all the applicable occurrences in the parent assembly or just the currently selected component.
# 12 Capturing configurations

Capturing configurations .................................................. 12-1
Using snapshots .................................................................. 12-1
    Create a snapshot ......................................................... 12-2
    Open an existing snapshot ............................................. 12-2
    View a snapshot .......................................................... 12-3
Using baselines .................................................................... 12-3
    Define baseline naming rules ......................................... 12-4
    Create a baseline .......................................................... 12-5
    Using smart baselines .................................................. 12-7
    Finding the baseline folder ............................................ 12-8
    Creating a dry run ......................................................... 12-8
    Hiding and viewing baselines ........................................ 12-8
        Hide baselines ......................................................... 12-8
        View hidden baselines ............................................. 12-9
Using intermediate data captures ........................................ 12-9
    Capture structure lines into IDC .................................... 12-9
Chapter

12 Capturing configurations

Capturing configurations

Teamcenter provides the following formats for persistently capturing the configuration of a structure:

- **Snapshots** containing only the configured product structure (item revisions), not the associated data. Consequently they require relatively little disk space.

  You can redisplay the saved structure at any time by sending the snapshot folder to Structure Manager. However, any item revisions that are not released are subject to change, including the associated data and CAD models.

  **Note** If the Baseline_create_snapshot_folder preference is set to 1, when you create a baseline of a structure, Teamcenter creates a snapshot folder under the baselined revision.

- **Baselines** containing a copy of the complete working data for the structure. Baselines occupy a significant amount of disk space, as you create a copy of the structure each time you baseline it. Many new revisions might be created and (with them) copies of the associated data and CAD designs.

- **Intermediate data capture (IDCs).** IDCs are similar in purpose, but save the configuration in PLM XML format. You can create IDCs in Structure Manager and view them in the Multi-Structure Manager application.

- **Product view.** When you click the floppy disk button on the Viewer menu bar, Teamcenter saves a PLM XML file that contains a visual representation of your current viewer session. The session file may subsequently be reopened to show the saved product view.

Using snapshots

A snapshot captures all the item revisions contained in a configured product structure. You can use the snapshot to redisplay the structure as saved.

When you create a baseline, you can configure Teamcenter to also create a snapshot folder by:

- Setting the Baseline_create_snapshot_folder preference to 1.

- Choosing Edit→Options→General→Item Revision, and moving Snapshot from the Available Relations column to the Shown Relations column.

- Choosing Edit→Options→Related Objects→Item Revision, and moving Snapshot from the Available Relations column to the Shown Relations column.
Snapshots and baselines are separate features that are normally used for different purposes.

You cannot create snapshot folders for precise baselines, only imprecise baselines. The **Baseline_create_snapshot_folder** preference is ignored if you create a precise baseline.

When you create a baseline of an imprecise structure, Teamcenter:

- Creates the baseline item revision.
- Creates a snapshot folder with the baseline job name under the baselined item revision.
- Populates the snapshot folder with references to the item revisions included in the structure when you created the baseline.

For more information about creating baselines, see *Using baselines*.

**Create a snapshot**

1. Configure the structure you want to save by applying the appropriate revision rule.

2. Choose **File→New→Snapshot**.

   Teamcenter displays the **Create Snapshot** dialog box.

3. In the dialog box, type a name for the snapshot and (optionally) a description.

   To track snapshots and what they refer to, name them carefully. Use the **Name** and **Description** boxes to do this. You may want to record the name of the revision rule used to construct the snapshot in the **Description** box.

4. Click **OK**.

   Teamcenter create the snapshot and folder, persisting the root item information in the folder.

   This action performs a full expansion of the structure, which may take some time for a large structure.

5. (Optional) Attach the snapshot to an item revision.
   
a. Select the folder and choose **Edit→Copy**.
   
b. Select the item revision and choose **Edit→Paste Special**.

   Teamcenter displays the **Paste Special** dialog box.

   c. Select **Snapshot** and then click **OK**.

   Teamcenter pastes the snapshot under the item revision.

**Open an existing snapshot**

1. Select the snapshot folder in My Teamcenter.
2. Drag-and-drop the snapshot folder into the Structure Manager application. The structure is displayed as you saved it in the snapshot.

The ad hoc revision rule applied in this Structure Manager window uses the snapshot folder as an override list. It also configures precise references.

View a snapshot

- You can view the item revisions stored in a snapshot by expanding the snapshot folder in My Teamcenter.

**Note** You should protect snapshots against modification of their contents using the Access Manager rule tree as described in Controlling access to snapshots.

Using baselines

During the development of a product design, you may want to share your working design with other users. You may also want to save an interim version of your design for future reference. To do this, you can create a baseline of the work-in-progress (WIP) design. When you request a baseline, Teamcenter creates a new revision for each unreleased revision in the structure and releases it with a predefined status, for example, TC_Baseline. It also links the new revision with the WIP revision using an IMAN_baseline relation. This method configures a completely released structure and thereby guarantees that the models are the same as when the baseline was created.

When you create a baseline, Teamcenter observes deep copy rules when copying datasets, forms, and other attachments associated with the item revision. Siemens PLM Software recommends you use CopyAsObject in deep copy rules as the baseline process takes a snapshot of objects in their current state.

For more information about defining deep copy rules, see the Business Modeler IDE Guide.

If the baseline finds an invalid item type or the current user does not have write access to any of the items, the baseline operation is rolled back. You define invalid item types in the Baseline_restricted_item_types preference, as described in . For example, you may not want to baseline engineering changes and documents.

For more information, see the Preferences and Environment Variables Reference.

Before creating a baseline, Siemens PLM Software recommends you first perform a dry run mode to identify invalid conditions. Set the Baseline_dryrun_always preference to true to always perform a dry run before creating the baseline.

The baseline process always starts from the top line of the current window, regardless of the selected line. The baseline operation processes lines that are configured out by variants or occurrence effectivity. Substitutes and packed lines are always processed. However, if the structure has suppressed components, you can optionally process them by selecting Show Suppressed Occurrences. If the structure has incremental changes, Siemens PLM Software recommends you use incremental change baselines.

To view the completed baseline, load it into Structure Manager after applying the appropriate revision rule.
Chapter 12  Capturing configurations

Note Before creating baselines, you must configure this feature as follows:

- Use the Business Modeler IDE to create the appropriate baseline naming rules for your site and attach them to the appropriate item revision types. You must also create a Baseline status type in the Business Modeler IDE.

For more information, see Define baseline naming rules.

- Set the Baseline_precise_bvr preference, which controls whether a precise or imprecise baseline is created.

- If your company shares baselines between different sites with Multi-Site Collaboration, your Teamcenter administrator sets the Baseline_auto_remote_checkout_allowed preference to true to define if the checkin and checkout process is automatic. If this preference is set to false, you must manually check out replicated items owned by other sites when you create the baseline.

- If you want to release the baseline immediately after creation, create the necessary workflow and add the workflow name to the Baseline_release_procedures preference. A baseline release process must adhere to a quick release template. Quick release templates are process templates that define a zero-step release procedure, allowing the baseline to become a released object that cannot be modified.

For more information, see the Workflow Designer Guide.

- Set the Baseline_allow_edits preference to ON to allow users to edit the item ID of items that are baselined. Once the item is released, the item ID can no longer be modified.

- If you are working with NX, Teamcenter may synchronize (refile) the assembly to NX before creating the baseline. This action is optional and depends on the setting of the Baseline_nxmanager_refile preference. You may also set the Baseline_refile_required_dstypes and Baseline_refile_not_required_item_types preferences to refine the refile operation.

- If the latest revision is the baseline revision, Teamcenter generates the next revision ID based on the ID of the revision of the baseline revision.

You can also create a baseline of a single item revision in My Teamcenter. In this case, a new copy of each BVR of the WIP revision is created. The precision of the new BVR is the same as that of original BVR, irrespective of the setting of the Baseline_precise_bvr preference.

Define baseline naming rules

Teamcenter provides a default baseline suffix rule with a pattern of ".".NNN, an initial value of .001, and a maximum value of .999.
Use the Business Modeler IDE to create the appropriate baseline naming rules for your site. The following example shows how to format a naming rule in the Business Modeler IDE for baselines of items:

```
Item Rule
A Rev
A.001
A.002
A.003
B Released Rev
B.001
B.002
C Working Rev
```

To establish this rule:

1. Create an item business object (type) called ItemPDR, if it does not already exist.

2. Create a naming rule called Baseline rev rule (any name can be used) with the following pattern:

   
   "."NNN

   Ensure you also select the Generate Counters check box.

3. Attach the Baseline rev rule naming rule to the baseline suffix property on the ItemPDR item business object.

For information about using the Business Modeler IDE, see the Business Modeler IDE Guide.

Create a baseline

1. Ensure you are logged on to an account that has Author privileges.

2. In the product structure tree, display the top line item revision of the structure you want to capture and choose Tools→Baseline.

   Teamcenter displays the Baseline dialog box.
3. In the dialog box, fill in the following boxes:

   - **Baseline Rev ID**
     
     This is generated according to naming rules defined in the Business Modeler IDE. You cannot change the displayed value.

   - **Description**
     
     Type a description that is stored with the baseline.

   - **Baseline Template**
     
     Select a release procedure template from the list. The available release procedures are defined by the administrator with the `Baseline_release_procedures` preference. The list does not show templates that are in edit mode. The default Workflow process is TC Default Baseline Process. The workflow process used for baselines must not include any signoffs.

   - **Job Name**
Teamcenter generates this name in the format **Baseline_ItemID_BaselineRevID**.

- **Baseline Label** (optional)
  Enter an alphanumeric string that represents the baseline label. Teamcenter uses the label you enter as the name of the baseline folder. This box is displayed only if your site uses baseline labels.

- **Job Description**
  Enter a description of the baseline job.

4. In the dialog box, select one or more of the following check boxes, and then click **OK** to create a baseline or dry run:

- **Open on Create**
  Opens the baseline automatically after it is created.

- **Dry Run Creation**
  Creates a report.
  For more information, see *Creating a dry run*.

- **Precise Baseline**
  Selects the type of baseline to create—precise or imprecise. Your site may be configured to allow only precise baselines, depending on the setting of the **Baseline_precise_bvr** preference.

If the **Baseline_create_snapshot_folder** preference is set to 1 and you created an imprecise baseline, Teamcenter also creates a snapshot folder under the baselined item revision.

**Using smart baselines**

The standard baseline process may be time-consuming and use significant disk space as it may create many new revisions and (consequently) copies of all the associated data and CAD designs. To avoid this, you can create a *smart* baseline, reusing a baseline revision whose work in progress revision is unmodified since its last baseline was created. You can only create smart baselines of assemblies. To enable smart baselines, your administrator sets the **ITEM_smart_baseline** preference to **ON**.

If you try to create a smart baseline of an assembly that has not changed since the previous baseline, a new baseline is not created. No informational message is displayed in Structure Manager to indicate this.

**Note** If you make changes to an occurrence property (for example, quantity) the last modified date of the parent BVR changes and Teamcenter therefore considers the parent item revision as a candidate for a new baseline. However, the item revision of the BOM line on which changes were made does not qualify for the new baseline.
Finding the baseline folder

After creating a baseline, Teamcenter places all the baseline item revisions in the structure in a baseline folder if the Baseline_create_snapshot_folder preference is ON. It attaches this folder to the top level of the structure using a Snapshot relation.

Caution If you expand the baseline item revision, Structure Manager displays the snapshot folder. If you then expand the snapshot folder, Structure Manager shows the item revisions that were captured in the snapshot. If you then expand the baseline revision in the snapshot folder, Structure Manager shows the snapshot folder again. Be aware that if you expand baseline data below a certain level, Structure Manager displays duplicate objects.

Note You must set the Snapshot relationship on the item revision to make the snapshot folder visible. Do this by choosing Edit→Options→General→Item Revision and adding Snapshot to the Available Relation column.

Creating a dry run

Performing a dry run of a baseline allows you to validate the data associated with the base item revision or structure before you create the actual baseline. This avoids the necessity to roll back the baseline, if Teamcenter encounters errors during its creation.

The dry run generates a report that contains error messages, if Teamcenter encountered any problems while traversing the structure.

Your administrator can configure Teamcenter to always make a dry run, by setting the value of the baselineDryRun and Baseline_dryrun_always preferences.

Hiding and viewing baselines

Teamcenter lets you control the display of baseline revisions.

Hide baselines

1. Choose Edit→Options. The Options dialog box appears.
2. Select Item.
3. Click the Display tab.
4. Select the Show displayable revisions only check box. The Select Revision Relation dialog box appears.
5. Select Displayable Revisions and click OK.
6. Specify the order and rule for revisions display.

For example, when the released status on baseline item revisions is Pending, you display the latest baseline revisions by setting the rule, Released Status,
equal to the condition, **Pending**, and set the limit to the maximum number of baselines you want to display.

7. Select **Descending** as the display order.

8. Click **OK**.

The hierarchy tree pane displays the latest baselines up to the limit set.

**View hidden baselines**

When there are more baselines created than are displayed, the hierarchy tree pane displays a **More** button under the item.

1. Click **More**.

2. Select the required baseline revision from the list.

The baseline is displayed in a separate pane.

**Using intermediate data captures**

An IDC is a PLM XML file that contains the definitions of all the objects in the captured structure. You can manage the PLM XML file in the same way as any other workspace object, including assigning it to a workflow, assigning it a release status and controlling access privileges with Access Manager.

You can create intermediate data captures (IDC) that contain the configuration of a structure at the time the IDC is created. An IDC may contain any configured structure including a collaboration context, structure context or group of structure lines. You can view IDCs with the Multi-Structure Manager application.

You can create an IDC that stores the current state of the selected root object and any related objects, such as structure lines or attachments. You cannot capture workspace objects that are not in the structure.

**Capture structure lines into IDC**

1. Select the root object in the structure and choose **Tools**→**Intermediate Data Capture**.

   Teamcenter displays the **New Intermediate Data Capture** dialog box.

2. Select **IntermediateDataCapture** from the list of IDC types at the left of the dialog box.

3. Enter the name and optional description of the intermediate data capture, choose a transfer mode name from the dropdown list, and then click **OK** or **Apply**.

   Teamcenter validates the objects in the structure you selected. If any of the objects cannot be captured, it displays an error message, otherwise it creates the PLM XML file containing the IDC.

   **Note** Ensure you select a transfer mode that is appropriate for the data you want to capture, for example, **ConfiguredDataExportDefault** or **BOMwriterExport**. The displayed list shows all transfer modes that are available in the system.
View incremental changes for a structure .................................................. 13-16
Find recently used change objects ................................................................. 13-17
Track attachments with incremental changes ............................................... 13-17
  Track changes to an attachment ................................................................. 13-18
  Track the creation or deletion of an attachment ......................................... 13-18
  Track creation of an attachment .................................................................. 13-18
  Track deletion of an attachment .................................................................. 13-18
Track changes retrospectively ......................................................................... 13-18
Remove incremental changes .......................................................................... 13-19
  Remove an individual change from the incremental change information pane ................................................................. 13-19
  Remove changes from an item with the Remove Changes command ............ 13-19
Split an incremental change ............................................................................ 13-20
Exporting and importing incremental change data ......................................... 13-20
  Export incremental change data using a briefcase file .............................. 13-21
  Import incremental change data using a briefcase file .............................. 13-21
  Export incremental change data using PLM XML ..................................... 13-22
  Import incremental change data using PLM XML ..................................... 13-22
Chapter 13  Managing incremental changes

Managing incremental changes

Teamcenter supports two methods of controlling changes to product structures, incremental change (described here) and revision configuration.

For conceptual information about these methods and how to choose between them, see Getting Started with Product Structure. For more information about revision configuration, see Using item revision configuration.

An incremental change collects together a number of structure changes to a component such as addition or removal of components or changes to attachments (data). Effectivity can be applied to incremental changes to configure the associated changes. This method of change control allows several independent structure changes to be made concurrently, including the addition or removal of unrelated components. Those changes can be implemented in any sequence. This method of change control is suitable for large, flat structures without nested subassemblies or components. The revisioning approach is not suitable for this type of structure, as a separate revision is required for every permutation of change.

To enable incremental changes, the Teamcenter administrator must set the Incremental_Change_Management preference to true.

Caution Siemens PLM Software recommends you do not use the Cancel Checkout command on item revisions that contain changes tracked by incremental change. This action causes permanent loss of incremental changes that are tracking structure edits.

Note You cannot manage changes to substitute parts with incremental changes.

Elements of incremental change

The following table describes product structure elements that may participate in an incremental change.
<table>
<thead>
<tr>
<th>Element</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute occurrence</td>
<td>A relationship between a parent assembly and an item one or more levels lower in the structure. The parent assembly is the context in which the absolute occurrence exists. You can define data on the absolute occurrence that overrides the data stored on the item when you select the context assembly and view the structure. Both relative occurrence data (notes and transforms) and attachments can be overridden with data on absolute occurrences. Each absolute occurrence can have one or more unique attribute values that distinguish it from the other absolute occurrence derived from the same single occurrence.</td>
</tr>
<tr>
<td>Attachment</td>
<td>A form, dataset, or folder related to an item revision.</td>
</tr>
<tr>
<td>Baseline</td>
<td>(Incremental change baseline.) A new revision of the parent assembly that has the occurrences and attachments as configured in Structure Manager when the incremental change baseline was created. There are no incremental changes and all unconfigured occurrences are removed.</td>
</tr>
<tr>
<td>Change</td>
<td>An individual change to a component (occurrence) or attachment. A change may be an add or a remove.</td>
</tr>
<tr>
<td>Incremental change (IC)</td>
<td>A collection object that contains the individual changes. An IC is modeled as an item of the EngChange type. You can release an incremental change and apply effectivity to it by attaching a release status. Incremental change (revisions) are configured by the revision rule, as are the components (occurrences) and attachments associated with the changes on the incremental change. You can revise incremental changes if required, in which case the changes are copied (this is not typically required).</td>
</tr>
<tr>
<td>Intent</td>
<td>A named object that represents an alternate solution. You can apply one or more intents to an incremental change to signify that the incremental change is valid for those intents. The user sets one or more intents in the revision rule that configures the incremental changes with those intents and, consequently, the associated changes. Intents are only available with incremental change, not with standard revision configuration.</td>
</tr>
<tr>
<td>Occurrence</td>
<td>(Sometimes called relative occurrence.) A hierarchical structure relationship between the immediate parent assembly and its child component item (in an imprecise assembly) or item revision (in a precise assembly). You can use a find number to identify for an occurrence, but this number may not be unique. Data can be stored on the occurrence, including occurrence notes and transforms.</td>
</tr>
</tbody>
</table>
Managing incremental changes

Setting up incremental change

Before using incremental change, you must complete several setup procedures, including creating the necessary change types, providing users with access, defining releases statuses, and writing revisions rules.

Create new change types

To create a new change type, use the Business Modeler IDE.

For more information about creating change types, see the Business Modeler IDE Guide.

Note  When creating incremental change, Teamcenter does not distinguish between change types for change management and incremental change. It is therefore advisable to name the change types clearly.

Controlling access to incremental changes

To create an incremental change, you must have write access to the incremental change revision. Your Teamcenter administrator controls this access with Access Manager. If your site requires a different access policy on incremental changes to regular engineering changes, other rules may be required, for example, the naming convention for incremental change identifiers.

Your administrator can use an In IC Context rule to allow Structure Manager or another structure editor application to control access to operations tracked by incremental change. This rule is unlike other rules because it does not depend on the properties of the object. If there is an active incremental change in the structure editor and the operation performed by the user is tracked by incremental change, the In IC Context (true) rule is satisfied, and Teamcenter applies its associated ACL. In this situation, applicable structure edits include edits to occurrences, occurrence notes, transforms, and attachments in structure context.

Caution Always use this rule with the true argument. The false argument applies to all objects, regardless of whether the structure is edited.

Examples of rules for controlling access to incremental changes

You can place the In IC Context rule at the top level of the rule tree as follows:

Has Bypass
In IC Context (true) → IC ACL
Has Status
Has Object

In this example, if there is an active incremental change and the operation performed by the user is tracked by incremental change, the In IC Context rule applies and its associated named ACL applies to objects affected by the operation. However, if there is no active incremental change, the subsequent rules apply.

You typically use this rule to relax a restriction, such as only allowing edits to a released structure for a specific status. For example:

Has Status () → Vault
Has Status (Pre-Released) → () (No ACL)
In IC Context (true) → Incremental Change Access
Chapter 13  *Managing incremental changes*

In addition, the user requires write access to the incremental change itself.

**Note**  There is no mechanism of enforcing that an incremental change is used when making structure edits.

You can also configure the **In IC Context** Access Manager rule as follows to allow write access to released structures at a specified status. This allows incremental change to track changes at prereleased stages of the structure (BOM view revision).

```
| Has Status () → Vault                      |
| Has Status (Pending IC) → Incremental Change Access (or Working) |
| Has Status (Pre-Released) → () (No ACL)     |
| In IC Context (true) → Incremental Change Access (or Working) |
```

The purpose of these rules follows:

- **Has Status ()→Vault**
  
  This standard rule ensures released parts cannot be modified.

- **Has Status (Pending IC)→Incremental Change Access (or Working)**
  
  This rule allows you to apply a status of **Pending IC** to an incremental change so that you can apply effectivity. This allows changes to be configured for the incremental change. However, designers still require write access to the incremental change to add changes.

  It may be sufficient to use the general working access control list (ACL). Alternatively, you may want to restrict editing of incremental changes to certain roles, in which case you should use a different ACL (for example, **Incremental Change Access**). When an incremental change is finally released (for example with **Released** status), it can no longer be modified due to the **Has Status ()→Vault** rule.

- **Has Status (Pre-Released)**
  
  **In IC Context (true)→ Incremental Change Access (or Working)**

  These rules ensure that when a status of **Pre-Released** is applied to an item revision, changes can only be made to the structure or the item revision with an incremental change. Prior to this, there is no status and the structure or item revision (attachments) can be edited by any user with suitable permissions defined in Access Manager.

  When an item revision and the BOM view revision are finally released, for example, with a **Released** status, the structure can no longer be modified due to the **Has Status ()→Vault** rule.

**Configuring release status for incremental change effectivity**

Your Teamcenter administrator sets the **Incremental Change_ReleaseStatus** preference to define the release status that Teamcenter attaches to an incremental change when it is created. Defining a release status in this way allows you to specify effectivity as soon as the incremental change is created. If you do not set this preference, you release the incremental change after it is created. The choice of which of these approaches to implement depends on your business practices. For example, you might set this preference to **Pending IC**.
The status defined in the preference must already exist. You must also create an Access Manager rule that allows write access to objects with this status or you cannot create changes in the incremental change.

**Note**  The status is applied only to incremental change if the effectivity is supplied when it is created.

### Setting a revision rule

When you apply a revision rule in Structure Manager, it configures both the structure item revisions and the incremental change revisions. This consideration is important if you use incremental change in combination with traditional revision configuration of structure item revisions. If you want to configure the structure item revisions and incremental change revisions independently, you must apply a separate status.

The revision rule you create depends on whether the incremental changes are configured by unit or date effectivity, or simply by release date. It also depends on the release status to apply.

### Example of revision rules for incremental changes

For an example of how the **Pre-Released** status can be applied to the item revisions and the **IC in Process** status to the incremental change revisions, see *Getting Started with Product Structure*.

The revision rule needed for that example is as follows:

- **Has Status = IC in Process, Configured by Unit:**
- **Has Status = Pre-Released, Configured by Unit:**
- **Has Status=Released, Configured by Unit**
- **Has Status = Released, Configured by Release Date**
- **Has Status = Pre-Released, Configured by Release Date**
- **Working**

The purpose of each entry in this revision rule is as follows:

- **Has Status = IC in Process, Configured by Unit:**
- **Has Status = Pre-Released, Configured by Unit:**

  Allows Teamcenter to configure both the incremental change and the structure revisions by unit number. Having separate statuses allows Access Manager to apply different access controls to the item revision and BOM view revision and to the incremental change.

- **Has Status=Released, Configured by Unit**

  Ensures the upper levels of the structure are configured correctly by standard revision configuration, as well as any finally released revisions at lower levels.

- **Has Status = Released, Configured by Release Date**
- **Has Status = Pre-Released, Configured by Release Date**
- **Working**

  Configure item revisions that do not have unit effectivity applied or are unreleased, that is, **working**.
Chapter 13  Managing incremental changes

Setting independent incremental change contexts

You can make independent edits in different Structure Manager windows using a different incremental change in each window. This process is referred to as setting independent incremental change contexts. Use the **IC Context** column in the list of available windows to identify the incremental change context in each window.

Copying or cutting structure lines with incremental changes

By default, if you cut or copy a line and then paste it to a new location, incremental change elements (ICEs) are not copied. This may necessitate significant manual recreation of data if you are cutting or copying many lines together. To automatically copy ICEs, the administrator must set two Business Modeler IDE constants:

- **Fnd0EnableIceCarryOver**
  - Defines item types of the source and destination *parent* BOM line under which ICEs should be copied while copying, cutting, and pasting. For example, by default, the constant value for **MEProcess** is set to true, and if the source and destination parent BOM line are both **MEProcess**, Teamcenter copies any ICEs.

- **Fnd0AttrIcesToExclude**
  - Defines the occurrence attributes which Teamcenter does not copy to the target location for occurrence attribute changes.

These settings apply to in-context changes to structure lines, their attachments, and their occurrence attributes.

**Note**  For structure changes, only remove changes associated with the original line are carried forward to the new location. Teamcenter does not consider add structure changes; otherwise, two occurrences appear at the same time at two different locations. Teamcenter copies attribute changes made in the immediate parent context, but higher level contexts are excluded. The new ICEs created are associated to the original IC revision.

Creating an incremental change baseline

You should periodically create a new baseline revision for an item that is tracked by incremental change after a certain number of incremental changes are created. By default, all outstanding incremental changes are rolled into the new revision. This approach reduces the amount of data in the new revision and reduces the time needed to configure the assembly. Use of incremental change baseline may affect the revision rules applied, as described in *Getting Started with Product Structure*.

When you create an incremental change baseline, the new revision of the parent assembly has the occurrences and attachments configured by the revision rule or unit effectivity set when you created the incremental change baseline.

When you create an incremental change baseline, by default any active incremental changes are not carried forward to the baseline, as described later. However, you can optionally configure your system to roll up or carry forward active incremental changes. (Active changes are any changes that are currently effective or will be effective in the future.)
Managing incremental changes

Do not simply revise a structure that has incremental changes on any of the components because the incremental changes are not copied and the structure is not configured as expected. You must create the incremental change baseline first.

Ensure the baseline cannot be modified by applying a status to apply vaulting to the BOM view revision, rather than the item revision. Do not use the status on the item revision for this purpose because the status is also used for configuration.

You must have access to the incremental changes to create an incremental change baseline. If Teamcenter determines that you do not have the necessary access, it rolls back the baseline operation and does not create the new item revision.

**Note** Do not confuse incremental change baselines with creating standard baselines of item revisions as described in Using baselines. With standard baselines, if the item is an assembly, you can automatically create a new revision of any unreleased components throughout the substructure. With incremental change, the baseline is applied only to the product structure, not to the components.

It is good practice to apply unit number effectivity to the assembly item revisions, even if the components are configured by incremental change. This approach identifies the effectivity of the new incremental change baseline revision, and also configure it appropriately. There should be no incremental changes on components in the new incremental change baseline revision that are effective prior to the unit number at which the incremental change baseline revision was created.

**Baselining structures with active incremental changes**

Optionally, when you create an incremental change of an item revision, any incremental changes that are active are carried forward or rolled up. An active change is any incremental change that has an out effectivity equal to or greater than the baseline effectivity, including any open-ended effectivity.

When you carry forward a change, the affected object of the change is copied to the new item revision. The copy of the affected object is qualified to the same incremental change. Consequently, the old and new copies of the affected object share the same change effectivity.

When you roll up a change, only the affected object of the change is copied forward. The qualification is not present on the new item revision.

By default, this enhancement is not configured and you must set the following preferences to use it:

- **IC_baseline_carry_forward_active_changes**
  Set to True to carry over active incremental changes when creating a baseline.

- **IC_baseline_carry_forward_status**
  Defines a list of status names to consider when carrying forward active incremental changes. The default value is pending.

**Determining active changes**

Teamcenter drops, rolls up, or carries forward changes to the new item revision, depending on the following conditions. (X indicates the baseline, which may be a unit number or date.)
## Managing incremental changes

<table>
<thead>
<tr>
<th>Lower end</th>
<th>Higher end</th>
<th>Drop, roll up, or carry forward?</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;X</td>
<td>&lt;X</td>
<td>Drop</td>
<td>The change was effective in the past with respect to the baseline and will not be effective in the future. The change is dropped.</td>
</tr>
<tr>
<td>&lt;=X</td>
<td>&gt;=X</td>
<td>Carry forward</td>
<td>The change is effective and remains effective to a certain point in the future. Beyond that point, the change is not configured and is therefore carried forward.</td>
</tr>
<tr>
<td>&lt;=X</td>
<td>UP</td>
<td>Carry forward if Pending status or roll up if Secured status.</td>
<td>The change is effective and remains effective in the future. It can be rolled up into the next revision. However, if the incremental change is not released, it can be edited and such edits may be reverted. Therefore, if the status is Pending, changes are carried forward.</td>
</tr>
<tr>
<td>&gt;X</td>
<td>&gt;X,UP</td>
<td>Carry forward</td>
<td>The change is effective in the future, so is carried forward.</td>
</tr>
</tbody>
</table>

**Note** Teamcenter supports discontinuous effectivity, with multiple out effectivities. If any of the effectivities is equal to or greater than the baseline effectivity, the change is considered active.

When you create the baseline, changes that are past effective are dropped, irrespective of status. For example, if you create a baseline at unit 25, there may be changes on an incremental change with effectivity on units 5 to 15. All these changes are dropped because they are past effective. If you subsequently change the effectivity of this incremental change to span or cross baseline unit 25, you must recreate the baseline to take the effectivity change into account.

Teamcenter determines if an effectivity is applicable in the current context. An item revision under incremental change may have several status objects attached to it, and the objects may be different types. A revision rule may have several entries configured by effectivity, and the entries may specify different status and effectivity types. To determine if an effectivity statement on an incremental change revision applies to the revision rule, Teamcenter checks that the combination of status type and effectivity type (date or unit) match an entry in the revision rule.

### Carrying forward or rolling up active changes

Teamcenter carries forward active changes if:

- The change is currently active and the qualifying incremental change is not released, or
Managing incremental changes

- The change will be configured in the future.

It copies the affected object to the new item revision. It also connects the new copy of the affected object by an incremental change element (ICE) to the same incremental change as the original affected object.

Teamcenter rolls up active changes if the change is currently active and the qualifying incremental change is released. It copies only the affected object to the new item revision.

ICEs link affected objects to revisions of incremental changes. As an incremental change evolves, the affected object may be qualified by several ICEs to multiple revisions of the same incremental change. If you do not assign explicit out effectivities, but supersede them with later in points (for example, A: 1–UP, B: 10–UP, C: 20–UP), multiple revisions of the same incremental change may be considered active. If the baseline effectivity is equal to or more than 20, the latest in rule determines that C is the currently configured revision. However, as you may subsequently change any effectivity, Teamcenter carries forward the affected object with ICE qualification to all of these active incremental change revisions.

Dropping inactive changes

If Teamcenter determines that a change is not active, it is dropped from the new item revision. If the affected object is added by the incremental change, because the relevant change is no longer active, Teamcenter omits the affected object from the new item revision. If the object is removed by the incremental change, the removal is reversed and the affected object is copied forward without the incremental change qualification.

Viewing properties of incremental change data

You can display the Associated ICs property for any line in the structure that has a change. This property shows the incremental change that resulted in the change. If there is more than one add or remove change on a given line, the incremental change associated with each change is listed.

You can also view the following properties in the Attachments pane:

- Incremental changes of relations
  Displays incremental changes that caused the attachment to be added to or removed from the item revision.

- Incremental changes of objects
  Displays incremental changes that caused the attachment to be created or deleted.

- Attachment root node (Al_absoce_rootline_string)
  Displays the root line of the attachment. If this is not the same as the item revision at the top of the Attachments pane, the attachment does not apply to all occurrences of the item revision, but to a specific (absolute) occurrence that may be the parent assembly or a higher level assembly.
Chapter 13  Managing incremental changes

Adding property columns

Note  Adding properties in this way may slow the loading of the structure. The properties are populated only for structure edits and do not apply to changes made to occurrence attributes, replacements, or attachments.

Several structure line properties that contain information about incremental change are not shown by default and you may want to display these properties when you work with incremental changes, as described in Displaying properties. Consider displaying some of the following properties:

- **Configured ICs**
  Lists the incremental changes that affect each structure line that is configured by the current revision rule. + and – symbols in the cells indicate adds and deletes, if applicable.

- **IOC – Incremental Change Occurrence Configured**
  Shows if the structure line is configured with incremental change.

- **IC Effectivity**
  Lists the incremental changes that affect each structure line and their effectivities. + and – symbols in the cells indicate adds and deletes, if applicable.

- **IC Release Status**
  Lists the incremental changes that affect each structure line and their release statuses. + and – symbols in the cells indicate adds and deletes, if applicable.

- **IC Intent**
  Lists the incremental changes that affect each structure line and their intents. + and - symbols in the cells indicate adds and deletes, if applicable.

Using incremental change

Using incremental change management is optional. To use it, your administrator must set the Incremental Change Management preference to true. When this preference is set to false, the incremental change toolbar is not visible and any loaded items or relationships under incremental change control display in a different color.

Using the incremental change toolbar

Use the incremental change toolbar to create, find, and manage incremental changes. The toolbar is located at the bottom of the Structure Manager application window if your Teamcenter administrator has set the Incremental_Change_Management preference to true.

Note  If this preference is changed, you must exit and start a new session to see the incremental change buttons.

The toolbar is grayed out if no structure is loaded. When you load a structure, Teamcenter activates the toolbar buttons.
You can drag the incremental change reference from the toolbar and drop it into an application such as Change Manager or My Teamcenter. For example, you can do this to release the incremental change or introduce it into a workflow. The incremental change window includes the following toolbar buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Button]</td>
<td>Creates a new incremental change.</td>
</tr>
<tr>
<td>![Button]</td>
<td>Searches for an incremental change order.</td>
</tr>
<tr>
<td>![Button]</td>
<td>Displays the MRU list containing the most recently used incremental changes.</td>
</tr>
<tr>
<td>![Button]</td>
<td>Displays the incremental change Information dialog box.</td>
</tr>
<tr>
<td>![Button]</td>
<td>Clears the active incremental change and turns off incremental change tracking.</td>
</tr>
</tbody>
</table>

**Using the attachments and information panels**

You can view the Attachments and Incremental Change Information panes when the data pane is displayed. To display the data pane, click the Show/Hide Data Panel button.

If you display the Associated ICs property, you can easily identify the incremental change that added or removed a structure line. You can sort the structure on this column to identify all the structure changes to a given assembly that are implemented by a specific incremental change.

- The Attachments pane allows you to view attachments (forms or datasets) to the item revision that corresponds to the selected line. It also allows you to add, remove, or create attachments and track these changes with an active incremental change.

- The Incremental Change Information pane allows you to identify the incremental changes that affect the selected line. This is useful if there are several changes (adds or removes) associated with a single line, and each change is attached to a different incremental change.

  You can drag-and-drop incremental changes from the data pane to set incremental change context.

- The Incremental Change Info pane allows you to undo (remove) individual changes from the selected line.

**Using the incremental change menus**

Use the following commands available on the Tools→Incremental Change menu to manage incremental changes.

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Retrospectively creates an add change and attaches it to the active incremental change.</td>
</tr>
</tbody>
</table>
### Managing incremental changes

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove</td>
<td>Retrospectively creates a remove change and attaches it to the active incremental change.</td>
</tr>
<tr>
<td>Create on Object</td>
<td>Establishes a create change to the attachment.</td>
</tr>
<tr>
<td>Delete on Object</td>
<td>Establishes a delete change to the attachment.</td>
</tr>
<tr>
<td>Edit Attachment</td>
<td>Allows you to edit an attachment (dataset or form) and track the changes with the active incremental change.</td>
</tr>
<tr>
<td>Remove Changes</td>
<td>Removes (undoes) changes on the active incremental change.</td>
</tr>
<tr>
<td>Incremental Change Baseline</td>
<td>Revises the parent assembly to create an incremental change baseline.</td>
</tr>
<tr>
<td>Split</td>
<td>Allows you to split some of the changes from the active incremental change into another existing incremental change.</td>
</tr>
<tr>
<td>Display Icons</td>
<td>Allows you to configure how Teamcenter displays incremental change icons by selecting one or more of the following options:</td>
</tr>
<tr>
<td></td>
<td>• None</td>
</tr>
<tr>
<td></td>
<td>• Current Context</td>
</tr>
<tr>
<td></td>
<td>• All Context</td>
</tr>
<tr>
<td></td>
<td>• Hide Remove Icons</td>
</tr>
</tbody>
</table>

If you are not showing unconfigured changes and are not interested in changes that are not actually configured, select the **Hide Remove Icons** option.

**Tip** Consider adding these icons to the toolbar to allow you to more easily change the context. To do this, right-click the toolbar, choose **Customize** from the shortcut menu, and choose the incremental change icons.

### Enable and disable incremental change management

Using incremental change management is optional. To use it, your administrator must set the **Incremental_Change_Management** preference to **true**. When this preference is set to **false**, the incremental change toolbar is not visible and any loaded items or relationships under incremental change control display in a different color.

### Turn off incremental change tracking

- Click the button in the incremental change toolbar.
Managing incremental changes

Teamcenter changes the **Active IC** box to display **No Active IC**. No edits are tracked.

**Customize buttons**

Incremental changes are displayed by symbols at the beginning of a structure line. When you add or remove a structure line, Teamcenter displays a plus or minus symbol in front of the respective line.

- Customize when incremental change symbols are displayed by choosing **Tools→Incremental Change→Display Icons** and selecting the contexts in which you want to see the symbols.

- Choose **Tools→Incremental Change→Display Icons→Hide/Remove Icons** to always hide the display of the symbols in the tree structure.

- If your administrator sets the **MoveICCreationToMenu** preference to **True**, the button on the incremental change toolbar is hidden. If this button is not visible, use the **Incremental Change→Create** menu command to create a new incremental change, unless this command is suppressed.

**Create a new incremental change**

1. Click the **Create Incremental Change** button on the incremental change toolbar.
   
   Teamcenter displays the **Create/Revise Incremental Change** dialog box.

2. Click the **IC Attributes** tab and set the following incremental change attributes:
   - Type an ID and revision for the change object. Alternately, click **Assign** to let the system assign this information for you.
   - (Optional) Type a description for the incremental change.
   - Select a change type from the **Incremental Change Type** list. Note that some of these types may be for general changes, not incremental changes.

3. Click the **Effectivity** tab and specify whether to set effectivity for the incremental change using unit serial numbers or dates by doing one of the following:
Chapter 13  Managing incremental changes

**Note** You cannot specify an effectivity until the incremental change is released. An incremental change may be released by a workflow process that is specific for your company or site.

If you do not specify an effectivity, Teamcenter creates the change object without a status.

The administrator determines the initial release status of all new incremental changes by setting the **Incremental_Change_ReleaseStatus** preference. If this preference is not set, you must specify it later when releasing the incremental change.

If the **Incremental_Change_ReleaseStatus** preference is not set, you cannot set effectivity while creating the incremental change. You must release the incremental change (revision) separately with the appropriate process. Once the release status is attached, you can set the effectivity on the incremental change.

- Click **Units** and specify the range of serial numbers to which the effectivity is to be applied. You can also click one of the following buttons:
  - **UP** button to define an unlimited effectivity from a starting number. For example, typing **1-UP** means the change is effective from unit 1 upward.
  - **SO** button to define an effectivity until all stock is exhausted. For example, typing **1-SO** means the change is effective from unit 1 until no stock remains.

**Tip** The tooltip provides you with more information about the formatting for this entry.

- Click **Dates** to set effectivity based on calendar dates. Multiple date ranges can be entered. To set a date:
  - Type the start and end dates for the effectivity period into the **From Date** and **To Date** cells in the date table.
  - Select a date in the calendar table and click **Set Date** to specify both the **From Date** and the **To Date** entries.

When the correct effectivity is shown, click **OK**.

4. If unit effectivity is set, populate the **End Item** box on the **Effectivity** tab using one of the following methods:
   - From the list of most recently used end items
   - Using the **Search** function to open an item by name or ID
   - By pasting an item from the clipboard

5. Click **OK** to finish creating a new incremental change and close the dialog box, or click **Cancel** to cancel the operation.

Teamcenter creates a copy of the new incremental change in your **New Stuff** folder.
6. At an appropriate time, the designated user or a workflow process approves the change object by adding the release status. The change object is now locked and you cannot use it to track further changes to the process or operation.

**Note** You can use a Workflow handler that renames the status and retains the effectivity, for example, the **add_status** handler with a **-remove** option.

**Showing unconfigured changes**

You can configure the display of the tree table to show the following:

- All components and attachments.
- Only those components and attachments that are configured by the current revision rule.

**Control display of unconfigured changes**

- Choose **View→Show Unconfigured Changes** to toggle between showing all lines or only those set by the current revision rule.

**Note** You can add a button to implement this function to the toolbar, allowing you to easily see the current mode. To do this, right-click the toolbar, choose **Customize**, and click the required button.

**Identify changes made in the current context**

- Click the **Changed by Current IC Edit Context** column header to re-sort the structure into changed and unchanged lines. This allows you to more easily identify the changes made to the structure in the current context.

**Find and make active an existing change object**

When an incremental change is active, all edits are made in the context of that incremental change. Teamcenter shows the ID and name of the incremental change in the incremental change toolbar. If the **Incremental Change** pane states **No Active IC**, no incremental change is active.

1. Click the **Select an Incremental Change context** button at the bottom of the dialog box.

   Teamcenter displays the **Select an Incremental Change context** dialog box.

2. Type either the name or ID of the change object to be displayed. You can use wildcard search characters, if necessary.

3. Click **Find**.

   All change objects matching your selection criteria are displayed in the dialog box. Use the navigation buttons at the bottom of the dialog box to navigate the list.
4. To select an incremental change object for display, double-click the change object in the dialog box list.

**View or edit information about an incremental change**

- Do one of the following:
  - Click the View/edit current IC information button.
  - Click More IC Info in the Incremental Change data tab.

Teamcenter displays the View/edit Change dialog box, which includes the following tabs:

- **IC Attributes** shows the change object name, description, and tag type.
- **Incremental Changes** shows the individual changes to components, attachments, created/deleted data, and occurrence notes that are tracked against this incremental change.

  **Note** A replacement is shown as an override.

- **Effectivity** allows you to view and edit the effectivity of the change object. Double-click a specific release status to open a dialog box containing all the effectivity information for the selected release status.

  **Note** To apply effectivity, your administrator must use Access Manager to assign you to the appropriate group and role.

- **Intents** displays the intents for which the incremental change is valid.

You can create a new intent by clicking the Intent button and typing the appropriate information in the Create Intent dialog box. You can then add the intent to the incremental change by ensuring it appears in the Intent to add box and clicking +. You can also search for existing intents and add them to the incremental change.

  **Note** To make the Intents tab visible, set the EnableIntents preference to true.

You can also use the symbols on a structure line to identify adds, removes, and absolute occurrences. For attachments, these symbols are displayed in the Attachments pane, not the main pane.

**View incremental changes for a structure**

To view all the incremental changes associated with a structure, select a line in the structure and click the Incremental Change Info data tab. For each line, this pane lists:

- **Type**

For attachments only, specifies the type of incremental change, create, delete, add, or remove. Note that edits to attachments are shown as create types.
Managing incremental changes

- **IC Context**
  Specifies the incremental change objects affecting the structure, listed in the order they are applied.

- **Release Status**
  Specifies the release status of the incremental change object, for example, *Production*.

- **Effectivity**
  Specifies the date or unit number effectivity of the incremental change.

- **IC Configured By**
  Specifies the revision rule that configures the incremental change for this structure. This allows you to see if an incremental change is configured and, if so, how it is configured.

For attachment changes, the affected lines and changed relationships are also listed. For occurrence attribute changes, the affected attributes and changed values are also listed.

To see more information about an incremental change, double-click the line in this pane; Teamcenter displays the changes made by the incremental change.

### Find recently used change objects

- Click the **Most Recently Used** button ( ) to display a list of previously used incremental changes from which you can choose.

### Track attachments with incremental changes

You can create an attachment to an item revision and track its status with an incremental change object, as follows:

1. Ensure you have created the appropriate incremental change object and that it is active. The active incremental change is shown in the **Incremental Change Edit Context** box in the incremental change toolbar.

2. Click the **Attachments** pane.

3. Select the structure line corresponding to the *item revision* under which you want to create the attachment.

4. Select the root node (item revision) in the **Attachments** pane.

5. Create a new attachment by choosing **File→New→Dataset/Form**.

Alternatively, you can attach an existing object by copying the dataset or form to the clipboard, then pasting it to the root node (item revision) in the **Attachments** pane.
Chapter 13  Managing incremental changes

Track changes to an attachment

To track changes (edits) made to an attachment, select the attachment (dataset or form) and choose Tools→Incremental Change→Edit Attachment.

Teamcenter also tracks edits if you double-click the dataset or form. With a dataset, the change is tracked when you open the form to edit; with a form, the change is tracked only when you click OK or Apply. Teamcenter tracks the changes by creating a copy of the dataset or form.

The Attachments pane displays the appropriate version of the attachment according to the configured incremental change against which the edits were tracked.

Note  You can view the original, unchanged attachment in My Teamcenter.

Track the creation or deletion of an attachment

You can track the creation of a dataset or form against an incremental change, so that the attachment itself has an effectivity that is derived from the effectivity of the incremental change; this is in addition to the effectivity applied by the incremental change that attaches the attachment to an item revision. This feature may be useful if the attachment is attached to more than one item revision.

- To track the creation of an attachment, select the attachment in the Attachments pane and choose Tools→Incremental Change→Create on Object.

- To track the deletion of an attachment, select the attachment in the Attachments pane and choose Tools→Incremental Change→Delete on Object.

Track creation of an attachment

- Select the attachment in the Attachments pane and choose Tools→Incremental Change→Create on Object.

Track deletion of an attachment

- Select the attachment in the Attachments pane and choose Tools→Incremental Change→Delete on Object.

Track changes retrospectively

If you forgot to activate an incremental change, you can retrospectively track changes by making the incremental change active and doing one of the following:

- Select the item or attachment that you wanted to track as added and choose Tools→Incremental Change→Add.

- Select the item or attachment that you wanted to track as removed and choose Tools→Incremental Change→Remove.

Teamcenter saves edits immediately to the database. It is not necessary to choose the Save Changes command.

You can only make changes to the active incremental change, that is, the one shown in the Incremental Change Edit Context box in the incremental change toolbar. If
you try to edit an incremental change that is not configured by the current revision rule, Teamcenter displays an error message.

Remove incremental changes

You can remove individual incremental changes one of two ways, from the **Incremental Change Information** pane or with an **Incremental Change** menu command.

**Note**  You require write access to edit structures with incremental changes in this way.

For structure and attachment changes:

- If the corresponding change is a remove, Teamcenter deletes it.

- If the corresponding change is an add and the user has write access to the parent BVR, Teamcenter deletes the add but not the occurrence. If you want to remove the occurrence, choose **Edit→Remove**. If the user does not have write access, the deletion request fails.

For occurrence attribute changes, if the change to undo is an add and it is the only change to the attribute, the change and the override value are both deleted. In other cases, only the change is deleted.

Remove an individual change from the incremental change information pane

1. In the **Incremental Change Information** pane, select the structure line of the occurrence or attachment whose changes you want to remove.

2. Select the change to undo and click **Undo Change**, depending on the change type that you want to remove. You can undo multiple changes in a single operation.

Remove changes from an item with the Remove Changes command

1. To remove changes to an occurrence, select the corresponding structure line.

   To remove changes to a dataset or form, select it in the **Attachments** pane.

2. Choose **Tools→Incremental Change→Remove Changes**.

   Teamcenter displays the **Remove Incremental Changes** dialog box.

3. Select the check box next to each change you want to remove, or click **Select All** to remove all changes, then click **OK**.

   **Note**  Occurrence attributes are not displayed in the **Remove Incremental Changes** dialog box; you can only undo them from the **Incremental Change Information** pane.
Split an incremental change

You may want to change the effectivity of some of the incremental change elements in an incremental change. As all elements of an incremental change have the same effectivity, you can only accomplish this by moving some of the incremental change elements into a different incremental change. To do this, choose **Tools**→**Incremental Change**→**Split**. You can move the incremental changes to an existing change object or create a new change object for the purpose.

Exporting and importing incremental change data

You can export changes (deltas) to the structure if they are tracked by incremental changes in two formats—TC XML using a briefcase file or PLM XML. Teamcenter allows you to export the structure changes alone (not the entire structure) without needing to create a new revision. The exported changes contain all the relevant data required by the importing site to achieve the same structure configuration as exists at the exporting site. You can export multiple independent, dependent, or overlapping incremental changes in a single action.

When you use this feature, you must ensure the structure is configured with the required effectivity and revision rules before initiating the export. Effectivity and revision rules are not exported with the changes; you must ensure they are identical in the exporting and importing sites separately.

Teamcenter tracks and exports the following changes when they are tracked by incremental changes:

- Adding a new or existing line to the structure
- Adding a new or existing subassembly to the structure
- Removing a line or subassembly from the structure
- Modifying relative occurrence properties
- Creating or modifying absolute occurrence properties
- Adding a new or existing attachment to a line, for example, a form or dataset
- Deleting an attachment
- Modifying an attachment

When exporting incremental change data using PLM XML:

- The structure must be fully configured.
- Any related changes that are not tracked by an incremental change are not considered for export.
- Changes in the context of incremental changes are considered as export candidates. For example, if you add, modify or remove a structure line in the context of an incremental change, all of its parents up to the top level are exported in addition to the affected line. However, the siblings of lines affected by the incremental changes are not exported.
Managing incremental changes

• If you add, modify, or remove a subassembly under an incremental change, its children exported even though they are not directly affected under the incremental change.

You can create an incremental baseline for a structure that was already exported. This action creates a new revision of the structure. As active changes are carried forward into the new incremental change baseline revision, you may add new incremental change elements (ICEs) affecting the new structure revision to the incremental change revision that is the parent of the original active ICEs. (This incremental change revision may already be exported for the original structure.) Because the new ICEs do not affect the revision of the structure that was exported when you perform a TC XML export, they are exported as a stub. The incremental baseline action has no additional effect on the export of the original structure and the incremental change revisions that affect it.

For more information, see the PLM XML/TC XML Export Import Administration Guide and the Data Exchange Guide.

Export incremental change data using a briefcase file

1. Choose Tools→Export→To Briefcase.

   Teamcenter displays the Export To Briefcase Via Global Services dialog box.

2. Click the Display/Set export options button in the bottom right-hand corner of the dialog box.

   Teamcenter displays the TIE Export Configured Export Default dialog box.

3. Select the check box corresponding to each of the export options you want to use and then click OK.

   Teamcenter closes the TIE Export Configured Export Default dialog box.

4. In the Export To Briefcase Via Global Services dialog box, enter all the required information including Reason, Target Sites, Option Set, Briefcase Package Name, Revision Rule, and Variant Rule, and then click OK.

   [Note] Ensure you select the TIEConfiguredExportDefault transfer option set to export incremental change based deltas.

   Teamcenter displays the Remote Export Options Setting confirmation dialog box.

5. Click Yes.

   Teamcenter starts the export of the product structure using the options you entered.

Import incremental change data using a briefcase file

1. Choose Tools→Import→From Briefcase.

   Teamcenter displays the Import from Briefcase Without Global Services dialog box.
2. Navigate to or type the path and file name of the briefcase file in the **Briefcase File** box. Select **TIEConfiguredImportDefault** from the **Option Set** list.

3. Click the **Display/Set export options** button and select the desired options.

4. (Optional) Select the **Site Check-In after import** box. If you select this box, all objects that are checked out to the unmanaged site are checked in during the import process. Otherwise, you must check them in individually after they are imported.

5. Click **Yes** to begin the import.

   **Note** The importing site does not verify it has the same base structure against which the delta was calculated.

   If you select a collaboration context for export of incremental change deltas, the export file includes the structure context and configuration contexts contained in it, as well as the configured incremental change data.

---

**Export incremental change data using PLM XML**

1. Choose **Tools** → **Export** → **To PLMXML**.

   Teamcenter displays the **PLMXML Export** dialog box.

2. Enter the required export directory, file name, choose the appropriate IC delta transfer mode (for example, **ConfiguredDataExportDefault**), and then click **OK**.

   Teamcenter displays a confirmation message if the export is successfully completed. It generates the output PLM XML file in directory the location shown in the **PLMXML Export** dialog box.

**Import incremental change data using PLM XML**

1. Choose **Tools** → **Import** → **From PLMXML**.

   Teamcenter displays the **PLMXML Import** dialog box.

2. Enter the name of the PLM XML file to import, choose the appropriate IC delta transfer mode (for example, **ConfiguredDataImportDefault**), select the required incremental change context, and then click **OK**.

   Teamcenter displays a confirmation message if the import is successfully completed. It imports only changes to the structure, as captured in the exported PLM XML file.
Chapter

14 Configuring structures by occurrence effectivity

Configuring structures by occurrence effectivity ......................... 14-1

Understanding occurrence effectivity ....................................... 14-1
  Editing occurrence effectivity ........................................... 14-2
  Defining mutually exclusive effectivity ranges ......................... 14-3
  Validating effectivity ..................................................... 14-3

Associate existing effectivity to an occurrence ........................... 14-3

Create effectivity on multiple occurrences ................................. 14-4

Modify the effectivity of an occurrence .................................... 14-4

Remove effectivity from an occurrence ..................................... 14-5

Copying occurrences with effectivity ...................................... 14-5

Setting the date for occurrence effectivity ............................... 14-6
  Combining occurrence effectivity and variant configuration ........ 14-6

Configuring occurrences with multi-unit configuration .................. 14-6
  Create a new effectivity group ......................................... 14-7
  Capture a multi-unit configuration and save it to an effectivity group 14-7
  Set an effectivity group to configure occurrences .................... 14-8

Customizing occurrence effectivity ....................................... 14-10
Chapter

14 Configuring structures by occurrence effectivity

Configuring structures by occurrence effectivity

You can associate an effectivity range with an occurrence. Teamcenter uses the date, unit, or unit and date combination specified in the revision rule to configure occurrences by their effective dates or units.

You can use date effectivity, unit number effectivity, or both, depending on the setting of the CFMOccEffMode preference. If this preference is set to legacy, you can only use date effectivities. If it is set to maintenance, you can create new effectivities in either scheme, but Teamcenter does not upgrade existing definitions. If it is set to upgrade, Teamcenter converts all existing definitions to allow you to configure any structure with date or unit number effectivity. Unit occurrence effectivities are only supported in maintenance and upgrade modes.

Occurrence effectivity is frequently used by manufacturers of military and aerospace products. The end item may correspond to a serial number or the tail number of an aircraft. If you do not split effectivities, you can optionally use the Configuration Item check box to indicate the end item, although Teamcenter does not enforce this use.

Note The import or export of a structure containing legacy occurrence effectivities is not supported. If you require individual structure nodes to have effectivity, consider using incremental change instead of occurrence effectivity. Structures managed with incremental change can be imported and exported using Multi-Site Collaboration.

Understanding occurrence effectivity

Occurrence effectivity information is stored in an effectivity object that one or more occurrences may reference. This object stores:

- The effective date or unit number ranges.
- The user who created the effectivity.
- When the data was created.

Each effectivity object has a unique identifier, which is displayed in the ID column of the structure properties table.

Several occurrences may share an effectivity object. When you edit the effectivity range on one occurrence, Teamcenter applies the change to all occurrences. (This is generally the reason for sharing effectivity.)
You can also pack occurrences if they share the same unit or date range and Access Manager protection status. Packed occurrences are displayed in a similar way to packed structure lines.

For more information, see *Packing or unpacking structure lines*.

You cannot import or export structures containing occurrence effectivity. If you require individual structure nodes to have effectivity, consider the use of incremental change.

For information about incremental change, see *Managing incremental changes*.

If an occurrence does not have an associated effectivity object, Teamcenter assumes it is always effective and it is configured regardless of the date or unit number set by the revision rule, as shown in the following figure.

---

**Occurrence effectivity rule**

When you create an effectivity condition on an occurrence, you change the parent BOM view revision. Consequently, you must have write access to the BOM view revision. However, you can make subsequent changes to the effectivity range if you have write access to the effectivity object, allowing you to edit effectivity data after the structure is released.

**Editing occurrence effectivity**

You can edit occurrence effectivity data outside of the change management process only if the *WSOM_only_edit_effectivity_in_ecm* preference is set to *yes*, as described in the *Preferences and Environment Variables Reference*.

To edit occurrence effectivity data, your Teamcenter user name must be included in the appropriate effectivity user group and role that the administrator defines with Access Manager.

For more information, see the *Access Manager Guide*. 
Defining mutually exclusive effectivity ranges

If you intend to define occurrences as mutually exclusive, manually check that they do not have overlapping effectivity ranges. For example, in the following figure, there are two different types of dynamo and it would be wrong to configure two dynamos at the same time.

![Diagram of Bike dynamo types]

Mutually exclusive effectivity ranges

When specifying effectivity, you can make the association between the occurrences clearer by using the same find number or attaching a special effectivity note to each.

Validating effectivity

You should check that effectivity ranges are consistent within the whole structure, ensuring that effectivity ranges lower down the structure lie within ranges higher up. You may not be aware of the constraints higher up the structure when you initially specify effectivity ranges at lower levels.

Teamcenter does not perform this validation automatically but you can include it as part of a workflow process that approves the effectivity ranges. In certain cases, this validation may not be appropriate, for example, when the structure is shared between different products.

Associate existing effectivity to an occurrence

> **Note** Use this approach only when you want the effectivity to be the same for all occurrences sharing this effectivity object. If you edit the effectivity object's date or unit number ranges, Teamcenter applies this change to all occurrences that reference it.

1. Select the line in the structure representing the occurrence with which you want to associate effectivity.
2. Choose **Tools→Effectivity→Occurrence Effectivity→View, Create and Edit**.
   Teamcenter opens the **Occurrence Effectivity** dialog box.
3. In the **Effectivity ID** box, type the identifier of the effectivity object you want to associate with the occurrence, and press the Enter key. Alternatively, you can search for the effectivity object by clicking **Search** adjacent to the **Effectivity ID** box.
Teamcenter populates the date or unit number table with the ranges from the effectivity object.

4. Click OK and Teamcenter associates the effectivity with the occurrence.

### Create effectivity on multiple occurrences

- Create and associate the same effectivity with several occurrences by selecting the appropriate line in the structure and choosing **Tools→Effectivity→Occurrence Effectivity→Create on Multiple BOM Lines**. The effectivity may be:
  
  - **Shared**
    
    Shared effectivity must have an ID. If you are creating shared effectivity, ensure the **Use shared effectivity** check box is selected.
  
  - **Unshared**
    
    Unshared effectivity has no ID. If you are creating unshared effectivity, ensure the **Use shared effectivity** check box is cleared.

### Modify the effectivity of an occurrence

**Note** Any changes you make affect all occurrences sharing the same effectivity object.

1. Select the line in the structure representing the occurrence whose effectivity you want to modify.

2. Choose **Tools→Effectivity→Occurrence Effectivity→View, Create and Edit**. Teamcenter opens the **Occurrence Effectivity** dialog box.

3. In the **Occurrence Effectivity** dialog box, choose **Units** or **Dates** effectivity, as appropriate, and define the effectivity range.

   - If defining unit effectivity, type the desired effectivity range in the **Units** box. Use the - character within a continuous range, and the , character to separate discontinuous ranges. For example, the unit range 1-5,7-9 defines effectivity for units 1 through 5, and 7 through 9 (but not effective for unit 6).

   - If defining date effectivity, select a cell in the **From** or **To** column, select a date from the calendar (and optionally type a time), and click **Set Date** to place that date in the selected cell. Click the **Clear Date** button to remove the date from the currently selected cell. Repeat this step for additional cells until you have entered all the desired date ranges.

   - Click the **UP** button to add the **and up** (open-ended effectivity) condition to the end of the unit or date effectivity range. If you are defining date effectivity,

   - Click the **SO** button to add the **stock out** condition to the end of the unit or date effectivity range.
Configuring structures by occurrence effectivity

**Note** Teamcenter interprets UP and SO conditions as open-ended for revision configuration purposes. The revision is considered effective for any value greater than or equal to the unit or date value immediately preceding the UP or SO. Stock out indicates that existing stocks of a component revision should be used up before the next revision.

- Check the **Apply Access Manager effectivity protection** check box to apply the predefined Access Manager rules to this effectivity.

- (Optional) For date effectivity, use the **End Item** dialog box to define an end item to qualify the effectivity range. You *must* use this with unit effectivity to specify a product, module, or subsystem that carries the unit number to which this effectivity refers. You can select an end item in one of the following ways:
  
  o Clicking **Open by Name** adjacent to the **End Item** box and searching for an item by identifier and/or name.

  o Copying an item to the clipboard before opening the **Occurrence Effectivity** dialog box and clicking **Paste** adjacent to the **End Item** box.

  o Clicking **MRU** adjacent to the **End Item** box.

**Note** If you want to remove the entered end item, click **Clear** adjacent to the **End Item** box.

4. Click **OK** to save the occurrence effectivity data you entered.

**Remove effectivity from an occurrence**

1. Select the line in the structure representing the occurrence whose effectivity you want to remove.

2. Choose **Tools→Effectivity→Occurrence Effectivity→View, Create and Edit**.

   Teamcenter displays the **Occurrence Effectivity** dialog box.

3. Click **Remove** to clear all boxes, including the identifier.

4. Click **OK** and Teamcenter removes the effectivity object from the selected occurrence. Any other occurrences sharing this effectivity retain their references to the effectivity object.

**Copying occurrences with effectivity**

When you save a BOM view revision with a different name (perform a **Save As** action), Teamcenter copies any occurrences that reference an effectivity object to the new BOM view revision. Thus, the same effectivity ranges apply to the copied structure.
Chapter 14  Configuring structures by occurrence effectivity

When you copy, cut or paste, Teamcenter does not reproduce any references to effectivity objects in the copy occurrences.

Setting the date for occurrence effectivity

Teamcenter configures the occurrence effectivity by the date defined in the current revision rule. Teamcenter uses an explicit date entry, if the current rule contains one. If the rule has no date entry, the effective date defaults to today, but you can manually set a different date using the Tools→Revision Rule→Set Date/Unit/End Item menu command.

For more information, see Defining a date entry and Set date/unit/end item.

You can choose to show only the configured occurrences, or all occurrences. You can toggle this setting by choosing View→Show Unconfigured by Occurrence Effectivity. If you display the EOC - Effective Occ. Config’d column in the structure properties, occurrences that are configured show a Y. If the occurrences are not configured, the column is blank.

Occurrences are configured if:

- The effectivity range encompasses the date specified by the current revision rule.
- They have no effectivity object. Such occurrences are always configured, regardless of date.

Combining occurrence effectivity and variant configuration

Variant and occurrence date effectivity are occurrence-based configuration methods that operate independently. The View menu includes separate commands to show or hide occurrences that are unconfigured by the two methods. In some cases, you may want to view a specific variant of the product at a particular effective date. In this case, you hide occurrences that are unconfigured by both date and variants. Similarly, you may want to view a generic product at a particular date, in which case, you would hide occurrences unconfigured by date only. To show how a single variant changes with effective date, you can hide unconfigured variants only.

Configuring occurrences with multi-unit configuration

Teamcenter allows you to configure product structure occurrences of an assembly based on specified multiple end items and the unit effectivity ranges for each of those end items. You can do impact analysis and eliminate the duplicate work required to maintain different product structures and complicated manual reconciliation.
A combination of multiple end items and range of units for each end item used to configure product structure occurrences is referred to as a **multi-unit configuration**. To enable the creation of multi-unit effectivities, the administrator must set the **Fnd0EnableMultiUnitConfiguration** global constant to **true** at each site with the Business Modeler IDE.

This feature allows you to:

- Specify multi-unit configurations and save them as effectivity groups.
- Save a combination of effectivity groups and revision rule as a configuration context. You can use the saved configuration context to apply the effectivity groups and revision rule to configure occurrences.
- View the configured structure in Lifecycle Visualization, CAD tools, and the embedded viewers of appropriate rich client applications.
- Configure occurrences by matching the occurrence effectivity with the multi-unit configuration.
- Configure occurrences that are added and deleted by incremental changes by matching the incremental change effectivity with the multi-unit configuration.

Teamcenter displays the **Revision Rule Entry** value for an incremental change (IC) configured by a multi-unit configuration as **Effectivity Group**. Therefore, ignore the status of this check box in the **IC Information** pane.

When an occurrence has occurrence effectivity and it is removed in the context of an IC, the occurrence is not configured if the multi-unit configuration matches the effectivity of the removing IC. This occurs whether the occurrence effectivity matches partially or completely with the multi-unit configuration.

Multi-unit configuration does not support nested effectivity and effectivity mapping.

### Create a new effectivity group

1. In My Teamcenter, choose **File→New→Item**.

   Teamcenter displays the **New Item** dialog box.

2. Select **Effectivity Group**, enter the necessary name, description, and identifier, and then click **Finish**.

   Teamcenter creates the base revision of the new effectivity group. (Effectivity groups cannot be revised, and you are unable to create further revisions of the new group.)

### Capture a multi-unit configuration and save it to an effectivity group

1. In My Teamcenter, right-click an effectivity group revision and choose **View/Edit Multi-Unit Configuration**.
Teamcenter displays the **View/Edit Multi Unit Configuration** dialog box with the **View/Edit Multi Unit Configuration** pane visible.

**Note** The **Most Recently Used** option is not available in this dialog box. Also, the **Open By Name** box is not available on the **Effectivity Groups** pane in this dialog box.

**Caution** This is a modeless dialog box. It allows you to copy items from other locations, such as your **Favorites** folder, and paste them into the dialog box. However, it also allows you to perform other actions, such as **Revise** and **Close** commands in My Teamcenter with the dialog box open.

If you open this dialog box using **View/Edit** in the **Set Date/Unit/End Item** dialog box (**Effectivity Groups** tab), the dialog box is modal and does not allow you to paste between applications.

2. Enter the necessary end item and unit range information, and then click **Add**, **Edit**, **Remove**, or **Undo** to update the effectivity group, as follows:

   - To add an end item unit range, enter the end item ID and the effective unit range and click the **Add** button. You can also search or browse for an end item to populate the **End Item** box. You can also copy the end item from your **Favorites** folder in My Teamcenter and paste it here. You can specify a combination of units or unit ranges in comma-separated format.

   - To remove an end item unit range, select it in the table and click **Remove**.

   - To edit an end item unit range, select it in the table and the system populates the **End Item ID** and **Unit Range** boxes from the selected entry. After you make the required changes, click **Modify**.

   - To revert the last change made in the dialog box, click **Undo**.

   **Note** **Undo** allows you to go back one level to the previous state in the dialog box. Thereafter, any subsequent clicks on the **Undo** button cause the dialog box to toggle between its current state and previous state.

   **Note** You can view and edit effectivity groups with certain limitations. Use the **View/Edit** button in the **Effectivity Groups** pane of the **Set Date/Unit/End Item** dialog box to add or modify the end items by manually typing the necessary data. You cannot search for or copy and paste end items here.

**Set an effectivity group to configure occurrences**

You set an effectivity group or groups to configure the product structure occurrences in addition to the revision rule.

1. Load the assembly to configure and choose **Tools**→**Revision Rule**→**Set Date/Unit/End Item**.

   Teamcenter displays the **Set Date/Unit/End Item** dialog box.

2. Enter the effectivity group identifier in the **Effectivity Group** box, and then click **Replace**, **Insert**, or **Append** to update the list of groups.
3. (Optional) To view the multi-unit configuration on an effectivity group, select it and click **View/Edit**. The system displays the **View/Edit Multi Unit Configuration** dialog box, as described previously. If you have the necessary access privileges, you can also modify the configuration.

When you apply the configuration, the system matches the occurrence effectivities configured for each occurrence with the multi-unit configuration set in the effectivity groups. Any occurrence whose occurrence effectivity is valid for any of the end item and unit range entries in the effectivity groups is displayed. An occurrence is loaded only once even if its effectivity matches more than one end item entry in the effectivity groups set in the session.

**Caution**  You can configure product structures with incremental changes using effectivity groups. However, only limited support is provided to configure occurrences with incremental changes using multi-unit configuration and the following limitations apply:

- You can configure only the addition and deletion of occurrences using effectivity groups. Other edits in the context of incremental change cannot be configured.

- An **add** occurrence edit is effective if the multi-unit configuration partially overlaps the effectivity of the incremental change.

- A **remove** occurrence edit is effective if the multi-unit configuration completely overlaps or is within the limits of the effectivity of the incremental change. That is, a partial overlap is sufficient to configure the **remove** edit. If there are multiple **remove** incremental changes, Teamcenter compares each of them with the multi-unit configuration separately. (It does not calculate the total **remove** effectivity and compare a single value with the multi-unit configuration.)

- Teamcenter evaluates the configuration of an occurrence based on an incremental change independently of its occurrence effectivity.

- If Teamcenter finds competing incremental changes (one adding the occurrence and the other removing it) and both can be configured with effectivity groups, it gives precedence to the **add** occurrence edit.

The following examples show how occurrence effectivity and incremental change interact.

<table>
<thead>
<tr>
<th>Structure line number</th>
<th>Type</th>
<th>Occurrence effectivity (explicit or implied)</th>
<th>Effectivity on removing IC1 and removing IC2</th>
<th>Multi-unit configuration set on BOM window</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Component</td>
<td>EndItem(1-20)</td>
<td>IC1(-) → EndItem1(1-9) IC2(-) → EndItem(10-20)</td>
<td>EndItem1(1-9)</td>
<td>Occurrence not configured.</td>
</tr>
</tbody>
</table>
Customizing occurrence effectivity

You can customize Teamcenter behavior when the user applies or sets occurrence effectivity on a BOM line.

To allow customization of the behavior when setting effectivity on an occurrence, the **bl_occ_effectivity** BOM line property is modifiable, and a setter method is provided on this property. Use the setter method of the property to attach an extension point if required.

To use this enhancement, the **CFMOccEffMode** preference must be set to **upgrade** or **maintenance**, not to **legacy**.

For more information about how to define and attach extension points to a setter method on a run-time BOM line property, see the *Business Modeler IDE Guide*. 
Chapter

15 Configuring structures by classic variants

Configuring structures by classic variants .................................. 15-1
Elements of classic variants ...................................................... 15-2
View and edit variant data ......................................................... 15-2
Configure to load ................................................................. 15-3
Using classic variants ............................................................. 15-4
  Example of using classic variants ........................................... 15-4
  Creating basic variant data ................................................... 15-5
  Setting a variant rule .......................................................... 15-5
  Storing variant data .......................................................... 15-7
  Placing variant data on a structure ....................................... 15-8
Configuring mandatory choices and accessories ......................... 15-8
Identifying unique variant data ................................................. 15-9
Identifying unique options ...................................................... 15-9
Placing variant data ............................................................. 15-10
Managing variant data by control change .................................. 15-11
Changing the allowed values of an option ................................ 15-11
Sharing structure ................................................................. 15-12
Configuring complex variant conditions ................................... 15-13
Creating a separate item for a particular variant ......................... 15-14
Using saved variant rules or default and derived values ............. 15-15
Creating substitutes of a variant component ............................. 15-15
Populating variant data ......................................................... 15-15
Find the location of variant data ............................................. 15-17
Chapter

15 Configuring structures by classic variants

Configuring structures by classic variants

Teamcenter supports two methods of variant configuration, classic variants and modular variants. For information about how to choose between these two methods, see *Getting Started with Product Structure*. Siemens PLM Software recommends that you do not create both classic variants and modular variants in the same product structure, as this may cause in unpredictable results.

Classic variant configuration allows you to create options (for example, color) and allowed values for each option. You can then associate these options with an item revision. For example, you might create an option called `color` with allowed values of `red` and `blue`. You usually implement variant configuration against a top-level assembly, but it is possible to implement them anywhere in the structure. You can then define a variant condition on those occurrences subject to variant rules. A variant rule is a set of options and values (for example, `color = red, material = cotton`) that is stored in the database. For example, you can specify `only load IF option color = value red` in the variant rule for the example option and allowed values. To configure a particular variant of the assembly or product, you must set the appropriate variant rule.

To prevent users from specifying illegal option values or combinations, you can set `default` option values, for example, `color = blue`, in the variant rule. You can also create variant rule checks, for example, `error if color = green AND material = cotton`.

You control changes to variant data by associating it with item revisions and BOM view revisions.

If you install the Teamcenter Integration for NX, classic variants do not synchronize with NX expressions. However, you can configure saved variant rules from NX, although you cannot interactively set variant rules. Also, unlike configuration in Structure Manager, you can apply multiple saved variant rules from NX. Classic variants suit situations where the user chooses one option value from a set of values. Only text option types supported.

Classic variant configuration supports:

- Options that are a mandatory choice or an accessory.
- Components that may be configured by more than one option.
- Variant assemblies that may be shared between products.

Classic variant configuration does not support:
Chapter 15  Configuring structures by classic variants

- Automatic creation of variant item.
- Updating of existing variant items.

*Note*  These capabilities *are* supported in modular variant configuration.

Elements of classic variants

The following table lists elements that may appear in a structure that is managed by classic variants.

<table>
<thead>
<tr>
<th>Element</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraint</td>
<td>An expression that sets an option value according to the values of other options, that is, derived defaults.</td>
</tr>
<tr>
<td>Derived default</td>
<td>A default value that depends on a certain condition (for example, <em>radio = stereo</em> if <em>car type = GLX</em>). A derived default is attached to an item revision but applies globally to a loaded structure.</td>
</tr>
<tr>
<td>Option default</td>
<td>A specific default value for an option (for example, <em>engine = 1200</em>). A fixed default is attached to an item revision but applies globally to a loaded structure. It can be used internally to set private from public option values or to set public option values on the child module.</td>
</tr>
<tr>
<td>Option</td>
<td>A parameter of variability. Options have a string type and a name.</td>
</tr>
<tr>
<td>Variant (structure)</td>
<td>A specific structure that is configured by applying a variant rule.</td>
</tr>
<tr>
<td>Variant condition</td>
<td>A condition that an engineering user sets on an occurrence to specify the option values that configure the occurrence (for example, <em>Load IF engine = 1200</em>). More complex condition statements may also be defined.</td>
</tr>
<tr>
<td>Variant rule</td>
<td>A collection of option values, typically set by a marketing user, to determine the variant of the structure to configure (for example, <em>car type = GLS, engine = 1200, gearbox = manual</em>). A saved variant rule is a persistent database object.</td>
</tr>
<tr>
<td>Variant rule check</td>
<td>A condition that specifies any option values or combinations of values that are not allowed. A variant rule check is attached to an item revision. Also called an <em>error check</em>.</td>
</tr>
</tbody>
</table>

View and edit variant data

- To view and edit classic variant data, display the data pane by clicking the *Show/Hide Data Panel* button 📊, then clicking the *Variants* tab.
The upper part of the **Variants** pane shows the variant data tree, presenting any variant data stored on the item revision represented by the structure line currently selected in the structure. The tree has three branches:

- Options
- Option defaults
- Rule checks

If the item revision has variant data, the branch has a + (plus) symbol and you can expand the branch to view the data.

The lower part of the pane allows you to create and edit variant data for the selected data, if you have write access to the item revision. You can also view further details of specific variant data, for example, the allowed values of an option.

**Tip** Use the `PSE_show_option_item_prefix` preference to show or hide the owning item ID as a prefix to the option name. For details, see the *Preferences and Environment Variables Reference*.

### Configure to load

You can eliminate the loading of unconfigured variants and consequently complete loading of the structure more quickly.

1. Choose **View→Enable Filtering Unconfigured due to Classic Variants**.

   Teamcenter enables configure to load filtering.

2. Send the structure to Structure Manager.

   If the `PSEVariantsMode` preference is set to **hybrid** or **modular**, Teamcenter displays the **Configure** dialog box. If it sent to **legacy**, it displays the **Variant Rule** dialog box.

3. Enter an option value for any item.

   Teamcenter activates the **Filter unconfigured BOM lines due to Classic Variants** check box.

4. Select the **Filter unconfigured BOM lines due to Classic Variants** check box.

   When the structure is subsequently loaded, Teamcenter does not load lines that are unconfigured by the selected variant rule. The title bar of the structure tree pane is colored green to indicate that filtering is applied.
You cannot disable this selection when the structure is loaded and it persists each time the structure is loaded. To change it, you must follow the previous steps and clear the Filter unconfigured BOM lines due to Classic Variants check box.

Enable or disable use of the configure to load feature with the PSEEnableFilteringUnconfigdDueToClassicVariantsPref preference; use the ConfigureToLoadEnableDefaultVariantConfig preference to enable or disable the Do not show this dialog automatically when opening BOM check box in the variant configuration dialog box.

Using classic variants

Variants allow you to create options (for example, color) and allowed values of those options (for example, red and blue) and associate them with an item revision. You usually do this at a top-level assembly, but you can implement variants anywhere in the structure. You then define a variant condition (for example, only load IF option color = value red is specified in the variant rule) on those occurrences that are subject to variant rules.

To configure a particular variant of an assembly or product, set a variant rule (a group of options and values such as color = red, material = cotton). This can be stored in the database and retrieved later.

To specify option values or combinations that are not allowed, you can also set default option values (for example, color = blue) for the variant rule and create variant rule checks (for example, error if color = green AND material = cotton). This functionality supports:

- Options that are a mandatory choice or an accessory.
- Components that are configured by more than one option.
- Variant assemblies that are shared between products.

Changes to variant data are controlled by association with item revisions and BOM view revisions.

You can save a variant rule in Structure Manager as a persistent workspace object, then use it in the Multi-Structure Manager application, thin client, or NX client. You can also send the object to another user.

Example of using classic variants

In this basic example of how to use variants, a top-level assembly is identified as Car Model G. It includes a body assembly and two choices of engine (1200 and 1600), as shown in the following figure. You create variant data on the structure to allow configuration of one or the other engine.
Creating basic variant data

To create the necessary basic variant data, do the following:

- Define options

  Create an engine option on the item Car Model G with allowed values 1200 and 1600. You can later create other necessary options and allowed values. These options configure components lower in the structure.

- Add variant conditions

  Having defined the options that determine different configurations of the car, you now specify a variant condition on each engine component to configure it appropriately. For the 1200 Engine component, you define a condition that loads this component only if the option engine is set to a value of 1200 (that is, Load IF engine = 1200). Similarly, define a condition for the 1600 Engine (that is, Load IF engine = 1600).

  You have now created all the static variant data necessary to configure a variant BOM. These steps are typically performed by design engineers or a specialized configuration department.

  A specific option value does not necessarily relate to a single component. Variant conditions including a single option value can cause any number of components at different places in the structure to be configured or not configured.

Setting a variant rule

To configure a particular variant of a structure, you use a variant rule. The variant rule defines the options in the structure for which you can set values. The marketing and sales organizations typically use the variant rule to configure a particular variant of the product. However, such configurations are limited to those that the design engineer allowed when creating the variant data on the structure.

Some options may already have values set as part of the basic variant data, as described previously. The rules define further variant data that can be created on the structure.
Chapter 15  Configuring structures by classic variants

There are three ways of setting a valid variant rule that configures an allowed variant of the product. This additional variant data is stored on an item revision.

- Variant rule checks

  Variant rule checks prevent the designer from defining option values or combinations of option values that are not allowed, as shown in the following figure.

<table>
<thead>
<tr>
<th>Options and Allowed Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>car type = GLX, GLS, LS</td>
</tr>
<tr>
<td>engine = 1200, 1600</td>
</tr>
<tr>
<td>gearbox = manual, automatic</td>
</tr>
<tr>
<td>fog lights = yes, no</td>
</tr>
</tbody>
</table>

A variant rule check consists of a condition (for example, engine = 1200 AND gearbox = automatic) and a warning message (for example, Incompatible engine and gearbox). Both the condition and the warning message are displayed if the condition is met when a user attempts to set values in the variant rule. Teamcenter displays the error when the user tries to specify the condition, rather than allowing the user to set a number of values and then displaying a number of error messages.

There are two main uses of checks:

- To prevent incompatible option values. For example, you want to prevent users from configuring a 1200 engine with an automatic gearbox if this combination is not allowed for technical reasons.

- To limit the range of allowed values for a specific option in a particular product. This may be necessary when assemblies are shared between different products in which there are different allowed option value ranges.

- Derived defaults

  Derived defaults allow one option value to set any number of other related option values. Options that potentially have derived values are indicated in the variant rule as potentially derived and must be completed last. In the example in the following figure, if the option car type is set to GLX, the option radio is set to stereo by default.
Defining derived values

- Fixed defaults

Fixed defaults allow an option to be set to a specific value. In the example in the previous figure, the default value for fog lights is **no**; unless specified, fog lights are not fitted. The fog light components are not shown at this level of the structure.

Storing variant data

Variant data can be stored on the following objects:

- Item revision:
  - Options and allowed values
  - Fixed and derived default values
  - Variant rule checks

- Occurrence:
  - Variant conditions
  - Controlling changes

Changes to variant data can have a dramatic effect on variant configuration. You can control changes with techniques such as access control lists (ACLs), locking, and release procedures.

Any user can set the variant rule to configure a particular variant. Users creating variant data must ensure that the necessary variant rule checks exist so that only valid rules can be set. You can use menu entry suppression to hide the variant rule entry from certain users and groups.

Variant data is owned by a specific revision of an item. As the item evolves, it may be necessary to change the set of allowed values for a particular option or possibly to add further options.
Placing variant data on a structure

When populating a structure with variant data, you must decide where to place options, defaults, and variant rule checks; typically, you attach this data to assembly items. The following types of variant data may be placed on a structure:

<table>
<thead>
<tr>
<th>Type of variant data</th>
<th>Purpose</th>
<th>Best practice</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marketing variant data</td>
<td>Set by marketing or customers to specify the required variant of the product.</td>
<td>Stored at the product level.</td>
</tr>
<tr>
<td>Engineering variant data</td>
<td>Set by design engineers to control detailed variant information that does not concern customers.</td>
<td>Stored at lower levels, attached to specific modules or assemblies.</td>
</tr>
</tbody>
</table>

**Note** Option identification names are not unique in the database; they are unique only to the owning item. You must specify an item when the option is not unique. Options are generally displayed with their owning item.

Configuring mandatory choices and accessories

In most structures, there are generally two categories of options:

- **Mandatory choice**
  
  In certain cases, the user must make a choice, for example, of an engine or radio. The user must choose one of many, mutually exclusive, options. You can set a default option, for example, radio = mono.
  
  When setting variant conditions on a set of mutually exclusive occurrences in this way, the product design engineer must ensure the conditions have the desired effect.
  
  One way to indicate mutually exclusive components is to set them all at the same find number in the structure. You could also create a special note type to give further information about variant data, for example, the associated occurrences.

  **Note** The APICS term option corresponds to mandatory choice in Teamcenter.

- **Accessory**
  
  Accessories are options for which the user does not have to make a choice. They are additional components and the user can select none, some, or all of the accessory options. By default, no accessories are configured. For example, fog lights may be offered as an accessory option.

  Siemens PLM Software recommends the following strategies:

  1. Use yes and no values for an accessory option.
  2. Set a Load IF <accessory option 1> = yes variant condition on the component occurrence or occurrences that are loaded if the accessory is chosen.
o Set an `<accessory option 1> = no` fixed default. As a result, Teamcenter displays `No` in the `Variant Rule` dialog box for the option, making clear that the option is an accessory and is not provided unless specifically requested (that is, set to `Yes` in the variant rule).

### Identifying unique variant data

Teamcenter prevents you from entering inconsistent data when defining variants. These checks are especially significant if you have a large volume of data to specify on a variant BOM. For example, Teamcenter make the following checks:

- You cannot specify a value for an option that you have not defined.
- If the option name is not unique, Teamcenter prompts you to specify an owning item.
- When you specify defaults, Teamcenter warns if you attempt to specify a default that would trigger an existing variant rule check.

If the variant rule check is not currently loaded (because the item to which it is attached is not loaded), Teamcenter prompts you to load the item with the variant rule check when you expand the structure.

### Identifying unique options

Option names are not unique in the database; they are unique to a particular owning item. Thus, an option is only fully identified when you also specify the owning item.

Teamcenter does not force you to define unique option names, allowing more than one item (product) to use the same option name, for example, `engine`. The set of allowed values for a particular option are unique to the owning item, for example, `engine` in owning item `Car Model G`, as shown in the following figure. With this owning item, the option has allowed values `1200` and `1600`, but `engine` in owning item `Car Model H` may have different values, for example, `1200`, `1600` and `2000`.

When you define an option name, Teamcenter prompts for the owning item. In dialog boxes and data displays, it then prefixes the option with the owning item to avoid any ambiguity.
Placing variant data

When you populate a structure with variant data, you decide the items to which options, defaults, and variant rule checks are attached.

Guidelines for the location of variant data follow:

- **Options**
  
  Most often, you attach options to the top-level item in the product.
  
  However, if an assembly is shared between products, you must attach any options directly to the assembly. For additional information, see *Sharing structure*.

- **Default option values**
  
  Generally, you attach default option values to the assembly item to which they apply. For the same option, defaults set at the top of the structure take precedence over any defaults lower down the structure tree.
  
  If you load the top-level structure, any defaults are always configured if there is conflict of option values.
  
  If option values are specified at lower levels of the structure, the option value that takes precedence. In this case, users who set defaults at lower levels in the structure may also have to duplicate them at the top level to ensure they take effect.

- **Variant rule checks**
  
  You can attach variant rule checks to the top-level item in the product. However, Teamcenter does not make these checks if the item to which they are attached is not loaded, as would happen if you open an assembly lower down the structure.
  
  If this occurs, you can duplicate the variant rule checks on assemblies lower down the structure, where relevant. If you duplicate many checks, they may only be meaningful in the context of the top-level item.

The arrangement of variant BOMs always depends closely on the product type. The structure of the BOM also influences your approach to variant management, for example, the modularity of the structure with respect to the options and structure reuse in other products.
Managing variant data by control change

An option is owned by a specific revision of an item. As the item evolves, you may change the set of allowed values of a particular option, or add or remove options and their allowed values. These changes affect the variant configuration and should be subject to the same change controls as any other structure modification.

You can control changes to variant data with Teamcenter release procedures implemented with Workflow. When an item revision and its associated BOM view revision are released and locked, you cannot make changes to the variant data. For more information, see the Workflow Designer Guide.

Changing the allowed values of an option

When an assembly is released, both the item revision and the BOM view revision are locked to prevent change. For example, dashboard assembly revision A020/A is released to production and offers the choice of none, mono, or stereo radio, as shown in the following figure.

Subsequently you withdraw the radio option and add a stereo-cassette option. The following figure shows the necessary changes:

- You change the allowed value of the radio option, removing the none value and adding the stereo-cassette value. As a result of this change, you revise the owning item A020 to revision B.

- You revise the dashboard assembly and add a new component P25 - Stereo-Cassette and the appropriate variant condition. You also remove component P30 - Blank Plate.
Changing option allowed values

If a revision rule configures revision A of the dashboard assembly, you see the original set of components. Teamcenter presents \textit{none}, \textit{mono} and \textit{stereo} values of the \textit{radio} option in the variant rule.

If revision B of the dashboard assembly is configured, you see the modified assembly and are presented with the modified \textit{mono}, \textit{stereo}, and \textit{stereo-cassette} values of the \textit{radio} option.

Depending on your business practices, you may also revise the body assembly to:

- Remove the component, \textbf{P080 - Wing Without Hole}, which is no longer necessary.

- Remove the redundant variant condition from the occurrence of \textbf{P085 - Wing With Hole}.

- Optionally, modify the variant conditions on the aerials. This modification is not essential and the audio system still behaves correctly if the change is not made.

Sharing structure

Classic variants supports sharing of variant structures between products.

For example, a dashboard assembly is used in two different products \textbf{Car Model G} and \textbf{Car Model H}, as shown in the following figure. Because the dashboard assembly is shared between products, you should place options that control variants of the assembly (for example, \textit{radio}) on the assembly item and not higher up the structure. The \textit{radio} option must have the entire range of values that are allowed in all products in which the assembly is used, that is, \textit{mono}, \textit{stereo}, \textit{stereo-cassette} and \textit{stereo-CD}.

Teamcenter applies a variant rule check to each product, preventing you from specifying a variant rule for the \textit{radio} option that is not allowed within the product, for example, \textit{stereo-cassette} for \textbf{Car Model G} and \textit{stereo-CD} for \textbf{Car Model H}.

You must revise the dashboard assembly item, if the relevant parts are released and locked to add the extra allowed values to the option. You can change the structure at the same time to add the new variational components.
Configuring structures by classic variants

Shared Structure

Car model H (A02000) is now produced with a different choice of radios to Car Model G (A01000). A variant rule check is put on the owning product to limit the choice of values.

Warning: "Invalid Option Value"
IF radio = Stereo

Warning: "Invalid Option Value"
IF radio = Stereo-Cassette

Warning: "Invalid Option Value"
IF engine = Mono

Warning: "Invalid Option Value"
IF engine = Stereo

Derived Default:
IF car type = GLX, radio = stereo

Derived Default:
IF car type = GLS, radio = Stereo

Car Model H
A02000/A

Car Model G
A01000/A

Radio = Mono, Stereo, Stereo-Cassette, Stereo-CD

Load IF radio = Stereo-CD

Load IF radio = Stereo-Cassette

Load IF radio = Stereo

Load IF radio = Mono

Shared Structure

Configuring complex variant conditions

Although you can define variant conditions only from simple Boolean expressions (for example, **Load IF car type = GLX OR car type = GLS**), you can construct more complex conditions when configuration depends on more than one option.

For example, a special facia may be required if the customer chooses car type option **GLX** or **GLS** and also chooses the **Fog Lights** option. (Additional switches are necessary on the dashboard to control the fog lights, so the special facia is required.)

The special facia requires the following variant condition to meet this requirement:

```
Load IF fog lights = yes and (car type = GLX or car type = GLS)
```

You can construct the following variant condition in the **Variant Condition** dialog box to define this requirement:

```
fog lights = yes
AND car type = GLX
OR car type = GLS
```

When you have built this basic condition, select the GLX and GLS lines and click the (..) button. Teamcenter places brackets around the selected clauses, as follows:

```
fog lights = yes
```
Creating a separate item for a particular variant

You can create items with specific part numbers for a particular variant. You can then include the generic structure as a single component of the particular variant assembly of the product. You can do this for the top-level product and also for any subassemblies in it that have their own set of options.

On the new item for the particular variant, you set fixed default values for all the options, as shown in the following figure (for example, **A0100 Car Model G - Variant 1**). These fixed defaults override any other defaults that are set lower down the structure at the generic item level or lower. You are therefore certain of the settings resulting from these defaults for a particular variant.

Alternatively, you could use a saved variant rule instead of fixed default values, as this approach is easier to set up. The saved variant rule contains the list of default option values.
Using saved variant rules or default and derived values

You can use both saved variant rules and default and derived option values to configure a bill of materials from a single high level entity. In the case of saved variant rules, this entity is a variant rule workspace object. In the default/derived values case, this entity may be a single option that is defined on the top level assembly from which all other option values are derived. Alternatively, you can use the extra item as described in Creating a separate item for a particular variant.

The derived defaults method allows you to define dependencies as an integrated part of the structure. Its main disadvantage is the complexity of setting up derivation rules.

Saved variant rules are simpler to set up, but they are not as tightly coupled with the structure.

Siemens PLM Software recommends you use saved variant rules when initially building your structure. You can then convert to default and derived values once you have fully analyzed the interactions.

Saved variant rules may provide a useful configuration mechanism to store marketing packages after the structure is released.

Creating substitutes of a variant component

You can create substitutes of variant components in the same way as other components that do not have a variant condition.

For more information, see Defining substitute components.

Populating variant data

There are many different ways to apply variant data that affect the ease of maintenance of the product and the use of shared subassemblies. If you populate the structure with variant data that is stored on the optimal item revisions, you make future changes easier to manage. Some of these considerations are discussed in Placing variant data.

The following procedures for populating variant data all reference the same example. In this example, the product Car Model G shown in the following figure has a variant structure that depends on the values the customer chooses for the following mandatory and nonmandatory options:

- Car type – GLX, GLS or LS
- Engine – 1200 or 1600
- Gearbox – manual or automatic
- Radio – none, mono, or stereo
- Aerial type – standard or electric
- Accessory option fog lights – yes or no
The following considerations also apply, depending on customer selections:

- If the customer does not want a radio (radio = none in the variant rule) and a blanking plate is fitted. Teamcenter configures the wing (fender) with no hole and no aerial.

- If the customer chooses one of the radio options, Teamcenter configures the wing with the hole (for an aerial), and the standard aerial or the electric aerial.

- If the customer does not specify a particular type of aerial, the standard aerial is fitted. This is the fixed default.

- If the customer specifies car type GLX, Teamcenter configures a stereo radio. This is the derived default.

- The 1200 engine cannot be fitted to an automatic gearbox. This combination is excluded by a variant rule check.

The radio option is stored on the dashboard assembly for later use in another product, Car Model H.
Populating variant data

Before applying variant data, you should create the necessary items and structure. To add the variant data, you may want to open the whole structure in a Structure Manager window to make navigation of the entire structure more straightforward.

Find the location of variant data

- As you create variant data, you may want to check the location of variant data that already exists. To do this, check the **HVD - Has Variant Data** column in the structure navigation tree—each item that has associated variant data shows a Y in this column.

The node of any item that has variant conditions displays the **Variant Data** image in the **Variant Conditions** column in the structure tree.
Working with options

You can create, modify, rename, remove or delete options for variants.

Create options

Define the options of the structure, as follows. The examples refer to the structure of A01000 - Car Model G, as described in Populating variant data.

1. Choose View→Show/Hide Data Panel or click the Show/Hide Data Panel button on the toolbar.

Teamcenter opens the data pane.

2. Click the Variants tab and select the line representing the owning item revision that stores the variant data. Typically this is the top-level item in the structure, in this example, A01000 - Car Model G.

3. Click the Options branch in the variant data tree.

Teamcenter displays the Option dialog box.

4. In the Option dialog box, enter the necessary options, for example:
   - In the Name box, type engine.
   - Optionally, enter the engine size in the Description box.
   - Type an allowed value (1200) and press Enter or + (plus). Teamcenter now displays the allowed value 1200 in the list of allowed values.
   - Type the other allowed value (1600) and press Enter.

5. Click Create ✦ to create the option. A + (plus) symbol appears against the Options branch in the variant data tree indicating that Teamcenter created the options.

6. Repeat steps 4 and 5 to define the other options on the same assembly, for example:

<table>
<thead>
<tr>
<th>Option</th>
<th>Allowed values</th>
<th>Owning item</th>
</tr>
</thead>
<tbody>
<tr>
<td>car type</td>
<td>GLS, GLX, LS</td>
<td>A01000 - Car Model G</td>
</tr>
<tr>
<td>gearbox</td>
<td>automatic, manual</td>
<td>A01000 - Car Model G</td>
</tr>
<tr>
<td>fog lights</td>
<td>yes, no</td>
<td>A01000 - Car Model G</td>
</tr>
</tbody>
</table>

7. Repeat steps 2 through 6 to define the options on other assemblies, for example, the following body and dashboard assemblies:

<table>
<thead>
<tr>
<th>Option</th>
<th>Allowed values</th>
<th>Owning item</th>
</tr>
</thead>
<tbody>
<tr>
<td>aerial</td>
<td>standard, electric</td>
<td>A0200 - Body Assy</td>
</tr>
<tr>
<td>radio</td>
<td>none, mono, stereo</td>
<td>A020 - Dashboard Assy</td>
</tr>
</tbody>
</table>
8. Click Save  to save the changes. If you forget to do this, Teamcenter prompts when you select another BOM line. A Y appears in the Has Variant Data (HVD) column for Car Model G.

**Change option values**

1. If necessary, choose View→Show/Hide Data Panel or click the Show/Hide Data Panel button on the toolbar.
   Teamcenter opens the data pane.

2. Click the Variants tab and select the structure line with the item revision that owns (stores) the option whose values you want to change. If you are unsure of the owning item, you can identify this from the Variant Rule dialog box.

3. Expand the Options branch in the variant data tree.

4. Select the option whose values you want to change.
   Teamcenter displays the allowed values in the Option dialog box.

5. In the Option dialog box, do one of the following:
   - Enter another allowed value and press the Enter key.
   - Select the value and click – (minus button) to remove an allowed value from an option.

6. Click Modify  and Teamcenter updates the contents of the selected option.

7. Click Save  to save the changes.

**Note** Any variant data that references removed option values can no longer be set as these values are not available for selection. You typically create a new revision of the item if you need to preserve the historic data.

**Create new options from existing options**

When an option has values similar to those on an existing option, it may be quicker to create the new option values from those of the existing option:

1. If necessary, choose View→Show/Hide Data Panel or click the Show/Hide Data Panel button on the toolbar.
   Teamcenter opens the data pane.

2. Click the Variants tab and select the option to copy in the Options branch of the variant data tree.
   Teamcenter displays the Option dialog box, prepopulated with the values and name of the original option.

3. In the Option dialog box, type a new name for the option (duplicate names within an item are not allowed) and modify the values as required.

4. Click Create  to create the new option.
5. Click **Save** to save the changes.

**Rename an option**

1. If necessary, choose **View→Show/Hide Data Panel** or click the **Show/Hide Data Panel** button on the toolbar.
   Teamcenter opens the data pane.

2. Click the **Variants** tab and select the option to rename in the **Options** branch of the variant data tree.

3. Type a new name and click **Modify** to modify the option.

4. Click **Save** to save the changes.

**Note** You cannot rename an option that is used in more than one revision of the item.

Also, you cannot rename an option that is shared between sites in a Multi-Site Collaboration environment.

**Remove an option**

To remove an option from its owning item revision:

1. If necessary, choose **View→Show/Hide Data Panel** or click the **Show/Hide Data Panel** button on the toolbar.
   Teamcenter opens the data pane.

2. Click the **Variants** tab and select the option to remove in the **Options** branch of the variant data tree.

3. Click **Delete** in the **Option** dialog box.

**Deleting an option**

When you delete (remove) an option, you remove it only from the item revision. When you remove the option from the last item revision that owns it, you are (in effect) deleting the option.

- You cannot remove an option from an item revision that is released or to which you do not have write access.

- You cannot delete an option that is used in a variant condition. If you attempt to do this, Teamcenter displays an error message that lists all the BOM view revisions that have occurrences with variant conditions referencing that option.

**Working with variant conditions**

After you define the options, you must create variant conditions on the variant components.
Examples refer to the dashboard assembly use case, as described in *Populating variant data*.

The following procedures assume you are using the new variant model. If you use the old variant model, use the **Variant Conditions** property instead of the **Variant Formula** property. When you implement the new variant model, Teamcenter evaluates variant conditions using the new data model, even if they use the old **Variant** object model. The **Variant Rule** and variant condition editor dialog boxes continue to show available **Variant** objects. However, when you save an expression in the editor, it is converted to the new data model.

You create variant conditions in the scope of a specific option. If you move the structure line out of the scope of the option referenced in the variant condition, the variant condition is not retained.

**Create variant conditions**

1. Ensure you have displayed the **Variant Formula** property in the structure tree in Structure Manager.

2. Select the structure line for the option for which you want to create variant conditions, for example, **P060 - Cigar Lighter**.

3. Click the **Variant Condition** button on the toolbar, choose **Edit→Variant Condition**, or double-click the **Variant Formula** property cell.

   Teamcenter displays the **Variant Condition** dialog box. The upper part of the dialog box shows the individual clauses that comprise a variant condition. You can use the buttons to move clauses up or down, delete a clause, or bracket clauses. The lower part of the dialog box allows you to define a clause and you can use the following buttons to control how a clause is added to the list in the upper area:

   - Replace
   - Insert
   - Append
   - Clear

4. Enter the option, for example, **car type**.

   To view available options, click the list of values to display a list of options. Click the desired option to select a value and automatically populate the **(Owning)** **Item** box.

   Teamcenter lists only options that are loaded in the current Structure Manager window because their owning item is loaded or they are used in a variant condition in the structure.
Chapter 15  Configuring structures by classic variants

You can type in an option name that is not loaded. If the option name is not unique, the owning item is not populated. You must populate it by clicking the list of values in the item box and selecting the one you require. If you forget to do this, Teamcenter displays an error message when you click the list of values when trying to enter a value for the option.

5. Use the following operators to construct a variant condition:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>! =</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&gt; =</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&lt; =</td>
<td>Less than or equal to</td>
</tr>
</tbody>
</table>

Note If you use >, > =, <, or < = operators, the values of the associated option must be numeric and only decimal values are permitted.

Note (!) is higher than AND (&); AND (&) higher than OR (|). That is, A OR B AND A = A OR (B AND A).

6. Enter the value of the option, for example, GLS.

7. Select List of Values to display the allowed values for the radio option and click the required value.

8. Press the Enter key or click Append.

Teamcenter adds the condition to the list. It clears the Value box and shows the option’s owning item, for example, [A01000].

Note The Enter key provides a shortcut for the selected button—Clear, Replace, Insert, or Append). By default, this button is Append.

However, if the last button you clicked was Clear, Teamcenter clears all the necessary boxes.

9. Click OR.

Teamcenter constructs a variant condition from the defined clauses joined by AND and OR operators.

For more information, see Configuring complex variant conditions.

10. Enter the value of another option, for example, GLX, and click Return or Append.

Teamcenter displays the second clause in the list in the upper part of the dialog box.

Note If you are only specify one clause (for example, radio = mono) in a condition, you can set the AND switch or the OR switch.
11. Click **OK** to create the variant condition on the occurrence.
   
   If a line is packed, Teamcenter applies the condition to each of the packed occurrences.

**Modifying variant conditions**

A variant condition is made up of one or more clauses, for example:

```
    aerial = standard
    AND aerial = electric
```

You can modify a condition by inserting, replacing or removing clauses.

**Insert a clause before another clause**

1. Specify the new clause.

2. Select the clause before which you want to insert the new clause.

3. Click **Insert**. Teamcenter inserts the new clause above the selected clause.

**Replace a clause**

Replacing a clause can be very useful with large compound conditions containing many clauses because this action does not change the order. Preserving clause order maintains the algebra and makes scanning for occurrences with similar conditions easier.

1. Specify the replacement clause.

2. Select the clause to replaced in the list.

3. Click **Replace**. Teamcenter replaces the original clause with the new one.

**Copy a clause**

1. Select the clause to copy and click **Copy**. You can also double-click the clause. This action copies the option name, value, and operator setting to the boxes and sets the **And / Or** button in the lower part of the dialog box.

2. Edit the value and/or operator, set the appropriate **AND or OR** button, and append the clause.

3. Select an existing clause and click **Replace** to replace the existing clause. You can also click **Insert** to place the clause above the selected clause.

**Note** You can use **Copy** in conjunction with **Replace**, as a convenient way to edit variant conditions.
Remove a clause

- To remove a clause, select the clause and click Delete \( \times \).

Move a clause

To change the position of a clause within a condition, select the clause and click Up \( \uparrow \) or Down \( \downarrow \).

You can move multiple clauses in a single operation by selecting a range of clauses before clicking the appropriate arrow button.

Group a clause

You can change the grouping of clauses by adding and removing brackets, as follows:

**Note** Teamcenter supports multiple levels of grouping.

To add brackets around a range of clauses, select the range of clauses and click (...) .

To remove brackets around a range of clauses, select the range of clauses, including the lines that contain both the opening and closing brackets, and click (...) .

Copy variant conditions to other occurrences

You may want to add the same or similar variant condition to many occurrences, for example, the standard and electric aerials. You can do this by copying an existing variant condition and modifying it for another occurrence.

1. Right-click the structure line containing the existing variant condition. You can select any point on the line, not necessarily the variant condition cell.

   Teamcenter displays the structure line shortcut menu.

2. In the shortcut menu, choose **Copy** or press the Ctrl+C shortcut keys.

   Teamcenter copies the contents of the occurrence to the clipboard.

3. Move the cursor over the **Variant Condition** cell on the target line to which you want to copy the variant condition and right-click to display the structure line shortcut menu.

   **Note** The **Variant Condition** property is used with the old variant model. This action is not available with the new variant model.

4. In the shortcut menu, choose **Paste Property**. (There are no shortcut keys; you cannot use Ctrl+V.)

5. Click **Edit Variant Condition** \( \text{button} \) on the toolbar.

   Teamcenter displays the **Variant Condition** dialog box containing the variant condition for the standard aerial.

   **Note** This action is not available
6. Select **aerial = standard** and click **Remove**.  
   Teamcenter removes the clause from the dialog box.

7. Click **AND**, and then define the **aerial = electric** clause.

8. Select the structure line for the electric aerial and click **OK** in the **Variant Rule** dialog box.  
   Teamcenter adds the newly defined condition to the occurrence for the electric aerial.

**Remove a variant condition from an occurrence**

1. Select the structure line representing the occurrence and click **Edit Variant**  
   **Condition** on the toolbar.  
   Teamcenter displays the **Variant Condition** dialog box.

2. Select all of the clauses in the **Variant Condition** dialog box and click **Delete**  
   to remove all the clauses.

3. Click **OK** to apply the change to the occurrence (that is, effectively remove the variant condition).

**Working with variant rules**

You use a **variant rule** to configure a particular variant of a structure. The variant rule contains all the options that are used in the structure. You can set and unset variant rules to manage variability.

The current variant rule is not copied to any further Structure Manager windows that you open on the same structure.

**Setting variant rules**

You set the appropriate variant rule to obtain the required values for applicable options. You do not have to specify a value for every option and some options may remain unset; typically, you would set all options to completely configure a variant structure.

Some options may appear already set because they have a default value that Teamcenter automatically sets. Structure Manager shows the item to which the specified default is attached.

If you specify a derived default on an item, Teamcenter sets the default value once you enter a value for the primary option from which the default value is derived. Derived defaults are marked as **potentially derived** and, where possible, you should specify these values last.

If you specify an option value that is disallowed by a variant rule check, Teamcenter displays an error message that states the problem and the applicable variant rule.
Teamcenter only sets default values if the item to which the default is attached is loaded.

**Showing and hiding unconfigured components**

You can show or hide all unconfigured components by choosing View→Show Unconfigured Variants.

When you choose this command, Teamcenter toggles between showing and hiding all unconfigured components in the structure.

**Showing unconfigured components**

You can display all components in the structure by choosing the Show Unconfigured Variants menu command. You can then use the VOC - Variant Occ. Config’d column in the properties table to identify the configured components. This column shows a Y if the component is configured, is blank if it is not configured, or ? if Teamcenter cannot determine if it is configured. The ? indicator appears when a variant condition contains options that are unset in the variant rule.

Teamcenter displays only options that are loaded. To ensure you see all used options, you must completely expand the structure.

**Hiding unconfigured components**

You can hide all unconfigured variant components in the structure display by choosing the Show Unconfigured Variants command again. Components marked ? in the VOC column are displayed when unconfigured components are hidden.

**Set or unset the required variant rule**

- To set a variant rule and configure a particular variant of the structure, click the Variant Rule button on the toolbar or choose Tools→Variant Rule.

  Teamcenter displays the Variant Rule dialog box. You can sort the options in the dialog box by any of the columns, such as Option (name) or State, by clicking the column header.

**Set a variant rule**

1. Click the Value box of the option you want to set (for example, engine).
   Teamcenter displays the allowed values for that option.

2. Click the required value (for example, 1200).
   Teamcenter displays the selected value in the box and changes the state of the option from Unset to Set by User.

**Unset an option value**

1. Click the Value box of the option whose value you want to unset.

2. Click a blank value.
Teamcenter clears the value of the option and changes the state of the option to **Unset**.

**Note**  If the option has a default value, it returns to that default, allowing you to easily return to the default value after you have overridden it.

**Working with derived default values**

You can only observe the effect of derived default values when you have set the option defaults.

For example, if you select the `car type` option and set the value to **GLX**, you notice the `radio` option is set to **stereo** as a result of the derived default **IF car type = GLX, radio = stereo**.

Teamcenter shows the state of the `radio` option as potentially derived. It does not indicate the item the value is potentially derived from, as it could be derived from several items, depending on the option set first.

**Working with variant rule checks**

You can only observe the effect of a variant rule check when you specify the variant rule checks, for example:

1. Select the `engine` option and set it to **1200**.

2. Select the `gearbox` option and set it to **automatic**. Teamcenter displays the following error message:

   Incompatible engine and gearbox IF engine = 1200 AND gearbox = automatic

**Working with variant rules in the database**

You can store variants rules in the database and retrieve them later.

When you have set a variant rule with the **Variant Rule** dialog box, as described in *Setting variant rules*, you can store the variant rule in the database. You may want to store a variant rule for one of several reasons, including:

- To store the current state of the variant rule, because you want to exit Teamcenter and do not want to reenter the variant rule when you return.

- To store specific structure configurations, typically for analysis, testing, or marketing purposes. For example, you can store a variant rule that defines the structure configuration you use for a certain test. Similarly, you can store a variant rule that defines the standard **1600 GLS** car package for marketing.

Teamcenter stores variant rules as workspace objects, allowing any application access to them. You can cut, copy, and paste variant rules between applications, or apply release procedures and access control to them.

**Store variant rules in the database**

- To store the variant rule that is current in Structure Manager, click the **Variant Rule** button on the toolbar or choose **Tools—Variant Rule**.
Teamcenter displays the Variant Rule dialog box. The dialog box contains the Load, Reload, Save, and Save As buttons that allow you to store and retrieve variant rules.

Save a variant rule in the database

1. Set the options on the structure to the required values.
2. Click the Save As button.
   Teamcenter displays the Save As Variant Rule dialog box.
3. In the dialog box, enter:
   - The name of the new variant rule.
     Siemens PLM Software recommends you choose a name that clearly defines the purpose of the rule. For example, if the variant rule configures the 1600 GLS car, name the rule 1600 GLS or a similar name.
     **Note** The name is visible in other applications, including NX and the thin client, where users can view and configure variant structures. It is also displayed in the Manipulate Windows dialog box to indicate the configuration set in the window.
   - Optionally, a more detailed description.
   - The relation type.
     Teamcenter stores variant rules on the top-level item revision of the structure in the current window. You can choose the relation type by which the variant rules are attached. The default relation type is Manifestation, but you can change this to Specification if you prefer.
4. Click OK.
   Teamcenter displays the name of the variant rule in the title bar of the Variant Rule dialog box, indicating it is the current variant rule.
5. Click Apply or OK.
   Teamcenter applies the variant rule to the current structure in the Structure Manager window. It displays the name of the variant rule in the window banner, after the revision rule.
   The variant rule is now stored in the database, together with all options listed in the Variant Rule dialog box as Set by User or Set by <rule>.
6. Optionally, confirm the variant rule is stored by opening My Teamcenter and expanding the item revision at the top level of the structure. The variant rule object should be visible.

Load variant rules from the database

To retrieve a variant rule from the database and use it to configure the current structure:
1. Click the Load button in the Variant Rule dialog box.
Teamcenter displays the **Load Variant Rule** dialog box.

- The top of the dialog box includes a box in which you specify the variant rule to load. It also has an **Open by Name** button that allows you to search for any variant rule saved in the database by its name.

- The middle section displays a list of the variant rules attached to the top-level item revision of the structure open in the current window.

- The lower section displays the details (options and values) of the variant rule to load (this is the rule specified in the box at the top of the dialog box). You can use this information to preview the rule and ensure it is the rule you want to apply.

2. In the dialog box, select the required variant rule in the list, or search for it by clicking the **Open by Name** button.

   Teamcenter shows the name of the selected variant rule in the box at the top of the dialog box.

3. Choose how the new variant rule should affect any existing option values that you have set, as follows:
   - Set **Override** and all options not defined by the loaded rule are unset.
   - Set **Update** and only the values of those options listed in the rule are changes. All other options remain in the same state as before you loaded the rule. This allows you to form a complete variant by loading a number of partial rules.

4. Click **OK**.

   Teamcenter displays the name of the loaded variant rule in the **Variant Rule** dialog box title bar and sets the options are set accordingly. The **State** column in the properties table contains **Set by rule-name**, allowing you to identify how these values are set.

### Modifying saved variant rules

To modify a saved variant rule, you must load it as the current variant rule. If the rule is currently loaded, its name is displayed in the title bar of the **Variant Rule** dialog box. If it is not currently loaded, load the rule with the **Update** switch set, as described in **Load variant rules from the database**.

If you change any option values, the title of the **Variant Rule** dialog box changes to show (modified) after the rule name.

To cancel any changes, click **Reload** to unset all the option values and reload the variant rule from the database.

When you have set the options to the required values, click the **Save** button.

Teamcenter writes the new values to the database, overwriting the previous values of the same variant rule. Alternatively, you can click **Save As** to store the values as a new variant rule, which then becomes the current variant rule.
Chapter 15  Configuring structures by classic variants

Copy variant rules

- Copy a variant rule to the clipboard by clicking Copy.
  You can paste the copied rule into the required location in My Teamcenter or another application.

View variant rules in My Teamcenter

- To view the contents of a variant rule in My Teamcenter, click the Variants tab to display a list of options and values stored in the variant rule.

Working with variant rule checks

Variant rule checks allow a designer to define combinations of option values that are not allowed. A variant rule check consists of a condition (for example, engine = 1200 AND gearbox = automatic) and a warning message (for example, Incompatible engine and gearbox). Teamcenter displays an error message containing the condition and warning message if the rule check is triggered when you set values in the variant rule.

Set variant rule check

1. Open the data pane by choosing View→Show/Hide Data Panel or clicking the Show/Hide Data Panel button on the toolbar.
2. On the data pane, click the Variants tab.
3. Select the line representing the owning item revision on which you want to store the variant data, for example, Car Model G.
4. Select the Rule Check branch in the variant data tree. Teamcenter displays the Rule Check dialog box.
5. In the Warning Text box of the dialog box, enter an error message, for example, Incompatible engine and gearbox.
6. Define the relevant variant condition, for example, engine = 1200 AND gearbox = automatic.
7. Click Create . Teamcenter creates the rule check.
8. Expand the Rule Check branch and verify the new rule check is added below any that already existed, for example:
   ERROR Incompatible engine and gearbox IF engine = 1200 AND gearbox = automatic
9. If you need to change the rule check, select it in the Rule Check branch of the variant data tree. Teamcenter displays the Rule Check dialog box, allowing you to change any of the boxes.
10. Click Modify to apply the changes.

11. Click Save to save the changes.

   A Y appears in the Has Variant Data (HVD) column of the properties table, if variant data was not already created.

**Modify a rule check**

1. Select the rule check you want to change in the Rule Check branch of the variant data tree.

   Teamcenter displays the Rule Check dialog box containing details of the rule check.

2. In the dialog box, change the appropriate boxes.

3. Click Modify to apply the changes.

4. Click Save to save the changes.

**Delete rule checks**

1. Select the rule check to delete in the Rule Check branch of the variant data tree.

   Teamcenter displays the Rule Check dialog box.

2. In the dialog box, click Delete and the selected rule check disappears.

3. Click Save to save the changes.

**Working with option defaults**

Default options allow a designer to preset option values in the variant rule. The preset value may be:

- **Fixed**
  
  A fixed default value is a value that you specify. In the example, the option aerial has a default value set to standard.

- **Derived**
  
  A derived default is a value that is set to a value that depends on a condition. In the example, the option radio has a value set to stereo if car type = GLX.

Defaults are owned by an item revision, like other variant data. Use the Variant Rule dialog box to identify the item a default was set on and whether the default is fixed or derived.

You can identify if an item has variant data attached by viewing the HVD - Has Variant Data column in the structure properties table.

You can override option values or reinstate them as necessary.
Understanding default precedence

You set defaults on a particular item, but Teamcenter applies them globally to the whole currently loaded structure. Derived defaults always take precedence over fixed defaults. If you have set conflicting fixed default values for the same option in a structure, Teamcenter always uses the first default value it finds, according to the following rules:

- A default that is higher up the tree in a direct path takes precedence.
- Defaults at the top level always take precedence.

If you set conflicting derived default values for the same option in a structure, Teamcenter displays an error message when you attempt to save the option default or set the option value in the variant rule that causes the conflicting derived default to apply. The error may also appear when you expand the structure to the point that the conflicting derived default is loaded.

Specify fixed option defaults

To set the fixed option defaults, for example, aerial = standard and fog lights = no on item A0200, Body Assy:

1. Open the data pane by choosing View→Show/Hide Data Panel or clicking the Show/Hide Data Panel button on the toolbar.
2. In the data pane, click the Variant Data tab.
3. Select the line representing the owning item revision that stores the variant data, for example, Body Assy.
4. Select the Option Defaults branch in the variant data tree. Teamcenter displays the Option Defaults dialog box.
5. In the dialog box, enter the name of the option in the Option box and select a value from the list of possible values. For example, enter aerial in the Option box and choose aerial from the list of values.
   
   - **Note** The list of values contains only options that are loaded in Structure Manager.

   You can type in the name of an option name that is not loaded. If the option name is not unique, Teamcenter displays an error when you try to enter a value. You must specify an owning item.

6. Enter a value in the Value box, for example, standard. You do not specify a condition for a fixed option default, so the lower part of the dialog box is not used.
7. Click Create to create the option default. Click List of Values and click standard.
8. Expand the Option Default branch and verify the new option default is added below any that already existed, for example:

   DEFAULT aerial TO standard
9. Repeat steps 4 through 8 to define any other fixed defaults, for example, fog lights = no.

10. Click Save to save the changes.

A Y appears in the Has Variant Data (HVD) column of the properties table for the owning item revision (for example, Body Assy, if variant data was not already created.

Specify derived option defaults

To specify derived option defaults, follow the same procedure as specifying fixed option defaults, except that you also specify a condition. To set a derived option default, for example, radio TO stereo IF car type = GLX on item A01000, Car Model G:

1. Select the structure line that represents the owning item revision, for example, Car Model G.

2. Select the Option Defaults branch in the variant data tree.
   Teamcenter displays the Option Defaults dialog box.

3. Enter the name of the option in the Option box, for example, radio.

4. Enter the value of the option in the Value box, for example, stereo.

5. Define the condition, for example, car type = GLX.

6. Click Create to create the option default.

7. Expand the Option Default branch and verify the option default is added below any that already existed, for example:

   set radio TO stereo IF car type = GLX

8. Click Save to save the changes.

A Y appears in the HVD - Has Variant Data column of the properties table for the owning item revision (A01000, Car Model G), if variant data was not already created.

Modify option defaults

1. Select the option default you want to change in the Option Defaults branch of the variant data tree.
   Teamcenter displays in the Option Defaults dialog box.

2. In the dialog box, change the relevant boxes.

3. Click Modify to apply the changes.

4. Click Save to save the changes.
Chapter 15  Configuring structures by classic variants

Delete option defaults

1. Select the option default to delete in the Option Defaults branch of the variant data tree.

   Teamcenter displays the Option Defaults dialog box.

2. In the dialog box, click Delete and the selected option default disappears.

3. Click Save to save the changes.

Saving, refreshing, and copying variant data

You should be aware how Teamcenter handles variant data when you select any of the following actions:

- Save

  Variant data stored on item revisions (options, defaults and rule checks) is saved only when you click Save at the bottom of the Variants pane. This button is active only if there are unsaved changes. If you forget to save changes, you are prompted when you select another structure line.

  Variant conditions are stored in the BOM view revision. They are saved only when you click Save on the toolbar or choose File→Save. If you forget to save changes, you are prompted when you close the Structure Manager application.

- Refresh

  To reload the variant data on the item revision for the currently selected line, click the Refresh button in the Variants pane. This action discards changes made since the last time you clicked Save, and loads any changes made by other users in the meantime.

- Save As

  If you select an item revision and choose Save As, option and variant data on the first level of the structure does not carry forward because the BVR context changes. At the second and subsequent levels of the structure, the BVR context is the same, and options and variant conditions are therefore carried forward.

- Copy

  When you copy an item or item revision, any variant conditions are not copied.

  For more information, see Copy variant conditions to other occurrences.

Working with variant items

You can create variant items in a structure that includes classic variants to specify particular nonvariable elements of the structure. However, Teamcenter does not enforce variability rules in classic variants, and you should implement business practices that ensure all relevant options appear in the interface.

Alternatively, if your product designs permit, consider using modular variants, rather than classic variants, as described in Configuring structures by modular
variants. For detailed procedures for creating and maintaining variant items, see Creating and searching for variant items.

Creating variant items for classic variants

**Caution** Classic variants provides partial support for variant items. You can manually create and link variant items, but you cannot automatically create or update them. Variant items are fully supported (including automatic creation and updating) if you implement modular variants, as described in Creating and searching for variant items.

In many structures that are configured with classic variants, you define all options on the top-level item. This has the advantage of transparency—if all options are defined at the top level and sound business practices ensure consistency, the user can easily ensure the configuration is complete. When you configure the options, you determine the configuration state of all variants throughout the structure, so ensuring that a variant item is a completely configured structure.

The following figure shows a typical structure of an engine.

### Structure of engine

You can define options on the top-level **Engine Family** item as follows:

<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENG</td>
<td>V6L, V6S</td>
</tr>
<tr>
<td>TRANS</td>
<td>M10, M50</td>
</tr>
</tbody>
</table>

These options determine the configuration of the lower levels of the structure through variant conditions, as shown in the following figure.
Chapter 15  Configuring structures by classic variants

Structure of engine with option values

Before you create the variant item, you must configure the structure manually or with a saved variant rule, as shown in the following figure.

Configured structure of engine

You then create a variant item of Mainstream Module, as described later, and the resulting item is a new VI For Engine structure, as shown in the following figure.

VI for engine structure
Because the variant item only prunes the immediate children that are unconfigured, the **Short Block** item still exists in the resulting structure, but as an unconfigured item. It may seem advantageous to permanently remove the **Short Block** item, so that you can manage and export a minimal structure. However, this action permanently removes **Short Block** from **Cylinder block**, an item that still appears in the generic **Mainstream Module**. Because the **Short Block** item is still applicable in different configurations of **Mainstream Module**, removal is not an appropriate action.

Another possible course of action is to create variant items at every level of the structure, or at least down to the lowest level that has any variant conditions. For example, you could create variant items for the **Crankcase** and **Cylinder Block** items, as shown in the following figure.

![Lower level variant items in engine structure](image)

**Configuring variant items**

To create and manage variant items for classic variant structures, you must set the following preference.

- **PSEAllowLegacyVICreation**
  
  Set this preference to `true` to permit the creation of variant items for structures that include classic variant options. It also permits the creation of variant items from assemblies that are not modules. The default setting is `false`.

Additional preferences required for variant configuration are described in *Administering the product structure*.  

---

*Configuring structures by classic variants*
Chapter

16 Configuring structures by modular variants

Configuring structures by modular variants ........................................ 16-1

Modular variants terminology ............................................................. 16-2

Using modular variants ........................................................................ 16-3
  Configuring a public interface and private options ............................. 16-3
  Linking options between parent modules and child modules .......... 16-4
  Presenting options ........................................................................... 16-5
  Linking a parent module option to options on child modules .......... 16-6
  Linking public and private options ..................................................... 16-6
  Creating variant items ....................................................................... 16-6
  Creating modular assemblies ............................................................... 16-7
  Creating modular piece parts ............................................................... 16-8
  Defining options ................................................................................ 16-8
    Defining global options ..................................................................... 16-8
    Defining external options ................................................................ 16-9
    Setting option defaults .................................................................... 16-11
  Checking for errors ............................................................................ 16-11
  Configuring a structure ...................................................................... 16-12
  Setting expression values .................................................................. 16-12

Viewing and creating option and variant data ...................................... 16-12
  View variant data ............................................................................... 16-12
  Creating variant data ......................................................................... 16-13
  Create new options ........................................................................... 16-14
    Create options manually .................................................................. 16-15
      Examples of public and private options ......................................... 16-15
    Set external option definitions ......................................................... 16-15
  Present child options ........................................................................ 16-17
  Create a new error check .................................................................... 16-19
  Create module constraints .................................................................. 16-20
  Managing child module constraints .................................................... 16-21
    Create a child module option constraint .......................................... 16-22
    Edit an option or constraint .............................................................. 16-23
    Delete an option or constraint ........................................................ 16-23
  Edit variant conditions ....................................................................... 16-23
  Edit expressions in MVL ..................................................................... 16-25
  Developing complex expressions with MVL ....................................... 16-26
    Determining precedence in MVL ....................................................... 16-26
    Understanding MVL conventions ..................................................... 16-27
Reserved words ................................................. 16-28
Reserved symbols .............................................. 16-29
Using the expert mode ........................................... 16-30
Example of an expression coded in MVL ......................... 16-32

Configuring a variant structure by setting variant rules .............. 16-33
Configure the variant structure ..................................... 16-34
Selecting option values .......................................... 16-35
Test current product configuration .................................. 16-36
Create a saved configuration ...................................... 16-36
Load a saved configuration ....................................... 16-37
Importing and updating variant data ............................... 16-38

Creating and searching for variant items ........................ 16-38
Populate a complete variant structure ............................. 16-38
Creating and updating variant items ............................... 16-39
Search for a variant item ......................................... 16-40
Create a new variant item ........................................ 16-41
Adding a generic item property ................................... 16-42
Create variant items automatically ................................ 16-42
Setting preferences for automatic variant item creation ........ 16-44
Revising variant items and generic modules ....................... 16-45
Update a variant item ............................................. 16-45
Unlink variant items ............................................. 16-46
Synchronizing with NX .......................................... 16-46
Driving geometry ................................................. 16-47
Driving assembly component position ............................ 16-49
Working with component arrays ................................ 16-49
Chapter

16 Configuring structures by modular variants

Configuring structures by modular variants

Teamcenter supports two methods of variant configuration, modular variants (described here) and classic variants, as described in Configuring structures by classic variants.

For information on how to choose between these two methods, see Getting Started with Product Structure.

Siemens PLM Software recommends that you do not create both classic variants and modular variants in the same product structure, as this may cause in unpredictable results.

**Caution** Modular variants are not available with precise structures. If you want to implement modular variants, create imprecise structures.

The Teamcenter Integration for NX does not fully support modular variants. To exchange variant assembly data between Teamcenter and NX, you must implement classic variants. However, the Teamcenter Integration for NX does support the synchronization of part data for modular variant items. You can synchronize option values with NX expressions when working with geometric options and variants, but you cannot see stored option sets in NX; use variant items instead of stored option sets.

Modular variants make substantial use of temporary table space. The database administrator must ensure sufficient temporary table space is configured in accordance with the database manufacturer’s guidelines and deployment recommendations provided by Siemens PLM Software.

Before you can use modular variants, your Teamcenter administrator must complete the configuration steps and set certain preferences, as described in Configuring modular variants.
## Modular variants terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Derived default</td>
<td>A default value that depends on a certain condition (for example, radio = stereo IF car type = GLX). A derived default is attached to an item revision, but applies globally to a loaded product structure.</td>
</tr>
<tr>
<td>Error check</td>
<td>A type of constraint in which a message is generated for a given combination of option values. Error checking is supported at three levels—error, warning and information.</td>
</tr>
<tr>
<td>External option</td>
<td>An option that is typically placed at the top-level module and sets the value of options that reference it in lower level modules.</td>
</tr>
<tr>
<td>Global option</td>
<td>An option that defines a set of standard allowed values in a central module. These values can be used in other modules.</td>
</tr>
<tr>
<td>Module</td>
<td>A container for options and constraints that describes the variability of a given item. A module encapsulates option definition to the area of the structure where it is needed.</td>
</tr>
<tr>
<td>Multiple configuration</td>
<td>Unique configurations of specific usages of a module. You facilitate multiple configurations with occurrence names and by configuring paths to modules.</td>
</tr>
<tr>
<td>Option</td>
<td>A parameter of variability. Options have a type (real, integer, or logical), visibility (public or private), a name, and a default value. You can save several options in a saved option set (SOS) or saved variant rule.</td>
</tr>
<tr>
<td>Presented option</td>
<td>An option in a module that points to a public option in a directly included child module.</td>
</tr>
<tr>
<td>Private option</td>
<td>An option that is visible only to the constraints within the module in which it was defined.</td>
</tr>
<tr>
<td>Public option</td>
<td>An option that is visible by constraints in a direct parent module and can be presented to a direct parent module. The public interface to the module.</td>
</tr>
<tr>
<td>Variant (structure)</td>
<td>A specific structure that is configured by applying a variant rule.</td>
</tr>
<tr>
<td>Variant condition</td>
<td>A condition that an engineering user sets on an occurrence to specify the option values that configure the occurrence (for example, Load IF engine = 1200). More complex condition statements may also be defined.</td>
</tr>
<tr>
<td>(Variant) Configuration</td>
<td>The values set for all public options in the top-level module that configure a structure.</td>
</tr>
<tr>
<td>Variant item (VI)</td>
<td>A specific nonvariant instance of a module.</td>
</tr>
<tr>
<td>Variant rule check</td>
<td>A condition that specifies any option values or combinations of values that are not allowed. A variant rule check is attached to an item revision. Also called an error check.</td>
</tr>
</tbody>
</table>
Using modular variants

To minimize engineering and production costs, you can create modules in the product—self-contained plug-compatible units that can be reused. This technique imposes tight constraints on how the product is designed; Teamcenter supports those constraints when you work with modular variants. When you use modular variants, the options and associated logic are attached to a module item. Variant conditions on the components can only refer to options on the parent module, thus making the module independent of any other parts in the structure with regard to variant logic. This approach requires variant data and option values to be propagated up and down the structure so that end users (customers) can set options on lower level modules when configuring the whole product from the top level.

Manufactured goods are often designed and assembled from modules. For example, consider a company that produces a range of refrigerators and freezers in different sizes and colors. The door assemblies are developed in a department that designs a modular door suitable for use in any refrigerator or freezer. They design a generic door assembly that has all possible components for any use—a sheet steel outer door and two internal covers, one for a freezer and one for a refrigerator. (This is a simplified example; in a real product there would be many more individual components.)

You can then configure the door assembly for a particular use in a refrigerator/freezer by setting various parameters or options that describe it, for example, door width, door height, application (refrigerator or freezer), and color (white or stainless steel). This intelligent door assembly is called a module.

The door module is completely self-contained and so can be reused in any product by setting its public interface options. The public interface options only control the features and components contained in the door module itself, and make no reference to options in higher or lower level modules. The modular variant functionality enforces this linking.

Note Teamcenter evaluates options from the top of the structure downwards, so the position of each module is significant.

The structure of the door assembly and its associated options is modelled as follows.

Structure of assembly and options

Configuring a public interface and private options

The public interface options can be set by the customer of the module. In the case of the door assembly, the customer is the design department that uses the door module.
In the case of the refrigerator freezer module itself, the customer chooses from the public options made available at that level, for example, appliance width, appliance height, freezer at the top or bottom, number of shelves, and so on.

There may also be some internal options that are not set by the user, but are set according to the values of the public options. For example, the height of the door is set according to the appliance height, allowing for two doors, a 50 mm floor panel, and an LED display at the top. To allow for this, you create a private (hidden) option called **Door Height** on the refrigerator freezer module) that is controlled by the public option **Appliance Height** as follows:

\[
\text{Door Height} = (\text{Appliance Height}/2) - 50\text{mm}
\]

The **Door Height** option on the refrigerator freezer module is used to automatically set the **Door Height** option on the door module. You need not know this relationship, simply enter the overall height of the appliance.

You could use the same principle to define private options for all the assemblies of the refrigerator freezer and bring them together only in the top-level assembly.

**Linking options between parent modules and child modules**

To configure the refrigerator freezer appliance, you must set the options for each and every assembly. It may take a long time to set all the options, some of which are the same in all submodules. Also, if you consider the width, it would have to be set in the module for the carcass, the door, and the shelves. It may preferable to set the options at only the top level module for the entire appliance and have this value propagate through the structure. To do this, you must create links between the child modules and the current module (the main refrigerator assembly). You can create these links in two ways, as shown in the following figure:

- Options from the child module are presented up into the parent module where they are visible and can be set.

- Options in the parent module can set options in the child module.
Presenting options

You can configure the same module differently, depending on where it is located.
Options can be presented to a parent module from a child module to make them visible as though they were part of the public interface for the parent module. For example, the Number of shelves option is presented up from the carcass module to the refrigerator freezer module, allowing you to choose the value at the parent level. You could also use the present method if you want to set options for different occurrences of the same module to different values, depending on their location.

You could place the door module in a refrigerator freezer assembly with this method. In this example, the same door module is used twice, once as a freezer door and once as a refrigerator door. The options created previously control the components of each door and the doors have different components due to their different functions. You can name each occurrence of the door appropriately, for example, top and bottom. You then present the Application option (with possible values refrigerator and freezer) for each door to the parent refrigerator freezer module. This gives two options to set in the refrigerator freezer module, one for each door; you can set these to different values.

Linking a parent module option to options on child modules

To set the width value, you could present the options as described in Presenting options. However, you must set the width option once for each door. As the doors are identical for any given appliance, it would be better to set this value only once. You could create an Appliance Width option in the top level module and link this single option to all width options in the child modules. When the Appliance Width is set in the refrigerator freezer module, it propagates to the carcass module, to both door modules, the shelves, and so on. The link is referred to as a child module constraint.

Linking public and private options

To enforce modularity, it is only possible to link options between a parent and its immediate child modules; you cannot skip a module level. To cascade down or up more than one level, you must repeat the linking process as necessary. Teamcenter enforces the following restrictions on linking:

- You can only present public options up from the child module. You cannot present them down from the parent module.
- You can only link options from the parent module to public options in the child module, although the option in the parent module can be public or private.

Creating variant items

A variant item is a specific variant of a completely configured module. For example, it could be a door assembly with: height of 500 mm, width of 600 mm, application of refrigerator and color of white.
Variant items are physical parts with no variability, and can be allocated an actual manufacturing part number. Conversely, modules cannot be manufactured. Modules with a large number of options and numeric options (with an infinite range unless allowed values are specified) have a correspondingly large number of permutations; not all of these permutations are manufactured. It is useful to be able to reuse permutations that have previously been sold, as significant engineering work may have been invested in creating technical documentation, drawings, and manufacturing data that is attached to the variant items.

The modular variants functionality allows you to create new variant items when they are required. You can also search for existing variant items to reuse in new products. Variant items are built up into a complete structure for a specific configuration corresponding to a product or customer order; in this structure all modules are replaced by specific variant items.

If you are using NX, you can use the option values on variant items to determine the expression values on an NX CAD part.

**Caution**  
If a module has variant items linked to it, you cannot change any of the variant data without revising the module. Such changes may invalidate existing variant items linked to the module revision. Disallowed changes include:

- Removing or adding an allowed option value.
- Removing or adding an option.
- Setting or adding a variant condition on a BOM line.
- Changing variant logic such as module constraints, defaults, and rule checks.

If you want to make any of these changes, you must first revise the module.

You cannot update existing variant items linked to previous module revisions. You can create a new variant item, but Teamcenter then contains two different IDs for variant items that have the same configuration and share the same stored option set (SOS) values; this arrangement does not adequately enforce modularity. The new variant item may also contain additional components and, if so, it would not be appropriate to update the existing variant item.

### Creating modular assemblies

You can configure the variant components in a modular assembly by applying a variant condition. For example, for the door module mentioned previously, create the following conditions:

**On the Door Liner Fridge, Insulation Fridge and Egg Tray components:**

Load if Application = fridge

**On the Door Liner Freezer and Insulation Freezer components:**

Load if Application = freezer
The options you can use in the variant condition are limited to the public and private options on the parent module. This limitation enforces modularity.

Creating modular piece parts

You can set options on a piece part to use with a CAD model in NX. You can map these options to an associated expression in NX that determines the geometry of the part; for example, you could map the **Width** option to the geometry of the door. When you create a variant item, Teamcenter copies the model (UGMASTER dataset), and automatically sets the option value to the associated expression value in NX, for example, **Width = 500**.

If you design the door assembly module of the refrigerator freezer as a modular assembly, having a different component for each width and height of door, this could lead to a very large number of components for each size of door. It is more efficient to design the piece part for the door itself as a module, with options for width and height. The variability is then catered for by the variant items, which are created on demand as required, without needing to modify the parent door assembly module to add components for every new size of door.

Defining options

Teamcenter allows you to create several different option types. You define options in standard variants only and string values are available. The following variant types are provided:

- String
- Integer
- Real
- Logical (true, false)

You can use the **=, >, <, >=, <=** and **to** operators with real and integer options, both in the allowed values for an option and in variant conditions and constraints. For example, you can set the door width option to a range of values, such as **400 to 700**. This allows the user to set any value within the range, although there are discrete values allowed for standardization (500 and 600 only).

Defining global options

Global options are a convenient way of defining a fixed set of allowed values. Examples of global options are **Color = white, stainless** and **Appliance Width = 500, 600**. You can also set a range such as **Angle >=0, < 360**. You can then reference these global options in other modules.

The value configured is **not** the same in each module where the global option is used. Use external options if you require this effect.

To define a global option, add the item ID that contains the global option definition to the **PSM_global_option_item_ids** preference. This preference lists the IDs of all items that contain global options, for example:

```plaintext
PSM_global_option_item_ids=
```
These definitions can then be reused when authoring variant modules. In Structure Manager, you can drop these global options into the module for which they are required.

To add items to the list of IDs, in Structure Manager, select an item and choose **Tools→Variants→Set/Unset Global Option Item**.

**Defining external options**

An external option is typically defined on the top-level module in the structure. Its allowed values are the same as those on the option that references it. In addition, the value set for the external option on the top-level module in the variant rule is propagated to all options that reference the external option.

The following figure shows an extension of the refrigerator freezer example that illustrates this concept.
Creating external options
Create an item called **GO-5000** to define global options. This item is a standalone module and contains three global options for color, width and voltage. Each such global option is specified with standard allowed values.

The color global option is used in the refrigerator freezer and door assembly modules so that the allowed values are controlled from the color master global option in the **GO-5000** module. To set the actual value configured for the unit color on the door module for some variant of the product, you must create a link between the unit color option in the refrigerator freezer and the option in the door assembly, as shown in the previous figure.

The appliance width external option is created in the refrigerator freezer module. It is used by the door width option in the door assembly module and by the carcass width option in the carcass module. Typically, the external option would reference a global option, but this is not mandatory. In this case, the value set for the appliance width for any variant of the refrigerator freezer is automatically propagated to the options that use it lower in the structure (namely door width and carcass width), without needing to create a link.

**Setting option defaults**

You can set default values for options in the following ways:

- In the option definition. This is the most common and visible place to set a default.

- Using a module constraint to set a default value.

- Using a module constraint to fix a default value that cannot be overridden by the user.

In the refrigerator freezer example, for some models, the freezer may always be at the bottom and the refrigerator at the top. In this case, the value for the application option would be fixed for each path in the refrigerator freezer module.

**Note** When using a global option definition, you can override a default set in the global definition in the module in which the global option definition is used.

**Checking for errors**

You may not want to allow all possible permutations of a module. For example, in the refrigerator freezer, the top application and bottom application cannot both be set to the same value of **Refrigerator**. You can use error checks to warn about unsupported combinations, by displaying a message when the user attempts to set option value combinations specified in the error check. You can define one of the following messages to warn of unsupported combinations:

- **Error**
  Teamcenter displays the error message, and the user is not allowed to configure the combination specified.

- **Warning**
  Teamcenter displays the warning message, but the user may set the combination specified.
Chapter 16  Configuring structures by modular variants

- Information
  Teamcenter displays the information message, and the user may set the combination specified.

  **Note**  Create error checks at the appropriate module, typically at the top level. Do not create them on global items.

**Configuring a structure**

When you have defined the option modules, configure the structure to simulate the choices that the end user or customer is offered. This process ensures that the structure is correctly and completely configured. The end user or customer can only set values for options on the product itself; for example, for the refrigerator freezer; they cannot set options in lower level modules.

Before doing this, you must design all the lower level modules (door assembly, door, carcass and so on) such that they are completely configured by whatever combination of options is set in the refrigerator freezer module. You should do this following the methods previously described, namely:

- Options from the child module should be presented up to the parent module.
- Options in the parent module may set options in the child module.
- Option defaults should be set where appropriate.

  **Note**  Checking that the refrigerator freezer product is completely authored is a manual process.

**Setting expression values**

Modular variants support the capability to set an expression value in NX from an associated option value in Teamcenter; this capability is not available in classic variants. Make the association simply by ensuring the expression name in the NX part is the same as the option name on the item module; the **UGMASTER** dataset for the part must be defined in this item module.

You can use options to set any expression. In a piece part, you typically use expressions for geometric parameters such as length or the number of elements in an array of features. In an assembly, you typically use option values to control position, for example, by determining the parameters of a mating condition such as the linear or angular offset.

**Viewing and creating option and variant data**

Before creating option and variant data, set the relevant preferences required for variant configuration, as described in *Configuring modular variants*.

**View variant data**

1. In the product structure, select the top-level item of the structure for which modular variant data already exists.
2. Click the **Show/Hide Data Panel** button on the toolbar.
   Teamcenter displays the data pane.

3. On the data pane, click the **Variants** tab.
   Teamcenter displays any available variant data that already exists, for example, option definitions and constraints.

An example of variant data for the refrigerator freezer discussed previously is shown in *Using modular variants*.

**Tip** Use the **PSE_show_option_item_prefix** preference to show or hide the owning item ID as a prefix to the option name. For details, see the *Preferences and Environment Variables Reference*.

### Creating variant data

Use the buttons listed next to create or edit variant data. They are located at the bottom of the **Variant Data** pane.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Create" /></td>
<td>Create a new option</td>
<td>Creates a new option.</td>
</tr>
<tr>
<td><img src="image2" alt="Present" /></td>
<td>Present a child option in the parent module</td>
<td>Displays options from a child module in the parent module (the current module).</td>
</tr>
<tr>
<td><img src="image3" alt="Create" /></td>
<td>Create a new error check</td>
<td>Allows Teamcenter to highlight any specified configuration by one of the following methods:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• A warning that a combination is not allowed. In this case, you cannot continue with the requested configuration.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• A warning message that a combination is not advised. In this case, you can proceed after acknowledging the warning message.</td>
</tr>
<tr>
<td><img src="image4" alt="Create" /></td>
<td>Create new internal modular constraints</td>
<td>When you click this button, Teamcenter displays the <strong>Error Checks</strong> dialog box, allowing you to define the severity of the error, the message that appears when the specified combination is set, and the condition.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specifies the setting of an option value based on the values of other options within the module, or the setting or fixing of an option value.</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
<td>Purpose</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image" alt="Create" /></td>
<td>Create new child option constraints</td>
<td>Sets a child option based on a parent option. The child option must already exist.</td>
</tr>
<tr>
<td><img src="image" alt="Edit" /></td>
<td>Edit the selected option or constraints.</td>
<td>If you highlight an option or constraint and click this button, Teamcenter displays the Edit dialog box. Double-clicking the option or constraint has the same result.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle" /></td>
<td>Toggle expert mode</td>
<td>Toggles expert mode on or off when editing constraints.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Delete the selected object.</td>
<td>Removes the highlighted option or constraint.</td>
</tr>
<tr>
<td><img src="image" alt="Show" /></td>
<td>Show legacy data.</td>
<td>Displays the legacy Variant Data pane. For information about legacy (classic) variants, see Configuring structures by classic variants.</td>
</tr>
</tbody>
</table>

**Caution** Do not rename existing options or values. If you do this, constraints and other data are not updated.

**Create new options**

You can create a new option in one of two ways:

- Click the **New Option** button.
  Teamcenter displays the New Option wizard that guides you through the creation process.

- Click the lower radio button in the New Option wizard.
  Teamcenter displays the **Create New Option** dialog box, allowing you to create the new option manually, as described in Create options manually.

**Note** An option must have:

- Visibility (public or private)
- A name and description
- A type (string or logical, integer or real)
- Allowed values or range (if required)
- A default value (optional)
Create options manually

If you use the Create New Option dialog box, you can create many similar options more quickly than with the wizard. To create an option in this way, enter the following information in the dialog box:

- Select the visibility of the option, PRIVATE or PUBLIC.
  - Public options may be set by a user or a parent module option when configuring a module.
  - Private options cannot be set by the user and are not displayed when configuring a module. Private options are set from public options by constraints.
- Enter a name and description for the option.
- Choose a type for the option from the dropdown list, String with default, Real/Integer or Logical. If you choose String, you must enter the allowed values in the Allowed Values box.
- If the option is based on a global option definition (for example, Appliance Width), select the global option from the dropdown list.
- Enter the remaining information required in the dialog box.

Examples of public and private options

In the refrigerator freezer example described previously, the following public and private options are defined:

- The Appliance Width option is a public option. It is set by a customer when configuring the product.
- The Door Height option is a private option. It is set by a constraint according to the value of the Appliance Height public option.

Set external option definitions

You can set external option definitions only with the New Option wizard, which guides you through the following steps:

Note: You must create an external option as a global option or variant items fail at lower level modules.

- Do not define an external option from an option lower in the structure. Because Teamcenter evaluates definitions from the top down, this configuration fails.
- Do not use external options with variant items.
- External options are not updated when option values are added to the global option on which they are based. This behavior occurs because the option values are cached.

1. Select a public option.
2. Enter a name. You do not need to use the same name as the referenced external option.

3. For option type, select **The same type and restrictions as an existing option**.

4. For derived option type, select **Search for Existing Options**.

5. In the next window, enter the item name (not item ID) of the module on which the external option is defined and click Next. You can use wildcards (*) to search for all modules in the database, not only those defined as global options. Select the option you require, as shown in the following example.

6. In the next window, select the **Use option as an external option** check box and click Next.

This completes the definition of the new option, and you can now view it in the Variants pane, as follows.
Configuring structures by modular variants

New option definition

Teamcenter does not indicate that it is an external option here. However, if you view the option in the **Edit Option** dialog box, a check box shows that the option is external, as shown in the following figure.

**Note** You cannot set this option as **external** in this dialog box.

Edit option dialog box

Teamcenter considers that the affected module uses the external option. If you place the cursor over a global option definition, you see a tool tip in the format:

*Optionx* (on lower level module) uses external option *Y* (on higher level module)

For example:

Public 002508:Trim uses MV-F1000 Trim

Present child options

You must *present* options of a child module in the parent so they appear as a public option of the module. For example, in the refrigerator freezer example, the **Application** option of the **Door Assembly** module is presented to the parent refrigerator freezer module. There are two occurrences of the **Door Assembly**
module, which have their paths labeled in the **Occurrence Name** structure line property as **Top** and **Bottom**. Each path in the **Door Assembly** module is presented separately, allowing you to configure each occurrence differently.

You cannot set a default value for the presenting option. Any default is inherited from the master, that is, the lowest level module from which the option is presented. If you change the default on the master, Teamcenter propagates the change to all the levels to which the option is presented.

To present a child option:

1. In the product structure, select the parent module to which you want to present the child option and click the **Create Presented Option** button.

   Teamcenter displays the **Present Options** dialog box, as shown in the following figure:

   ![Present option dialog box]

   **Present option dialog box**

2. Make the following entries in the dialog box:
   - In the **Select Module** list, select the module to present from, for example, the **Door Assembly**.
   - In the **Select Options** list, select the option to present or check the **Select all** check box to present all options.
   - In the **Select paths** list, select the path to present from (or paths if there are many occurrences). By default, the **Select none** check box is checked and you should clear this if appropriate.
• When you have made the appropriate selections, as shown in the previous figure, click **OK**.

Teamcenter displays the result in the data pane, as shown in the following figure.

![Presented child option in data pane](image)

**Create a new error check**

Not all permutations of option values in a module may be permitted. For example, in the refrigerator freezer example, the **Top Application** and **Bottom Application** cannot be set to the same value of **Fridge**. You should create error checks to warn the user of unsupported combinations when they configure a module. When the user tries to set the option value combinations specified in the error check, Teamcenter displays the defined message.

**Caution**  Do not create error checks on global options as they will not be executed.

To create an error check:

1. Select the module on which you want to create the error check (typically, the top level) and click the **Error Checks** button.

   Teamcenter displays the **Error Checks** dialog box, as shown in the following figure.

   ![Error checks dialog box](image)

2. Make the following entries in the dialog box:
   - Choose the type of error check from the **Severity** list, which may be one of the following:
Chapter 16  Configuring structures by modular variants

- **Error**
  If an error condition occurs, Teamcenter displays an error message and the user may not configure the specified combination.

- **Warning**
  If a warning condition occurs, Teamcenter displays a warning message and the user may set the specified combination.

- **Information**
  If an information condition occurs, Teamcenter displays an information message and the user may set the specified combination.

- In the **Message** box, enter the text of the message you want Teamcenter to display.

- In the **Condition** box, specify the combination of option values that triggers the error check, from options on the parent module only.

3. When you have made the appropriate selections, as shown in the previous figure, click **OK**.

Teamcenter displays the result in the data pane, as shown in the following figure.

![Error check in data pane](image)

**Create module constraints**

Use a module constraint to set option values within a module. You may create a module constraint for the following reasons:

- To set a private option value that depends on a value of the public option in the module. You can use logic and simple mathematical operators to set conditions.

- To set a default option value. The user can override this value when configuring the structure. In this case, there is no condition on other option values and Teamcenter sets a value.

- To set fixed (hard-wired) option values that the user cannot override when configuring the structure. As before, if there is no condition on other option values, Teamcenter sets a value.

In the refrigerator freezer example, you use a module constraint to set the **Door Height** private option in the **Fridge Freezer** module according to the **Appliance**
**Height** public option. This constraint is defined with mathematical operators in MVL (modular variant language), rather than through the user interface.

To define a module constraint:

1. Select the module on which you want to define a constraint and click the `Constraints` button.

   Teamcenter displays the **Constraints** dialog box, as shown in the following figure.

   ![Constraints dialog box](image)

2. Make the following entries in the dialog box:
   - Choose **Set** or **Fix** from the list. Choose **Set** to set a private option from the value of a public option. Choose **Set** or **Fix** to directly associate an option with a defined value in the **To Value** list (do not use the **Condition** box.)
   - Choose an option in the **Option** list and choose its value in the **To Value**. When you do this, you set the option—in this case, the private option, unless you set a value with no condition.
   - In the **Condition** box, specify the constraint condition of the public option that is setting the private option.

3. When you have made the appropriate selections, click **OK** or **Apply**. If you click **Apply**, the **Constraints** dialog box remains displayed and you can create other constraints.

   **Caution**  Do not click **OK** and **Apply** or you will create two identical constraints.

4. Repeat steps 1 through 3 for each public/private option value combination that must be mapped.

**Managing child module constraints**

Use this function to set a child module option based on a parent module option that should be mapped to the option in the parent, that is, all values. The child option must already exist.
Create a child module option constraint

1. Select the child module and click the Child Constraint button.
   Teamcenter displays the Constraints dialog box.

2. Make the following entries in the dialog box:
   - Set the type of constraint. Typically, you set rather than fix the constraint.
   - Set the child option. You can display a list of public options for all child modules using the list.
   - Select whether to map individual values or all the options. The following figure shows how to map all the options, by clicking the or to option button. This is the most common approach to setting child module options.
     Teamcenter does not detect if the options have different allowed values. However, if the options are of different types, Teamcenter detects and prevents you setting such values.
   - Map specific option values to a specific option value in the child and set the conditions as required.
   - Optionally, specify a path in the Occurrence Name structure line property if you need to map many occurrences of the child to different option values.

A Constraints dialog box with this information fully entered is shown next.

### Constraints dialog box

3. Click the Apply button and repeat step 2 if you want to create several child module constraints. Alternatively, if you only want to create a single child module constraint, click OK.

   **Caution** Do not click OK after clicking Apply because this creates two identical constraints.
Teamcenter displays the child option constraints, as shown in the following figure. This example shows all the parent options mapped to the child options without any conditions.

**Child module constraints**

**Edit an option or constraint**

- To edit a selected option or constraint, click the Edit button or double-click the line in the data pane.

**Delete an option or constraint**

1. Select the row in the data pane that represents the constraint or option.

2. Click the Delete button.

   Teamcenter deletes the selected constraint or option.

**Edit variant conditions**

You create variant conditions to control the conditions under which Teamcenter configures an occurrence.

You can create or edit a selected variant condition in one of three ways:

- Display the Variant Conditions column in the structure properties table and double-click the relevant cell.

- Choose Edit→Variant Condition.

- Click the Edit button.

Teamcenter displays the Variant Condition dialog box, as shown in the following figure.
Chapter 16  Configuring structures by modular variants

Variant condition dialog box

You can only include the options in the parent module in the variant condition. You can create any number of conditions and lines.

Use the buttons provided to manipulate the condition statements and display them, as shown in the following figure.

Condition statements

You can copy existing variant conditions to reuse as follows:

1. Right-click the appropriate structure line and choose **Copy**.

2. Right-click the structure line to copy the variant condition onto and choose **Paste Property**. If you select more than one line, the variant conditions apply to all the selected lines.
If you have existing legacy variant conditions, you can edit them by clicking the **Edit Legacy** button.

**Edit expressions in MVL**

There are certain complex conditions that you cannot create or edit in the **Variant Condition** dialog box. In these cases, you must edit the modular variants language (MVL) that represents the condition directly.

For example, you may want to set the following condition for the refrigerator freezer:

\[
\text{Door Height} = \left( \frac{\text{Appliance Height}}{2} \right) - 50\text{mm}
\]

1. Click the **Edit MVL** button.

   Teamcenter displays the Constraints node with a **Complex Constraints** entry, as shown in the following figure.

   ![Complex constraints](image)

2. Double-click the **Complex Constraints** entry node.

   Teamcenter displays a dialog box in which you can edit and save the MVL expression, as shown in the following figure.

   ![Saved MVL expression](image)

3. Edit the MVL expression as appropriate. You can use many mathematical operators, as described in *Developing complex expressions with MVL*.

   **Caution** If you edit an expression in expert mode in this way, Teamcenter marks the module as an **Expert** module. You can no longer maintain the module with the basic user interface.
Chapter 16  Configuring structures by modular variants

You can view the MVL of existing variant data for examples of the required syntax. An example of how to use mathematical operators with options follows:

```
set 002504:’Door Height’ to 002504:’Appliance Height’/2*002504:’Clearance’-002504:’Offset’
```

In this example, 'Clearance' and 'Offset' are private options you created to store a variable for use in this logic.

If a name or identifier includes spaces or special characters (for example, - ), you must embed them in quotation marks, for example: set 'MV-2504:’Door Height'.

To identify the available entries at any point in the expression, Teamcenter utilizes Intellisense™. When you create or edit the expression, Teamcenter displays a list of available entries. Select an entry with the mouse or the up and down arrow keys, then press Enter to put the entry into the expression.

For more details of how to edit MVL expressions, see Developing complex expressions with MVL.

Developing complex expressions with MVL

Use modular variants language (MVL) language to define inherited options and constraints. It allows you to define semantics and expressions that Teamcenter can interpret and evaluate.

You can also use MVL to define interfaces, that is, to define the modules options and how the module derives any options from another module, as described previously. You can also use it to define constraint and conditions.

Determining precedence in MVL

MVL statements comprise the following three elements:

- Error checks, consisting of error, information, or warning messages
- Internal module constraints
- Child module constraints

Teamcenter expects each statement to contain these elements in the order listed. When you use the Internal module constraints dialog box and the Child module constraints dialog box to construct constraints or error checks, respectively, Teamcenter arranges the MVL elements into the required order. However, if you develop statements in the MVL editor and enter the elements in an incorrect order, Teamcenter does not rearrange them. No error or warning messages are displayed, but the variant structure may not be configured correctly.

Similarly, if your MVL statements contain comments, Teamcenter may not rearrange the elements into the required order.

Also, internal and child constraints are evaluated in the following order, where 1 has the lowest priority and 7 the highest:

1. Default
2. User set
3. Set
4. User fix
5. Fix  
6. External  
7. Variant item

For example, a user set takes precedence over the default value of an option for a given type of constraint.

**Understanding MVL conventions**

When coding in MVL, note the following conventions:

- MVL is case sensitive. All statements and keywords are typed in lowercase.

- White space is ignored, except when contained inside single or double quotation marks.

- Single and double quotation marks have semantically different meanings. Single quotation marks are required for some identifiers (IDs) and double quotes are used for string literals.

- Text appearing inside square brackets is optional. However, if the ‘[’ and ‘]’ characters appear inside single quotes, you should type them.

- Words that are in *monospaced* font are keywords and should be typed exactly as shown.

- Words in *italicized* font are primitives, and the most common ones follow.

- Lines preceded with a # character contain comments. If an MVL expression contains comments, you cannot view it in the user interface.

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ID</strong></td>
<td>An ID may be:</td>
<td>Car</td>
</tr>
<tr>
<td><strong>Module ID</strong></td>
<td>- A string that starts with a letter and only contains alphanumeric characters, or</td>
<td>‘My Car’</td>
</tr>
<tr>
<td><strong>OptionName</strong></td>
<td></td>
<td>‘an option name’</td>
</tr>
<tr>
<td><strong>PathName</strong></td>
<td>- A string enclosed in single quotation marks and containing any symbols. Inside the single quotes, you can use the \ character to escape a single quotation mark, and itself.</td>
<td></td>
</tr>
</tbody>
</table>

Use IDs for module IDs, path names, and option names.

*Note* Siemens PLM Software recommends that you do not a reserved word as the ID, module ID or path name.
Chapter 16  Configuring structures by modular variants

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
</table>
| **Option** | An option is a module ID, followed by a : and an option. In certain circumstances, an option can be followed by a path name inside square brackets. | Car:Model  
'My Car': 'an option'  
Wheel:Tyre[front.left] |
| **String** | A string literal is any characters enclosed inside double quotes. You can use the back slash character to escape itself and the double quotes character. | "This is a string \"hello\"" |
| **Integer** | An integer literal is any number. Optionally, you can place a - in front of the integer. | 34342  
-18344 |
| **Real** | An real number is any floating point number. To distinguish a whole number from an integer, always include the decimal point in real numbers, even if it is followed by a zero. However, Teamcenter attempts to interpret an integer as a real number if the context allows. | 1.3432  
-2342.1343  
67.0 |
| **Logical** | A logical literal. | true  
false |

**Reserved words**

<table>
<thead>
<tr>
<th>Reserved word</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>and</td>
<td>Logical AND of logical expressions.</td>
</tr>
<tr>
<td>default</td>
<td>Specifies a default for an option.</td>
</tr>
<tr>
<td>elif</td>
<td>Use to construct conditional statements.</td>
</tr>
<tr>
<td>else</td>
<td>Use to construct conditional statements.</td>
</tr>
<tr>
<td>endif</td>
<td>Use to construct conditional statements.</td>
</tr>
<tr>
<td>error</td>
<td>Sends an error message.</td>
</tr>
<tr>
<td>false</td>
<td>Logical FALSE literal.</td>
</tr>
<tr>
<td>fix</td>
<td>Fixes an option to a given value.</td>
</tr>
<tr>
<td>hide</td>
<td>Reserved for future use.</td>
</tr>
<tr>
<td>if</td>
<td>Use to construct conditional statements.</td>
</tr>
<tr>
<td>implements</td>
<td>Use to implement options.</td>
</tr>
<tr>
<td>inform</td>
<td>Sends an informational message.</td>
</tr>
<tr>
<td>integer</td>
<td>Denotes the integer value type.</td>
</tr>
<tr>
<td>legacy</td>
<td>Reserved for future use.</td>
</tr>
<tr>
<td>logical</td>
<td>Denotes the logical value type.</td>
</tr>
</tbody>
</table>
### Reserved word

<table>
<thead>
<tr>
<th>Reserved word</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>not</td>
<td>Logical <strong>NOT</strong> of logical expressions.</td>
</tr>
<tr>
<td>or</td>
<td>Logical <strong>OR</strong> of logical expressions.</td>
</tr>
<tr>
<td>presents</td>
<td>Use to present options.</td>
</tr>
<tr>
<td>private</td>
<td>Specifies a private option.</td>
</tr>
<tr>
<td>public</td>
<td>Specifies a public option.</td>
</tr>
<tr>
<td>real</td>
<td>Denotes the real value type.</td>
</tr>
<tr>
<td>set</td>
<td>Sets an option to a given value.</td>
</tr>
<tr>
<td>show</td>
<td>Reserved for future use.</td>
</tr>
<tr>
<td>string</td>
<td>Denotes the string value type.</td>
</tr>
<tr>
<td>then</td>
<td>Use to construct conditional statements.</td>
</tr>
<tr>
<td>to</td>
<td>Use in various places.</td>
</tr>
<tr>
<td>true</td>
<td>Logical <strong>TRUE</strong> literal.</td>
</tr>
<tr>
<td>unset</td>
<td>Literal <strong>UNSET</strong> value.</td>
</tr>
<tr>
<td>uses</td>
<td>Reserved for future use.</td>
</tr>
<tr>
<td>warn</td>
<td>Sends an warning message.</td>
</tr>
</tbody>
</table>

### Reserved symbols

<table>
<thead>
<tr>
<th>Reserved symbol</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal</td>
</tr>
<tr>
<td>!=</td>
<td>Not equal</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less equal</td>
</tr>
<tr>
<td>&gt;=</td>
<td>More equal</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less</td>
</tr>
<tr>
<td>&gt;</td>
<td>More</td>
</tr>
<tr>
<td>.</td>
<td>Dot</td>
</tr>
<tr>
<td>:</td>
<td>Colon</td>
</tr>
<tr>
<td>;</td>
<td>Semicolon</td>
</tr>
<tr>
<td>,</td>
<td>Comma</td>
</tr>
<tr>
<td>(</td>
<td>Bracket open</td>
</tr>
<tr>
<td>)</td>
<td>Bracket close</td>
</tr>
<tr>
<td>[</td>
<td>Square bracket open</td>
</tr>
<tr>
<td>]</td>
<td>Square bracket close</td>
</tr>
<tr>
<td>{</td>
<td>Curly braces open</td>
</tr>
<tr>
<td>}</td>
<td>Curly braces close</td>
</tr>
<tr>
<td>+</td>
<td>Plus</td>
</tr>
<tr>
<td>+=</td>
<td>Plus equal.</td>
</tr>
</tbody>
</table>
Chapter 16  Configuring structures by modular variants

Reserved symbol | Purpose
--- | ---
—= | Minus equals
— | Minus
* | Multiply
/ | Divide

**Using the expert mode**

As mentioned previously, the expert mode editor for complex constraints includes the Intellisense autocompletion feature. If you type a new constraint, the editor displays a dialog box containing suggestions for what you might type next. The contents of the dialog box changes according to any additional characters you type. If your typing does not match any of the suggested entries, the dialog box disappears and the text typed appears in the current cursor position in the text area. However, if you press a tab key or Enter key while the dialog box is open, Teamcenter transfers the current selection in the dialog box into the text area. You can use the up and down arrow keys to scroll through the list of suggestions or you can right-click in the suggestion list to select an entry directly. At any time, you can press the backspace key in the dialog window to hide the menu; you can type a space character, tab or new line to redisplay the appropriately populated dialog window.

The following table shows the suggested value that you can select, depending on the position of the cursor:

<table>
<thead>
<tr>
<th>Cursor position</th>
<th>Possible selections</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start of the expression</td>
<td>set, fix, if, warn, error, inform</td>
</tr>
<tr>
<td>2</td>
<td>Where an option selection is required</td>
<td>Module interface</td>
</tr>
</tbody>
</table>
### Configuring structures by modular variants

<table>
<thead>
<tr>
<th>Cursor position</th>
<th>Possible selections</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td><strong>set</strong> or <strong>fix</strong> following by an option</td>
<td>If you selected the option rather than typing it, <strong>to</strong> appears automatically and you do not need to make this selection. Go to line 4 of this table.</td>
</tr>
<tr>
<td>4</td>
<td>When a value selection is required</td>
<td>Valid value If the option requiring a value is an enumeration, a list of allowable values is shown. If the option is logical, <strong>true</strong> and <strong>false</strong> is shown. A value may also be another option of the same type from the module interface (see line 2). You must type strings and numbers manually in double quotes. Go to line 5.</td>
</tr>
<tr>
<td>5</td>
<td>After value</td>
<td>Appropriate operator or expression end If the expression already contains a comparison operator, <strong>and</strong> and <strong>or</strong> are shown. If you select one of these, go to line 2. If the value is numeric *<em>+, -, <em>, /</em></em> are shown. If you select one of these, go to line 4. If the value follows <strong>if</strong> and precedes a comparison operator, <strong>=</strong> and <strong>!=</strong>, as well as <strong>&lt;, &lt;=, &gt;, &gt;=</strong> if the value is numeric. If you select one of these, go to line 4. If you are building a constraint and the value follows both an <strong>if</strong> and a comparison operator, <strong>then</strong> is also shown. If you select this, go to line 6. If the constraint also contains <strong>then, else, else if, endif</strong> are also shown. If you select <strong>else</strong>, go to line 6.</td>
</tr>
</tbody>
</table>
Chapter 16  Configuring structures by modular variants

<table>
<thead>
<tr>
<th>Cursor position</th>
<th>Possible selections</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>After then in a derived default set, fix, error, warning, info</td>
<td>6. If you select else, go to line 2. If you select endif, Teamcenter disables all buttons other than OK and Cancel. If you are building a variant condition and the value follows both if and a comparison operator, endif is also shown. If you select this, Teamcenter halts interactive expression building.</td>
</tr>
<tr>
<td>7</td>
<td>After error, warning, or info None. You must type the message text.</td>
<td>If you select set or fix, go to line 2, otherwise go to line 7. Teamcenter creates single quotes (open and close) and places the cursor between them. You can place the cursor to the right of the closing quote to make else, else if, and endif available as selections (see line 5).</td>
</tr>
</tbody>
</table>

Example of an expression coded in MVL

In this example, the options in the following product structure are coded in MVL:

```
I0100 – Car
I0200 – BrakeSystem
  I0300 – Disk Brake Assembly
    I0400 – Standard Pads
    I0410 – Performance Pads
    I0420 – Solid Disk
    I0430 – Vented Disk
  I0300 – Disk Brake Assembly
    I0400 – Standard Pads
    I0410 – Performance Pads
    I0420 – Solid Disk
    I0430 – Vented Disk
I0310 – Drum Brake
```

Give the first of the I0320 lines the name front and the second one rear. Do this by modifying the blk_occ_occurrence_name occurrence name property. You should then add the following option declarations.

<table>
<thead>
<tr>
<th>Item</th>
<th>Scope</th>
<th>Name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>I0100</td>
<td>public</td>
<td>Model</td>
<td>string</td>
<td>LS, LX, GX</td>
</tr>
</tbody>
</table>
Configuring structures by modular variants

<table>
<thead>
<tr>
<th>Item</th>
<th>Scope</th>
<th>Name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>I0200</td>
<td>public</td>
<td>Config</td>
<td>string</td>
<td>Standard, Semi Sports, Sports</td>
</tr>
<tr>
<td>I0300</td>
<td>public</td>
<td>Performance</td>
<td>string</td>
<td>Normal, High</td>
</tr>
<tr>
<td>I0300</td>
<td>private</td>
<td>Pads</td>
<td>string</td>
<td>OK, Good</td>
</tr>
<tr>
<td>I0300</td>
<td>private</td>
<td>Disk</td>
<td>string</td>
<td>Solid, Vented</td>
</tr>
</tbody>
</table>

Now add the following MVL constraints:

<table>
<thead>
<tr>
<th>Item</th>
<th>MVL constraints</th>
</tr>
</thead>
</table>
| I0100 | if I0100:Model = "LS" then set I0200_BrakeSys:Config to "Standard" 
          elif I0100:Model = "LX" then set I0200_BrakeSys:Config to "Semi Sports" 
          else set I0200_BrakeSys:Config to "Sports" endif |
| I0200 | set I0300:Performance to "Normal" 
          if I0200:Config != "Standard" then set I0300:Performance[front] to "High" 
          endif 
          if I0200:Config = "Sports" then set I0300:Performance[rear] to "High" endif |
| I0300 | set I0300:Pads to "OK" 
          set I0300:Disk to "Solid" 
          if I0300:Performance = "High" then set I0300:Disk to "Vented" 
          set I0300:Pads to "Good" endif |

Configuring a variant structure by setting variant rules

You configure a variant structure by setting the option values on the top-level module. If the structure is completely authored with variant data, all the lower level modules are completely configured.

For example, users are offered the following public options when they configure the product.
Public options

Defaults are set for all the options and the dialog box contains the default values. However, users can override (set) the default values if they are not fixed defaults when you toggle Set/fix to Set. This prevents any subsequent programmatic set or fix of the option by MVL from overriding the value set by user.

Configure the variant structure

1. Click the Variant Rule button on the toolbar or choose Tools→Variants→Configure.
   Teamcenter displays the Configuration dialog box (as shown in the previous figure), showing all the options of the top-level module.

2. Set the following option values to configure the structure. You can place the cursor over the Value cell to display a tool tip containing further information about the required option value as follows.
   - Public or private
   - Option name
   - Allowed values
   - Implements (a global option definition) or presents (where appropriate)

   This information is displayed in modular variants language (MVL), for example:
   
   public ‘Appliance Width’ integer=500,600 default=500
Or

```java
public '002547 Number of shelves' presents 002547: 'Number of shelves'
Public 'Number of shelves' integer = 1, 2, 3, 0 default 3
```

If you want to restore the original, default settings, click the Default button.

**Note** In production use, you would not configure the structure for a lower level module. However, you may want to do this when debugging, to check that all options are set in the lower level modules when the top-level module is completely set (this verifies all options have a value). To do this, set Tools→Variants→Only Configure Root to off.

For general use, set Tools→Variants→Only Configure Root to on; the Configuration dialog box only displays options for the top-level module, regardless of the structure line selected.

### Selecting option values

In the **Configuration** dialog box, you can select option values in one of two ways, as follows:

- If an option has allowed values, Teamcenter displays all the available values.
- You select values for numeric (real and integer) options manually as a single value or a range. To see the allowed range or values, place the cursor over the option and Teamcenter displays a detailed tool tip.

The **Configure** dialog box contains a table of options and any default values set. Options that do not have a default value are blank. The features of the **Configure** dialog box that you can use to select option values are as follows.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading</td>
<td>Identifies and names the module to configure.</td>
</tr>
<tr>
<td>Option</td>
<td>Lists public and legacy options for the selected module.</td>
</tr>
<tr>
<td>Value</td>
<td>Opens a dialog box containing default values for options.</td>
</tr>
<tr>
<td>OK</td>
<td>Configures the structure and closes the dialog box.</td>
</tr>
<tr>
<td>Apply</td>
<td>Configures the structure and does not close the dialog box.</td>
</tr>
<tr>
<td>Load</td>
<td>Opens a dialog box that enables you to retrieve a saved configuration.</td>
</tr>
<tr>
<td>Save</td>
<td>Opens a dialog box that allows you to save the current configuration.</td>
</tr>
<tr>
<td>VI</td>
<td>Opens a variant item search dialog box with values set.</td>
</tr>
<tr>
<td>Default</td>
<td>Resets the configuration with option default values.</td>
</tr>
<tr>
<td>Clear</td>
<td>Clears all configuration values.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Closes the dialog box without applying configuration.</td>
</tr>
<tr>
<td>Display only public options</td>
<td>Shows configuration of private options. You cannot set them here.</td>
</tr>
<tr>
<td>Configuration</td>
<td>Displays the configuration status.</td>
</tr>
</tbody>
</table>
Test current product configuration

Checking that a product is completely authored is a manual process. You must set all option values for the relevant variant of the module, select each lower-level module (possibly starting at the lowest level modules) and check that all the option values are set correctly.

1. Choose **Tools→Variants→View Child Configurations→On**, allowing the **Configuration** dialog box to display options for the selected BOM line and not the top-level module.

2. Select each lower level module in the structure, then click the **Variant Rule** button on the toolbar or choose **Tools→Variants→Configure**.

   In each case, Teamcenter displays the **Configuration** dialog box, allowing you to confirm all the option values are set. The **Configuration** dialog box is updated dynamically and it is not necessary to re-display it each time you select a new module.

3. If all lower level modules are not completely configured, define further constraints in the higher level modules or present lower level options to the top-level module, as required.

4. Optionally, save the variant configuration tested as a saved configuration.

Create a saved configuration

Save the current configuration to save a configuration of modules with a large number of options for reuse, for example, in a separate session.

1. Click the **Save** button in the **Configuration** dialog box.

   Teamcenter displays the **Save** dialog box, as shown in the following figure. Note that two variant rules are already saved and attached to the current module.
Configuring structures by modular variants

Saving a variant configuration

2. In the dialog box, enter a name for the saved configuration, for example, 1200x500 Top Fridge.

3. Select the location of the saved configuration. By default, it is attached by a Specification relation to the current module, but you can select another relation from the list.

   Note: Your Teamcenter administrator configures the available relations by setting the PSESavedConfigRelationTypes site preference.

Load a saved configuration

You can load a previously saved configuration and apply it to the current module. If the configuration does not have all the option values defined, Teamcenter prompts you with the following message:

Clear values or overlay?
Not all options are set with this saved configuration.
Do you want to clear set values before applying this configuration?

Click one of the following buttons to continue:

- Click Yes to only set the option values set in the configuration and clear those values that are unset. You also restore defaults if set.

- Click No to omit any option values not defined in the loaded configuration as they are currently set.
Chapter 16  Configuring structures by modular variants

Caution  You cannot load variants of modular variant assemblies from NX; you can only load legacy data.

Importing and updating variant data

- You can import or update a stored option set (SOS) from an external system. To do this, your administrator must add the appropriate closure rule to the transfer mode, as described in the PLM XML/TC XML Export Import Administration Guide. You must choose this transfer mode each time you import or update an SOS.

Creating and searching for variant items

For details of how to create and search variant items, see Creating and updating variant items.

Populate a complete variant structure

There are two approaches to populating a variant structure—top-down and iterative bottom-up.

The most common approach for simple products is top-down. A customer places an order and the salesman sets the values of the options in the variant rule, then creates a variant item for the top-level item. The variant item represents the customer order. The salesman then substitutes all the lower level modules with variant items, if they exist, or creates new ones if they do not exist.

Alternatively, you can use an iterative bottom-up approach when the customer order can be adjusted to use variants items that are already available, as follows:

1. The salesman uses an SOS at the top level of the structure to define the customer order; a variant item is not yet created. This action configures the entire structure.

2. The salesman searches for variant items for each module to see if they exist. This is an iterative process-creating variant items and changing values on the SOS until a complete structure of variant items is created. The customer may want to modify the original SOS due to variant items that are available and satisfactory, but did not match the original specification.

Caution  You cannot push values for lower level saved option sets up to higher levels.

3. When a complete set of variant items are located, the salesman confirms the top-level SOS option values are correct and verifies the configuration with the customer order.

4. The salesman creates a variant item for the top level by saving the generic item with a unique customer name and prunes unconfigured structure lines. The children that are modules are still generic.

5. Edit the structure by substituting the generic modules with the variant item that works for the SOS at the top level.
6. Repeat step 5 for all other modules at all levels.

Creating and updating variant items

A variant item is a specific variant of a completely configured assembly, for example, a Door assembly with \texttt{height = 500, width = 600; application = fridge, and color = white}. Variant items are physical parts with no variability. You can allocate a manufacturing part number to a variant item.

You cannot manufacture an unconfigured structure. They may have a large number of options and numeric options; options have a limited number of selections, while numeric options may have an infinite range unless permitted values are specified. This results in a correspondingly large number of product permutations, not all of which are valid. You may want to reuse permutations that have previously been sold, particularly if significant engineering work was invested in creating the associated technical documentation, drawings and manufacturing data. You can attach such associated data to the variant items once they are created.

You can search for existing variant items so that they can be reused. If a suitable variant item does not already exist, you can create new variant items as required. You can then build up variant items into a complete structure for a specific configuration, for example, a configuration that corresponds to a customer order. In this specific configuration, all modules are replaced by variant items.

It is good business practice to release the generic item revision before you generate variant items from it. If you do not do this, the variant items fully correspond to the generic items from which you generated them. Teamcenter does not enforce a release process for generic item revisions.

Teamcenter allows you to manage variant items, as follows:

- Search for existing variant items by entering option values.
- Create a new variant item if no existing variant item is found. You should create new variant item at the lowest possible level of the structure.
- Replace a selected variant item in the associated assembly to build up a complete variant item structure.
- Open a variant item and view it.

After creating a variant item from a generic structure, you cannot make any structure changes to the BOM view revisions of the generic item revision or the variant item revision. Such changes make both the generic structure and the variant item structure invalid. To make any such structural change, revise the generic structure and then make changes to the new revision. These changes are not reflected in previously linked variant items automatically; you must search for the affected variant items and update them individually with the changes.

You cannot make structural changes to the generic item when it is linked to a variant item, including adding or removing a line, and creating a relation. Likewise, you can change the item revision master form attributes on the variant item, but cannot make structural changes. If you make changes to the master form attributes, you should search for other variant items that should be updated. For more information about updating a variant item, see \textit{Update a variant item}.

\textit{Configuring structures by modular variants}
Search for a variant item

Before starting this process, ensure you have created a variant item for the top level, as described in Create a new variant item. Typically, this has a completely defined saved option set with a value or a range of values specified for all options. Alternatively, you can start with an incomplete saved option set and use an iterative process to populate the lower level generic items. You should replace all the generic items with variant items.

**Note**  You can automatically create variant items for an entire generic structure, as described in Create variant items automatically.

Likewise, relationships such as Connected To are carried forward from the generic component to the variant item.

To search for an existing variant item (for example, to make a substitution), open the top-level variant item by clicking the Open button and choosing Tools→Variants→Search.

Teamcenter displays the Variant Item Search dialog box.

When you perform a variant item search, Teamcenter applies the current Structure Manager revision rule to the generic structure and configures the revisions accordingly.

If Tools→Variants→Only Configure Root is not selected, the dialog box shows options for the root module only. If it is selected, you can use it to identify reuse for any module represented by a selected line in the structure.

After you specify the search requirements, execute a query for matching variant items by clicking the Search button.

Teamcenter displays the search results at the bottom of the dialog box showing the matching variant items. Search results in which one variant item matches the criteria are shown in the following example.

If the query is successful, the identifiers and names of variant items whose values match the search criteria populate the list next to the Search button.
The search only finds *linked* variant items—unlinked variant items may have structure changes and would therefore not be applicable.

If the variant item search is successful, Teamcenter loads the first variant item returned by the query and shows its values in the **Value Found** column. If you select a different variant item from the list, Teamcenter loads it and updates the **Value Found** column. You can then click the **Replace** button to replace the selected item with the variant item.

**Create a new variant item**

If a variant item search is unsuccessful, you can create a new variant item to replace the selected generic item as follows:

1. **Ensure you specify a single value for each option and each requirement** (that is, do not enter ranges or multiple selections), and then click **New**. Teamcenter displays the **New Variant Item** dialog box. (This dialog box is similar to the **New Item** dialog box but includes an additional tab that shows the configuration values.)

2. **Optionally**, click **Default** to clear the table and populate the requirements with option defaults.

3. **Optionally**, click **Replace** to define the new variant item as a replacement for the selected generic item.

4. Click **Apply** to configure the structure with the selected variant item.

A typical variant configuration is shown in the following example.

In this example, all the options and values are unavailable (grayed out) because you cannot modify them for a variant item.
The following example shows a structure in which all the generic modules are not yet replaced with variant items; for example, the cooling system and carcass. The variant structure is complete only when you replace these generic modules with variant items.

Variant items are identified by a gray image with a red check mark \( \text{\ding{51}} \); generic modules are identified by a gray image \textit{without} the red check mark \( \text{\ding{51}} \).

**Adding a generic item property**

You can add the \textbf{Generic Item} property as a column in the properties table in the structure. Use this column to see the generic item to which a variant item is linked.

For details of how to add a property as a column in the properties table, see \textit{Displaying properties}.

**Create variant items automatically**

You can create a fully instantiated structure by manually searching for generic items and substituting a variant item for each such generic item, as described previously. However, this process is time-consuming if your structure is large and complex. In this case, consider creating variant item structures automatically as follows.
Item IDs are generated automatically, according to the naming rule for the item type of the generic structure; however, if you set the `PSEAutoViNewItemPopup` preference to `True`, you are prompted for an item ID during the creation process. If you set this preference to `False`, no prompts are displayed.

If you configure automatic creation, you can set a prefix for the name with the `PSEAutoViNamePrefix` preference.

Beginning with Teamcenter 10, the order in which variant items are automatically created is changed. Prior to Teamcenter 10, lines were processed according to their position or appearance with respect to the top line. Consequently, children of the first subassembly under the top line were processed before the second subassembly. This is referred to as the depth-first-search method. After Teamcenter 10, lines are processed in order of their level in the structure. For example, all subassemblies of an equivalent level are processed together before any of their children. This is referred to as the breadth-first-search method.

1. Load and select the generic structure for which you want to automatically create variant items.

2. Click the **Variant Rule** button on the toolbar or choose **Tools** → **Variants** → **Configure**.

   Teamcenter displays the **Configuration** dialog box, showing all the options of the top-level module.

3. Click the **VI** button on the dialog box.

   Teamcenter displays the **Search** dialog box.

4. Select the required option and click the **Search** button.

   If there is not already a variant item for the top line, the search results list is empty and Teamcenter enables the **Auto VI** button.

5. To begin automatic creation of variant items, click the **Auto VI** button.

   Teamcenter displays the **Auto Create VI Structures** confirmation dialog box.

6. Click **Yes** in the dialog box.

   Teamcenter begins the automatic creation process. It displays a progress bar until all variant items are complete. The dialog box is updated constantly with results as the variant items are created and substituted. The preceding **Search** dialog box also shows feedback as the process continues. This process may take a significant time to complete if you have a large generic structure and particularly if the variant logic is large and complex at the upper levels.

**Tip** If performance is not acceptable, try creating variant items for the upper level manually and automatically populating the generic structure for the lower levels. You can then manually substitute these variant items into the variant item for the top level.
If you request a prompt for each item identifier, item revision identifier, and item name, Teamcenter displays the **New Variant Item** dialog box each time and the process pauses until you enter values in the dialog box and click **Finish**.

**Note** This prompt displays only if the **PSEAutoViNewItemPopup** preference is set to **ON**.

7. When the automatic creation process is complete, Teamcenter enables the **OK** button, and you can click this button to close the progress window.

**Setting preferences for automatic variant item creation**

You can set the following preferences to determine how variant items are created:

- **PSEAutoViCreateEmptyVI**
  This preference determines if the process creates a variant item for each nonmodule that Teamcenter encounters. If set to **True** (on), the process continues to the bottom of the generic structure, assigning empty variant items (variant items with no variant configuration) for each item that is not a module. If set to **False** (off), Teamcenter does not creates a variant item for a nonmodule.

- **PSEAutoViStopVICreationForUnconfiguredModule**
  This preference determines if the automatic creation process stops as soon as it encounters an item that is not a generic item. If set to **False** (off), the process continues to the bottom of the generic structure, displaying warning messages for each unconfigured generic item encountered. (This is the best practice for most business environments.) If set to **True** (on), Teamcenter stops the process when it encounters an unconfigured generic item.

- **PSEAutoViNewItemPopup**
  This preference determines if Teamcenter prompts you for an item identifier, item revision identifier and item name each time the automatic creation process creates a variant item. If set to **False** (off), Teamcenter automatically assigns values according to the predefined numbering and naming schemes. For example, if you have a generic item called **00100/A Generic Wheel**, Teamcenter may create a generic item called **00200/A VI_Generic Wheel**. If set to **True** (on), Teamcenter prompts you for this information each time a variant item is created.

- **PSEAutoViNamePrefix**
  If the **PSEAutoViNewItemPopup** preference is set to **False** (off), this preference defines the naming scheme prefix that Teamcenter uses. For example, if you set this preference to **VI**- and create a generic item called **Wheel**, the name of the variant item is **VI-Wheel**.

- **PSEBypassVISearch**
  Set this preference to **true** to add a **Create** button to the **Configure** dialog box as soon as the user sets a value for each option. This allows the user to bypass the requirement to search for similar variant item configurations before creating a new variant item. The default setting is **false**.

- **PSECreateVISameType**
If you set this preference to true, Teamcenter always creates a variant item with the same type as its parent and creates the variant item with a Save As action. The default setting is false.

For more information about setting preferences, see the Preferences and Environment Variables Reference.

Revising variant items and generic modules

When you create a variant item, Teamcenter links it to the generic module item revision from which it is generated. This relationship allows you to search for variant items. It also prevents any changes to the variant items, unless they are unlinked, as described in Unlink variant items. However, you cannot search for unlinked variant items.

You cannot make changes to the option data, add or remove static components, or apply variant conditions to a generic item if it is linked to a variant item, as these actions would cause inconsistencies. You must revise the generic item before making changes.

If any option data is changed on the newly-revised generic item, you cannot revise the existing variant items, but must create new variant items.

At this point, there are no longer any variant items linked to the new generic item revision. The changes made are not reflected automatically in any existing variant items linked to previous generic item revisions. You must search for the affected variant items and update them individually with the changes.

However, you cannot make structural changes to the generic item when it is linked to a variant item, including adding or removing a line, and creating a relation.

You can change the item revision master form attributes on the variant item, but you cannot make structural changes. If you make changes to the master form attributes, you should search for other variant items that should be updated.

Update a variant item

When you make structural or option data changes to a generic item, Teamcenter does not automatically propagate such changes to the variant item revisions associated with previous module revisions. You can make such changes manually by creating a new revision of selected variant items to include the structural changes, as follows:

You can only revise variant items to reflect changes to the generic item if the variability is unchanged, that is, it has the same options and allowed values. You can add static components, but not components that have a variant condition, unless the variant condition refers to the original options and values.

1. Load the structure, select the revised generic item, and choose Tools→Variants→Update Variant Item.

Teamcenter displays the welcome window of the VI Update wizard.

You can load the structure with the generic item revision as the top-level line or with the generic item at a lower level. If the generic item revision is not
the top-level line, you must set Tools→Variants→Only Configure Root to Off before you can update variant items.

**Note**

You cannot update variant items if only one item revision of the generic item exists. You can only update variant items against the second and subsequent item revisions of the generic item.

2. Select the previous item revision of the generic item whose variant items you want to update and click Next.

The **VI Update** wizard shows the saved option set values against which you can search for applicable variant items.

3. Choose the saved option set values against which you want to search for variant items from the lists and click Next.

The **VI Update** wizard shows a list of variant items matching the chosen criteria.

**Note**

If you leave any saved option set values blank, Teamcenter includes all possible values in the search criteria. If you leave all saved option set values blank, the results include all available variant items.

4. Select the variant items to update from the list of search results, and click Update to create new variant item revisions that include the structure changes.

Teamcenter shows the **Revise** dialog box, allowing you to define a revision, name, description and unit of measure for the new variant item revision.

To view a selected variant item revision before you update it, click Open.

5. After you define the new variant item revision and click Finish, Teamcenter closes the **Revise** dialog box and updates the **VI Update** wizard with the new variant item revision. The Update button is grayed out and you cannot make further changes to the new variant item revision. To inspect the new variant item revision, click the Open button.

6. If applicable, you can select another variant item revision from the list and repeat the update procedure. Do this until all the necessary variant item revisions are updated.

7. After you finish updating new variant item revisions, click Next and the **VI Update** wizard allows you to select another generic item revision whose variant item revisions require updating.

To update the variant item revisions of another generic item revision, select the **Do you want to update variant items for other revisions of the generic component?** check box and click Finish.

To exit without updating additional variant item revisions, click Finish without selecting the check box.

**Unlink variant items**

You may want to unlink variant items from the generic module item so that you can change the variant item. This is desirable if you use the generic structure as a quick way to create variant items for a particular customer order and the generic order is then further customized for the specific order.
To unlink variant items, choose **Tools→Variants→Unlink Variant Item**.

Teamcenter displays the **Unlink Variant Item** dialog box and you can click **Yes** to confirm deletion of the variant item.

When you unlink variant items, they are not found during a variant item search, because they have evolved and may not be appropriate for the purpose. However, if they are still appropriate, you can reuse in the structure for a new order.

**Note** You cannot relink a variant item after you have unlinked it from the generic module.

### Synchronizing with NX

You can use option values to drive NX part expression values from variant items. For variant items, the option values are fixed and hence the geometry of the CAD design also remains fixed. You cannot synchronize generic item modules with NX, as the value may change each time a variant rule is specified.

To enable synchronization, choose the corresponding customer default in NX.

When you create a variant item, Teamcenter performs a **Save As** operation. For correct synchronization with NX, use Business Modeler IDE to set your deep copy rules for **Save As** on the appropriate item type so that Teamcenter copies the **UGMASTER** dataset as an object, not as reference.

Set the Business Modeler IDE rules for deep copies so that, when you choose the **Save As** command for an item revision, the following are copied as objects:

- **UGMaster** datasets
- **UGPart** datasets
- **Altreps**
- (Optional) **UGScenario** datasets
- (Optional) **DirectModel** datasets

To create JT files for modular piece parts and view them in Teamcenter, you must create the corresponding variant items and persistently store the JT files for the different geometry.

You can drive piece part geometry from an assembly using the options presented to the assembly from the piece parts. To do this, set the value of the option on the assembly, which sets the option on the piece part in the **generic** structure. You then create a variant item for the assembly, which has an option and a value, and the value is the same as for the assembly. You now create a variant item with the corresponding option value, and substitute it into the assembly for the generic part. There is now an implicit link through the variant item structure.

**Note** Creating a variant item of an assembly does not automatically create variant items of the piece parts in the assembly. You must manually or automatically create variant items throughout the structure, as described in the previous paragraph.

The synchronization process matches the option and expression names, so you must take care to ensure they are identical and note the following points:
Chapter 16  Configuring structures by modular variants

- Names are case sensitive
- Do not use spaces in option names as expressions cannot accept spaces.
- Do not use underscores.

Caution: NX does not indicate if an expression is synchronized with Teamcenter. If the expression value is changed manually in NX, the manual value is overwritten next time the part is loaded from Teamcenter. You can use naming conventions as an indication of synchronization.

You can optionally create a special item type for variant items. If you do this, ensure the type is set to the base type, not the variant item type.

Driving geometry

The following figures shows how a Height option in Teamcenter drives a Height expression value in NX.
Mapping options to expressions in NX

Driving assembly component position

You can drive assembly component positions with mating conditions by setting the expression value of the mating offset to linear or angular.

Working with component arrays

You can drive component arrays in NX from Teamcenter options, but should take care in certain situations. For example, you may have a number of holes in a circular array that are controlled by an array in NX. Bolts are located in each hole and consequently the number of bolts needed is determined by the number of holes. Similarly, the positions of the bolts depend on the positions of the holes.

The number of bolts can be determined by a Teamcenter variant condition, for example:

For bolts 7 and 8, variant condition = I f No_Bolts>7
For bolts 9 and 10, variant condition = I f No_Bolts>8

You may encounter problems if you use the NX array to determine the number of bolts in this situation and, if possible, you should avoid arrays. Alternatively, you can define the location of each bolt as a mating offset, whose size is determined by a formula, for example, \(360/(\text{No_Bolts} - 1)\). Each bolt is then mated to a bolt that
is always present, rather than possibly mated to a suppressed and unconfigured component.

Take care to associate the variant condition with the correct component. To achieve this, you can label each occurrence in NX with the component name and make the same name visible in the Teamcenter product structure.

You can control this functionality with the Teamcenter Integration for NX assembly **Variant Item Update** preference.
Chapter

17 Working with platform designs

Working with platform designs .................................................. 17-1
Create global options .............................................................. 17-1
Add an architecture element to a design .................................. 17-2
Adding a new component in the installation assembly ............... 17-2
Replace a design in a product .................................................. 17-2
Replace part in product ........................................................... 17-4
Creating an audit report .......................................................... 17-4
   Create an audit report ......................................................... 17-5
Remove a design from a product ............................................. 17-6
Chapter

17 Working with platform designs

Working with platform designs

In a typical organization, CAD designers and part engineers are not expected to author variability without guidance, although they must be aware of the variability their design supports. Teamcenter allows configuration experts to use Platform Designer to define variability against a known nomenclature with which designers are familiar. This scheme is referred to as the product architecture and each company has a unique taxonomy for defining their generic parts within such a scheme. Designers and part engineers can use Structure Manager to utilize this predefined variability in their designs. For more details about platform designs and architecture, see Getting Started with Product Structure and the Platform Designer Guide.

Create global options

Use Structure Manager to create global options that are unique across all programs, that is, options that are unique to your design and do not appear in any other product architecture. Depending on the size of your product, this list can become extremely large, so it is important to analyze the need for each option carefully.

1. Create the master variant data as a set of options for a specific product item. You must use classic variants.

   For more information about creating variant options, see Configuring structures by classic variants.

2. Enter the ID of the item in which you created the options as the value in the PSM_global_option_item_ids preference. You can create more than one global option item to create a different set of options for different product contexts.

   ![Note](image)

   To add items to the list of IDs, in Structure Manager, select an item and choose Tools→Variants→Set/Unset Global Option Item.

3. Restart the rich client.

   An additional tab labelled Variability now appears in Structure Manager. Use the Variability tab to assign variability to a product context for use in Platform Designer.

   For more information, see the Platform Designer Guide.
Add an architecture element to a design

Add an existing architecture element to the design in Structure Manager, as follows:

1. In Structure Manager, select and right-click the top level node of the structure. Teamcenter displays a shortcut menu.

2. Choose Set In Context to enable in context edits anywhere in the structure.

3. For each occurrence that appears both in the design and the product architecture, edit the identifiers so that the absolute occurrence identifier matches the architecture element identifier. Teamcenter maps the item to the architecture element.

   After creating an architecture breakdown structure in Platform Designer and sending it to Structure Manager, do not copy and paste or drag and drop architecture elements in the same window. It can lead to data corruption in Platform Designer. If you inadvertently perform one of these actions, delete the resulting line using the Remove Design from Product button.

Adding a new component in the installation assembly

If a new component is added to the installation assembly and the absolute occurrence identifier matches the architecture element, Teamcenter creates a new occurrence in the structure in Structure Manager, then registers named variant expressions (NVEs) and sets the variant condition on the occurrence.

When the product structure contains the installation assembly with the new occurrence, you can configure the product for the new component by applying an appropriate variant rule to the top level node.

Replace a design in a product

If you are using Platform Designer to help manage the variability of your product, you can replace your CAD design solution in the product structure with another design using the Replace Design in Product wizard in Structure Manager. This wizard assists you in finding the correct design based on the variability associated with the architecture breakdown element. The resulting design solution carries design usage properties such as shape, position, effectivity, or variant expressions.

1. Select the structure line for the design solution to which you want to add variant data.

2. Click Replace Design in Product.

   The Replace Design in Product dialog box is displayed.

3. Locate the product context item revision by defining your search criteria in the search boxes and clicking .

   The system displays the results of the search in the upper pane. Alternatively, you can copy the product item to the clipboard and paste.
4. Select the required product context.
   The system displays the product context in the lower pane.
   Teamcenter remembers the product context the next time you use the wizard, so steps 3 and 4 are not required if you are not changing the product context.

5. Click Next.
   The design solution is displayed in the upper and lower panes. Ignore the upper part of the wizard. This is for the Add design to product wizard that shares the same pane.

6. Click Next.

7. In the Architecture box, select the top-level architecture you want to use. This is only necessary if there is more than one architecture.
   Do not skip this step if there are multiple architectures; otherwise, the next steps in the wizard do not work as expected.
   Teamcenter remembers this selection the next time you use the wizard.

8. Specify the architecture element to which you want to add the design solution in the Architecture Element ID box. Do one of the following:
   • Type the ID.
   • Click 🖼 to display the architecture. Expand to the required element and double-click to enter its ID in the Architecture Element ID box.

9. Click Next.

10. In the top part of the pane, select the named variant expressions (NVEs) that apply to the design solution.

11. (Optional) In the bottom part of the pane, further define the conditions under which this solution is valid by selecting additional splitting NVEs.
    Teamcenter adds these to the existing NVEs to further qualify the design that you select.

12. Click Finish.
    Teamcenter populates the NVE and associated variant condition on the occurrence of the design solution you selected in the first step.

   Display the Architecture Element ID property in Structure Manager to see the architecture element with which the design solution is now associated.
Chapter 17  Working with platform designs

Your design solution now has variant data and you can configure it by applying a variant rule to the design structure.

Replace part in product

- Click and follow the steps described for the Add Part to Product wizard in Platform Designer.

For more information, see the Platform Designer Guide.

The Replace Part in Product wizard behaves in basically the same way as the Add Part to Product wizard, except that you can use it to update the values for the part data (copied to the usage notes) or select a different NVE. The variant condition on the instance of the part solution is updated if the NVE changes.

Creating an audit report

Audit reports allow you to check that design solutions exist for each option combination (NVE) required on the architecture elements. This feature assumes you use both part and design solutions; if you use only part solutions, do not use this report.

Note  You create audit reports for design solutions in Structure Manager. Use Platform Designer to create audit reports for part solutions.

To create an audit report for design solutions, Teamcenter first performs a consistency check, verifying that for each design solution in the selected installation assembly, there is a part solution that matches the NVE on the design solution. It also checks that the variant condition on the design solution is consistent with the variant condition on the part solution. If the NVE changes on the architecture or part solution, the variant condition on the design solution may be out-of-date and require refreshing. Alternatively, the design solution itself may be changed to meet the new NVE requirement.
Designers perform this type of audit on the installation assembly for which they are responsible. You cannot perform this audit on a level higher than the installation assembly.

You can still use the audit report if no part solutions exist yet, because the NVEs on the architecture are checked. You can create an audit report for a particular configuration by setting the variant and revision rules audit algorithm details. The audit checks the following:

- If the NVE is not referenced by any solution.
- If the NVE is referenced by one or more solutions with a matching architecture element ID, but the variant condition is out-of-date (assuming there are no split NVEs).
- If the usage quantity is not a positive integer.
- If the solutions are referencing an NVE, but the architecture element ID references a split NVE.
- If the NVE is referenced by one or more solutions, but none of them have an architecture element ID that matches that of the NVE. The audit report delivers a list of architecture breakdowns in rows, with colored indicators specifying whether the line is an exact, partial, or mismatch with respect to an NVE, part number (typically the part solution ID), and usage quantity.

The audit algorithms use data stored in occurrence notes on the design solution. It is therefore necessary to replace a design in the product using the Replace Design in Product wizard before the audit can be run to populate the appropriate occurrence notes. These occurrence notes are:

- **Usage_Product**
- **Usage_PartNumber**
- **Usage_Quantity**

Configure these occurrence notes by setting the RDV_copied_occurrence_notes preference.

Create an audit report

1. Ensure you have set the following preferences:
   - **RDV_auto_functionality**
     When set to TRUE, Structure Manager displays the Tools→Audit Report menu command.
   - **RDV_copied_occurrence_notes**
     Specifies the occurrence notes for the Replace Design in Product wizard to populate before you can run the audit, for example, Usage_Product, Usage_PartNumber, and Usage_Quantity.

2. Select the installation assembly for which you want to create an audit report.
Chapter 17  Working with platform designs

**Note**  The audit only checks the immediate components of the installation assembly. Do not select a level higher than the installation assembly to which the design solutions are attached.

3. Choose **Tools→Audit Report**.

   The audit report opens in a separate dialog box.

4. At the top of the dialog box, choose a revision rule from the **Revision Rule** list. If the installation assembly structure is precise, select the appropriate revision rule. You can also audit a specific variant configuration by selecting a saved variant rule.

5. Click **Audit**.

   Structure Manager creates the audit report.

6. Select the top-level audit lines in the tree on the left to see the results.

   The audit report lists all the components in the selected installation assembly. You can expand the design to see the associated part solution—only two lines in the following example. However, for those lines, the NVE is matched, but the quantity is not.

7. (Optional) Refresh the variant condition and other copied occurrence data for the selected audit line by clicking at the bottom of the dialog box.

8. (Optional) Select a line in the report and click the **Details** tab to see all relevant attributes of this line.

**Remove a design from a product**

- Remove a selected design from a product structure by clicking the **Remove Design** button.
Chapter

18 Working with projects

Working with projects .................................................. 18-1
Assigning objects to projects ........................................... 18-1
Assign objects to projects from the tree or Properties table .... 18-2
Assign objects to projects by search results page or assign all objects found by the search ........................................... 18-2
Remove objects from projects ........................................... 18-3
Chapter

18 Working with projects

Working with projects

Projects represent and control access to a particular piece of work that may be accessible to multiple organizations, such as project teams, development teams, suppliers, and customers.

Objects, such as items, item revisions, datasets, and forms can be assigned to projects. Additionally, folders, or folders and their contents can be assigned to projects. Items, item revisions, and engineering change objects can be assigned to projects during the creation process. All other workspace objects can only be assigned to projects after the object has been created. Objects can be selected from search results and assigned to a project or projects.

When an object is assigned to a project, attachment objects, as defined by the propagation rules, are also assigned to the project. Propagation rules are determined by include and exclude relations lists. By default, the include relation list contains the following relation types:

- Specification
- Manifestation
- AltRep
- EC_affected_item_rel
- EC_solution_item_rel

For more information about defining propagation rules, see the Project and Program Guide.

You can only assign objects to projects if you are a privileged project team member. For more information, see the Project and Program Guide.

If you are a Teamcenter administrator or a project administrator, you can assign multiple objects in a structure to a project by running the update_project_bom utility. You can also use this utility to remove multiple objects from a structure.

Assigning objects to projects

Objects can be assigned to projects either during the creation process or after they are created. Items, item revisions, and engineering change objects can be assigned to a project during the creation process, all other objects must be assigned after they are created.
Objects can be assigned to projects by making selections from the tree or Properties table or by selecting from the search results display.

**Note** You can select from different lists of values (LOVs) for a property, depending on which project the object is assigned to.

For more information, see the Project and Program Guide.

### Assign objects to projects from the tree or Properties table

1. Select one or more objects in the tree display or Properties table.

2. Right-click and choose **Project→Assign**, or choose **Tools→Project→Assign** from the main menu.

   If multiple objects were selected in step 1, the system displays the **Assign Objects to Projects** dialog box. If a single object was selected, the system displays the **Assign an Object to Projects** dialog box. The projects of which you are a privileged member are displayed in the **Projects for Selection** list.

   **Caution** The objects you selected in step 1 may already be assigned to one or more projects. However, this is not reflected in the selection list.

3. Select the project or projects to which the objects will be assigned and move them to the **Selected Projects** list using the right-arrow button. To select all projects in the list, click the double-arrow button.

4. Click **Apply** to assign the objects to the projects and retain the dialog box. Click **OK** to assign the projects and dismiss the dialog box.

   **Note** You can also assign a selected object to a project by dragging it onto the project symbol.

### Assign objects to projects by search results page or assign all objects found by the search

1. Right-click a search results tab.

   Teamcenter displays the Explorer shortcut menu.

2. Choose **Project→Assign**.

   Teamcenter displays the **Assign Object to Projects** dialog box.

3. Select the project or projects to which the objects will be assigned and move them to the **Selected Projects** list using the right-arrow button. To select all projects in the list, click the double-arrow button.

4. Select the objects to be assigned by selecting either the **Current Page** or **All Found Objects** button.

5. Click **Apply** to assign the objects to the projects and retain the dialog box. Click **OK** to assign the projects and dismiss the dialog box.
To selectively assign objects displayed in the search results tab, select the search results tab and perform the steps described in *Assign objects to projects from the tree or Properties table*.

## Remove objects from projects

1. Select one or more objects in the tree display or Properties table. You can also select the objects from the results of a search.

   **Note**: Two standard search forms, the Projects Search form and Objects in Projects form can be used to locate objects for removal from a project.

2. Right-click and choose Project→Remove, or choose Tools→Project→Remove from the main menu.

   If multiple objects were selected in step 1, the system displays the Remove Objects From Projects dialog box. If a single object was selected, the system displays the Remove an Object from Projects dialog box. The projects of which you are a privileged member are displayed in the Projects for Selection list.

3. Select the project or projects from which the objects will be removed and move them to the Selected Projects list using the right-arrow button. To select all projects in the list, click the double-arrow button.

4. Click Apply to remove the objects from the projects and retain the dialog box. Click OK to remove the projects and dismiss the dialog box.
Chapter

19 Administering the product structure

Administering the product structure ........................................ 19-1
Managing BOM view types .............................................. 19-1
  Create a BOM view type ........................................ 19-1
  Transitioning a site to multiple BOM views ......................... 19-2
    Renaming the default view .................................... 19-2
    Prerequisites for implementing multiple BOM views ........... 19-3
    Rename multiple BOM views .................................. 19-3

Setting assembly preferences ........................................... 19-3
  Setting assembly level of detail .................................. 19-3
  Determining JT file priorities ................................... 19-4
  Determining excluded reference sets .............................. 19-5

Create occurrence note types ........................................... 19-5

Configuring modular variants ........................................... 19-6

Configuring incremental change ....................................... 19-8

Using default revision rules ........................................... 19-9
  General rules .................................................. 19-9
  Released revisions only ....................................... 19-10
  Latest revisions ................................ .............. 19-10
  Precise revisions ............................................. 19-10
  Controlling access to revision rules ............................ 19-11
  Controlling access to snapshots ................................ 19-11

Importing remote components ......................................... 19-12

Apply a vendor parts selection rule ................................ 19-12

Configure units of measure ............................................. 19-12
Chapter

19 Administering the product structure

Administering the product structure

The Teamcenter administrator creates and manages BOM view and occurrence note types. To create or edit these types, you must be a member of the system administrator group.

Before creating new view types or occurrence note types, you should be familiar with the concepts described in Building and editing product structure.

For additional information, see Getting Started with Product Structure.

Managing BOM view types

BOM view types have only one modifiable attribute, Name. When you modify a BOM view type, you are initiating a single action that is equivalent to creating a new BOM view type and deleting an old BOM view type. However, you cannot delete Teamcenter objects from the database if they are referenced by other objects. Therefore, in most cases, you use the modify (rename) action to change the name of an existing BOM view type.

Note The view type is an attribute of a BOM view revision that specifies its intended usage, for example, design or manufacture. The administrator may define any number of view types, as described in the Business Modeler IDE Guide.

Teamcenter applies a default global view type where possible, for example, when opening an item revision. Use of a default view type avoids the need for a user to choose between multiple views.

Create a BOM view type

1. Start the Business Modeler IDE and, in the Extensions view, select the project in which you want to create the new note type. Right-click the project and choose Organize→Set active extension file on the shortcut menu. Select the options.xml file as the file in which to save the new BOM view type.

2. Expand the project and the Options→View Type folders.

3. Right-click the View Type folder and choose New View Type from the shortcut menu. The New View Type wizard runs.
4. Perform the following steps in the **View Type** dialog box:

   **Note** The **Project** box defaults to the already selected project.

   a. In the **Name** box, enter the name you want to assign to the new BOM view type.

   b. In the **Description** box, enter a description of the new BOM view type.

   c. Select the **Attach Value List** check box if you want to attach a list of values (LOV) to the BOM view type.

   d. If you select the **Attach Value List** check box, click the **Browse** button to the right of the **LOV** box to locate the list of values to attach to the BOM view. Type an asterisk * in the **Find** dialog box to see all possible selections. Click the **Browse** button to the right of the **Default Value** box to choose the value from the list of values that you want to use for the BOM view type.

   e. Click **Finish**.

   The new BOM view type displays under the View folder in the Extensions view.

5. To save the changes to the data model, choose **File → Save Data Model**.

**Transitioning a site to multiple BOM views**

Before you transition to production use of multiple BOM views, you must understand the definitions of **view** and **default view**, as described in *Getting Started with Product Structure*.

Although Teamcenter supports multiple BOM views, the default configuration is a single BOM view type called **View** that applies to the entire site. To manage multiple BOM views, you must designate one BOM view type as the default view by setting the **PSE_default_view_type** preference. Because the initial (default) configuration of Teamcenter installation and upgrades from all previous versions of Teamcenter is single view and uses the **View** BOM view type, this preference is set to **view** by default.

**Renaming the default view**

When sites transition to multiple BOM views, the **View** BOM view name may be too generic to retain. Before proceeding with a site-wide implementation of multiple BOM views, consider if you want to continue using this generic BOM view type or if you should rename it to something more meaningful.

When you rename a BOM view type, the change is immediate. However, if you use the default BOM view revision (BVR) names provided with Teamcenter, these names are no longer appropriate. When it creates each BVR, Teamcenter assigns it a name according to the BOM view type and item revision ID. If you subsequently change the name of the BOM view type, the names of existing BOM view revisions that use this name are not automatically updated. You can rename affected BVRs by running the **ps_rename_bvrs** utility against them, as described in the *Utilities Reference*.

The **ps_rename_bvrs** utility renames existing BOM views and BOM view revisions (BVRs) to the current default naming scheme implemented by the
USER_ps_default_bom_view_name and USER_ps_default_bvr_name user exits. You do not need to synchronize BVR names immediately after renaming the BOM view type, but can perform this activity in batches for multiple item identifiers.

Prerequisites for implementing multiple BOM views

Before implementing multiple BOM views, you should do the following:

• In the default configuration, all data is stored in the View BOM view. If you decide to rename this default view, choose a new name that reflects the primary use of this view, for example, Design.

• Establish BOM view naming conventions before you create additional product structure data. This minimizes the number of BVRs that you must rename to reestablish automatic updates.

Rename multiple BOM views

To transition a site to multiple BOM views by renaming the default BOM view type:

1. Rename the existing default View BOM view type to your new selected default name.

2. Decide if this renamed BOM view type is the new default BOM view type. In most cases, you would make it the default because your existing product structure data is saved under it. However, you can make any valid BOM view type the default view.

3. If you decide to make another BOM view type the default view, create the necessary BOM view type.

4. Change the PSE_default_view_type preference setting to the new default BOM view type.

5. Decide if the BOM view renamed in step 1 is synchronized to NX. If so, change the TC_NX_view_type preference to the renamed BOM view type.

6. Run the ps_rename_bvrs utility against the affected BOM view revision names, as described in the Utilities Reference.

Setting assembly preferences

The Teamcenter administrator determines the following functionality by setting the relevant preferences.

Setting assembly level of detail

You can display a part or assembly in the embedded viewer by selecting the corresponding line in the assembly tree and clicking the Graphics tab. If a JT file is associated with the line (that is, if the item revision corresponding to the line has a DirectModel dataset containing a JT file) Teamcenter displays the JT file in the viewer. Any descendents of that line with attached JT files are displayed likewise.
By defining a naming convention for reference sets and JT files, you control the behavior of assemblies in the viewer. You specify the naming convention by setting the `JT_File OverrideChildren_Refsets` preference. The default setting of this preference is `unset`, but you can set it to any NX reference set names, for example, `SIMPLE` or `FULL`.

If you click on a structure line, Teamcenter displays the corresponding JT file. If there is no JT file, the viewer shows all of its immediate children. Teamcenter repeats this process recursively down each branch of the product structure until it finds and displays a JT file. However, if the JT file is in the preference list, none of its children are displayed.

If you do not set the `JT_File OverrideChildren_Refsets` preference, Teamcenter continues processing and displaying the children.

**Determining JT file priorities**

Normally each item has a maximum of one JT file in its associated `DirectModel` dataset and Teamcenter always displays this file in the viewer. However, it is possible for a `DirectModel` dataset to contain several JT files with different names, so you should set rules that determine the file to display. By default, Teamcenter uses the JT file that matches the NX REF SET occurrence note for the structure line, that is, it tries to use the same reference set as the Teamcenter Integration for NX part file.

`DirectModel` support of NX reference sets can take two forms:

- **DirectModel** datasets created prior to Teamcenter 8, which consist of multiple JT files named according to the available reference sets.

- **DirectModel** datasets created using Teamcenter 8 or later, which may consist of a single JT file that contains all of the information necessary to define the geometry configurations for each reference set.

To override the default behavior, you can set the `JT_File Priority_Refsets` preference to any NX reference set names, for example, `EMPTY`, `ENTIREPART`, `LASTSAVED` or `MODEL`.

You specify a list of JT file names in priority order. For example, if you set the preference to `[empty.jt, entirepart.jt, lastsaved.jt, model.jt]`, Teamcenter first tries to use a file called `empty.jt`. If none exists, it uses `entirepart.jt`. If that does not exist, it uses `lastsaved.jt`, and then `model.jt`.

**Note** This example applies to `DirectModel` datasets created using Teamcenter 8 or later. If the datasets were created in an earlier version, the reference set names and file names in the preference are preceded with a `$` sign, for example, `$EMPTY`. If the datasets were created in mixed releases, the preference must contain both types of entry, that is `{empty.jt, empty.jt, $entirepart.jt, entirepart.jt, $lastsaved.jt, lastsaved.jt, $model.jt, model.jt}`.

If you do not specifically set this preference, the viewer uses the default entries, that is, `{empty.jt, entirepart.jt, lastsaved.jt, model.jt}`.
Determining excluded reference sets

You can set the JT_File_Excluded_Refsets preference to define reference set names that are not visualized in an assembly. However, the reference sets you exclude with this preference can be viewed, if required, using the Replace JT option. This preference does not have a default setting and you can set it to any of the following values:

- **Empty**
  This reference set name is appropriate for most sites. NX uses this name to identify geometry that should not be visualized in an assembly.

- **Entries other than Empty**
  Sites that define reference set names to identify geometry that should not be visualized can add the names to the preference instead of Empty.

Create occurrence note types

You can associate occurrence note types with an occurrence in the product structure, as described in Displaying occurrence notes. Users can specify a value for any note type that is defined for the site.

Some standard note types are supplied to allow synchronization of occurrence attributes with NX. These note types can be displayed but not deleted.

You can define lists of values (LOVs) and default values for occurrence notes.

To create a new occurrence note type:

1. Start the Business Modeler IDE and, in the Extensions view, select the project in which you want to create the new note type. Right-click the project and choose Organize→Set active extension file. Select the options.xml file as the file in which to save the new note type.

2. Expand the project and the Options→Note folders.

3. Right-click the Note folder and choose New Note Type from the shortcut menu. The New Note Type wizard runs.

4. Perform the following steps in the Note Type dialog box:

   The Project box defaults to the already selected project.

   a. In the Name box, enter the name you want to assign to the new note type.

   b. In the Description box, enter a description of the new note type.

   c. Select the Attach Value List check box if you want to attach a list of values (LOV) to the note.

   d. If you selected the Attach Value List check box, click the Browse button to the right of the LOV box to locate the list of values to attach to the note. Type an asterisk * in the Find dialog box to see all possible selections. Click the
Chapter 19  

*Administering the product structure*

**Configure**

Browse button to the right of the Default Value box to choose the value from the list of values that you want to use for the note type.

e. Click Finish.

The new occurrence note type displays under the Note folder in the Extensions view.

5. To save the changes to the data model, chose File→Save Data Model.

**Configuring modular variants**

Configure modular variants by setting the following preferences.

For more information about setting preferences, see the *Preferences and Environment Variables Reference*.

- **PSEVariantsMode**
  
  Determines if the modular variants functionality is used. Allowed values are:
  
  o  **modular**
      
      Use only the modular variants functionality. Users cannot view, edit, or configure legacy variants.
  
  o  **hybrid**
      
      Allows users to define modules in structures containing legacy variant data.
  
  o  **legacy**
      
      Use only legacy variants functionality.

  The default setting is **PSEVariantsMode=hybrid**.

  In addition to enabling the modular variants functionality, the default setting allows users to display, edit, and configure legacy variants, but with the modular variants dialog boxes. Legacy variants do not provide all of the advantages of encapsulation that modular variants enforce, nor is it possible to create variant items within a structure that contains legacy variants. Consequently, Siemens PLM Software recommends you use this setting during migration from legacy variants to modular variants. Once migration is complete, you change the preference setting to **modular**.

- **DisableSaveSos**

  Use this site preference to restrict the saving of option values in a saved option set (SOS) when you begin to transition to managing options with the Product Configurator.

  o  If this preference is set to **true**, users are not permitted to save option values in an SOS, if you have set the **PSEVariantsMode** preference to **modular** or **hybrid**. If a user tries to save option values in an SOS, Teamcenter displays an error message.

  o  If this preference is set to **false**, users may save option values in an SOS. However, if all the set option values are classic options, you can save them.
as a saved variant rule, rather than an SOS if the PSEVariantsMode preference is set to hybrid. If a user tries to save option values in an SOS in hybrid mode, Teamcenter displays a Do you want to save the configuration as a variant rule? informational message. If you click Yes, Teamcenter displays the Variant Rule dialog box, allowing you to save the options as a saved variant rule. If you click No, Teamcenter displays the Save Configuration dialog box, allowing you to save the options as an SOS.

- **PSM_global_option_item_ids**
  Set this preference to a list of all item identifiers that contain global option definitions. The default is an empty list. These definitions can be reused when authoring variant modules. For example:

  PSM_global_option_item_ids=
  000400
  000410
  000420

  To implement this functionality:
  1. Create an item to store the global options.
  2. Create the desired global options and allowed values.
  3. Update the PSM_global_option_item_ids preference to include the new item identifier.
  4. In Structure Manager, display the Create Option dialog box and verify the new item and options are shown in the Based On dropdown list.

- **PSESavedConfigRelationTypes**
  When saving a selected option set or variant configuration, the user can choose whether to save to the Home folder, the Newstuff folder or to the module (item revision) being configured. Use this preference to set the possible relation types from which the user can select when saving to a module.

  The default setting is:

  PSESavedConfigRelationTypes=
  TC_specification
  TC_manifestation
  TC_relation

- **ShowModuleIcons**
  By default, the icons of the modular variants feature are hidden because their availability affects performance. If you use modular variants, make the icons visible by setting this preference to true.

- **PSEAllowLegacyVICreation**
  Set this preference to true to permit the creation of variant items for structures that include classic variant options. It also permits the creation of variant items from assemblies that are not modules. The default setting is false.

- **PSEBypassVISearch**
Chapter 19  Administering the product structure

Set this preference to true to add a Create button to the Configure dialog box as soon as the user sets a value for each option. This allows the user to bypass the requirement to search for similar variant item configurations before creating a new variant item. The default setting is false.

- **PSECreateVISameType**
  If you set this preference to true, Teamcenter always creates a variant item with the same type as its parent and creates the variant item with a Save As action. The default setting is false.

- **PSEShowUnconfigdVarPref**
  Determines whether structure lines with variant conditions that do not configure for the current variant rule are shown by default in a new Structure Manager window. The preference affects classic variants as well as modular variants. If a structure line is shown even though its variant condition evaluates to false for the current variant rule, you can use the following properties to identify the lines that do not configure for the current variant rule:

  bl_is_variant=Y
  bl_variant_state=

- **PSEIsNewVILinkedToModule**
  Determines if variant items are linked to the generic item by default. If it is set to false, they are not linked to the generic item. The default value of this preference is true.

Configuring incremental change

Configure incremental change by setting the following preferences.

For more information about setting preferences, see the Preferences and Environment Variables Reference.

- **Incremental_Change_Management**
  Set to true to enable incremental changes.

- **EnableIntents**
  Set to off by default as configuration with intents adds a performance overhead if your site does not use intents. If you set this preference to on, the intent tabs appear in the appropriate dialog boxes.

- **ShowUnconfiguredByChangeEffectivity**
  By default, all incremental changes (configured and unconfigured) are visible to the user. To hide unconfigured changes, set the ShowUnconfiguredByChangeEffectivity preference to true.

- **Incremental_Change_ReleaseStatus**
  Defines a release status that is attached to an incremental change when the user first creates it, for example, Pending. The status must already exist and have an Access Manager rule that allows write access to objects with this status.
• **MoveICCreationToMenu**

Determines if the [Create IC Object](#) button on the incremental change toolbar or the [Incremental Change→Create Context](#) menu command is visible. If this preference is **True**, the menu command is visible unless suppressed with Command Suppression; if it is **False**, the button is visible.

You should also ensure an **In IC Context** rule is available in Access Manager, allowing a user write access to a released structure.

### Using default revision rules

Teamcenter provides default revision rules that may be used at your site. Some of the default rules are described below.

**Note** The [PSEShowUnconfigdEffPref](#) preference determines whether structure lines with effectivity that do not configure for the current revision rule or incremental changes are shown by default in a new Structure Manager window. If a structure line is shown even though its effectivity evaluates to **false** for the current revision rule or incremental changes, you can use the following properties to identify the lines that do not configure for the current variant rule:

- `bl_has_date_effectivity=Y`
- `bl_is_occ_configured=`

#### General rules

**Name = Working; Any Status**

Selects the latest working revisions. If none exist, it selects the latest released revisions. For example:

- Working (any user, any group)
  - Has Status = Any, Configured by: Date Released

**Name = Working (Current User) ; Any Status**

Selects only the latest working revisions owned by the user running the Teamcenter session. If none exist, it selects the latest released revisions. This rule allows users to configure only their own working data. For example:

- Working, user = Current User
  - Has Status = Any, Configured by: Date Released

**Name = Working (Current Group) ; Any Status**

Selects only the latest working revisions owned by the group that the user running the Teamcenter session is currently logged into. If none exist, it selects the latest released revisions. This rule allows users to configure only the working data within their team. For example:

- Working, user = Current Group
  - Has Status = Any, Configured by: Date Released
Name = Any Status; Working
Selects the latest released revisions. If none exist, it selects working revisions. Use this rule if you want to configure a released structure and want to be aware of items that are used in the structure and are not released yet. For example:

- Has Status = Any, Configured by: Date Released
- Working (any user, any group)

Released revisions only
Name = Any Status, No Working
Selects the latest released revisions, no working revisions selected. For example:

- Has Status = Any, Configured by: Date Released

Latest revisions
Use these rules to configure revisions, regardless of whether they are working or released.

Name = Latest by Creation Date
Selects the latest revisions according to the date they were created, regardless of whether they are working or released. For example:

- Latest (Creation date)

Name = Latest by Alpha Rev Order
Selects the latest revisions according to the revision ID, regardless of whether they are working or released. The revisions are sorted in alphanumeric order. For example:

- Latest (Alpha-numeric order)

Precise revisions
Any revision rules that configures precise references must have a Precise entry. You can also include this entry in any of the previous rules if they configure precise references.

Name = Latest Working
Selects precise references if they exist. For imprecise assemblies, it selects the latest working revisions. If none exist, it selects the latest released revisions. For example:

- Precise
- Working (any user, any group)
- Has Status = Any, Configured by: Date Released

Name = Precise; Any Status, No Working
Selects the precise references to specific item revisions in precise assemblies. If imprecise assemblies are present, only working revisions are selected. For example:

- Precise
- Has Status = Any, Configured by: Date Released
Controlling access to revision rules

Use Access Manager to control user access to revision rules. You can limit read access to control the users who can see and use a revision rule. You can use this technique to reduce the number of inapplicable revision rules that are presented to ordinary users, or to restrict rules to certain groups of users. You can use write access to control the users who can modify a revision rule.

You can apply an Access Manager rule globally to all rules using a class revision rule or other attribute, (for example, OwningGroup) if you created the revision rules appropriately. You can add object ACLs to specific revision rules for exception cases. A typical default Access Manager (AM) rule and rule tree ACL follow:

Access Manager rule:

HasClass (RevisionRule) -> Private Rev Rule ACL
OwningGroup (dba) -> Public Rev Rule

Private revision rule ACL:

This ACL prevents Teamcenter displaying privately created revision rules to all users. Only the owning user and system administrator have access to the private rule. You can define an entry for owning user that gives access to all users in the owning group. Alternatively, you could add it as an object ACL to the specific rule.

Owning User: Read, Write, Delete, Copy, Change
System Administrator: Read, Write, Delete, Change
World: No Read, No Write, No Delete, No Copy, No Change

Public revision rule ACL:

This ACL ensures that public revision rules are visible to all users. It also only allows users with a configuration role or members of a system administration group to modify public rules. You should control these permissions carefully, as unintended modification of revision rules can have significant consequences.

Role = Configurator: Write
System Administrator: Write, Delete, Change
World: Read, No Write, No Delete, No Copy, No Change

Controlling access to snapshots

You can use the following Access Manager rule to control access to snapshots, which are stored in a special class of folder.

Access Manager rule:

Has Class (Folder) ->
Has Class (Snapshot) -> Snapshot

Snapshot ACL:

Typically, snapshots are not modified once created, but this restriction depends on your business practice.

Owning User: Write, Delete, Copy, Change (as required)
Chapter 19  Administering the product structure

System Administrator: Change
World: Read, No Write, No Delete, No Copy, No Change

Importing remote components

If you have assembly structures that are replicated at several sites with Multi-Site Collaboration, Teamcenter may prompt users whether to import missing components—that is components that are not yet replicated at your site. If you set the PSE_prompt_for_remote_import preference to on, Teamcenter prompts if remote items should be imported when you expand the structure. When Structure Manager displays a Ready message, all remote components are imported successfully. If this preference is set to off, Teamcenter imports missing components without prompting the user.

Apply a vendor parts selection rule

The administrator can create a selection condition that limits the vendor parts that are displayed in the data pane. For example, you may see only preferred parts.

For details of how to create a selection condition, see the Business Modeler IDE Guide.

1. Choose Tools→Vendor Parts Selection Rule.
   Teamcenter displays the View/Set Current Vendor Parts Selection Rule dialog box.

2. Select the required selection rule and click OK.
   Teamcenter applies the selected rule to future actions.

Configure units of measure

You can configure Teamcenter to allow users to specify a quantity for a product structure (BOM) line in a user-defined unit of measure (UOM).

1. Create an XML file that specifies all UOM conversion rules that are valid at your site. The file must be in the following format:

   ```xml
   <?xml version="1.0" encoding="utf-8"?>
   <UOMConversionTable>
   <Formula from_uom="kg" to_uom="gm" multiplier="1000"/>
   <Formula from_uom="km" to_uom="m" multiplier="1000"/>
   </UOMConversionTable>
   ```

   **Caution**  Teamcenter does not validate the entries in this file. Ensure you check the entries carefully to avoid invalid conversions.

2. Create a text dataset and attach the XML file to it as a named reference.

3. Set the Fnd0PSEQtyConversionDSName global constant in the Business Modeler IDE to the name of the dataset created in the previous step.
4. Set the `Fnd0PSEEnableQtyConversionUOM` global constant in the Business Modeler IDE to `TRUE` to enable UOM conversion.

For more information about setting global constants, see the *Business Modeler IDE Guide*. 
Appendix

A  Glossary
Appendix

A Glossary

A

absolute occurrence
Relationship between a parent assembly and an item one or more levels down in the structure. The parent assembly is the context in which the absolute occurrence exists. When you select the context assembly and view the structure, you can define data on the absolute occurrence that overrides the data stored on the parent. Compare to occurrence.

allocation
Relationship between constituents of two structural views of a product, for example, a relationship between constituents of the functional breakdown and the physical breakdown of a product.

appearance
Sequence of occurrences that describes a unique path through an exploded structure. An appearance corresponds to a unique instance of the component that is referenced by the leaf node of the path within the top-level assembly. An appearance may have spatial data associated with it, allowing spatial searches.

Appearance Configuration
Teamcenter application used to configure the use of appearance:

• Defining the appearance sets for which the site tracks appearances.

• Configuring the mapping of occurrence notes into appearance attributes.

assembly
Compound object that is assembled from other objects and may add additional information to their interpretation.

• In the context of an assembly, other assemblies are called subassemblies, while noncompound objects are called components.

• A single-level compound object that is distinct from a multilevel product structure or bill of materials, which is a hierarchy of assemblies. Assembly data is stored in a BOM view revision.

B

baseline
Collection of items and the relationships between the items that is established to ensure their continued existence. It enables their configuration to be reconstructed and audited. Baselines are often created to preserve the state of a design at a particular checkpoint. You can baseline precise or imprecise structures.
Appendix A  Glossary

BOM  
Bill of materials.

- 100% BOM  
The as sold product configuration, for example, the configuration of a car to be built and shipped to the dealer.

- 120% BOM  
Partial overlay of selected variant conditions. You cannot build the product from a 120% BOM.

- 150% BOM  
Overlays of all possible variant configurations. You cannot build the product from a 150% BOM.

See also design bill of materials and manufacturing bill of materials.

BOM view  
Teamcenter object used to manage product structure information for an item.

BOM view revision (BVR)  
Workspace object that stores the single-level assembly structure of an item revision. Access can be controlled on the structure (BOM view revision) independently of other data. BOM view revisions are meaningful only in the context of the item revisions for which they are created.

BVR  
See BOM view revision (BVR).

C  
Change Manager  
Teamcenter application used to track changes to a product throughout its life cycle. The user proposes a change to a product and then manages the entire cycle of review, approval, and implementation of the change. The user can articulate the work required to implement a change, assess its impact on any managed business items, and notify life cycle participants about proposed and authorized changes. Before and after product configurations can also be compared.

change order  
Teamcenter object that references the problem, originating change requests, solutions, and related information. A change order contains sufficient information to incorporate the change.

change request  
Teamcenter object that requests a change, reference the problem, proposed solutions, and related information. A change request contains sufficient information to allow a decision to proceed further with the change.

collaboration context  
Teamcenter object that holds a collection of data contained in structure and configuration contexts. This data allows you to capture multiple different Teamcenter structures in one container. You can open a collaboration context in the Multi-Structure Manager application, in Manufacturing Process Planner, or in
Part Planner. You can also use a collaboration context to collect data to share with a third-party application. See also structure context.

**component**
Part in a product structure defined in Teamcenter. A component is the lowest level part in the product structure: it cannot be broken down into subparts.

**composition**
Special kind of structure context that allows components to be added from one or more structure contexts, each of which may contain a different product structure. Compositions are used for design studies and manufacturing processes that contain data from both product and plant structures.

**configuration rule**
Rule that configures a structure. There are two kinds of configuration rules: revision rule and variant rule.

**dataset**
Teamcenter workspace object used to manage data files created by other software applications. Each dataset can manage multiple operating system files, and each dataset references a dataset tool object and a dataset business object.

**design bill of materials**
List of components and subassemblies used to define an assembly structure, and the representation of the assembly structure. Compare with manufacturing bill of materials.

**direct model dataset**
Dataset containing a JT (visualization) file.

**effectivity**
Identification of the valid use of an aspect of product data tracked by unit, date, or intent. You can specify a start definition, end definition, or both for a particular effectivity. There are three types of effectivities:

- **Unit effectivity** specifies the range of item units or serial numbers.
- **Date effectivity** specifies the range of dates. This is also known as an incorporation point.
- **Intent effectivity** specifies a purpose, target, or milestone, for example, Production, Prototype, or Carryover.

**end item**
Top-level node of an assembly that can represent a product or a factory structure.

**end item effectivity**
Date or unit number suggesting when the released configuration is used for production of the specified end item.
Glossary

F

feature
Physical or geometric object associated with a product, component, or part. Alternatively, a logical attribute of a product, component, or part. Examples: a weld point, a signal, or a geometric pattern. A feature may be represented by a generic design element (GDE) in a BOM. See also generic design element.

find number
Number that identifies individual occurrences (or groups of occurrences) within a single-level assembly. Components are ordered by find number within an assembly.

G

GDE
See generic design element.

generic design element
BOM item that cannot have different revisions. See also feature.

global alternate
Alternate that is interchangeable with another part, regardless of where the part is used in the product structure. A global alternate applies to any revision of the part and is independent of views.

I

imprecise assembly
Single-level assembly that has items as the components. The revision is determined by the revision rule settings. Compare with precise assembly.

incremental change
Engineering change that collects several individual changes to components or attachments in a structure, allowing them to be released simultaneously. An incremental change is released and effectivity is applied to it by attaching an appropriate release status.

installation assembly
Node in the CAD structure to which design solutions are added and variant conditions applied, according to the named variant expression selected on the architecture element. An installation assembly (IA) can be associated with an architecture element to guide the designer by limiting the named variant expressions from which to choose when adding a design to the product. Any structures above an installation assembly are for organizational and navigational purposes only—there are no transforms or geometry above an IA. IAs are designed in product space, and are therefore all positioned correctly relative to one another when viewed together.

item
Workspace object generally used to represent a product, part, or component. Items can contain other workspace objects including other items and object folders.

item revision
Workspace object generally used to manage revisions to items.
Glossary

L

line of assembly
Also called assembly component tree. Relation that represents one level of an assembly breakdown and contains attributes that are only pertinent to the corresponding level.

line of usage (LOU)
Business logic entity summarizing all configuration conditions that select a given part for a usage address in the product. The information referenced by a line of usage may include a part identifier for the line of usage, a partition identifier, quantity, valid configuration and effectivity conditions, and business attributes. The LOU describes the incorporation of a part and its CAD solution into the product for a given configuration and effectivity.

logical identity
Combination of the usage address and position designator of an absolute occurrence. See also position designator and usage address.

M

manufacturing bill of materials
Defines how the product is manufactured, rather than how it is designed. Compare with design bill of materials.

most recently used (MRU)
Shortcut list of the objects you have accessed most recently with the particular application.

MRU
See most recently used (MRU).

Multi-Structure Manager
Teamcenter application that enables users to view and manipulate data in a specific context.

O

occurrence
Hierarchical structure relationship between the immediate parent assembly and its child component item or item revision in a precise assembly. Sometimes called relative occurrence.

occurrence effectivity
Method of configuring the occurrences in a structure with effectivity. See also effectivity.

occurrence group
Collection of occurrences and absolute occurrences in the BOM. An occurrence group typically represents an assembly.

occurrence path
Representation of the path from a top-level assembly to an occurrence of a component or subassembly. An occurrence path is unique to the context of a specific BOM;
different BOMs cannot contain the same occurrence paths. The occurrence path does not change if the configuration of the BOM changes.

**occurrence type**
Object used to distinguish how items occur in a product structure. An occurrence consists of one component in an assembly including its relative position with respect to its parent assembly. Occurrence types are representations of the **PSOccurrence** business object.

**option**
Attribute of an item revision with a set of allowed values (for example, engine: 1200, 1600). Options are used when specifying variant data to configure a variant of an assembly. Option names are unique within an item revision, but not within the database.

**P**

**part**
Business object type that can participate in a structure as an assembly or component, with or without attached datasets. In Teamcenter, a business item managed in a company's part releasing system. Typically, the assembly or component is designed and built by the OEM.

**partition (Manufacturing Process Planner)**
Subdivision of a structure. Typically used to group a subset of the structure occurrences in a context. Partitions may be used to arrange the structure organizationally, for example, by physical areas of the product.

**piece part**
Part with no structure (no associated BOM view revision).

**position designator**
Value that represents the position of a single part from a line of usage. For example, if the line of usage references four wheels, there are four position designators—one for each wheel.

**precise assembly**
Single-level assembly that has item revisions as the components. The item revision is configured by a precise entry in a revision rule. Compare with **imprecise assembly**.

**product structure**
Hierarchy of assembly parts and component parts with a geometric relationship between them, for example, a bill of materials (BOM). Variant and revision rules define the generic BOM. This BOM can then be loaded to display the configured variant.

**product view**
Saved configuration of the assembly viewer, including the selection of objects, zoom factor, rotation angle, and pan displacements.

**properties**
Keys and values that specify the configuration settings for an application in the Teamcenter rich client.
R

reference designator
Identifier appended to part attributes in the product structure. It allows unique identification when the part is used several times in the same structure. Reference designators need only be unique across a single level of the product structure.

release status
Status associated with a workspace object when it is released through a workflow process.

revision rule
Parameter set by the user that determines which revision of an item is used to configure product context.

S

snapshot
Folder that contains all the revisions of a configured product structure. A snapshot can be used to redisplay the as-saved structure.

spatial data
Either NX true shape files or PLM visualization JT files that define the volume of the part as a set of cubes. The cube size is set in the CAD programs defaults file. The CAD files do not set absolute position; this is defined when the files are associated with an appearance.

structure
Representation of multiple objects and their interdependencies. For example, a classification structure represents classes and their inheritance dependencies, and an assembly structure represents how components and subassemblies are associated to build up an assembly. The structure can be viewed in several applications, including Structure Manager, Manufacturing Process Planner, Part Planner, Multi-Structure Manager, and Resource Manager.

In Resource Manager, most structures are hierarchical. For example, they acquire the form of a tree where each node can have only one parent but multiple siblings and children.

structure context
BOM or assembly structure contained in a collaboration context. The structure context can contain occurrence groups, items, and item revisions. See also collaboration context.

substitute
Component that can be used interchangeably within an occurrence, typically for manufacturing purposes. The preferred substitute is displayed in the structure.

supersedure
Manually created relation that graphically displays deleted components and the components that replace them. A supersedure is always created in the context of a parent assembly. Therefore, a single component can be used in more than one supersedure if it is used in different parent assemblies. A supersedure can be created for changes of part number or of quantity, but not for changes in a part revision.
Appendix A  Glossary

U

usage address
Type of object that occupies an occurrence in the structure, for example, wheel.

V

variant condition
- Rules applicable to one component in a product structure.
- Condition set on an occurrence to specify the option values required to configure that occurrence (for example, Load IF engine = 1200).

variant rule
Collection of option values used in determining the variant of the BOM to be configured (for example, car type = GLS, engine = 1200, gearbox = manual).

view type
Attribute of a BOM view revision. The view type specifies the BOM view revision’s intended use (for example, design or manufacture). The view type distinguishes one BOM view revision from another BOM view revision of the same item revision.

W

workflow
Automation of the concept that all work flows through one or more business processes to accomplish an objective. Using workflow, documents, information, and tasks are passed between participants during the completion of a particular process.

working revision
Revision that can be changed by a user with write privileges. No record of intermediate states of a working revision is maintained by Teamcenter.
Index

Numerics/Symbols
3D models, viewing .................................. 7-7

A
Absolute occurrence
  Purpose .............................................. 5-2
Absolute occurrence, purpose ....................... 13-2
Absolute occurrences ................................ 5-8
  Apply variant condition .......................... 5-14
  Associate a dataset .............................. 5-14
  Associate a form .................................. 5-14
  Associate a transformation ....................... 5-14
  Associate an occurrence note ..................... 5-14
  Associate data .................................... 5-13
Create .............................................. 5-11
Disable in context edits ............................. 5-13
Edit override data .................................. 5-12
Incremental change .................................. 5-6
Multiple contexts ................................... 5-16
Remove override data ................................ 5-13
Symbols .............................................. 5-10
Tracking changes ................................... 5-6
Using .................................................. 5-2
View attachments ................................... 5-15
Viewing .............................................. 5-8
Access control, view types ........................... 1-38
Access Manager
  Controlling revision rules ......................... 19-11
  Controlling snapshots ............................ 19-11
  Incremental change ................................ 13-3
Access, revision rules ................................ 11-2
Accessories (options) ............................... 15-8
Active unit .......................................... 4-87, 4-89, 4-92
Aggregate
  Purpose .............................................. 1-31
Aggregate occurrences
  Convert to individual components ................ 3-14
  Create ............................................. 3-13
All notes property
  Display ............................................. 6-22
  Edit ................................................. 6-23
Allowed values (options) ............................ 15-11
Architecture breakdown
  Add component data ............................... 17-2
  Architecture element
    Add to design .................................... 17-2
  Assemblies, product views ......................... 7-10
  Assembly
    Collapse ......................................... 3-8
    Expand ........................................... 3-7
    Limit expansion ................................. 3-8
    Purpose .......................................... 1-31
  Assembly level of detail preference ............. 19-3
  Assembly preferences .............................. 19-3
  Assembly replicas
    Synchronize ...................................... 3-30
    Viewing .......................................... 3-29
Assign
  Objects to projects ............................... 18-1
  Associations, fixing ............................. 4-21
  Attachment, purpose ............................. 13-2
Attachments
  Track creation ...................................... 13-18
  Track deletion ..................................... 13-18
  Track with incremental changes .................. 13-17
  Tracking edits ..................................... 13-18
Attribute search
  Perform search ..................................... 9-4
Attribute searches
  Making .............................................. 9-1
  Search criteria .................................... 9-5
Audit report ........................................... 17-4

B
Baseline
  Create .............................................. 12-5
  Dry run ............................................ 12-8
  Finding folder ..................................... 12-8
  Incremental change ................................ 13-6
    Carrying forward active changes ................ 13-8
    Determining active changes ..................... 13-7
    Dropping inactive changes ...................... 13-9
    Rolling up active changes ....................... 13-8
    Structures with active changes ................ 13-7
Naming rules ......................................... 12-4
Smart ................................................. 12-7
Index

Generating ........................................... 7-9
Export .................................................. 4-77
  Traceability report
    Excel ............................................. 4-77
Export To Excel dialog box ......................... 4-77
Expression values, setting ......................... 16-12
Expressions (NX) .................................... 16-48
External option, purpose ............................ 16-2
External options, defining ......................... 16-9

F
File formats .......................................... 7-1
File menu ............................................. 1-3
Find in display ...................................... 3-14
Find number
  Edit .................................................. 6-14
  Purpose ............................................ 1-32
Find number assignment preference ............... 2-5
Find numbers ........................................ 3-4
Fixed defaults, variant rules ....................... 15-7
Fixed option defaults ................................ 15-32
Fly To Selected ...................................... 7-7
Folder, snapshot ..................................... 12-8
Forms
  Associate with absolute occurrence .............. 5-14

G
GCS .................................................... 3-15–3-17
Generic item property ............................... 16-42
Global alternates
  Add .................................................. 4-51
  List .................................................. 4-51
  Managing ............................................ 4-50
  Remove ............................................. 4-52
  Set preferred ...................................... 4-52
Global option, purpose .............................. 16-2
Global options, defining ............................ 16-8
Global options, platform designs .................. 17-1
Grading ............................................... 4-70
  Override results ................................... 4-73
  Run ................................................... 4-71
  Substance compliance ............................. 4-74
  View results ....................................... 4-71
Graphical compare tab ................................ 10-13
Graphical comparison
  Common parts ...................................... 10-8
  Configure .......................................... 10-7
  Initiate ............................................ 10-8
  Structures under change
    management ....................................... 10-9
  Understanding ..................................... 10-7
Graphical history
Comparing revisions .......................... 10-11
Comparison ................................. 10-13
Comparison results .......................... 10-15
Comparison sliders .......................... 10-12
Detail histories ............................. 10-18
Disparate revision histories ................. 10-18
Example .................................... 10-13
Progression pane ............................ 10-10
Related revision histories .................... 10-16
Revision list pane ............................ 10-10
Revisions tab ............................... 10-10
Show supersedures ........................... 10-16
Supersedure link ............................. 10-16
Variant changes ............................. 10-35
Graphics menu ................................ 1-18
Graphics, manipulate ........................ 7-9
Group entries by item type (revision rules) .... 11-13
Grouped entries (revision rules) ............... 11-13
Grouping entries, example (revision rules) ..... 11-13
Guided component search ..................... 3-15–3-16
Remove component ........................... 3-17

H
Has item type entry .......................... 11-15
Has item type rule entry ...................... 11-14
Hierarchy scope .............................. 4-87, 4-89
Highlighting, enabling ....................... 4-22

I
ICS_tablepagesize preference .................. 4-93
IDC
  Capturing structure lines ................... 12-9
  Creating ................................ 12-9
Images (structure tree) ...................... 1-27
Imprecise assembly
  Purpose ................................ 11-5
  Understanding ........................... 1-38
Imprecise assembly line color
  preference ............................... 2-3
Incremental change
  Access control ........................... 13-3
  Attachments pane ......................... 13-11
  Baseline ................................ 13-6
    Carrying forward active changes .......... 13-8
    Determining active changes .............. 13-7
    Dropping inactive changes .............. 13-9
    Rolling up active changes .............. 13-8
  Structures with active changes .......... 13-7
  Configure ................................ 19-8
  Copy .................................... 4-66
  Create .................................. 4-66
  Paste ................................... 4-66

Copying or cutting lines with ICEs ............. 13-6
Elements ................................... 13-1
Independent contexts ........................ 13-6
Information pane ............................ 13-11
Menus ..................................... 13-11
Preference settings ........................ 13-10
Properties .................................. 13-9
Release status configuration ................. 13-4
Set revision rule ........................... 13-5
Toolbar .................................... 13-10
Tracking absolute occurrences ............... 5-6
Incremental change, purpose ................... 13-2
Incremental changes
  Create new .............................. 13-13
  Customize buttons ......................... 13-13
  Export using Briefcase .................... 13-21
  Export using PLM XML .................... 13-22
  Export using TC XML ..................... 13-21
  Exporting ............................... 13-20
  Find existing ........................... 13-15
  Find recently used ........................ 13-17
  Import using Briefcase ................... 13-21
  Import using PLM XML .................... 13-22
  Import using TC XML ..................... 13-21
  Importing ............................... 13-20
  Preference settings ........................ 13-12
  Removing ................................ 13-19
  Show unconfigured changes ................. 13-15
  Split .................................... 13-20
  Track attachments ........................ 13-17
  Tracking retrospectively ................... 13-18
  Turn off tracking ........................ 13-12
  View for structure ........................ 13-16
  Viewing information ....................... 13-16
Incremental_Change_Management ................. 19-8
Incremental_Change_ReleaseStatus ............. 19-8
Incremental_Change_ReleaseStatus preference .... 13-4
Information center elements, showing or hiding .... 2-3
Installation assembly, adding component ........ 17-2
Intent, purpose ................................ 13-2
Intermediate data capture, see IDC
Item
  Create from template ...................... 4-4
  Create new .............................. 4-13
  Creating for variant configuration .......... 15-14
  Delete single ........................... 4-69
  Deleting multiple ......................... 4-69
Item elements
  Copy ..................................... 4-66
  Create .................................. 4-66
  Paste ................................... 4-66
Index

Remove ........................................ 4-66
Replace ......................................... 4-66
Using ............................................. 4-65
View notes ....................................... 4-67
Item identifier ................................. 1-35
Item master form attributes,
  displaying .................................... 6-15
Item name ....................................... 1-35
Item revision configuration ............. 11-1
Item revisions ................................. 1-34
  Copy .......................................... 4-10
  Create new .................................. 4-13
  Paste ........................................ 4-10
  Releasing multiple ......................... 11-23
Items ........................................... 1-34
  Copy .......................................... 4-10
  Paste ........................................ 4-10
  Working with ............................... 1-34

J
Java heap size, viewer .................... 2-6
JT file priorities preference ............ 19-4
JT_File_Excluded_Refsets
  preference .................................. 19-5
JT_File.OverrideChildren_Refsets
  preference .................................. 19-4
JT_File.Priority_Refsets preference .... 19-4

L
Latest entry (revision rules) ........... 11-11
Latest entry by creation date, example
  (revision rules) ............................ 11-11
Library object
  Find ......................................... 4-81
  Selecting .................................. 4-94
Licensing ..................................... 10-7
Lifecycle Visualization
  Configure cache ......................... 7-5
  File formats .............................. 7-1
  Refresh .................................... 7-6
  Save session ............................. 7-10
  User-defined file formats ............. 7-1
  Using ...................................... 7-2
Lifecycle Visualization, open structure
  in .......................................... 3-25
Line
  Purpose .................................... 1-32
Link
  Create .................................... 4-67
  Remove .................................... 4-67
Links, supersedures ..................... 10-14
Live Excel ................................. 10-14

Export
  Traceability report .................... 4-77
Logical BOM, comparing
  Lowest level mode ....................... 10-4

M
Make where-used searches ............... 1-42
Mandatory choices (options) .......... 15-8
Marking up product structure
  Apply all markups ...................... 4-28
  Apply markup ............................ 4-27
  Carrying forward markups ............ 4-29
  Comment on markup ..................... 4-27
  Concepts ................................ 4-24
  Create markup ........................... 4-26
  Delete markup ........................... 4-29
  Display markup properties .......... 4-26
  Enabling ................................ 4-25
  Review markup ........................... 4-27
Sample workflows ....................... 4-29, 4-31–4-33
  BOMMarkup_AddStatus
    process .................................. 4-40
  BOMMarkup_Review process ........... 4-34
  Create BOMMarkup_SplitTargets
    process .................................. 4-35
  Validate access to apply markup .... 4-27
Measurement unit ....................... 4-87, 4-89, 4-92–4-93
Memory allocation, viewer ............ 2-6
Message area ............................. 4-86
Microsoft Office Communicator ....... 3-28
Modular variants ......................... 16-1
  Configure ................................ 19-6
  Configuring private options .......... 16-3
  Configuring public interface ........ 16-3
  Configuring structure ................ 16-12
  Create error check ..................... 16-19
  Create module constraints .......... 16-20
  Create options ........................ 16-14
  Create options manually ............ 16-15
  Creating .................................. 16-3
  Creating variant data ................. 16-13
  Creating variant items ............... 16-6
  Defining external options .......... 16-9
  Defining global options .............. 16-8
  Defining options ....................... 16-8
  Delete option or constraint .......... 16-23
  Edit option or constraint ............ 16-23
  Error checking .......................... 16-11
  Linking options ........................ 16-4
  Managing child module
    constraints .......................... 16-21
  Option defaults ....................... 16-11
  Overview ................................ 16-1

Index-6  Structure Manager Guide
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Present child options</td>
<td>16-17</td>
</tr>
<tr>
<td>Presenting options</td>
<td>16-5</td>
</tr>
<tr>
<td>Private options</td>
<td>16-15</td>
</tr>
<tr>
<td>Public options</td>
<td>16-15</td>
</tr>
<tr>
<td>Set external options</td>
<td>16-15</td>
</tr>
<tr>
<td>Setting expression values</td>
<td>16-12</td>
</tr>
<tr>
<td>Synchronizing with NX</td>
<td>16-47</td>
</tr>
<tr>
<td>Terminology</td>
<td>16-2</td>
</tr>
<tr>
<td>Test configuration</td>
<td>16-36</td>
</tr>
<tr>
<td>View variant data</td>
<td>16-12</td>
</tr>
<tr>
<td>Modular variants language (MVL)</td>
<td></td>
</tr>
<tr>
<td>Conventions</td>
<td>16-27</td>
</tr>
<tr>
<td>Edit expressions</td>
<td>16-25</td>
</tr>
<tr>
<td>Expert mode</td>
<td>16-30</td>
</tr>
<tr>
<td>Precedence</td>
<td>16-26</td>
</tr>
<tr>
<td>Reserved symbols</td>
<td>16-29</td>
</tr>
<tr>
<td>Reserved words</td>
<td>16-28</td>
</tr>
<tr>
<td>Module constraints</td>
<td></td>
</tr>
<tr>
<td>Create</td>
<td>16-20</td>
</tr>
<tr>
<td>Module, purpose</td>
<td>16-2</td>
</tr>
<tr>
<td>MoveICCreationToMenu</td>
<td>19-9</td>
</tr>
<tr>
<td>Multi-Site Collaboration, syntax</td>
<td>3-29</td>
</tr>
<tr>
<td>Multi-site</td>
<td></td>
</tr>
<tr>
<td>Multi-unit configuration</td>
<td>14-6</td>
</tr>
<tr>
<td>Capture</td>
<td>14-7</td>
</tr>
<tr>
<td>Multiple BOM views</td>
<td>19-2</td>
</tr>
<tr>
<td>Multiple components, packing</td>
<td>3-11</td>
</tr>
<tr>
<td>Multiple configuration, purpose</td>
<td>16-2</td>
</tr>
<tr>
<td>Multiple views</td>
<td>1-37</td>
</tr>
<tr>
<td>Copy</td>
<td>4-13</td>
</tr>
<tr>
<td>Creating</td>
<td>1-41</td>
</tr>
<tr>
<td>Locating</td>
<td>1-41</td>
</tr>
<tr>
<td>Multiple views, managing</td>
<td>3-7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing</td>
<td>4-68</td>
</tr>
<tr>
<td>Packed notes</td>
<td>6-24</td>
</tr>
<tr>
<td>Purpose</td>
<td>1-32, 6-1</td>
</tr>
<tr>
<td>Remove</td>
<td>6-24</td>
</tr>
<tr>
<td>Teamcenter Integration for NX types</td>
<td>6-23</td>
</tr>
<tr>
<td>NX</td>
<td></td>
</tr>
<tr>
<td>Add parts</td>
<td>4-64</td>
</tr>
<tr>
<td>Synchronizing modular variants</td>
<td>16-47</td>
</tr>
<tr>
<td>NX, open structure in</td>
<td>3-24</td>
</tr>
<tr>
<td>NX, opening structure in</td>
<td>3-24</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td></td>
</tr>
<tr>
<td>Objects</td>
<td></td>
</tr>
<tr>
<td>Copying</td>
<td>4-9</td>
</tr>
<tr>
<td>Pasting</td>
<td>4-9</td>
</tr>
<tr>
<td>Occurrence</td>
<td></td>
</tr>
<tr>
<td>Managing part relationships</td>
<td>11-29</td>
</tr>
<tr>
<td>Purpose</td>
<td>1-33, 5-2</td>
</tr>
<tr>
<td>Show superseded item revision</td>
<td>11-29</td>
</tr>
<tr>
<td>Update precise</td>
<td>11-29</td>
</tr>
<tr>
<td>Occurrence effectivity</td>
<td></td>
</tr>
<tr>
<td>Associate existing</td>
<td>14-3</td>
</tr>
<tr>
<td>Capture multi-unit configuration</td>
<td>14-7</td>
</tr>
<tr>
<td>Copying</td>
<td>14-5</td>
</tr>
<tr>
<td>Create new effectivity group</td>
<td>14-7</td>
</tr>
<tr>
<td>Creating</td>
<td>14-4</td>
</tr>
<tr>
<td>Customizing</td>
<td>14-10</td>
</tr>
<tr>
<td>Editing</td>
<td>14-2</td>
</tr>
<tr>
<td>Multi-unit configuration</td>
<td>14-6</td>
</tr>
<tr>
<td>Mutually exclusive ranges</td>
<td>14-3</td>
</tr>
<tr>
<td>Remove</td>
<td>14-5</td>
</tr>
<tr>
<td>Save multi-unit configuration to effectivity group</td>
<td>14-7</td>
</tr>
<tr>
<td>Set new effectivity group</td>
<td>14-8</td>
</tr>
<tr>
<td>Setting date</td>
<td>14-6</td>
</tr>
<tr>
<td>Understanding</td>
<td>14-1</td>
</tr>
<tr>
<td>Validating</td>
<td>14-3</td>
</tr>
<tr>
<td>With variant configuration</td>
<td>14-6</td>
</tr>
<tr>
<td>Occurrence note</td>
<td></td>
</tr>
<tr>
<td>Associate with absolute occurrence</td>
<td>5-14</td>
</tr>
<tr>
<td>Occurrence note types</td>
<td></td>
</tr>
<tr>
<td>Create</td>
<td>19-5</td>
</tr>
<tr>
<td>Occurrence notes</td>
<td></td>
</tr>
<tr>
<td>Changing default value</td>
<td>6-23</td>
</tr>
<tr>
<td>Display all notes</td>
<td>6-22</td>
</tr>
<tr>
<td>Display single note type</td>
<td>6-22</td>
</tr>
<tr>
<td>Displaying</td>
<td>6-22</td>
</tr>
<tr>
<td>Edit</td>
<td>6-23</td>
</tr>
<tr>
<td>Edit all notes</td>
<td>6-23</td>
</tr>
<tr>
<td>Purpose</td>
<td>6-1</td>
</tr>
<tr>
<td>Teamcenter Integration for NX types</td>
<td>6-23</td>
</tr>
</tbody>
</table>
# Index

- Tracking changes ............................................ 6-24
- Occurrence, purpose ....................................... 13-2
- Occurrences
  - Absolute .................................................. 5-8
  - Absolute occurrences ................................... 5-2
  - Attributes ................................................ 4-11–4-12
  - Create imprecise ........................................ 5-2
  - Create precise ............................................ 5-2
  - Splitting .................................................. 4-20
- On-demand validation of structure edits .............. 4-21
- Open product structure ................................. 3-5
- Option default, purpose ................................. 15-2
- Option defaults
  - Creating ................................................. 15-31
  - Default precedence ..................................... 15-32
  - Delete .................................................... 15-34
  - Modify .................................................... 15-33
  - Specify .................................................. 15-32–15-33
- Option defaults, defining ................................. 16-11
- Option Definition dialog box ......................... 16-15
- Option values
  - Selecting ............................................... 16-35
- Option, purpose ............................................. 15-2, 16-2
- Optional parts ............................................. 4-61
- Options
  - Accessories .............................................. 15-8
  - Change values ........................................... 15-19
  - Changing allowed values .............................. 15-11
  - Child module constraints ............................. 16-21
  - Create ................................................... 15-18, 16-14
  - Create manually ........................................ 16-15
  - Create new from existing ............................ 15-19
  - Delete .................................................... 16-23
  - Deleting .................................................. 15-20
  - Derived defaults ........................................ 15-33
  - Edit ....................................................... 16-23
  - Examples .................................................. 16-15
  - Fixed defaults ........................................... 15-32
  - Identifying unique ...................................... 15-9
  - Location .................................................. 15-10
  - Mandatory ................................................. 15-8
  - Remove ..................................................... 15-20
  - Rename ..................................................... 15-20
  - Set external .............................................. 16-15
- Options and variants ...................................... 16-12
- Options, defining .......................................... 16-8
- Outline image
  - Generate ................................................ 7-8
  - Preferences .............................................. 7-8
- Override data
  - Creating for absolute occurrences .......................... 5-15
  - Propagating ............................................. 5-16
  - Override folder ......................................... 11-19
- Override list, purpose ................................... 11-5
- Owning item display preference ....................... 2-4
- Owning user ............................................... 3-28

## P

- Pack all structure lines ................................. 3-12
- Pack structure lines .................................... 3-12
- Packed notes .............................................. 6-24
- Panes
  - Properties .............................................. 4-85–4-86
  - Search ................................................... 4-82–4-83
  - Table ..................................................... 4-93
- Part
  - Publishing preferences ................................ 2-5
  - Purpose .................................................. 1-33
- Part families, importing ................................. 3-29
- Parts
  - Add to NX ............................................... 4-64
  - Creating detail histories .............................. 10-18
  - Edit related substitutes ................................ 4-60
  - Isolate for viewing ..................................... 7-8
  - Managing occurrence relationships .................. 11-29
  - Optional ............................................... 4-61
  - Relate substitutes ...................................... 4-39
  - Relating substitutes .................................... 4-59
  - View related substitutes ............................... 4-61
- Paste item ................................................... 4-10
- Paste item revision ...................................... 4-10
- Pasting objects .......................................... 4-9
- Perspectives
  - In general ............................................... 1-30
- Piece part, purpose ...................................... 1-33
- Platform designs
  - Global options ......................................... 17-1
  - Variability .............................................. 17-1
- Precedence, MVL .......................................... 16-26
- Precise assemblies
  - Configuring ............................................ 11-3
  - Precise assembly
    - Purpose .............................................. 11-5
    - Understanding ......................................... 1-38
  - Precise assembly line color preference ................ 2-3
  - Preferences ............................................. 14-2
  - Assembly ................................................. 19-3
  - Assembly level of detail ............................... 19-3
  - DisableSaveSos ......................................... 19-6
  - EnableIntents .......................................... 19-8
  - Excluded reference sets ............................... 19-5
  - ICS_table_pagesize ..................................... 4-93
  - Incremental_Change_Management ....................... 19-8
Incremental_Change_
  ReleaseStatus  ...............  13-4, 19-8
JT file priorities ............  19-4
JT_File_Excluded_Refsets ...  19-5
JT_File_OverrideChildren_Refsets  19-4
JT_File_Priority_Refsets ......  19-4
Local user ....................  2-1
MoveICCreationToMenu ...  19-9
PS_new_seqno_mode ..........  2-5
PSE_default_view_type ......  2-1, 19-2
PSE_show_option_item_prefix  2-4
PSEAllowLegacyVICreation ...  19-7
PSEAutoPackPref .............  2-2
PSEBypassVISearch ..........  19-7
PSECreateVISameType ........  19-8
PSEImpreciseColorPref ......  2-3
PSEIsNewVILinkedToModule ...  19-8
PSEPreciseColorPref ..........  2-3
PSESavedConfigRelationTypes
  preference ...................  19-7
PSEShowUnconfigdEffPref ...  2-3, 19-9
PSEShowUnconfigdVarPref ....  2-3, 19-8
PSEVariantsMode ..............  19-6
PSM_global_option_item_ids ...  19-7
PUBLISHLAlignableSourceTypes  2-5
PUBLISHLAlignableTargetTypes  2-5
Setting .....................  1-1
ShowModuleIcons preference  19-7
ShowUnconfiguredByChange
  Effectivity ...................  19-8
TC_BOM_Precision_Preference  2-2
TC_config_rule_name ..........  2-1
Preferred substitute ..........  4-55
Preferred substitute, change 4-59
Prerequisites for Structure Manager  1-1
Presented option, purpose ...  16-2
Print structure print table ...  3-23
Printing
  in Teamcenter Rapid Start  3-19
Printing structure information 3-21
Printing watermarks ..........  3-20
Private option, purpose ...  16-2
Private options ..............  16-15
Privileged use commands ....  11-6
Process and Change Selector dialog
  box ......................  4-94
Product generations ..........  11-28
Product structure
  Apply all markups ..........  4-28
Apply markup ...............  4-27
Apply revision rule ..........  11-18
Browse .....................  1-42, 3-1
Build .....................  1-42
Building ....................  4-1
Carrying forward markups ....  4-29
Clone ........................  4-2
Cloning .....................  4-1
Close window ................  4-8
Comment on markup ...........  4-27
Compare .....................  1-42, 10-1
Concurrent changes ..........  4-9
Configure for comparison ...  10-4
Configure with variant rules 16-34
Configuring with variant rules 16-33
Configuring with variants ...  16-12
Create mark up ..............  4-26
Delete markup ...............  4-29
Display mark up properties  4-26
Duplicate ....................  4-2
Edit ........................  1-42
Editing .......................  4-1
Enabling markup mode .........  4-25
Excel report ..................  3-17
Export SOS ....................  16-38
Export to Briefcase ........  4-61
Exporting related parts ....  4-61
Insert level ..................  4-16
Load saved configuration ...  16-37
Marking up ...................  4-24
Move node ....................  4-17
Open ........................  3-5
Open in Lifecycle Visualization 3-25
Open in NX ...................  3-24
Open in Teamcenter lifecycle
  visualization ................  3-24
Open in viewer ...............  7-5
Opening in NX .................  3-24
Placing variant data on ....  15-8
Populate variants ..........  16-38
Previously loaded ..........  3-7
Print application graphics
  information ..................  3-23
Print contents information  3-22
Print object properties .....  3-21
Print table ...................  3-23
Printing application information 3-22
Printing information .........  3-21
Properties ...................  3-4
Purpose ......................  1-33
Refresh .......................  4-7
Refresh window ...............  4-8
Remove level ................  4-17
Replace node ................  4-19
Rearranging ..................  4-14
Review markup ...............  4-29
Review markup mode ..........  4-27
Review markup, sample 1 ....  4-31
Review markup, sample 2 ....  4-31
## Index

Review markup, sample 3 ........................................ 4-32
Review markup, sample 4 ........................................ 4-33
BOMMarkup_AddStatus process ................................ 4-40
BOMMarkup_Review process .................................... 4-34–4-35
Save changes ..................................................... 4-7
Save configuration .............................................. 16-36
Sharing .................................................................... 4-7
Split occurrence ................................................... 15-12
Synchronize to viewer ............................................ 7-7
Test configuration .................................................. 16-36
Validate access to apply markup .............................. 4-27
Viewing structure .................................................. 3-1
Visualize ................................................................ 4-2-2
Product structures, save change records ................... 4-75
Product views
  Assemblies ......................................................... 7-10
  Cancel check out of dataset ................................. 7-19
  Check in dataset ............................................... 7-19
  Check out dataset .............................................. 7-19
  Checking in ..................................................... 7-19
  Checking out ................................................... 7-19
  Configure ........................................................ 7-12
  Create ............................................................ 7-11
  Create preview manually .................................... 7-16
  Delete ................................................................ 7-20
  Identify structure configuration ............................ 7-17
  Manage ............................................................ 7-12
  Manage unconfigured data ................................. 7-17
  Open ............................................................... 7-18
  Previewing ........................................................ 7-15
  Refresh ................................................................ 7-19
  Retrieve ........................................................... 7-18
  Save ................................................................... 7-11
  Send to external viewer ...................................... 7-20
Product, remove from design .................................. 17-6
Progression pane .................................................. 10-10
Projects
  Assign objects to .................................................. 18-1
  Overview ................................................................ 18-1
  Remove objects from .......................................... 18-3
Properties
  Adding (incremental change) .................................. 13-10
  Column configurations ......................................... 6-10
    Apply ............................................................ 6-10
    Delete .......................................................... 6-11
    Freeze .......................................................... 6-12
    Save ............................................................. 6-10
    Update .......................................................... 6-11
  Compound property, adding .................................. 6-15
  Create display name ............................................ 6-9
  Create rollup report ............................................. 6-18
  Create rollup report template .............................. 6-17
  Creating rollup reports ....................................... 6-16
  Display .................................................................. 6-1
  Display names ..................................................... 6-9
  Edit in place ....................................................... 6-14
  Export rollup report ............................................. 6-19
  Find components by ........................................... 3-14
  Incremental change ............................................ 13-9
  Modify ................................................................ 6-12
  Product structure ............................................... 3-4
  Variant Formula .................................................. 6-19
  View .................................................................... 3-4, 6-12
  View or edit rollup report ...................................... 6-19
Properties pane ...................................................... 4-85–4-86
Property column
  Insert .................................................................... 3-4
  Remove ............................................................. 3-4
  PS_new_seqno_mode preference .............................. 2-5
  ps_rename_bvrs utility ......................................... 19-2
  PSE_default_view_type preference .......................... 2-1
  PSE_default_view_type preference .......................... 19-2
  PSE_show_option_item_prefix preference .................. 2-4
  PSEAllowLegacyVICreation preference ...................... 19-7
  PSEAutoPackPref preference .................................. 2-2
  PSEBypassVISearch preference .............................. 19-7
  PSECreateVISameType preference ............................. 19-8
  PSEImpreciseColorPref preference .......................... 2-3
  PSEIsNewVIlinkedToModule preference ....................... 19-8
  PSEPreciseColorPref preference ................................ 2-3
  PSESavedConfigRelationTypes ................................ 19-7
  PSEShowUnconfigdEffPref ..................................... 19-9
  PSEShowUnconfigdEffPref preference ......................... 2-3
  PSEShowUnconfigdVarPref preference ......................... 2-3
  PSEVariantsMode preference .................................. 19-6
  PSM_global_option_item_ids preference .................... 19-7
  Public option, purpose ........................................ 16-2
  Public options .................................................... 16-15
  Publish part CAD link .......................................... 2-5

Q
  Quantity property, edit .......................................... 6-15
  Quantity, define .................................................. 3-13
  Quick add .......................................................... 4-11
  Quick search ....................................................... 4-85

R
  Recursive deletion ............................................... 4-69
Related parts, exporting structure ........ 4-61
Related revision histories ............ 10-16
Relational operators ............... 4-91
Relationships, substitute parts .... 4-59
Release status
  Incremental change ............. 13-4
  Purpose .................. 11-5
Release structures ............. 4-94
Remote components
  Import .......................... 3-29
  Importing ......................... 19-12
  Viewing ......................... 3-29
Remove
  Objects from projects .......... 18-3
Replace operation, convert from add and delete ........ 4-55
Replacing component ............ 4-53
Repositioning
  Parts and assemblies ............ 7-9
Requirement
  Trace links
    Delete .......................... 4-78
Requirements
  Link .......................... 4-75
  Trace links, create ............ 4-76
  Traceability report, generate .... 4-76
Reserved symbols, MVL ............. 16-29
Reserved words, MVL ............. 16-28
Restructure product structure .... 4-14
  Highlighting edits ............... 4-22
  Insert level ....................... 4-16
  Move node ........................ 4-17
  On-demand validation ............ 4-21
Remove level ..................... 4-17
Replace node ....................... 4-19
  Split occurrence .................. 4-20
Revision configuration ............ 1-42
  Elements .......................... 11-5
Revision effectivity
  Display data ..................... 11-21
  Edit data ....................... 11-21
Revision list pane ............. 10-10
Revision rules
  Apply .......................... 11-18
  Applying for variant item search .. 16-40
  Configure for searching .......... 4-90
  Controlling access ................ 19-11
  Create rule entry ................ 11-6
  Creating .......................... 11-6
  Date entry .................. 11-12
  Default .......................... 19-9
  Default preference ................. 2-1
  Defining entries ............... 11-8
  Delete rule entry ................ 11-7
  Edit .......................... 11-7
  Modify .......................... 11-7
  Latest by creation date entry, example .... 11-11

Edit rule entry .......................... 11-7
General rules .......................... 19-9
Graphical comparison ............... 10-9
Group entries by equal precedence ... 11-15
Group entries by item type .......... 11-13
Grouped entries ..................... 11-13
Grouping entries, example .......... 11-13
Incremental change .................. 13-5
Latest entry .......................... 11-11
Latest revisions ................... 19-10
Modify .......................... 11-7
Modify current rule ................ 11-7
Modify rule entry ................... 11-7
Nested effectivity ................ .. 11-25
Order of precedence ............... 11-2
Precise revisions ................... 19-10
Purpose .......................... 11-5
Read access .......................... 11-2
Released revisions rules .......... 19-10
Set .................................. 11-18
Set date/unit/end item ............ 11-18
Status entry .......................... 11-9
Status entry with effective date, example .......... 11-10
Status hierarchy ................... 11-10
Understanding ......................... 11-1
Unit number entry ..................... 11-12
Using from My Teamcenter ............ 11-29
Viewing information ............... 11-20
Working entry ................... 11-8
  Working entry with current user/group, example .... 11-9
  Working entry, example .......... 11-8
Revision Rules
  Apply .......................... 4-90
Revisions
  Compare histories graphically .... 10-16
  Comparing histories graphically .... 10-18
Revisions tab ..................... 10-10
Rich client perspectives and views .... 1-30
Rule entry .......................... 11-5
  Create .......................... 11-6
  Delete .......................... 11-7
  Edit .......................... 11-7
  Modify .......................... 11-7
Rules
  Date entry .......................... 11-12
  Group entries by equal precedence ... 11-15
  Group entries by item type .......... 11-13
  Grouped entries ..................... 11-13
  Grouping entries, example .......... 11-13
  Has item type ..................... 11-15
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Has item type, defining entry</td>
<td>11-14</td>
</tr>
<tr>
<td>Latest entry</td>
<td>11-11</td>
</tr>
<tr>
<td>Latest entry by creation date, example</td>
<td>11-11</td>
</tr>
<tr>
<td>Status entry</td>
<td>11-9</td>
</tr>
<tr>
<td>Status entry with effective date, example</td>
<td>11-10</td>
</tr>
<tr>
<td>Status hierarchy</td>
<td>11-10</td>
</tr>
<tr>
<td>Unit number entry</td>
<td>11-12</td>
</tr>
<tr>
<td>Working entry</td>
<td>11-8</td>
</tr>
<tr>
<td>Working entry with current user/group, example</td>
<td>11-9</td>
</tr>
<tr>
<td>Working entry, example</td>
<td>11-8</td>
</tr>
<tr>
<td>S</td>
<td></td>
</tr>
<tr>
<td>Saving changes, multiple windows</td>
<td>4-7</td>
</tr>
<tr>
<td>Saving current session</td>
<td>7-10</td>
</tr>
<tr>
<td>Scope</td>
<td></td>
</tr>
<tr>
<td>Class</td>
<td>4-87, 4-89</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>4-87, 4-89</td>
</tr>
<tr>
<td>Search</td>
<td></td>
</tr>
<tr>
<td>By attribute value</td>
<td>4-88</td>
</tr>
<tr>
<td>By object ID</td>
<td>4-82</td>
</tr>
<tr>
<td>Class hierarchy</td>
<td>4-82</td>
</tr>
<tr>
<td>Quick</td>
<td>4-85</td>
</tr>
<tr>
<td>Search all objects in selected class</td>
<td>4-86</td>
</tr>
<tr>
<td>Search button</td>
<td>4-83</td>
</tr>
<tr>
<td>Search Class dialog box</td>
<td>4-85</td>
</tr>
<tr>
<td>Search methods, workspace objects</td>
<td>4-83</td>
</tr>
<tr>
<td>Search pane</td>
<td>4-82–4-83</td>
</tr>
<tr>
<td>Searches</td>
<td></td>
</tr>
<tr>
<td>Attribute search</td>
<td>9-4</td>
</tr>
<tr>
<td>Enter criteria</td>
<td>9-5, 9-7</td>
</tr>
<tr>
<td>Form attribute filter</td>
<td>9-11–9-12</td>
</tr>
<tr>
<td>Limiting results</td>
<td>9-15</td>
</tr>
<tr>
<td>Manage results</td>
<td>9-13</td>
</tr>
<tr>
<td>Managing results</td>
<td>9-13</td>
</tr>
<tr>
<td>Managing results (examples)</td>
<td>9-13</td>
</tr>
<tr>
<td>Managing results panes</td>
<td>9-14</td>
</tr>
<tr>
<td>Nonspatial</td>
<td>3-17</td>
</tr>
<tr>
<td>Occurrence note search</td>
<td>9-7</td>
</tr>
<tr>
<td>Proximity filter</td>
<td>9-8</td>
</tr>
<tr>
<td>Spatial</td>
<td>3-17</td>
</tr>
<tr>
<td>Spatial filter</td>
<td>9-8</td>
</tr>
<tr>
<td>Spatial search</td>
<td>9-4</td>
</tr>
<tr>
<td>Spatial search granularity</td>
<td>9-11</td>
</tr>
<tr>
<td>Searching Classification, workspace object search</td>
<td>4-83</td>
</tr>
<tr>
<td>Searching using relational operators</td>
<td>4-91</td>
</tr>
<tr>
<td>Session recovery</td>
<td>4-97</td>
</tr>
<tr>
<td>Shared structure (variants)</td>
<td>15-12</td>
</tr>
<tr>
<td>ShowModuleIcons preference</td>
<td>19-7</td>
</tr>
<tr>
<td>ShowUnconfiguredByChangeEffectivity</td>
<td>19-8</td>
</tr>
<tr>
<td>Smart baseline</td>
<td>12-7</td>
</tr>
<tr>
<td>Snapshots</td>
<td></td>
</tr>
<tr>
<td>Controlling access</td>
<td>19-11</td>
</tr>
<tr>
<td>Create</td>
<td>12-2</td>
</tr>
<tr>
<td>Open</td>
<td>12-2</td>
</tr>
<tr>
<td>Purpose</td>
<td>11-6</td>
</tr>
<tr>
<td>View</td>
<td>12-3</td>
</tr>
<tr>
<td>Sorting data in the Table pane</td>
<td>4-93</td>
</tr>
<tr>
<td>Spatial search</td>
<td></td>
</tr>
<tr>
<td>Configuring</td>
<td>9-2</td>
</tr>
<tr>
<td>Defining granularity</td>
<td>9-11</td>
</tr>
<tr>
<td>Filter by form attribute</td>
<td>9-11–9-12</td>
</tr>
<tr>
<td>Limit results</td>
<td>9-15</td>
</tr>
<tr>
<td>Making</td>
<td>9-1</td>
</tr>
<tr>
<td>Manage search results</td>
<td>9-13</td>
</tr>
<tr>
<td>Managing search results</td>
<td>9-13</td>
</tr>
<tr>
<td>Managing search results (examples)</td>
<td>9-13</td>
</tr>
<tr>
<td>Managing search results panes</td>
<td>9-14</td>
</tr>
<tr>
<td>Perform search</td>
<td>9-4</td>
</tr>
<tr>
<td>Proximity filter</td>
<td>9-8</td>
</tr>
<tr>
<td>Search criteria</td>
<td>9-5, 9-7</td>
</tr>
<tr>
<td>Spatial filter</td>
<td>9-8</td>
</tr>
<tr>
<td>Spatial searches</td>
<td>3-17</td>
</tr>
<tr>
<td>Standard note</td>
<td></td>
</tr>
<tr>
<td>View</td>
<td>3-23</td>
</tr>
<tr>
<td>Viewing</td>
<td>3-23</td>
</tr>
<tr>
<td>Starting Structure Manager</td>
<td>1-2</td>
</tr>
<tr>
<td>Status entry (revision rules)</td>
<td>11-9</td>
</tr>
<tr>
<td>Status entry with effective date (revision rules)</td>
<td>11-10</td>
</tr>
<tr>
<td>Status hierarchy (revision rules)</td>
<td>11-10</td>
</tr>
<tr>
<td>Storage class</td>
<td>4-88</td>
</tr>
<tr>
<td>Storing variant data</td>
<td>15-7</td>
</tr>
<tr>
<td>Structure change records, save</td>
<td>4-75</td>
</tr>
<tr>
<td>Structure comparison</td>
<td></td>
</tr>
<tr>
<td>Choose mode</td>
<td>10-2</td>
</tr>
<tr>
<td>Clear results</td>
<td>10-6</td>
</tr>
<tr>
<td>Configure structures</td>
<td>10-4</td>
</tr>
<tr>
<td>Example results</td>
<td>10-6</td>
</tr>
<tr>
<td>Initiate</td>
<td>10-5</td>
</tr>
<tr>
<td>Interpret results</td>
<td>10-5</td>
</tr>
<tr>
<td>Multilevel mode</td>
<td>10-3</td>
</tr>
<tr>
<td>Perform</td>
<td>10-4</td>
</tr>
<tr>
<td>Understanding</td>
<td>10-1</td>
</tr>
<tr>
<td>Structure Edit</td>
<td></td>
</tr>
<tr>
<td>Creating</td>
<td>7-9</td>
</tr>
<tr>
<td>Structure line context menu</td>
<td>1-19</td>
</tr>
<tr>
<td>Structure lines</td>
<td></td>
</tr>
<tr>
<td>Pack</td>
<td>3-12</td>
</tr>
<tr>
<td>Pack all</td>
<td>3-12</td>
</tr>
<tr>
<td>Packing restrictions</td>
<td>3-11</td>
</tr>
<tr>
<td>Packing with references</td>
<td>3-12</td>
</tr>
<tr>
<td>Select</td>
<td>3-10</td>
</tr>
</tbody>
</table>
Index

Shortcut menu ........................................ 4-10
Unload ................................................. 3-8
Unpack .................................................. 3-12
Unpack all .............................................. 3-12
Unpacking with references ......................... 3-12
Structure lines, capturing in IDC ................... 12-9
Structure Manager
  Interface ................................................. 1-2
Structure properties rollup report ................. 6-16
Structure properties rollup reports
  Create report ........................................ 6-18
  Create template ....................................... 6-17
  Export report ......................................... 6-19
  View or edit report .................................... 6-19
Structure tree
  Sorting ................................................. 3-10
Structure tree (Viewer) ................................. 7-6
Structures
  Fixing associations .................................. 4-21
  Grading ............................................... 4-70
  Release ............................................... 4-94
Structures tab .......................................... 10-11
Subcomponents
  Display ................................................ 7-21
  Manipulate .......................................... 7-20
  Merge ................................................. 7-21
  View .................................................. 7-21
Substance compliance
  Apply exemption ...................................... 4-74
  Grading BOM .......................................... 4-74
  Initiate check ........................................ 4-74
  Request declaration .................................. 4-75
  View dashboard ...................................... 4-74
Substance declaration .................................. 4-75
Substitute
  Change preferred .................................... 4-59
  Create ................................................. 4-57
  Defining ............................................. 4-55
  Display ............................................... 4-56
  Display on separate line ............................ 4-57
  Edit part relationships .............................. 4-60
  Edit properties ...................................... 4-57
  Existing substitutes ................................ 4-60
  Exporting data ...................................... 4-61
  Managing relationships .............................. 4-59
  Preferred ............................................. 4-55
  Purpose ............................................... 1-33
  Relate parts ......................................... 4-59
  Relating parts ...................................... 4-59
  Remove ............................................... 4-58
  View part relationships ............................. 4-61
Substitutes .............................................. 15-15
  Compare .............................................. 4-57
  Supersedure
    Change parent assembly ............................. 10-24
    Creating new (different product) .................. 10-24
    Supersedure pane .................................... 10-14
    Supersedure tree
      Browse ............................................. 10-23
      Using .............................................. 10-23
    Supersedures ........................................ 10-7
      Adds ............................................... 10-12
      Associate custom form ............................. 10-34
      Browse ............................................. 10-23
      Cancels ............................................ 10-12
      Create custom form ................................ 10-34
      Enable custom form ................................ 10-34
      Links .............................................. 10-14, 10-16
      Moves .............................................. 10-12
      Reshapes .......................................... 10-13
      Show graphically .................................. 10-16
      Supersedure pane .................................... 10-14
      Supersedure tree .................................... 10-23
      View ................................................. 10-19
      Viewing ............................................ 10-29

T
  Tab descriptions ..................................... 1-26
  Table pane
    Sorting data ........................................ 4-93
    Viewing search results ............................... 4-93
  TC_BOM_Precision_Preference
    preference .......................................... 2-2
  TC_config_rule_name_preference ..................... 2-1
  Teamcenter lifecycle visualization
    Functionality levels ................................ 7-1
    Teamcenter lifecycle visualization, open structure in ....... 3-24
  Teamcenter Rapid Start
    Printing ............................................. 3-19
    Templates, create item from ......................... 4-4
    Tools menu .......................................... 1-10
  Trace links
    Create .............................................. 4-76
    Delete .............................................. 4-78
  Traceability report
    Export to Excel ..................................... 4-77
    Traceability report, generate ....................... 4-76
    Transfer supersedures, creating ..................... 10-25
  Transformation
    Permanent .......................................... 7-9
    Transformation, associate with absolute occurrence ........ 5-14
    Transforms ......................................... 3-26
    Types
Occurrence notes .......................... 19-5

U
Unconfigured changes ...................... 13-15
Unconfigured components
  Hiding .................................. 15-26
  Showing .................................. 15-26
Unconfigured occurrences visibility
  preference ................................ 2-3
Unconfigured variants visibility
  preference ................................ 2-3
Unit number entry (revision rules) ....... 11-12
Unit of measure ........................... 4-87, 4-89, 4-92–4-93
Units of measure
  Define .................................. 4-49
  Defining .................................. 4-49
Units of Measure .......................... 19-12
Unpacking all structure lines ............ 3-12
Unpacking structure lines ............... 3-12
Unprivileged user commands .............. 11-6
UOM ...................................... 19-12
User-defined file formats .................. 7-1
Users, configuring .......................... 11-6

V
Variability, platform designs ............... 17-1
Variant (structure), purpose ............... 15-2, 16-2
Variant condition, apply to absolute
  occurrence ................................ 5-14
Variant condition, definition .............. 16-2
Variant condition, purpose ................. 15-2
Variant conditions
  Copy .................................. 15-24
  Create .................................. 15-21
  Edit .................................. 16-23
  Edit in MVL ................................ 16-25
  Modifying ................................ 15-23
  Remove ................................ 15-25
Variant configuration ...................... 15-1, 16-1
  Complex conditions ..................... 15-13
  Creating separate item ................. 15-14
  Manage options ......................... 15-18
  Manage variant rules .................... 15-25
  Managing conditions ................. 15-20
  Save and copy variant data ............ 15-34
  Sharing structure ..................... 15-12
  Substitutes ................................ 15-15
  Variant rule checks ..................... 15-30
  Variant rules in the database .......... 15-27
Variant configuration, purpose .......... 16-2
Variant data
  Avoiding inconsistencies ............... 15-9
Change control .............................. 15-11
Configure to load .......................... 15-3
Copying .................................. 15-34
Creating .................................. 16-13
Edit .................................. 15-2
Filtering unconfigured lines .............. 15-3
Find .................................. 15-17
Placing .................................. 15-10
Populating .................................. 15-15
refreshing .................................. 15-34
Save .................................. 15-34
Save as .................................. 15-34
View .................................. 15-2, 16-12
Variant Formula property .................. 6-19
Variant items ................................ 16-6
  Classic variants ......................... 15-34
  Configure for classic variants ........ 15-37
  Create automatically .................... 16-42
  Creating ................................ 16-39
  Creating automatically (preferences) ................................ 16-44
  Creating new ................................ 16-41
  Revising ................................ 16-45
  Searching for ............................... 16-39–16-40
Unlink .................................. 16-46
Updating .................................. 16-45
Variant items, purpose ..................... 16-2
Variant rule
  Copy .................................. 15-30
  Derived default values .................. 15-27
  Load from database ...................... 15-28
  Modify saved ................................ 15-29
  Rule checks ................................ 15-27
  Save in database ......................... 15-28
  Set .................................. 15-26
  Set required rule ......................... 15-26
  Setting ................................ 15-25
  Store in database ......................... 15-27
  Unset option value ....................... 15-26
  Unset required rule ....................... 15-26
  View in My Teamcenter .................. 15-30
Variant rule checks ......................... 15-27
Variant rules
  Checks .................................. 15-6
  classic variants ......................... 15-4
  Configuring structure with ............ 16-33
  Derived defaults ......................... 15-6
Index

Fixed defaults ........................................ 15-7
Saved .................................................. 15-15
Setting (classic variants) ......................... 15-5
 Variant structure
 Configure .............................................. 16-34
 Importing .............................................. 16-38
 Load saved configuration ......................... 16-37
 Populate .............................................. 16-38
 Pull from NX .......................................... 3-25
 Push to NX ............................................ 3-24
 Save configuration ................................. 16-36
 Test configuration ................................ 16-36
 Updating .............................................. 16-38
 Variants ................................................ 1-42
 Configuring private options (modular variants) 16-3
 Configuring public interface (modular variants) 16-3
 Configuring structure (modular variants) ........ 16-12
 Creating data (classic variants) .................. 15-5
 Creating variant items (modular variants) ...... 16-6
 Defining external options (modular variants) ... 16-9
 Defining global options (modular variants) ..... 16-8
 Defining options (modular variants) ............. 16-8
 Error checking (modular variants) ............... 16-11
 Example of classic variants ...................... 15-4
 Linking options (modular variants) ............... 16-4
 Modular variants ................................. 16-3
 Option defaults (modular variants) .............. 16-11
 Placing variant data on structure (classic variants) 15-8
 Presenting options (modular variants) .......... 16-5
 Setting expression values (modular variants) ... 16-12
 Storing variant data (classic variants) .......... 15-7
 Track changes ...................................... 10-35
 Using classic variants ............................. 15-4
 Vendor parts
 Apply selection rule .............................. 19-12
 View menu ........................................... 1-8
 View Mode button ................................. 4-92
 View types
 Controlling access ................................ 1-38

Definition ............................................. 19-1
 Purpose .............................................. 1-33
 Setting .............................................. 4-5
 Setting default ..................................... 1-38
 Specifying .......................................... 1-37
 Understanding ..................................... 1-37
 Viewer
 Generate outline image .......................... 7-8
 Isolate parts ....................................... 7-8
 Open structure ..................................... 7-5
 Outline image preferences ...................... 7-8
 Save session ....................................... 7-10
 Structure tree ...................................... 7-6
 Synchronize to structure ......................... 7-7
 Using .............................................. 7-2
 Viewer pane
 Viewing results ................................... 4-93
 Viewing
 Supersedures ........................................ 10-29
 Viewing search results
 Properties pane ...................................... 4-92
 Table pane ......................................... 4-93
 Visualization, Java heap size ................. 2-6
 Visualization, memory allocation ............. 2-6
 Visualize product structure .................... 1-42
 Visualize structure ............................... 7-2

W
Watermarks
 Printing in Teamcenter Rapid Start ........... 3-20
 Welds ............................................... 3-34
 Where used utility ................................ 1-35
 Where-used searches ............................. 1-42
 Configuring for ................................... 8-1
 Make ............................................... 8-1
 Perform graphical search ....................... 8-4
 Perform search .................................... 8-5
 Print text or HTML results .................... 8-6
 Save results to HTML or text file ............. 8-7
 View HTML results ............................... 8-6
 Wildcard characters .............................. 4-92
 Working entry (revision rules) ............... 11-8
 Working entry (revision rules), example .... 11-8
 Working entry with current user group, example (revision rules) 11-9
 Working revision, definition ................... 11-6
 WSOM_only_edit_effectivity_in_ecm preference ........................................ 14-2