Teamcenter 10.1

Lifecycle Visualization
Integration Guide
Proprietary and restricted rights notice

This software and related documentation are proprietary to Siemens Product Lifecycle Management Software Inc.

© 2013 Siemens Product Lifecycle Management Software Inc. All Rights Reserved.

Siemens and the Siemens logo are registered trademarks of Siemens AG. Teamcenter is a trademark or registered trademark of Siemens Product Lifecycle Management Software Inc. or its subsidiaries in the United States and in other countries. All other trademarks, registered trademarks, or service marks belong to their respective holders.
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Proprietary and restricted rights notice</td>
<td>2</td>
</tr>
<tr>
<td><strong>Getting started</strong></td>
<td>1-1</td>
</tr>
<tr>
<td>Teamcenter integration overview</td>
<td>1-1</td>
</tr>
<tr>
<td>Before you begin</td>
<td>1-1</td>
</tr>
<tr>
<td>Lifecycle Visualization viewers</td>
<td>1-3</td>
</tr>
<tr>
<td>Basic concepts</td>
<td>1-9</td>
</tr>
<tr>
<td>Basic tasks</td>
<td>1-10</td>
</tr>
<tr>
<td><strong>Configuring the Lifecycle Viewer integration</strong></td>
<td>2-1</td>
</tr>
<tr>
<td>Teamcenter configuration overview</td>
<td>2-1</td>
</tr>
<tr>
<td>Teamcenter configuration options</td>
<td>2-1</td>
</tr>
<tr>
<td>Teamcenter preferences for visualization</td>
<td>2-10</td>
</tr>
<tr>
<td>Teamcenter Integration Preferences</td>
<td>2-56</td>
</tr>
<tr>
<td><strong>Viewing 2D images and 3D models</strong></td>
<td>3-1</td>
</tr>
<tr>
<td>2D and 3D visualization overview</td>
<td>3-1</td>
</tr>
<tr>
<td>Open visualization data from Teamcenter</td>
<td>3-1</td>
</tr>
<tr>
<td>Working with product structure from Teamcenter</td>
<td>3-2</td>
</tr>
<tr>
<td>Inserting and merging files</td>
<td>3-3</td>
</tr>
<tr>
<td>View related documents in My Teamcenter</td>
<td>3-3</td>
</tr>
<tr>
<td>Define Teamcenter User Areas</td>
<td>3-4</td>
</tr>
<tr>
<td>Search the Teamcenter database</td>
<td>3-4</td>
</tr>
<tr>
<td>Specify load option preferences</td>
<td>3-5</td>
</tr>
<tr>
<td>Specify open preferences for 2D or 3D files</td>
<td>3-8</td>
</tr>
<tr>
<td>Specify the PLM XML and Parasolid measurement unit</td>
<td>3-8</td>
</tr>
<tr>
<td><strong>Saving your work</strong></td>
<td>4-1</td>
</tr>
<tr>
<td>Overview of session files</td>
<td>4-1</td>
</tr>
<tr>
<td>Primary and secondary visualization documents</td>
<td>4-3</td>
</tr>
<tr>
<td>Overview of static and configured product structure</td>
<td>4-4</td>
</tr>
<tr>
<td>Save your work session</td>
<td>4-5</td>
</tr>
<tr>
<td>Merge a saved session with an active session</td>
<td>4-6</td>
</tr>
<tr>
<td>Specify session preferences</td>
<td>4-6</td>
</tr>
<tr>
<td><strong>Working with snapshots and product views</strong></td>
<td>5-1</td>
</tr>
<tr>
<td>Overview of snapshots and product views</td>
<td>5-1</td>
</tr>
<tr>
<td>Overview of Teamcenter product views</td>
<td>5-1</td>
</tr>
<tr>
<td>Using 2D snapshots with Teamcenter</td>
<td>5-20</td>
</tr>
<tr>
<td><strong>Sending 4GD worksets to Lifecycle Visualization</strong></td>
<td>6-1</td>
</tr>
<tr>
<td>4GD Lifecycle Visualization overview</td>
<td>6-1</td>
</tr>
<tr>
<td>Replay subset recipes when loading worksets</td>
<td>6-1</td>
</tr>
</tbody>
</table>
Contents

Launch worksets into Lifecycle Visualization ......................... 6-2
Display presented parents in Lifecycle Visualization .................. 6-3
Save a session referencing workset data .............................. 6-3
Save worksets in session packages for offline viewing ................ 6-4
Lifecycle Visualization features supported with 4GD data ............. 6-5

Working with Teamcenter visual issues ................................. 7-1

Teamcenter visual issues overview .................................... 7-1
Configuring Teamcenter visual issues ................................. 7-1
Creating Teamcenter visual issues .................................... 7-4
Reviewing Teamcenter visual issues .................................... 7-9

Working with JtSimplification data ..................................... 8-1

JtSimplification data overview ......................................... 8-1
Using JtSimplification data with other features ....................... 8-2
Resolve and fully load JtSimplification data ............................ 8-3

Using ClearanceDB with Teamcenter .................................. 9-1

Using ClearanceDB with Teamcenter .................................. 9-1
Product and system requirements ..................................... 9-2
Steps to analyze manage products .................................... 9-2
Configuring ClearanceDB to work with Teamcenter .................. 9-3
Analyzing managed ClearanceDB products ........................... 9-19
Working with DesignContext ............................................ 9-23
Chapter

1 Getting started

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Teamcenter integration overview</td>
<td>1-1</td>
</tr>
<tr>
<td>Before you begin</td>
<td>1-1</td>
</tr>
<tr>
<td>Lifecycle Visualization viewers</td>
<td>1-3</td>
</tr>
<tr>
<td>Basic concepts</td>
<td>1-9</td>
</tr>
<tr>
<td>Basic tasks</td>
<td>1-10</td>
</tr>
</tbody>
</table>
Chapter

1 Getting started

Teamcenter integration overview

The Lifecycle Visualization integration with Teamcenter enables you to work with managed visualization data in the external stand-alone application viewer or in the Lifecycle Viewer perspective in the rich client. The stand-alone application viewer is a separate application from Teamcenter. It expands upon Teamcenter’s embedded visualization components with support for optional software modules such as Concept Showroom, Visualization Illustration, and Variation Analysis. The Lifecycle Viewer is an embedded visualization application within the rich client. It provides nearly all of the visualization tools offered by the stand-alone viewer, many of which are not available for Teamcenter applications such as My Teamcenter or Structure Manager.

This guide provides information on configuring and using the Lifecycle Visualization integration with Teamcenter. More information on using the visualization products is located in the Visualizing Products section of the Teamcenter online help collection.

Before you begin

Prerequisites

The Lifecycle Visualization integration with Teamcenter supports Teamcenter lifecycle visualization stand-alone application viewer and the Lifecycle Viewer within the rich client.

The stand-alone application viewer and the Lifecycle Viewer are available in the Base, Standard, Professional, and Mockup product configurations. The Base configuration is automatically installed with the Rich Client. Some optional products are available only for the stand-alone application viewer, including Variation Analysis, Concept Showroom, and Jack.

The Teamcenter FMS Client Cache (FCC) must be installed on the client machine. This is automatically installed with the rich client. If you are using the thin client, you can install an FCC by installing the Teamcenter client communication system (TCCS) from the Lifecycle Visualization installation media.

You do not need Teamcenter administrator privileges to use the Lifecycle Visualization integration with Teamcenter or to set Teamcenter user preferences, but you do need Teamcenter administrator privileges to configure preferences at the site level.
Enable the Lifecycle Visualization integration

The Lifecycle Visualization integration with Teamcenter is part of the standard Teamcenter deployment architecture. Teamcenter is installed using Teamcenter Environment Manager (TEM).

For information about installing Lifecycle Visualization using TEM, see Teamcenter Environment Manager Help.

Configure the Lifecycle Visualization integration

Teamcenter is installed and initially configured using Teamcenter Environment Manager (TEM). After Teamcenter is installed, a number of configuration options exist that you can use to customize the Lifecycle Visualization integration.

For information on Lifecycle Visualization configuration options and preferences, see Teamcenter configuration overview.

Start the Lifecycle Visualization integration

If you are using the rich client, you can send visualization data into the stand-alone application viewer or the Lifecycle Viewer.

If you are using the thin client, you can send visualization data into the stand-alone application viewer only.

Rich client

• To send visualization data to the stand-alone application viewer, select the item revision, and click Start/Open in Lifecycle Visualization on the toolbar.

• To send visualization data to the Lifecycle Viewer, right-click the item revision, and choose Send To→Lifecycle Viewer.

Thin client

• To send visualization data to the stand-alone application viewer, select the item revision, and choose View→Teamcenter Visualization.

Note

• The options to send Teamcenter managed visualization data to the stand-alone application viewer may not shown by default on the user interface of the rich client or the thin client. For these options to be displayed, you must enable them via the Lifecycle Visualization options in the rich client or the TC_show_open_in_vmu_button preference.

For the steps to enable these options, see Display the Start/Open in Lifecycle Visualization UI.

• For more information on opening visualization files, see Open visualization data from Teamcenter.
Lifecycle Visualization viewers

The Lifecycle Visualization integration with Teamcenter supports the Teamcenter lifecycle visualization stand-alone viewer and the Lifecycle Viewer within the rich client. In addition, many rich client perspectives include embedded visualization components.

Stand-alone viewer

The stand-alone viewer, which runs outside of Teamcenter and is a separate installation, expands upon Teamcenter’s embedded visualization components with support for optional software modules such as Concept, Visualization Illustration, Quality Producer, and Variation Analysis. Stand-alone Lifecycle Visualization is integrated with Teamcenter, so you can send data from Teamcenter applications into the stand-alone viewer, perform analysis, and then save your work back to the database.

Stand-alone Lifecycle Visualization is available in the following product configurations:

- **Base**
  The Base product configuration enables you to view and mark up 2D images and perform basic 3D analysis operations such as measurements and cross sections.

- **Standard**
  The Standard product configuration provides many additional features, such as advanced navigation capabilities, markup tools, and support for precise 3D measurements.

- **Professional**
  The Professional product configuration adds analysis functionality such as 3D comparisons, as well as the ability to manipulate and transform 3D models, create outline captures, and play motion files that illustrate assembly sequences. You can optionally use add-on modules such as Animation, Concept, and Visualization Illustration.

- **Mockup**
  The Mockup product configuration provides all of the functionality from the other product configurations and also includes advanced features such as 3D clearance analysis, geometry simplification, part groups, 3D filters, and movie captures. You can optionally use all of the available add-on modules, including Quality Producer, Variation Analysis, Jack, and Path Planning.

Lifecycle Viewer

The Lifecycle Viewer is a full-fledged visualization client within Teamcenter. It provides nearly all of the visualization tools offered by the stand-alone viewer, many of which are not available in the embedded viewers within Teamcenter applications such as My Teamcenter.

The Lifecycle Viewer is available in the same product configurations as the stand-alone viewer, Base, Standard, Professional, and Mockup. Features available vary depending upon the licensing level. The Base configuration is automatically installed with the rich client.
Using the Lifecycle Viewer, you can:

- Work within a comprehensive user interface that provides access to many of the options previously available only with the stand-alone products, including menus and views (the equivalent of Project Workspace windows such as the Assembly).
- Insert or merge files within active Viewing windows.
- Work with multiple open datasets.
- Preserve the state of your work with session files.
- Save data as PLM XML.
- Export 2D images and 3D models as supported datasets.
- Author visualization data such as motion files, swept volumes, and .vfz collaboration files.

**Working with visualization data in the My Teamcenter viewer**

The **Viewer** view in My Teamcenter displays content dependent on the type of object selected in the current component view or in the **Details** view. Support for visualization data includes:

- If an item or item revision is selected, the viewer displays the associated image, printed circuit board, schematic, or JT data.
- If an image, ECAD PCB, ECAD Schematic, or JT dataset is selected, the viewer displays the image, printed circuit board, schematic, or model.

**Visualization use cases**

- View and markup of parts, printed circuit boards, schematics, drawings and images, without having to launch the stand-alone viewer or the Lifecycle Viewer.

**Visualization tools available**

- **2D Markup**
  Create 2D markups.
- **2D Multipage**
  Navigate among pages in multiple-page 2D images or documents.
- **2D Viewing**
  Pan, zoom, rotate, and flip 2D images.
- **3D Markup**
  Create 3D markups.
- **3D Measurement**
  Perform 3D measurements.
- **3D Navigation**
Pan, rotate, and zoom 3D models.

- **3D PMI**  
  View and manipulate PMI in your model.

- **3D Section**  
  Create 3D cross sections.

- **3D Selection**  
  Select parts and pick part entities.

- **3D Standard Views**  
  Examine your model from preset viewing angles.

- **ECAD Base**  
  Manipulate the view of ECAD document layers, control layer color and visibility, search, and create reports.

- **ECAD Markup**  
  Create ECAD markups.

- **ECAD Multipage**  
  Navigate among pages in multiple-page schematic documents.

- **ECAD Viewing**  
  Pan, zoom, rotate, and flip image.

- **Print**  
  Print documents.

**Structure Manager viewer**

The viewer embedded in Structure Manager is available within the **Viewer** tab of the data pane. The viewer allows you to view JT files attached to assemblies and components in the structure tree when you are viewing and editing a product structure.

**Visualization use cases**

- View 3D assemblies or structures.
- View subcomponents in an assembly.
- Compare product structures.
- Create and save product views.

**Visualization tools available**

- **3D Alignment**  
  Align parts with other parts in the viewing window.
Chapter 1  Getting started

- **3D Appearance**  
  Change the appearance of 3D models.

- **3D Clearance**  
  Check the clearance of parts in 3D models.

- **3D Comparison**  
  Compare the geometry of two sets of parts.

- **3D Coordinate System**  
  Create and align parts to local coordinate systems.

- **3D GDT Markup**  
  Create 3D GD&T markups.

- **3D Manipulators**  
  Transform 3D models.

- **3D Markup**  
  Create 3D markups.

- **3D Measurement**  
  Perform 3D measurements.

- **3D Movie Capture**  
  Capture your actions in the 3D viewing window as movie files.

- **3D Navigation**  
  Pan, rotate, and zoom 3D models.

- **3D PMI**  
  View and manipulate PMI in your model.

- **3D Section**  
  Create 3D cross sections.

- **3D Selection**  
  Select parts and pick part entities.

- **3D Standard Views**  
  Examine your model from preset viewing angles.

- **3D Thrustline Editor**  
  Create and manipulate thrustlines.

- **3D Visibility**  
  Hide obscuring parts and clip areas of your model.
Multi-Structure Manager viewer

The viewer embedded in Multi-Structure Manager is available within the **Object View** tab of the data panel. The viewer allows you to view associated 2D images and 3D models when you are viewing and editing a product or process structure.

**Visualization use cases**

- View product or process structures.
- View images associated with objects selected on the structure tab.
- View and create markups.
- Create and save product views.

**Visualization tools available**

- **2D Markup**
  Create 2D markups.

- **2D Multipage**
  Navigate among pages in multiple-page 2D images or documents.

- **2D Viewing**
  Pan, zoom, rotate, and flip 2D images.

- **3D Markup**
  Create 3D markups.

- **3D Measurement**
  Perform 3D measurements.

- **3D Navigation**
  Pan, rotate, and zoom 3D models.

- **3D PMI**
  View and manipulate PMI in your model.

- **3D Section**
  Create 3D cross sections.

- **3D Selection**
  Select parts and pick part entities.

- **3D Standard Views**
  Examine your model from preset viewing angles.
Manufacturing Process Planner viewer

The viewer embedded in Manufacturing Process Planner is available within the **Object View** tab of the data panel. The viewer allows you to view associated 2D images and 3D models when you are viewing and editing a process structure.

**Visualization use cases**

- View product or process structures.
- View images associated with objects selected on the structure tab.
- View and create markups.
- Create and save product views.

**Visualization tools available**

- **2D Markup**
  Create 2D markups.
- **2D Multipage**
  Navigate among pages in multiple-page 2D images or documents.
- **2D Viewing**
  Pan, zoom, rotate, and flip 2D images.
- **3D Markup**
  Create 3D markups.
- **3D Measurement**
  Perform 3D measurements.
- **3D Navigation**
  Pan, rotate, and zoom 3D models.
- **3D PMI**
  View and manipulate PMI in your model.
- **3D Section**
  Create 3D cross sections.
- **3D Selection**
  Select parts and pick part entities.
- **3D Standard Views**
  Examine your model from preset viewing angles.
JT Preview view

The JT Preview view enables you to examine .jt parts associated with items, item revisions, and datasets. When you select a compatible object, the .jt part is displayed in the view.

Visualization use cases
- Preview .jt parts.

Visualization tools available
- 3D Navigation
  - Pan, rotate, and zoom 3D models.

Image Preview view

The Image Preview view enables you to examine 2D raster images associated with items, item revisions, and datasets. When you select a compatible object, the image is displayed in the view.

Visualization use cases
- Preview 2D raster images.

Visualization tools available
- None

Basic concepts

Primary and secondary visualization documents

Visualization files in Teamcenter are always either primary or secondary documents. You can open primary documents independently from other documents, while secondary documents are dependent upon primary documents. For example, a JT file is a primary document, which you can view on its own without any other file having to be open; a markup layer (VPL file), in contrast, cannot be viewed on its own, and must be opened in the context of a primary document, such as a JT file.

For more information on visualization documents, see *Primary and secondary visualization documents*.

Static and configured product structure

Product structure from Teamcenter can be either static or configured, depending upon how you save and then subsequently re-open the session. When you initially send product structure into the Lifecycle Viewer or the stand-alone application viewer, the structure matches the currently active configuration settings from Teamcenter applications such as Structure Manager (revision rules, effectivity, variant rules, active assembly arrangements, and other settings).

For more information on how the stand-alone viewer and the Lifecycle Viewer open and save product structure from Teamcenter, see *Overview of static and configured product structure.*
Visualization session files

Session files save the state of the viewer so you can resume your work later. Saving your work as a session file enables you to preserve viewer elements such as open files, snapshots, part visibility, and part transformations.

For more information on how you can save your work in the Lifecycle Viewer or the stand-alone application viewer using session files, see Overview of session files.

Basic tasks

An understanding of how to complete the following tasks is helpful when first beginning to use the Lifecycle Visualization integration with Teamcenter:

- Turn on the UI options in the rich client and the thin client to send visualization data to the stand-alone application viewer.
  
  For more information on enabling the UI options to send visualization data into the stand-alone viewer, see Display the Start/Open in Lifecycle Visualization UI.

- Use the Teamcenter Integration Preferences to specify the default behavior of visualization datasets in Lifecycle Visualization.
  
  For more information on the Teamcenter Integration Preferences, see Overview of Teamcenter Integration Preferences.

- Open visualization files from Teamcenter in the stand-alone application viewer or the Lifecycle Viewer.
  
  For more information on opening visualization files, see Open visualization data from Teamcenter.

- Insert or merge visualization files with an active session in the stand-alone application viewer or the Lifecycle Viewer.
  
  For more information on inserting and merging visualization files, see Inserting and merging files.

- Search the Teamcenter database from the stand-alone application viewer.
  
  For more information on searching the Teamcenter database from the stand-alone application viewer, see Search the Teamcenter database.

- Create shortcuts to folder locations in Teamcenter.
  
  For more information on creating User Areas, see Define Teamcenter User Areas.
Chapter

2 Configuring the Lifecycle Viewer integration

Teamcenter configuration overview ........................................... 2-1
Teamcenter configuration options ........................................... 2-1
  Teamcenter server compatibility ......................................... 2-1
  Teamcenter client communication system (TCCS) requirements ..... 2-1
  Interoperation with the Teamcenter rich client on UNIX .......... 2-2
  Rich client embedded viewer compatibility ......................... 2-3
  Viewing data from multiple Teamcenter servers ..................... 2-3
Multiple File Management System (FMS) client caches (FCCs) ...... 2-4
Modifying Lifecycle Visualization configuration files ................. 2-5
Specify visualization licensing options ................................. 2-5
Display the Start/Open in Lifecycle Visualization UI .................. 2-6
Search schemas for the Lifecycle Viewer ................................. 2-7
Configuring FCC for background file loading ............................ 2-7
How group and role changes affect viewer behavior .................... 2-9
Configuring viewer features for multifield keys ....................... 2-10
Teamcenter preferences for visualization ............................... 2-10
  3DMarkup_relation_primary .............................................. 2-11
  DMI_markup_relation_primary .......................................... 2-12
  INTERROP_ExtraPLMXMLInstanceAttributes .......................... 2-13
  Interop_Vis_Attributes .................................................. 2-15
  Interop_Vis_Attributes_Admin_Filter ................................ 2-16
  ItemRevision_DirectModel3DMarkup_default_relation ............... 2-17
  ItemRevision_Vis_Session_default_relation ......................... 2-18
  JT_File_Use_Monolithic_Icon ......................................... 2-19
  ManagedIssueList ....................................................... 2-20
  ManagedIssueListQuery ................................................. 2-21
  ManagedIssueServer ..................................................... 2-22
  PLM_End_Item_Key ...................................................... 2-23
  SecondaryVMUDatasets .................................................. 2-24
  TC_DIS_2D_named_ref ................................................... 2-25
  TC_DIS_3D_named_ref ................................................... 2-26
  TC_DIS_Search ........................................................... 2-27
  TC_ENABLE_REPOSITION_DIALOG ....................................... 2-28
  TC_Schematic_BOMView_Types ......................................... 2-29
  TC_show_open_in_vmu_button .......................................... 2-30
  TCVIS_reposition_all_arrangements .................................. 2-31
  Vis_Doc_OpenOption ................................................... 2-32
  VIS_expand_below_batch_size ....................................... 2-33
Teamcenter Integration Preferences ................................. 2-56
  Overview of Teamcenter Integration Preferences .............. 2-56
  Teamcenter integration 3D loader preferences ................ 2-57
  Teamcenter Integration Session Preferences .................. 2-58
  Teamcenter Integration Markup Preferences ................... 2-58
  Teamcenter Integration Check Out Preferences ................. 2-59
  Teamcenter Integration Attributes Preferences ............... 2-60
  Teamcenter Integration Snapshot Preferences .................. 2-60
  Teamcenter Integration Visual Issue Preferences ............. 2-62
  Teamcenter Integration 3D Save Preferences ................... 2-63
Chapter 2  Configuring the Lifecycle Viewer integration

Teamcenter configuration overview

Use the configuration options described in the following sections to customize the Lifecycle Visualization integration with Teamcenter:

- **Teamcenter configuration options**
  This section provides information on subjects such as Teamcenter server compatibility, viewing data from multiple Teamcenter servers, and specifying search schemas.

- **Teamcenter preferences for visualization**
  This section provides information on the visualization-related preferences in Teamcenter.

- **Overview of Teamcenter Integration Preferences**
  This section provides information on the Teamcenter Integration Preferences available in the stand-alone application viewer and the Lifecycle Viewer.

Teamcenter configuration options

**Teamcenter server compatibility**

Lifecycle Visualization viewers from releases earlier than version 8 are not supported by and cannot communicate with Teamcenter 8 or later servers. However, the version 8 or later stand-alone viewers can communicate with DIS-enabled servers from previous Teamcenter releases.

**Teamcenter client communication system (TCCS) requirements**

The Teamcenter client communication system (TCCS) manages communication and file transfers between Teamcenter clients and servers. TCCS contains the Teamcenter Server Proxy (TSP) application which manages HTTP/S communication with a Teamcenter server and provides support for forward proxy, reverse proxy, and Kerberos authentication. TCCS also contains the FMS client cache (FCC), which uploads files from your workstation to a Teamcenter volume and also downloads requested files from the volume to your workstation. The Teamcenter lifecycle
visualization integration with Teamcenter requires an FCC to transfer volume data between Teamcenter and the viewer.

TCCS is normally installed with the Teamcenter rich client. If the Teamcenter rich client is installed on your machine, most likely no additional installation steps are necessary.

**Note** An FCC is required for Teamcenter 8 onwards. Although an FCC is not required for Teamcenter 2007, it is recommended.

For information on installing TCCS with the Teamcenter rich client, refer to the *Installation on Windows Clients Guide, Installation on Linux Clients Guide, or Installation on Macintosh Clients Guide* within the Teamcenter documentation.

If you do not have the Teamcenter rich client installed, but you need to transfer volume data between Teamcenter and the viewer, you can install TCCS from the Lifecycle Visualization DVDs or download it from the GTAC site. For more information on installing TCCS from the Lifecycle Visualization DVDs or the GTAC site, see the *Lifecycle Visualization Installation Guide*.

**Interoperation with the Teamcenter rich client on UNIX**

A configuration file is required on UNIX platforms to enable interoperation between the Teamcenter rich client, Lifecycle Visualization, and other Siemens PLM Software products. During installation, the *installed_programs.dat* file is created (or updated) in the /ugs directory. The file lists installed external applications that interoperate with the Teamcenter rich client.

The file must have the following format:

```
[HKEY_LOCAL_MACHINE\Software\Unigraphic Solutions\Installed Applications]
"<application_name>"="<path/executable>"
"<application_name>"="<path/executable>
```

There should be an entry for each instance of Mockup and Professional installed. (Standard and Base do not support interoperation.) The following is an example of the file:

```
[HKEY_LOCAL_MACHINE\Software\Unigraphics Solutions\Installed Applications]
"Teamcenter Visualization Professional 9"="/install path/bin/visviewpro"
"Teamcenter Visualization Mockup 9"="/install path/bin/vismockup"
```

**Note**

- You must be logged in as root during installation to create the /ugs directory. If you already have a /ugs directory, you do not need to be root to create or update the *installed_programs.dat* file.

- By default, Teamcenter looks for the *installed_programs.dat* file in /ugs directory, but you can set an `UGII_INTEROP_PROGRAMS` environment variable to use a different file.

- Teamcenter uses the last entry in the *installed_programs.dat* file with “Vis” in the name. If you have multiple versions of Teamcenter Visualization installed, make sure the one you want to use is the last entry in the file.
Rich client embedded viewer compatibility

For Teamcenter 2007, the embedded viewer must be exactly the same version as the rich client.

Starting with Teamcenter 8, the embedded viewer can be either the same version as the rich client, or a newer version, provided both components share the same major and minor release.

- The 8.3.3 version of the viewer is supported with the 8.3.2.1 version of the rich client. In this scenario, both components have the same major and minor release numbers, and the viewer is newer than the rich client.

- The 8.3.1 version of the viewer is not supported with the 8.3.2.1 version of the rich client. In this scenario, even though both components have the same major and minor release numbers, the viewer is older than the rich client.

- The 8.3 version of the viewer is not supported with the 8.2 version of the rich client. In this scenario, the viewer and the rich client do not have the same minor release number.

When using a version of the viewer that is newer than your rich client, new viewer features may not be available if they require rich client or server support. In addition, if a newer version of the viewer is installed, you must copy the SingleEmbeddedViewer.jar file from the \viewer_install_location\Program folder to the \rac_install_location\rac\plugins folder, overwriting the older version of the file. Note that upgrading an embedded viewer installation automatically upgrades any stand-alone viewer that is already installed.

Viewing data from multiple Teamcenter servers

If you plan to view data from multiple Teamcenter servers such as Teamcenter, Teamcenter engineering process management, and Teamcenter Enterprise, the various databases may not be coordinated with the viewer. You can only connect to one server at a time with only one FMS.

You must install either the rich clients for these servers or the FCC. Contact your Teamcenter administrator to obtain these client products. You must also modify the fcc.xml file by doing the following:

1. Contact your Teamcenter administrator for the following information about each server for each Teamcenter product you want to view visualization data from:
   - The site id number
   - The parentfsc address

2. Open a command window on your machine and navigate to teamcenter-product-installation-directory\tces\bin.

   Example  d:\tc\10\tces\bin

3. At the command prompt, type: fccstat -stop -kill.

5. Open the fcc.xml file in a text editor.

6. Search in the file for the following string: **external site access definition.**

7. After the line containing this string, add the following lines:

   ```xml
   <site id="site number" overridable="true">
   <parentfsc address="URL" priority="1"/>
   </site>
   ```

   **Example**

   ```xml
   <site id="101010101" overridable="true">
   <parentfsc address="http://tcentserver:4444/" priority="1"/>
   </site>
   ```

8. (If you have multiple Teamcenter product servers and you want to view visualization data from all of them) Repeat the previous step for each server.

   **Note**
   
   • For each additional `<site>` entry you add to the fcc.xml file, in the `<parentfsc>` tag, increment the value of the priority attribute, so that each entry has a different priority.
   
   • You can connect to only one server at a time.

9. Save the fcc.xml file.

10. At the command prompt, type: **fccstat –start**

### Multiple File Management System (FMS) client caches (FCCs)

If you plan to view data from multiple Teamcenter products, such as Teamcenter, Teamcenter engineering process management, and Teamcenter Enterprise, you may have installed multiple File Management System (FMS) client caches (FCCs). If your machine has multiple FCCs and you want to view visualization data from a particular product, your machine’s **FMS_HOME** environment variable must point to the location of the product’s FMS.

To check or change the value of the **FMS_HOME** environment variable, do the following:

   **Note**  
   A TCCS/FCC stop is required before changing **FMS_HOME**.

### Windows

1. Right-click **My Computer** and select **Properties**.

2. In the **System Properties** dialog box, click the **Advanced** tab.

3. On the **Advanced** page, click **Environment Variables**.
4. On the **Environment Variables** page, in the **User variables** section, find **FMS_HOME** and verify that its path refers to the installation path of the product from which you want to load visualization data.

5. If necessary, change the path as needed.

   **Example**

   ```
   d:\tc\10\tccs
   ```

**Linux**

1. In the shell window from which the software product was launched, type ```echo $FMS_HOME```.

   A path to the installation of that product is displayed.

2. Check the path to verify that the **FMS_HOME** environment variable is pointing to the right product.

3. If necessary, change the path as needed.

   **Example**

   ```
   ../tc/10/tccs
   ```

**Modifying Lifecycle Visualization configuration files**

Because the files used to configure Teamcenter are cached, if you update **client_specific.properties** or **tcviewer.properties**, your changes may not take effect in the viewers because the rich client is still referencing the cached files. If your changes do not appear, do the following:

- To clear the cache, add the **–clean** argument to the command line in the shortcut you use to start the rich client. Once your changes appear, you can remove the argument from the command line.

- If you update a JAR file in the **../rac/plugins** directory, make sure to replace the original JAR file with the updated version. Do not leave the original version of the JAR file in the directory.

**Specify visualization licensing options**

Licensing for the Lifecycle Viewer and the Teamcenter embedded viewers must be specified in the **client_specific.properties** file, which is located in the **../rac\plugins\configuration_8000.0.0** directory on client machines.

**Caution** These settings must match the licensing configuration available from your Teamcenter license server. They are set automatically during the client installation and in most cases should not be modified.

1. Open the **client_specific.properties** file in a text editor.

2. If necessary, add the following lines to the file:
### Configuring the Lifecycle Viewer integration

<table>
<thead>
<tr>
<th>This line</th>
<th>Requires this information</th>
</tr>
</thead>
<tbody>
<tr>
<td>PortalViewer_License_Level</td>
<td>The name of your product configuration. Type the value listed below that matches your licensing level:</td>
</tr>
<tr>
<td></td>
<td>• Base</td>
</tr>
<tr>
<td></td>
<td>• Standard</td>
</tr>
<tr>
<td></td>
<td>• Professional</td>
</tr>
<tr>
<td></td>
<td>• Mockup</td>
</tr>
<tr>
<td>PortalViewer_Optional_Licenses</td>
<td>The names of functionality options not included in the default product configurations. Type the values, separated by commas, listed below that match any additional visualization licenses you have purchased:</td>
</tr>
<tr>
<td></td>
<td>• ECAD</td>
</tr>
<tr>
<td></td>
<td>• Analysis</td>
</tr>
<tr>
<td></td>
<td>• Path_Planning</td>
</tr>
<tr>
<td></td>
<td>• Concept_Desktop</td>
</tr>
<tr>
<td></td>
<td>• Collaboration</td>
</tr>
<tr>
<td></td>
<td>• Simplified_Rendering</td>
</tr>
</tbody>
</table>

**Example**

This example shows the visualization licensing parameters in the `client_specific.properties` file set to run the Mockup product configuration, with all available options:

```properties
PortalViewer_License_Level=Mockup
PortalViewer_Optional_Licenses=ECAD,Analysis,Path_Planning,Concept_Desktop,Collaboration,Simplified_Rendering
```

### Display the Start/Open in Lifecycle Visualization UI

The options to send Teamcenter-managed visualization data to the stand-alone application viewer may not be shown by default on the user interface of the rich client or the thin client. For these options to be displayed, you must enable them using the `TC_show_open_in_vmu_button` preference.

1. In the rich client, choose **Edit→Options**.
2. In the **Options** dialog box, select **Lifecycle Visualization**.
3. Select the **Show "Open in Lifecycle Visualization" command** check box.
4. Click **OK**.
In the rich client, the **Start/Open in Lifecycle Visualization** toolbar button and the **File→Open in Lifecycle Visualization** menu command are displayed. In the thin client, the **View→Teamcenter Visualization** menu command is displayed.

For information on setting Teamcenter preferences, see the *Preferences and Environment Variables Reference*.

**Search schemas for the Lifecycle Viewer**

By default, the following system-defined search schemas are used when searches are performed from the file dialogs within the stand-alone viewers and the Lifecycle Viewer:

- Dataset
- Item
- Item revision
- Part

To add additional system-defined search schemas, modify the **TC_DIS_Search** preference.

**Note** For more information about performing searches in Teamcenter, see *Rich Client Interface Guide*.

**Configuring FCC for background file loading**

Using background file loading for large JT models may improve the performance of subsequent analysis operations, for example creating a cross section of a vehicle engine. Background file loading uses secondary processing when the system is idle. Initial file rendering caches JT file fragments that support displaying the model in the viewer. Once the initial rendering is complete, background file loading uses secondary processes to begin streaming complete files that you selected. During this process your users can view, rotate, and interact with the model; however, they might interrupt background loading or defer it to a later time because the primary viewer rendering takes higher priority. For example cutting a cross-sectioning may defer the background loading to a later time.

Consider the following when you configure FCC to support background file loading:

- Load your JT data from Teamcenter. This feature only supports working with managed data and FMS.
- Use or install FCC 9.1 or later.
- Update the following configuration settings in the *fcc.xml* configuration file:
  - Set segment cache to twice the size of the largest model.

  **Example** If the largest model is 2 GBs, set the segment cache to 4 GBs, that is, set the cache to twice the size of the largest model.
Chapter 2  Configuring the Lifecycle Viewer integration

- Set whole file cache to twice the size of the largest model.

- Review and set MinimumReadCacheAgeMinutes longer than end users will be away from the active viewing session. For example, if your users can normally be interrupted for two hours during an active viewer session, set this option to three hours.

**Note** The initial file rendering performance is not significantly influenced by selecting background file loading.

For detailed information about installing and configuring FMS and FCC, see the following:

- For more information about installing FCC in Teamcenter lifecycle visualization, see the Installation Guide.

- For more information about Teamcenter FMS, see *How FMS works* in the Teamcenter System Administration Guide.

- For more information about configuring FCC using fccdefaults, see *FCC cache parameters* in the FMS client configure file in the FMS files section of the System Administration Guide.

For steps to select background loading, see *Load JT files using background processing*.

**Cache purging**

Cache purging is a process that removes the oldest files in the FCC whole file cache to make disk space for newer cache files. Minimum values for cache purging include the size of the segment and whole file caches, and minimum cache file age. To prevent the application from deleting (purging) model files from your FCC cache, the fccdefaults options must be set to optimize how you work in your environment.

**Example**

- In this example, a model is 8 GBs, but available local disk space is 7 GBs.

  Your users can expect poor performance because the entire model cannot be loaded in the whole file cache. As a result, data is downloaded using segment cache until it writes more than the allocated data. It is important to note that data is loaded in Teamcenter lifecycle visualization, but additional time is needed to render all parts.

- In this example, a large model is 2 GBs, and both the whole file and segment cache are set to 1 GB.

  The data is downloaded using segment cache. The segment cache automatically purges the oldest files whenever you access an object, which reduces performance. To resolve the performance problem, the system administrator should set the both the whole file and segment cache size to 4 GBs.

  **Note** If the option, MinimumReadCacheAgeMinutes, has not been exceeded, the cache increases to support loading the 2 GB model. That is, the cache expands so the 2GB model is loaded.
or until the age exceeds its configured value (the default value is four hours).

- In this example, the cache size grows larger than the segment cache and `MinimumReadCacheAgeMinutes` is exceeded.

  The default for the `MinimumReadCacheAgeMinutes` option is four hours. Files in your model have been downloaded and they are stored in your cache. If a file has not been accessed after four hours, and you need to access and work with new data, the cache policy is configured to purge the older files to make room for newer ones.

### How group and role changes affect viewer behavior

If you change your Teamcenter group or role while visualizing data, the behavior of the viewer depends on your configuration.

#### Stand-alone viewer in four-tier mode

If you change your group or role while visualizing data in the stand-alone viewer in four-tier mode, you may need to close the viewer and reopen your data. Consider the following scenario:

1. Log on to a Teamcenter session in the rich client using the default group and role.
2. Launch data into the stand-alone viewer in four-tier mode.
3. In the rich client, switch to a different group and role.
4. To send additional data into the stand-alone viewer, you must do the following:
   a. In the stand-alone viewer, save all unsaved data.
   b. Close the viewer.
   c. Launch your data into a new instance of the viewer.

#### Embedded Lifecycle Viewer and the stand-alone viewer in two-tier mode

If you change your group or role while visualizing data in the Lifecycle Viewer or the stand-alone viewer in two-tier mode, the data is displayed correctly without any additional actions. Consider the following scenario:

1. Log on to a Teamcenter session in the rich client using the default group and role.
2. Launch data into the Lifecycle Viewer or the stand-alone viewer in two-tier mode.
3. In the rich client, switch to a different group and role.
4. Send the same data again to the viewer.

   The data is displayed as if the group and role switch did not happen. This is because the previously loaded data is cached.
5. Send different data to the viewer.
The data is displayed correctly for the current group and role. This is because the new data was not cached.

**Configuring viewer features for multifield keys**

Multifield keys are identifiers assigned to objects to ensure their uniqueness in the database. For example, if the item business object type is configured to use multifield keys, it is possible to have two item objects with the same item ID.

Most visualization features support multifield key data without requiring any additional configuration, with the following exceptions:

- **ClearanceDB** — The managed product name must include the __PLM_ITEMREV_UID value for the item revision, and the clearance.cfgproduct file must include the multifield key properties for the item containing the product.
  
  For more information about using ClearanceDB with multi-field key data, see the *ClearanceDB Administration Guide*.

- **MDS stamping** — The *MetaDataStamp_template* preference must specify the values of the multifield key properties associated with the item containing the MDS_default_styles_template dataset.
  
  For more information about configuring MDS stamping to work with multi-field key data, see the *Preferences and Environment Variables Reference*.

**Teamcenter preferences for visualization**
3DMarkup_relation_primary

**DESCRIPTION**
Indicates the list of valid primary object types for the 3Dmarkup relation. These are the dataset types that you can mark up with the 3D markup tools. The format is `relation-name_relation_primary=List of valid primary object types`. This preference is applicable for the stand-alone viewer and the Lifecycle Viewer.

**Note** All `<relation_business_object>_relation_primary` preferences are obsolete and are replaced by relation properties. Use the Business Modeler IDE to create and manage relation properties.

**VALID VALUES**
One or more strings as values; each string must be a valid Teamcenter dataset type.

**DEFAULT VALUES**
- DirectModel
- DirectModelAssembly

**DEFAULT PROTECTION SCOPE**
Site preference.
**DMI_markup_relation_primary**

**DESCRIPTION**
Indicates the list of valid primary object types for the DMI_markup relation. These are the dataset types that you can mark up with the 2D markup tools. The format is relation-name_relation_primary=List of valid primary object types. This preference is applicable for the stand-alone viewer and the Lifecycle Viewer.

**Note** All <relation_business_object>_relation_primary preferences are obsolete and are replaced by relation properties. Use the Business Modeler IDE to create and manage relation properties.

**VALID VALUES**
One or more strings as values; each string must be a valid Teamcenter dataset type.

**DEFAULT VALUES**
DirectModel
DrawingSheet
Image

**DEFAULT PROTECTION SCOPE**
Site preference.
INTEROP_ExtraPLMXMLInstanceAttributes

DESCRIPTION

Determines the mapping of Structure Manager BOM line attributes to Lifecycle Visualization attributes.

- This preference is applicable only for PLM XML generated by the BOMWriter. For the SOA-based Teamcenter integration with Lifecycle Visualization 8 and later, use the Interop_Vis_Attributes and Interop_Vis_Attributes_Admin_Filter preferences.

- This preference works only with stand-alone Lifecycle Visualization and the Lifecycle Viewer.

VALID VALUES

Accepts multiple string pairs as values. Each group of strings must be in the following format:

| target:root/part-instance/occurrence |
| key:Lifecycle Visualization attribute name |
| prop:BOM line property |
| propuid:bomline property tag value converted to UID |
| literal: literal string |
| attr:attribute name |

- **target**:root writes user attributes to the ProductRevisionView element of the top BOM line item revision in the generated PLM XML file.

- **target**:part writes user attributes to all ProductRevisionView elements in the generated PLM XML file.

- **target**:instance writes user attributes to all Instance elements in the generated PLM XML file.

- **target**:occurrence writes user attributes to all Occurrence elements in the generated PLM XML file.

For example, the following values create the following mappings:

| target:Occurrence |
| key:USER_DATA_1 |
| prop:bl_ItemRevision Master_user_data_1 |
| target:Instance |
| key:COMMENTS |
| prop:bl_ItemRevision Master_item_comment |
| key:CATEGORY |
| literal:CRITICALPART |
| target:Part |
| key:BOM_VIEW_TAG |
| propuid:bl_bomview |
Maps the user_data_1 attribute from the child Item Revision Master form to the USER_DATA_1 Lifecycle Visualization attribute. This mapping is written on all Occurrence elements.

Maps the comments attribute from the child Item Revision Master form to the COMMENTS Lifecycle Visualization attribute. This mapping is written on all Instance elements.

Maps the CRITICALPART (literal string) to the CATEGORY Lifecycle Visualization attribute. This mapping is written on all Instance elements.

Maps the bl_bomview (UID value) to the BOM_VIEW_TAG Lifecycle Visualization attribute. This mapping is written on all ProductRevisionView elements.

DEFAULT VALUES

None.

DEFAULT PROTECTION SCOPE

Site preference.
Interop_Vis_Attributes

**DESCRIPTION**

Indicates which Teamcenter attributes are available when an assembly is displayed in Lifecycle Visualization. The Lifecycle Visualization **Teamcenter Integration Preferences** dialog box (File→Preferences→Teamcenter Integration→Attributes) provides a convenient user interface for managing this preference.

The **Interop_Vis_Attributes** preference corresponds to the right column in the **Teamcenter Integration Preferences** dialog box as shown.

![Teamcenter Integration Preferences dialog box](image)

**VALID VALUES**

A list of Teamcenter BOM line attributes. If **Interop_Vis_Attributes_Admin_Filter** is set, **Interop_Vis_Attributes** must be a subset of it.

**DEFAULT VALUES**

None.

**DEFAULT PROTECTION SCOPE**

User preference.
Interop_Vis_Attributes_Admin_Filter

DESCRIPTION

Indicates which Teamcenter attributes are presented to users when assemblies are viewed in Lifecycle Visualization Teamcenter Integration Preferences dialog box (File→Preferences→Teamcenter Integration→Attributes). Those presented are the ones that users can then display (see the Interop_Vis_Attributes preference description).

The Interop_Vis_Attributes_Admin_Filter preference corresponds to the left column in the Teamcenter Integration Preferences dialog box as shown.

![Teamcenter Integration Preferences dialog box](image)

If there is no setting for the Interop_Vis_Attributes_Admin_Filter preference, the left column lists all BOM line attributes as candidates for users to select display (that is, candidates to move to right column).

VALID VALUES

A list of Teamcenter BOM line attributes. If Interop_Vis_Attributes_Admin_Filter is set, Interop_Vis_Attributes must be a subset of it.

DEFAULT VALUES

None.

DEFAULT PROTECTION SCOPE

User preference.
**ItemRevision_DirectModel3DMarkup_default_relation**

**DESCRIPTION**

Specifies the relation that has to be created when a DirectModel3DMarkup dataset is pasted under an item revision. The relation specified for this preference is the default relation that is created between the DirectModel3DMarkup dataset and the target item revision. This preference is applicable for the stand-alone viewer and the Lifecycle Viewer.

**Warning**

This preference is set automatically by the application and must not be modified.

**VALID VALUES**

A valid Teamcenter relation.

**DEFAULT VALUES**

**VisMarkup**

**DEFAULT PROTECTION SCOPE**

Site preference.
ItemRevision_Vis_Session_default_relation

DESCRIPTION

Specifies the relation that has to be created when a Vis_Session dataset is pasted under an item revision. The relation specified for this preference is the default relation that is created between the Vis_Session dataset and the target item revision. This preference is applicable for the stand-alone viewer and the Lifecycle Viewer.

**Warning**

This preference is set automatically by the application and must not be modified.

VALID VALUES

A valid Teamcenter relation.

DEFAULT VALUES

VisSession

DEFAULT PROTECTION SCOPE

Site preference.
### JT_File_Use_Monolithic.Icon

**DESCRIPTION**  
Specifies whether a monolithic icon is displayed to indicate the presence of structure in a JT file in the BOM tree of the Structure Manager and Manufacturing Process Planner applications.

<table>
<thead>
<tr>
<th>VALID VALUES</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>true</strong></td>
<td>The monolithic icon is displayed when a monolithic JT file containing structure is loaded in the viewer.</td>
</tr>
<tr>
<td><strong>false</strong></td>
<td>The monolithic icon is not displayed unless the node is affected by the JT_File.OverrideChildren_Refsets preference.</td>
</tr>
</tbody>
</table>

**DEFAULT VALUES**  
**true**

**DEFAULT PROTECTION SCOPE**  
User preference.
ManagedIssueList

**DESCRIPTION**

Specifies the thin client URL of your Teamcenter visual issues list. This preference is applicable for the stand-alone viewer only. When you use the **View existing issues** command in the stand-alone viewer, the thin client displays the specified list.

**Note**  By default, the visual issues list includes all IssueReport Revisions. To display only visual issues that match predefined search criteria, you must also set the **ManagedIssueListQuery** preference.

**VALID VALUES**

Accepts a single string as a value. Must be a valid URL.

**Example**  


**DEFAULT VALUES**

None.

**PROTECTION SCOPE**

Site preference.
ManagedIssueListQuery

DESCRIPTION
Specifies the name of a saved search to use when working with visual issues in the stand-alone viewer. By default, when you use the View existing issues command, the thin client displays a list of all existing IssueReport Revisions. If you have created a custom search to find IssueReport Revisions according to criteria such as Owning Group and Issue Category, you can specify to use that search instead of the default.

For more information on creating a custom search for IssueReport Revisions, see the Issue Manager Guide.

VALID VALUES
Accepts a string as a value. Must be the name of a saved search.

DEFVAL VALUES
None.

DEFAULT PROTECTION SCOPE
User preference.
**ManagedIssueServer**

**DESCRIPTION**
Specifies to use the legacy visual issues feature, which interfaces with Teamcenter community collaboration, or the Teamcenter visual issues system. This preference is applicable for the stand-alone viewer only.

**VALID VALUES**
True or False. Type True to use the Teamcenter visual issues system in the stand-alone viewer, or False to use the legacy visual issues feature.

**DEFAULT VALUES**
True

**DEFAULT PROTECTION SCOPE**
Site preference.
## PLM_End_Item_Key

| DESCRIPTION | Indicates which Teamcenter occurrence note (BOM line attribute key/name) is used to identify an occurrence as an end item. If the identified occurrence note exists on an occurrence and has a value of **True**, that occurrence is treated as an end item by the viewer. For information on using end items to control the scope of clearance analysis, see *Working with 3D Models*. |
| VALID VALUES | A string representing the key/name of the corresponding Teamcenter occurrence note. |
| DEFAULT VALUES | None. |
| DEFAULT PROTECTION SCOPE | User preference. |
SecondaryVMUDatasets

DESCRIPTION
Defines the dataset types, connected using a secondary relationship, used to search for files in ambiguous conditions. Ambiguous conditions result from performing file operations on objects or datasets.

These are the non-VMU dataset types that can contain VMU datasets. VMU datasets are datasets that can be directly launched from the rich client or the thin client into the Lifecycle Viewer or a stand-alone viewer.

VALID VALUES
The existing NX dataset values.

DEFAULT VALUES
UGMASTER
UGPART
UGALTREP

DEFAULT PROTECTION SCOPE
Site preference.
## TC_DIS_2D_named_ref

**DESCRIPTION**
Defines the possible reference names of 2D file types that are capable of 2D markups. This preference is applicable for the Lifecycle Viewer and the viewers embedded in Teamcenter applications such as My Teamcenter and Structure Manager.

**VALID VALUES**
One or more strings as values; each string must be a valid Teamcenter reference name.

**DEFAULT VALUES**
- Quickshade-Image
- PLT
- BMP
- CAL
- TIFF
- Graphics-Interface
- Sheet
- PDF
- JPEG
- TIF

**DEFAULT PROTECTION SCOPE**
Site preference.
Chapter 2  Configuring the Lifecycle Viewer integration

TC_DIS_3D_named_ref

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defines the possible reference names of 3D file types that are capable of 3D markups. This preference is applicable for the Lifecycle Viewer and the viewers embedded in Teamcenter applications such as My Teamcenter and Structure Manager.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>VALID VALUES</th>
</tr>
</thead>
<tbody>
<tr>
<td>One or more strings as values; each string must be a valid Teamcenter reference name.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT VALUES</th>
</tr>
</thead>
<tbody>
<tr>
<td>ConfiguredAssembly</td>
</tr>
<tr>
<td>UGPART</td>
</tr>
<tr>
<td>IMAGE</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT PROTECTION SCOPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site preference.</td>
</tr>
</tbody>
</table>
**TC_DIS_Search**

**DESCRIPTION**

The search schemas used when searches are performed from the file dialogs within the stand-alone viewers and the Lifecycle Viewer.

**VALID VALUES**

One or more strings as values; each string must be an existing Teamcenter search schema.

**DEFAULT VALUES**

- Dataset...
- Item...
- Item Revision...
- Part

**DEFAULT PROTECTION SCOPE**

User preference.
TC_ENABLE_REPOSITION_DIALOG

**DESCRIPTION**
Specifies whether to use the **Reposition** or the **Transformation** dialog boxes to transform parts in the rich client embedded viewers.

**VALID VALUES**

- **true** Specifies the following:
  - **Reposition** is an option on the **Graphics** menu.
  - The **Reposition – Exploded View** dialog box appears when you choose **Graphics→Reposition→Temporary Position**.
  - The **Reposition – BOM Line Edit** dialog box appears when you choose **Graphics→Reposition→Persistent Position**.

- **false** Specifies the following:
  - **Transformation** is an option on the **Graphics** menu.
  - The **Persistent Transformation** dialog box appears when you choose **Graphics→Transformation→Persistent Transformation**.
  - The **Temporary Transformation** dialog box appears when you choose **Graphics→Transformation→Temporary Transformation**.

**DEFAULT VALUES**

- **false**

**DEFAULT PROTECTION SCOPE**

User preference.
## TC_Schematic_BOMView_Types

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
<th>Determines whether Lifecycle Visualization is used in schematic mode or 3D mode. If left unset, Lifecycle Visualization is used in 3D mode.</th>
</tr>
</thead>
<tbody>
<tr>
<td>VALID VALUES</td>
<td>Takes multiple strings as values. Each value must be a set of <strong>BOM View</strong> types. It is intended that the types represent logical BOMs. For example:</td>
</tr>
</tbody>
</table>
|             | **Piping System View**  
|             | **Electrical System View** |

<table>
<thead>
<tr>
<th>DEFAULT VALUES</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEFAULT PROTECTION SCOPE</td>
<td>Site preference.</td>
</tr>
</tbody>
</table>
**TC_show_open_in_vmu_button**

**DESCRIPTION**
Specifies whether the **Start/Open in Lifecycle Visualization** button is displayed in the rich client and the **View→Teamcenter Visualization** menu command is displayed in the thin client.

**VALID VALUES**
Accepts one of the following strings as values: **True** or **False**.

**DEFAULT VALUES**
false

**DEFAULT PROTECTION SCOPE**
User preference.
**TCVIS_reposition_all_arrangements**

**DESCRIPTION**
Controls the extent of persistent transformations in arrangements. If undefined or set to **True**, persistent transformations made using the **Graphics→Transformation→Persistent Transformation** menu command are applied to all arrangements in the structure; if set to **False**, persistent transformations are applied only to the active arrangement.

**VALID VALUES**

- **True**
  Persistent transformations are applied to all arrangements in the structure.

- **False**
  Persistent transformations are applied only to the active arrangement.

**DEFAULT VALUES**

**True**

**DEFAULT PROTECTION SCOPE**
User preference.
## Vis_Doc_OpenOption

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifies the behavior for opening a document in the embedded or stand-alone Lifecycle Visualization viewer when the same document is already open in that viewer.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>VALID VALUES</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CreateNewDocument</strong></td>
<td>Opens a duplicate document window.</td>
</tr>
<tr>
<td><strong>ActivateExistingDocument</strong></td>
<td>Makes the already open document window active.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT VALUES</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ActivateExistingDocument</strong></td>
<td>User preference.</td>
</tr>
</tbody>
</table>
## VIS_expand_below_batch_size

### DESCRIPTION
Defines the batch size of BOM lines to expand for all assembly expand operations in the Lifecycle Viewer and the stand-alone application viewer. BOM lines are expanded in each assembly level in batches, the size of which is defined by this preference.

**Note** Use the **RAC_expand_below_batch_size** preference to specify the batch size of expand operations in the Structure Manager viewer.

### VALID VALUES
Accepts a single integer as a value. A positive integer defines the number of lines processed per batch. Use -1 to indicate no maximum batch size, in which case all lines in a single level are processed in a single batch.

### DEFAULT VALUES
50

### DEFAULT PROTECTION SCOPE
User preference.
Chapter 2  Configuring the Lifecycle Viewer integration

---

**VIS_mmvindexgen_admin_group**

**DESCRIPTION**

Specifies what user group has the authority to run the *mmvindexgen* harvester.

**Note** Create the *MmvIndexGenAdmin* user group and add those users with the authority to run the *mmvindexgen* harvester, or change the default value of this preference to the name of an existing user group.

For information about creating Teamcenter groups, see the *Organization Guide*.

**VALID VALUES**

Accepts a single string as a value.

**DEFAULT VALUES**

*MmvIndexGenAdmin*

**DEFAULT PROTECTION SCOPE**

Site preference.
**VIS_multi_file_datasettypes**

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifies the visualization dataset types that can contain more than one named reference. Users can view the selected named reference in the My Teamcenter embedded viewer.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>VALID VALUES</th>
</tr>
</thead>
<tbody>
<tr>
<td>One or more strings as values; each string must be a valid Teamcenter dataset type.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT VALUES</th>
</tr>
</thead>
<tbody>
<tr>
<td>DirectModel</td>
</tr>
<tr>
<td>DrawingSheet</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT PROTECTION SCOPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site preference.</td>
</tr>
</tbody>
</table>
Vis_PV_BlockingViewToggles

DESCRIPTION

Defines the list of the view toggles states that can affect how product views are created.

For more details about blocking view toggles, see the Vis_PV_InvalidConfigWarnLevel preference.

VALID VALUES

- Show Unconfigured Variants
- Show Unconfigured Changes
- Show Unconfigured Assigned Occurrences
- Show Unconfigured By Occurrence Effectivity
- Show Suppressed Occurrences
- Show GCS Connection Points

DEFAULT VALUES

- Show Unconfigured Variants
- Show Unconfigured Changes
- Show Unconfigured Assigned Occurrences
- Show Unconfigured By Occurrence Effectivity

DEFAULT PROTECTION SCOPE

Site preference.
### Vis_PV_HowTo_Configure_BOM

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indicates how the BOM window is to be configured before a product view is applied to it. This configuration is captured in the product view with the use of the VisStructureContext object. This object records the Revision Rule, Variant Rule, Assembly Arrangement and Occurrence Effectivity.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>VALID VALUES</th>
</tr>
</thead>
<tbody>
<tr>
<td>One of the following strings:</td>
</tr>
<tr>
<td>• <strong>UseCurrent</strong> – the product view is applied without modifying the configuration of the BOM window. The current configuration is used.</td>
</tr>
<tr>
<td>• <strong>UsePV</strong> – the BOM recipe that is recorded in the product view is used to configure the BOM window.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT VALUES</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>UseCurrent</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT PROTECTION SCOPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>User preference.</td>
</tr>
</tbody>
</table>
Vis_PV_InvalidConfigWarnLevel

**DESCRIPTION**

Defines the intervention level when you capture a product view containing an active view toggle state.

**VALID VALUES**

- **Off** – User is allowed to create/update PV without any intervention. Legacy behavior.
- **Warning** – A warning message is displayed to the user alerting the presence of active view toggles on the BOM window.
- **Prevent** – User shall not be allowed to proceed with creation of the product view.

**DEFAULT VALUES**

**Warning**

**DEFAULT PROTECTION SCOPE**

Site preference.
## Vis_PV_ImageCapture

### DESCRIPTION
Indicates whether an Image Capture should be added when a product view is created. It also is used to determine how the Image Capture options are configured.

### VALID VALUES
One of the following strings:

- **NoImageCapture** – an Image Capture is not generated.
- **CaptureUsingPrefs** – an Image Capture is generated using Teamcenter preferences that affect Image Capture generation.
- **CaptureUsingDialog** – an Image Capture is generated and the application uses the Image Export dialog option to configure the Image Capture.

### DEFAULT VALUES
- **NoImageCapture**

### PROTECTION SCOPE
User preference.
### Vis_PV_Play_Motion

**DESCRIPTION**
Indicates whether the motion file (if one exists) should be played automatically using the current view when the product view is applied.

**VALID VALUES**
- **True**
- **False**

**DEFAULT VALUES**
- **True**

**DEFAUL T PROTECTION SCOPE**
User preference.

**NOTE**
This preference is only supported by embedded viewers.
### Vis_PV_Show_Name_Dialog

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
<th>Indicates whether the application displays the name of a product view when it was created. If set to false, the product view name is generated automatically.</th>
</tr>
</thead>
</table>
| VALID VALUES | True  
False |
| DEFAULT VALUES | True |

User preference.
## Vis_PV_Geometry_Asset

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
<th>Indicates whether the application captures a 3D Geometry Asset when a product view is created. This preference also specifies if an outline capture should be captured with the 3D Geometry Asset.</th>
</tr>
</thead>
<tbody>
<tr>
<td>VALID VALUES</td>
<td>One of the following strings:</td>
</tr>
<tr>
<td></td>
<td><strong>NoGeoAsset</strong> – a 3D Geometry Asset is not captured.</td>
</tr>
<tr>
<td></td>
<td><strong>GeoAssetWithOutline</strong> – a 3D Geometry Asset is captured along with an Outline Capture.</td>
</tr>
<tr>
<td></td>
<td><strong>GeoAssetWithoutOutline</strong> – a 3D Geometry Asset is captured without an Outline Capture.</td>
</tr>
<tr>
<td>DEFAULT VALUES</td>
<td><strong>NoGeoAsset</strong></td>
</tr>
<tr>
<td>DEFAULT PROTECTION SCOPE</td>
<td>User preference.</td>
</tr>
</tbody>
</table>

**NOTE**

This preference replaces the previously existing Business Modeler IDE business object constant named **Fnd0VisPVGeoAsset**. This change is made to allow greater flexibility to the administrators in controlling how this information is set.
Vis_PV_capture3DGeomAssetAsOutline

**DESCRIPTION**
Activates the creation of outline capture when you save a product view in Lifecycle Visualization.

**Note** This preference is only used if 3D Geometry Asset Capture is enabled for product view save with no menus.

**VALID VALUES**
- **True**
- **False**

**DEFAULT VALUES**
- **False**

**DEFAULT PROTECTION SCOPE**
- Site preference.
Vis_PV_ImageCaptureHeight

**DESCRIPTION**

Defines the height in pixels of the preview image created when saving a product view from Lifecycle Visualization.

*Note* This preference is only used if **Image Capture** is selected for product views, and if you clear **Use Image Export Dialog**.

**VALID VALUES**

A positive integer from 1 to 1040.

*Note* When you select a value of 0 for either width or height, both values are calculated automatically.

**DEFAULT VALUES**

400

**DEFAULT PROTECTION SCOPE**

Site preference.
Vis_PV_ImageCaptureResolution

**DESCRIPTION**

Defines the resolution of the preview image created when saving a product view from Lifecycle Visualization.

**VALID VALUES**

A positive integer from 1 (lowest resolution) to 1040 (highest resolution).

**DEFAULT VALUES**

250

**DEFAULT PROTECTION SCOPE**

Site preference.
Vis_PV_ImageCaptureType

**DESCRIPTION**
Defines the format of the preview image created when saving a product view from Lifecycle Visualization.

**Note** This preference is only used if Image Capture is selected for product views, and if you clear Use Image Export Dialog.

**VALID VALUES**
- BMP 24bit
- BMP 8bit
- BMP BW
- JPEG 24bit
- PNG 24bit
- PNG 8bit
- PNG BW
- TIFF 24bit
- TIFF 8bit
- TIFF BW

**DEFAULT VALUES**
- JPEG 24bit

**DEFAULT PROTECTION SCOPE**
Site preference.
### Vis_PV_ImageCaptureWidth

**DESCRIPTION**

Defines the width in pixels of the preview image created when saving a product view from Lifecycle Visualization.

**Note** This preference is only used if Image Capture is selected for product views, and if you clear Use Image Export Dialog.

**VALID VALUES**

A positive integer from 1 to 1040.

**Note** When you select a value of 0 for either width or height, both values are calculated automatically.

**DEFAULT VALUES**

600

**DEFAULT PROTECTION SCOPE**

Site preference.
Vis_PV_ThumbnailHeight

**DESCRIPTION**
Defines the height of thumbnails created in Lifecycle Visualization.

**VALID VALUES**
A positive integer from 1 to 1040.

**DEFAULT VALUES**
80

**DEFAULT PROTECTION SCOPE**
Site preference.
### Vis_PV_ThumbnailQuality

**DESCRIPTION**

Defines the resolution of a thumbnail created in Lifecycle Visualization.

**VALID VALUES**

A positive integer from 1 (lowest) to 1040 (highest).

**DEFAULT VALUES**

100

**DEFAULT PROTECTION SCOPE**

Site preference.
Vis_PV_ThumbnailWidth

**DESCRIPTION**
 Defines the width in pixels of thumbnails created when saving a Product View from Lifecycle Visualization.

**VALID VALUES**
 A positive integer from 1 to 1040.

**DEFAULT VALUES**

80

**DEFAULT PROTECTION SCOPE**
 Site preference.
VisMarkup_relation_primary

DESCRIPTION
Indicates the valid primary object type for the Visualization 3D Markup relation. The format is relation-name_relation_primary=valid primary object type. This preference is applicable for the stand-alone viewers and the Lifecycle Viewer.

Warning This preference is set automatically by the application and must not be modified.

Note All <relation_business_object>_relation_primary preferences are obsolete and are replaced by relation properties. Use the Business Modeler IDE to create and manage relation properties.

VALID VALUES
A valid Teamcenter dataset type.

DEFAULT VALUES
ItemRevision

DEFAULT PROTECTION SCOPE
Site preference.
### VisSession_relation_primary

**DESCRIPTION**

Indicates the valid primary object type for the Visualization Session relation. The format is `relation-name_relation_primary=valid primary object type`. This preference is applicable for the stand-alone viewers and the Lifecycle Viewer.

**Warning**

This preference is set automatically by the application and must not be modified.

**Note**

All `<relation_business_object>_relation_primary` preferences are obsolete and are replaced by relation properties. Use the Business Modeler IDE to create and manage relation properties.

**VALID VALUES**

A valid Teamcenter dataset type.

**DEFAULT VALUES**

**ItemRevision**

Site preference.
VMU_Datasets

DESCRIPTION
Determines the datasets that can be directly launched in Teamcenter lifecycle visualization using the **File→Open in VMU** command in the rich client, or using the **View** link from a dataset page in the thin client. To open files such as .tiff files and PDF files, the dataset types used to manage these files must be appended to the existing values for this preference. You must also add the custom reference names within these custom dataset types to the **VMU_FileSearchOrder** preference.

VALID VALUES
One or more strings as values; each string must be a valid Teamcenter dataset type.

DEFAULT VALUES
- ClearanceDBConnection
- ClearanceDBReport
- ClearanceResults
- ClearanceResultsFilter
- DirectModel
- DirectModel3DMarkup
- DirectModelAnimation
- DirectModelAssembly
- DirectModelFlowChart
- DirectModelIllustrationBook
- DirectModelIllustrationSheet
- DirectModelMarkup
- DirectModelMotion
- DirectModelSession
- DrawingSheet
- ECADDFX
- Image
- JtSimplification
- Markup
- Nastran
- PADImage
- PADReport
- PCBFA
- PCBM Markup
- SCHFA
- SnapShotViewData
- Text
- VisJackEnvironment
- VisJackFigure
- VisJackPosture
- VisJackPsurf
- VisMovieCapture
- VisPublishGeometryAsset
- VisPublishTechnicalIllustration
- VisPublishTechnicalPortfolio
- VisPublishVisioStencil
- VisPublishVisioTemplate
- VisQualityCluster
Chapter 2  Configuring the Lifecycle Viewer integration

Vis_Session
VSAProcessDoc
VSAMeasurementDoc
Zone

DEFAULT
PROTECTION
SCOPE

Site preference.
**VMU_FileSearchOrder**

**DESCRIPTION**
Defines the order that reference names are used to search for files in ambiguous conditions. Ambiguous conditions result from performing file operations on objects or datasets. Add your custom dataset types to the **VMU_Datasets** preference to launch them in Teamcenter lifecycle visualization. You must also add the custom reference names within these custom dataset types to the **VMU_FileSearchOrder** preference.

**VALID VALUES**
One or more strings as a values; each string must be a named reference that exists within datasets that can be loaded in Teamcenter lifecycle visualization mockup.

**DEFAULT VALUES**
- Markup
- Image
- JTPART
- JTSESSION
- Package
- ConfiguredAssembly
- 3DModel
- Quickshade-Image
- PLT
- BMP
- CAL
- TIFF
- Graphics-Interface
- Sheet
- Process
- Measurement
- FlowChart
- Animation
- Motion
- IllustrationBook
- IllustrationSheet

**DEFAULT PROTECTION SCOPE**
Site preference.
VMU_RelationSearchOrder

**DESCRIPTION**

Defines the ordered list of relations used for searching relations between visualization datasets and items or item revisions. New relations must be added to the list.

**VALID VALUES**

One or more strings; each string must be a valid Teamcenter relation.

**DEFAULT VALUES**

- IMAN_Rendering
- IMAN_specification
- IMAN_MOTION
- IMAN_3D_snap_shot
- IMAN_manifestation
- TC_Attaches

**DEFAULT PROTECTION SCOPE**

Site preference.

Teamcenter Integration Preferences

**Overview of Teamcenter Integration Preferences**

Use the Teamcenter Integration Preferences to specify the default behavior of visualization datasets in Lifecycle Visualization. In the stand-alone viewer or the Lifecycle Viewer, choose **File→Preferences→Teamcenter Integration** to adjust any of the following preferences:

<table>
<thead>
<tr>
<th>Use this option</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Teamcenter integration 3D loader preferences</td>
<td>Specify the unit of measurement for PLM XML and Parasolid files loaded from Teamcenter. Also specify how to load 3D documents containing both static and configured product structure.</td>
</tr>
<tr>
<td>Teamcenter Integration Session Preferences</td>
<td>Control the default save location for session files.</td>
</tr>
<tr>
<td>Teamcenter Integration Markup Preferences</td>
<td>Control how new markups are named and whether or not to display messages during batch modifications.</td>
</tr>
<tr>
<td>Teamcenter Integration Check Out Preferences</td>
<td>Specify the default behavior when attempting to load checked out objects.</td>
</tr>
</tbody>
</table>
### Teamcenter integration 3D loader preferences

Use the Teamcenter integration 3D loader preferences to specify the unit of length for product structure data sent as a new document to the Lifecycle Viewer or stand-alone application viewer. You can also specify how to load 3D documents containing both static and configured structure.

1. Choose **File→Preferences→Teamcenter Integration**.
2. Click the **3D Loader** tab.
3. In the **Document Units** section, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the unit of measurement</td>
<td>From the <strong>Document Units</strong> list, select a unit of measurement.</td>
</tr>
<tr>
<td>Use the document units specified in the top-level product structure, if present</td>
<td>Select the <strong>Use structure units if they exist</strong> check box.</td>
</tr>
</tbody>
</table>

**Note**
- The default unit of length for product structure data sent to the Lifecycle Viewer or the stand-alone application viewer is meters.
- Changes to the **Document Units** preference do not apply to documents that are open in the session. After modifying the preference, close and reopen your documents for the change to take effect.
- The **Document Units** preference is not applicable for structure that is inserted or merged into an existing document.
- The **Document Units** preference has no effect on static structure that is opened in the Lifecycle Viewer or the stand-alone application viewer. The document unit of length for static data is specified using the **PLMXML units** setting in **PLMXML Preferences**.
4. In the **Product Structure** section, choose one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open configured structure according to its current state in Teamcenter. The most recent structure configuration is loaded.</td>
<td>Click <strong>Configure an updated structure</strong>.</td>
</tr>
<tr>
<td>For 4GD subsets, replay the subset recipe before opening the data.</td>
<td>a. Click <strong>Configure an updated structure</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. From the <strong>Update subset on load</strong> list, select one of the following:</td>
</tr>
<tr>
<td></td>
<td>• No Update</td>
</tr>
<tr>
<td></td>
<td>• Replay Recipe</td>
</tr>
<tr>
<td>When both configured and static product structure are available, open the structure according to its state at the time the session was saved.</td>
<td>Click <strong>Load static structure (structure at time of session save)</strong>.</td>
</tr>
<tr>
<td>When both configured and static product structure are available, choose how to load the structure when you attempt to open it.</td>
<td>Click <strong>Ask at load time</strong>.</td>
</tr>
</tbody>
</table>

**Teamcenter Integration Session Preferences**

Use the Teamcenter Integration Session Preferences to control how sessions are saved.

1. Choose **File**→**Preferences**→**Teamcenter Integration**.
2. Click the **Session** tab.
3. In the **Default Storage Location** section, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save session files with the base document.</td>
<td>Click <strong>Attach to base document</strong>.</td>
</tr>
<tr>
<td>Save session files in a new location.</td>
<td>Click <strong>Alternate location</strong>.</td>
</tr>
</tbody>
</table>

**Teamcenter Integration Markup Preferences**

Use the Teamcenter Integration Markup Preferences to control how new markups are named and to display messages during batch modifications.

1. Choose **File**→**Preferences**→**Teamcenter Integration**.
2. Click the **Markup** tab.
3. In the **General** section, do any of the following:
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name new markup datasets as you create them</td>
<td>Select the Show New Dataset selection dialog check box.</td>
</tr>
<tr>
<td>Display warning messages during batch operations</td>
<td>Select the Show warnings during batch modifications check box.</td>
</tr>
<tr>
<td>Display errors that occur during batch operations</td>
<td>Select the Show partial errors during batch modifications check box.</td>
</tr>
</tbody>
</table>

**Teamcenter Integration Check Out Preferences**

Use the Teamcenter Integration Check Out Preferences to specify the default behavior when attempting to load checked out objects.

1. Choose **File→Preferences→Teamcenter Integration**.

2. Click the **Check Out** tab.

3. In the **Document Checked Out By** section, do any of the following:

<table>
<thead>
<tr>
<th>To specify how to load documents</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>When the documents are checked out by someone else</td>
<td>In the <strong>Different user</strong> section, choose from the following options</td>
</tr>
<tr>
<td>When you have opened the documents in another application</td>
<td>• Load in read only mode</td>
</tr>
<tr>
<td></td>
<td>• Cancel load</td>
</tr>
<tr>
<td></td>
<td>• Show warnings</td>
</tr>
<tr>
<td></td>
<td>In the <strong>Same User / Different Application</strong> section, choose from the following options</td>
</tr>
<tr>
<td></td>
<td>• Load in read only mode</td>
</tr>
<tr>
<td></td>
<td>• Break lock and check out</td>
</tr>
<tr>
<td></td>
<td>• Cancel load</td>
</tr>
<tr>
<td></td>
<td>• Show warnings</td>
</tr>
<tr>
<td></td>
<td>In the <strong>Same User / Same Application</strong> section, choose from the following options</td>
</tr>
<tr>
<td></td>
<td>• Load in read only mode</td>
</tr>
<tr>
<td></td>
<td>• Cancel load</td>
</tr>
<tr>
<td></td>
<td>• Show warnings</td>
</tr>
</tbody>
</table>
Teamcenter Integration Attributes Preferences

Use the Teamcenter Integration Attributes Preferences to control the display of Teamcenter and NX attributes present in visualization datasets.

**Note** This preference is applicable for assemblies only. It has no effect on individual JT datasets.

1. Choose **File→Preferences→Teamcenter Integration**.
2. Click the **Attributes** tab.
3. In the **Teamcenter Attributes** tab, select the attributes that you want to display.

   **Tip** To select multiple adjacent attributes, click the first attribute, press Shift, and then click the last attribute. To select multiple nonadjacent attributes, hold Ctrl as you click each item.

4. Click **Add**.
   The selected attributes move to the **Displayed Attributes** section.
5. (Optional) Select the **Use Display Names** check box.
   The attributes are shown using display names if your database administrator defined them.
6. Close and restart the application.

   **Note** • You can also set the attributes to display within Teamcenter. Choose **Edit→Options→Index**, and then search for **Interop_Vis_Attributes**.

   • To display attributes that are longer than a single line, your system administrator must have grouped them into a single, multiline attribute.

Teamcenter Integration Snapshot Preferences

Use the Teamcenter Integration Snapshot Preferences to control how 2D and 3D snapshots are saved to Teamcenter.

1. Choose **File→Preferences→Teamcenter Integration**.
2. Click the **Snapshot** tab.
3. In the **2D Snapshot** section, do any of the following:

<table>
<thead>
<tr>
<th><strong>To</strong></th>
<th><strong>Do this</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter form data on 2D snapshots</td>
<td>Select the <strong>Show attributes form on save</strong> check box.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> You can enter data for any custom form fields. <strong>Revision</strong> and <strong>Page</strong> information is entered automatically.</td>
</tr>
</tbody>
</table>
To | Do this
---|---
Save a 2D geometry asset | a. Select the **Capture 2D geometry asset** check box.
b. (Optional) Adjust the **Geometry asset image quality** slider.

Adjust the 2D geometry asset image quality | Use the slider bar to make adjustments in a range from **Good**, **Better**, or **Best**.

4. In the **Teamcenter Product View** section, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Add or update 3D geometry asset for product views | a. Select the **Add or Update 3D Geometry Asset** check box.
b. (Optional) Select the **Draw Outline** check box to generate an outline of the 3D geometry asset.  

**Note** If you do not see the **Add or Update 3D Geometry Asset** check box, contact your administrator.

Create an image capture of the product view | a. Select the **Image Capture** check box.
b. (Optional) Select the **Use image export dialog** check box to display the **Export Image** dialog box when you save the product view. If this option is cleared, the application uses Teamcenter preferences to control such image capture options as size, file type, and resolution.  

**Note** If you do not see the **Image Capture** check box, contact your administrator.

Rename the product view before saving it | a. Select the **Show Snapshot Name Dialog** check box to display the **New Teamcenter Product View Dataset** dialog box.
b. In the **New Teamcenter Product View Dataset** dialog box, type a new name for the product view.
Chapter 2  Configuring the Lifecycle Viewer integration

Note • Use 3D Product View preferences to modify how Teamcenter product views are processed.

• The 3D Product View preferences are unavailable in the following conditions:
  o When you do not send Teamcenter data to Lifecycle Viewer. That is, you must have an active connection to a Teamcenter server.
  o When the Teamcenter protection scope of the preferences is higher than your permission scope. For example, if your administrator set the preference protection scope to SITE, and your protection scope is set to USER, the 3D Product View options are unavailable.

• If you have permissions, when you change a product view preference in Lifecycle Viewer you also change the corresponding Teamcenter preference on the server.

Teamcenter Integration Visual Issue Preferences

Use the Teamcenter Integration Visual Issue Preferences to control the default behavior of visual issue creation.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the Visual Issue tab,

3. Do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify a visual report template</td>
<td>From the Issue Type list, select a template.</td>
</tr>
<tr>
<td></td>
<td>Note Issue Report is the default issue type. Your organization may also allow you to choose from additional issue types.</td>
</tr>
<tr>
<td>Specify the issue relation to use for snapshots</td>
<td>In the Issue Relation for Snapshots section, choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Snapshot Before Fix</td>
</tr>
<tr>
<td></td>
<td>• Snapshot After Fix</td>
</tr>
<tr>
<td>Specify the data type attached to the visual issue</td>
<td>From the Data Type list, select one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Product View or 2D Snapshot</td>
</tr>
<tr>
<td></td>
<td>• Session File</td>
</tr>
<tr>
<td>Enter options for visual issue creation each time an issue is created</td>
<td>Select the Ask at the time the Issue is created check box.</td>
</tr>
</tbody>
</table>
**Teamcenter Integration 3D Save Preferences**

Use the Teamcenter Integration 3D Save Preferences to specify how to save 3D documents that contain both configured and static product structure.

1. Choose **File→Preferences→Teamcenter Integration**.

2. Click the **3D Save** tab.

3. In the **Product Structure** section, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify to save configured structure only</td>
<td>Select <strong>Save only configured structure</strong>.</td>
</tr>
<tr>
<td>Specify to save both configured and static representations of the current structure</td>
<td>Select <strong>Save configured and static representations of the current structure.</strong></td>
</tr>
</tbody>
</table>
Chapter

3 Viewing 2D images and 3D models

2D and 3D visualization overview ........................................ 3-1
Open visualization data from Teamcenter ............................. 3-1
Working with product structure from Teamcenter .................... 3-2
Inserting and merging files .................................................. 3-3
View related documents in My Teamcenter ............................ 3-3
Define Teamcenter User Areas ............................................. 3-4
Search the Teamcenter database .......................................... 3-4
Specify load option preferences ........................................... 3-5
Specify open preferences for 2D or 3D files ........................... 3-8
Specify the PLM XML and Parasolid measurement unit ............. 3-8
Chapter

3 Viewing 2D images and 3D models

2D and 3D visualization overview

The Lifecycle Visualization integration with Teamcenter enables you to work with managed visualization data in the external stand-alone application viewer or in the Lifecycle Viewer perspective in the rich client. If you are using the rich client, you can send visualization data into the stand-alone application viewer or the Lifecycle Viewer. If you are using the thin client, you can send visualization data into the stand-alone application viewer only.

Open visualization data from Teamcenter

You can open visualization data, including 2D images and 3D models, in the stand-alone viewer and the Lifecycle Viewer.

Note The options to send Teamcenter managed visualization data to the stand-alone viewer may not be shown by default on the user interface of the rich client or the thin client. For these options to be displayed, you must enable them using the Lifecycle Visualization options in the rich client or the TC_show_open_in_vmu_button preference.

• Do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send any of the following to the stand-alone viewer:</td>
<td>o (Rich client) Select the object and do one of the following:</td>
</tr>
<tr>
<td>o An item or item revision that includes visualization data</td>
<td>■ On the My Teamcenter toolbar, click Start/Open In Lifecycle Visualization.</td>
</tr>
<tr>
<td>o A BOM view</td>
<td>■ Choose File—Open in Lifecycle Visualization.</td>
</tr>
<tr>
<td>o Selected product structure</td>
<td>o (Thin client) Select the check box for the object you want to open and choose View—Teamcenter Visualization.</td>
</tr>
<tr>
<td>o 4GD worksets</td>
<td></td>
</tr>
<tr>
<td>o A 3D dataset such as a JT file</td>
<td></td>
</tr>
<tr>
<td>o A 2D or ECAD dataset such as an image or PCB file</td>
<td></td>
</tr>
</tbody>
</table>
To | Do this
---|---
Send any of the following to the Lifecycle Viewer: | (Rich client only) Right-click the object and click **Send To—Lifecycle Viewer**.
  o An item or item revision that includes visualization data | Note You can open data in the Lifecycle Viewer only from the rich client.
  o A BOM view | 
  o Selected product structure | 
  o 4GD worksets | 
  o A 3D dataset such as a JT file | 
  o A 2D or ECAD dataset such as an image or PCB file | 

If you are using the rich client, the file opens in the viewer. If you are using the thin client, a VVI file is launched. The VVI file contains the information necessary for the stand-alone viewer to open the file. Click **Open** to open the visualization file in the viewer.

### Working with product structure from Teamcenter

You can send a full or partial product structure from the Structure Manager to the Lifecycle Viewer or a stand-alone viewer. Open the structure in a new Viewing window, insert the structure as a new assembly in an active Viewing window, or merge the structure with an existing assembly in an active Viewing window.

To send product structure to the visualization client, select the product structure within the Structure Manager and then do one of the following:

- Click **Start/Open In Lifecycle Visualization** to send the product structure to a stand-alone viewer.

- Right-click the product structure and click **Send To—Lifecycle Viewer** to send the product structure to the Lifecycle Viewer.

To send a full product structure to the visualization client, select the root or top line of the product structure. To send a partial product structure, select any child nodes within the root product structure hierarchy. Partial product structure consists of the lines representing the unique paths down to the selected structure.

**Note** When working with partial product structures, the following limitations apply:

- You can expand only the child hierarchy of the launched lines.

- All viewer operations, such as filters and clearance analysis, are applicable only for the launched lines.
Teamcenter applications such as Structure Manager include view toggles that enable you to see BOM lines that are configured out because of effectivity or variants. The view toggle Show Suppressed Occurrences enables you to see BOM lines that are suppressed in the current assembly arrangement. If you send an assembly to the stand-alone application viewer or the Lifecycle Viewer when this view toggle is on, the suppressed structure elements are grayed out. If you open a product view that captured suppressed occurrences, an inactive structure warning is displayed. To avoid this problem, set the Product View Creation Preferences to prevent the creation of product views when the Show Suppressed Occurrences view toggle is enabled.

For more details about working with product views, see Overview of Teamcenter product view preferences.

Inserting and merging files

When you want to insert or merge a 2D, 3D, or ECAD file into an opened similar file format, the system asks how you want to open the file. The following insert and merge options exist:

- Insert the file into the current window.
- Merge the file into the current window.
- Insert or merge the file into a new Viewing window.

The steps required to insert or merge files vary slightly depending upon the applications involved. When working with local data in the stand-alone viewer, you must use the File→Insert or File→Merge commands. When working with Teamcenter managed data, you send the data you want to insert or merge into the stand-alone viewer or the Lifecycle Viewer, and then specify how you want to open the data in the Load Option Preferences dialog box.

View related documents in My Teamcenter

When viewing a 3D model, you can open the associated item revision in My Teamcenter to access additional information or attachments.

1. Display the product structure or part.

2. In the Assembly view, right-click the product structure or parts and choose Send to My Teamcenter.
   - or -
   In the Viewing window, right-click the geometry and choose Send to My Teamcenter.
   The associated item revision is opened in My Teamcenter.
Define Teamcenter User Areas

You can create shortcuts to folder locations in Teamcenter. When opening or saving files, you can go directly to a location without browsing intervening directory structure.

1. Choose File, and then perform an action that brings up a file dialog (Save As, Export, etc.).

   Tip If you have directories containing hundreds or thousands of files, it may take a while for the complete list of files to appear. You can press Ctrl-Break (Windows) or Esc (Mac and Linux) to stop the file listing at any point.

   The file dialog box that corresponds to your selection appears.

2. In the file dialog box, browse to a location that you want to add to your User Areas.

3. Choose Tools→Add Current Location To User Areas.

   A folder representing the location appears within your User Areas.

4. Type a name for the User Area.

   A shortcut to the specified location is created.

5. To access a User Area, click User Areas in the shortcuts panel on the left side of the file dialog box.

Search the Teamcenter database

When opening, inserting, or merging files in the stand-alone viewer, you can search a mapped Teamcenter server for datasets, item revisions, items, and parts.

1. From the File menu, choose one of the following:

   - Open
   - Insert
   - Merge

2. From the shortcut bar of the dialog box, click Servers.

   Your list of mapped servers appears.

3. Double-click the server you want to search to access it, and then choose Tools→Search Server.

4. In the Select Search section of the Server Search Dialog dialog box, select a search object. Choose from the following types of searches:

   - Dataset
   - Item Revision
• Item
• Part

The Enter Search Criteria section is populated with the available search variations.

5. In the Enter Search Criteria section, select a search criteria, type an appropriate search keyword, and click Search.

The server is searched using the criteria you specified. When the search is completed, the Search Results dialog box appears.

6. To open a search result, do one of the following:
   • Double-click the search result
   • Select the search result and then click Select.

Specify load option preferences

1. Choose File→Preferences→Load Options.

2. In the Load Option Preferences dialog box, choose from the following preferences:

<table>
<thead>
<tr>
<th>In this section</th>
<th>Select this</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Structure</td>
<td>Open document</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Open the document in a new window.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• (If the document is already open in a window) display the window.</td>
</tr>
<tr>
<td>Product Structure</td>
<td>Insert document into active window</td>
<td>Insert the data into the currently active window.</td>
</tr>
</tbody>
</table>
### In this section

#### Product Structure
- **Select this:** Merge document into active window

Note: You can merge product structure only if the data being sent is compatible with the contents of the active Viewing window. For structure to merge, the data being sent to the visualization client and the data in the active Viewing window must share the following structure configuration properties:
- Revision rule
- Root or top line
- Variant rule (if either set of data uses a variant rule)
- Active assembly arrangement (if either set of data uses arrangements)

#### Product Structure
- **Select this:** Ask at load time

Select your options each time you open a file.

#### Markups
- **Select this:** Open with markups

Open markups associated with the data.

#### Markups
- **Select this:** Ask at load time

Select your options each time you open a file.

---

**2D Page**
Viewing 2D images and 3D models

<table>
<thead>
<tr>
<th>In this section</th>
<th>Select this</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents</td>
<td>Open document</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Open the document in a new window.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• (If the document is already open in a window) display the window.</td>
</tr>
<tr>
<td>Documents</td>
<td>Insert document into active window</td>
<td>Insert the data into the currently active window.</td>
</tr>
<tr>
<td>Documents</td>
<td>Ask at load time</td>
<td>Select your options each time you open a file.</td>
</tr>
<tr>
<td>Documents</td>
<td>Open with markups</td>
<td>Open markups associated with the data.</td>
</tr>
<tr>
<td>Documents</td>
<td>Ask at load time</td>
<td>Select your options each time you open a file.</td>
</tr>
</tbody>
</table>

ECAD Page

<table>
<thead>
<tr>
<th>In this section</th>
<th>Select this</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents</td>
<td>Open document</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Open the document in a new window.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• (If the document is already open in a window) display the window.</td>
</tr>
<tr>
<td>Documents</td>
<td>Insert documents into active window</td>
<td>Insert the data into the currently active window.</td>
</tr>
<tr>
<td>Documents</td>
<td>Ask at load time</td>
<td>Select your options each time you open a file.</td>
</tr>
</tbody>
</table>

**Note**

- Selections are persisted each time the dialog box opens.
- The default settings for the **Load Option Preferences** dialog box are **Ask at load time** and **Merge document into active window**.
- For 3D, for **If merge is not possible** the default is **Open document**.
- If you choose **Ask at load time**, you can use the load option preference to change how you want to open files.
Chapter 3  Viewing 2D images and 3D models

Specify open preferences for 2D or 3D files

Some file types can be opened as 2D or as 3D file types. Previously, you were prompted to select how you wanted to open DWG/DFX, IGES, and PRT file types. Now you can use File Open Preferences to specify that you want to be prompted to then open the file as 2D or 3D, to always open these file types as 2D, or to always open these file types as 3D.

1. Choose File→Preferences→File Open.

2. In the File Open Preferences dialog box, select or clear your desired method of opening DWG, DFX, IGES, or PRT file types.

Note This functionality is supported in Standard service levels and above. For Base service levels, these files always open as 2D file types.

3D IGES files are supported only in the stand-alone viewers.

Specify the PLM XML and Parasolid measurement unit

By default, the unit of measurement for PLM XML and Parasolid files is meters. You can use the PLMXML Units setting to specify another unit of measurement.

1. Choose File→Preferences→PLM XML.

2. In the PLMXML Preferences dialog box, on the Load page, select a unit of measurement for PLMXML Units.

Note • The PLM XML Units setting is saved in session files. If you change and save the model units setting with a VF file, the specified model units of the session file override the current PLMXML Units setting.

• Session files referencing PLM XML models that were created prior to Teamcenter lifecycle visualization 5.1.0.2, do not contain the model units specification. The software uses the current PLMXML Units setting on the Load page of the PLM XML Preferences dialog box if you load the session file with a newer viewer. This event may result in content displayed in the wrong scale. The model units is always meters for pre-5.1.0.2 PLM XML files.

As a work around, migrate the session file to a Teamcenter lifecycle visualization 5.1.0.2 version. Load and save the file in Teamcenter lifecycle visualization 5.1.0.2.
Chapter

4 Saving your work

Overview of session files .................................................. 4-1
Primary and secondary visualization documents ....................... 4-3
Overview of static and configured product structure .................. 4-4
Save your work session ...................................................... 4-5
Merge a saved session with an active session .......................... 4-6
Specify session preferences .................................................. 4-6
Overview of session files

Session files save the state of the viewer so you can resume your work later. Saving your work as a session file enables you to preserve the following:

- Open files
- Snapshot information
- 3D preferences
- Alternate assembly hierarchies
- True Shading settings
- Cross sections
- 3D Measurements
- User Defined coordinate systems
- 3D layers
- Teamcenter revision rules, effectivity, variant rules, active assembly arrangements, and other configuration settings.

**Example**

You are working with *model1.jt*, *model2.jt*, and *image.tif*. You have created snapshots, changed background colors, and created markup layers. You then save your work as a .vf session file.

When you re-open the session file, the three files open, and the snapshots, background colors, and markup layers appear as they were when you saved the session.

Primary and secondary documents

Session files reference *primary* and *secondary* documents. A session file can preserve the state of multiple primary documents, and each primary document may be associated with multiple secondary documents.
Static and configured product structure

In terms of session files, product structure is considered to be either static or configured. Static product structure is a unique version of the document that is created at the time the session is saved. This type of data ensures that loading the session at a later time will result in the same product structure that was loaded when the session was first saved. Configured product structure is dynamic and references Teamcenter configuration settings. This type of data can be thought of as a recipe which can be used later to get different document revisions.

For more information on how product structure references are preserved in session files, see Overview of static and configured product structure.

Session save options

You have a number of options for saving session data to different locations, depending upon whether the session consists of local data only or includes data from Teamcenter.

If the session includes only data loaded from your local machine, you can save the session to a location on your local machine or network.

If the session includes Teamcenter-managed data, you can save the session to the Teamcenter server in the following ways:

- Attach to Base Document - Save the session within the item revision of the primary document.
Saving your work

- **Attach to Selected Bomline** - Save the session within the item revision of the selected BOM line in the 3D assembly tree.

- **Alternate Location** - Save the session to a different location. Click **Browse**, and then specify the folder, item, or item revision within which you want to save the session.

  **Note** You can use the **Teamcenter Integration Session Preferences** to specify default session save options.

Primary and secondary visualization documents

Visualization files in Teamcenter are always either **primary** or **secondary** documents. You can open primary documents independently from other documents, while secondary documents are dependent upon primary documents. For example, a JT file is a primary document, which you can view on its own without any other file having to be open; a markup layer (VPL file), in contrast, cannot be viewed on its own, and must be opened in the context of a primary document, such as a JT file.

A primary document:

- Can exist in the database on its own.

- Consists of data that has been translated from some master source data such as a CAD file.

- Consists of one file (for example, a 2D image) or a logical set of files (for example, assembly and part files).

- Can be opened in a Lifecycle Visualization viewer independently of any other documents.

- May have secondary types of documents that depend on it, but may not be aware of these secondary files.

A secondary document:

- Always relies on a primary document.

- Is only meaningful in the context of a primary document (for example, a 3D markup).

- Cannot be viewed in a Lifecycle Visualization viewer without a primary document.

- Is always aware of its primary document.

- May contain many types of data which may serve different purposes (for example, a snapshot consists of layer data, view data, motion data, thumbnail data, and so forth).

- May capture additional information about the primary document.
Overview of static and configured product structure

Product structure from Teamcenter is either static or configured. Configured product structure is dynamically built according to revision rules, effectivity, variant rules, active assembly arrangements, and other settings, depending on how the structure is initially launched and how the visualization session is subsequently authored.

Configured structure

The following scenarios result in a configured structure in the viewer:

- From My Teamcenter or the thin client, launch a BOM view or BOM view revision (or any object that includes a BOM view or BOM view revision, such as an item or item revision) into the stand-alone viewer or the Lifecycle Viewer. The structure is configured in the viewer according to your default revision rule.

- From the stand-alone viewer, open a BOM view or BOM view revision (or any object that includes a BOM view or BOM view revision, such as an item or item revision). The structure is configured in the viewer according to your default revision rule.

- From Structure Manager, Multi-Structure Manager, or Manufacturing Process Planner in the rich client, launch one or more BOM lines into the stand-alone viewer or the Lifecycle Viewer. The structure is configured in the viewer according to whatever configuration is currently active in the launching application.

- From Structure Manager or Manufacturing Process Planner in the thin client, launch one or more BOM lines into the stand-alone viewer. The structure is configured in the viewer according to whatever configuration is currently active in the launching application.

Static structure

The following scenarios result in a static structure in the viewer:

- Perform any process that results in opening a PLM XML file in the stand-alone viewer or the Lifecycle Viewer. For example, launching a QL file or a DirectModelAssembly dataset results in the loading of a PLM XML file into the viewer. The viewer treats these data types as static structure, since a session file authored in the viewer references the static PLM XML.

- Open a VF session file that points to static PLM XML. This occurs under the following conditions:
  - The Capture Static Structure check box is selected when the session file is authored.
  - The structure in the viewer is saved as PLM XML (File→Save As) before the session is authored.

VF session files and configured or static structures

Opening a session dataset can result in the loading of a static structure or a configured structure, depending upon the data and the conditions under which the session authored.
When you save a session referencing configured structure, the session preserves the product structure configuration active in the viewer. However, if you select the **Capture Static Structure** check box in the **Session Save As** dialog box, the viewer also saves the exact product structure you have open at the time you save the session. When you load the session later, the viewer detects if this static structure is available and asks you how you want to open it: as a static structure (the exact product structure that was active in the viewer at the time the session was saved) or a configured structure (according to the configuration settings in effect at the time the session was saved). Note that if the **Capture Static Structure** check box is not selected when you initially save the session, when you open the session later the structure is loaded dynamically based on the configuration in effect at the time the session was saved.

You can set a Teamcenter Integration Preference to automatically handle this when loading a session. You can choose to:

- Always load the static structure
- Always load the configured structure (the latest version of the structure according to the configuration settings in effect at the time the session was saved)
- Ask how to load a structure at load time

For information on setting the Teamcenter Integration Preferences, see *Teamcenter Integration Session Preferences.*

### Save your work session

You can save your work as a .vf session file. When you open the session file later, your work is restored.

1. Choose **File→Save Session.**

2. In **Session Storage Location**, click one of the following:

<table>
<thead>
<tr>
<th>Use this option</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attach to Base Document</td>
<td>Save the session within the ItemRevision of the base document.</td>
</tr>
<tr>
<td>Attach to Selected Bomline</td>
<td>Save the session within the ItemRevision of the selected BOM line in the 3D assembly tree.</td>
</tr>
<tr>
<td>Alternate location</td>
<td>Save the session to a different location. Click <strong>Browse</strong>, and then specify the folder, Item, or ItemRevision within which you want to save the session.</td>
</tr>
</tbody>
</table>

3. To rename the session file or any secondary documents that you have created during your work session and not yet saved, such as markup layers or motion documents, double-click the default name of the document and type a new name.

**Note** You cannot use any non-ASCII character (including 8 bit accented Western European and multi-byte characters) for a file name.
Chapter 4  Saving your work

4. Click **Save**.

   The session file is saved. Any new or unsaved secondary documents are also saved with the session file to their specified locations.

   **Note** If you have unsaved clearance results, the **Save Clearance Results As** dialog box appears. You must save to a .txt file to reference the results in a session file.

Merge a saved session with an active session

1. Start a new work session or open a session file.

2. In My Teamcenter, right-click a session dataset and choose **Send To→Lifecycle Viewer**.

   If the sessions can be merged, the **Merge Sessions** dialog box appears.

3. Click **Merge**.

   The saved session is merged with the contents of the active session.

Specify session preferences

1. Choose **File→Preferences→Session**.

2. In the **Session Preferences** dialog box, change any of the following settings:

<table>
<thead>
<tr>
<th>In this section</th>
<th>Use this preference</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session Merge</td>
<td>Reuse existing windows if possible</td>
<td>When opening a session while another session is active, merge the sessions in the active Viewing window.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note</strong> If this option is not turned on, the sessions are opened in separate Viewing windows.</td>
</tr>
<tr>
<td>Ask at load time</td>
<td></td>
<td>When attempting to open a session while another session is active, display the <strong>Merge Sessions</strong> dialog box, from which you can specify to merge the session into a single Viewing window.</td>
</tr>
</tbody>
</table>
In this section | Use this preference | To
---|---|---
Session Save | Enable password protection for session package | Apply password protection to .vfz session packages.
 | Maintain dynamic references when possible | When session files are opened, attempt to update linked references.
Session Open | Show Attachments on open | When session packages are opened, display the Attachments dialog box, from which you can open attachments saved with the session.

3. Click **OK**.
5 Working with snapshots and product views

Overview of snapshots and product views ........................................... 5-1

Overview of Teamcenter product views ........................................... 5-1
  Overview of product view states ........................................ 5-2
  Overview of Teamcenter product view preferences ................. 5-4
  Overview of product view toggle states ............................... 5-5
Overview of Teamcenter product views ........................................... 5-1

Opening product views ............................................................... 5-7
  Open product views from the Product View Gallery or Attachment panel .............................................................. 5-7
  Open product views from My Teamcenter or Thin Client ....... 5-9
  Opening NX motion product views ......................................... 5-10
Creating a new product view ......................................................... 5-10
Add a product view ....................................................................... 5-11
Update or replace a product view .............................................. 5-12
Save product views to Teamcenter .............................................. 5-14
Save several product views to Teamcenter ................................. 5-15
Capturing images and creating 3D geometry assets ................. 5-16
  Create product view 3D geometry assets ......................... 5-17
  Capture an image of a product view .................................. 5-18
  Product view system constraints and preferences .............. 5-19

Using 2D snapshots with Teamcenter .......................................... 5-20
Send Teamcenter 2D snapshots to the viewer .......................... 5-21
Create Teamcenter 2D snapshots using an item revision ....... 5-22
Save Teamcenter 2D snapshots ................................................. 5-22
How do I track design changes using Teamcenter 2D snapshots? 5-23

Lifecycle Visualization Integration Guide
Chapter

5 Working with snapshots and product views

Overview of snapshots and product views

Snapshots capture the state of the Viewing window. If you capture snapshots of several views of your image or model, you can return to any view by applying its snapshot.

You can create the following types of snapshots:

- **2D snapshots**
  
  Used to capture the state of the 2D Viewing window when working with 2D images. You can create and view 2D snapshots in the stand-alone viewer, the Lifecycle Viewer, Manufacturing Process Planner, and Multi-Structure Manager. When created in the stand-alone viewer or the Lifecycle Viewer, 2D snapshots are persisted in session files and PLM XML, or saved to the Teamcenter server as Vis_Snapshot_2D_View_Data datasets. When created in Manufacturing Process Planner or Multi-Structure Manager, 2D snapshots are saved as Vis_Snapshot_2D_View_Data datasets.

- **3D snapshots**
  
  Used to capture the state of the 3D Viewing window when working with 3D models. You can create and view 3D snapshots in the stand-alone viewer and the Lifecycle Viewer. 3D snapshots are persisted in session files and PLM XML only.

- **Product views**
  
  Used to capture the state of a 3D scene in Teamcenter. You can create product views in the Lifecycle Viewer, the stand-alone application viewer, Manufacturing Process Planner, Multi-Structure Manager, and Structure Manager. You can open product views in all these viewers. When you create product views, you save them as a SnapShotViewData dataset.

  When you send a product view to the Lifecycle Viewer or open it in the integrated viewer, you can then modify the product view (modify the existing product view, add a new one, or update the existing product view) and save it as a dataset in Teamcenter.

Overview of Teamcenter product views

Teamcenter supports opening and modifying product views in Lifecycle Viewer or in the integrated stand-alone application viewer. You can also save product views
Chapter 5  Working with snapshots and product views

to Teamcenter. Product views include views of the assembly or part that may include markups, updates to part color, part repositioning, and motion 3D snapshots (created using NX).

You can create, modify, and save Teamcenter product views in the following Teamcenter applications:

- Any application that supports the **Product View Gallery**.
  These include Manufacturing Process Planner, Multi-Structure Manager, and Structure Manager.
- My Teamcenter and thin client.

**Working with the Product View Gallery**

For Teamcenter applications that support the **Product View Gallery**, you can send the product view to the Lifecycle Viewer or to the integrated stand-alone application viewer. You are given a choice to open the product view as a static structure or live structure. You can then manage the product view, for example by adding markups, changing the view, adding new product views, and updating the product view. You can also right-click in the Snapshot page and select **Save as Teamcenter Product View** to create a new snapshot in Teamcenter.

The **Product View Gallery** is supported by Structure Manager, Multi-Structure Manager, and Manufacturing Process Planner.

When you work with product views in the **Product View Gallery**, you can:

- Send one product view from the **Product View Gallery** to the Lifecycle Viewer or to the integrated stand-alone application viewer.

- Send several product views to the Lifecycle Viewer or to the integrated stand-alone application viewer, once you have configured the **Enable Multiple Select in Product View Gallery**.

- Merge them into the active document or open them in a new viewing window from either the Teamcenter **Attachment** panel or the **Product View Gallery**.

  **Note** You can only merge the product views that share the same base structure.

**Working with My Teamcenter and the thin client**

You can open, update, and save an existing product view from My Teamcenter or the thin client in the Lifecycle Viewer or in the integrated stand-alone application viewer.

If you save a session, the open product views are converted to 3D snapshots, and saved in the session without reference to the Teamcenter product view datasets.

For details about working with standard visualization snapshots, see **Working with 3D snapshots**.

**Overview of product view states**

When product views are saved, they capture the following minimum information:

- The static structure capture of the visible occurrences.
• The configuration that was applied to the structure at the time the product view was captured.

• The view state data (for example, markups, cross sections, repositioned component transforms, and so forth).

• 2D image data (for example, thumbnail, preview images, geometry asset).

You can control how the structure is opened and configured before you apply the viewing data.

You can load and apply product views with three different behaviors:

• As static structure.

  When you open the static structure, you open the static capture of the visible product structure at the time it was saved. The structure is pruned to show only the visible lines at the time of capture. You can use this product view option when you need to be sure the exact captured 3D scene is reproduced. You open a product view in a static structure by opening it in the My Teamcenter view panel, or by sending a product view from My Teamcenter to the Lifecycle Viewer or to the integrated stand-alone application viewer and selecting the static structure load option.

• As as-saved structure configuration.

  When you open the product view in the as-saved structure configuration, the structure is configured in the same way it was configured when the product view was captured prior to applying the view. Since the structure is configured dynamically in this case, there is no way to guarantee this product view is identical to what it was when it was captured, because the structure may have changed since the product view was captured. This allows the product view to be kept up to date as the structure is updated. You open a product view in the as-saved structure configuration by setting the Configuration Rules—update from Product View option when the product view is applied in the Product View Gallery, or by sending the product view from My Teamcenter to the Lifecycle Viewer or to the integrated stand-alone application viewer and selecting the dynamic structure load option.

• As the current structure configuration.

  When you open the product structure in the current structure configuration, you open the product view in accordance to its current configuration set in the Product View Gallery of the launching program (for example, Structure Manager). You open a product view in a current structure configuration by setting the Configuration Rules—use current option when the product view is applied in the Product View Gallery, or by sending the product view from the Product View Gallery to the Lifecycle Viewer or to the integrated stand-alone application viewer and then selecting the dynamic structure load option.
Parts may appear in incorrect positions when product views authored in the Lifecycle Viewer or the stand-alone application viewer are restored in certain Teamcenter embedded viewers. This problem occurs when the motion system records part transformations on subassembly nodes, and the transformations are subsequently captured by the product view. These assembly-level transformations generated by the motion system are not applied correctly when the product view is restored in Structure Manager, Multi-Structure Manager, and Manufacturing Process Planner.

You can avoid this limitation by keeping 3D part transformations at the part level when working with motion in the Lifecycle Viewer or the stand-alone application viewer. Rather than transforming an entire assembly or subassembly, expand the structure and select all of the individual parts and move them instead.

**Overview of Teamcenter product view preferences**

You can change several product view and product view related characteristics using Teamcenter product view preferences. Previously, product view preferences were accessed in the **Product View Gallery**. Now, you can access product view preferences by navigating to the Teamcenter **Options** menu; choose **Edit→Options→Visualization→Product View**.

Product view preferences are now centralized and changes to these characteristics can also be made by using Teamcenter preferences. Your site administrator can also
set preference protection scope for product view preferences to USER (the default), GROUP, or SITE.

Note If the protection scope is set to GROUP or SITE, preferences are displayed but you may not have permission to change them.

For more details about product view preferences, see Visualization preferences in Preferences and Environment Variables Reference.

For more details about setting product view preferences using the Options menu, see Option reference in Rich Client Interface Guide.

For more details about working with product views in Teamcenter, see Working with product views in Structure Manager Guide.

Overview of product view toggle states

Using Teamcenter, you can set product view options to show or hide unconfigured objects by selecting or clearing view toggle states. When you send the product view to the viewer, these unconfigured objects are shown or hidden as they were shown or hidden when the product view was captured. You can set view toggle state preferences in Teamcenter by navigating to Edit→Options→Product View.

The captured product views may result in active view toggles that generate non-buildable assembly configurations. To control the creation of non-buildable product views, your administrator may prevent generating product views when certain unconfigured objects exist. In addition to preventing the creation of toggle view states, the administrator can also choose to warn or process product views which contain unconfigured data.

If you choose to update the configuration from the product view when you reopen it, the saved view selections are retrieved; if you choose to use the current configuration, the saved view selections are ignored.
The administrator can set preferences to determine how product views are created when unconfigured objects are shown. The administrators options include the following:

- **Off**
- **Warning**
  
  In the **Invalid assembly state** dialog box that appears, a message indicates that active view toggle states were detected. You can then choose to proceed with product view creation or modification or you can cancel the task.

- **Prevent**
  
  In the **Invalid assembly state** dialog box that appears, a message indicates that active view toggles were detected. You are asked to turn off active toggles in order to proceed with product view creation or modification.
You use the view toggle **Show Suppressed Occurrences** to see BOM lines that are suppressed in the current assembly arrangement in Structure Manager. If you send an assembly to the stand-alone application viewer or the Lifecycle Viewer when this view toggle is on, the suppressed structure elements are grayed out. An inactive structure warning appears when you open a product view that contains suppressed occurrences. This can be avoided if you choose the appropriate View Toggle Warning Level for product view creation and then select **Show Suppressed Occurrences** from **Edit→Options→Product View**.

For more details about working with view toggle states in Teamcenter, see **Manage unconfigured data in a product view** in **Manufacturing Process Planner Guide**.

For more details about product view preferences, see **Visualization preferences** in **Preferences and Environment Variables Reference**.

### Opening product views

You create product views in Teamcenter using the **Product View Gallery**. Product views can then be sent to the Lifecycle Viewer or to the integrated stand-alone application viewer.

You can:

- **Open product views from the Product View Gallery or Attachment panel**. The current configuration of the structure in the launching program is loaded in the viewer when you apply the product view.

- **Open product views from My Teamcenter or Thin Client**. You are given the option to open the product view as a static structure or dynamic structure.
  - If you elect to open the product view as a static structure, the exact structure that was saved with the product view is reloaded and applied.
  - If you select to open the product view as a dynamic structure, the as-saved configuration of the structure when last saved is applied when the product view is applied.

- **Open an NX motion product view**. In this case, you open a product view that contains motion and that was authored by NX.

### Open product views from the Product View Gallery or Attachment panel

You can open product views from a Teamcenter application that supports the **Product View Gallery** and open them in the Lifecycle Viewer or in the integrated stand-alone application viewer. You can also open product views from the Teamcenter **Attachment panel**.

You are given a choice to open the product view in a live structure (dynamic) or in an as-saved configuration (static).

Teamcenter applications that support the **Product View Gallery** include Structure Manager, Multi-Structure Manager, or Manufacturing Process Planner.

1. From Structure Manager, Multi-Structure Manager, or Manufacturing Process Planner, do one of the following:
Chapter 5  Working with snapshots and product views

- Choose View→Show/Hide Data Panel.

- On the toolbar, click Show/Hide Data Panel.

2. Click the Viewer tab.

3. If Create 3D Product Views toolbar is not visible, right-click in the viewer menu bar and choose Create Markup.
   Teamcenter displays the Create Markup toolbar.

4. On the Create Markup toolbar, select Create 3D Product Views.
   Teamcenter displays the Product View Gallery window, which contains thumbnails of any previously saved product views that are associated with the selected object.

5. Right-click any product view thumbnail and select one of the following:
   - Send to Lifecycle Viewer
   - Open in Teamcenter Visualization

6. To configure the software to open more than one product view at a time, do the following:
   Open the Product View Gallery.
   Right-click in the lower portion of the Product View Gallery dialog box, for example near Cancel.
   Click Options and then select Enable Multiple Selection.
   Press Ctrl and click each product view you want to open in the viewer.
   
   In the 3D Load Options dialog box that appears, select Open in a new window or Merge into active window.
Working with snapshots and product views

- The option to merge is only available if the new 3D product view shares a base structure with the document that is already open.

- If you selected Merge into active window, you are asked once again to confirm the merge. Additional product structure occurrences automatically open in the active window.

- If you open product views from the same assembly one at a time, the 3D Load Options dialog box appears giving you the choice to open each product view in a new window or to merge it into the active window.

7. (Optional) From the Attachments panel do one of the following:
   - Right-click a product view and select Send To→Lifecycle Viewer.
     The product view opens in the Lifecycle Viewer.
   - Select the product view and then choose File→Open.

For more information about working with the Product View Gallery, see Working with Product Views in Teamcenter Help.

Open product views from My Teamcenter or Thin Client

You can send existing product view datasets from My Teamcenter and Thin Client to the Lifecycle Viewer and the integrated stand-alone application viewer.

Open product views from My Teamcenter

1. Select the 3D product view that you want to open.

2. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send the product view to the Lifecycle Viewer</td>
<td>Right-click the product view and select Send To→Lifecycle Viewer.</td>
</tr>
</tbody>
</table>

| Send the product view to the integrated stand-alone application viewer | Highlight the product view and do one of the following: |
| | • Choose File→Open In Lifecycle Visualization. |
| | • On the main toolbar, click Open/Start in Lifecycle Visualization. |

3. If the Product Structure dialog box appears, select one of the following:
Chapter 5  Working with snapshots and product views

<table>
<thead>
<tr>
<th>Select this option</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configured structure</td>
<td>Load the latest configured structure based on the as-saved configuration settings when the product view was last saved and apply the product view. Configured product structure is dynamic.</td>
</tr>
<tr>
<td>Static structure</td>
<td>Load the original static structure captured when the product view was last saved and apply the product view. This option makes sure the exact 3D scene is recreated.</td>
</tr>
</tbody>
</table>

Open product views from Thin Client

1. Select the product view that you want to open.
2. Click View.

   The integrated stand-alone application viewer opens and the product view is displayed.

Opening NX motion product views

You use NX to create product views that contain motion. After you save the motion product view into Teamcenter, you can open the product view in the Lifecycle Viewer or in the integrated stand-alone application viewer. You can play motion files forward or backward, jump to a specific frame, fast forward, rewind, and repeat the animation.

For more information on working with VFM motion files, see Managing motion files.

**Note** You cannot save a motion product view to Teamcenter from the Lifecycle Viewer or in the integrated stand-alone application viewer. You cannot update a product view that was saved by NX to preserve the interoperability with NX. You can, however, create a new product view after you open a motion product view.

Create a new product view

1. From a Teamcenter application that supports the Product View Gallery, create a view you want to capture in the Viewer window.

2. On the Create Markup toolbar, select Create 3D Product Views.

   Teamcenter displays the Product View Gallery window, which contains thumbnails of any previously saved product views that are associated with the selected object.
3. Click **Create a new snapshot**.

**Add a product view**

You can create a product view on a structure that you opened in the Lifecycle Viewer or in the integrated stand-alone application viewer. You can also update or create a new product view from an existing product view as long as you opened it as a dynamic structure.

1. **Send a dynamic structure to the Lifecycle Viewer or the integrated stand-alone application viewer, or send a product view and open it with dynamic structure.**

2. **From the viewer, adjust the orientation, add a markup, or make changes to the view of the model.**

3. **On the Snapshots page, right-click and select Add.**
The new product view appears on the Snapshots page.

4. Select **Save as Teamcenter Product View**.

**Update or replace a product view**

You can update or replace an existing product view that you have opened in the Lifecycle Viewer or in the integrated stand-alone application viewer.

1. Send an existing product view to the Lifecycle Viewer or in the integrated stand-alone application viewer and open it as a dynamic structure.

2. From the viewer, adjust the orientation, add a markup, or make changes to the view of the model.

3. In the Snapshots page, right-click the product view and select **Update or Replace**.

   **Note** Using **Replace** is similar to deleting and recapturing a snapshot. The 3D elements captured in the snapshot reflect the current Snapshot Preferences.

   Using **Replace** also recaptures the thumbnail image displayed in the **Snapshots** view. The name of the snapshot is retained.
Using **Update** recaptures the 3D elements that are present in the snapshot. For 3D content to be updated, the appropriate preferences must be active in the Snapshot Preferences. Only preexisting 3D elements within the snapshot are modified. 3D elements not enabled in the preferences when the snapshot was initially generated are not created.

Using **Update** also recaptures the thumbnail image displayed in the Project Workspace window **Snapshots** view.
Save product views to Teamcenter

You can update or save new dynamic product views to Teamcenter. The product view is saved as a SnapshotViewData dataset. You select the BOM line in the product structure for the location to attach the saved product view to. If you do not select a BOM line, the top node in the product structure is automatically used.

Use the following steps to save a single product view:

1. Load a configured structure in the viewer or load an existing product view.

2. Create a new product view, add an additional product view, or update an existing product view.

3. On the Snapshots page, right-click and select Save as Teamcenter Product View.
4. Do one of the following in the **New Teamcenter Product View Dataset** dialog box:
   - Accept the system name for the product view by clicking **OK**.
   - Type in a name in **Enter name for new Product View dataset** and then click **OK**.

**Save several product views to Teamcenter**

You create several different product views and you want to save them back to Teamcenter in the exact viewing state they were created in. Use the following steps to save several product views.

1. Load a configured structure in the viewer or load an existing product view.
2. Create more than one product views.
3. On the Snapshots page, highlight the first product view, then double-click.
4. On the Snapshots page, right-click and select **Save as Teamcenter Product View**.

![Context menu with Save as Teamcenter Product View highlighted](image)

5. Repeat Step 4 for each product view that you want to save in the initial viewing state.

**Example**

You open data and create three product views. The first is a circle, the second is a square, and the third is a triangle.

If you highlight the first product view, right-click and select **Save as Teamcenter Product View**, you will save the product view with the triangle (the current view) when you expected to save the product view with the circle.

If you highlight the first product view, double-click, and then right-click and select **Save as Teamcenter Product View**, you save the product view with the circle.

Highlight the product view with the square, double-click, and then right-click and select **Save as Teamcenter Product View**, you save the product view with the square.

### Capturing images and creating 3D geometry assets

You may find it useful to capture an image of your product view when working with various issues encountered in the design and manufacturing process. For publishing, creating 3D geometry assets of the product view may be beneficial. A 3D geometry asset is data that is included in illustrations and publishing. You must have Visio in order to work with 3D geometry assets.
The appearance of the captured image and 3D geometry assets is determined by you and by your site administrator. Your site administrator controls whether or not these options are available.

If these features are made available by the administrator, you can set preferences for them using the **Snapshot** tab of the **Teamcenter Integration Preferences** dialog box.

### Create product view 3D geometry assets

You can save 3D geometry assets in the Teamcenter product view dataset if 3D geometry assets are available in your environment.

**Note** Creating 3D geometry assets is only supported on Windows 32-bit operating systems.

1. Choose **File→Preferences→Teamcenter Integration Preferences**.

2. From the **Snapshot** tab of the **Teamcenter Integration Preferences** dialog box, select the **Add or Update 3D Geometry Asset** check box.

3. (Optional) Select the **Draw Outline** check box if you also want to save an outline capture in the Teamcenter product view dataset.

**Tip** One way to verify the saved 3D geometry asset is to use the Teamcenter **Named References** dialog box.

   a. Highlight the saved product view in My Teamcenter, right-click and select **Named References**.

   b. Highlight **3DGeoAsset** and click **Download**. Choose the name and location on your local file system to save the file.

   c. Open the saved .asset file in Visio 2007, or later.
Capture an image of a product view

You can save captured images in the Teamcenter dataset if image capture is available in your environment.

1. Choose File→Preferences→Teamcenter Integration Preferences.

2. From the Snapshot tab of the Teamcenter Integration Preferences dialog box, select the Image Capture check box.

3. (Optional) Select the Use Image Export Dialog check box if you want the Export Image dialog box to appear. You can use this dialog box to change the resolution, file type, or color mode of the image capture.

One way to verify the saved image capture is to use the Teamcenter Named References dialog box.

a. Highlight the saved product view in My Teamcenter, right-click and select Named References.

b. Highlight Image and click Download. Choose the name and location on your local file system to save the file.

c. Open the saved file.
Product view system constraints and preferences

You or your site administrator can use system constraints and site preferences to control the appearance and behavior of thumbnails, image captures, and 3D geometry assets.

Site preferences control the following behaviors:

<table>
<thead>
<tr>
<th>Thumbnail</th>
<th>Vis_PV_ThumbnailWidth</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Vis_PV_ThumbnailHeight</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_thumbnailQuality</td>
</tr>
<tr>
<td>Image Capture</td>
<td>Vis_PV_ImageCaptureWidth</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_ImageCaptureHeight</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_ImageCaptureType</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_ImageCaptureResolution</td>
</tr>
<tr>
<td>3D Geometry Asset</td>
<td>Vis_PV_capture3DGeomAssetAsOutline</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Thumbnail</th>
<th>Vis_PV_ThumbnailWidth</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Vis_PV_ThumbnailHeight</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_thumbnailQuality</td>
</tr>
<tr>
<td>Image Capture</td>
<td>Vis_PV_ImageCaptureWidth</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_ImageCaptureHeight</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_ImageCaptureType</td>
</tr>
<tr>
<td></td>
<td>Vis_PV_ImageCaptureResolution</td>
</tr>
</tbody>
</table>
Using 2D snapshots with Teamcenter

Teamcenter supports creating and saving several 2D snapshots over time so you can track and review changes that have been made. For example, you may want to compare various components of a design today with changes made during the manufacturing lifecycle. Teamcenter supports tracking these changes with the **2D Compare** option, which is a tool supported by several Teamcenter applications including Manufacturing Process Planner and Multi-Structure Manager. These applications also support the **Snapshot Gallery**, and snapshots must be stored in this gallery before you can use **2D Compare**.

You can send either an item revision (base document) or a previously saved snapshot (derived data) from Teamcenter to the Lifecycle Viewer. You can also open an item revision or previously saved snapshot in the Lifecycle Visualization viewer when it is integrated with Teamcenter. If the matching base document is not open, the viewer opens the base document and inserts the snapshot. The viewer immediately applies the snapshot layer to the view. When the base document is open, you may be prompted to open this document in a new window or insert it into the existing view. Teamcenter supports sending item revision and snapshot data from My Teamcenter or from the **Snapshot Gallery**.

For more information about understanding base and derived data, see **Primary and secondary visualization documents**.

Once the Teamcenter item revision or previously saved snapshot is displayed in the viewer, you add markups and then create a snapshot of a specific area of the image. You save the snapshot in Teamcenter, and it is associated with the Teamcenter item revision.

While you can send 2D snapshot item revisions from Teamcenter applications such as My Teamcenter, Manufacturing Process Planner, and Multi-Structure Manager, snapshots must be in the **Snapshot Gallery** in order to use **2D Compare** tools.
For more information about working with the Snapshot Gallery and 2D Compare, see the Teamcenter topic, Working with 2D snapshots.

For more information about specifying 2D snapshot preferences, see Overview of Teamcenter Integration Preferences.

Send Teamcenter 2D snapshots to the viewer

1. In My Teamcenter, do one of the following:

<table>
<thead>
<tr>
<th>To send a Teamcenter 2D snapshot to</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Lifecycle Viewer</td>
<td>Right-click the Teamcenter 2D snapshot or item revision and click Send To→Lifecycle Viewer.</td>
</tr>
<tr>
<td>A stand-alone viewer</td>
<td>Select a Teamcenter 2D snapshot or an item revision and do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• On the My Teamcenter toolbar, click Start/Open in Lifecycle Visualization.</td>
</tr>
<tr>
<td></td>
<td>• Choose File→Open in Lifecycle Visualization.</td>
</tr>
</tbody>
</table>

The viewer opens. If Ask at load time is turned on in the 2D Load Options, the Load Option dialog box is displayed.

**Note** If the Load Option dialog box is not displayed, the dataset is loaded according to the current Load Options settings.

2. (If the 2D Load Options dialog box is displayed) Click one of the following options:

<table>
<thead>
<tr>
<th>Use this option</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open document</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Open the document in a new window.</td>
</tr>
<tr>
<td></td>
<td>• (If the document is already open in a window) display the window.</td>
</tr>
<tr>
<td>Insert document into active window</td>
<td>Insert the document into the currently active window.</td>
</tr>
</tbody>
</table>
**Chapter 5  Working with snapshots and product views**

<table>
<thead>
<tr>
<th>Use this option</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open with markups</td>
<td>Open markups associated with the dataset.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Markup layers appear in the 2D assembly as snapshot layers. The snapshot layer is locked so you can review changes to future snapshots.</td>
</tr>
<tr>
<td>Don’t show this dialog again</td>
<td>Always use the current settings without displaying the <strong>2D Load Options</strong> dialog box.</td>
</tr>
</tbody>
</table>

For more information about sending 2D snapshots from the **Snapshot Gallery**, see *Working with 2D snapshots*.

**Create Teamcenter 2D snapshots using an item revision**

1. Select an item revision and **send it to a viewer**.
2. **Create a 2D markup** on the base image.
3. Zoom into the image or pan the image and do one of the following:
   - In the **Snapshots** view, right-click and choose **Add**.
   - On the **Snapshots** toolbar, click **Add**

   Your snapshot is added to the **Snapshots** view.

   **Note** The snapshot or snapshots that you created support features associated with standard 2D snapshot options. For example, these options include adding, inserting, deleting, and naming snapshots.

   When you save the image as a Teamcenter snapshot, the snapshot is locked and cannot be edited.

**Save Teamcenter 2D snapshots**

1. Display the item revision that includes a base image in a viewer and **add both a markup and snapshot**.

   The snapshot is displayed in the **Snapshots** view.

2. Right-click anywhere in the **Snapshots** view and select **Save as Teamcenter Snapshot**.

   The snapshot is saved to your Teamcenter server. The border is now wider than a non-Teamcenter snapshot and the snapshot is automatically named.
Working with snapshots and product views

- The Teamcenter snapshot cannot be edited and all shortcut menu options are unavailable except for Add.
- Because the snapshot is locked, you can create future snapshots to display changes to the design.

3. (Optional) If prompted, complete the revision, page, and custom attribute values in the Form Data dialog box.
   The Revision and Page values are auto-filled. Add appropriate custom data, as needed.

- Optionally, you can save the Teamcenter item revision and snapshot as a session. The session contains all data associated with this session and saves it as one file. When you open the session later, your work is restored.

How do I track design changes using Teamcenter 2D snapshots?

In the following example, the 2D image of a garage door assembly is used. The image is shipped with Teamcenter and is saved in the 2D example folder.

- This example describes how you create and save a Teamcenter snapshot, and it includes opening the item revision in Lifecycle Visualization, adding a markup, and adding a snapshot of the image. The final step is to save the snapshot back to Teamcenter.
- To realize the full benefit of comparing snapshots, use Teamcenter applications such as Manufacturing Process Planner and Multi-Structure Manager because these applications include storing snapshots in the Snapshot Gallery. When snapshots are stored in the Snapshot Gallery, the 2D Compare feature is available.
- For more information about working with the Snapshot Gallery and 2D Compare, see the Teamcenter topic, Working with 2D snapshots.

1. From My Teamcenter, highlight an item revision.
2. Choose **File→Open In Lifecycle Visualization**.

3. **Create a 2D markup.**

   In this example, a text markup is added to the image.

4. **Zoom and pan the image until you are satisfied with the section for your snapshot.**

   In this example, the area of focus is the part displayed in the following graphic.

5. **From the Snapshots toolbar, select Add.**

6. **From the Snapshots view, right-click and choose Save as a Teamcenter Snapshot.**

   When the snapshot is saved to Teamcenter, the snapshot border is wider than non-Teamcenter snapshots. This feature makes it easier to identify both Teamcenter and non-Teamcenter snapshots. Also, the snapshot is automatically given a name. You can view the name by moving your cursor over the snapshot.

---

**Note** Because the snapshot layer locks the image, the image cannot be modified. Future snapshots can then be compared to this image.
• Before you save the snapshot to Teamcenter, notice that all shortcut menu options are available.

• When you save the snapshot to Teamcenter, all shortcut menu options are unavailable except for **Add** and the name of the snapshot.
Chapter

6 Sending 4GD worksets to Lifecycle Visualization

4GD Lifecycle Visualization overview ........................................ 6-1
Replay subset recipes when loading worksets ............................... 6-1
Launch worksets into Lifecycle Visualization ............................... 6-2
Display presented parents in Lifecycle Visualization ....................... 6-3
Save a session referencing workset data ..................................... 6-3
Save worksets in session packages for offline viewing .................... 6-4
Lifecycle Visualization features supported with 4GD data ................. 6-5
Chapter

6 Sending 4GD worksets to Lifecycle Visualization

4GD Lifecycle Visualization overview

You can launch 4GD worksets into stand-alone Lifecycle Visualization or the Lifecycle Viewer for viewing and analysis. This gives you the ability to conduct design reviews using visualization features unavailable in the 3D viewer embedded in 4GD Designer, including session files and session packages. A session file enables you to save the state of your work; when you open the session file later, your work is restored. Session packages allow you to move your work to another location.

Worksets usually consist of one or more subsets, each of which is populated by the search criteria captured in the subset recipe. You can specify to replay subset recipes when loading worksets into Lifecycle Visualization. When a subset recipe is replayed, it is repopulated with the most current data. Replaying subset recipes when loading worksets adversely impacts loading performance. The extent of the performance impact depends upon the complexity of the subset recipe and the size of the collaborative design.

You can display visualization data associated with 4GD worksets as a flat list of design elements or in the context of the presented parent hierarchy.

Replay subset recipes when loading worksets

You can specify to replay subset recipes when loading worksets into Lifecycle Visualization.

1. Choose File→Preferences→Teamcenter Integration.

2. On the 3D Loader tab of the Teamcenter Integration Preferences dialog box, in the Product Structure section, select Configure an updated structure.

3. From the Update Subset on load list, select one of the following:
   - No Update
     Use this option if you want to load subsets without replaying the subset recipes.
   - Replay Recipe
     Use this option if you want to replay subset recipes before loading the data. This ensures that you obtain the latest data.
Chapter 6  Sending 4GD worksets to Lifecycle Visualization

4. Click OK.
   
   Note  When you update this preference, the changes are applicable only for data subsequently launched into Lifecycle Visualization. There is no effect on worksets currently open in the viewer.

Launch worksets into Lifecycle Visualization

You can launch 4GD worksets into the stand-alone application viewer or the embedded Lifecycle Viewer.

Note  Lifecycle Visualization supports viewing configured worksets only. You cannot open other 4GD objects, such as individual design elements or subsets.

1. Set the load option preferences for 3D files.
   
   For more information about load option preferences, see Specify load option preferences.
   
   Note  You can specify to open 4GD worksets as new documents or to insert worksets into the active Viewing window as a new model in the assembly tree. You cannot merge 4GD worksets in Lifecycle Visualization.

2. Specify how to load any subsets contained within the workset.
   
   For more information about configuring the behavior of subsets in Lifecycle Visualization, see Replay subset recipes when loading worksets.

3. To send 4GD worksets into stand-alone Lifecycle Visualization from My Teamcenter or 4GD Designer, do any of the following:
   
   • Right-click a workset and choose Start/Open in Teamcenter Visualization.
   
   • On the My Teamcenter toolbar, click Start/Open In Lifecycle Visualization.
   
   • On the 4GD Designer Content Explorer toolbar, click Start/Open In Lifecycle Visualization.
   
   Note  By default, these options are hidden.

   For information about showing the UI for sending data into the stand-alone application viewer, see Display the Start/Open in Lifecycle Visualization UI.

4. To send 4GD worksets into the Lifecycle Viewer from My Teamcenter or 4GD Designer, right-click a workset, point to Send To, and select Lifecycle Viewer.
Display presented parents in Lifecycle Visualization

You can display visualization data associated with 4GD worksets as a flat list of parts or in the context of the presented parent hierarchy.

For information about presented parents, see the 4th Generation Design Guide.

1. In the stand-alone application viewer or the Lifecycle Viewer, open and display a 4GD workset containing visualization data.

   ![4GD data displayed as a flat list]

2. Do any of the following:
   - In the Assembly view, right-click an empty area and choose Preferences. Choose Tools→Assembly→Preferences.
3. In the Assembly Preferences dialog box, select the Presented Parents check box.
4. Click OK.
5. In the assembly tree, expand the presented parents to reveal nodes for the subset’s design element members. Presented parents are represented by an icon.

   ![4GD data displayed with presented parents]

Save a session referencing workset data

When you work with 4GD worksets in stand-alone Lifecycle Visualization or the Lifecycle Viewer, you can use a session file to save the state of your work. When you open the session file later, your work is restored.

For more information about session files, see Managing Files.

1. Choose File→Save Session.
2. In the Session Save As dialog box, in the Session Storage Location section, select one of the following options:
Chapter 6  Sending 4GD worksets to Lifecycle Visualization

- **Attach to Base Document**
  
  Save the session within the workset revision.

- **Attach to selected Bomline**
  
  Save the session within the item revision of a selected BOM line in the assembly tree.

  **Note** The Attach to Selected Bomline option is unavailable for 4GD subsets and design elements.

- **Alternate location**
  
  Save the session to a different location. Click Browse, and then specify a save location.

3. Select the Capture static structure check box to capture the current state of the document structure as a PLM XML file.

  **Note** To load the PLM XML file and restore the capture document state when you open the session, you must specify Load static structure (structure at time of save) in the Teamcenter integration preferences.

4. Click Save.

**Save worksets in session packages for offline viewing**

When you launch 4GD worksets into stand-alone Lifecycle Visualization or the Lifecycle Viewer, you can save the files as a session package for offline viewing in locations without access to Teamcenter.

For more information about session packages, see Managing Files.

1. Choose File→Save Session.

2. In the Session Save As dialog box, in the Session Storage Location section, select Alternate Location.

3. Click Browse and select the folder where you want to save the file.

4. Select the Save As Session Package check box.
In the **Files** section, the **Package** column appears with a check box for each document in the session.

5. For each document that you want to include in the session package, ensure the check box is selected.

![Session Save As](image)

6. Select the **Capture static structure** check box to capture the current state of the document structure as a PLM XML file.

**Note** To load the PLM XML file and restore the capture document state when you open the session, you must specify **Load static structure (structure at time of save)** in the Teamcenter integration preferences.

7. Click **Save**.

**Lifecycle Visualization features supported with 4GD data**

The following limitations apply for the visualization of 4GD data in stand-alone Lifecycle Visualization or the Lifecycle Viewer:

- You can open full worksets only. Other 4GD objects are not supported, including design elements outside of the context of a workset, collaborative designs, and partition hierarchies.
- Individual design elements or subsets within a workset are not supported.
- Merge operations are not supported.
- You cannot attach a session file to a selected subset or design element structure line.
- Massive Model Visualization (MMV) data is not supported.
- Motion datasets are not supported.
• You can create 3D markups when visualizing 4GD worksets, but you must use session files to save the markups in Teamcenter. Individual VPL datasets are not supported in the context of worksets.

• Product views are not supported.

• Teamcenter visual issues are not supported.

• Cacheless searches are not supported with 4GD workset data. This includes Teamcenter Scoping for visual reports and the Teamcenter filtering option available on various filter types.

For information about creating visual reports using 4GD workset data, see *Create visual reports using Teamcenter structure lines.*

For information about configuring the attribute filter for client-side searches of cached Teamcenter data, see *Set attribute properties to search Teamcenter structure lines.*

• Visualization of the following advanced NX assembly operations in the context of a workset is not supported:
  
  o Assembly arrangements
  
  o Geometry and transform overrides
  
  o Promoted geometry
  
  o Overrides (geometry, position, attributes) on reused design elements within a collaborative design
Chapter 7  Working with Teamcenter visual issues

Teamcenter visual issues overview .................................................. 7-1

Configuring Teamcenter visual issues ............................................ 7-1
   Configuring the viewer to work with Teamcenter visual issues .......... 7-1
   Enable Teamcenter visual issues .............................................. 7-2
   Specify the URL of your Teamcenter issues list .......................... 7-2
   Filter the Teamcenter visual issues list ................................... 7-3

Creating Teamcenter visual issues .............................................. 7-4
   Creating Teamcenter visual issues ........................................... 7-4
   Visual issue dataset creation behavior ..................................... 7-4
   Create Teamcenter visual issues ............................................. 7-5
   Create Teamcenter visual issues from snapshots ......................... 7-6
   Create Teamcenter visual issues from clearance results ............... 7-7
   Attach visualization data to Teamcenter visual issues ................. 7-8

Reviewing Teamcenter visual issues ........................................... 7-9
   Reviewing Teamcenter visual issues overview ............................ 7-9
   Create a visual issue list in Issue Manager .............................. 7-10
   Display a list of Teamcenter visual issues in the viewer ............... 7-10
   Search for visual issues in My Teamcenter ............................... 7-11
   Open Teamcenter visual issues .............................................. 7-11
   Open Teamcenter visual issue attachments ............................... 7-12
   Teamcenter visual issue attachments ....................................... 7-13
   Edit Teamcenter visual issues .............................................. 7-14
   Delete Teamcenter visual issues in the viewer ........................... 7-15
Chapter 7  Working with Teamcenter visual issues

Teamcenter visual issues overview

You can use Teamcenter visual issues to capture and track design problems with 2D images and 3D models. Created and viewed in the stand-alone viewer or the Lifecycle Viewer, visual issues are managed in Issue Manager.

Visual issues consist of an issue report and an issue report revision, along with an automatically generated product view, 2D snapshot, or session file. When reviewers send an issue report revision to the stand-alone viewer or the Lifecycle Viewer, the visualization data associated with the issue is displayed in the same state it was in when the issue was created.

Configuring Teamcenter visual issues

Configuring the viewer to work with Teamcenter visual issues

Use the following Teamcenter preferences to configure the stand-alone viewer to work with Teamcenter visual issues:

<table>
<thead>
<tr>
<th>Use this preference</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>ManagedIssueServer</td>
<td>Enable the creation of Teamcenter visual issues. When you send visualization data from Teamcenter to the stand-alone viewer, the viewer is automatically configured to create Teamcenter visual issues. However, if you also use the Teamcenter community collaboration issue management system, you may need to set ManagedIssueServer to true for the viewer to create issues in the Teamcenter database.</td>
</tr>
<tr>
<td>ManagedIssueList</td>
<td>Specify the thin client URL of your visual issues list. When you choose Actions→Issues→View in the stand-alone viewer, the thin client launches and displays either the default list of visual issues (all issue report revisions) or a filtered list.</td>
</tr>
</tbody>
</table>
Enable Teamcenter visual issues

Set the Teamcenter ManagedIssueServer preference to true to enable Teamcenter visual issues in the stand-alone viewer.

1. In Teamcenter, choose Edit→Options.
2. Near the bottom of the Options dialog box, click Index.
   Options related to specifying preferences are displayed.
4. In Preferences List, click ManagedIssueServer.
   The Preference Details section displays the current settings for the ManagedIssueServer preference.
5. In Current Values, type true.
6. Click Modify.
   The preference is saved.
7. Click Cancel to close the Options dialog box.
8. In Teamcenter, select an item revision that includes visualization data, and then choose File→Open in Lifecycle Visualization.
   Teamcenter sends the visualization data to the stand-alone viewer. Once the data is loaded, the viewer is configured to create Teamcenter visual issues.

Specify the URL of your Teamcenter issues list

You must use the Teamcenter ManagedIssueList preference to specify the URL of your thin client. When you choose Actions→Issues→View in the stand-alone viewer, the thin client launches and displays the default list of visual issues.

1. In Teamcenter, choose Edit→Options.
2. In the Options dialog box, click Index.
4. In Preferences List, click ManagedIssueList.
   The Preference Details section displays the current settings for the ManagedIssueList preference.
5. In **Current Values**, type the thin client URL using this syntax:
   \[\text{http://<thin client URL>?TC_file=search/issuelist.html}\]
   
   **Example** \[\text{http://tcserver:7001/tc/webclient?TC_file=search/issuelist.html}\]

6. Click **Modify**.
   The preference is saved.

7. Click **Cancel** to close the **Options** dialog box.

8. In Teamcenter, select an item revision that includes visualization data, and choose **File→Open in Lifecycle Visualization**.
   Teamcenter sends the visualization data to the stand-alone viewer.

9. Choose **Actions→Issues→View**.
   The thin client displays the default visual issues list.

   **Note** The default visual issues list includes all of the issue report revisions that have been created. Alternatively, you can use a Teamcenter saved search to display only visual issues that match predefined search criteria.

**Filter the Teamcenter visual issues list**

You can use a Teamcenter saved search to filter the visual issues list according to your specified criteria.

1. In Teamcenter, choose **Window→Show View→Search**.

2. At the top of the **Search** view, click **Select a Search**.

3. In the **Change Search** dialog box, expand **System Defined Searches**, and then select **IssueReport Revision**.

4. Click **OK**.
   The issue report revision search options are displayed.

5. Construct your search by specifying criteria such as **Issue Category** and **Issue Assignee**.

   **Note** For information on creating searches in Teamcenter, see **Search techniques** in the **Rich Client Interface Guide**.

6. At the top of the **Search** view, click **Add Search to My Saved Searches**.

7. In the **Add Search to My Saved Searches** dialog box, type a name for the search, and then click **OK**.
   The search is saved.

8. Choose **Edit→Options**.

9. Near the bottom of the **Options** dialog box, click **Index**.
Options related to specifying preferences are displayed.


11. In **Preferences List**, select **ManagedIssueListQuery**.

   The **Preference Details** section displays the current settings for the **ManagedIssueList** preference.

12. In **Current Values**, type the name of the saved search.

13. Click **Modify**.

   The preference is saved. When you display the visual issues list from the stand-alone viewer, it includes only visual issues that match your predefined search criteria.

### Creating Teamcenter visual issues

Teamcenter issue reports are used to capture and manage design problems. When you create a visual issue in the Lifecycle Viewer or the stand-alone viewer, the state of the viewer is captured by a 2D snapshot, product view, or session file, which is automatically attached to the issue. When reviewers open the issue in the viewer, the associated visualization data is displayed for evaluation.

Visual issue creation involves the following tasks:

- Understand the **conditions** under which different types of visualization datasets (2D snapshots, product views, or session files) are generated and attached to visual issues.

- Create a single visual issue in the Lifecycle Viewer or the stand-alone viewer.

- Create visual issues from one or more 2D or 3D snapshots.

- Create visual issues from one or more clearance results.

- Manually attach visualization datasets to an existing issue report revision.

### Visual issue dataset creation behavior

When you create a visual issue in the Lifecycle Viewer or the stand-alone viewer, the state of the viewer is captured by a 2D snapshot, product view, or session file, which is automatically attached to the issue. The type of visualization dataset generated and associated with the visual issue varies depending upon these factors:
### This visualization dataset | Is created under these conditions
---|---
2D snapshot | A 2D image is the active document in the viewer. The image also must be associated with an item revision, or a session file is created instead of a snapshot.

| Product view | A 3D model is the active document in the viewer. In addition, the following conditions must be met:
| | • The model must be associated with an item revision.
| | • The model must be larger than a single part.
| | • The model must include configured product structure (dynamic product structure referencing Teamcenter configuration settings).
| | • The Viewing window must not include any inserted models.
| | If any of these conditions are not met, a session file is created instead of a product view.

| Session file | A 2D image or 3D model is the active document in the viewer. |

## Create Teamcenter visual issues

You can create Teamcenter visual issues in the Lifecycle Viewer or the stand-alone viewer.

1. From the Teamcenter rich client or thin client, send an item revision that includes visualization data to the Lifecycle Viewer or the stand-alone viewer.

2. Adjust the view of the image or model.

   **Tip** Any changes you make to the state of the Viewing window are preserved by the visual issue, including markups, measurements, and part or layer visibility.

3. On the Issues toolbar, click **Create and log an issue**.
   
   The **Visual Issue** dialog box appears.

4. For **Type**, choose **issue report**.

   **Note** **Issue Report** is the default issue type. Your organization may also allow you to choose from additional issue types.
Chapter 7  Working with Teamcenter visual issues

5. In Name, type a name for the issue report.

6. Depending upon your data and your settings in the Teamcenter Integration Visual Issue Preferences, the viewer may generate a 2D snapshot or product view when the issue is created. In the Visual Issue Relation section, choose one of the following Teamcenter relation types for the dataset:
   - Snapshot Before Fix
   - Snapshot After Fix
   [Note] If the Visual Issue Relation settings are inactive, the viewer generates a session file and associates it with the issue.

7. Click OK.
   The Issue Attribute Dialog appears, displaying the available attributes.

8. Double-click Synopsis to provide a name for the issue report revision.
   The Attribute Edit dialog box appears.

9. In Value, type a name for the issue report revision.

10. Double-click any of the other attributes to add information relevant to the issue.

11. Click OK.
    [Note] Depending upon the Teamcenter Integration Snapshot Preferences, you may need to specify other information for a 2D snapshot or provide a name for a product view.

    The viewer creates an issue report and an issue report revision, along with a 2D snapshot, product view, or session file.

12. If a 2D snapshot or product view cannot be created, do the following to associate a new session file with the issue:
    a. If an error message is displayed, click OK to close it.
    b. In the dialog box that asks you if you want to create a session file, click Yes.
       A session file is created and attached to the visual issue.

Create Teamcenter visual issues from snapshots

You can create Teamcenter visual issues from 2D or 3D snapshots. If you have multiple snapshots, a separate issue report is created for each selected snapshot.

1. From the Teamcenter rich client or thin client, send an item revision that includes visualization data to the Lifecycle Viewer or the stand-alone viewer.

2. Create one or more snapshots.

3. Select each snapshot from which you want to create a visual issue. For multiple selections, hold Ctrl as you click each snapshot.
Selected snapshots have a green border.


5. For Type, choose Issue Report.

   **Note** Issue Report is the default issue type. Your organization may also allow you to choose from additional issue types.

6. In Name, type a name for the issue report.

7. The viewer will generate a 2D snapshot or product view for each selected snapshot. In the Visual Issue Relation section, choose one of the following Teamcenter relation types for the datasets:

   • Snapshot Before Fix
   
   • Snapshot After Fix

8. Click OK. The Issue Attribute Dialog appears, displaying the available attributes.

9. Double-click Synopsis to provide a name for the issue report revision.

   The Attribute Edit dialog box appears.

10. In Value, type a name for the issue report revision.

11. Double-click any of the other attributes to add information relevant to the issue.

12. Click OK.

13. If you selected multiple snapshots, the Issue Attribute Dialog appears for each snapshot. Add information relevant to the issue, and click OK.

**Create Teamcenter visual issues from clearance results**

You can create Teamcenter visual issues from clearance results. A separate issue is created for each specified result.

1. From the Teamcenter rich client or thin client, open a 3D model in the Lifecycle Viewer or the stand-alone viewer.

2. Perform a clearance check.

3. In the General Clearance Results list, select one or more clearance results. For multiple selections, hold Ctrl as you click each issue.

4. Do one of the following:
Chapter 7  Working with Teamcenter visual issues

- (If posting a single issue) Right-click the clearance result and select Submit an Issue.
- (If posting multiple issues) Right-click any of the selected clearance results and select Post Issues.

The Visual Issue dialog box appears.

5. For Type, choose Issue Report.

Note: Issue Report is the default issue type. Your organization may also allow you to choose from additional issue types.

6. In Name, type a name for the issue report.

7. The viewer will generate a product view for each selected clearance result. In the Visual Issue Relation section, choose one of the following Teamcenter relation types:
   - Snapshot Before Fix
   - Snapshot After Fix

8. Click OK.

   The Issue Attribute Dialog appears, displaying the available attributes.

9. Double-click Synopsis to provide a name for the issue report revision.

   The Attribute Edit dialog box appears.

10. In Value, type a name for the issue report revision.

11. Double-click any of the other attributes to add information relevant to the issue.

12. Click OK.

   The Save As dialog box appears.

13. Type a name for the clearance results file, and click Save.

   The clearance results file is saved to the database.

14. If you are posting multiple clearance results, the Visual Issue and Issue Attribute Dialog dialog boxes are displayed again. Complete the steps described above for each issue.

   A new visual issue is created for each clearance issue selected in the General Clearance Results list.

Attach visualization data to Teamcenter visual issues

You can manually attach 2D snapshots or product views to issue report revisions.

1. Cut or copy a 2D snapshot or product view dataset.

2. Select the issue report revision.
3. Choose **Edit→Paste Special**.

4. In the **Paste Special** dialog box, choose one of the following relations:
   - **Snapshot Before Fix**
   - **Snapshot After Fix**

5. Click **OK**.

The dataset is attached to the visual issue.

**Note** When an issue report revision is launched into the Lifecycle Viewer or the stand-alone viewer, only 2D snapshots or product views in the **Snapshot Before Fix** and **Snapshot After Fix** folders, or session files in the **Reference Items** folder, are automatically opened in the viewer. All other pasted visualization data must be **manually opened**.

**Reviewing Teamcenter visual issues**

**Reviewing Teamcenter visual issues overview**

When a Teamcenter visual issue is created in the Lifecycle Viewer or the stand-alone viewer, an issue report revision is added to the database, along with an associated 2D snapshot, product view, or session file. Issue report revisions are typically accessed using issue lists in Issue Manager. You can configure issue lists to include only visual issues that match search criteria such as **Issue Category** and **Issue Assignee**.

To access your issues, you can launch Issue Manager from within the Lifecycle Viewer. You can also choose to display a list of issues from within the stand-alone viewer.

When you open a visual issue in the Lifecycle Viewer or the stand-alone viewer, the visualization dataset associated with the issue is automatically opened and displayed. You can also expand the issue report revision object from an issue list, manually select a visualization dataset, and send it to a supported viewer. You can...
open 2D snapshots, product views, and session files in the stand-alone viewer or the Lifecycle Viewer. You can also open product views in Structure Manager.

After opening a visual issue in the viewer, you can choose to update the associated visualization dataset or delete the issue report revision object from the database.

**Create a visual issue list in Issue Manager**

To access visual issues in Issue Manager, you must use an issue list. You can configure your issue list to include only issues that match specific search criteria.

1. In Issue Manager, in the **Issue Home** view, click **Manage Issue Lists**  
   The **Manage Issue Lists** dialog box appears.

2. Click **Add**.  
   A new issue list is displayed.

3. In the **Issue List Name** column, click **New Issue List**.

4. Type a name for the issue list, and press Enter.

5. Select the **Show** check box.

6. For **Assigned Search**, choose **IssueReport Revision** to create a custom search.

7. Click **Configure**.  
   The **Configure Search** dialog box is displayed.

8. Set the search options, and click **OK**.  
   The **Configure Search** dialog box closes.

9. Click **OK**.  
   The **Manage Issue Lists** dialog box closes. In the **Issue Home** view, the new issue list is displayed. Expand the issue list to access the issues matching your search criteria.

**Display a list of Teamcenter visual issues in the viewer**

You can choose to display a list of visual issues from within the stand-alone viewer.

- In the stand-alone viewer or the Lifecycle Viewer, do one of the following:
  - On the **Issues** toolbar, click **View existing issues**  
  - Choose **Actions→Issues→View**.

In the stand-alone viewer, the thin client displays the default list of visual issues. In the Lifecycle Viewer, the Issue Manager opens.

**Note** By default, the visual issues list displayed in the thin client includes all issue report revisions. You can also specify to display a list of visual issues that match predefined search criteria.
Search for visual issues in My Teamcenter

You can create and save custom search queries to access visual issues in My Teamcenter.

Create a saved search for visual issues

1. In My Teamcenter, choose Window→Show View→Search.

2. At the top of the Search view, click Select a Search.

3. In the Change Search dialog box, expand the System Defined Searches folder, and select IssueReport Revision.

4. Click OK.

   The IssueReport Revision search options are displayed.

5. Construct your search.

   In Issue ID, type IR* to display a list of every issue. To narrow the scope of the search, specify additional search options such as Issue Category and Issue Assignee.

   For information on creating searches in My Teamcenter, see Search techniques in the Rich Client Interface Guide.

6. At the top of the Search view, click Add Search to My Saved Searches.

7. In the Add Search to My Saved Searches dialog box, type a name for the search.

   The search is saved and listed in your My Saved Searches folder.

Use a saved search for visual issues

1. In My Teamcenter, at the top of the Search view, click Select a Search.

2. In the Change Search dialog box, expand the My Saved Searches folder, and select a saved search.

3. Click OK.

   The search is performed. If IssueReport Revisions matching your search query are found, they are displayed in the Search Results view.

Open Teamcenter visual issues

You can send an issue report revision, along with an associated visualization dataset, to the stand-alone viewer and the Lifecycle Viewer.

- Do any of the following:
  - To send a visual issue to the stand-alone viewer from the rich client, select the issue report revision, and choose File→Open in Lifecycle Visualization.
  - To send a visual issue to the stand-alone viewer from the thin client, select the issue report revision, and choose View→Teamcenter Visualization.
Chapter 7  Working with Teamcenter visual issues

0 (Rich Client only) To send a visual issue to the Lifecycle Viewer, right-click the issue report revision, and choose Send To—Lifecycle Viewer.

The visual issue opens in the viewer and the data is displayed in exactly the same state as it was in when the issue was created or last updated. All 2D snapshots and product views with the **Snapshot Before Fix** and **Snapshot After Fix** relations are displayed on the **Snapshots** tab of the Product Workspace window (stand-alone viewer) or the **Snapshots** view (Lifecycle Viewer). A dashed border around the thumbnail image indicates that a product view or 2D snapshot is associated with a visual issue.

![2D snapshot thumbnail in the stand-alone viewer](image)

![Product view thumbnail in the Lifecycle Viewer](image)

**Open Teamcenter visual issue attachments**

You can open Teamcenter visual issue attachments, including 2D snapshots, product views, and session files, in the stand-alone viewer or the Lifecycle Viewer. You can also open product views in Structure Manager.

1. Expand an issue report revision.

   The issue folders are displayed.

   ![Issue folders](image)

2. Expand the folders to display visualization datasets, if present.

   ![Visualization datasets](image)
For an overview of the visual issue folder structure, see Teamcenter visual issue attachments.

3. Do any of the following:
   - To send a visualization dataset to the stand-alone viewer from the rich client, select the dataset, and choose File→Open in Lifecycle Visualization.
   - To send a visualization dataset to the stand-alone viewer from the thin client, select the dataset, and choose View→Teamcenter Visualization.
   - (Rich Client only) To send a visualization dataset to the Lifecycle Viewer, right-click the dataset, and choose Send To→Lifecycle Viewer.
   - (Rich Client only) To send a product view dataset to the Structure Manager, right-click the dataset, and choose Send To→Structure Manager.

Teamcenter visual issue attachments

Depending upon your data and the Teamcenter Integration Visual Issue Preferences in the viewer, the following types of visualization data may be generated automatically when Teamcenter visual issues are created.

<table>
<thead>
<tr>
<th>Visualization dataset type</th>
<th>Visual issue folder</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product views</td>
<td>Snapshot Before Fix</td>
<td><img src="IR-000067/A1-caster3_assm/A-View" alt="Example" /></td>
</tr>
<tr>
<td></td>
<td>Snapshot After Fix</td>
<td><img src="20110304-145607" alt="Example" /></td>
</tr>
<tr>
<td>2D snapshots</td>
<td>Snapshot Before Fix</td>
<td><img src="IR-000131/A1-000014/A" alt="Example" /></td>
</tr>
<tr>
<td></td>
<td>Snapshot After Fix</td>
<td>![Example](000014/A1-Multi-sheet CGM)</td>
</tr>
</tbody>
</table>
## Edit Teamcenter visual issues

In the Lifecycle Viewer or the stand-alone viewer, you can save new snapshots to an existing Teamcenter visual issue or delete existing snapshots from the issue. You can also update a single snapshot.

1. **Open the visual issue** in the stand-alone viewer or the Lifecycle Viewer.

2. Modify the contents of the Viewing window.

3. In the **Snapshots** view (Lifecycle Viewer) or on the **Snapshots** tab (stand-alone viewer), do one of the following:

   - To save new 2D snapshots or product views to the visual issue, select the new snapshots.
   - To delete 2D snapshots or product views from the visual issue, right-click the snapshots that you want to delete, and choose **Delete**.
   - To update a single 2D snapshot or product view, select the snapshot associated with the visual issue.

   **Tip** A snapshot associated with a visual issue has a dashed border.

4. Do one of the following:

   - On the **Issues** toolbar, click **Update existing issue**.
   - Choose **Actions**→**Issues**→**Update Existing**.
Delete Teamcenter visual issues in the viewer

You can delete Teamcenter visual issues directly in the stand-alone viewer or the Lifecycle Viewer.

1. **Open the visual issue** in the stand-alone viewer or the Lifecycle Viewer.

2. Do one of the following:
   - On the Issues toolbar, click **Delete this issue**.
   - Choose **Actions→Issues→Delete**.

The issue report and issue report revision are deleted.
Chapter

8 Working with JtSimplification data

JtSimplification data overview ........................................ 8-1
Using JtSimplification data with other features .................... 8-2
Resolve and fully load JtSimplification data .......................... 8-3
Chapter

8 Working with JtSimplification data

JtSimplification data overview

Complex JT models accessed remotely from Teamcenter often suffer from long loading times because of the size and complexity of their data. JtSimplification datasets solve this problem by providing simplified data for each of a model's subassemblies. When you open a JtSimplification dataset and turn on the root node of the model, the simplified data is automatically loaded and displayed, which enables you to view the entire 3D model much more quickly than is otherwise possible with a standard JT file. If you choose to explore the model in greater detail, the full data for each subassembly level is loaded incrementally as the structure is expanded in the assembly tree or in the viewing window.

JtSimplification datasets are created using the Simpgen translator, which is included with the Teamcenter Dispatcher system. Administrators can schedule JtSimplification production from the My Teamcenter Translation menu.

JtSimplification data is used automatically when you send the assembly into the viewer and turn on the root node. Since the geometry from a standard JT subassembly and a simplified subassembly looks the same in the viewing window, a gray icon is used to represent subassemblies that consist of simplified geometry.
JtSimplification data requires an additional license and is supported only in the stand-alone viewers and the Lifecycle Viewer within the Teamcenter Rich Client. If you do not have a license for the JtSimplification functionality or if you load a JtSimplification dataset in an unsupported viewer, the full model loads as standard JT data.

You can use the `TCVIS_ALSG_ENABLED` environment variable to disable support for the viewing of JtSimplification datasets in the Lifecycle Viewer and the stand-alone viewers. By default, this variable is not set and JtSimplification is automatically enabled in properly licensed viewers. Set this variable to `False` if you want to disable the functionality.

### Using JtSimplification data with other features

When you load a JtSimplification dataset, the Viewing window displays simplified data for each of the model's subassemblies, which may lead to unexpected results when you perform certain actions within the viewer. The table below lists features that may exhibit non-standard behavior when used with JtSimplification data.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Behavior with JtSimplification data</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D file export</td>
<td>If you export a JtSimplification dataset, subassembly nodes that contain JtSimplification data are not included in the exported model.</td>
</tr>
<tr>
<td>Snapshots</td>
<td>When you capture a snapshot with a JtSimplification dataset, the simplified data is not resolved and the snapshot image is produced from the simplified geometry. <strong>Tip</strong> You can apply a snapshot that captured simplified geometry even after the geometry is resolved.</td>
</tr>
<tr>
<td>Session save</td>
<td>When you save a session file with the <strong>Capture static structure</strong> check box selected in the <strong>Session Save As</strong> dialog box, all of the JtSimplification geometry is resolved as part of the saved session. Otherwise, the state of unresolved simplified geometry is maintained.</td>
</tr>
<tr>
<td>Part or assembly properties</td>
<td>When you right-click a part or assembly and select <strong>Properties</strong>, the JtSimplification data is not resolved and the displayed geometric properties are computed from the simplified geometry.</td>
</tr>
</tbody>
</table>

To avoid any of the limitations described below, resolve the simplified data to fully load the assembly information and geometry.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Behavior with JtSimplification data</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D measurement</td>
<td>When you perform 3D measurements on JtSimplification datasets, the simplified geometry is not automatically resolved.</td>
</tr>
<tr>
<td>Clearance</td>
<td>When you perform clearance analysis with JtSimplification datasets, the simplified geometry is not automatically resolved.</td>
</tr>
<tr>
<td>Part Edit</td>
<td>If you perform any Part Edit operation, all JtSimplification geometry is automatically resolved and all of the parts are loaded.</td>
</tr>
<tr>
<td>Cross section</td>
<td>If you perform any cross section operation, all JtSimplification geometry is automatically resolved and all of the parts are loaded.</td>
</tr>
<tr>
<td>Show edges</td>
<td>If you right-click a subassembly and select Show Edges, the JtSimplification geometry of the selected subassembly is automatically resolved.</td>
</tr>
<tr>
<td>Outline capture</td>
<td>If you perform an outline capture on a JtSimplification dataset, the simplified geometry is used to create the outline capture.</td>
</tr>
<tr>
<td>Concept appearance edit</td>
<td>If you perform any Concept appearance edit operation, all JtSimplification geometry is resolved and all the parts are loaded.</td>
</tr>
<tr>
<td>True Shading</td>
<td>If you apply occurrence specific materials to simplified geometry, the affected subassembly is resolved and fully loaded. Also, global wash and metallic material finishes may not display as expected.</td>
</tr>
<tr>
<td>PLM XML save</td>
<td>When you save a JtSimplification dataset as PLM XML, all JtSimplification geometry is automatically resolved and all the parts are loaded.</td>
</tr>
</tbody>
</table>

**Resolve and fully load JtSimplification data**

When you open a JtSimplification dataset and turn on the root node of the model, the simplified data is automatically loaded and displayed. If you want to view the contents of a subassembly in more detail, you can manually expand the simplified structure to fully load the assembly information and geometry.

- Do any of the following:
**Chapter 8  Working with JtSimplification data**

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resolve all of the simplified data within the model</td>
<td>0  In the assembly tree, right-click the root node of the model and select <strong>Resolve All.</strong></td>
</tr>
</tbody>
</table>
| Resolve the next level of simplified data within a single subassembly | 0  In the assembly tree, click the plus sign to the left of the subassembly node.  
   -or-  
   In the assembly tree, right-click the subassembly node and select **Resolve.**  
   -or-  
   In the Viewing window, right-click geometry within the subassembly and select **Resolve.** |
Chapter

9 Using ClearanceDB with Teamcenter

Using ClearanceDB with Teamcenter ........................................... 9-1
Product and system requirements ................................................. 9-2
Steps to analyze manage products ................................................ 9-2

Configuring ClearanceDB to work with Teamcenter ......................... 9-3
  Teamcenter global configuration options .................................... 9-3
  Specify to use absolute occurrence IDs ...................................... 9-9
  Configure the Clearance.cfgproduct file .................................... 9-10
  Configuring ClearanceDB for multifield key data ......................... 9-10
  Understanding clearance variant analysis .................................. 9-11
  Enable variant analysis for clearance ....................................... 9-13
  Caching managed data for analysis ......................................... 9-15

Analyzing managed ClearanceDB products .................................... 9-19
  Analyze a managed product ...................................................... 9-19
  Example output from managed analysis ...................................... 9-20
  View results in the Lifecycle Viewer and Structure Manager .............. 9-22

Working with DesignContext ....................................................... 9-23
  DesignContext clearance analysis modes ................................... 9-24
  Specify connection information for DesignContext ....................... 9-26
  Specify to create an SCO for clearance results ............................. 9-26
  Display additional clearance results information .......................... 9-27
  Load ClearanceDB results in DesignContext .................................. 9-27
  Performing real-time analysis ................................................... 9-28
  Open clearance results in an SCO ............................................ 9-28
Chapter

9 Using ClearanceDB with Teamcenter

Using ClearanceDB with Teamcenter

You can perform ClearanceDB analysis on product data stored in Teamcenter. Analysis of managed product data is performed via the `analyze_managed_product.pl` script, which launches the processes that evaluate the data and then automatically uploads the results to the ClearanceDB database.

ClearanceDB offers a number of options for working with Teamcenter, including:

- Analyze the data associated with BOM lines on a product-by-product basis.
- Perform a single clearance variant analysis that excludes all non-buildable part pairs from a 150% BOM line.
- Work with DesignContext to identify a series of target parts and then quickly find other relevant data within a given proximity to those parts.

You can evaluate ClearanceDB results in stand-alone Mockup, the Teamcenter Lifecycle Viewer, Structure Manager, and DesignContext.
Product and system requirements

The ClearanceDB integration with Teamcenter has the following requirements:

- A properly configured and functioning ClearanceDB software environment, including the ClearanceDB Server, Proxy, and Client tiers.
- A Teamcenter 8.x, 9.x, or 10.x server.
- An FMS file client cache (FCC).
- A Teamcenter user account with system administrator privileges.
- A Mockup license in the rich client to view results in the Lifecycle Viewer or Structure Manager, or DesignContext with the Repeatable Digital Validation (RDV) component.
- Product data in the JT or PLM XML format within an item revision on the Teamcenter server.
- Absolute occurrence IDs for all BOM lines to be analyzed.

Steps to analyze manage products

The following process describes the tasks needed to analyze a Teamcenter item revision in ClearanceDB:

1. Ensure that your environment meets the requirements for performing ClearanceDB analysis on data from Teamcenter.

2. Create a ClearanceDB product, following the procedures located in the ClearanceDB Administration Guide. This includes the following:
   - The product configuration, which is required.
   - Rules, at least one of which is required.
   - Conditions, which are optional.
   - Zones, which are optional.

   **Note** The name of the product must be the same as the top-level node in the assembly. Send the item revision containing the product data to Structure Manager to obtain the name of the top level assembly node, which is displayed in the **BOM Line** column.

   If you are working within a Teamcenter multifield key environment, see Configuring ClearanceDB for multifield key data.

3. Update the global configuration options for working with Teamcenter data.

4. Specify for ClearanceDB to use absolute occurrence IDs.

5. Specify the item and revision IDs for the top level assembly of your product.

7. If you want to perform analysis using Teamcenter variant conditions, enable variant analysis for clearance.

8. If you want to cache the product data on your locale machine to improve the performance of the analysis, adjust the load_fcccache options.

9. Use the analyze_managed_product.pl script to perform analysis on the managed product and merge the results with the database.

Configuring ClearanceDB to work with Teamcenter

Teamcenter global configuration options

You must update the Clearance.cfgglobal file to match your Teamcenter environment.

1. Using a text editor, open the Clearance.cfgglobal file.

2. Change any of the following settings in the Section 1: Teamcenter Configuration section of the file to configure ClearanceDB to work with Teamcenter:

   **TC_ROOT**
   Specifies the Teamcenter root directory.

   **TC_DATA**
   Specifies the Teamcenter TC_DATA directory.

   **TeamcenterUserId**
   Specifies a Teamcenter user name with Teamcenter system administration privileges. If no user name is provided, ClearanceDB uses the operating system user name.

   **TeamcenterUserPassword**
   Specifies the password associated with the specified Teamcenter user.

   **TeamcenterUserGroupId**
   Specifies the Teamcenter group ID. If no group ID is provided, ClearanceDB uses the default group of the specified Teamcenter user.

   **RevisionRule**
   Specifies the revision rule for the product's top level product structure node.

   **Note** This is the same option as the `bomwriter -u=` command line argument.

   **Note** This is the same option as the `bomwriter -p=` command line argument.

   **Note** This is the same option as the `bomwriter -g=` command line argument.
This is the same option as the **bomwriter -revision_rule** command line argument.

**SavedVariantRule**
Specifies the saved variant configuration to pass to the **bomwriter**.

**LexicographicalVariantAnalysis**
Defines the mode of the evaluation of variant condition relational expressions. Choose one of the following:

- **No** — If undeterminable variant conditions exist, the affected variant inferences are asked from the server. This is the default.
- **Yes** — If undeterminable variant conditions exist, evaluate them lexicographically.

**Note**  Variant conditions that cannot be evaluated based on textual representations are undeterminable.

**VariantAnalysisClientTraceFile**
Specifies the name for the log file of the variant analysis. By default, this is not set, and a log file is not generated.

**Example**  
```
VariantAnalysisClientTraceFile=cldb_variant_analysis.log
```

**VariantAnalysisClientTraceFlags**
Specified the content of the log file of the variant analysis. The trace flags are additive, concatenated with the plus (+) character.

**Example**  
```
VariantAnalysisClientTraceFlags=CONFIGURATION+STATISTICS
```

Add any of the following flags:

- **CONFIGURATION**
  Lists the variant analysis configuration attributes.

- **STATISTICS**
  Provides the basic variant analysis statistics.

- **VARIANTCONDITIONS**
  Provides details of textual variant conditions.

- **DETERMINABILITY**
  Lists the determinability of variant conditions.

- **SATISFIABILITY**
  Lists the satisfiability of variant conditions.

- **EXCLUDEDVCPAIRS**
  Lists excluded variant condition pairs.

- **EXCLUDEDUIDPAIRS**
  Lists excluded clearance element pairs as ABSOCCs.

- **EXCLUDEDNGIDPAIRS**
  Lists excluded clearance element pairs as NGIDs.

- **IMPACT**
  Lists the impact of variant conditions on the product structure.
Caution Enabling the \texttt{EXCLUDEDUIDPAIRS} and \texttt{EXCLUDEDNGIDPAIRS} trace flags may result in extremely large log files.

**VariantLogicalExpression**
Defines the variant condition \texttt{UserValue} title and \texttt{BOM line} property pair in the PLM XML file. This has the form of:

- "Variant Condition":\texttt{bl\_variant\_condition}
- "Variant Formula":\texttt{bl\_formula}

**Example**

```
VariantLogicalExpression="VC:bl\_variant\_condition"
```

**Note**
This must match the content of the \texttt{BomWriterUserAttributes} setting.

**RunLevel**
Specifies the actions of the \texttt{analyze\_managed\_product.pl} script. Use a value from 1 to 6.

1 — In the product directory, a .vvi file is created, which is used by the \texttt{bomwriter} to generate a .plmxml file referencing the managed data.
2 — Using the .vvi and .plmxml files in the product directory, the Clearance Calculator performs analysis upon the managed product data and generates a results file.
3 — The results file is uploaded to the ClearanceDB database.
4 — Both the RunLevel 1 and 2 actions are performed.
5 — Both the RunLevel 2 and 3 actions are performed.
6 — All of the RunLevel actions are performed, 1, 2, and 3.

**BomWriterUserAttributes**
Specifies the variant conditions for the \texttt{bomwriter} to include in the generated .plmxml file. Type these according to the following syntax:

```
target:Instance,key:myAttribute,literal:`\"My Attribute Value\"`
```

**Note**
This is the same option as the \texttt{bomwriter -ua=} command line argument.

**Example**

```
BomWriterUserAttributes=target:Instance,key: VC,prop: bl\_variant\_condition
```

**TeamcenterWebServerPath**
Specifies the Teamcenter web server path, including the protocol, host name, and port number. Type this according to the following syntax:

**TeamcenterWebServerPath=http://machine\_name:port**

**Example**

```
```
JtDataStagingProcess
Specifies to use the Teamcenter load_fcccache utility to download the model data from the Teamcenter server to the local system for clearance analysis. Enabling this option pre-populates the FMS client cache (FCC), which leads to faster and more reliable analysis.

Valid values are 0 (off) or 1 (on). The default value is 0.

JtDataStagingProcessErrorLimit
Specifies when to abort the analyze_managed_product.pl script, based on the following custom error codes:

FILECOPY_FAILED
INVALID_DAKID_FORMAT
FCC_OPENFILE_FAILED
FCC_DOWNLOAD_FAILED
GET_READ_TICKET_FAILED
DATASET_READ_FAILED
PLMXML_MISSING_JT
CHMOD_FAILED
COPYOUT_CLEANUP_FAILED

You can specify a numerical value for each error code. By default, the error codes are given values that correspond to the severity of the problem, with the lowest value representing the most severe failure. If a value is not specified for the JtDataStagingProcessErrorLimit setting, the script stops whenever an error occurs during the staging process.

The default value is 30.

Note The default values are recommended for the JtDataStagingProcessErrorLimit setting and the related error codes. Essentially, with these defaults the clearance analysis will abort when any of these errors occur, and you can use the reported error message to troubleshoot the problem.

FILECOPY_FAILED
Specifies the error code that indicates a copy operation to the output directory has failed.

The default value is 20.

INVALID_DAKID_FORMAT
Specifies the error code that indicates an invalid DAKID was found.

The default value is 21.

FCC_OPENFILE_FAILED
Specifies the error code that indicates the FCC failed to open the file using the ticket.

The default value is 22.

FCC_DOWNLOAD_FAILED
Specifies the error code that indicates a failure most likely due to a missing file in the volume.
The default value is 23.

**GET_READ_TICKET_FAILED**
Specifies the error code that indicates a read ticket failed.
The default value is 24.

**DATASET_READ_FAILED**
Specifies the error code that indicates no read access on the dataset.
The default value is 25.

**PLMXML_MISSING_JT**
Specifies the error code that indicates a missing JT file reference in the .plmxml file.
The default value is 26.

**CHMOD_FAILED**
Specifies the error code that indicates a failure to set the access mode during copy out.
The default value is 27.

**COPYOUT_CLEANUP_FAILED**
Specifies the error code that indicates a failure to remove a file during lifetime cleanup.
The default value is 28.

**CopyOutLocation**
Specifies the location for the dataset files downloaded from Teamcenter server.
The default location is the product directory in the ClearanceDB Work Area.

**Note** Do not use special characters in folder names.

**BucketCount**
Specifies how many directories to use for the cached files. Spreading the files over multiple directories can lead to better performance.
The default value is 30.

**UseAbsoluteLocation**
Specifies to use an absolute value for the location attribute in the .plmxml file generated by the bomwriter. It is usually better to have a relative reference, although there are instances where an absolute reference is required, such as when the .plmxml file is moved to a different location from the referenced files.
The default value is No.

**DirAccessMode**
Specifies the access mode setting for the directories created to hold the cached files. Use a chmod octal value. This setting is used only on UNIX and Linux systems.
The default value is 0640.
 FileAccessMode
  Specifies the access mode setting for the cached files. Use a chmod octal value. This setting is used only on UNIX and Linux systems.
  
  The default value is 0640.

BucketPrefix
  Specifies a prefix to add to the names of directories created to hold the cached files.
  
  The default value is RW.

FilenamePrefix
  Specifies a prefix to add to the names of the cached files.
  
  The default value is fmsr_.

CopyOutLifetime
  Specifies the lifetime of the files cached in the StagingProcessDownloads directory. The directory is scanned for files older than the specified value, which are removed. The lifetime value is specified in seconds, where one day is equal to 86400 seconds and two weeks is equal to 1209600 seconds.
  
  The default value is 1209600 (two weeks).

  Note  This option requires the FilenamePrefix option to be set since it uses the prefix as validation of ownership to prevent the accidental removal of files.

LifetimeCheck
  Specifies to scan the StagingProcessDownloads directory for files older than the CopyOutLifetime value.
  
  Valid values are 0 (off) or 1 (on). The default value is 0.

LifetimeCheckInterval
  Specifies how often to scan the StagingProcessDownloads directory for files older than the CopyOutLifetime value. If the directory holds many files and it is not important to check the lifetime each time the analyze_managed_product.pl script is run, you can improve performance by increasing the value so the check is made less frequently. If the specified value is 10, the lifetime check occur once over the course of 10 script executions.
  
  The default value is 10.

LifetimeProcessLimit
  Specifies the maximum number of seconds the file lifetime check is allowed to continue. The lifetime check randomly examines cached files. If the StagingProcessDownloads directory consists of many files, this option has the effect of randomly processing a subset of files each time the lifetime check takes place. Over time, all of the files are examined.
  
  The default value is 300.

LogTypes
  Specifies the type of logging to be reported. The following are valid log types:
NONE
ERROR
WARNING
INFORMATION
DEBUG
PERFORMANCE
ALL

Note Use the + sign to use multiple log types. For example, ERROR+WARNING.

**RulesObject = Requirement Rules from ClearanceDB Server**
Specify to perform analysis using the product’s rules and conditions from the ClearanceDB database. To enable this option, remove the number sign symbol (#) that precedes the RulesObject = Requirement Rules from ClearanceDB Server line.

**RulesObject = Variant Analysis**
Specify to perform analysis using Teamcenter variant conditions. To enable this option, remove the number sign symbol (#) that precedes the RulesObject = Variant Analysis line.

**ResultsObject = ClearanceDB Results**
Specify to generate a ClearanceDB results file (ClearanceResultsDbUpload.csvcldb). To enable this option, remove the number sign symbol (#) that precedes the ResultsObject = ClearanceDB Results line.

**Attribute=__PLM_ABSOCC_UID, Part and Parents (Part First)**
Specify to use product structure absolute occurrences. To enable this option, remove the number sign symbol (#) that precedes the Attribute=__PLM_ABSOCC_UID,Part and Parents (Part First) line.

3. Save the file.

**Specify to use absolute occurrence IDs**
For ClearanceDB to work with data from Teamcenter, an absolute occurrence ID is required for each product structure node of the BOM line to be analyzed.

1. Enable absolute occurrence IDs in the global configuration options (specified in the Clearance.cfgglobal file) by removing the number sign symbol (#) that precedes the Attribute=__PLM_ABSOCC_UID,Part and Parents (Part First) line.

2. Add the following entry to the process configuration (specified in the configuration.csvcldb file) for each product:
Configure the Clearance.cfgproduct file

For the Clearance Calculator to analyze Teamcenter managed data, you must specify the item ID and revision of the top level assembly of your product. If your Teamcenter data is configured with multifield key data, you must specify the item key.

1. Use a text editor, open the Clearance.cfgproduct file for the product and provide the following information:

   **ItemKey**
   Specifies the Teamcenter values of the multifield key properties for the item containing your product.

   **Note**  
   This setting is applicable only to Teamcenter products configured with multifield key data. It corresponds to the –key argument for the Teamcenter bomwriter utility.

   You can obtain the necessary multifield key strings with the Teamcenter get_key_string utility.

   **ItemId**
   Specifies the Teamcenter item ID of the top level assembly of your product.

   **ItemRevision**
   Specifies the Teamcenter revision of the top level assembly of your product.

2. Save the file.

Configuring ClearanceDB for multifield key data

Multifield keys are identifiers assigned to objects to ensure their uniqueness in the database. For example, if the item business object type is configured to use multifield keys, it is possible to have two item objects with the same item ID.

For ClearanceDB to analyze Teamcenter data configured with multifield key data, you must do the following:

- When running the create_product.pl script to create the product in the ClearanceDB database, append the __PLM_ITEMREV_UID for the item revision to the product name.

  To find the UID for an item revision, open the item revision in Structure Manager, and view the bl_rev_fnd0objectld property. Include this value within brackets after the (View) suffix, enclosing the entire product name in quotation marks, as shown below:

  **Example**  
  “000092/A;1-cottonpicker (View) [4BYKHkIYy_loP]”

- When configuring the clearance.cfgproduct file for the product, populate the ItemKey parameter with the multifield key properties of the item. This setting corresponds to the –key argument for the Teamcenter bomwriter utility.

  To obtain the key information, use the Teamcenter get_key_string utility.
Understanding clearance variant analysis

Clearance variant analysis is based on product variant information stored in Teamcenter. Analysis is performed on a 150% BOM structure, which is the union of all of the structure of a product without respect to buildable combinations. Non-buildable combinations of product structure are detected and excluded from the clearance analysis.

The benefits of removing non-buildable occurrence relationships from ClearanceDB analysis include the following:

- A reduction in clearance calculations
- Overall faster clearance analysis
- Fewer clearance incidents for engineers and designers to evaluate
A simple example with variant conditions (150% BOM with variants)

Using variant analysis, a single 150% BOM can contain all buildable product combinations. This enables you to perform a single clearance analysis, which excludes all non-buildable part pairs.

With no variants, all nodes are analyzed (15 part pairs).
No nodes are excluded.

With the E=V6 variant, nodes 1, 2, 3, and 4 are analyzed (6 part pairs).
Nodes 5 and 6 are excluded (9 part pairs).

With the E=V8 variant, nodes 1, 2, 5, and 6 are analyzed (6 part pairs).
Nodes 3 and 4 are excluded (9 part pairs).
A simple example without variant conditions (separate 100% BOMs)

Without using variant analysis, you must create and manage separate 100% BOMs to represent each buildable product combination. You must evaluate each BOM with a separate clearance analysis.

For the analysis of the V6 Engine, without variant conditions, nodes 1, 2, 3, and 4 are analyzed (6 part pairs).

No nodes are excluded.

For the analysis of the V8 Engine, without variant conditions, nodes 1, 2, 5, and 6 are analyzed (6 part pairs).

No nodes are excluded.

For more information about working with Teamcenter variant conditions, see Getting Started with Product Structure in the Teamcenter online Help collection.

Enable variant analysis for clearance

You must enable the option to evaluate ClearanceDB products according to Teamcenter variant conditions.

1. Using a text editor, open Clearance.cfgglobal and adjust the following settings:

   **Note** You can also specify these options in the Clearance.cfgproduct file for the product.

   **LexicographicalVariantAnalysis**
   Defines the mode of the evaluation of variant condition relational expressions. Choose one of the following:

   **No** — If undeterminable variant conditions exist, the affected variant inferences are asked from the server. This is the default.
Yes — If undeterminable variant conditions exist, evaluate them lexicographically.

**Note** Variant conditions that cannot be evaluated based on textual representations are undeterminable.

**VariantAnalysisClientTraceFile**
Specifies the name for the log file of the variant analysis. By default, this is not set, and a log file is not generated.

**Example** 
VariantAnalysisClientTraceFile=cldb_variant_analysis.log

**VariantAnalysisClientTraceFlags**
Specified the content of the log file of the variant analysis. The trace flags are additive, concatenated with the plus (+) character.

**Example** 
VariantAnalysisClientTraceFlags=CONFIGURATION+STATISTICS

Add any of the following flags:

- **CONFIGURATION** Lists the variant analysis configuration attributes.
- **STATISTICS** Provides the basic variant analysis statistics.
- **VARIANTCONDITIONS** Provides details of textual variant conditions.
- **DETERMINABILITY** Lists the determinability of variant conditions.
- **SATISFIABILITY** Lists the satisfiability of variant conditions.
- **EXCLUDEDVCPAIRS** Lists excluded variant condition pairs.
- **EXCLUDEDUIDPAIRS** Lists excluded clearance element pairs as ABSOCCs.
- **EXCLUDEDNGIDPAIRS** Lists excluded clearance element pairs as NGIDs.
- **IMPACT** Lists the impact of variant conditions on the product structure.

**Caution** Enabling the **EXCLUDEDUIDPAIRS** and **EXCLUDEDNGIDPAIRS** trace flags may result in extremely large log files.

**VariantLogicalExpression**
Define the variant condition UserValue title and BOM line property pair in the PLM XML file. This has the form of:

“Variant Condition”:bl_variant_condition

“Variant Formula”:bl_formula

**Example** 
VariantLogicalExpression="VC-V6:bl_variant_condition"
Using ClearanceDB with Teamcenter

Note This must match the content of the BomWriterUserAttributes setting.

BomWriterUserAttributes
Specify the variant conditions for the bomwriter to include in the generated .plmxml file. Type these according to the following syntax:

\texttt{target:Instance, key:myAttribute, literal: \"My Attribute Value\"}

Note This is the same option as the bomwriter -ua= command line argument.

Example Use this option to include variant model related BOM line properties in the generated .plmxml file. For example:

BomWriterUserAttributes=target:Instance, key: VC-V6, prop: bl_variant_condition

RulesObject = Variant Analysis
Specify to perform analysis using Teamcenter variant conditions. To enable this option, remove the number sign symbol (#) that precedes the RulesObject = Variant Analysis line.

2. Save the file.

Caching managed data for analysis
You can configure ClearanceDB to use the load_fcccache utility to download and cache model data from the Teamcenter server to your local machine, improving both the reliability and performance of the analysis. Options to control the load_fcccache utility are located in the Clearance.cfgglobal file.

Note For most of these settings the default values are recommended and they should not be modified unless you understand how the changes will affect the data staging process. Exceptions include

- \texttt{JtDataStagingProcess} — By default the load_fcccache option is disabled and you must change this setting to enable it.

- \texttt{CopyOutLocation} — This setting specifies where to copy the files cached from Teamcenter.

- \texttt{LogTypes} — This setting controls the content of the log files.

For more information on the Teamcenter File Management System (FMS), see the System Administration Guide in the Teamcenter documentation.

1. Using a text editor, open Clearance.cfgglobal and adjust the following settings:

JtDataStagingProcess
Specifies to use the Teamcenter load_fcccache utility to download the model data from the Teamcenter server to the local system for clearance analysis. Enabling this option pre-populates the FMS client cache (FCC), which leads to faster and more reliable analysis.
Valid values are 0 (off) or 1 (on). The default value is 0.

**JtDataStagingProcessErrorLimit**

Specifies when to abort the `analyze_managed_product.pl` script, based on the following custom error codes:

- `FILECOPY_FAILED`
- `INVALID_DAKID_FORMAT`
- `FCC_OPENFILE_FAILED`
- `FCC_DOWNLOAD_FAILED`
- `GET_READ_TICKET_FAILED`
- `DATASET_READ_FAILED`
- `PLMXML_MISSING_JT`
- `CHMOD_FAILED`
- `COPYOUT_CLEANUP_FAILED`

You can specify a numerical value for each error code. By default, the error codes are given values that correspond to the severity of the problem, with the lowest value representing the most severe failure. If a value is not specified for the `JtDataStagingProcessErrorLimit` setting, the script stops whenever an error occurs during the staging process.

The default value is 30.

**Note**

The default values are recommended for the `JtDataStagingProcessErrorLimit` setting and the related error codes. Essentially, with these defaults the clearance analysis will abort when any of these errors occur, and you can use the reported error message to troubleshoot the problem.

**FILECOPY_FAILED**

Specifies the error code that indicates a copy operation to the output directory has failed.

The default value is 20.

**INVALID_DAKID_FORMAT**

Specifies the error code that indicates an invalid DAKID was found.

The default value is 21.

**FCC_OPENFILE_FAILED**

Specifies the error code that indicates the FCC failed to open the file using the ticket.

The default value is 22.

**FCC_DOWNLOAD_FAILED**

Specifies the error code that indicates a failure most likely due to a missing file in the volume.

The default value is 23.

**GET_READ_TICKET_FAILED**

Specifies the error code that indicates a read ticket failed.

The default value is 24.
**DATASET_READ_FAILED**
Specifies the error code that indicates no read access on the dataset.
The default value is 25.

**PLMXML_MISSING_JT**
Specifies the error code that indicates a missing JT file reference in the .plmxml file.
The default value is 26.

**CHMOD_FAILED**
Specifies the error code that indicates a failure to set the access mode during copy out.
The default value is 27.

**COPYOUT_CLEANUP_FAILED**
Specifies the error code that indicates a failure to remove a file during lifetime cleanup.
The default value is 28.

**CopyOutLocation**
Specifies the location for the dataset files downloaded from Teamcenter server.
The default location is the product directory in the ClearanceDB Work Area.

**Note** Do not use special characters in folder names.

**BucketCount**
Specifies how many directories to use for the cached files. Spreading the files over multiple directories can lead to better performance.
The default value is 30.

**UseAbsoluteLocation**
Specifies to use an absolute value for the location attribute in the .plmxml file generated by the bomwriter. It is usually better to have a relative reference, although there are instances where an absolute reference is required, such as when the .plmxml file is moved to a different location from the referenced files.
The default value is **No**.

**DirAccessMode**
Specifies the access mode setting for the directories created to hold the cached files. Use a chmod octal value. This setting is used only on UNIX and Linux systems.
The default value is **0640**.

**FileAccessMode**
Specifies the access mode setting for the cached files. Use a chmod octal value. This setting is used only on UNIX and Linux systems.
The default value is **0640**.
**BucketPrefix**
Specifies a prefix to add to the names of directories created to hold the cached files.

The default value is **RW**.

**FilenamePrefix**
Specifies a prefix to add to the names of the cached files.

The default value is **fmsr_**.

**CopyOutLifetime**
Specifies the lifetime of the files cached in the *StagingProcessDownloads* directory. The directory is scanned for files older than the specified value, which are removed. The lifetime value is specified in seconds, where one day is equal to 86400 seconds and two weeks is equal to 1209600 seconds.

The default value is **1209600** (two weeks).

**Note** This option requires the **FilenamePrefix** option to be set since it uses the prefix as validation of ownership to prevent the accidental removal of files.

**LifetimeCheck**
Specifies to scan the *StagingProcessDownloads* directory for files older than the **CopyOutLifetime** value.

Valid values are 0 (off) or 1 (on). The default value is 0.

**LifetimeCheckInterval**
Specifies how often to scan the *StagingProcessDownloads* directory for files older than the **CopyOutLifetime** value. If the directory holds many files and it is not important to check the lifetime each time the *analyze_managed_product.pl* script is run, you can improve performance by increasing the value so the check is made less frequently. If the specified value is 10, the lifetime check occur once over the course of 10 script executions.

The default value is **10**.

**LifetimeProcessLimit**
Specifies the maximum number of seconds the file lifetime check is allowed to continue. The lifetime check randomly examines cached files. If the *StagingProcessDownloads* directory consists of many files, this option has the effect of randomly processing a subset of files each time the lifetime check takes place. Over time, all of the files are examined.

The default value is **300**.

**LogTypes**
Specifies the type of logging to be reported. The following are valid log types:

- **NONE**
- **ERROR**
- **WARNING**
INFORMATION
DEBUG
PERFORMANCE
ALL

Note Use the + sign to use multiple log types. For example, ERROR+WARNING.

2. Save the file.

Analyzing managed ClearanceDB products

Analysis of managed products is performed via the analyze_managed_product.pl script, which triggers the following events in sequence:

1. The bomwriter utility generates a .plmxml file referencing the Teamcenter product data.

2. The load_fcccache utility downloads the product data to your local machine. A second .plmxml file referencing the cached data is generated.

3. The Clearance Calculator analyzes the cached data according to a ClearanceDB product configuration (defined in the configuration.csvcldb file, together with any specified rules, conditions, and zones). ClearanceDB results are generated and uploaded to the ClearanceDB database.

Analyze a managed product

Take the following steps to perform a ClearanceDB analysis upon a Teamcenter managed product.

1. Configure the Clearance Calculator, as described in the Configure clearance analysis section of the ClearanceDB Administration Guide.

2. Navigate to the appropriate product directory in your ClearanceDB Work Area.

3. From the command prompt, type

   ```
   analyze_managed_product.pl <product>
   ```

   Example ```
   analyze_managed_product.pl flux_capacitor
   ```

   Depending upon how you set the RunLevel parameter in the Clearance.cfgglobal file, one or more of the following actions are performed:

<table>
<thead>
<tr>
<th>This RunLevel setting</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the product directory, a.vvi file is created, which is used by the bomwriter to generate a .plmxml file referencing the managed data.</td>
</tr>
</tbody>
</table>
This RunLevel setting | Does this
---|---
2 | Using the .vvi and .plmxml files in the product directory, the Clearance Calculator performs analysis upon the managed product data and generates a results file.
3 | The results file is uploaded to the ClearanceDB database.
4 | Both the RunLevel 1 and 2 actions are performed.
5 | Both the RunLevel 2 and 3 actions are performed.
6 | All of the RunLevel actions are performed, 1, 2, and 3.

The analysis runs, and when it is complete the clearance results file, ClearanceResultsDbUpload.csvcldb, appears in the product directory.

Example output from managed analysis

The command line output below is from a successful ClearanceDB analysis of a Teamcenter managed product.

```
C:\ClearanceDB_Work_Area\Products\141-f10002_A_1-Front_Suspension__view_\analyze_managed_product.pl
#-----------------------------------------
# analyze_managed_product.pl
#-----------------------------------------
#
# Teamcenter Configuration:
# TC_ROOT=Y:\
# TC_DATA=Z:\
# TeamcenterUserId=tcuser
# RevisionRule=Latest Working
# RunLevel=6
# JtDataStagingProcess=1
#-----------------------------------------
"141-f10002_A_1-Front_Suspension__view_.vvi" file is created in the product directory. Please verify it.
#-----------------------------------------
# Step 1a of 3: Run Bomwriter.exe
#-----------------------------------------

Running:
Y:\bin\bomwriter -u=tcuser -p=xxxxxxxx -g= -item="141-f10002" -rev=A -format=plmxml+type=AbsoluteOccurrences+us-target:Root,key:Configuration,literal:"Latest Working" -revision_rule="Latest Working" -output_file="C:\ClearanceDB_Work_Area/Products/141-f10002_A_1-Front_Suspension__view_/141-f10002_A_1-Front_Suspension__view_.plmxml"
platform=MSWin32
C:\ClearanceDB_Work_Area/Products/141-f10002_A_1-Front_Suspension_view_/bomwriter_exec.bat
C:\ClearanceDB_Work_Area\Products\141-f10002_A_1-Front_Suspension_view_/set TC_ROOT=Y:\
C:\ClearanceDB_Work_Area\Products\141-f10002_A_1-Front_Suspension_view_/set TC_DATA=Z:\
C:\ClearanceDB_Work_Area\Products\141-f10002_A_1-Front_Suspension_view_/call Z:\\tc_profilevars
#-----------------------------------------

# Bomwriter.exe execution SUCCEEDED
# Execution time = 00:15:03
#-----------------------------------------
#
# Step 1b of 3: Run Load_fcccache.exe
#-----------------------------------------

Staging process uses config file: C:\ClearanceDB_Work_Area/Clearance.cfgglobal
The staging process saved the original plmxml as: C:\ClearanceDB_Work_Area/Products/
Using ClearanceDB with Teamcenter

141-f10002_A_1-Front_Suspension_view /141-f10002_A_1-Front_Suspension_view_orig.plxml
Warning: Invaild "CopyOutLocation" in the configuration file. Use product dir by default.

Running:
Y:\bin\load_fcccache -u=tcuser -p=xxxxxxxx -config=C:\ClearanceDB Work Area\Clearance.cfgglobal -f-load -plxml=C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view /141-f10002_A_1-Front_Suspension_view_orig.plxml -output_plmxml=C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view /141-f10002_A_1-Front_Suspension_view_orig.plxml -copy_out=C:\ClearanceDB Work Area\Products\141-F10002_A_1-Front_Suspension_view / StagingProcessDownloads -log_filename=C:\ClearanceDB Work Area\Products/141-f10002_A_1-Front_Suspension_view_/JtDataStagingProcess.log

C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/set
C:/ClearanceDB_Work_Area/Products/141-f10002_A_1-Front_Suspension_view /stage_exec.bat
C:/ClearanceDB_Work_Area/Products/141-f10002_A_1-Front_Suspension_view_/clearance_exec.bat
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/set
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/set TC_ROOT=Y:\
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/call Z:\\tc_profilevars

DEBUG 2010-02-09T19:21:16.509Z: Setting BucketCount to: 30
DEBUG 2010-02-09T19:21:16.509Z: Setting UseAbsoluteLocation to: No
DEBUG 2010-02-09T19:21:16.618Z: Setting Lifet imeCheck to: 0
DEBUG 2010-02-09T19:21:16.618Z: Setting the LifetimeCheckInterval to: 10
DEBUG 2010-02-09T19:21:16.634Z: Setting the lifetimeProcessLimit to: 100

FCC Interface Implementation fms.8.2.0.20091029.01(fms.8.2.0.20091029.01) initialized.

# Load_fcccache.exe execution SUCCEEDED
# Execution time = 00:13:05
#---------------------------------------------

# Step 2 of 3: Run Clearance.exe
#---------------------------------------------

## Running:
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view /clearance_exec.bat
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/set VP_AUTO_TESTING=True
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/set EAI_CL_DATASOURCE= cldbmachine:7206
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/set EAI_CL_CONNECT_DATA= CLDB_PROXY_CONNECT
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/set PATH=C:\\Perl;\\bin;
C:\WINDOWS\\c:\WINDOWS\System32;C:\\vis\\Products\\Mockup\\ClearanceDB
C:\ClearanceDB Work Area\Products\141-f10002_A_1-Front_Suspension_view_/C:\\\vis\\Products\\Mockup\\clearance.exe -d 5 -c C:\ClearanceDB Work Area\Products\3\141-F10002_A_1-Front_Suspension_view_ /141-f10002_A_1-Front_Suspension_view_.vvi

Teamcenter Visualization Clearance Testing.
Launching worker process.
Creating clearance components.
Loading input file.
Performing clearance test.
Generating pairs.
Product = 141-f10002/A1-Front_Suspension (view) (Latest Working)
2010/02/09-14:30:41: Connected to ClearanceDB Proxy on machine cldbmachine, at port 7206.
2010/02/09-14:30:44: Reconnected to ClearanceDB Proxy on machine cldbmachine, at port 7206.
2010/02/09-14:30:45: Reconnected to ClearanceDB Proxy on machine cldbmachine, at port 7206.
Number of unique rules = 1
2010/02/09-14:30:48: Reconnected to ClearanceDB Proxy on machine cldbmachine, at port 7206.
2010/02/09-14:30:49: Reconnected to ClearanceDB Proxy on machine cldbmachine, at port 7206.
The statistics of 141-f10002/A1-Front_Suspension (view):
  Number of element occurrences = 53
  Number of unchanged element occurrences = 0
  Number of excluded element occurrences = 0

The requirement engine called total of 1461 times.
Clearance test bed has been created with CADID matching keyed by PART names.
All pairs have been generated.
Processing pairs. Launching 2 processes for analysis.
Process 1: All pairs have been processed.
View results in the Lifecycle Viewer and Structure Manager

View results in the Lifecycle Viewer

1. In My Teamcenter, right-click the item revision containing your product data and choose Send To→Lifecycle Viewer.

   The dataset opens in the Lifecycle Viewer.

2. Choose Clearance→Preferences→Requirement Components.

3. In the Requirement Rule Components dialog box, select the Requirement Rules from ClearanceDB Server check box, and then click OK.

4. On the 3D Clearance toolbar, click Load Results 📊.
Using ClearanceDB with Teamcenter

Choose Clearance→Results→Load.

5. In the Load Clearance Results dialog box, from the Files of Type list, choose ClearanceDB DataBase Connection (*.dbc).

6. Select your DataBase Connection (DBC) file, and click Open.

   The 3D model and the database content are matched by the name of the top-level assembly node. Results are displayed in the General Clearance Results list.

View results in Structure Manager

1. In My Teamcenter, right-click the item revision containing your product data and choose Send To→Structure Manager.

   The Structure Manager opens and displays the product structure.

2. Choose View→Show/Hide Data Panel.

3. In the Data Panel, click the Viewer tab.

   The visualization components load and the Structure Manager embedded viewer opens.


5. In the Requirement Rule Components dialog box, select the Requirement Rules from ClearanceDB Server check box, and then click OK.

6. Right-click the embedded viewer toolbar area and choose 3D Clearance.

   The 3D Clearance toolbar is displayed.

7. On the 3D Clearance toolbar, click Load Results.

8. In the Load Clearance Results dialog box, from the Files of Type list, choose ClearanceDB DataBase Connection (*.dbc).

9. Select your DataBase Connection (DBC) file, and click Open.

   The 3D model and the database content are matched by the name of the top-level assembly node. Results are displayed in the General Clearance Results list.

Working with DesignContext

You can combine ClearanceDB with Teamcenter’s DesignContext application to create an Integrated Clearance Management (ICM) system. DesignContext identifies a series of target parts and then quickly finds other relevant data within a given proximity to those parts. This data can be sent to ClearanceDB to perform clearance analysis in database query (batch) mode or real-time mode. Results are displayed in DesignContext, and also can be sent to the Structure Manager, the Lifecycle Viewer, or standalone Mockup for display and further analysis.

ClearanceDB accepts any pruned or full product structure provided it is represented by a JT file in the Teamcenter database. Any parts for which JT data is not available
are not included in the clearance analysis. The product structure also should be searchable in DesignContext.

The ICM system offers two clearance analysis modes:

- **Database query mode**
  In database query mode, the ClearanceDB administrator creates a batch process to perform clearance analysis periodically as a background task, typically every night. The batch process invokes the Clearance Calculator to perform the analysis and uploads the results to the ClearanceDB database. The DesignContext end user can then evaluate the results, identify issues, and assign the issues via a workflow to designers to analyze and resolve within other applications such as the Lifecycle Viewer, Structure Manager, NX, or other CAD package.

- **Real-time mode**
  In real-time mode, the rich client user selects target and background Bill of Materials (BOM) lines in DesignContext, and then invokes a clearance analysis that is performed in real time. Typically, this option is used to make on-the-fly clearance calculations after design changes or prior to releasing a part. Teamcenter runs these calculations in the background, allowing the end user to continue with other work while waiting for the results. Results are displayed in the DesignContext **issues** panes.

A SCO (Structure Context Object) containing the clearance results can also be created in the **Newstuff** folder, provided the **RDVCreateSCOForClearance** preference is set to **true**. The SCO can be opened in a subsequent session to retrieve the selected product structure lines and analysis results.

**Note** For more information on using DesignContext, see the **DesignContext Guide** in the Teamcenter documentation.

### DesignContext clearance analysis modes

#### Database query mode

The ClearanceDB administrator configures the scope of the analysis and the DesignContext end user can only view the results. The end user can use the DesignContext search engine capabilities to focus upon particular parts.

Clearance issues are displayed in one of the following **issues** panes:

- **Target-Target Issues**
  Shows clearance issues among all the appearances in the DesignContext target appearances table in the third window. The specific issue between each pair of parts is listed.

- **Target-Background Issues**
  Shows clearance issues among target parts against all the appearances in the DesignContext background appearances table in the third window. The specific issue between each pair of parts is listed.

- **Target-Other Issues**
Teamcenter displays each pair of parts that violate one of the defined clearance rules. All violations are shown in the context of the selected target part appearance or appearances. For each violation, the following information is listed:

- **Type**
  The clearance violation type.

- **Result**
  The calculated violation with respect to the requirement.

- **Requirement**
  The required clearance.

- **Location**
  The x,y,z coordinates of the violation.

**Note** You can also view additional results information such as issue **Status**, **Priority**, and **Date First Found**. To update the selection of columns shown in the **Issues** panes, modify the **ClearanceDBShownColumns** preference in the rich client.

### Real-time mode

Real-time clearance analysis is a two step process. The first step is to create search criteria for the clearance calculation. The second step is to send the search criteria to **DesignContext** to see the clearance analysis results.

To perform real-time clearance analysis, the end user manually selects BOM lines of interest in **DesignContext**. BOM lines involved in the analysis process are **DesignContext** target parts. The user selects these parts from the target and background BOM lines that are configured in the **DesignContext** third window. Global background parts cannot be included in a real-time clearance analysis. If particular BOM lines are not selected, all BOM lines in the target appearances are considered target parts.

**Teamcenter** analyses the BOM lines selected as **DesignContext** target parts against all other BOM lines in the **DesignContext** third window. It presents the issues in the following categories:

- **Target parts** against all the appearances in the **DesignContext** target appearances table in the third window.

- **Target parts** against all the appearances in the **DesignContext** background appearances table in the third window.

Optionally, **Teamcenter** may create an SCO (Structure Context Object) in the **Newstuff** folder containing information about the session. The SCO can be opened in a subsequent session to retrieve the selected product structure lines and analysis results.

**Note** Creation of an SCO is optional and occurs only if the **RDVCreateSCOForClearance** preference is set to **true** in the rich client.
Specify connection information for DesignContext

For DesignContext to connect with the ClearanceDB database, you must use the Teamcenter RDVClearanceProxyServers preference to specify the ClearanceDB connection information.

**Note** You must have Teamcenter administrator rights to modify the RDVClearanceProxyServers preference.

1. Log on to the rich client as the administrator.
2. Choose Edit→Options.
3. At the bottom of the Options dialog box, click Search.
4. In the Search On Keywords box, type RDVClearanceProxyServers, and then click the magnifying glass icon to search for the preference.
5. In the Preferences List, select RDVClearanceProxyServers.
6. In the Current Values box, type your connection information according to the following syntax:
   
   `<machine_name>:<port>:<connection_name>`
   
   where

<table>
<thead>
<tr>
<th>For this parameter</th>
<th>Type this</th>
</tr>
</thead>
<tbody>
<tr>
<td>machine_name</td>
<td>The name of the system running the ClearanceDB Proxy or Oracle Client.</td>
</tr>
<tr>
<td>port</td>
<td>The port number used for the ClearanceDB connection.</td>
</tr>
<tr>
<td>connection_name</td>
<td>The name of the Oracle connection.</td>
</tr>
</tbody>
</table>

7. Click the + sign to the right of the Current Values box.

   **Note** The RDVClearanceProxyServers preference can consist of multiple ClearanceDB connections. For each additional connection that you want to establish, type the required connection information as described above and then click the + sign to the right of the Current Values box to update the preference.

8. Click Modify.

Specify to create an SCO for clearance results

Set the RDVCCreateSCOForClearance preference to true if you want to create an SCO (Structure Context Object) after performing real-time analysis.

**Note** You must have Teamcenter administrator rights to modify the RDVCCreateSCOForClearance preference.

1. Log on to the rich client as the administrator.
2. Choose Edit→Options.

3. At the bottom of the Options dialog box, click Search.

4. In the Search On Keywords box, type RDVCreateSCOForClearance, and then click the magnifying glass icon to search for the preference.

5. In the Preferences List, select RDVCreateSCOForClearance.

6. In the Current Values box, type true.

7. Click Modify.

**Display additional clearance results information**

Modify the ClearanceDBShownColumns preference to display additional clearance results information in the DesignContext Issues panes.

*Note* You must have Teamcenter administrator rights to modify the ClearanceDBShownColumns preference.

1. Log on to the rich client as the administrator.

2. Choose Edit→Options.

3. At the bottom of the Options dialog box, click Search.

4. In the Search On Keywords box, type ClearanceDBShownColumns, and then click the magnifying glass icon to search for the preference.

5. In the Preferences List, select ClearanceDBShownColumns.

6. In the Current Values box, type the names of the ClearanceDB results columns that you want to display.

7. Click Modify.

**Load ClearanceDB results in DesignContext**

1. Choose Tools→Clearance Analysis.

2. In the Clearance Analysis dialog box, select Query the database for existing results.

3. Click Start Analysis.

After a delay that depends on the quantity of stored data, Teamcenter displays the retrieved clearance issues in one of the Issues panes.

4. To view the associated parts in the embedded viewer, select one or more issues and click the Communicate to DesignContext button.

Teamcenter opens the relevant BOM lines in DesignContext, allowing you to examine the clearance details in the embedded viewer.
Chapter 9  Using ClearanceDB with Teamcenter

Alternatively, you can also view the parts associated with one or more selected issues in standalone Teamcenter lifecycle visualization mockup if you click the Start/Open In TcVis button.

Performing real-time analysis

1. In DesignContext, load the ClearanceDB results.

2. Select the product structure lines of interest in the third DesignContext window. If you do not select any lines, Teamcenter includes all appearances in the third DesignContext window in the analysis.

3. Choose Tools→Clearance Analysis.

4. In the Clearance Analysis dialog box, select Perform Real-Time Clearance Analysis.

5. Click Start Analysis.

A progress bar shows the percentage completion of the calculation, and you can click Cancel above the progress bar to terminate the process if necessary. After a delay that depends on the scope of the query, Teamcenter displays the clearance issues in one of the Issues panes.

6. Click OK on the form.

Note  Real-time analysis results are not stored in the ClearanceDB database. If you want to preserve them, you must create an SCO (Structure Context Object) object. You can open the SCO in a subsequent session to retrieve the selected product structure lines and analysis results. The RDVCreatSCOForClearance preference must be set to true for an SCO to be created.

Open clearance results in an SCO

1. In your Newstuff folder, right-click the SCO containing your results and choose Send To→Design Context. Teamcenter opens the results in the first DesignContext window.

2. Click Finish. Teamcenter opens the third DesignContext window.

Note  Click Yes on any confirmation dialog boxes that are displayed.

3. Choose Tools→Clearance Analysis. Teamcenter displays the Clearance Analysis dialog box.

4. Select Display Cached Results from SCO and then click Start Analysis. After a delay that depends on the quantity of stored data, Teamcenter displays the retrieved clearance issues in one of the Issues panes.